]> git.pld-linux.org Git - packages/tla.git/blob - tla.spec
- pl, some cleanups
[packages/tla.git] / tla.spec
1 Summary:        tla arch - revision control system
2 Summary(pl):    tla arch - system kontroli wersji
3 Name:           tla
4 Version:        1.1pre7
5 Release:        2
6 License:        GPL v2
7 Group:          Development/Version Control
8 Source0:        http://ftp.gnu.org/gnu/gnu-arch/%{name}-%{version}.tar.gz
9 # Source0-md5:  98542bdbcaf2e6146f41ba90a7643fc0
10 URL:            http://regexps.srparish.net/www/
11 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
12
13 %description
14 tla arch is a revision control system: a program that lets programmers
15 archive a history of changes made to the software they maintain and
16 that, more importantly, helps programmers to coordinate, synchronize,
17 and combine multiple lines of development for a single project.
18
19 arch version tla is a C version of the reference arch concepts.
20
21 %description -l pl
22 tla arch jest systemem kontroli wersji - programem, który pozwala
23 programistom archiwizowaæ historiê zmian wykonanych w rozwijanym przez
24 nich oprogramowaniu oraz, co wa¿niejsze, pomaga programistom
25 koordynowaæ, synchronizowaæ i ³±czyæ wiele linii kodu podczas rozwoju
26 projektu.
27
28 arch w wersji tla to wersja w C wzorcowych idei arch.
29
30 %prep
31 %setup -q
32
33 %build
34 cd src
35 mkdir =build
36 cd =build
37 ## imitate what an rpm macro would export
38 export CFLAGS="%{rpmcflags}" CXXFLAGS="%{rpmcflags}" FFLAGS="%{rpmcflags}"
39 ../configure --prefix=%{_prefix} --destdir=%{buildroot}
40 %{__make}
41
42 # ok, I tested already
43 %{__make} test
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__make} -C src/=build install
49
50 ## move some docs to a place the rpm doc macro likes
51 cp src/tla/=THANKS =THANKS
52 cp --recursive src/docs-tla/html html
53 cp --recursive src/docs-tla/ps ps
54 cp --recursive src/docs-tla/texi texi
55
56 # CLEANUP UNKNOWN USAGE DIRS
57 rm -rf $RPM_BUILD_ROOT%{_libdir}
58 rm -rf $RPM_BUILD_ROOT%{_prefix}/src
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %files
64 %defattr(644,root,root,755)
65 %doc COPYING =INSTALL =RELEASE-ID html ps texi
66 %attr(755,root,root) %{_bindir}/*
67 #{_includedir}
68 #{_libdir}
69 #{_libexecdir}
This page took 0.028943 seconds and 4 git commands to generate.