]> git.pld-linux.org Git - packages/tla.git/blob - tla.spec
- up to 1.3 final
[packages/tla.git] / tla.spec
1 Summary:        tla arch - revision control system
2 Summary(pl):    tla arch - system kontroli wersji
3 Name:           tla
4 Version:        1.3
5 Release:        1
6 Epoch:          1
7 License:        GPL v2
8 Group:          Development/Version Control
9 Source0:        http://www.seyza.com/releases/%{name}-%{version}.tar.gz
10 # Source0-md5:  6093412e85d63fe79469bf386308d437
11 # http://people.debian.org/~asuffield/daily/tla/lord/
12 Patch0:         %{name}-neon.patch
13 URL:            http://www.gnu.org/software/gnu-arch/
14 Requires:       diffutils
15 Requires:       patch
16 Requires:       tar
17 BuildRequires:  neon-devel
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 tla arch is a revision control system: a program that lets programmers
22 archive a history of changes made to the software they maintain and
23 that, more importantly, helps programmers to coordinate, synchronize,
24 and combine multiple lines of development for a single project.
25
26 arch version tla is a C version of the reference arch concepts.
27
28 %description -l pl
29 tla arch jest systemem kontroli wersji - programem, który pozwala
30 programistom archiwizowaæ historiê zmian wykonanych w rozwijanym przez
31 nich oprogramowaniu oraz, co wa¿niejsze, pomaga programistom
32 koordynowaæ, synchronizowaæ i ³±czyæ wiele linii kodu podczas rozwoju
33 projektu.
34
35 arch w wersji tla to wersja w C wzorcowych idei arch.
36
37 %prep
38 %setup -q
39 %patch0 -p1
40
41 %build
42 rm -rf src/tla/libneon
43 ln -s /usr/include/neon src/tla/libneon
44 cd src
45 mkdir =build
46 cd =build
47
48 CFLAGS="%{rpmcflags}"
49 CXXFLAGS="%{rpmcflags}"
50 FFLAGS="%{rpmcflags}"
51 export CFLAGS CXXFLAGS FFLAGS
52
53 # custom configure script
54 ../configure \
55         --prefix=%{_prefix} \
56         --destdir=$RPM_BUILD_ROOT \
57         --with-ssh-is-openssh=1 \
58         --with-cc="%{__cc}"
59 %{__make} -j1
60
61 # ok, I tested already
62 %{__make} -j1 test
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66
67 %{__make} -j1 -C src/=build install
68
69 cp --recursive src/docs-tla/html html
70
71 rm -rf html/.arch-ids
72 rm -rf $RPM_BUILD_ROOT%{_libdir}
73 rm -rf $RPM_BUILD_ROOT%{_prefix}/src
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %files
79 %defattr(644,root,root,755)
80 %doc html
81 %attr(755,root,root) %{_bindir}/*
This page took 0.06329 seconds and 4 git commands to generate.