]> git.pld-linux.org Git - packages/tla.git/blob - tla.spec
- obsolete
[packages/tla.git] / tla.spec
1 Summary:        tla arch - revision control system
2 Summary(pl):    tla arch - system kontroli wersji
3 Name:           tla
4 Version:        1.3.3
5 Release:        4
6 Epoch:          1
7 License:        GPL v2
8 Group:          Development/Version Control
9 Source0:        ftp://ftp.gnu.org/pub/gnu/gnu-arch/%{name}-%{version}.tar.gz
10 # Source0-md5:  61d5dea41e071f78a8319401ee07ab0b
11 Patch0:         %{name}-neon.patch
12 Patch1:         %{name}-debian.patch
13 URL:            http://www.gnu.org/software/gnu-arch/
14 BuildRequires:  findutils
15 BuildRequires:  neon-devel
16 Requires:       diffutils
17 Requires:       patch
18 Requires:       tar
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 tla arch is a revision control system: a program that lets programmers
23 archive a history of changes made to the software they maintain and
24 that, more importantly, helps programmers to coordinate, synchronize,
25 and combine multiple lines of development for a single project.
26
27 arch version tla is a C version of the reference arch concepts.
28
29 %description -l pl
30 tla arch jest systemem kontroli wersji - programem, który pozwala
31 programistom archiwizowaæ historiê zmian wykonanych w rozwijanym przez
32 nich oprogramowaniu oraz, co wa¿niejsze, pomaga programistom
33 koordynowaæ, synchronizowaæ i ³±czyæ wiele linii kodu podczas rozwoju
34 projektu.
35
36 arch w wersji tla to wersja w C wzorcowych idei arch.
37
38 %prep
39 %setup -q
40 %patch0 -p1
41 %patch1 -p1
42
43 %build
44 rm -rf src/tla/libneon
45 ln -s /usr/include/neon src/tla/libneon
46 cd src
47 mkdir =build
48 cd =build
49
50 CFLAGS="%{rpmcflags}"
51 CXXFLAGS="%{rpmcflags}"
52 FFLAGS="%{rpmcflags}"
53 export CFLAGS CXXFLAGS FFLAGS
54
55 # custom configure script
56 ../configure \
57         --prefix=%{_prefix} \
58         --destdir=$RPM_BUILD_ROOT \
59         --with-ssh-is-openssh=1 \
60         --with-cc="%{__cc}"
61 %{__make} -j1
62
63 # ok, I tested already
64 %{__make} -j1 test
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68
69 %{__make} -j1 -C src/=build install
70
71 rm -rf html
72 cp -a src/docs-tla html
73 find html -type f ! -name "*.html" -exec rm -rf "{}" ";"
74 find html -type d -name ".arch-ids" -exec rm -rf "{}" ";" || :
75 find html -type d -name "{arch}" -exec rm -rf "{}" ";" || :
76
77 rm -rf $RPM_BUILD_ROOT%{_libdir}
78 rm -rf $RPM_BUILD_ROOT%{_prefix}/src
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %files
84 %defattr(644,root,root,755)
85 %doc html
86 %attr(755,root,root) %{_bindir}/*
This page took 0.049497 seconds and 3 git commands to generate.