]> git.pld-linux.org Git - packages/tigervnc.git/blob - tigervnc.spec
- rpm -q errors ignored.
[packages/tigervnc.git] / tigervnc.spec
1 # TODO:
2 # - tigervnc.init
3
4 %define         snap            r4159
5 %define         xversion        1.9
6
7 Summary:        A TigerVNC remote display system
8 Summary(pl.UTF-8):      System zdalnego dostępu TigerVNC
9 Name:           tigervnc
10 Version:        1.0.90
11 Release:        8
12 License:        GPL v2
13 Group:          X11/Applications/Networking
14 #Source0:       http://dl.sourceforge.net/tigervnc/%{name}-%{version}.tar.gz
15 Source0:        %{name}-%{version}-%{snap}.tar.bz2
16 # Source0-md5:  bd83717c960fb9e585387948b5cb41e2
17 Source1:        %{name}.desktop
18 Patch0:         tigervnc-cookie.patch
19 Patch1:         tigervnc-ldnow.patch
20 Patch2:         tigervnc-rh102434.patch
21 Patch3:         tigervnc-rh611677-generate_modkeymap-max_keys.patch
22 Patch4:         tigervnc-rh611677.patch
23 Patch5:         tigervnc-rh633931.patch
24 Patch6:         tigervnc-viewer-reparent.patch
25 Patch7:         tigervnc-as-needed.patch
26 Patch8:         tigervnc-options-dialog.patch
27 URL:            http://www.tigervnc.com/
28 BuildRequires:  ImageMagick
29 BuildRequires:  ImageMagick-coder-png
30 BuildRequires:  ImageMagick-coder-svg
31 BuildRequires:  cpp
32 BuildRequires:  gnutls-devel
33 BuildRequires:  libjpeg-devel
34 BuildRequires:  zlib-devel
35 BuildRequires:  xorg-xserver-server-source >= %{xversion}
36 # xserver BRs, should match xorg-xserver-server.spec
37 BuildRequires:  Mesa-libGL-devel >= 7.8.1
38 # for glx headers
39 BuildRequires:  OpenGL-GLX-devel
40 BuildRequires:  autoconf >= 2.57
41 BuildRequires:  automake
42 BuildRequires:  libdrm-devel >= 2.4.5
43 BuildRequires:  libtool
44 BuildRequires:  ncurses-devel
45 BuildRequires:  pam-devel
46 BuildRequires:  perl-base
47 BuildRequires:  pixman-devel >= 0.16.0
48 BuildRequires:  pkgconfig >= 1:0.19
49 BuildRequires:  xorg-app-mkfontscale
50 BuildRequires:  xorg-font-font-util >= 1.1
51 BuildRequires:  xorg-lib-libX11-devel
52 BuildRequires:  xorg-lib-libXau-devel
53 BuildRequires:  xorg-lib-libXaw-devel
54 BuildRequires:  xorg-lib-libXdamage-devel
55 BuildRequires:  xorg-lib-libXdmcp-devel
56 BuildRequires:  xorg-lib-libXext-devel  >= 1.0.99.4
57 BuildRequires:  xorg-lib-libXfont-devel >= 1.4.2
58 BuildRequires:  xorg-lib-libXi-devel >= 1.2.99.1
59 BuildRequires:  xorg-lib-libXmu-devel
60 BuildRequires:  xorg-lib-libXpm-devel
61 BuildRequires:  xorg-lib-libXrender-devel
62 BuildRequires:  xorg-lib-libXres-devel
63 BuildRequires:  xorg-lib-libXt-devel >= 1.0.0
64 BuildRequires:  xorg-lib-libXtst-devel >= 1.0.99.2
65 BuildRequires:  xorg-lib-libXv-devel
66 BuildRequires:  xorg-lib-libXxf86dga-devel
67 BuildRequires:  xorg-lib-libXxf86misc-devel
68 BuildRequires:  xorg-lib-libXxf86vm-devel
69 BuildRequires:  xorg-lib-libfontenc-devel
70 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.8.0
71 BuildRequires:  xorg-lib-libxkbfile-devel
72 BuildRequires:  xorg-lib-libxkbui-devel >= 1.0.2
73 BuildRequires:  xorg-lib-xtrans-devel >= 1.2.2
74 BuildRequires:  xorg-proto-bigreqsproto-devel >= 1.1.0
75 BuildRequires:  xorg-proto-damageproto-devel >= 1.1
76 BuildRequires:  xorg-proto-fixesproto-devel >= 4.1
77 BuildRequires:  xorg-proto-fontcacheproto-devel
78 BuildRequires:  xorg-proto-fontsproto-devel
79 BuildRequires:  xorg-proto-glproto-devel >= 1.4.10
80 BuildRequires:  xorg-proto-inputproto-devel >= 1.9.99.902
81 BuildRequires:  xorg-proto-kbproto-devel >= 1.0.3
82 BuildRequires:  xorg-proto-printproto-devel
83 BuildRequires:  xorg-proto-randrproto-devel >= 1.2.99.3
84 BuildRequires:  xorg-proto-recordproto-devel
85 BuildRequires:  xorg-proto-renderproto-devel >= 0.11
86 BuildRequires:  xorg-proto-resourceproto-devel
87 BuildRequires:  xorg-proto-scrnsaverproto-devel >= 1.1.0
88 BuildRequires:  xorg-proto-videoproto-devel
89 BuildRequires:  xorg-proto-xcmiscproto-devel >= 1.2.0
90 BuildRequires:  xorg-proto-xextproto-devel >= 1:7.0.99.3
91 BuildRequires:  xorg-proto-xf86bigfontproto-devel >= 1.2.0
92 BuildRequires:  xorg-proto-xf86dgaproto-devel >= 2.0.99.1
93 BuildRequires:  xorg-proto-xf86driproto-devel >= 2.1.0
94 BuildRequires:  xorg-proto-xf86miscproto-devel
95 BuildRequires:  xorg-proto-xf86vidmodeproto-devel >= 2.2.99.1
96 BuildRequires:  xorg-proto-xproto-devel >= 7.0.17
97 BuildRequires:  xorg-util-util-macros >= 1.10
98 Provides:       vnc-client
99 Conflicts:      vnc
100 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
101
102 %define         _xserverver     %(LC_ALL=C rpm -q --qf '%{V}' xorg-xserver-server-source 2> /dev/null)
103
104 %description
105 TigerVNC is a suite of VNC servers and clients that have a focus on
106 performance and remote display functionality. Originally this software
107 was based on the (never released) VNC 4 branch of TightVNC.
108
109 %description -l pl.UTF-8
110 TigerVNC to zestaw serwerów i klientów VNC, które koncentrują się
111 na wydajności i funkcjonalności zdalnego wyświetlania. Pierwotnie
112 oprogramowanie oparte było na (nigdy nie wydanej)
113 gałęzi VNC 4 TightVNC.
114
115 %package server
116 Summary:        VNC X server - TigerVNC version
117 Summary(pl.UTF-8):      X serwer VNC - wersja TigerVNC
118 Group:          X11/Applications/Networking
119 Requires:       xorg-app-rgb
120 # for vncpasswd tool
121 Requires:       %{name}-utils = %{version}-%{release}
122 # for mcookie
123 Requires:       util-linux
124 Obsoletes:      vnc-server
125
126 %description server
127 This package contains VNC X server in TigerVNC version.
128
129 %description server -l pl.UTF-8
130 Ten pakiet zawiera X serwer VNC w wersji TigerVNC.
131
132 %package utils
133 Summary:        Additional utilities for TigerVNC
134 Summary(pl.UTF-8):      Dodatkowe narzędzia do TigerVNC
135 Group:          X11/Applications/Networking
136 Obsoletes:      vnc-utils
137
138 %description utils
139 This package contains additional TigerVNC utilities: vncconfig and
140 vncpasswd. vncconfig is used to configure and control a running
141 instance of Xvnc, or any other X server with the VNC extension.
142 vncpasswd generates password file (both on server and viewer side).
143
144 %description utils -l pl.UTF-8
145 Ten pakiet zawiera dodatkowe narzędzia do tightvnc: vncconfig i
146 vncpasswd. vncconfig służy do konfigurowania i kontroli działającej
147 instancji Xvnc lub innego serwera X z rozszerzeniem VNC.
148 vncpasswd służy to tworzenia pliku z hasłem (zarówno po
149 stronie serwera, jak i przeglądarki).
150
151 %package -n xorg-xserver-libvnc
152 Summary:        TigerVNC module for X.org server
153 Summary(pl.UTF-8):      Moduł TigerVNC dla servera X.org
154 Group:          X11/Servers
155 %requires_eq_to xorg-xserver-server xorg-xserver-server-source
156 Provides:       xorg-xserver-module(vnc)
157
158 %description -n xorg-xserver-libvnc
159 This package contains libvnc.so module for X.org server,
160 allowing others to access the desktop on your machine.
161
162 %description -n xorg-xserver-libvnc -l pl.UTF-8
163 Ten pakiet zawiera moduł libvnc.so dla serwera X.org,
164 pozwalający na zdalny dostęp do pulpitu.
165
166 %prep
167 %setup -q -n %{name}
168 %patch0 -p1
169 %patch1 -p1
170 %patch2 -p1
171 %patch4 -p1
172 %patch5 -p1
173 %patch6 -p1
174 %patch7 -p1
175 %patch8 -p1
176
177 %{__sed} -i -e 's|^po/Makefile.in||' configure.ac
178
179 cp -a %{_usrsrc}/xorg-xserver-server-%{_xserverver}/* unix/xserver
180 cd unix/xserver
181 patch -p1 <../xserver19.patch
182 %patch3 -p1
183
184 %build
185 %{__gettextize}
186 %{__libtoolize}
187 %{__aclocal}
188 %{__autoconf}
189 %{__autoheader}
190 %{__automake}
191
192 %{configure} \
193         --with-system-jpeg
194
195 %{__make}
196
197 cd unix/xserver
198 %{__automake}
199 %{__autoconf}
200 %configure \
201         --with-os-name="PLD/Linux" \
202         --with-os-vendor="PLD/Team" \
203         --disable-config-dbus \
204         --disable-config-hal \
205         --disable-config-udev \
206         --disable-builddocs \
207         --without-xmlto \
208         --without-fop \
209         --without-doxygen \
210         --disable-devel-docs \
211         --with-default-font-path="%{_fontsdir}/misc,%{_fontsdir}/TTF,%{_fontsdir}/OTF,%{_fontsdir}/Type1,%{_fontsdir}/100dpi,%{_fontsdir}/75dpi" \
212         --disable-xorg \
213         --disable-xnest \
214         --disable-xvfb \
215         --disable-dmx \
216         --disable-xwin \
217         --disable-xephyr \
218         --disable-kdrive \
219         --disable-xfbdev \
220         --disable-dri2 \
221         --with-pic \
222         --disable-static \
223         --disable-xinerama \
224         --disable-composite \
225         --enable-glx \
226         --enable-glx-tls \
227         --enable-aiglx \
228         --enable-dga \
229         --enable-glx-tls \
230         --enable-install-libxf86config \
231         --enable-record \
232         --disable-xsdl \
233         --disable-xfake \
234         --enable-secure-rpc \
235         --with-dri-driver-path=%{_libdir}/xorg/modules/dri \
236         --with-xkb-output=/var/lib/xkb
237
238 %{__make}
239 cd -
240
241 cd media
242 %{__make}
243
244 %install
245 rm -rf $RPM_BUILD_ROOT
246 install -d $RPM_BUILD_ROOT%{_iconsdir}/hicolor/{16x16,22x22,24x24,32x32,48x48,scalable}/apps \
247         $RPM_BUILD_ROOT%{_desktopdir}
248
249 %{__make} install \
250         DESTDIR=$RPM_BUILD_ROOT
251
252 cd unix/xserver/hw/vnc
253 %{__make} install \
254         DESTDIR=$RPM_BUILD_ROOT
255 cd -
256
257 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
258
259 install media/icons/tigervnc_16.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/16x16/apps/tigervnc.png
260 install media/icons/tigervnc_22.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/22x22/apps/tigervnc.png
261 install media/icons/tigervnc_24.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps/tigervnc.png
262 install media/icons/tigervnc_32.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/32x32/apps/tigervnc.png
263 install media/icons/tigervnc_48.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/48x48/apps/tigervnc.png
264 install media/icons/tigervnc.svg $RPM_BUILD_ROOT%{_iconsdir}/hicolor/scalable/apps/tigervnc.svg
265
266 %find_lang %{name}
267
268 %clean
269 rm -rf $RPM_BUILD_ROOT
270
271 %post
272 [ ! -x /usr/bin/update-desktop-database ] || %update_desktop_database_post
273 [ ! -x /usr/bin/gtk-update-icon-cache ] || %update_icon_cache hicolor
274
275 %postun
276 [ ! -x /usr/bin/update-desktop-database ] || %update_desktop_database_postun
277 [ ! -x /usr/bin/gtk-update-icon-cache ] || %update_icon_cache hicolor
278
279 %files -f %{name}.lang
280 %defattr(644,root,root,755)
281 %doc doc/*
282 %attr(755,root,root) %{_bindir}/vncviewer
283 %{_mandir}/man1/vncviewer.1*
284 %{_desktopdir}/tigervnc.desktop
285 %{_iconsdir}/hicolor/*/apps/tigervnc.*
286
287 %files server
288 %defattr(644,root,root,755)
289 %attr(755,root,root) %{_bindir}/Xvnc
290 %attr(755,root,root) %{_bindir}/vncserver
291 %attr(755,root,root) %{_bindir}/x0vncserver
292 %{_mandir}/man1/Xvnc.1*
293 %{_mandir}/man1/vncserver.1*
294 %{_mandir}/man1/x0vncserver.1*
295
296 %files utils
297 %defattr(644,root,root,755)
298 %attr(755,root,root) %{_bindir}/vncconfig
299 %attr(755,root,root) %{_bindir}/vncpasswd
300 %{_mandir}/man1/vncconfig.1*
301 %{_mandir}/man1/vncpasswd.1*
302
303 %files -n xorg-xserver-libvnc
304 %defattr(644,root,root,755)
305 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libvnc.so
This page took 0.069293 seconds and 4 git commands to generate.