]> git.pld-linux.org Git - packages/tigervnc.git/blob - tigervnc.spec
- new snap for xserver 1.10
[packages/tigervnc.git] / tigervnc.spec
1 # TODO:
2 # - tigervnc.init
3
4 %define         snap            r4237
5 %define         xversion        1.10.0
6
7 Summary:        A TigerVNC remote display system
8 Summary(pl.UTF-8):      System zdalnego dostępu TigerVNC
9 Name:           tigervnc
10 Version:        1.0.90
11 Release:        0.1
12 License:        GPL v2
13 Group:          X11/Applications/Networking
14 #Source0:       http://dl.sourceforge.net/tigervnc/%{name}-%{version}.tar.gz
15 Source0:        %{name}-%{version}-%{snap}.tar.bz2
16 # Source0-md5:  171a4310bc5bc8d5ab5a83c404cf551b
17 Source1:        %{name}.desktop
18 Patch0:         %{name}-cookie.patch
19 Patch1:         %{name}-ldnow.patch
20 Patch2:         %{name}-rh102434.patch
21 Patch5:         %{name}-viewer-reparent.patch
22 Patch6:         %{name}-as-needed.patch
23 URL:            http://www.tigervnc.com/
24 BuildRequires:  ImageMagick
25 BuildRequires:  ImageMagick-coder-png
26 BuildRequires:  ImageMagick-coder-svg
27 BuildRequires:  Mesa-libGL-devel >= 7.8.1
28 BuildRequires:  cpp
29 BuildRequires:  gnutls-devel
30 BuildRequires:  libjpeg-devel
31 BuildRequires:  xorg-xserver-server-source >= %{xversion}
32 BuildRequires:  zlib-devel
33 # xserver BRs, should match xorg-xserver-server.spec
34 # for glx headers
35 BuildRequires:  OpenGL-GLX-devel
36 BuildRequires:  autoconf >= 2.57
37 BuildRequires:  automake
38 BuildRequires:  libdrm-devel >= 2.4.5
39 BuildRequires:  libtool
40 BuildRequires:  ncurses-devel
41 BuildRequires:  pam-devel
42 BuildRequires:  perl-base
43 BuildRequires:  pixman-devel >= 0.16.0
44 BuildRequires:  pkgconfig >= 1:0.19
45 BuildRequires:  xorg-app-mkfontscale
46 BuildRequires:  xorg-font-font-util >= 1.1
47 BuildRequires:  xorg-lib-libX11-devel
48 BuildRequires:  xorg-lib-libXau-devel
49 BuildRequires:  xorg-lib-libXaw-devel
50 BuildRequires:  xorg-lib-libXdamage-devel
51 BuildRequires:  xorg-lib-libXdmcp-devel
52 BuildRequires:  xorg-lib-libXext-devel >= 1.0.99.4
53 BuildRequires:  xorg-lib-libXfont-devel >= 1.4.2
54 BuildRequires:  xorg-lib-libXi-devel >= 1.2.99.1
55 BuildRequires:  xorg-lib-libXmu-devel
56 BuildRequires:  xorg-lib-libXpm-devel
57 BuildRequires:  xorg-lib-libXrender-devel
58 BuildRequires:  xorg-lib-libXres-devel
59 BuildRequires:  xorg-lib-libXt-devel >= 1.0.0
60 BuildRequires:  xorg-lib-libXtst-devel >= 1.0.99.2
61 BuildRequires:  xorg-lib-libXv-devel
62 BuildRequires:  xorg-lib-libXxf86dga-devel
63 BuildRequires:  xorg-lib-libXxf86misc-devel
64 BuildRequires:  xorg-lib-libXxf86vm-devel
65 BuildRequires:  xorg-lib-libfontenc-devel
66 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.8.0
67 BuildRequires:  xorg-lib-libxkbfile-devel
68 BuildRequires:  xorg-lib-libxkbui-devel >= 1.0.2
69 BuildRequires:  xorg-lib-xtrans-devel >= 1.2.2
70 BuildRequires:  xorg-proto-bigreqsproto-devel >= 1.1.0
71 BuildRequires:  xorg-proto-damageproto-devel >= 1.1
72 BuildRequires:  xorg-proto-fixesproto-devel >= 4.1
73 BuildRequires:  xorg-proto-fontcacheproto-devel
74 BuildRequires:  xorg-proto-fontsproto-devel
75 BuildRequires:  xorg-proto-glproto-devel >= 1.4.10
76 BuildRequires:  xorg-proto-inputproto-devel >= 1.9.99.902
77 BuildRequires:  xorg-proto-kbproto-devel >= 1.0.3
78 BuildRequires:  xorg-proto-printproto-devel
79 BuildRequires:  xorg-proto-randrproto-devel >= 1.2.99.3
80 BuildRequires:  xorg-proto-recordproto-devel
81 BuildRequires:  xorg-proto-renderproto-devel >= 0.11
82 BuildRequires:  xorg-proto-resourceproto-devel
83 BuildRequires:  xorg-proto-scrnsaverproto-devel >= 1.1.0
84 BuildRequires:  xorg-proto-videoproto-devel
85 BuildRequires:  xorg-proto-xcmiscproto-devel >= 1.2.0
86 BuildRequires:  xorg-proto-xextproto-devel >= 1:7.0.99.3
87 BuildRequires:  xorg-proto-xf86bigfontproto-devel >= 1.2.0
88 BuildRequires:  xorg-proto-xf86dgaproto-devel >= 2.0.99.1
89 BuildRequires:  xorg-proto-xf86driproto-devel >= 2.1.0
90 BuildRequires:  xorg-proto-xf86miscproto-devel
91 BuildRequires:  xorg-proto-xf86vidmodeproto-devel >= 2.2.99.1
92 BuildRequires:  xorg-proto-xproto-devel >= 7.0.17
93 BuildRequires:  xorg-util-util-macros >= 1.10
94 Requires(post,postun):  gtk-update-icon-cache
95 Requires(post,postun):  hicolor-icon-theme
96 Provides:       vnc-client
97 Conflicts:      vnc
98 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
99
100 %define         _xserverver     %(LC_ALL=C rpm -q --qf '%{V}' xorg-xserver-server-source 2> /dev/null)
101
102 %description
103 TigerVNC is a suite of VNC servers and clients that have a focus on
104 performance and remote display functionality. Originally this software
105 was based on the (never released) VNC 4 branch of TightVNC.
106
107 %description -l pl.UTF-8
108 TigerVNC to zestaw serwerów i klientów VNC, które koncentrują się
109 na wydajności i funkcjonalności zdalnego wyświetlania. Pierwotnie
110 oprogramowanie oparte było na (nigdy nie wydanej)
111 gałęzi VNC 4 TightVNC.
112
113 %package server
114 Summary:        VNC X server - TigerVNC version
115 Summary(pl.UTF-8):      X serwer VNC - wersja TigerVNC
116 Group:          X11/Applications/Networking
117 Requires:       xorg-app-rgb
118 # for vncpasswd tool
119 Requires:       %{name}-utils = %{version}-%{release}
120 # for mcookie
121 Requires:       util-linux
122 Obsoletes:      vnc-server
123
124 %description server
125 This package contains VNC X server in TigerVNC version.
126
127 %description server -l pl.UTF-8
128 Ten pakiet zawiera X serwer VNC w wersji TigerVNC.
129
130 %package utils
131 Summary:        Additional utilities for TigerVNC
132 Summary(pl.UTF-8):      Dodatkowe narzędzia do TigerVNC
133 Group:          X11/Applications/Networking
134 Obsoletes:      vnc-utils
135
136 %description utils
137 This package contains additional TigerVNC utilities: vncconfig and
138 vncpasswd. vncconfig is used to configure and control a running
139 instance of Xvnc, or any other X server with the VNC extension.
140 vncpasswd generates password file (both on server and viewer side).
141
142 %description utils -l pl.UTF-8
143 Ten pakiet zawiera dodatkowe narzędzia do tightvnc: vncconfig i
144 vncpasswd. vncconfig służy do konfigurowania i kontroli działającej
145 instancji Xvnc lub innego serwera X z rozszerzeniem VNC.
146 vncpasswd służy to tworzenia pliku z hasłem (zarówno po
147 stronie serwera, jak i przeglądarki).
148
149 %package -n xorg-xserver-libvnc
150 Summary:        TigerVNC module for X.org server
151 Summary(pl.UTF-8):      Moduł TigerVNC dla servera X.org
152 Group:          X11/Servers
153 %requires_eq_to xorg-xserver-server xorg-xserver-server-source
154 Provides:       xorg-xserver-module(vnc)
155
156 %description -n xorg-xserver-libvnc
157 This package contains libvnc.so module for X.org server,
158 allowing others to access the desktop on your machine.
159
160 %description -n xorg-xserver-libvnc -l pl.UTF-8
161 Ten pakiet zawiera moduł libvnc.so dla serwera X.org,
162 pozwalający na zdalny dostęp do pulpitu.
163
164 %prep
165 %setup -q -n %{name}
166 %patch0 -p1
167 %patch1 -p1
168 %patch2 -p1
169 %patch5 -p1
170 %patch6 -p1
171
172 %{__sed} -i -e 's|^po/Makefile.in||' configure.ac
173
174 cp -a %{_usrsrc}/xorg-xserver-server-%{_xserverver}/* unix/xserver
175 cd unix/xserver
176 patch -p1 <../xserver110.patch
177
178 %build
179 %{__gettextize}
180 %{__libtoolize}
181 %{__aclocal}
182 %{__autoconf}
183 %{__autoheader}
184 %{__automake}
185
186 %{configure} \
187         --with-system-jpeg
188
189 %{__make}
190
191 cd unix/xserver
192 %{__automake}
193 %{__autoconf}
194 %configure \
195         --with-os-name="PLD/Linux" \
196         --with-os-vendor="PLD/Team" \
197         --disable-config-dbus \
198         --disable-config-hal \
199         --disable-config-udev \
200         --disable-builddocs \
201         --without-xmlto \
202         --without-fop \
203         --without-doxygen \
204         --disable-devel-docs \
205         --with-default-font-path="%{_fontsdir}/misc,%{_fontsdir}/TTF,%{_fontsdir}/OTF,%{_fontsdir}/Type1,%{_fontsdir}/100dpi,%{_fontsdir}/75dpi" \
206         --disable-xorg \
207         --disable-xnest \
208         --disable-xvfb \
209         --disable-dmx \
210         --disable-xwin \
211         --disable-xephyr \
212         --disable-kdrive \
213         --disable-xfbdev \
214         --disable-dri2 \
215         --with-pic \
216         --disable-static \
217         --disable-xinerama \
218         --disable-composite \
219         --enable-glx \
220         --enable-glx-tls \
221         --enable-aiglx \
222         --enable-dga \
223         --enable-glx-tls \
224         --enable-install-libxf86config \
225         --enable-record \
226         --disable-xsdl \
227         --disable-xfake \
228         --enable-secure-rpc \
229         --with-dri-driver-path=%{_libdir}/xorg/modules/dri \
230         --with-xkb-output=/var/lib/xkb
231
232 %{__make}
233 cd -
234
235 cd media
236 %{__make}
237
238 %install
239 rm -rf $RPM_BUILD_ROOT
240 install -d $RPM_BUILD_ROOT%{_iconsdir}/hicolor/{16x16,22x22,24x24,32x32,48x48,scalable}/apps \
241         $RPM_BUILD_ROOT%{_desktopdir}
242
243 %{__make} install \
244         DESTDIR=$RPM_BUILD_ROOT
245
246 cd unix/xserver/hw/vnc
247 %{__make} install \
248         DESTDIR=$RPM_BUILD_ROOT
249 cd -
250
251 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
252
253 install media/icons/tigervnc_16.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/16x16/apps/tigervnc.png
254 install media/icons/tigervnc_22.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/22x22/apps/tigervnc.png
255 install media/icons/tigervnc_24.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps/tigervnc.png
256 install media/icons/tigervnc_32.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/32x32/apps/tigervnc.png
257 install media/icons/tigervnc_48.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/48x48/apps/tigervnc.png
258 install media/icons/tigervnc.svg $RPM_BUILD_ROOT%{_iconsdir}/hicolor/scalable/apps/tigervnc.svg
259
260 %find_lang %{name}
261
262 %clean
263 rm -rf $RPM_BUILD_ROOT
264
265 %post
266 [ ! -x /usr/bin/update-desktop-database ] || %update_desktop_database_post
267 %update_icon_cache hicolor
268
269 %postun
270 [ ! -x /usr/bin/update-desktop-database ] || %update_desktop_database_postun
271 %update_icon_cache hicolor
272
273 %files -f %{name}.lang
274 %defattr(644,root,root,755)
275 %doc doc/*
276 %attr(755,root,root) %{_bindir}/vncviewer
277 %{_mandir}/man1/vncviewer.1*
278 %{_desktopdir}/tigervnc.desktop
279 %{_iconsdir}/hicolor/*/apps/tigervnc.*
280
281 %files server
282 %defattr(644,root,root,755)
283 %attr(755,root,root) %{_bindir}/Xvnc
284 %attr(755,root,root) %{_bindir}/vncserver
285 %attr(755,root,root) %{_bindir}/x0vncserver
286 %{_mandir}/man1/Xvnc.1*
287 %{_mandir}/man1/vncserver.1*
288 %{_mandir}/man1/x0vncserver.1*
289
290 %files utils
291 %defattr(644,root,root,755)
292 %attr(755,root,root) %{_bindir}/vncconfig
293 %attr(755,root,root) %{_bindir}/vncpasswd
294 %{_mandir}/man1/vncconfig.1*
295 %{_mandir}/man1/vncpasswd.1*
296
297 %files -n xorg-xserver-libvnc
298 %defattr(644,root,root,755)
299 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libvnc.so
This page took 0.089161 seconds and 4 git commands to generate.