]> git.pld-linux.org Git - packages/tigervnc.git/blob - tigervnc.spec
- rel 3
[packages/tigervnc.git] / tigervnc.spec
1 # TODO:
2 # - tigervnc.init
3
4 %define         snap            r4159
5 %define         xversion        1.9
6
7 Summary:        A TigerVNC remote display system
8 Summary(pl.UTF-8):      System zdalnego dostępu TigerVNC
9 Name:           tigervnc
10 Version:        1.0.90
11 Release:        3
12 License:        GPL v2
13 Group:          X11/Applications/Networking
14 #Source0:       http://dl.sourceforge.net/tigervnc/%{name}-%{version}.tar.gz
15 Source0:        %{name}-%{version}-%{snap}.tar.bz2
16 # Source0-md5:  bd83717c960fb9e585387948b5cb41e2
17 Source1:        %{name}.desktop
18 Patch0:         tigervnc-cookie.patch
19 Patch1:         tigervnc-ldnow.patch
20 Patch2:         tigervnc-rh102434.patch
21 Patch3:         tigervnc-rh611677-generate_modkeymap-max_keys.patch
22 Patch4:         tigervnc-rh611677.patch
23 Patch5:         tigervnc-rh633931.patch
24 Patch6:         tigervnc-viewer-reparent.patch
25 Patch7:         tigervnc-as-needed.patch
26 URL:            http://www.tigervnc.com/
27 BuildRequires:  ImageMagick
28 BuildRequires:  ImageMagick-coder-png
29 BuildRequires:  ImageMagick-coder-svg
30 BuildRequires:  cpp
31 BuildRequires:  libjpeg-devel
32 BuildRequires:  zlib-devel
33 BuildRequires:  xorg-xserver-server-source >= %{xversion}
34 # xserver BRs, should match xorg-xserver-server.spec
35 BuildRequires:  Mesa-libGL-devel >= 7.8.1
36 # for glx headers
37 BuildRequires:  OpenGL-GLX-devel
38 BuildRequires:  autoconf >= 2.57
39 BuildRequires:  automake
40 BuildRequires:  libdrm-devel >= 2.4.5
41 BuildRequires:  libtool
42 BuildRequires:  ncurses-devel
43 BuildRequires:  pam-devel
44 BuildRequires:  perl-base
45 BuildRequires:  pixman-devel >= 0.16.0
46 BuildRequires:  pkgconfig >= 1:0.19
47 BuildRequires:  xorg-app-mkfontscale
48 BuildRequires:  xorg-font-font-util >= 1.1
49 BuildRequires:  xorg-lib-libX11-devel
50 BuildRequires:  xorg-lib-libXau-devel
51 BuildRequires:  xorg-lib-libXaw-devel
52 BuildRequires:  xorg-lib-libXdamage-devel
53 BuildRequires:  xorg-lib-libXdmcp-devel
54 BuildRequires:  xorg-lib-libXext-devel  >= 1.0.99.4
55 BuildRequires:  xorg-lib-libXfont-devel >= 1.4.2
56 BuildRequires:  xorg-lib-libXi-devel >= 1.2.99.1
57 BuildRequires:  xorg-lib-libXmu-devel
58 BuildRequires:  xorg-lib-libXpm-devel
59 BuildRequires:  xorg-lib-libXrender-devel
60 BuildRequires:  xorg-lib-libXres-devel
61 BuildRequires:  xorg-lib-libXt-devel >= 1.0.0
62 BuildRequires:  xorg-lib-libXtst-devel >= 1.0.99.2
63 BuildRequires:  xorg-lib-libXv-devel
64 BuildRequires:  xorg-lib-libXxf86dga-devel
65 BuildRequires:  xorg-lib-libXxf86misc-devel
66 BuildRequires:  xorg-lib-libXxf86vm-devel
67 BuildRequires:  xorg-lib-libfontenc-devel
68 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.8.0
69 BuildRequires:  xorg-lib-libxkbfile-devel
70 BuildRequires:  xorg-lib-libxkbui-devel >= 1.0.2
71 BuildRequires:  xorg-lib-xtrans-devel >= 1.2.2
72 BuildRequires:  xorg-proto-bigreqsproto-devel >= 1.1.0
73 BuildRequires:  xorg-proto-damageproto-devel >= 1.1
74 BuildRequires:  xorg-proto-fixesproto-devel >= 4.1
75 BuildRequires:  xorg-proto-fontcacheproto-devel
76 BuildRequires:  xorg-proto-fontsproto-devel
77 BuildRequires:  xorg-proto-glproto-devel >= 1.4.10
78 BuildRequires:  xorg-proto-inputproto-devel >= 1.9.99.902
79 BuildRequires:  xorg-proto-kbproto-devel >= 1.0.3
80 BuildRequires:  xorg-proto-printproto-devel
81 BuildRequires:  xorg-proto-randrproto-devel >= 1.2.99.3
82 BuildRequires:  xorg-proto-recordproto-devel
83 BuildRequires:  xorg-proto-renderproto-devel >= 0.11
84 BuildRequires:  xorg-proto-resourceproto-devel
85 BuildRequires:  xorg-proto-scrnsaverproto-devel >= 1.1.0
86 BuildRequires:  xorg-proto-videoproto-devel
87 BuildRequires:  xorg-proto-xcmiscproto-devel >= 1.2.0
88 BuildRequires:  xorg-proto-xextproto-devel >= 1:7.0.99.3
89 BuildRequires:  xorg-proto-xf86bigfontproto-devel >= 1.2.0
90 BuildRequires:  xorg-proto-xf86dgaproto-devel >= 2.0.99.1
91 BuildRequires:  xorg-proto-xf86driproto-devel >= 2.1.0
92 BuildRequires:  xorg-proto-xf86miscproto-devel
93 BuildRequires:  xorg-proto-xf86vidmodeproto-devel >= 2.2.99.1
94 BuildRequires:  xorg-proto-xproto-devel >= 7.0.17
95 BuildRequires:  xorg-util-util-macros >= 1.10
96 Provides:       vnc-client
97 Conflicts:      vnc
98 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
99
100 %define         _xserverver     %(LC_ALL=C rpm -q --qf '%{V}' xorg-xserver-server-source)
101
102 %description
103 TigerVNC is a suite of VNC servers and clients that have a focus on
104 performance and remote display functionality. Originally this software
105 was based on the (never released) VNC 4 branch of TightVNC.
106
107 %description -l pl.UTF-8
108 TigerVNC to zestaw serwerów i klientów VNC, które koncentrują się
109 na wydajności i funkcjonalności zdalnego wyświetlania. Pierwotnie
110 oprogramowanie oparte było na (nigdy nie wydanej)
111 gałęzi VNC 4 TightVNC.
112
113 %package server
114 Summary:        VNC X server - TigerVNC version
115 Summary(pl.UTF-8):      X serwer VNC - wersja TigerVNC
116 Group:          X11/Applications/Networking
117 Requires:       xorg-app-rgb
118 # for vncpasswd tool
119 Requires:       %{name}-utils = %{version}-%{release}
120 # for mcookie
121 Requires:       util-linux
122 Obsoletes:      vnc-server
123
124 %description server
125 This package contains VNC X server in TigerVNC version.
126
127 %description server -l pl.UTF-8
128 Ten pakiet zawiera X serwer VNC w wersji TigerVNC.
129
130 %package utils
131 Summary:        Additional utilities for TigerVNC
132 Summary(pl.UTF-8):      Dodatkowe narzędzia do TigerVNC
133 Group:          X11/Applications/Networking
134 Obsoletes:      vnc-utils
135
136 %description utils
137 This package contains additional TigerVNC utilities: vncconfig and
138 vncpasswd. vncconfig is used to configure and control a running
139 instance of Xvnc, or any other X server with the VNC extension.
140 vncpasswd generates password file (both on server and viewer side).
141
142 %description utils -l pl.UTF-8
143 Ten pakiet zawiera dodatkowe narzędzia do tightvnc: vncconfig i
144 vncpasswd. vncconfig służy do konfigurowania i kontroli działającej
145 instancji Xvnc lub innego serwera X z rozszerzeniem VNC.
146 vncpasswd służy to tworzenia pliku z hasłem (zarówno po
147 stronie serwera, jak i przeglądarki).
148
149 %package -n xorg-xserver-libvnc
150 Summary:        TigerVNC module for X.org server
151 Summary(pl.UTF-8):      Moduł TigerVNC dla servera X.org
152 Group:          X11/Servers
153 %requires_eq_to xorg-xserver-server xorg-xserver-server-source
154 Provides:       xorg-xserver-module(vnc)
155
156 %description -n xorg-xserver-libvnc
157 This package contains libvnc.so module for X.org server,
158 allowing others to access the desktop on your machine.
159
160 %description -n xorg-xserver-libvnc -l pl.UTF-8
161 Ten pakiet zawiera moduł libvnc.so dla serwera X.org,
162 pozwalający na zdalny dostęp do pulpitu.
163
164 %prep
165 %setup -q -n %{name}
166 %patch0 -p1
167 %patch1 -p1
168 %patch2 -p1
169 %patch4 -p1
170 %patch5 -p1
171 %patch6 -p1
172 %patch7 -p1
173
174 %{__sed} -i -e 's|^po/Makefile.in||' configure.ac
175
176 cp -a %{_usrsrc}/xorg-xserver-server-%{_xserverver}/* unix/xserver
177 cd unix/xserver
178 patch -p1 <../xserver19.patch
179 %patch3 -p1
180
181 %build
182 %{__gettextize}
183 %{__libtoolize}
184 %{__aclocal}
185 %{__autoconf}
186 %{__autoheader}
187 %{__automake}
188
189 %{configure} \
190         --with-system-jpeg
191
192 %{__make}
193
194 cd unix/xserver
195 %{__automake}
196 %{__autoconf}
197 %configure \
198         --with-os-name="PLD/Linux" \
199         --with-os-vendor="PLD/Team" \
200         --disable-config-dbus \
201         --disable-config-hal \
202         --disable-config-udev \
203         --disable-builddocs \
204         --without-xmlto \
205         --without-fop \
206         --without-doxygen \
207         --disable-devel-docs \
208         --with-default-font-path="%{_fontsdir}/misc,%{_fontsdir}/TTF,%{_fontsdir}/OTF,%{_fontsdir}/Type1,%{_fontsdir}/100dpi,%{_fontsdir}/75dpi" \
209         --disable-xorg \
210         --disable-xnest \
211         --disable-xvfb \
212         --disable-dmx \
213         --disable-xwin \
214         --disable-xephyr \
215         --disable-kdrive \
216         --disable-xfbdev \
217         --disable-dri2 \
218         --with-pic \
219         --disable-static \
220         --disable-xinerama \
221         --disable-composite \
222         --enable-glx \
223         --enable-glx-tls \
224         --enable-aiglx \
225         --enable-dga \
226         --enable-glx-tls \
227         --enable-install-libxf86config \
228         --enable-record \
229         --disable-xsdl \
230         --disable-xfake \
231         --enable-secure-rpc \
232         --with-dri-driver-path=%{_libdir}/xorg/modules/dri \
233         --with-xkb-output=/var/lib/xkb
234
235 %{__make}
236 cd -
237
238 cd media
239 %{__make}
240
241 %install
242 rm -rf $RPM_BUILD_ROOT
243 install -d $RPM_BUILD_ROOT%{_iconsdir}/hicolor/{16x16,22x22,24x24,32x32,48x48,scalable}/apps \
244         $RPM_BUILD_ROOT%{_desktopdir}
245
246 %{__make} install \
247         DESTDIR=$RPM_BUILD_ROOT
248
249 cd unix/xserver/hw/vnc
250 %{__make} install \
251         DESTDIR=$RPM_BUILD_ROOT
252 cd -
253
254 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
255
256 install media/icons/tigervnc_16.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/16x16/apps/tigervnc.png
257 install media/icons/tigervnc_22.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/22x22/apps/tigervnc.png
258 install media/icons/tigervnc_24.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps/tigervnc.png
259 install media/icons/tigervnc_32.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/32x32/apps/tigervnc.png
260 install media/icons/tigervnc_48.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/48x48/apps/tigervnc.png
261 install media/icons/tigervnc.svg $RPM_BUILD_ROOT%{_iconsdir}/hicolor/scalable/apps/tigervnc.svg
262
263 %find_lang %{name}
264
265 %clean
266 rm -rf $RPM_BUILD_ROOT
267
268 %post
269 [ ! -x /usr/bin/update-desktop-database ] || %update_desktop_database_post
270 [ ! -x /usr/bin/gtk-update-icon-cache ] || %update_icon_cache hicolor
271
272 %postun
273 [ ! -x /usr/bin/update-desktop-database ] || %update_desktop_database_postun
274 [ ! -x /usr/bin/gtk-update-icon-cache ] || %update_icon_cache hicolor
275
276 %files -f %{name}.lang
277 %defattr(644,root,root,755)
278 %doc doc/*
279 %attr(755,root,root) %{_bindir}/vncviewer
280 %{_mandir}/man1/vncviewer.1*
281 %{_desktopdir}/tigervnc.desktop
282 %{_iconsdir}/hicolor/*/apps/tigervnc.*
283
284 %files server
285 %defattr(644,root,root,755)
286 %attr(755,root,root) %{_bindir}/Xvnc
287 %attr(755,root,root) %{_bindir}/vncserver
288 %attr(755,root,root) %{_bindir}/x0vncserver
289 %{_mandir}/man1/Xvnc.1*
290 %{_mandir}/man1/vncserver.1*
291 %{_mandir}/man1/x0vncserver.1*
292
293 %files utils
294 %defattr(644,root,root,755)
295 %attr(755,root,root) %{_bindir}/vncconfig
296 %attr(755,root,root) %{_bindir}/vncpasswd
297 %{_mandir}/man1/vncconfig.1*
298 %{_mandir}/man1/vncpasswd.1*
299
300 %files -n xorg-xserver-libvnc
301 %defattr(644,root,root,755)
302 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libvnc.so
This page took 0.052505 seconds and 4 git commands to generate.