]> git.pld-linux.org Git - packages/tigervnc.git/blob - tigervnc.spec
- fix for type casting compilation error
[packages/tigervnc.git] / tigervnc.spec
1 # TODO:
2 # - tigervnc.init
3
4 %define         xversion        1.14.0
5
6 Summary:        A TigerVNC remote display system
7 Summary(pl.UTF-8):      System zdalnego dostępu TigerVNC
8 Name:           tigervnc
9 Version:        1.2.0
10 Release:        17
11 License:        GPL v2
12 Group:          X11/Applications/Networking
13 Source0:        http://dl.sourceforge.net/tigervnc/1.2.0/%{name}-%{version}.tar.gz
14 # Source0-md5:  3a5755b4ed600a81c3a17976c6f8420d
15 Source1:        %{name}.desktop
16 Patch0:         %{name}-cookie.patch
17 Patch1:         %{name}-ldnow.patch
18 Patch2:         %{name}-rh102434.patch
19 Patch3:         %{name}-viewer-reparent.patch
20 Patch4:         %{name}-as-needed.patch
21 Patch5:         %{name}-ipv6.patch
22 Patch6:         %{name}-xorg111.patch
23 Patch7:         %{name}-rh692048.patch
24 Patch8:         gnutls3.patch
25 Patch9:         no-bashizm.patch
26 Patch10:        xorg112.patch
27 Patch11:        cmake-mandir.patch
28 Patch12:        sed-all.patch
29 Patch13:        xorg113.patch
30 Patch14:        xserver113.patch
31 Patch15:        format-security.patch
32 Patch16:        xorg114.patch
33 URL:            http://www.tigervnc.com/
34 BuildRequires:  ImageMagick
35 BuildRequires:  ImageMagick-coder-png
36 BuildRequires:  ImageMagick-coder-svg
37 BuildRequires:  Mesa-libGL-devel >= 7.8.1
38 BuildRequires:  cpp
39 BuildRequires:  gnutls-devel
40 BuildRequires:  libjpeg-turbo-devel
41 BuildRequires:  xorg-xserver-server-source >= %{xversion}
42 BuildRequires:  zlib-devel
43 # xserver BRs, should match xorg-xserver-server.spec
44 # for glx headers
45 BuildRequires:  OpenGL-GLX-devel
46 BuildRequires:  autoconf >= 2.57
47 BuildRequires:  automake
48 BuildRequires:  libdrm-devel >= 2.4.5
49 BuildRequires:  libtool
50 BuildRequires:  nasm
51 BuildRequires:  ncurses-devel
52 BuildRequires:  pam-devel
53 BuildRequires:  perl-base
54 BuildRequires:  pixman-devel >= 0.16.0
55 BuildRequires:  pkgconfig >= 1:0.19
56 BuildRequires:  xorg-app-mkfontscale
57 BuildRequires:  xorg-font-font-util >= 1.1
58 BuildRequires:  xorg-lib-libX11-devel
59 BuildRequires:  xorg-lib-libXau-devel
60 BuildRequires:  xorg-lib-libXaw-devel
61 BuildRequires:  xorg-lib-libXdamage-devel
62 BuildRequires:  xorg-lib-libXdmcp-devel
63 BuildRequires:  xorg-lib-libXext-devel >= 1.0.99.4
64 BuildRequires:  xorg-lib-libXfont-devel >= 1.4.2
65 BuildRequires:  xorg-lib-libXi-devel >= 1.2.99.1
66 BuildRequires:  xorg-lib-libXmu-devel
67 BuildRequires:  xorg-lib-libXpm-devel
68 BuildRequires:  xorg-lib-libXrender-devel
69 BuildRequires:  xorg-lib-libXres-devel
70 BuildRequires:  xorg-lib-libXt-devel >= 1.0.0
71 BuildRequires:  xorg-lib-libXtst-devel >= 1.0.99.2
72 BuildRequires:  xorg-lib-libXv-devel
73 BuildRequires:  xorg-lib-libXxf86dga-devel
74 BuildRequires:  xorg-lib-libXxf86misc-devel
75 BuildRequires:  xorg-lib-libXxf86vm-devel
76 BuildRequires:  xorg-lib-libfontenc-devel
77 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.13
78 BuildRequires:  xorg-lib-libxkbfile-devel
79 BuildRequires:  xorg-lib-libxkbui-devel >= 1.0.2
80 BuildRequires:  xorg-lib-xtrans-devel >= 1.2.2
81 BuildRequires:  xorg-proto-bigreqsproto-devel >= 1.1.0
82 BuildRequires:  xorg-proto-damageproto-devel >= 1.1
83 BuildRequires:  xorg-proto-fixesproto-devel >= 4.1
84 BuildRequires:  xorg-proto-fontcacheproto-devel
85 BuildRequires:  xorg-proto-fontsproto-devel
86 BuildRequires:  xorg-proto-glproto-devel >= 1.4.10
87 BuildRequires:  xorg-proto-inputproto-devel >= 1.9.99.902
88 BuildRequires:  xorg-proto-kbproto-devel >= 1.0.3
89 BuildRequires:  xorg-proto-printproto-devel
90 BuildRequires:  xorg-proto-randrproto-devel >= 1.3
91 BuildRequires:  xorg-proto-recordproto-devel
92 BuildRequires:  xorg-proto-renderproto-devel >= 0.11
93 BuildRequires:  xorg-proto-resourceproto-devel
94 BuildRequires:  xorg-proto-scrnsaverproto-devel >= 1.1.0
95 BuildRequires:  xorg-proto-videoproto-devel
96 BuildRequires:  xorg-proto-xcmiscproto-devel >= 1.2.0
97 BuildRequires:  xorg-proto-xextproto-devel >= 1:7.0.99.3
98 BuildRequires:  xorg-proto-xf86bigfontproto-devel >= 1.2.0
99 BuildRequires:  xorg-proto-xf86dgaproto-devel >= 2.0.99.1
100 BuildRequires:  xorg-proto-xf86driproto-devel >= 2.1.0
101 BuildRequires:  xorg-proto-xf86miscproto-devel
102 BuildRequires:  xorg-proto-xf86vidmodeproto-devel >= 2.2.99.1
103 BuildRequires:  xorg-proto-xproto-devel >= 7.0.22
104 BuildRequires:  xorg-util-util-macros >= 1.10
105 Requires(post,postun):  gtk-update-icon-cache
106 Requires(post,postun):  hicolor-icon-theme
107 Requires:       libjpeg-turbo
108 Provides:       vnc-client
109 Conflicts:      vnc
110 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
111
112 %define         _xserverver     %(LC_ALL=C rpm -q --qf '%{V}' xorg-xserver-server-source 2> /dev/null)
113
114 %description
115 TigerVNC is a suite of VNC servers and clients that have a focus on
116 performance and remote display functionality. Originally this software
117 was based on the (never released) VNC 4 branch of TightVNC.
118
119 %description -l pl.UTF-8
120 TigerVNC to zestaw serwerów i klientów VNC, które koncentrują się
121 na wydajności i funkcjonalności zdalnego wyświetlania. Pierwotnie
122 oprogramowanie oparte było na (nigdy nie wydanej)
123 gałęzi VNC 4 TightVNC.
124
125 %package server
126 Summary:        VNC X server - TigerVNC version
127 Summary(pl.UTF-8):      X serwer VNC - wersja TigerVNC
128 Group:          X11/Applications/Networking
129 Requires:       xorg-app-rgb
130 # for vncpasswd tool
131 Requires:       %{name}-utils = %{version}-%{release}
132 # for mcookie
133 Requires:       util-linux
134 Requires:       libjpeg-turbo
135 Requires:       xorg-app-xauth
136 Obsoletes:      vnc-server
137
138 %description server
139 This package contains VNC X server in TigerVNC version.
140
141 %description server -l pl.UTF-8
142 Ten pakiet zawiera X serwer VNC w wersji TigerVNC.
143
144 %package utils
145 Summary:        Additional utilities for TigerVNC
146 Summary(pl.UTF-8):      Dodatkowe narzędzia do TigerVNC
147 Group:          X11/Applications/Networking
148 Obsoletes:      vnc-utils
149
150 %description utils
151 This package contains additional TigerVNC utilities: vncconfig and
152 vncpasswd. vncconfig is used to configure and control a running
153 instance of Xvnc, or any other X server with the VNC extension.
154 vncpasswd generates password file (both on server and viewer side).
155
156 %description utils -l pl.UTF-8
157 Ten pakiet zawiera dodatkowe narzędzia do tightvnc: vncconfig i
158 vncpasswd. vncconfig służy do konfigurowania i kontroli działającej
159 instancji Xvnc lub innego serwera X z rozszerzeniem VNC.
160 vncpasswd służy to tworzenia pliku z hasłem (zarówno po
161 stronie serwera, jak i przeglądarki).
162
163 %package -n xorg-xserver-libvnc
164 Summary:        TigerVNC module for X.org server
165 Summary(pl.UTF-8):      Moduł TigerVNC dla servera X.org
166 Group:          X11/Servers
167 %requires_eq_to xorg-xserver-server xorg-xserver-server-source
168 Provides:       xorg-xserver-module(vnc)
169
170 %description -n xorg-xserver-libvnc
171 This package contains libvnc.so module for X.org server,
172 allowing others to access the desktop on your machine.
173
174 %description -n xorg-xserver-libvnc -l pl.UTF-8
175 Ten pakiet zawiera moduł libvnc.so dla serwera X.org,
176 pozwalający na zdalny dostęp do pulpitu.
177
178 %prep
179 %setup -q
180 %patch0 -p1
181 %patch1 -p1
182 %patch2 -p1
183 #patch3 -p1
184 %patch4 -p1
185 %patch5 -p0
186 %patch7 -p1
187 %patch8 -p1
188 %patch9 -p1
189 %patch11 -p1
190 %patch12 -p1
191 %patch15 -p1
192
193 cp -a %{_usrsrc}/xorg-xserver-server-%{_xserverver}/* unix/xserver
194 cd unix/xserver
195 patch -p1 <%{PATCH14}
196 cd -
197 %patch6 -p1
198 %patch10 -p1
199 %patch13 -p1
200 %patch16 -p1
201
202 %build
203 %cmake .
204 %{__make}
205
206 cd unix/xserver
207 %{__aclocal} -I m4
208 %{__autoconf}
209 %{__automake}
210 export CXXFLAGS="%{rpmcxxflags} -fpermissive"
211 %configure \
212         --with-os-name="PLD/Linux" \
213         --with-os-vendor="PLD/Team" \
214         --disable-config-dbus \
215         --disable-config-hal \
216         --disable-config-udev \
217         --without-xmlto \
218         --without-fop \
219         --without-doxygen \
220         --disable-devel-docs \
221         --with-default-font-path="%{_fontsdir}/misc,%{_fontsdir}/TTF,%{_fontsdir}/OTF,%{_fontsdir}/Type1,%{_fontsdir}/100dpi,%{_fontsdir}/75dpi" \
222         --disable-xorg \
223         --disable-xnest \
224         --disable-xvfb \
225         --disable-dmx \
226         --disable-xwin \
227         --disable-xephyr \
228         --disable-kdrive \
229         --disable-xfbdev \
230         --disable-dri \
231         --enable-dri2 \
232         --with-pic \
233         --disable-static \
234         --disable-xinerama \
235         --disable-composite \
236         --enable-glx \
237         --enable-glx-tls \
238         --enable-aiglx \
239         --enable-dga \
240         --enable-glx-tls \
241         --enable-install-libxf86config \
242         --enable-record \
243         --disable-xfake \
244         --enable-secure-rpc \
245         --with-xkb-output=/var/lib/xkb \
246         --disable-unit-tests
247
248 %{__make}
249 cd -
250
251 cd media
252 %{__make}
253
254 %install
255 rm -rf $RPM_BUILD_ROOT
256 install -d $RPM_BUILD_ROOT%{_iconsdir}/hicolor/{16x16,22x22,24x24,32x32,48x48,scalable}/apps \
257         $RPM_BUILD_ROOT%{_desktopdir}
258
259 %{__make} install \
260         DESTDIR=$RPM_BUILD_ROOT
261
262 cd unix/xserver/hw/vnc
263 %{__make} install \
264         DESTDIR=$RPM_BUILD_ROOT
265 cd -
266
267 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
268
269 install media/icons/tigervnc_16.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/16x16/apps/tigervnc.png
270 install media/icons/tigervnc_22.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/22x22/apps/tigervnc.png
271 install media/icons/tigervnc_24.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps/tigervnc.png
272 install media/icons/tigervnc_32.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/32x32/apps/tigervnc.png
273 install media/icons/tigervnc_48.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/48x48/apps/tigervnc.png
274 install media/icons/tigervnc.svg $RPM_BUILD_ROOT%{_iconsdir}/hicolor/scalable/apps/tigervnc.svg
275
276 %find_lang %{name}
277
278 %clean
279 rm -rf $RPM_BUILD_ROOT
280
281 %post
282 [ ! -x /usr/bin/update-desktop-database ] || %update_desktop_database_post
283 %update_icon_cache hicolor
284
285 %postun
286 [ ! -x /usr/bin/update-desktop-database ] || %update_desktop_database_postun
287 %update_icon_cache hicolor
288
289 %files -f %{name}.lang
290 %defattr(644,root,root,755)
291 %doc doc/*
292 %attr(755,root,root) %{_bindir}/vncviewer
293 %{_mandir}/man1/vncviewer.1*
294 %{_desktopdir}/tigervnc.desktop
295 %{_iconsdir}/hicolor/*/apps/tigervnc.*
296
297 %files server
298 %defattr(644,root,root,755)
299 %attr(755,root,root) %{_bindir}/Xvnc
300 %attr(755,root,root) %{_bindir}/vncserver
301 %attr(755,root,root) %{_bindir}/x0vncserver
302 %{_mandir}/man1/Xvnc.1*
303 %{_mandir}/man1/vncserver.1*
304 %{_mandir}/man1/x0vncserver.1*
305
306 %files utils
307 %defattr(644,root,root,755)
308 %attr(755,root,root) %{_bindir}/vncconfig
309 %attr(755,root,root) %{_bindir}/vncpasswd
310 %{_mandir}/man1/vncconfig.1*
311 %{_mandir}/man1/vncpasswd.1*
312
313 %files -n xorg-xserver-libvnc
314 %defattr(644,root,root,755)
315 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libvnc.so
This page took 0.047678 seconds and 3 git commands to generate.