]> git.pld-linux.org Git - packages/tigervnc.git/blob - tigervnc.spec
- fixes for xorg 1.11 fro fedora
[packages/tigervnc.git] / tigervnc.spec
1 # TODO:
2 # - tigervnc.init
3
4 %define         xversion        1.10.0
5
6 Summary:        A TigerVNC remote display system
7 Summary(pl.UTF-8):      System zdalnego dostępu TigerVNC
8 Name:           tigervnc
9 Version:        1.1.0
10 Release:        3.2
11 License:        GPL v2
12 Group:          X11/Applications/Networking
13 Source0:        http://dl.sourceforge.net/tigervnc/1.1.0/%{name}-%{version}.tar.gz
14 # Source0-md5:  1a5598b4a2ac530fb51411438959e11e
15 Source1:        %{name}.desktop
16 Patch0:         %{name}-cookie.patch
17 Patch1:         %{name}-ldnow.patch
18 Patch2:         %{name}-rh102434.patch
19 Patch3:         %{name}-viewer-reparent.patch
20 Patch4:         %{name}-as-needed.patch
21 Patch5:         %{name}-ipv6.patch
22 Patch6:         %{name}-xorg111.patch
23 URL:            http://www.tigervnc.com/
24 BuildRequires:  ImageMagick
25 BuildRequires:  ImageMagick-coder-png
26 BuildRequires:  ImageMagick-coder-svg
27 BuildRequires:  Mesa-libGL-devel >= 7.8.1
28 BuildRequires:  cpp
29 BuildRequires:  gnutls-devel
30 BuildRequires:  libjpeg-turbo-devel
31 BuildRequires:  xorg-xserver-server-source >= %{xversion}
32 BuildRequires:  zlib-devel
33 # xserver BRs, should match xorg-xserver-server.spec
34 # for glx headers
35 BuildRequires:  OpenGL-GLX-devel
36 BuildRequires:  autoconf >= 2.57
37 BuildRequires:  automake
38 BuildRequires:  libdrm-devel >= 2.4.5
39 BuildRequires:  libtool
40 BuildRequires:  nasm
41 BuildRequires:  ncurses-devel
42 BuildRequires:  pam-devel
43 BuildRequires:  perl-base
44 BuildRequires:  pixman-devel >= 0.16.0
45 BuildRequires:  pkgconfig >= 1:0.19
46 BuildRequires:  xorg-app-mkfontscale
47 BuildRequires:  xorg-font-font-util >= 1.1
48 BuildRequires:  xorg-lib-libX11-devel
49 BuildRequires:  xorg-lib-libXau-devel
50 BuildRequires:  xorg-lib-libXaw-devel
51 BuildRequires:  xorg-lib-libXdamage-devel
52 BuildRequires:  xorg-lib-libXdmcp-devel
53 BuildRequires:  xorg-lib-libXext-devel >= 1.0.99.4
54 BuildRequires:  xorg-lib-libXfont-devel >= 1.4.2
55 BuildRequires:  xorg-lib-libXi-devel >= 1.2.99.1
56 BuildRequires:  xorg-lib-libXmu-devel
57 BuildRequires:  xorg-lib-libXpm-devel
58 BuildRequires:  xorg-lib-libXrender-devel
59 BuildRequires:  xorg-lib-libXres-devel
60 BuildRequires:  xorg-lib-libXt-devel >= 1.0.0
61 BuildRequires:  xorg-lib-libXtst-devel >= 1.0.99.2
62 BuildRequires:  xorg-lib-libXv-devel
63 BuildRequires:  xorg-lib-libXxf86dga-devel
64 BuildRequires:  xorg-lib-libXxf86misc-devel
65 BuildRequires:  xorg-lib-libXxf86vm-devel
66 BuildRequires:  xorg-lib-libfontenc-devel
67 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.8.0
68 BuildRequires:  xorg-lib-libxkbfile-devel
69 BuildRequires:  xorg-lib-libxkbui-devel >= 1.0.2
70 BuildRequires:  xorg-lib-xtrans-devel >= 1.2.2
71 BuildRequires:  xorg-proto-bigreqsproto-devel >= 1.1.0
72 BuildRequires:  xorg-proto-damageproto-devel >= 1.1
73 BuildRequires:  xorg-proto-fixesproto-devel >= 4.1
74 BuildRequires:  xorg-proto-fontcacheproto-devel
75 BuildRequires:  xorg-proto-fontsproto-devel
76 BuildRequires:  xorg-proto-glproto-devel >= 1.4.10
77 BuildRequires:  xorg-proto-inputproto-devel >= 1.9.99.902
78 BuildRequires:  xorg-proto-kbproto-devel >= 1.0.3
79 BuildRequires:  xorg-proto-printproto-devel
80 BuildRequires:  xorg-proto-randrproto-devel >= 1.2.99.3
81 BuildRequires:  xorg-proto-recordproto-devel
82 BuildRequires:  xorg-proto-renderproto-devel >= 0.11
83 BuildRequires:  xorg-proto-resourceproto-devel
84 BuildRequires:  xorg-proto-scrnsaverproto-devel >= 1.1.0
85 BuildRequires:  xorg-proto-videoproto-devel
86 BuildRequires:  xorg-proto-xcmiscproto-devel >= 1.2.0
87 BuildRequires:  xorg-proto-xextproto-devel >= 1:7.0.99.3
88 BuildRequires:  xorg-proto-xf86bigfontproto-devel >= 1.2.0
89 BuildRequires:  xorg-proto-xf86dgaproto-devel >= 2.0.99.1
90 BuildRequires:  xorg-proto-xf86driproto-devel >= 2.1.0
91 BuildRequires:  xorg-proto-xf86miscproto-devel
92 BuildRequires:  xorg-proto-xf86vidmodeproto-devel >= 2.2.99.1
93 BuildRequires:  xorg-proto-xproto-devel >= 7.0.17
94 BuildRequires:  xorg-util-util-macros >= 1.10
95 Requires(post,postun):  gtk-update-icon-cache
96 Requires(post,postun):  hicolor-icon-theme
97 Requires:       libjpeg-turbo
98 Provides:       vnc-client
99 Conflicts:      vnc
100 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
101
102 %define         _xserverver     %(LC_ALL=C rpm -q --qf '%{V}' xorg-xserver-server-source 2> /dev/null)
103
104 %description
105 TigerVNC is a suite of VNC servers and clients that have a focus on
106 performance and remote display functionality. Originally this software
107 was based on the (never released) VNC 4 branch of TightVNC.
108
109 %description -l pl.UTF-8
110 TigerVNC to zestaw serwerów i klientów VNC, które koncentrują się
111 na wydajności i funkcjonalności zdalnego wyświetlania. Pierwotnie
112 oprogramowanie oparte było na (nigdy nie wydanej)
113 gałęzi VNC 4 TightVNC.
114
115 %package server
116 Summary:        VNC X server - TigerVNC version
117 Summary(pl.UTF-8):      X serwer VNC - wersja TigerVNC
118 Group:          X11/Applications/Networking
119 Requires:       xorg-app-rgb
120 # for vncpasswd tool
121 Requires:       %{name}-utils = %{version}-%{release}
122 # for mcookie
123 Requires:       util-linux
124 Requires:       libjpeg-turbo
125 Obsoletes:      vnc-server
126
127 %description server
128 This package contains VNC X server in TigerVNC version.
129
130 %description server -l pl.UTF-8
131 Ten pakiet zawiera X serwer VNC w wersji TigerVNC.
132
133 %package utils
134 Summary:        Additional utilities for TigerVNC
135 Summary(pl.UTF-8):      Dodatkowe narzędzia do TigerVNC
136 Group:          X11/Applications/Networking
137 Obsoletes:      vnc-utils
138
139 %description utils
140 This package contains additional TigerVNC utilities: vncconfig and
141 vncpasswd. vncconfig is used to configure and control a running
142 instance of Xvnc, or any other X server with the VNC extension.
143 vncpasswd generates password file (both on server and viewer side).
144
145 %description utils -l pl.UTF-8
146 Ten pakiet zawiera dodatkowe narzędzia do tightvnc: vncconfig i
147 vncpasswd. vncconfig służy do konfigurowania i kontroli działającej
148 instancji Xvnc lub innego serwera X z rozszerzeniem VNC.
149 vncpasswd służy to tworzenia pliku z hasłem (zarówno po
150 stronie serwera, jak i przeglądarki).
151
152 %package -n xorg-xserver-libvnc
153 Summary:        TigerVNC module for X.org server
154 Summary(pl.UTF-8):      Moduł TigerVNC dla servera X.org
155 Group:          X11/Servers
156 %requires_eq_to xorg-xserver-server xorg-xserver-server-source
157 Provides:       xorg-xserver-module(vnc)
158
159 %description -n xorg-xserver-libvnc
160 This package contains libvnc.so module for X.org server,
161 allowing others to access the desktop on your machine.
162
163 %description -n xorg-xserver-libvnc -l pl.UTF-8
164 Ten pakiet zawiera moduł libvnc.so dla serwera X.org,
165 pozwalający na zdalny dostęp do pulpitu.
166
167 %prep
168 %setup -q
169 %patch0 -p1
170 %patch1 -p1
171 %patch2 -p1
172 %patch3 -p1
173 %patch4 -p1
174 %patch5 -p0
175
176 cp -a %{_usrsrc}/xorg-xserver-server-%{_xserverver}/* unix/xserver
177 cd unix/xserver
178 patch -p1 <../xserver110.patch
179 cd -
180 %patch6 -p1
181
182 %build
183 %{__gettextize}
184 %{__libtoolize}
185 %{__aclocal}
186 %{__autoconf}
187 %{__autoheader}
188 %{__automake}
189
190 %{configure} \
191         --with-system-jpeg
192
193 %{__make}
194
195 cd unix/xserver
196 %{__automake}
197 %{__autoconf}
198 %configure \
199         --with-os-name="PLD/Linux" \
200         --with-os-vendor="PLD/Team" \
201         --disable-config-dbus \
202         --disable-config-hal \
203         --disable-config-udev \
204         --without-xmlto \
205         --without-fop \
206         --without-doxygen \
207         --disable-devel-docs \
208         --with-default-font-path="%{_fontsdir}/misc,%{_fontsdir}/TTF,%{_fontsdir}/OTF,%{_fontsdir}/Type1,%{_fontsdir}/100dpi,%{_fontsdir}/75dpi" \
209         --disable-xorg \
210         --disable-xnest \
211         --disable-xvfb \
212         --disable-dmx \
213         --disable-xwin \
214         --disable-xephyr \
215         --disable-kdrive \
216         --disable-xfbdev \
217         --disable-dri2 \
218         --with-pic \
219         --disable-static \
220         --disable-xinerama \
221         --disable-composite \
222         --enable-glx \
223         --enable-glx-tls \
224         --enable-aiglx \
225         --enable-dga \
226         --enable-glx-tls \
227         --enable-install-libxf86config \
228         --enable-record \
229         --disable-xfake \
230         --enable-secure-rpc \
231         --with-xkb-output=/var/lib/xkb
232
233 %{__make}
234 cd -
235
236 cd media
237 %{__make}
238
239 %install
240 rm -rf $RPM_BUILD_ROOT
241 install -d $RPM_BUILD_ROOT%{_iconsdir}/hicolor/{16x16,22x22,24x24,32x32,48x48,scalable}/apps \
242         $RPM_BUILD_ROOT%{_desktopdir}
243
244 %{__make} install \
245         DESTDIR=$RPM_BUILD_ROOT
246
247 cd unix/xserver/hw/vnc
248 %{__make} install \
249         DESTDIR=$RPM_BUILD_ROOT
250 cd -
251
252 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
253
254 install media/icons/tigervnc_16.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/16x16/apps/tigervnc.png
255 install media/icons/tigervnc_22.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/22x22/apps/tigervnc.png
256 install media/icons/tigervnc_24.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps/tigervnc.png
257 install media/icons/tigervnc_32.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/32x32/apps/tigervnc.png
258 install media/icons/tigervnc_48.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/48x48/apps/tigervnc.png
259 install media/icons/tigervnc.svg $RPM_BUILD_ROOT%{_iconsdir}/hicolor/scalable/apps/tigervnc.svg
260
261 %find_lang %{name}
262
263 %clean
264 rm -rf $RPM_BUILD_ROOT
265
266 %post
267 [ ! -x /usr/bin/update-desktop-database ] || %update_desktop_database_post
268 %update_icon_cache hicolor
269
270 %postun
271 [ ! -x /usr/bin/update-desktop-database ] || %update_desktop_database_postun
272 %update_icon_cache hicolor
273
274 %files -f %{name}.lang
275 %defattr(644,root,root,755)
276 %doc doc/*
277 %attr(755,root,root) %{_bindir}/vncviewer
278 %{_mandir}/man1/vncviewer.1*
279 %{_desktopdir}/tigervnc.desktop
280 %{_iconsdir}/hicolor/*/apps/tigervnc.*
281
282 %files server
283 %defattr(644,root,root,755)
284 %attr(755,root,root) %{_bindir}/Xvnc
285 %attr(755,root,root) %{_bindir}/vncserver
286 %attr(755,root,root) %{_bindir}/x0vncserver
287 %{_mandir}/man1/Xvnc.1*
288 %{_mandir}/man1/vncserver.1*
289 %{_mandir}/man1/x0vncserver.1*
290
291 %files utils
292 %defattr(644,root,root,755)
293 %attr(755,root,root) %{_bindir}/vncconfig
294 %attr(755,root,root) %{_bindir}/vncpasswd
295 %{_mandir}/man1/vncconfig.1*
296 %{_mandir}/man1/vncpasswd.1*
297
298 %files -n xorg-xserver-libvnc
299 %defattr(644,root,root,755)
300 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libvnc.so
This page took 0.0807290000000001 seconds and 3 git commands to generate.