]> git.pld-linux.org Git - packages/thrift.git/blob - thrift.spec
Some more work on python interface. Still needs lot of work
[packages/thrift.git] / thrift.spec
1 # TODO: BR for java, ruby, perl, more general BR
2 # TODO: Separate packages per each lang ?
3 # TODO: Fix ruby install
4 # TODO: Add Mono ?
5 # TODO: thrift-python -> python-trift ?
6 Summary:        Framework for scalable cross-language services development
7 Summary(pl.UTF-8):      Szkielet budowania skalowalnych usług dla różnych języków programowania 
8 Name:           thrift
9 Version:        0.2.0
10 Release:        0.2
11 License:        - enter GPL/GPL v2/GPL v3/LGPL/BSD/BSD-like/other license name here)
12 Group:          Applications
13 # http://www.apache.net.pl/incubator/thrift/0.2.0-incubating/thrift-0.2.0-incubating.tar.gz
14 Source0:        http://www.apache.net.pl/incubator/%{name}/%{version}-incubating/%{name}-%{version}-incubating.tar.gz
15 # Source0-md5:  9958c57c402c02171ba0bcc96183505c
16 Patch0:         %{name}-Werror_strlcpy_fix.patch
17 URL:            http://incubator.apache.org/thrift/
18 BuildRequires:  boost-devel >= 1.33.1
19 BuildRequires:  python-devel >= 2.4
20 BuildRequires:  zlib-devel >= 1.2.3
21 #Requires:      -
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Software framework for scalable cross-language services development. It combines a software stack with a code generation engine to build services that work efficiently and seamlessly between C++, Java, Python, PHP, Ruby, Erlang, Perl, Haskell, C#, Cocoa, Smalltalk, and OCaml.
26
27 %description -l pl.UTF-8
28 Programowy szkielet dla rozwoju skalowanych usług dla różnych języków programowania. Zawiera oprogramowanie wraz silnikiem generowania kodu do tworzenie usług
29 które spawnie działają pomiędzy C++, Javą, Pythonem, PHP, Rybym, Erlangiem, Perlem, Heskellem, C#, Cocoa, Smalltalikiem i Ocamlem.  
30
31
32 %package devel
33 Summary:        Header files for thrift
34 Summary(pl.UTF-8):      Pliki nagłówkowe thrift
35 Group:          Development/Libraries
36 Requires:       %{name} = %{version}-%{release}
37
38 %description devel
39 Header files for thrift.
40
41 %description devel -l pl.UTF-8
42 Pliki nagłówkowe thrift.
43
44
45 %package python
46 Summary:        Python thrift interface
47 Summary(pl.UTF-8):      Interfejs thrift dla Pythona
48 Group:          Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50
51 %description python
52 Python thrift interface.
53
54 %description python -l pl.UTF-8
55 Interfejs thrift dla Pythona.
56
57
58 %prep
59 %setup -q
60 %patch0 -p1
61
62 %build
63 %configure \
64     --without-ruby
65 %{__make}
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69
70 %{__make} install \
71         DESTDIR=$RPM_BUILD_ROOT
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %files
77 %defattr(644,root,root,755)
78 # %doc AUTHORS CREDITS ChangeLog NEWS README THANKS TODO
79 %attr(755,root,root) %{_bindir}/*
80
81 %files devel
82 %defattr(644,root,root,755)
83 # %doc devel-doc/*
84 %{_libdir}/lib%{name}.so
85 %{_libdir}/lib%{name}.la
86 %{_libdir}/lib%{name}z.so
87 %{_libdir}/lib%{name}z.la
88 %{_includedir}/%{name}
89 # %{_aclocaldir}/*.m4
90 # %{_pkgconfigdir}/*.pc
91
92
93 %files python
94 %defattr(644,root,root,755)
95 # %doc AUTHORS CREDITS ChangeLog NEWS README THANKS TODO
96 # change %{py_sitedir} to %{py_sitescriptdir} for 'noarch' packages!
97 %{py_sitedir}/%{name}
98 # %{py_sitedir}/*.py[co]
99 # %attr(755,root,root) %{py_sitedir}/*.so
100 %if "%{py_ver}" > "2.4"
101 %{py_sitedir}/Thrift-*.egg-info
102 %endif
This page took 0.053157 seconds and 4 git commands to generate.