]> git.pld-linux.org Git - packages/thrift.git/blob - thrift.spec
- Fixed cpp libs build. Split to devel libs and static.
[packages/thrift.git] / thrift.spec
1 # TODO
2 # - BR for java, ruby, perl, more general BR
3 # - Separate packages per each language
4 # - fix perl: missing vendordir on install
5 # - fix java: not installing to %{_javadir}
6 # - avoid downloading from net when build building java
7 # - Fix ruby install
8 # - Fix PHP build
9 # - Add Mono
10 # - Fix parallel build make.
11
12 Summary:        Framework for scalable cross-language services development
13 Summary(pl.UTF-8):      Szkielet budowania skalowalnych usług dla różnych języków programowania
14 Name:           thrift
15 Version:        0.5.0
16 Release:        3.9
17 License:        Apache v2.0
18 Group:          Development/Libraries
19 Source0:        http://ftp.tpnet.pl/vol/d1/apache//incubator/thrift/%{version}-incubating/%{name}-%{version}.tar.gz
20 # Source0-md5:  14c97adefb4efc209285f63b4c7f51f2
21 Patch0:         %{name}-Werror_strlcpy_fix.patch
22 Patch1:         %{name}-cpp_link_fix.patch
23 URL:            http://incubator.apache.org/thrift/
24 BuildRequires:  autoconf
25 BuildRequires:  automake
26 BuildRequires:  bison
27 BuildRequires:  boost-devel >= 1.33.1
28 BuildRequires:  flex
29 BuildRequires:  libevent-devel
30 BuildRequires:  pkgconfig
31 BuildRequires:  python-devel >= 1:2.4
32 BuildRequires:  rpm-pythonprov
33 BuildRequires:  rpmbuild(macros) >= 1.219
34 BuildRequires:  zlib-devel >= 1.2.3
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 Software framework for scalable cross-language services development.
39 It combines a software stack with a code generation engine to build
40 services that work efficiently and seamlessly between C++, Java,
41 Python, PHP, Ruby, Erlang, Perl, Haskell, C#, Cocoa, Smalltalk, and
42 OCaml.
43
44 %description -l pl.UTF-8
45 Programowy szkielet dla rozwoju skalowanych usług dla różnych języków
46 programowania. Zawiera oprogramowanie wraz silnikiem generowania kodu
47 do tworzenie usług które spawnie działają pomiędzy C++, Javą,
48 Pythonem, PHP, Rybym, Erlangiem, Perlem, Haskellem, C#, Cocoa,
49 Smalltalikiem i Ocamlem.
50
51
52 %package devel
53 Summary:        C++ header files
54 Summary(pl.UTF-8):      Pliki nagłówkowe i bibliotek iterfejsu C++ thrift
55 Group:          Development/Libraries
56 Requires:       %{name}-cpp = %{version}-%{release}
57
58 %description devel
59 Header and libarary files for C++ thrift inteface.
60
61 %description devel -l pl.UTF-8
62 Pliki nagłówkowe i bibliotek iterfejsu C++ thrift.
63
64
65 %package static
66 Summary:        Thrift C++ static libraries
67 Summary(pl.UTF-8):      Biblioteki statyczne iterfejsu C++ thrift
68 Group:          Development/Libraries
69 Requires:       %{name}-devel = %{version}-%{release}
70
71 %description static
72 Static libarary files for C++ thrift inteface.
73
74 %description static -l pl.UTF-8
75 Statyczne biblioteki iterfejsu C++ thrift.
76
77
78 %package -n %{name}-libs
79 Summary:        C++ thrift interface libraries
80 Summary(pl.UTF-8):      Interfejs thrift dla C++
81 Group:          Development/Libraries
82 Requires:       %{name} = %{version}-%{release}
83
84 %description -n %{name}-libs
85 C++ thrift interface libraries
86
87 %description -n %{name}-libs -l pl.UTF-8
88 Biblioteki interfejsu thrift dla C++.
89
90
91 %package -n python-%{name}
92 Summary:        Python thrift interface
93 Summary(pl.UTF-8):      Interfejs thrift dla Pythona
94 Group:          Development/Languages/Python
95 Requires:       %{name} = %{version}-%{release}
96
97 %description -n python-%{name}
98 Python thrift interface.
99
100 %description -n python-%{name} -l pl.UTF-8
101 Interfejs thrift dla Pythona.
102
103 %prep
104 %setup -q
105 %patch0 -p1
106 %patch1 -p1
107
108 %build
109 # %{__aclocal}
110 # %{__autoconf}
111 %{__autoheader}
112 %{__automake}
113 %configure \
114         --without-csharp \
115         --without-erlang \
116         --without-haskell \
117         --without-java \
118         --without-perl \
119         --without-php \
120         --without-php_extension \
121         --without-ruby
122
123 %{__make} -j1
124
125 %install
126 rm -rf $RPM_BUILD_ROOT
127
128 %{__make} install \
129         DESTDIR=$RPM_BUILD_ROOT
130
131 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
132 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
133 %py_postclean
134
135 %clean
136 rm -rf $RPM_BUILD_ROOT
137
138 %post   libs -p /sbin/ldconfig
139 %postun libs -p /sbin/ldconfig
140
141 %files
142 %defattr(644,root,root,755)
143 %attr(755,root,root) %{_bindir}/thrift
144
145 %files devel
146 %defattr(644,root,root,755)
147 %{_libdir}/libthrift.la
148 %{_libdir}/libthriftz.la
149 %{_libdir}/libthriftnb.la
150 %attr(755,root,root) %{_libdir}/libthrift.so
151 %attr(755,root,root) %{_libdir}/libthriftz.so
152 %attr(755,root,root) %{_libdir}/libthriftnb.so
153 %{_includedir}/%{name}
154 %{_pkgconfigdir}/thrift-nb.pc
155 %{_pkgconfigdir}/thrift-z.pc
156 %{_pkgconfigdir}/thrift.pc
157
158 %files static
159 %defattr(644,root,root,755)
160 %{_libdir}/libthrift.a
161 %{_libdir}/libthriftz.a
162 %{_libdir}/libthriftnb.a
163
164 %files libs
165 %defattr(644,root,root,755)
166 %attr(755,root,root) %{_libdir}/libthrift.so.*.*.*
167 %attr(755,root,root) %ghost %{_libdir}/libthrift.so.0
168 %attr(755,root,root) %{_libdir}/libthriftz.so.*.*.*
169 %attr(755,root,root) %ghost %{_libdir}/libthriftz.so.0
170 %attr(755,root,root) %{_libdir}/libthriftnb.so.*.*.*
171 %attr(755,root,root) %ghost %{_libdir}/libthriftnb.so.0
172
173 %files -n python-%{name}
174 %defattr(644,root,root,755)
175 %dir %{py_sitedir}/%{name}
176 %dir %{py_sitedir}/%{name}/protocol
177 %{py_sitedir}/%{name}/protocol/*.py[co]
178 %attr(755,root,root) %{py_sitedir}/%{name}/protocol/fastbinary.so
179 %dir %{py_sitedir}/%{name}/server
180 %{py_sitedir}/%{name}/server/*.py[co]
181 %dir %{py_sitedir}/%{name}/transport
182 %{py_sitedir}/%{name}/transport/*.py[co]
183 %{py_sitedir}/%{name}/*.py[co]
184 %if "%{py_ver}" > "2.4"
185 %{py_sitedir}/Thrift-*.egg-info
186 %endif
This page took 0.070306 seconds and 4 git commands to generate.