]> git.pld-linux.org Git - packages/thrift.git/blob - thrift.spec
- Started work on 0.5.0. Disabled PHP, Java. Stopped by link problems.
[packages/thrift.git] / thrift.spec
1 # TODO
2 # - BR for java, ruby, perl, more general BR
3 # - package -libs & ldconfig
4 # - Separate packages per each language
5 # - fix perl: missing vendordir on install
6 # - fix java: not installing to %{_javadir}
7 # - avoid downloading from net when build building java
8 # - Fix ruby install
9 # - Fix PHP build
10 # - Add Mono
11 # - libthriftnb.so lacks some libs when linking
12 Summary:        Framework for scalable cross-language services development
13 Summary(pl.UTF-8):      Szkielet budowania skalowalnych usług dla różnych języków programowania
14 Name:           thrift
15 Version:        0.5.0
16 Release:        0.1
17 License:        Apache v2.0
18 Group:          Development/Libraries
19 Source0:        http://ftp.tpnet.pl/vol/d1/apache//incubator/thrift/%{version}-incubating/thrift-%{version}.tar.gz
20 # Source0-md5:  14c97adefb4efc209285f63b4c7f51f2
21 Patch0:         %{name}-Werror_strlcpy_fix.patch
22 URL:            http://incubator.apache.org/thrift/
23 BuildRequires:  bison
24 BuildRequires:  boost-devel >= 1.33.1
25 BuildRequires:  flex
26 BuildRequires:  libevent-devel
27 BuildRequires:  pkgconfig
28 BuildRequires:  python-devel >= 1:2.4
29 BuildRequires:  rpm-pythonprov
30 BuildRequires:  rpmbuild(macros) >= 1.219
31 BuildRequires:  zlib-devel >= 1.2.3
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 Software framework for scalable cross-language services development.
36 It combines a software stack with a code generation engine to build
37 services that work efficiently and seamlessly between C++, Java,
38 Python, PHP, Ruby, Erlang, Perl, Haskell, C#, Cocoa, Smalltalk, and
39 OCaml.
40
41 %description -l pl.UTF-8
42 Programowy szkielet dla rozwoju skalowanych usług dla różnych języków
43 programowania. Zawiera oprogramowanie wraz silnikiem generowania kodu
44 do tworzenie usług które spawnie działają pomiędzy C++, Javą,
45 Pythonem, PHP, Rybym, Erlangiem, Perlem, Heskellem, C#, Cocoa,
46 Smalltalikiem i Ocamlem.
47
48 %package devel
49 Summary:        Header files for thrift
50 Summary(pl.UTF-8):      Pliki nagłówkowe thrift
51 Group:          Development/Libraries
52 Requires:       %{name} = %{version}-%{release}
53
54 %description devel
55 Header files for thrift.
56
57 %description devel -l pl.UTF-8
58 Pliki nagłówkowe thrift.
59
60 %package -n python-%{name}
61 Summary:        Python thrift interface
62 Summary(pl.UTF-8):      Interfejs thrift dla Pythona
63 Group:          Development/Languages/Python
64 Requires:       %{name} = %{version}-%{release}
65
66 %description -n python-%{name}
67 Python thrift interface.
68
69 %description -n python-%{name} -l pl.UTF-8
70 Interfejs thrift dla Pythona.
71
72 %prep
73 %setup -q
74 %patch0 -p1
75
76 %build
77 %configure \
78         --without-ruby \
79         --without-php \
80         --without-java \
81         --without-php_extension
82         
83 %{__make}
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87
88 %{__make} install \
89         DESTDIR=$RPM_BUILD_ROOT
90
91 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
92 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
93 %py_postclean
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %files
99 %defattr(644,root,root,755)
100 %attr(755,root,root) %{_bindir}/thrift
101
102 %files devel
103 %defattr(644,root,root,755)
104 %{_libdir}/libthrift.so
105 %{_libdir}/libthrift.la
106 %{_libdir}/libthriftz.so
107 %{_libdir}/libthriftz.la
108 %{_includedir}/%{name}
109 %{_pkgconfigdir}/thrift-nb.pc
110 %{_pkgconfigdir}/thrift-z.pc
111 %{_pkgconfigdir}/thrift.pc
112
113 %files -n python-%{name}
114 %defattr(644,root,root,755)
115 %dir %{py_sitedir}
116 %dir %{py_sitedir}/%{name}
117 %dir %{py_sitedir}/%{name}/protocol
118 %{py_sitedir}/%{name}/protocol/*.py[co]
119 %attr(755,root,root) %{py_sitedir}/%{name}/protocol/fastbinary.so
120 %dir %{py_sitedir}/%{name}/server
121 %{py_sitedir}/%{name}/server/*.py[co]
122 %dir %{py_sitedir}/%{name}/transport
123 %{py_sitedir}/%{name}/transport/*.py[co]
124 %{py_sitedir}/%{name}/*.py[co]
125 %if "%{py_ver}" > "2.4"
126 %{py_sitedir}/Thrift-*.egg-info
127 %endif
This page took 0.037575 seconds and 3 git commands to generate.