]> git.pld-linux.org Git - packages/tesseract.git/blob - tesseract.spec
- updated to 4.1.0
[packages/tesseract.git] / tesseract.spec
1 # TODO:
2 # - warnings at compile stage about pointer size on amd64 - needs check
3 # - warning: Installed (but unpackaged) file(s) found:
4 #        /usr/bin/language-specific.sh
5 #        /usr/bin/tesstrain.sh
6 #        /usr/bin/tesstrain_utils.sh
7 #
8 # Conditional build:
9 %bcond_without  openmp  # OpenMP support
10 %bcond_with     opencl  # OpenCL support
11 Summary:        Tesseract Open Source OCR Engine
12 Summary(pl.UTF-8):      Tesseract - silnik OCR o otwartych źródłach
13 Name:           tesseract
14 Version:        4.1.0
15 Release:        1
16 License:        Apache v2.0
17 Group:          Applications/Graphics
18 #Source0Download: https://github.com/tesseract-ocr/tesseract/releases
19 Source0:        https://github.com/tesseract-ocr/tesseract/archive/%{version}/%{name}-%{version}.tar.gz
20 # Source0-md5:  88572a88fc757bc7b43ae81502f921a2
21 URL:            https://github.com/tesseract-ocr/
22 %{?with_opencl:BuildRequires:   OpenCL-devel}
23 BuildRequires:  autoconf >= 2.63
24 BuildRequires:  automake
25 BuildRequires:  cairo-devel
26 BuildRequires:  leptonlib-devel >= 1.74
27 %{?with_openmp:BuildRequires:   libgomp-devel}
28 BuildRequires:  libicu-devel >= 52.1
29 BuildRequires:  libstdc++-devel >= 6:4.7
30 BuildRequires:  libtiff-devel
31 BuildRequires:  libtool >= 2:2
32 BuildRequires:  pango-devel >= 1:1.22.0
33 Requires:       leptonlib >= 1.74
34 Suggests:       tesseract-data >= 3
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 A commercial quality OCR engine originally developed at HP between
39 1985 and 1995. In 1995, this engine was among the top 3 evaluated by
40 UNLV. It was open-sourced by HP and UNLV in 2005.
41
42 %description -l pl.UTF-8
43 Silnik OCR o komercyjnej jakości oryginalnie stworzony przez HP w
44 latach 1985-1995. W 1995 roku był jednym z 3 najlepszych wg UNLV.
45 Źródła zostały uwolnione przez HP i UNLV w 2005 roku.
46
47 %package training
48 Summary:        Tesseract training tools
49 Summary(pl.UTF-8):      Narzędzia treningowe Tesseracta
50 Group:          Applications/Graphics
51 Requires:       %{name} = %{version}-%{release}
52 Requires:       pango >= 1:1.22.0
53
54 %description training
55 This package contains the Tesseract training tools.
56
57 %description training -l pl.UTF-8
58 Ten pakiet zawiera programy do trenowania Tesseracta.
59
60 %package devel
61 Summary:        Header files for Tesseract libraries
62 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek Tesseracta
63 Group:          Development/Libraries
64 Requires:       %{name} = %{version}-%{release}
65 Requires:       leptonlib-devel >= 1.74
66 Requires:       libstdc++-devel >= 6:4.7
67
68 %description devel
69 This package contains the development header files necessary to
70 develop applications using Tesseract API.
71
72 %description devel -l pl.UTF-8
73 Ten pakiet zawiera pliki nagłówkowe potrzebne do tworzenia programów
74 wykorzystujących API Tesseracta.
75
76 %package static
77 Summary:        Static Tesseract libraries
78 Summary(pl.UTF-8):      Statyczne biblioteki Tesseracta
79 Group:          Development/Libraries
80 Requires:       %{name}-devel = %{version}-%{release}
81
82 %description static
83 Static Tesseract libraries.
84
85 %description static -l pl.UTF-8
86 Statyczne biblioteki Tesseracta.
87
88 %prep
89 %setup -q
90
91 %build
92 %{__libtoolize}
93 %{__aclocal}
94 %{__autoconf}
95 %{__autoheader}
96 %{__automake}
97 %configure \
98         %{?with_opencl:--enable-opencl} \
99         %{!?with_openmp:--disable-openmp}
100 %{__make}
101 %{__make} training
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105
106 %{__make} install \
107         DESTDIR=$RPM_BUILD_ROOT
108
109 %{__make} training-install \
110         DESTDIR=$RPM_BUILD_ROOT
111
112 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libtesseract.la
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %post   -p /sbin/ldconfig
118 %postun -p /sbin/ldconfig
119
120 %files
121 %defattr(644,root,root,755)
122 %doc AUTHORS ChangeLog README.md
123 %attr(755,root,root) %{_bindir}/tesseract
124 %attr(755,root,root) %{_libdir}/libtesseract.so.*.*.*
125 %attr(755,root,root) %ghost %{_libdir}/libtesseract.so.4
126 %{_datadir}/tessdata
127 %{_mandir}/man1/tesseract.1*
128
129 %files training
130 %defattr(644,root,root,755)
131 %attr(755,root,root) %{_bindir}/ambiguous_words
132 %attr(755,root,root) %{_bindir}/classifier_tester
133 %attr(755,root,root) %{_bindir}/cntraining
134 %attr(755,root,root) %{_bindir}/combine_lang_model
135 %attr(755,root,root) %{_bindir}/combine_tessdata
136 %attr(755,root,root) %{_bindir}/dawg2wordlist
137 %attr(755,root,root) %{_bindir}/lstmeval
138 %attr(755,root,root) %{_bindir}/lstmtraining
139 %attr(755,root,root) %{_bindir}/merge_unicharsets
140 %attr(755,root,root) %{_bindir}/mftraining
141 %attr(755,root,root) %{_bindir}/set_unicharset_properties
142 %attr(755,root,root) %{_bindir}/shapeclustering
143 %attr(755,root,root) %{_bindir}/text2image
144 %attr(755,root,root) %{_bindir}/unicharset_extractor
145 %attr(755,root,root) %{_bindir}/wordlist2dawg
146 %{_mandir}/man1/ambiguous_words.1*
147 %{_mandir}/man1/classifier_tester.1*
148 %{_mandir}/man1/cntraining.1*
149 %{_mandir}/man1/combine_lang_model.1*
150 %{_mandir}/man1/combine_tessdata.1*
151 %{_mandir}/man1/dawg2wordlist.1*
152 %{_mandir}/man1/lstmeval.1*
153 %{_mandir}/man1/lstmtraining.1*
154 %{_mandir}/man1/merge_unicharsets.1*
155 %{_mandir}/man1/mftraining.1*
156 %{_mandir}/man1/set_unicharset_properties.1*
157 %{_mandir}/man1/shapeclustering.1*
158 %{_mandir}/man1/text2image.1*
159 %{_mandir}/man1/unicharset_extractor.1*
160 %{_mandir}/man1/wordlist2dawg.1*
161
162 %files devel
163 %defattr(644,root,root,755)
164 %attr(755,root,root) %{_libdir}/libtesseract.so
165 %{_includedir}/%{name}
166 %{_pkgconfigdir}/tesseract.pc
167 %{_mandir}/man5/unicharambigs.5*
168 %{_mandir}/man5/unicharset.5*
169
170 %files static
171 %defattr(644,root,root,755)
172 %{_libdir}/libtesseract.a
This page took 0.060995 seconds and 4 git commands to generate.