]> git.pld-linux.org Git - packages/tesseract.git/blob - tesseract.spec
- updated to 4.0.0
[packages/tesseract.git] / tesseract.spec
1 # TODO:
2 # - warnings at compile stage about pointer size on amd64 - needs check
3 #
4 # Conditional build:
5 %bcond_without  openmp  # OpenMP support
6 %bcond_with     opencl  # OpenCL support
7 Summary:        Tesseract Open Source OCR Engine
8 Summary(pl.UTF-8):      Tesseract - silnik OCR o otwartych źródłach
9 %define _beta   beta.4
10 Name:           tesseract
11 Version:        4.0.0
12 Release:        1
13 License:        Apache v2.0
14 Group:          Applications/Graphics
15 #Source0Download: https://github.com/tesseract-ocr/tesseract/releases
16 Source0:        https://github.com/tesseract-ocr/tesseract/archive/%{version}/%{name}-%{version}.tar.gz
17 # Source0-md5:  ebed139edb16f10c5ba6ee3bf38f7dc5
18 Patch0:         a2x.patch
19 URL:            https://github.com/tesseract-ocr/
20 %{?with_opencl:BuildRequires:   OpenCL-devel}
21 BuildRequires:  autoconf >= 2.59
22 BuildRequires:  automake
23 BuildRequires:  cairo-devel
24 BuildRequires:  leptonlib-devel >= 1.74
25 %{?with_openmp:BuildRequires:   libgomp-devel}
26 BuildRequires:  libicu-devel
27 BuildRequires:  libstdc++-devel >= 6:4.7
28 BuildRequires:  libtiff-devel
29 BuildRequires:  libtool >= 2:2
30 BuildRequires:  pango-devel
31 Suggests:       tesseract-data >= 3
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 A commercial quality OCR engine originally developed at HP between
36 1985 and 1995. In 1995, this engine was among the top 3 evaluated by
37 UNLV. It was open-sourced by HP and UNLV in 2005.
38
39 %description -l pl.UTF-8
40 Silnik OCR o komercyjnej jakości oryginalnie stworzony przez HP w
41 latach 1985-1995. W 1995 roku był jednym z 3 najlepszych wg UNLV.
42 Źródła zostały uwolnione przez HP i UNLV w 2005 roku.
43
44 %package training
45 Summary:        Tesseract training tools
46 Summary(pl.UTF-8):      Narzędzia treningowe Tesseracta
47 Group:          Applications/Graphics
48 Requires:       %{name} = %{version}
49
50 %description training
51 This package contains the Tesseract training tools.
52
53 %description training -l pl.UTF-8
54 Ten pakiet zawiera programy do trenowania Tesseracta.
55
56 %package devel
57 Summary:        Header files for Tesseract libraries
58 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek Tesseracta
59 Group:          Development/Libraries
60 Requires:       %{name} = %{version}-%{release}
61 Requires:       leptonlib-devel
62 Requires:       libstdc++-devel
63
64 %description devel
65 This package contains the development header files necessary to
66 develop applications using Tesseract API.
67
68 %description devel -l pl.UTF-8
69 Ten pakiet zawiera pliki nagłówkowe potrzebne do tworzenia programów
70 wykorzystujących API Tesseracta.
71
72 %package static
73 Summary:        Static Tesseract libraries
74 Summary(pl.UTF-8):      Statyczne biblioteki Tesseracta
75 Group:          Development/Libraries
76 Requires:       %{name}-devel = %{version}-%{release}
77
78 %description static
79 Static Tesseract libraries.
80
81 %description static -l pl.UTF-8
82 Statyczne biblioteki Tesseracta.
83
84 %prep
85 %setup -q
86 %patch0 -p1
87
88 %build
89 %{__libtoolize}
90 %{__aclocal}
91 %{__autoconf}
92 %{__autoheader}
93 %{__automake}
94 %configure \
95         %{?with_opencl:--enable-opencl} \
96         %{!?with_openmp:--disable-openmp}
97 %{__make}
98 %{__make} training
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102
103 %{__make} install \
104         DESTDIR=$RPM_BUILD_ROOT
105
106 %{__make} training-install \
107         DESTDIR=$RPM_BUILD_ROOT
108
109 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libtesseract.la
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %post   -p /sbin/ldconfig
115 %postun -p /sbin/ldconfig
116
117 %files
118 %defattr(644,root,root,755)
119 %doc AUTHORS COPYING ChangeLog README.md
120 %attr(755,root,root) %{_bindir}/tesseract
121 %attr(755,root,root) %{_libdir}/libtesseract.so.*.*.*
122 %attr(755,root,root) %ghost %{_libdir}/libtesseract.so.4
123 %{_datadir}/tessdata
124 %{_mandir}/man1/tesseract.1*
125
126 %files training
127 %defattr(644,root,root,755)
128 %attr(755,root,root) %{_bindir}/ambiguous_words
129 %attr(755,root,root) %{_bindir}/classifier_tester
130 %attr(755,root,root) %{_bindir}/cntraining
131 %attr(755,root,root) %{_bindir}/combine_lang_model
132 %attr(755,root,root) %{_bindir}/combine_tessdata
133 %attr(755,root,root) %{_bindir}/dawg2wordlist
134 %attr(755,root,root) %{_bindir}/lstmeval
135 %attr(755,root,root) %{_bindir}/lstmtraining
136 %attr(755,root,root) %{_bindir}/merge_unicharsets
137 %attr(755,root,root) %{_bindir}/mftraining
138 %attr(755,root,root) %{_bindir}/set_unicharset_properties
139 %attr(755,root,root) %{_bindir}/shapeclustering
140 %attr(755,root,root) %{_bindir}/text2image
141 %attr(755,root,root) %{_bindir}/unicharset_extractor
142 %attr(755,root,root) %{_bindir}/wordlist2dawg
143 %{_mandir}/man1/ambiguous_words.1*
144 %{_mandir}/man1/classifier_tester.1*
145 %{_mandir}/man1/cntraining.1*
146 %{_mandir}/man1/combine_lang_model.1*
147 %{_mandir}/man1/combine_tessdata.1*
148 %{_mandir}/man1/dawg2wordlist.1*
149 %{_mandir}/man1/lstmeval.1*
150 %{_mandir}/man1/lstmtraining.1*
151 %{_mandir}/man1/merge_unicharsets.1*
152 %{_mandir}/man1/mftraining.1*
153 %{_mandir}/man1/set_unicharset_properties.1*
154 %{_mandir}/man1/shapeclustering.1*
155 %{_mandir}/man1/text2image.1*
156 %{_mandir}/man1/unicharset_extractor.1*
157 %{_mandir}/man1/wordlist2dawg.1*
158
159 %files devel
160 %defattr(644,root,root,755)
161 %attr(755,root,root) %{_libdir}/libtesseract.so
162 %{_includedir}/%{name}
163 %{_pkgconfigdir}/tesseract.pc
164 %{_mandir}/man5/unicharambigs.5*
165 %{_mandir}/man5/unicharset.5*
166
167 %files static
168 %defattr(644,root,root,755)
169 %{_libdir}/libtesseract.a
This page took 0.115369 seconds and 4 git commands to generate.