]> git.pld-linux.org Git - packages/tdb.git/blob - tdb.spec
- up to 1.1.2; switch to samba implementation; add python bindings
[packages/tdb.git] / tdb.spec
1 %define snap    20080818
2 Summary:        TDB - Trivial Database
3 Summary(pl.UTF-8):      TDB - prosta baza danych
4 Name:           tdb
5 Version:        1.1.2
6 Release:        0.%{snap}.1
7 License:        GPL
8 Group:          Libraries
9 Source0:        %{name}-%{snap}.tar.bz2
10 # Source0-md5:  128dfb4865c2fcabf36d8cfbb1d20d06
11 URL:            http://tdb.samba.org/
12 BuildRequires:  gdbm-devel
13 BuildRequires:  python-devel
14 BuildRequires:  rpm-pythonprov
15 Obsoletes:      tdb-extras
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 TDB is a Trivial Database. In concept, it is very much like GDBM, and
20 BSD's DB except that it allows multiple simultaneous writers and uses
21 locking internally to keep writers from trampling on each other. TDB
22 is also extremely small.
23
24 %description -l pl.UTF-8
25 TDB to Trivial Database, czyli prosta baza danych. W założeniach jest
26 bardzo podobna do GDBM lub DB z BSD z wyjątkiem tego, że pozwala na
27 zapis wielu procesom jednocześnie i używa wewnętrznie blokowania, aby
28 nie pozwolić piszącym na zadeptanie się nawzajem. TDB jest ponadto
29 ekstremalnie mała.
30
31 %package devel
32 Summary:        Header files for TDB library
33 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki TDB
34 Group:          Development/Libraries
35 Requires:       %{name} = %{version}-%{release}
36
37 %description devel
38 Header files for TDB library.
39
40 %description devel -l pl.UTF-8
41 Pliki nagłówkowe biblioteki TDB.
42
43 %package static
44 Summary:        Static TDB library
45 Summary(pl.UTF-8):      Statyczna biblioteka TDB
46 Group:          Development/Libraries
47 Requires:       %{name}-devel = %{version}-%{release}
48
49 %description static
50 Static TDB library.
51
52 %description static -l pl.UTF-8
53 Statyczna biblioteka TDB.
54
55 %package extras
56 Summary:        TDB additional utilities
57 Summary(pl.UTF-8):      Dodatkowe narzędzia do TDB
58 Group:          Applications/Databases
59 Requires:       %{name} = %{version}-%{release}
60
61 %description extras
62 TDB additional utilities.
63
64 %description extras -l pl.UTF-8
65 Dodatkowe narzędzia do TDB.
66
67 %package -n python-tdb
68 Summary:        Python bindings for TDB
69 Group:          Libraries/Python
70 Requires:       %{name} = %{version}-%{release}
71 %pyrequires_eq  python-libs
72
73 %description -n python-tdb
74 Python bindings for TDB.
75
76 %prep
77 %setup -q -n %{name}
78
79 %build
80 %configure
81 %{__make}
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85
86 %{__make} install \
87         DESTDIR=$RPM_BUILD_ROOT
88
89 install libtdb.so $RPM_BUILD_ROOT%{_libdir}
90
91 %py_comp $RPM_BUILD_ROOT
92 %py_ocomp $RPM_BUILD_ROOT
93 %py_postclean
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %post   -p /sbin/ldconfig
99 %postun -p /sbin/ldconfig
100
101 %files
102 %defattr(644,root,root,755)
103 %doc docs/README
104 %attr(755,root,root) %{_bindir}/tdbbackup
105 %attr(755,root,root) %{_bindir}/tdbdump
106 %attr(755,root,root) %{_bindir}/tdbtool
107 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
108
109 %files devel
110 %defattr(644,root,root,755)
111 %attr(755,root,root) %{_libdir}/lib*.so
112 %{_includedir}/tdb.h
113 %{_pkgconfigdir}/*.pc
114
115 %files static
116 %defattr(644,root,root,755)
117 %{_libdir}/lib*.a
118
119 %files -n python-tdb
120 %defattr(644,root,root,755)
121 %attr(755,root,root) %{py_sitedir}/*.so
122 %{py_sitescriptdir}/*.py[co]
This page took 0.12696 seconds and 4 git commands to generate.