]> git.pld-linux.org Git - packages/tdb.git/blob - tdb.spec
- spec resurrected
[packages/tdb.git] / tdb.spec
1 Summary:        TDB - Trivial Database
2 Summary(pl.UTF-8):      TDB - prosta baza danych
3 Name:           tdb
4 Version:        1.2.9
5 Release:        1
6 License:        LGPL v3+
7 Group:          Libraries
8 Source0:        http://samba.org/ftp/tdb/%{name}-%{version}.tar.gz
9 # Source0-md5:  4d97d18bbe9040038d4e003495bb8cd1
10 URL:            http://tdb.samba.org/
11 BuildRequires:  gdbm-devel
12 BuildRequires:  python-devel
13 BuildRequires:  rpm-pythonprov
14 Obsoletes:      tdb-extras
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 TDB is a Trivial Database. In concept, it is very much like GDBM, and
19 BSD's DB except that it allows multiple simultaneous writers and uses
20 locking internally to keep writers from trampling on each other. TDB
21 is also extremely small.
22
23 %description -l pl.UTF-8
24 TDB to Trivial Database, czyli prosta baza danych. W założeniach jest
25 bardzo podobna do GDBM lub DB z BSD z wyjątkiem tego, że pozwala na
26 zapis wielu procesom jednocześnie i używa wewnętrznie blokowania, aby
27 nie pozwolić piszącym na zadeptanie się nawzajem. TDB jest ponadto
28 ekstremalnie mała.
29
30 %package devel
31 Summary:        Header files for TDB library
32 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki TDB
33 Group:          Development/Libraries
34 Requires:       %{name} = %{version}-%{release}
35 Obsoletes:      tdb-static
36
37 %description devel
38 Header files for TDB library.
39
40 %description devel -l pl.UTF-8
41 Pliki nagłówkowe biblioteki TDB.
42
43 %package -n python-tdb
44 Summary:        Python bindings for TDB
45 Summary(pl.UTF-8):      Pythonowy interfejs do TDB
46 Group:          Libraries/Python
47 Requires:       %{name} = %{version}-%{release}
48 %pyrequires_eq  python-libs
49
50 %description -n python-tdb
51 Python bindings for TDB.
52
53 %description -n python-tdb -l pl.UTF-8
54 Pythonowy interfejs do TDB.
55
56 %prep
57 %setup -q
58
59 %build
60 # note: configure in fact is waf call
61 CC="%{__cc}" \
62 CFLAGS="%{rpmcflags}" \
63 PYTHONDIR=%{py_sitedir} \
64 ./configure \
65         --prefix=%{_prefix} \
66         --libdir=%{_libdir}
67
68 %{__make} \
69         V=1
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73
74 %{__make} install \
75         DESTDIR=$RPM_BUILD_ROOT
76
77 # it's a symlink
78 #cp -a libtdb.so $RPM_BUILD_ROOT%{_libdir}
79
80 #py_comp $RPM_BUILD_ROOT
81 #py_ocomp $RPM_BUILD_ROOT
82 #py_postclean
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %post   -p /sbin/ldconfig
88 %postun -p /sbin/ldconfig
89
90 %files
91 %defattr(644,root,root,755)
92 %doc docs/README
93 %attr(755,root,root) %{_bindir}/tdbbackup
94 %attr(755,root,root) %{_bindir}/tdbdump
95 %attr(755,root,root) %{_bindir}/tdbrestore
96 %attr(755,root,root) %{_bindir}/tdbtool
97 %attr(755,root,root) %{_libdir}/libtdb.so.*.*.*
98 %attr(755,root,root) %ghost %{_libdir}/libtdb.so.1
99 %{_mandir}/man8/tdbbackup.8*
100 %{_mandir}/man8/tdbdump.8*
101 %{_mandir}/man8/tdbrestore.8*
102 %{_mandir}/man8/tdbtool.8*
103
104 %files devel
105 %defattr(644,root,root,755)
106 %attr(755,root,root) %{_libdir}/libtdb.so
107 %{_includedir}/tdb.h
108 %{_pkgconfigdir}/tdb.pc
109
110 %files -n python-tdb
111 %defattr(644,root,root,755)
112 %attr(755,root,root) %{py_sitedir}/tdb.so
This page took 0.053233 seconds and 4 git commands to generate.