]> git.pld-linux.org Git - packages/tcl.git/blob - tcl.spec
bdcb1b38a48e63b0278b49e8cbd81b23d742d943
[packages/tcl.git] / tcl.spec
1 Summary:        Tool Command Language embeddable scripting language, with shared libraries
2 Summary(fr):    Tool Command Language, langage de script avec bibliothèques partagées
3 Summary(pl):    Tool Command Language - jêzyk skryptowy z bibliotekami dynamicznymi
4 Summary(tr):    TCL ile kullanýlabilen betik dili
5 Name:           tcl
6 Version:        8.3.4
7 Release:        3
8 License:        BSD
9 Group:          Development/Languages/Tcl
10 Source0:        ftp://ftp.scriptics.com/pub/tcl/tcl8_3/%{name}%{version}.tar.gz
11 Source1:        %{name}-pl-man-pages.tar.bz2
12 Patch0:         %{name}-glibc21.patch
13 Patch1:         %{name}-tmpfix.patch
14 Patch2:         %{name}-manlnk.patch
15 Patch3:         %{name}-64bit.patch
16 Patch4:         %{name}-readline.patch
17 Patch5:         %{name}-headers_fix.patch
18 Patch6:         %{name}-opt.patch
19 Icon:           tcl.gif
20 URL:            http://www.scriptics.com/
21 BuildRequires:  autoconf
22 BuildRequires:  ncurses-devel >= 5.2
23 BuildRequires:  readline-devel >= 4.2
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 TCL is a simple scripting language that is designed to be embedded in
28 other applications. This package includes tclsh, a simple example of a
29 tcl application. TCL is very popular for writing small graphical
30 applications because of the TK widget set which is closely tied to it.
31
32 %description -l de
33 TCL ist eine einfache Skriptsprache, die zur Ingegration in andere
34 Applikationen vorgesehen ist. Dieses Paket umfaßt tclsh, ein einfaches
35 Beispiel einer tcl-Applikation. TCL wird gern zum Schreiben kleiner
36 grafischer Anwendungen benutzt, weil das TK-Widget-Set eng damit
37 verknüpft ist.
38
39 %description -l fr
40 TCL est un langage simple de script, conçu pour être intégré dans
41 d'autres applications. Ce paquetage contient tclsh, un exemple simple
42 d'application tcl. TCL est très utilisé pour écrire de petites
43 applications graphiques grâce à l'ensemble de widgets TK qui lui est
44 très lié.
45
46 %description -l pl
47 TCL jest prostym jêzykiem skryptowym, przeznaczonym do wspó³pracy z
48 innymi aplikacjami. W pakiecie znajduje siê równie¿ tclsh - prosty
49 przyk³ad programów. TCL jest bardzo popularnym jêzykiem do pisania
50 ma³ych programów graficznych.
51
52 %description -l tr
53 TCL, baþka uygulamalarýn içine gömülmesi hedeflenerek geliþtirilmiþ
54 basit bir betimleme dilidir. Bu paket basit bir tcl uygulamasý örneði
55 olan tclsh kabuðunu içerir. TCL, kendisi ile sýkýca ilintili olan TK
56 arayüz elemaný kümesinin de desteðiyle küçük grafik uygulamalar yazma
57 konusunda son derece yaygýn kullanýlmaktadýr.
58
59 %package devel
60 Summary:        Tool Command Language header files and development documentation
61 Summary(pl):    Pliki nag³ówkowe oraz dokumentacja dla tcl (Tool Command Language)
62 Group:          Development/Languages/Tcl
63 Requires:       %{name} = %{version}
64
65 %description devel
66 Tool Command Language embeddable scripting language header files and
67 develppment documentation.
68
69 %description devel -l pl
70 Pliki nag³ówkowe oraz dokumentacja dla tcl (Tool Command Language).
71
72 %prep
73 %setup  -q -n %{name}%{version}
74 %patch0 -p1
75 #%patch1 -p1 CHECK IT!
76 %patch2 -p1
77 %patch3 -p1
78 %patch4 -p1
79 %patch5 -p1
80 %patch6 -p1
81
82 %build
83 cd unix
84 sed -e "s/^CFLAGS_OPTIMIZE.*/CFLAGS_OPTIMIZE=%{optflags} -D__NO_STRING_INLINES -D__NO_MATH_INLINES -D_REENTRANT/" \
85         Makefile.in > Makefile.in.new
86 mv -f Makefile.in.new Makefile.in
87 %{__autoconf}
88 %configure \
89         --enable-shared \
90         --disable-threads \
91         --enable-64bit \
92         --enable-gcc
93 %{__make}
94
95 sed -e "s#%{_builddir}/%{name}%{version}/unix#%{_libdir}#; \
96         s#%{_builddir}/%{name}%{version}#%{_includedir}#" tclConfig.sh > tclConfig.sh.new
97 mv -f tclConfig.sh.new tclConfig.sh
98
99 %install
100 rm -rf $RPM_BUILD_ROOT
101 install -d $RPM_BUILD_ROOT{%{_prefix},%{_mandir}/man1}
102
103 cd unix
104 %{__make} install \
105         INSTALL_ROOT=$RPM_BUILD_ROOT \
106         MAN_INSTALL_DIR=$RPM_BUILD_ROOT%{_mandir}
107
108 ln -sf libtcl8.3.so $RPM_BUILD_ROOT%{_libdir}/libtcl.so
109 mv -f $RPM_BUILD_ROOT%{_bindir}/tclsh8.3 $RPM_BUILD_ROOT%{_bindir}/tclsh
110
111 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %post   -p /sbin/ldconfig
117 %postun -p /sbin/ldconfig
118
119 %files
120 %defattr(644,root,root,755)
121 %attr(755,root,root) %{_bindir}/*
122 %attr(755,root,root) %{_libdir}/lib*.so
123 %{_libdir}/tcl8.3
124 %{_mandir}/man1/*
125 %lang(pl) %{_mandir}/pl/man1/*
126
127 %files devel
128 %defattr(644,root,root,755)
129 %attr(755,root,root) %{_libdir}/tclConfig.sh
130 %{_libdir}/libtclstub8.3.a
131 %{_includedir}/*
132 %{_mandir}/man[3n]/*
133 %lang(pl) %{_mandir}/pl/mann/*
This page took 0.028975 seconds and 2 git commands to generate.