]> git.pld-linux.org Git - packages/tbb.git/blob - tbb.spec
undo pdf update (hash different on each download)
[packages/tbb.git] / tbb.spec
1 # use: major=year, minor=Update version, [micro=date if present]
2 %define         major   2021
3 %define         minor   4
4 %define         micro   0
5 Summary:        The Threading Building Blocks library abstracts low-level threading details
6 Summary(pl.UTF-8):      Threading Building Blocks - biblioteka abstrahująca niskopoziomowe szczegóły obsługi wątków
7 Name:           tbb
8 Version:        %{major}.%{minor}.%{micro}
9 Release:        1
10 License:        Apache v2.0
11 Group:          Development/Tools
12 # Source0Download: https://github.com/oneapi-src/oneTBB/releases
13 Source0:        https://github.com/01org/tbb/archive/v%{version}/oneTBB-%{version}.tar.gz
14 # Source0-md5:  fa317f16003e31e33a57ae7d888403e4
15 Source1:        http://www.threadingbuildingblocks.org/uploads/81/91/Latest%20Open%20Source%20Documentation/Design_Patterns.pdf
16 # Source1-md5:  46062fef922d39abfd464bc06e02cdd8
17 Source2:        http://www.threadingbuildingblocks.org/uploads/81/91/Latest%20Open%20Source%20Documentation/Getting_Started.pdf
18 # Source2-md5:  b8f94104c47f9667e537b98bd940494a
19 Source3:        http://www.threadingbuildingblocks.org/uploads/81/91/Latest%20Open%20Source%20Documentation/Reference.pdf
20 # Source3-md5:  1481cbd378f4964691046d0ba570b374
21 Source4:        http://www.threadingbuildingblocks.org/uploads/81/91/Latest%20Open%20Source%20Documentation/Tutorial.pdf
22 # Source4-md5:  5bbdd1050c5dac5c1b782a6a98db0c46
23 URL:            http://www.threadingbuildingblocks.org/
24 BuildRequires:  cmake >= 3.1
25 BuildRequires:  libstdc++-devel
26 BuildRequires:  pkgconfig
27 BuildRequires:  rpmbuild(macros) >= 1.605
28 BuildRequires:  sed >= 4.0
29 # We need "arch" binary:
30 BuildRequires:  util-linux
31 ExclusiveArch:  %{ix86} %{x8664} x32 %{arm} aarch64 ia64 ppc ppc64
32 # __TBB_machine_cmpswp8 uses gcc's __sync_val_compare_and_swap8 or directly cmpxchg8b asm instruction
33 ExcludeArch:    i386 i486
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 Threading Building Blocks (TBB) is a C++ runtime library that
38 abstracts the low-level threading details necessary for optimal
39 multi-core performance. It uses common C++ templates and coding style
40 to eliminate tedious threading implementation work.
41
42 TBB requires fewer lines of code to achieve parallelism than other
43 threading models. The applications you write are portable across
44 supported platforms. Since the library is also inherently scalable, no
45 code maintenance is required as more processor cores become available.
46
47 %description -l pl.UTF-8
48 Threading Building Blocks (TBB) to biblioteka uruchomieniowa C++
49 abstrahująca niskopoziomowe szczegóły obsługi wątków potrzebne dla
50 optymalnej wydajności na procesorach wielordzeniowych. Wykorzystuje
51 szablony C++ w celu wyeliminowania nudnej pracy nad wielowątkowością.
52
53 TBB wymaga mniej linii kodu do osiągnięcia równoległości niż inne
54 modele wątkowania. Aplikacje są przenośne między obsługiwanymi
55 platformami. Biblioteka jest skalowalna, więc nie jest wymagane
56 modyfikowanie kodu wraz z dostępnością większej liczby rdzeni
57 procesor.
58
59 %package devel
60 Summary:        The Threading Building Blocks C++ headers
61 Summary(pl.UTF-8):      Pliki nagłówkowe C++ bibliotek Threading Building Blocks
62 Group:          Development/Libraries
63 Requires:       %{name} = %{version}-%{release}
64
65 %description devel
66 Header files and shared object symlinks for the Threading Building
67 Blocks (TBB) C++ libraries.
68
69 %description devel -l pl.UTF-8
70 Pliki nagłówkowe i dowiązania symboliczne dla bibliotek C++ Threading
71 Building Blocks.
72
73 %package doc
74 Summary:        The Threading Building Blocks documentation
75 Summary(pl.UTF-8):      Dokumentacja bibliotek Threading Building Blocks
76 Group:          Documentation
77
78 %description doc
79 PDF documentation for the user of the Threading Building Block (TBB)
80 C++ library.
81
82 %description doc -l pl.UTF-8
83 Dokumentacja w formacie PDF dla użytkowników biblioteki C++ Threading
84 Building Blocks (TBB).
85
86 %prep
87 %setup -q -n oneTBB-%{version}
88
89 cp -p %{SOURCE1} %{SOURCE2} %{SOURCE3} %{SOURCE4} .
90
91 %build
92 %cmake -B build \
93         -DTBB_STRICT:BOOL=OFF \
94         -DTBB_TEST:BOOL=OFF
95
96 %{__make} -C build
97
98 %install
99 rm -rf $RPM_BUILD_ROOT
100
101 %{__make} -C build install \
102         DESTDIR=$RPM_BUILD_ROOT
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %post   -p /sbin/ldconfig
108 %postun -p /sbin/ldconfig
109
110 %files
111 %defattr(644,root,root,755)
112 %doc README.md third-party-programs.txt
113 %attr(755,root,root) %{_libdir}/libtbb.so.*.*
114 %attr(755,root,root) %ghost %{_libdir}/libtbb.so.12
115 %attr(755,root,root) %{_libdir}/libtbbmalloc.so.*.*
116 %attr(755,root,root) %ghost %{_libdir}/libtbbmalloc.so.2
117 %attr(755,root,root) %{_libdir}/libtbbmalloc_proxy.so.*.*
118 %attr(755,root,root) %ghost %{_libdir}/libtbbmalloc_proxy.so.2
119
120 %files devel
121 %defattr(644,root,root,755)
122 %attr(755,root,root) %{_libdir}/libtbb.so
123 %attr(755,root,root) %{_libdir}/libtbbmalloc.so
124 %attr(755,root,root) %{_libdir}/libtbbmalloc_proxy.so
125 # likely to be owned by different package?
126 %dir %{_includedir}/oneapi
127 %{_includedir}/oneapi/tbb.h
128 %{_includedir}/oneapi/tbb
129 %{_includedir}/tbb
130 %{_pkgconfigdir}/tbb.pc
131 %{_libdir}/cmake/TBB
132
133 %files doc
134 %defattr(644,root,root,755)
135 %doc *.pdf
This page took 0.060114 seconds and 4 git commands to generate.