]> git.pld-linux.org Git - packages/talloc.git/blob - talloc.spec
- added O for dropped python packages
[packages/talloc.git] / talloc.spec
1 #
2 Summary:        The talloc library - a hierarchical pool based memory system
3 Summary(pl.UTF-8):      Biblioteka talloc - system przydzielania pamięci oparty na hierarchicznej puli
4 Name:           talloc
5 Version:        2.3.0
6 Release:        2
7 Epoch:          2
8 License:        LGPL v3+
9 Group:          Libraries
10 Source0:        https://www.samba.org/ftp/talloc/%{name}-%{version}.tar.gz
11 # Source0-md5:  8416b153547add81cd1a4d24e598c890
12 URL:            http://talloc.samba.org/
13 BuildRequires:  docbook-dtd42-xml
14 BuildRequires:  docbook-style-xsl
15 BuildRequires:  libxslt-progs
16 BuildRequires:  python3 >= 1:3.2
17 BuildRequires:  python3-devel >= 1:3.2
18 BuildRequires:  python3-modules >= 1:3.2
19 BuildRequires:  rpm-pythonprov
20 Provides:       libtalloc = 2:%{version}-%{release}
21 Obsoletes:      libtalloc < 2:2.0.7-2
22 Obsoletes:      python-talloc
23 Obsoletes:      python-talloc-devel
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 # %{_includedir}/pytalloc.h shared between python*-talloc-devel
27 %define         _duplicate_files_terminate_build        0
28
29 %description
30 The talloc library implements a hierarchical allocator with
31 destructors.
32
33 %description -l pl.UTF-8
34 Biblioteka talloc jest implementacją systemu zarządzania pamięcią
35 opartego na hierarchicznej puli wraz z destruktorami.
36
37 %package devel
38 Summary:        Development files for the talloc library
39 Summary(pl.UTF-8):      Pliki programistyczne biblioteki talloc
40 Group:          Development/Libraries
41 Requires:       %{name} = %{epoch}:%{version}-%{release}
42 Provides:       libtalloc-devel = 2:%{version}-%{release}
43 Obsoletes:      libtalloc-devel < 2:2.0.7-2
44 Obsoletes:      libtalloc-static
45
46 %description devel
47 Development files needed to create programs that link against the
48 talloc library.
49
50 %description devel -l pl.UTF-8
51 Pliki programistyczne potrzebne do tworzenia programów używających
52 biblioteki talloc.
53
54 %package -n python3-talloc
55 Summary:        Python 3 binding for talloc library
56 Summary(pl.UTF-8):      Wiązanie Pythona 3 do biblioteki talloc
57 Group:          Libraries/Python
58 Requires:       %{name} = %{epoch}:%{version}-%{release}
59 Requires:       python3-libs >= 1:3.2
60
61 %description -n python3-talloc
62 Python 2 binding for talloc library.
63
64 %description -n python3-talloc -l pl.UTF-8
65 Wiązanie Pythona 3 do biblioteki talloc.
66
67 %package -n python3-talloc-devel
68 Summary:        Development files for Python 3 pytalloc-util library
69 Summary(pl.UTF-8):      Pliki programistyczne biblioteki pytalloc-util dla Pythona 3
70 Group:          Development/Libraries
71 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
72 Requires:       python3-devel >= 1:3.2
73 Requires:       python3-talloc = %{epoch}:%{version}-%{release}
74
75 %description -n python3-talloc-devel
76 Development files for Python 3 pytalloc-util library.
77
78 %description -n python3-talloc-devel -l pl.UTF-8
79 Pliki programistyczne biblioteki pytalloc-util dla Pythona 3.
80
81 %prep
82 %setup -q
83
84 %build
85 # threading breaks waf
86 export JOBS=1
87
88 CC="%{__cc}" \
89 CFLAGS="%{rpmcflags}" \
90 %{__python3} buildtools/bin/waf configure \
91         --prefix=%{_prefix} \
92         --libdir=%{_libdir} \
93         --disable-rpath
94
95 %{__make} \
96         V=1
97
98 %install
99 rm -rf $RPM_BUILD_ROOT
100
101 %{__make} install \
102         DESTDIR=$RPM_BUILD_ROOT
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %post   -p /sbin/ldconfig
108 %postun -p /sbin/ldconfig
109
110 %triggerpostun -p /sbin/postshell -- libtalloc < 2:2.0.1-5
111 -rm -f %{_libdir}/libtalloc.so.2
112 /sbin/ldconfig
113
114 %post   -n python3-talloc -p /sbin/ldconfig
115 %postun -n python3-talloc -p /sbin/ldconfig
116
117 %files
118 %defattr(644,root,root,755)
119 %attr(755,root,root) %{_libdir}/libtalloc.so.*.*.*
120 %attr(755,root,root) %ghost %{_libdir}/libtalloc.so.2
121
122 %files devel
123 %defattr(644,root,root,755)
124 %doc talloc_guide.txt
125 %attr(755,root,root) %{_libdir}/libtalloc.so
126 %{_includedir}/talloc.h
127 %{_pkgconfigdir}/talloc.pc
128 %{_mandir}/man3/talloc.3*
129
130 %files -n python3-talloc
131 %defattr(644,root,root,755)
132 %attr(755,root,root) %{_libdir}/libpytalloc-util.cpython-3*.so.*.*.*
133 %attr(755,root,root) %ghost %{_libdir}/libpytalloc-util.cpython-3*.so.2
134 %attr(755,root,root) %{py3_sitedir}/talloc.cpython-3*.so
135
136 %files -n python3-talloc-devel
137 %defattr(644,root,root,755)
138 %attr(755,root,root) %{_libdir}/libpytalloc-util.cpython-3*.so
139 %{_includedir}/pytalloc.h
140 %{_pkgconfigdir}/pytalloc-util.cpython-3*.pc
This page took 0.070493 seconds and 4 git commands to generate.