]> git.pld-linux.org Git - packages/talloc.git/blob - talloc.spec
- ldconfig for libpytalloc-util libraries
[packages/talloc.git] / talloc.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x library
4
5 Summary:        The talloc library - a hierarchical pool based memory system
6 Summary(pl.UTF-8):      Biblioteka talloc - system przydzielania pamięci oparty na hierarchicznej puli
7 Name:           talloc
8 Version:        2.1.16
9 Release:        1
10 Epoch:          2
11 License:        LGPL v3+
12 Group:          Libraries
13 Source0:        https://www.samba.org/ftp/talloc/%{name}-%{version}.tar.gz
14 # Source0-md5:  4ff5a73fbfc92ae7e9c63ceb7b4ee025
15 URL:            http://talloc.samba.org/
16 BuildRequires:  docbook-dtd42-xml
17 BuildRequires:  docbook-style-xsl
18 BuildRequires:  libxslt-progs
19 %if %{with python2}
20 BuildRequires:  python >= 1:2.4.2
21 BuildRequires:  python-devel >= 1:2.4.2
22 %endif
23 BuildRequires:  python3 >= 1:3.2
24 BuildRequires:  python3-devel >= 1:3.2
25 BuildRequires:  python3-modules >= 1:3.2
26 BuildRequires:  rpm-pythonprov
27 Provides:       libtalloc = 2:%{version}-%{release}
28 Obsoletes:      libtalloc < 2:2.0.7-2
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 # %{_includedir}/pytalloc.h shared between python*-talloc-devel
32 %define         _duplicate_files_terminate_build        0
33
34 %description
35 The talloc library implements a hierarchical allocator with
36 destructors.
37
38 %description -l pl.UTF-8
39 Biblioteka talloc jest implementacją systemu zarządzania pamięcią
40 opartego na hierarchicznej puli wraz z destruktorami.
41
42 %package devel
43 Summary:        Development files for the talloc library
44 Summary(pl.UTF-8):      Pliki programistyczne biblioteki talloc
45 Group:          Development/Libraries
46 Requires:       %{name} = %{epoch}:%{version}-%{release}
47 Provides:       libtalloc-devel = 2:%{version}-%{release}
48 Obsoletes:      libtalloc-devel < 2:2.0.7-2
49 Obsoletes:      libtalloc-static
50
51 %description devel
52 Development files needed to create programs that link against the
53 talloc library.
54
55 %description devel -l pl.UTF-8
56 Pliki programistyczne potrzebne do tworzenia programów używających
57 biblioteki talloc.
58
59 %package -n python-talloc
60 Summary:        Python 2 binding for talloc library
61 Summary(pl.UTF-8):      Wiązanie Pythona 2 do biblioteki talloc
62 Group:          Libraries/Python
63 Requires:       %{name} = %{epoch}:%{version}-%{release}
64 Requires:       python-libs >= 1:2.4.2
65
66 %description -n python-talloc
67 Python 2 binding for talloc library.
68
69 %description -n python-talloc -l pl.UTF-8
70 Wiązanie Pythona 2 do biblioteki talloc.
71
72 %package -n python-talloc-devel
73 Summary:        Development files for Python 2 pytalloc-util library
74 Summary(pl.UTF-8):      Pliki programistyczne biblioteki pytalloc-util dla Pythona 2
75 Group:          Development/Libraries
76 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
77 Requires:       python-devel >= 1:2.4.2
78 Requires:       python-talloc = %{epoch}:%{version}-%{release}
79
80 %description -n python-talloc-devel
81 Development files for Python 2 pytalloc-util library.
82
83 %description -n python-talloc-devel -l pl.UTF-8
84 Pliki programistyczne biblioteki pytalloc-util dla Pythona 2.
85
86 %package -n python3-talloc
87 Summary:        Python 3 binding for talloc library
88 Summary(pl.UTF-8):      Wiązanie Pythona 3 do biblioteki talloc
89 Group:          Libraries/Python
90 Requires:       %{name} = %{epoch}:%{version}-%{release}
91 Requires:       python3-libs >= 1:3.2
92
93 %description -n python3-talloc
94 Python 2 binding for talloc library.
95
96 %description -n python3-talloc -l pl.UTF-8
97 Wiązanie Pythona 3 do biblioteki talloc.
98
99 %package -n python3-talloc-devel
100 Summary:        Development files for Python 3 pytalloc-util library
101 Summary(pl.UTF-8):      Pliki programistyczne biblioteki pytalloc-util dla Pythona 3
102 Group:          Development/Libraries
103 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
104 Requires:       python3-devel >= 1:3.2
105 Requires:       python3-talloc = %{epoch}:%{version}-%{release}
106
107 %description -n python3-talloc-devel
108 Development files for Python 3 pytalloc-util library.
109
110 %description -n python3-talloc-devel -l pl.UTF-8
111 Pliki programistyczne biblioteki pytalloc-util dla Pythona 3.
112
113 %prep
114 %setup -q
115
116 %build
117 # threading breaks waf
118 export JOBS=1
119
120 CC="%{__cc}" \
121 CFLAGS="%{rpmcflags}" \
122 %{__python3} buildtools/bin/waf configure \
123         --prefix=%{_prefix} \
124         --libdir=%{_libdir} \
125         --disable-rpath \
126         --extra-python="%{__python}"
127
128 %{__make} \
129         V=1
130
131 %install
132 rm -rf $RPM_BUILD_ROOT
133
134 %{__make} install \
135         DESTDIR=$RPM_BUILD_ROOT
136
137 %clean
138 rm -rf $RPM_BUILD_ROOT
139
140 %post   -p /sbin/ldconfig
141 %postun -p /sbin/ldconfig
142
143 %triggerpostun -p /sbin/postshell -- libtalloc < 2:2.0.1-5
144 -rm -f %{_libdir}/libtalloc.so.2
145 /sbin/ldconfig
146
147 %post   -n python-talloc -p /sbin/ldconfig
148 %postun -n python-talloc -p /sbin/ldconfig
149
150 %post   -n python3-talloc -p /sbin/ldconfig
151 %postun -n python3-talloc -p /sbin/ldconfig
152
153 %files
154 %defattr(644,root,root,755)
155 %attr(755,root,root) %{_libdir}/libtalloc.so.*.*.*
156 %attr(755,root,root) %ghost %{_libdir}/libtalloc.so.2
157
158 %files devel
159 %defattr(644,root,root,755)
160 %doc talloc_guide.txt
161 %attr(755,root,root) %{_libdir}/libtalloc.so
162 %{_includedir}/talloc.h
163 %{_pkgconfigdir}/talloc.pc
164 %{_mandir}/man3/talloc.3*
165
166 %if %{with python2}
167 %files -n python-talloc
168 %defattr(644,root,root,755)
169 %attr(755,root,root) %{_libdir}/libpytalloc-util.so.*.*.*
170 %attr(755,root,root) %ghost %{_libdir}/libpytalloc-util.so.2
171 %attr(755,root,root) %{py_sitedir}/talloc.so
172
173 %files -n python-talloc-devel
174 %defattr(644,root,root,755)
175 %attr(755,root,root) %{_libdir}/libpytalloc-util.so
176 %{_includedir}/pytalloc.h
177 %{_pkgconfigdir}/pytalloc-util.pc
178 %endif
179
180 %files -n python3-talloc
181 %defattr(644,root,root,755)
182 %attr(755,root,root) %{_libdir}/libpytalloc-util.cpython-3*.so.*.*.*
183 %attr(755,root,root) %ghost %{_libdir}/libpytalloc-util.cpython-3*.so.2
184 %attr(755,root,root) %{py3_sitedir}/talloc.cpython-3*.so
185
186 %files -n python3-talloc-devel
187 %defattr(644,root,root,755)
188 %attr(755,root,root) %{_libdir}/libpytalloc-util.cpython-3*.so
189 %{_includedir}/pytalloc.h
190 %{_pkgconfigdir}/pytalloc-util.cpython-3*.pc
This page took 0.063943 seconds and 4 git commands to generate.