]> git.pld-linux.org Git - packages/talloc.git/blob - talloc.spec
- up to 2.3.0; upstream dropped python2 support
[packages/talloc.git] / talloc.spec
1 #
2 Summary:        The talloc library - a hierarchical pool based memory system
3 Summary(pl.UTF-8):      Biblioteka talloc - system przydzielania pamięci oparty na hierarchicznej puli
4 Name:           talloc
5 Version:        2.3.0
6 Release:        1
7 Epoch:          2
8 License:        LGPL v3+
9 Group:          Libraries
10 Source0:        https://www.samba.org/ftp/talloc/%{name}-%{version}.tar.gz
11 # Source0-md5:  8416b153547add81cd1a4d24e598c890
12 URL:            http://talloc.samba.org/
13 BuildRequires:  docbook-dtd42-xml
14 BuildRequires:  docbook-style-xsl
15 BuildRequires:  libxslt-progs
16 BuildRequires:  python3 >= 1:3.2
17 BuildRequires:  python3-devel >= 1:3.2
18 BuildRequires:  python3-modules >= 1:3.2
19 BuildRequires:  rpm-pythonprov
20 Provides:       libtalloc = 2:%{version}-%{release}
21 Obsoletes:      libtalloc < 2:2.0.7-2
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 # %{_includedir}/pytalloc.h shared between python*-talloc-devel
25 %define         _duplicate_files_terminate_build        0
26
27 %description
28 The talloc library implements a hierarchical allocator with
29 destructors.
30
31 %description -l pl.UTF-8
32 Biblioteka talloc jest implementacją systemu zarządzania pamięcią
33 opartego na hierarchicznej puli wraz z destruktorami.
34
35 %package devel
36 Summary:        Development files for the talloc library
37 Summary(pl.UTF-8):      Pliki programistyczne biblioteki talloc
38 Group:          Development/Libraries
39 Requires:       %{name} = %{epoch}:%{version}-%{release}
40 Provides:       libtalloc-devel = 2:%{version}-%{release}
41 Obsoletes:      libtalloc-devel < 2:2.0.7-2
42 Obsoletes:      libtalloc-static
43
44 %description devel
45 Development files needed to create programs that link against the
46 talloc library.
47
48 %description devel -l pl.UTF-8
49 Pliki programistyczne potrzebne do tworzenia programów używających
50 biblioteki talloc.
51
52 %package -n python3-talloc
53 Summary:        Python 3 binding for talloc library
54 Summary(pl.UTF-8):      Wiązanie Pythona 3 do biblioteki talloc
55 Group:          Libraries/Python
56 Requires:       %{name} = %{epoch}:%{version}-%{release}
57 Requires:       python3-libs >= 1:3.2
58
59 %description -n python3-talloc
60 Python 2 binding for talloc library.
61
62 %description -n python3-talloc -l pl.UTF-8
63 Wiązanie Pythona 3 do biblioteki talloc.
64
65 %package -n python3-talloc-devel
66 Summary:        Development files for Python 3 pytalloc-util library
67 Summary(pl.UTF-8):      Pliki programistyczne biblioteki pytalloc-util dla Pythona 3
68 Group:          Development/Libraries
69 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
70 Requires:       python3-devel >= 1:3.2
71 Requires:       python3-talloc = %{epoch}:%{version}-%{release}
72
73 %description -n python3-talloc-devel
74 Development files for Python 3 pytalloc-util library.
75
76 %description -n python3-talloc-devel -l pl.UTF-8
77 Pliki programistyczne biblioteki pytalloc-util dla Pythona 3.
78
79 %prep
80 %setup -q
81
82 %build
83 # threading breaks waf
84 export JOBS=1
85
86 CC="%{__cc}" \
87 CFLAGS="%{rpmcflags}" \
88 %{__python3} buildtools/bin/waf configure \
89         --prefix=%{_prefix} \
90         --libdir=%{_libdir} \
91         --disable-rpath
92
93 %{__make} \
94         V=1
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98
99 %{__make} install \
100         DESTDIR=$RPM_BUILD_ROOT
101
102 %clean
103 rm -rf $RPM_BUILD_ROOT
104
105 %post   -p /sbin/ldconfig
106 %postun -p /sbin/ldconfig
107
108 %triggerpostun -p /sbin/postshell -- libtalloc < 2:2.0.1-5
109 -rm -f %{_libdir}/libtalloc.so.2
110 /sbin/ldconfig
111
112 %post   -n python3-talloc -p /sbin/ldconfig
113 %postun -n python3-talloc -p /sbin/ldconfig
114
115 %files
116 %defattr(644,root,root,755)
117 %attr(755,root,root) %{_libdir}/libtalloc.so.*.*.*
118 %attr(755,root,root) %ghost %{_libdir}/libtalloc.so.2
119
120 %files devel
121 %defattr(644,root,root,755)
122 %doc talloc_guide.txt
123 %attr(755,root,root) %{_libdir}/libtalloc.so
124 %{_includedir}/talloc.h
125 %{_pkgconfigdir}/talloc.pc
126 %{_mandir}/man3/talloc.3*
127
128 %files -n python3-talloc
129 %defattr(644,root,root,755)
130 %attr(755,root,root) %{_libdir}/libpytalloc-util.cpython-3*.so.*.*.*
131 %attr(755,root,root) %ghost %{_libdir}/libpytalloc-util.cpython-3*.so.2
132 %attr(755,root,root) %{py3_sitedir}/talloc.cpython-3*.so
133
134 %files -n python3-talloc-devel
135 %defattr(644,root,root,755)
136 %attr(755,root,root) %{_libdir}/libpytalloc-util.cpython-3*.so
137 %{_includedir}/pytalloc.h
138 %{_pkgconfigdir}/pytalloc-util.cpython-3*.pc
This page took 0.14527 seconds and 3 git commands to generate.