]> git.pld-linux.org Git - packages/systemtap.git/blob - systemtap.spec
- updated files a bit
[packages/systemtap.git] / systemtap.spec
1 #
2 # TODO: - enable server
3 #       - BRs
4 #       - more configure options
5 #
6 %bcond_with     doc
7 Summary:        Instrumentation System
8 Summary(pl.UTF-8):      System oprzyrządowania
9 Name:           systemtap
10 Version:        1.8
11 Release:        0.1
12 License:        GPL v2+
13 Group:          Base
14 Source0:        http://sources.redhat.com/systemtap/ftp/releases/%{name}-%{version}.tar.gz
15 # Source0-md5:  5b7ab0ae0efc520f0b19f9dbf11977c9
16 Source1:        systemtap.tmpfiles
17 Patch0:         %{name}-configure.patch
18 Patch1:         %{name}-build.patch
19 Patch2:         %{name}-rpm5-support.patch
20 Patch3:         %{name}-no-Werror.patch
21 URL:            http://sourceware.org/systemtap/
22 BuildRequires:  autoconf
23 BuildRequires:  automake
24 BuildRequires:  xmlto
25 BuildRequires:  avahi-devel
26 BuildRequires:  elfutils-devel
27 BuildRequires:  glib2-devel
28 BuildRequires:  mysql-devel
29 BuildRequires:  nss-devel
30 BuildRequires:  sqlite3-devel
31 BuildRequires:  texlive-latex
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 SystemTap is an instrumentation system for systems running Linux 2.6.
36 Developers can write instrumentation to collect data on the operation
37 of the system.
38
39 %description -l pl.UTF-8
40 SystemTap to system oprzyrządowania dla systemów opartych na Linuksie
41 2.6. Programiści mogą pisać narzędzia do zbierania danych dotyczących
42 operacji w systemie.
43
44 %package server
45 Summary:        Instrumentation System Server
46 License:        GPL v2+
47 Group:          Applications/System
48 URL:            http://sourceware.org/systemtap/
49 Requires:       /bin/mktemp
50 Requires:       systemtap-devel = %{version}-%{release}
51 Requires:       unzip
52 Requires:       zip
53 Requires(post): /sbin/chkconfig
54 Requires(preun):        /sbin/chkconfig
55
56 %description server
57 This is the remote script compilation server component of systemtap.
58 It announces itself to nearby clients with avahi (if available), and
59 compiles systemtap scripts to kernel objects on their demand.
60
61
62 %package devel
63 Summary:        Programmable system-wide instrumentation system - development headers, tools
64 License:        GPL v2+
65 Group:          Development/Libraries
66 URL:            http://sourceware.org/systemtap/
67 Requires:       gcc
68 Requires:       linux-libc-headers
69 Requires:       make
70
71 %description devel
72 This package contains the components needed to compile a systemtap
73 script from source form into executable (.ko) forms. It may be
74 installed on a self-contained developer workstation (along with the
75 systemtap-client and systemtap-runtime packages), or on a dedicated
76 remote server (alongside the systemtap-server package). It includes a
77 copy of the standard tapset library and the runtime library C files.
78
79 %package runtime
80 Summary:        Programmable system-wide instrumentation system - runtime
81 License:        GPL v2+
82 Group:          Base
83 URL:            http://sourceware.org/systemtap/
84
85 %description runtime
86 SystemTap runtime contains the components needed to execute a
87 systemtap script that was already compiled into a module using a local
88 or remote systemtap-devel installation.
89
90 %package client
91 Summary:        Programmable system-wide instrumentation system - client
92 License:        GPL v2+
93 Group:          Base
94 URL:            http://sourceware.org/systemtap/
95 Requires:       coreutils
96 Requires:       grep
97 Requires:       openssh-clients
98 Requires:       sed
99 Requires:       systemtap-runtime = %{version}-%{release}
100 Requires:       unzip
101 Requires:       zip
102
103 %description client
104 This package contains/requires the components needed to develop
105 systemtap scripts, and compile them using a local systemtap-devel or a
106 remote systemtap-server installation, then run them using a local or
107 remote systemtap-runtime. It includes script samples and
108 documentation, and a copy of the tapset library for reference.
109
110
111 %package initscript
112 Summary:        Systemtap Initscripts
113 License:        GPL v2+
114 Group:          Base
115 URL:            http://sourceware.org/systemtap/
116 Requires:       systemtap = %{version}-%{release}
117 Requires(post): /sbin/chkconfig
118 Requires(preun):        /sbin/chkconfig
119 Requires(preun):        rc-scripts
120 Requires(postun):       rc-scripts
121
122 %description initscript
123 Sysvinit scripts to launch selected systemtap scripts at system
124 startup.
125
126 %package sdt-devel
127 Summary:        Static probe support tools
128 License:        GPLv2+ and Public Domain
129 Group:          Development/Libraries
130 URL:            http://sourceware.org/systemtap/
131
132 %description sdt-devel
133 This package includes the <sys/sdt.h> header file used for static
134 instrumentation compiled into userspace programs and libraries, along
135 with the optional dtrace-compatibility preprocessor to process related
136 .d files into tracing-macro-laden .h headers.
137
138 %prep
139 %setup -q
140 %patch0 -p1
141 %patch1 -p1
142 %patch2 -p1
143 %patch3 -p1
144
145 %build
146 %{__aclocal}
147 %{__autoconf}
148 %{__autoheader}
149 %{__automake}
150 cd runtime/staprun
151 %{__aclocal}
152 %{__autoconf}
153 %{__autoheader}
154 %{__automake}
155 cd -
156 %configure \
157         --disable-silent-rules \
158         --enable-pie \
159         --enable-sqlite \
160         --%{?with_doc:en}%{!?with_doc:dis}able-docs \
161         --enable-server
162 %{__make}
163
164 %install
165 rm -rf $RPM_BUILD_ROOT
166 install -d $RPM_BUILD_ROOT{/var/cache/%{name},%{systemdtmpfilesdir}}
167
168 %{__make} install \
169         DESTDIR=$RPM_BUILD_ROOT
170
171 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/stap-server.conf
172
173 %find_lang %{name}
174
175 %clean
176 rm -rf $RPM_BUILD_ROOT
177
178 %files
179 %defattr(644,root,root,755)
180 %doc AUTHORS HACKING NEWS README*
181 %doc %{_docdir}
182 %attr(755,root,root) %{_bindir}/stap
183 %attr(755,root,root) %{_bindir}/stap-merge
184 %attr(755,root,root) %{_bindir}/stap-report
185 %attr(755,root,root) %{_bindir}/staprun
186 %attr(755,root,root) %{_bindir}/stapsh
187 %{_datadir}/%{name}
188 %{_libexecdir}/%{name}
189 %dir /var/cache/%{name}
190 %{_mandir}/man1/stap.1*
191 %{_mandir}/man1/stap-merge.1*
192 %{_mandir}/man3/*.3*
193 %{_mandir}/man7/*.7*
194 %{_mandir}/man8/staprun.8*
195
196 %files sdt-devel -f %{name}.lang
197 %defattr(644,root,root,755)
198 %attr(755,root,root) %{_bindir}/dtrace
199 %{_includedir}/sys/sdt.h
200 %{_includedir}/sys/sdt-config.h
201 %{_mandir}/man1/dtrace.1*
This page took 0.079346 seconds and 3 git commands to generate.