]> git.pld-linux.org Git - packages/systemtap.git/blob - systemtap.spec
- add rpm5 support (patch from mandriva)
[packages/systemtap.git] / systemtap.spec
1 #
2 # TODO: - enable server
3 #       - BRs
4 #       - more configure options
5 #
6 %bcond_with     doc
7 Summary:        Instrumentation System
8 Summary(pl.UTF-8):      System oprzyrządowania
9 Name:           systemtap
10 Version:        1.8
11 Release:        0.1
12 License:        GPL v2+
13 Group:          Base
14 Source0:        http://sources.redhat.com/systemtap/ftp/releases/%{name}-%{version}.tar.gz
15 # Source0-md5:  5b7ab0ae0efc520f0b19f9dbf11977c9
16 Patch0:         %{name}-configure.patch
17 Patch1:         %{name}-build.patch
18 Patch2:         %{name}-rpm5-support.patch
19 URL:            http://sourceware.org/systemtap/
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 BuildRequires:  xmlto
23 BuildRequires:  avahi-devel
24 BuildRequires:  elfutils-devel
25 BuildRequires:  glib2-devel
26 BuildRequires:  mysql-devel
27 BuildRequires:  nss-devel
28 BuildRequires:  sqlite3-devel
29 BuildRequires:  texlive-latex
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 SystemTap is an instrumentation system for systems running Linux 2.6.
34 Developers can write instrumentation to collect data on the operation
35 of the system.
36
37 %description -l pl.UTF-8
38 SystemTap to system oprzyrządowania dla systemów opartych na Linuksie
39 2.6. Programiści mogą pisać narzędzia do zbierania danych dotyczących
40 operacji w systemie.
41
42 %package server
43 Summary:        Instrumentation System Server
44 License:        GPL v2+
45 Group:          Applications/System
46 URL:            http://sourceware.org/systemtap/
47 Requires:       /bin/mktemp
48 Requires:       systemtap-devel = %{version}-%{release}
49 Requires:       unzip
50 Requires:       zip
51 Requires(post): /sbin/chkconfig
52 Requires(preun):        /sbin/chkconfig
53
54 %description server
55 This is the remote script compilation server component of systemtap.
56 It announces itself to nearby clients with avahi (if available), and
57 compiles systemtap scripts to kernel objects on their demand.
58
59
60 %package devel
61 Summary:        Programmable system-wide instrumentation system - development headers, tools
62 License:        GPL v2+
63 Group:          Development/Libraries
64 URL:            http://sourceware.org/systemtap/
65 Requires:       gcc
66 Requires:       linux-libc-headers
67 Requires:       make
68
69 %description devel
70 This package contains the components needed to compile a systemtap
71 script from source form into executable (.ko) forms. It may be
72 installed on a self-contained developer workstation (along with the
73 systemtap-client and systemtap-runtime packages), or on a dedicated
74 remote server (alongside the systemtap-server package). It includes a
75 copy of the standard tapset library and the runtime library C files.
76
77 %package runtime
78 Summary:        Programmable system-wide instrumentation system - runtime
79 License:        GPL v2+
80 Group:          Base
81 URL:            http://sourceware.org/systemtap/
82
83 %description runtime
84 SystemTap runtime contains the components needed to execute a
85 systemtap script that was already compiled into a module using a local
86 or remote systemtap-devel installation.
87
88 %package client
89 Summary:        Programmable system-wide instrumentation system - client
90 License:        GPL v2+
91 Group:          Base
92 URL:            http://sourceware.org/systemtap/
93 Requires:       coreutils
94 Requires:       grep
95 Requires:       openssh-clients
96 Requires:       sed
97 Requires:       systemtap-runtime = %{version}-%{release}
98 Requires:       unzip
99 Requires:       zip
100
101 %description client
102 This package contains/requires the components needed to develop
103 systemtap scripts, and compile them using a local systemtap-devel or a
104 remote systemtap-server installation, then run them using a local or
105 remote systemtap-runtime. It includes script samples and
106 documentation, and a copy of the tapset library for reference.
107
108
109 %package initscript
110 Summary:        Systemtap Initscripts
111 License:        GPL v2+
112 Group:          Base
113 URL:            http://sourceware.org/systemtap/
114 Requires:       systemtap = %{version}-%{release}
115 Requires(post): /sbin/chkconfig
116 Requires(preun):        /sbin/chkconfig
117 Requires(preun):        rc-scripts
118 Requires(postun):       rc-scripts
119
120 %description initscript
121 Sysvinit scripts to launch selected systemtap scripts at system
122 startup.
123
124 %package sdt-devel
125 Summary:        Static probe support tools
126 License:        GPLv2+ and Public Domain
127 Group:          Development/Libraries
128 URL:            http://sourceware.org/systemtap/
129
130 %description sdt-devel
131 This package includes the <sys/sdt.h> header file used for static
132 instrumentation compiled into userspace programs and libraries, along
133 with the optional dtrace-compatibility preprocessor to process related
134 .d files into tracing-macro-laden .h headers.
135
136 %prep
137 %setup -q
138 %patch0 -p1
139 %patch1 -p1
140 %patch2 -p1
141
142 %build
143 %{__aclocal}
144 %{__autoconf}
145 %{__autoheader}
146 %{__automake}
147 %configure \
148         --disable-silent-rules \
149         --enable-pie \
150         --enable-sqlite \
151         --%{?with_doc:en}%{!?with_doc:dis}able-docs \
152         --enable-server
153 %{__make}
154
155 %install
156 rm -rf $RPM_BUILD_ROOT
157
158 %{__make} install \
159         DESTDIR=$RPM_BUILD_ROOT
160
161 install -d $RPM_BUILD_ROOT/var/cache/%{name}
162
163 %find_lang %{name}
164
165 %clean
166 rm -rf $RPM_BUILD_ROOT
167
168 %files
169 %defattr(644,root,root,755)
170 %doc AUTHORS HACKING NEWS README*
171 %doc %{_docdir}
172 %attr(755,root,root) %{_bindir}/stap
173 %attr(755,root,root) %{_bindir}/stap-merge
174 %attr(755,root,root) %{_bindir}/stap-report
175 %attr(755,root,root) %{_bindir}/stapgraph
176 %attr(755,root,root) %{_bindir}/staprun
177 %{_datadir}/%{name}
178 %{_libexecdir}/%{name}
179 %dir /var/cache/%{name}
180 #%{_mandir}/man1/*.1*
181 #%{_mandir}/man3/*.3*
182 #%{_mandir}/man7/*.7*
183 #%{_mandir}/man8/*.8*
184
185 %files sdt-devel -f %{name}.lang
186 %defattr(644,root,root,755)
187 %attr(755,root,root) %{_bindir}/dtrace
188 %{_includedir}/sys/sdt.h
189 %{_includedir}/sys/sdt-config.h
190 %{_mandir}/man1/dtrace.1*
This page took 0.044662 seconds and 3 git commands to generate.