]> git.pld-linux.org Git - packages/systemd.git/blob - systemd.spec
- rel 1
[packages/systemd.git] / systemd.spec
1 #
2 # TODO:
3 #       - remove compat-pld-var-run.tmpfiles and maybe tmpfiles-not-fatal.patch
4 #         after enough packages provide their own tmpfiles.d configs for
5 #         /var/run directories
6 #
7 # Conditional build:
8 %bcond_without  audit           # without audit support
9 %bcond_without  cryptsetup      # without cryptsetup support
10 %bcond_without  gtk             # build gtk tools
11 %bcond_without  pam             # PAM authentication support
12 %bcond_with     plymouth        # plymouth support
13 %bcond_without  selinux         # without SELinux support
14 %bcond_without  tcpd            # libwrap (tcp_wrappers) support
15
16 Summary:        A System and Service Manager
17 Summary(pl.UTF-8):      systemd - zarządca systemu i usług dla Linuksa
18 Name:           systemd
19 Version:        42
20 Release:        1
21 License:        GPL v2+
22 Group:          Base
23 Source0:        http://www.freedesktop.org/software/systemd/%{name}-%{version}.tar.xz
24 # Source0-md5:  7686b44e368d2523901d3e903ed4dcea
25 Source1:        %{name}-sysv-convert
26 Source2:        %{name}_booted.c
27 Source3:        ifup@.service
28 Source4:        network-post.service
29 Source5:        network.service
30 Source6:        compat-pld-media.tmpfiles
31 Source7:        compat-pld-var-run.tmpfiles
32 Patch0:         target-pld.patch
33 Patch1:         config-pld.patch
34 Patch2:         shut-sysv-up.patch
35 Patch3:         pld-sysv-network.patch
36 Patch4:         tmpfiles-not-fatal.patch
37 URL:            http://www.freedesktop.org/wiki/Software/systemd
38 BuildRequires:  acl-devel
39 %{?with_audit:BuildRequires:    audit-libs-devel}
40 BuildRequires:  autoconf >= 2.63
41 BuildRequires:  automake >= 1:1.11
42 %{?with_cryptsetup:BuildRequires:       cryptsetup-luks-devel}
43 BuildRequires:  dbus-devel >= 1.3.2
44 BuildRequires:  docbook-style-xsl
45 %if %{with gtk}
46 BuildRequires:  glib2-devel >= 1:2.26.1
47 BuildRequires:  gtk+2-devel >= 2:2.24.0
48 BuildRequires:  libgee-devel
49 BuildRequires:  libnotify-devel >= 0.7.0
50 %endif
51 BuildRequires:  binutils >= 3:2.22.52.0.1-2
52 BuildRequires:  gperf
53 BuildRequires:  intltool >= 0.40.0
54 BuildRequires:  kmod-devel >= 5
55 BuildRequires:  libcap-devel
56 %{?with_selinux:BuildRequires:  libselinux-devel}
57 BuildRequires:  libtool >= 2:2.2
58 %{?with_tcpd:BuildRequires:     libwrap-devel}
59 BuildRequires:  libxslt-progs
60 BuildRequires:  m4
61 %{?with_pam:BuildRequires:      pam-devel}
62 %{?with_plymouth:BuildRequires: plymouth-devel}
63 BuildRequires:  pkgconfig >= 0.9.0
64 BuildRequires:  rpmbuild(macros) >= 1.627
65 BuildRequires:  udev-devel >= 1:172
66 # not required for building from release (which contains *.c for *.vala)
67 #BuildRequires: vala >= 0.10.0
68 BuildRequires:  xz-devel
69 Requires:       %{name}-libs = %{version}-%{release}
70 Requires:       %{name}-units = %{version}-%{release}
71 Requires:       SysVinit-tools
72 Requires:       agetty
73 Requires:       dbus >= 1.4.16-6
74 Requires:       filesystem >= 4.0-2
75 Requires:       kmod >= 5
76 Requires:       rc-scripts >= 0.4.5.1-7
77 Requires:       setup >= 2.8.0-2
78 Requires:       udev-core >= 1:175-5
79 Requires:       udev-libs >= 1:172
80 Suggests:       ConsoleKit
81 Suggests:       fsck >= 2.20
82 Suggests:       nss_myhostname
83 # python modules required by systemd-analyze
84 Suggests:       %{name}-no-compat-tmpfiles
85 Suggests:       python-dbus
86 Suggests:       python-modules
87 Suggests:       service(klogd)
88 Suggests:       service(syslog)
89 Provides:       udev-acl
90 # systemd takes care of that and causes problems
91 Conflicts:      binfmt-detector
92 # sytemd wants pam with pam_systemd.so in system-auth...
93 Conflicts:      pam < 1:1.1.5-5
94 # ...and sudo hates it
95 Conflicts:      sudo < 1:1.7.8p2-4
96 Conflicts:      upstart
97 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
98
99 %define         _libexecdir     %{_prefix}/lib
100
101 %description
102 systemd is a system and service manager for Linux, compatible with
103 SysV and LSB init scripts. systemd provides aggressive parallelization
104 capabilities, uses socket and D-Bus activation for starting services,
105 offers on-demand starting of daemons, keeps track of processes using
106 Linux cgroups, supports snapshotting and restoring of the system
107 state, maintains mount and automount points and implements an
108 elaborate transactional dependency-based service control logic. It can
109 work as a drop-in replacement for sysvinit.
110
111 %description -l pl.UTF-8
112 systemd jest zarządcą systemu i usług dla Linuksa, kompatybilny ze
113 skryptami SysV i LSB. systemd udostępnia rozbudowane zdolności
114 paralelizacji, do uruchamiania usług używa socketów oraz D-Busa,
115 oferuje uruchamianie usług na życzenie, monitoruje procesy używając
116 linuksowych cgroups, wspomaga zapisywanie (snapshot) i odczytywanie
117 (restore) stanu systemu, zarządza (auto)mount pointami oraz
118 implementuje starannie opracowaną transakcjonalną, bazującą na
119 zależnościach logikę kontroli usług. Może pracować jako zastępca dla
120 sysvinit.
121
122 %package init
123 Summary:        systemd /sbin/init and LSB/SysV compatibility symlinks
124 Summary(pl.UTF-8):      /sbin/init z systemd i dowiązania dla kompatybilności z LSB/SysV
125 Group:          Base
126 Requires:       systemd
127 Provides:       readahead = 1:1.5.7-3
128 Provides:       virtual(init-daemon)
129 Obsoletes:      SysVinit
130 Obsoletes:      readahead < 1:1.5.7-3
131 Obsoletes:      virtual(init-daemon)
132
133 %description init
134 Install this package when you are ready to final switch to systemd.
135
136 %description init -l pl.UTF-8
137 Ten pakiet należy zainstalować po przygotowaniu się do ostatecznego
138 przejścia na systemd.
139
140 %package units
141 Summary:        Configuration files, directories and installation tool for systemd
142 Summary(pl.UTF-8):      Pliki konfiguracyjne, katalogi i narzędzie instalacyjne dla systemd
143 Group:          Base
144 Requires(post): coreutils
145 Requires(post): gawk
146
147 %description units
148 Basic configuration files, directories and installation tool for the
149 systemd system and service manager.
150
151 This is common config, use %{_sysconfdir}/systemd/system to override.
152
153 %description units -l pl.UTF-8
154 Podstawowe pliki konfiguracyjne, katalogi i narzędzie instalacyjne dla
155 zarządcy systemu i usług systemd.
156
157 Ten pakiet zawiera ogólną konfigurację, ustawienia można nadpisać
158 poprzez katalog %{_sysconfdir}/systemd/system.
159
160 %package gtk
161 Summary:        Graphical frontend for systemd
162 Summary(pl.UTF-8):      Graficzny interfejs do systemd
163 Group:          Base
164 Requires:       %{name} = %{version}-%{release}
165 Requires:       polkit
166
167 %description gtk
168 Graphical front-end for systemd.
169
170 %description gtk -l pl.UTF-8
171 Graficzny interfejs do systemd.
172
173 %package libs
174 Summary:        Shared systemd libraries
175 Summary(pl.UTF-8):      Biblioteki współdzielone systemd
176 Group:          Libraries
177
178 %description libs
179 Shared systemd libraries.
180
181 %description libs -l pl.UTF-8
182 Biblioteki współdzielone systemd.
183
184 %package devel
185 Summary:        Header files for systemd libraries
186 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek systemd
187 Group:          Development/Libraries
188 Requires:       %{name}-libs = %{version}-%{release}
189
190 %description devel
191 Header files for systemd libraries.
192
193 %description devel -l pl.UTF-8
194 Pliki nagłówkowe bibliotek systemd.
195
196 %package -n bash-completion-systemd
197 Summary:        bash-completion for systemd
198 Summary(pl.UTF-8):      Bashowe dopełnianie składni dla systemd
199 Group:          Applications/Shells
200 Requires:       %{name}
201 Requires:       bash-completion
202
203 %description -n bash-completion-systemd
204 bash-completion for systemd.
205
206 %description -n bash-completion-systemd -l pl.UTF-8
207 Bashowe dopełnianie składni dla systemd
208
209 %package no-compat-tmpfiles
210 Summary:        Force update of packages that provide tmpfiles.d configuration
211 Group:          Base
212 Requires(post): sed > 4.0
213 Conflicts:      ConsoleKit-dirs < 0.4.5-7
214 Conflicts:      NetworkManager < 2:0.9.2.0-3
215 Conflicts:      Zope < 2.11.8-2
216 Conflicts:      amavisd-new < 1:2.7.0-1
217 Conflicts:      apache-base < 2.2.21-4
218 Conflicts:      apache-mod_bw < 0.92-3
219 Conflicts:      apache-mod_fastcgi < 2.4.6-6
220 Conflicts:      apache1-base < 1.3.42-5
221 Conflicts:      apache1-mod_fastcgi < 2.4.6-2
222 Conflicts:      asterisk < 10.0.1-2
223 Conflicts:      autossh-init < 1.4b-3
224 Conflicts:      balance < 3.54-2
225 Conflicts:      bind < 7:9.8.1.P1-4
226 Conflicts:      bopm < 3.1.3-4
227 Conflicts:      callweaver < 1.2.1-9
228 Conflicts:      cassandra-bin < 0.8.9-2
229 Conflicts:      clamav < 0.97.3-3
230 Conflicts:      cups < 1:1.5.0-10
231 Conflicts:      dbus < 1.4.16-4
232 Conflicts:      dovecot < 1:2.0.16-3
233 Conflicts:      dspam < 3.9.0-6
234 Conflicts:      fail2ban < 0.8.4-4
235 Conflicts:      filesystem < 4.0-3
236 Conflicts:      gammu-smsd < 1:1.31.0-3
237 # Break gdm2.20 installs
238 #Conflicts:     gdm < 2:3.2.1.1-9
239 Conflicts:      greylistd < 0.8.8-2
240 Conflicts:      inn < 2.4.6-7
241 Conflicts:      ipsec-tools < 0.8.0-3
242 Conflicts:      jabber-common < 0-9
243 Conflicts:      laptop-mode-tools < 1.58-2
244 Conflicts:      libgpod < 0.8.0-6
245 Conflicts:      libvirt-utils < 0.9.9-4
246 Conflicts:      lighttpd < 1.4.30-5
247 Conflicts:      lirc < 0.9.0-20
248 Conflicts:      mailman < 5:2.1.14-4
249 Conflicts:      memcached < 1.4.11-2
250 Conflicts:      mpd < 0.16.5-4
251 Conflicts:      mrtg < 2.17.0-3
252 Conflicts:      munin-common < 1.4.5-5
253 Conflicts:      nagios-nrpe < 2.13-2
254 Conflicts:      ndisc6-rdnssd < 1.0.1-3
255 Conflicts:      nscd < 6:2.14.1-5
256 Conflicts:      nss_ldapd-nslcd < 0.8.4-2
257 Conflicts:      openct < 0.6.20-3
258 Conflicts:      openl2tp < 1.8-3
259 Conflicts:      openldap-overlay-nssov < 2.4.28-4
260 Conflicts:      openldap-servers < 2.4.28-4
261 Conflicts:      openvpn < 2.2.2-2
262 Conflicts:      pam-pam_mount < 2.12-3
263 Conflicts:      pam-pam_ssh < 1.97-2
264 Conflicts:      pcsc-lite < 1.8.1-2
265 Conflicts:      php-dirs < 1.2-3
266 Conflicts:      policyd < 2.0.10-3
267 Conflicts:      pound < 2.6-2
268 Conflicts:      pptp < 1.7.2-3
269 Conflicts:      proftpd-common < 2:1.3.4a-2
270 Conflicts:      pulseaudio-server < 1.1-2
271 Conflicts:      quagga < 0.99.20-3
272 Conflicts:      radvd < 1.8.5-2
273 Conflicts:      rc-scripts < 0.4.5.2-3
274 Conflicts:      red5 < 0.9.0-2
275 Conflicts:      redis-server < 2.4.2-4
276 Conflicts:      smokeping < 2.4.2-10
277 Conflicts:      smtp-gated < 1.4.17-2
278 Conflicts:      socat < 1.7.2.0-2
279 Conflicts:      speech-dispatcher < 0.7.1-2
280 Conflicts:      sphinx < 2.0.3-4
281 Conflicts:      splashutils < 1.5.4.3-3
282 Conflicts:      stunnel < 4.50-2
283 Conflicts:      tenshi < 0.12-2
284 Conflicts:      tor < 0.2.2.35-2
285 Conflicts:      ucarp < 1.5.2-3
286 Conflicts:      udisks < 1.0.4-3
287 Conflicts:      util-vserver < 0.30.216-1.pre3002.3
288 Conflicts:      vpnc < 0.5.3-2
289 Conflicts:      web2ldap < 1.1.0rc1-2
290 Conflicts:      wesnoth-server < 1:1.10-2
291 Conflicts:      wpa_supplicant < 0.7.3-10
292 Conflicts:      xl2tpd < 1.3.0-2
293
294 %description no-compat-tmpfiles
295 Force update of packages that provide tmpfiles.d configuration
296
297 %prep
298 %setup -q
299 %patch0 -p1
300 %patch1 -p1
301 %patch2 -p1
302 %patch3 -p1
303 %patch4 -p1
304 cp -p %{SOURCE2} src/systemd_booted.c
305
306 %build
307 %{__aclocal} -I m4
308 %{__autoconf}
309 %{__autoheader}
310 %{__automake}
311 %configure \
312         %{__enable_disable audit} \
313         %{__enable_disable cryptsetup libcryptsetup} \
314         %{__enable_disable gtk} \
315         %{__enable_disable pam} \
316         %{__enable_disable plymouth} \
317         %{__enable_disable selinux} \
318         %{__enable_disable tcpd tcpwrap} \
319         --disable-silent-rules \
320         --disable-static \
321         --with-distro=pld \
322         --with-rootprefix= \
323         --with-rootlibdir=/%{_lib} \
324         --enable-split-usr
325
326 %{__make}
327 ./libtool --mode=link --tag=CC %{__cc} %{rpmcppflags} %{rpmcflags} -o systemd_booted %{rpmldflags} src/systemd_booted.c -L. -lsystemd-daemon
328
329 %install
330 rm -rf $RPM_BUILD_ROOT
331
332 %{__make} install \
333         DESTDIR=$RPM_BUILD_ROOT
334
335 ./libtool --mode=install install -m755 systemd_booted $RPM_BUILD_ROOT/bin/systemd_booted
336
337 # Main binary has been moved, but we don't want to break existing installs
338 ln -s ../lib/systemd/systemd $RPM_BUILD_ROOT/bin/systemd
339
340 # Create SysV compatibility symlinks. systemctl/systemd are smart
341 # enough to detect the way they were called
342 install -d $RPM_BUILD_ROOT/sbin
343 ln -s ../lib/systemd/systemd $RPM_BUILD_ROOT/sbin/init
344 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/halt
345 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/poweroff
346 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/reboot
347 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/runlevel
348 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/shutdown
349 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/telinit
350
351 ln -s ../modules $RPM_BUILD_ROOT%{_sysconfdir}/modules-load.d/modules.conf
352 # disable random and console SYSV service
353 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/random.service
354 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/console.service
355
356 # add static (non-NetworkManager) networking
357 install %{SOURCE3} $RPM_BUILD_ROOT%{systemdunitdir}/ifup@.service
358 install %{SOURCE4} $RPM_BUILD_ROOT%{systemdunitdir}/network-post.service
359 install %{SOURCE5} $RPM_BUILD_ROOT%{systemdunitdir}/network.service
360
361 # install compatibility tmpfiles configs
362 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/compat-pld-media.conf
363 install %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/compat-pld-var-run.conf
364
365 # All wants links are created at %post to make sure they are not owned
366 # and hence overriden by rpm if the user deletes them (missingok?)
367 %{__rm} -r $RPM_BUILD_ROOT%{_sysconfdir}/systemd/system/*.target.wants
368
369 # it is in rc-scripts pkg
370 %{__rm} $RPM_BUILD_ROOT%{systemdunitdir}/rc-local.service
371
372 # Make sure these directories are properly owned:
373 #       - halt,kexec,poweroff,reboot: generic ones used by ConsoleKit-systemd,
374 #       - syslog _might_ be used by some syslog implementation (none for now),
375 #       - isn't dbus populated by dbus-systemd only (so to be moved there)?
376 install -d $RPM_BUILD_ROOT%{systemdunitdir}/{dbus,halt,kexec,poweroff,reboot,syslog}.target.wants
377
378 # Create new-style configuration files so that we can ghost-own them
379 touch $RPM_BUILD_ROOT%{_sysconfdir}/{hostname,locale.conf,machine-id,machine-info,os-release,timezone,vconsole.conf}
380
381 # Install SysV conversion tool for systemd
382 install -p %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}
383
384 install -d $RPM_BUILD_ROOT/var/log
385 :> $RPM_BUILD_ROOT/var/log/btmp
386 :> $RPM_BUILD_ROOT/var/log/wtmp
387
388 %if %{without gtk}
389 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/systemadm.1*
390 %endif
391
392 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
393 %{__rm} $RPM_BUILD_ROOT/%{_lib}/security/pam_systemd.la
394 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
395
396 %clean
397 rm -rf $RPM_BUILD_ROOT
398
399 %post
400 /bin/systemd-machine-id-setup > /dev/null 2>&1 || :
401 /bin/systemctl daemon-reexec > /dev/null 2>&1 || :
402
403 %postun
404 if [ $1 -ge 1 ]; then
405         /bin/systemctl try-restart systemd-logind.service >/dev/null 2>&1 || :
406 fi
407
408 %post   libs -p /sbin/ldconfig
409 %postun libs -p /sbin/ldconfig
410
411 %post units
412 if [ $1 -eq 1 ]; then
413         # Try to read default runlevel from the old inittab if it exists
414         runlevel=$(/bin/awk -F ':' '$3 == "initdefault" && $1 !~ "^#" { print $2 }' /etc/inittab 2> /dev/null)
415         if [ -z "$runlevel" ] ; then
416                 target="%{systemdunitdir}/graphical.target"
417         else
418                 target="%{systemdunitdir}/runlevel$runlevel.target"
419         fi
420
421         # And symlink what we found to the new-style default.target
422         ln -s "$target" %{_sysconfdir}/systemd/system/default.target >/dev/null 2>&1 || :
423
424         # Setup hostname
425         [ -f /etc/sysconfig/network ] && . /etc/sysconfig/network
426         if [ -n "$HOSTNAME" -a "$HOSTNAME" != "pldmachine" ]; then
427                 [ -f /etc/hostname ] && mv -f /etc/hostname /etc/hostname.rpmsave
428                 echo $HOSTNAME > /etc/hostname
429                 chmod 644 /etc/hostname
430         fi
431 fi
432 # Enable the services we install by default.
433 /bin/systemctl enable \
434         getty@.service \
435         network.service \
436         network-post.service \
437         remote-fs.target \
438         systemd-readahead-replay.service \
439         systemd-readahead-collect.service >/dev/null 2>&1 || :
440
441 # Find and enable all installed interfaces
442 mkdir -p %{_sysconfdir}/systemd/system/network.target.wants >/dev/null 2>&1 || :
443 for f in /etc/sysconfig/interfaces/ifcfg-* ; do
444         ff=$(basename $f)
445         ff=${ff##ifcfg-}
446         case "$ff" in
447         *.rpmorig|*.rpmnew|*.rpmsave|*~|*.orig)
448                 continue
449                 ;;
450         *)
451                 DEVICE="" ; ONBOOT="" ; USERS=""
452                 . $f 2>/dev/null
453                 [ ${USERS:-no} != no ] && continue
454                 if [ "$DEVICE" = "$ff" -a ${ONBOOT:-no} = "yes" ]; then
455                         ln -s %{systemdunitdir}/ifup@.service \
456                                 %{_sysconfdir}/systemd/system/network.target.wants/ifcfg@$ff.service >/dev/null 2>&1 || :
457                 fi
458                 ;;
459         esac
460 done
461
462 %preun units
463 if [ $1 -eq 0 ] ; then
464         /bin/systemctl disable \
465                 getty@.service \
466                 network.service \
467                 network-post.service \
468                 remote-fs.target \
469                 systemd-readahead-replay.service \
470                 systemd-readahead-collect.service >/dev/null 2>&1 || :
471
472         %{__rm} -f %{_sysconfdir}/systemd/system/default.target >/dev/null 2>&1 || :
473         %{__rm} -f %{_sysconfdir}/systemd/system/network.target.wants/ifcfg@*.service >/dev/null 2>&1 || :
474 fi
475
476 %postun units
477 if [ $1 -ge 1 ]; then
478         /bin/systemctl daemon-reload > /dev/null 2>&1 || :
479 fi
480
481 %post no-compat-tmpfiles
482 %{__sed} -i -e '/^#/!s/^/# /g' %{_sysconfdir}/tmpfiles.d/compat-pld-var-run.conf
483
484 %files
485 %defattr(644,root,root,755)
486 %doc DISTRO_PORTING README TODO
487 /etc/dbus-1/system.d/org.freedesktop.hostname1.conf
488 /etc/dbus-1/system.d/org.freedesktop.locale1.conf
489 /etc/dbus-1/system.d/org.freedesktop.login1.conf
490 /etc/dbus-1/system.d/org.freedesktop.systemd1.conf
491 /etc/dbus-1/system.d/org.freedesktop.timedate1.conf
492 %ghost %config(noreplace) %{_sysconfdir}/machine-id
493 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hostname
494 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/locale.conf
495 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/machine-info
496 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/os-release
497 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/timezone
498 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/vconsole.conf
499 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/systemd/*.conf
500 %dir %{_sysconfdir}/systemd/user
501 /etc/xdg/systemd
502 %attr(755,root,root) /bin/systemd
503 %attr(755,root,root) /bin/systemd-ask-password
504 %attr(755,root,root) /bin/systemd-journalctl
505 %attr(755,root,root) /bin/systemd-loginctl
506 %attr(755,root,root) /bin/systemd-machine-id-setup
507 %attr(755,root,root) /bin/systemd-notify
508 %attr(755,root,root) /bin/systemd-tty-ask-password-agent
509 %attr(755,root,root) %{_bindir}/systemd-analyze
510 %attr(755,root,root) %{_bindir}/systemd-cat
511 %attr(755,root,root) %{_bindir}/systemd-cgtop
512 %attr(755,root,root) %{_bindir}/systemd-cgls
513 %attr(755,root,root) %{_bindir}/systemd-nspawn
514 %attr(755,root,root) %{_bindir}/systemd-stdio-bridge
515 %attr(755,root,root) %{_bindir}/systemd-sysv-convert
516 %attr(755,root,root) /lib/systemd/systemd-*
517 %dir /lib/systemd/system-generators
518 %attr(755,root,root) /lib/systemd/systemd
519 %attr(755,root,root) /lib/systemd/system-generators/systemd-*-generator
520 %dir /lib/systemd/system-shutdown
521 /lib/udev/rules.d/99-systemd.rules
522 /lib/udev/rules.d/70-uaccess.rules
523 /lib/udev/rules.d/71-seat.rules
524 /lib/udev/rules.d/73-seat-late.rules
525 %dir %{_libexecdir}/systemd
526 %{_libexecdir}/systemd/user
527 %dir %{_libexecdir}/systemd/user-generators
528 %config(noreplace,missingok) %{_libexecdir}/tmpfiles.d/*.conf
529 %{_datadir}/dbus-1/interfaces/org.freedesktop.hostname1.xml
530 %{_datadir}/dbus-1/interfaces/org.freedesktop.locale1.xml
531 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.*.xml
532 %{_datadir}/dbus-1/interfaces/org.freedesktop.timedate1.xml
533 %{_datadir}/dbus-1/services/org.freedesktop.systemd1.service
534 %{_datadir}/dbus-1/system-services/org.freedesktop.hostname1.service
535 %{_datadir}/dbus-1/system-services/org.freedesktop.locale1.service
536 %{_datadir}/dbus-1/system-services/org.freedesktop.login1.service
537 %{_datadir}/dbus-1/system-services/org.freedesktop.systemd1.service
538 %{_datadir}/dbus-1/system-services/org.freedesktop.timedate1.service
539 %{_datadir}/polkit-1/actions/org.freedesktop.hostname1.policy
540 %{_datadir}/polkit-1/actions/org.freedesktop.locale1.policy
541 %{_datadir}/polkit-1/actions/org.freedesktop.login1.policy
542 %{_datadir}/polkit-1/actions/org.freedesktop.systemd1.policy
543 %{_datadir}/polkit-1/actions/org.freedesktop.timedate1.policy
544 %dir %{_datadir}/systemd
545 %{_datadir}/systemd/kbd-model-map
546 %{_mandir}/man1/systemd.1*
547 %{_mandir}/man1/systemd-*.1*
548 %{_mandir}/man3/sd_booted.3*
549 %{_mandir}/man3/sd_is_fifo.3*
550 %{_mandir}/man3/sd_is_socket.3
551 %{_mandir}/man3/sd_is_socket_inet.3
552 %{_mandir}/man3/sd_is_socket_unix.3
553 %{_mandir}/man3/sd_listen_fds.3*
554 %{_mandir}/man3/sd_notify.3*
555 %{_mandir}/man3/sd_notifyf.3
556 %{_mandir}/man3/sd_readahead.3*
557 %{_mandir}/man5/binfmt.d.5*
558 %{_mandir}/man5/hostname.5*
559 %{_mandir}/man5/locale.conf.5*
560 %{_mandir}/man5/machine-id.5*
561 %{_mandir}/man5/machine-info.5*
562 %{_mandir}/man5/modules-load.d.5*
563 %{_mandir}/man5/os-release.5*
564 %{_mandir}/man5/sysctl.d.5*
565 %{_mandir}/man5/systemd.*.5*
566 %{_mandir}/man5/systemd-logind.conf.5*
567 %{_mandir}/man5/timezone.5*
568 %{_mandir}/man5/vconsole.conf.5*
569 %{_mandir}/man7/daemon.7*
570 %{_mandir}/man7/sd-daemon.7*
571 %{_mandir}/man7/sd-login.7*
572 %{_mandir}/man7/sd-readahead.7*
573 %{_mandir}/man7/systemd.special.7*
574 %attr(640,root,root) %ghost /var/log/btmp
575 %attr(664,root,utmp) %ghost /var/log/wtmp
576
577 %if %{with pam}
578 %attr(755,root,root) /%{_lib}/security/pam_systemd.so
579 %{_mandir}/man8/pam_systemd.8*
580 %endif
581
582 %files init
583 %defattr(644,root,root,755)
584 %attr(755,root,root) /sbin/halt
585 %attr(755,root,root) /sbin/init
586 %attr(755,root,root) /sbin/poweroff
587 %attr(755,root,root) /sbin/reboot
588 %attr(755,root,root) /sbin/runlevel
589 %attr(755,root,root) /sbin/shutdown
590 %attr(755,root,root) /sbin/telinit
591 %{_mandir}/man1/init.1
592 %{_mandir}/man8/halt.8*
593 %{_mandir}/man8/poweroff.8
594 %{_mandir}/man8/reboot.8
595 %{_mandir}/man8/runlevel.8*
596 %{_mandir}/man8/shutdown.8*
597 %{_mandir}/man8/telinit.8*
598
599 %files units
600 %defattr(644,root,root,755)
601 %dir %{_sysconfdir}/binfmt.d
602 %dir %{_sysconfdir}/modules-load.d
603 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/modules-load.d/modules.conf
604 %dir %{_sysconfdir}/sysctl.d
605 %dir %{_sysconfdir}/systemd
606 %dir %{_sysconfdir}/systemd/system
607 %dir %{_sysconfdir}/tmpfiles.d
608 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/tmpfiles.d/*.conf
609 %dir %{_libexecdir}/binfmt.d
610 %dir %{_libexecdir}/modules-load.d
611 %dir %{_libexecdir}/sysctl.d
612 %{_libexecdir}/sysctl.d/coredump.conf
613 %attr(755,root,root) /bin/systemctl
614 %attr(755,root,root) /bin/systemd-tmpfiles
615 %attr(755,root,root) /bin/systemd_booted
616 %{_mandir}/man1/systemctl.1*
617 %{_mandir}/man5/tmpfiles.d.5*
618 %{_mandir}/man8/systemd-tmpfiles.8*
619 %{_npkgconfigdir}/systemd.pc
620
621 %{systemdunitdir}/*.automount
622 %{systemdunitdir}/*.mount
623 %{systemdunitdir}/*.path
624 %{systemdunitdir}/*.service
625 %{systemdunitdir}/*.socket
626 %{systemdunitdir}/*.target
627 %{systemdunitdir}/*.timer
628 %dir %{systemdunitdir}/*.wants
629 %config(noreplace,missingok) %{systemdunitdir}/*.wants/*
630
631 %if %{with gtk}
632 %files gtk
633 %defattr(644,root,root,755)
634 %attr(755,root,root) %{_bindir}/systemadm
635 %attr(755,root,root) %{_bindir}/systemd-gnome-ask-password-agent
636 %{_mandir}/man1/systemadm.1*
637 %endif
638
639 %files libs
640 %defattr(644,root,root,755)
641 %attr(755,root,root) /%{_lib}/libsystemd-daemon.so.*.*.*
642 %attr(755,root,root) %ghost /%{_lib}/libsystemd-daemon.so.0
643 %attr(755,root,root) /%{_lib}/libsystemd-id128.so.*.*.*
644 %attr(755,root,root) %ghost /%{_lib}/libsystemd-id128.so.0
645 %attr(755,root,root) /%{_lib}/libsystemd-journal.so.*.*.*
646 %attr(755,root,root) %ghost /%{_lib}/libsystemd-journal.so.0
647 %attr(755,root,root) /%{_lib}/libsystemd-login.so.*.*.*
648 %attr(755,root,root) %ghost /%{_lib}/libsystemd-login.so.0
649
650 %files devel
651 %defattr(644,root,root,755)
652 %attr(755,root,root) %{_libdir}/libsystemd-daemon.so
653 %attr(755,root,root) %{_libdir}/libsystemd-id128.so
654 %attr(755,root,root) %{_libdir}/libsystemd-journal.so
655 %attr(755,root,root) %{_libdir}/libsystemd-login.so
656 %{_includedir}/%{name}
657 %{_pkgconfigdir}/libsystemd-daemon.pc
658 %{_pkgconfigdir}/libsystemd-id128.pc
659 %{_pkgconfigdir}/libsystemd-journal.pc
660 %{_pkgconfigdir}/libsystemd-login.pc
661 %{_mandir}/man3/sd_get_seats.3*
662 %{_mandir}/man3/sd_get_sessions.3*
663 %{_mandir}/man3/sd_get_uids.3*
664 %{_mandir}/man3/sd_is_mq.3*
665 %{_mandir}/man3/sd_login_monitor_flush.3*
666 %{_mandir}/man3/sd_login_monitor_get_fd.3*
667 %{_mandir}/man3/sd_login_monitor_new.3*
668 %{_mandir}/man3/sd_login_monitor_unref.3*
669 %{_mandir}/man3/sd_pid_get_owner_uid.3*
670 %{_mandir}/man3/sd_pid_get_session.3*
671 %{_mandir}/man3/sd_pid_get_unit.3*
672 %{_mandir}/man3/sd_seat_can_multi_session.3*
673 %{_mandir}/man3/sd_seat_get_active.3*
674 %{_mandir}/man3/sd_seat_get_sessions.3*
675 %{_mandir}/man3/sd_session_get_seat.3*
676 %{_mandir}/man3/sd_session_get_uid.3*
677 %{_mandir}/man3/sd_session_is_active.3*
678 %{_mandir}/man3/sd_uid_get_seats.3*
679 %{_mandir}/man3/sd_uid_get_sessions.3*
680 %{_mandir}/man3/sd_uid_get_state.3*
681 %{_mandir}/man3/sd_uid_is_on_seat.3*
682
683 %files -n bash-completion-systemd
684 %defattr(644,root,root,755)
685 /etc/bash_completion.d/systemd-bash-completion.sh
686
687 %files no-compat-tmpfiles
688 %defattr(644,root,root,755)
689 # empty package
This page took 0.074882 seconds and 4 git commands to generate.