]> git.pld-linux.org Git - packages/systemd.git/blob - systemd.spec
- enable plymouth bcond, it's just files, as qboosh said
[packages/systemd.git] / systemd.spec
1 #
2 # TODO:
3 #       - remove compat-pld-var-run.tmpfiles and maybe tmpfiles-not-fatal.patch
4 #         after enough packages provide their own tmpfiles.d configs for
5 #         /var/run directories
6 #
7 # Conditional build:
8 %bcond_without  audit           # without audit support
9 %bcond_without  cryptsetup      # without cryptsetup support
10 %bcond_without  gtk             # build gtk tools
11 %bcond_without  pam             # PAM authentication support
12 %bcond_without  plymouth        # do not install plymouth units
13 %bcond_without  selinux         # without SELinux support
14 %bcond_without  tcpd            # libwrap (tcp_wrappers) support
15
16 Summary:        A System and Service Manager
17 Summary(pl.UTF-8):      systemd - zarządca systemu i usług dla Linuksa
18 Name:           systemd
19 Version:        44
20 Release:        3.4
21 License:        GPL v2+
22 Group:          Base
23 Source0:        http://www.freedesktop.org/software/systemd/%{name}-%{version}.tar.xz
24 # Source0-md5:  11f44ff74c87850064e4351518bcff17
25 Source1:        %{name}-sysv-convert
26 Source2:        %{name}_booted.c
27 Source3:        network.service
28 Source4:        compat-pld-media.tmpfiles
29 Source5:        compat-pld-var-run.tmpfiles
30 Source10:       pld-storage-init-late.service
31 Source11:       pld-storage-init.service
32 Source12:       pld-wait-storage.service
33 Source13:       pld-storage-init.sh
34 Patch0:         target-pld.patch
35 Patch1:         config-pld.patch
36 Patch2:         shut-sysv-up.patch
37 Patch3:         pld-sysv-network.patch
38 Patch4:         tmpfiles-not-fatal.patch
39 Patch5:         CVE-2012-1174.patch
40 Patch6:         rc.local.patch
41 URL:            http://www.freedesktop.org/wiki/Software/systemd
42 BuildRequires:  acl-devel
43 %{?with_audit:BuildRequires:    audit-libs-devel}
44 BuildRequires:  autoconf >= 2.63
45 BuildRequires:  automake >= 1:1.11
46 BuildRequires:  binutils >= 3:2.22.52.0.1-2
47 %{?with_cryptsetup:BuildRequires:       cryptsetup-luks-devel}
48 BuildRequires:  dbus-devel >= 1.3.2
49 BuildRequires:  docbook-style-xsl
50 BuildRequires:  gperf
51 BuildRequires:  intltool >= 0.40.0
52 BuildRequires:  kmod-devel >= 5
53 BuildRequires:  libcap-devel
54 %{?with_selinux:BuildRequires:  libselinux-devel >= 2.1.0}
55 BuildRequires:  libtool >= 2:2.2
56 %{?with_tcpd:BuildRequires:     libwrap-devel}
57 BuildRequires:  libxslt-progs
58 BuildRequires:  m4
59 %{?with_pam:BuildRequires:      pam-devel}
60 BuildRequires:  pkgconfig >= 0.9.0
61 BuildRequires:  rpmbuild(macros) >= 1.627
62 BuildRequires:  udev-devel >= 1:172
63 # not required for building from release (which contains *.c for *.vala)
64 #BuildRequires: vala >= 0.10.0
65 BuildRequires:  xz-devel
66 %if %{with gtk}
67 BuildRequires:  glib2-devel >= 1:2.26.1
68 BuildRequires:  gtk+2-devel >= 2:2.24.0
69 BuildRequires:  libgee-devel
70 BuildRequires:  libnotify-devel >= 0.7.0
71 %endif
72 Requires:       %{name}-libs = %{version}-%{release}
73 Requires:       %{name}-units = %{version}-%{release}
74 Requires:       /etc/os-release
75 Requires:       SysVinit-tools
76 Requires:       agetty
77 Requires:       dbus >= 1.4.16-6
78 Requires:       filesystem >= 4.0-2
79 Requires:       libutempter
80 Requires:       rc-scripts >= 0.4.5.3-6
81 Requires:       setup >= 2.8.0-2
82 Requires:       udev-core >= 1:175-5
83 Requires:       udev-libs >= 1:172
84 Requires:       virtual(module-tools)
85 Suggests:       %{name}-no-compat-tmpfiles
86 Suggests:       ConsoleKit
87 Suggests:       fsck >= 2.20
88 Suggests:       kmod >= 5
89 Suggests:       nss_myhostname
90 Suggests:       service(klogd)
91 Suggests:       service(syslog)
92 Provides:       udev-acl
93 # systemd takes care of that and causes problems
94 Conflicts:      binfmt-detector
95 # sytemd wants pam with pam_systemd.so in system-auth...
96 Conflicts:      pam < 1:1.1.5-5
97 # ...and sudo hates it
98 Conflicts:      sudo < 1:1.7.8p2-4
99 # for prefdm script
100 Conflicts:      xinitrc-ng < 1.0
101 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
102
103 %define         _libexecdir     %{_prefix}/lib
104
105 %description
106 systemd is a system and service manager for Linux, compatible with
107 SysV and LSB init scripts. systemd provides aggressive parallelization
108 capabilities, uses socket and D-Bus activation for starting services,
109 offers on-demand starting of daemons, keeps track of processes using
110 Linux cgroups, supports snapshotting and restoring of the system
111 state, maintains mount and automount points and implements an
112 elaborate transactional dependency-based service control logic. It can
113 work as a drop-in replacement for sysvinit.
114
115 %description -l pl.UTF-8
116 systemd jest zarządcą systemu i usług dla Linuksa, kompatybilny ze
117 skryptami SysV i LSB. systemd udostępnia rozbudowane zdolności
118 paralelizacji, do uruchamiania usług używa socketów oraz D-Busa,
119 oferuje uruchamianie usług na życzenie, monitoruje procesy używając
120 linuksowych cgroups, wspomaga zapisywanie (snapshot) i odczytywanie
121 (restore) stanu systemu, zarządza (auto)mount pointami oraz
122 implementuje starannie opracowaną transakcjonalną, bazującą na
123 zależnościach logikę kontroli usług. Może pracować jako zastępca dla
124 sysvinit.
125
126 %package init
127 Summary:        systemd /sbin/init and LSB/SysV compatibility symlinks
128 Summary(pl.UTF-8):      /sbin/init z systemd i dowiązania dla kompatybilności z LSB/SysV
129 Group:          Base
130 Requires:       systemd
131 Provides:       readahead = 1:1.5.7-3
132 Provides:       virtual(init-daemon)
133 Obsoletes:      SysVinit
134 Obsoletes:      readahead < 1:1.5.7-3
135 Obsoletes:      virtual(init-daemon)
136 Conflicts:      upstart
137
138 %description init
139 Install this package when you are ready to final switch to systemd.
140
141 %description init -l pl.UTF-8
142 Ten pakiet należy zainstalować po przygotowaniu się do ostatecznego
143 przejścia na systemd.
144
145 %package units
146 Summary:        Configuration files, directories and installation tool for systemd
147 Summary(pl.UTF-8):      Pliki konfiguracyjne, katalogi i narzędzie instalacyjne dla systemd
148 Group:          Base
149 Requires(post): coreutils
150 Requires(post): /bin/awk
151
152 %description units
153 Basic configuration files, directories and installation tool for the
154 systemd system and service manager.
155
156 This is common config, use %{_sysconfdir}/systemd/system to override.
157
158 %description units -l pl.UTF-8
159 Podstawowe pliki konfiguracyjne, katalogi i narzędzie instalacyjne dla
160 zarządcy systemu i usług systemd.
161
162 Ten pakiet zawiera ogólną konfigurację, ustawienia można nadpisać
163 poprzez katalog %{_sysconfdir}/systemd/system.
164
165 %package plymouth
166 Summary:        Plymouth support units for systemd
167 Summary(pl.UTF-8):      Jednostki wspierające Plymouth dla systemd
168 Group:          Base
169 Requires:       %{name}-units = %{version}-%{release}
170 Requires:       plymouth
171
172 %description plymouth
173 Plymouth (graphical boot) support units for systemd.
174
175 %description plymouth -l pl.UTF-8
176 Jednostki wspierające Plymouth (graficzny start systemu) dla systemd.
177
178 %package gtk
179 Summary:        Graphical frontend for systemd
180 Summary(pl.UTF-8):      Graficzny interfejs do systemd
181 Group:          Base
182 Requires:       %{name} = %{version}-%{release}
183 Requires:       polkit
184
185 %description gtk
186 Graphical front-end for systemd.
187
188 %description gtk -l pl.UTF-8
189 Graficzny interfejs do systemd.
190
191 %package analyze
192 Summary:        Tool for processing systemd profiling information
193 Group:          Base
194 Requires:       %{name} = %{version}-%{release}
195 Requires:       python-dbus
196 Requires:       python-modules
197 Requires:       python-pycairo
198 Conflicts:      %{name} < 44-3
199
200 %description analyze
201 'systemd-analyze blame' lists which systemd unit needed how much time
202 to finish initialization at boot. 'systemd-analyze plot' renders an
203 SVG visualizing the parallel start of units at boot.
204
205 %package libs
206 Summary:        Shared systemd libraries
207 Summary(pl.UTF-8):      Biblioteki współdzielone systemd
208 Group:          Libraries
209
210 %description libs
211 Shared systemd libraries.
212
213 %description libs -l pl.UTF-8
214 Biblioteki współdzielone systemd.
215
216 %package devel
217 Summary:        Header files for systemd libraries
218 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek systemd
219 Group:          Development/Libraries
220 Requires:       %{name}-libs = %{version}-%{release}
221
222 %description devel
223 Header files for systemd libraries.
224
225 %description devel -l pl.UTF-8
226 Pliki nagłówkowe bibliotek systemd.
227
228 %package -n bash-completion-systemd
229 Summary:        bash-completion for systemd
230 Summary(pl.UTF-8):      Bashowe dopełnianie składni dla systemd
231 Group:          Applications/Shells
232 Requires:       %{name}
233 Requires:       bash-completion
234
235 %description -n bash-completion-systemd
236 bash-completion for systemd.
237
238 %description -n bash-completion-systemd -l pl.UTF-8
239 Bashowe dopełnianie składni dla systemd
240
241 %package no-compat-tmpfiles
242 Summary:        Force update of packages that provide tmpfiles.d configuration
243 Group:          Base
244 Requires(post): sed > 4.0
245 Conflicts:      ConsoleKit-dirs < 0.4.5-7
246 Conflicts:      NetworkManager < 2:0.9.2.0-3
247 Conflicts:      Zope < 2.11.8-2
248 Conflicts:      amavisd-new < 1:2.7.0-1
249 Conflicts:      apache-base < 2.2.21-4
250 Conflicts:      apache-mod_bw < 0.92-3
251 Conflicts:      apache-mod_fastcgi < 2.4.6-6
252 Conflicts:      apache1-base < 1.3.42-5
253 Conflicts:      apache1-mod_fastcgi < 2.4.6-2
254 Conflicts:      asterisk < 10.0.1-2
255 Conflicts:      autossh-init < 1.4b-3
256 Conflicts:      balance < 3.54-2
257 Conflicts:      bind < 7:9.8.1.P1-4
258 Conflicts:      bopm < 3.1.3-4
259 Conflicts:      callweaver < 1.2.1-9
260 Conflicts:      cassandra-bin < 0.8.9-2
261 Conflicts:      clamav < 0.97.3-3
262 Conflicts:      cups < 1:1.5.0-10
263 Conflicts:      dbus < 1.4.16-4
264 Conflicts:      dovecot < 1:2.0.16-3
265 Conflicts:      dspam < 3.9.0-6
266 Conflicts:      fail2ban < 0.8.4-4
267 Conflicts:      filesystem < 4.0-3
268 Conflicts:      gammu-smsd < 1:1.31.0-3
269 # Break gdm2.20 installs
270 #Conflicts:     gdm < 2:3.2.1.1-9
271 Conflicts:      greylistd < 0.8.8-2
272 Conflicts:      inn < 2.4.6-7
273 Conflicts:      ipsec-tools < 0.8.0-3
274 Conflicts:      jabber-common < 0-9
275 Conflicts:      laptop-mode-tools < 1.58-2
276 Conflicts:      libgpod < 0.8.0-6
277 Conflicts:      libvirt-utils < 0.9.9-4
278 Conflicts:      lighttpd < 1.4.30-5
279 Conflicts:      lirc < 0.9.0-20
280 Conflicts:      mailman < 5:2.1.14-4
281 Conflicts:      memcached < 1.4.11-2
282 Conflicts:      mpd < 0.16.5-4
283 Conflicts:      mrtg < 2.17.0-3
284 Conflicts:      munin-common < 1.4.5-5
285 Conflicts:      nagios-nrpe < 2.13-2
286 Conflicts:      ndisc6-rdnssd < 1.0.1-3
287 Conflicts:      nscd < 6:2.14.1-5
288 Conflicts:      nss_ldapd-nslcd < 0.8.4-2
289 Conflicts:      openct < 0.6.20-3
290 Conflicts:      openl2tp < 1.8-3
291 Conflicts:      openldap-overlay-nssov < 2.4.28-4
292 Conflicts:      openldap-servers < 2.4.28-4
293 Conflicts:      openvpn < 2.2.2-2
294 Conflicts:      pam-pam_mount < 2.12-3
295 Conflicts:      pam-pam_ssh < 1.97-2
296 Conflicts:      pcsc-lite < 1.8.1-2
297 Conflicts:      php-dirs < 1.2-3
298 Conflicts:      policyd < 2.0.10-3
299 Conflicts:      pound < 2.6-2
300 Conflicts:      pptp < 1.7.2-3
301 Conflicts:      proftpd-common < 2:1.3.4a-2
302 Conflicts:      pulseaudio-server < 1.1-2
303 Conflicts:      quagga < 0.99.20-3
304 Conflicts:      radvd < 1.8.5-2
305 Conflicts:      rc-scripts < 0.4.5.2-3
306 Conflicts:      red5 < 0.9.0-2
307 Conflicts:      redis-server < 2.4.2-4
308 Conflicts:      smokeping < 2.4.2-10
309 Conflicts:      smtp-gated < 1.4.17-2
310 Conflicts:      socat < 1.7.2.0-2
311 Conflicts:      speech-dispatcher < 0.7.1-2
312 Conflicts:      sphinx < 2.0.3-4
313 Conflicts:      splashutils < 1.5.4.3-3
314 Conflicts:      stunnel < 4.50-2
315 Conflicts:      tenshi < 0.12-2
316 Conflicts:      tor < 0.2.2.35-2
317 Conflicts:      ucarp < 1.5.2-3
318 Conflicts:      udisks < 1.0.4-3
319 Conflicts:      util-vserver < 0.30.216-1.pre3002.3
320 Conflicts:      vpnc < 0.5.3-2
321 Conflicts:      web2ldap < 1.1.0rc1-2
322 Conflicts:      wesnoth-server < 1:1.10-2
323 Conflicts:      wpa_supplicant < 0.7.3-10
324 Conflicts:      xl2tpd < 1.3.0-2
325
326 %description no-compat-tmpfiles
327 Force update of packages that provide tmpfiles.d configuration
328
329 %prep
330 %setup -q
331 %patch0 -p1
332 %patch1 -p1
333 %patch2 -p1
334 %patch3 -p1
335 %patch4 -p1
336 %patch5 -p1
337 %patch6 -p1
338 cp -p %{SOURCE2} src/systemd_booted.c
339
340 %build
341 %{__aclocal} -I m4
342 %{__autoconf}
343 %{__autoheader}
344 %{__automake}
345 %configure \
346         %{__enable_disable audit} \
347         %{__enable_disable cryptsetup libcryptsetup} \
348         %{__enable_disable gtk} \
349         %{__enable_disable pam} \
350         %{__enable_disable plymouth} \
351         %{__enable_disable selinux} \
352         %{__enable_disable tcpd tcpwrap} \
353         --disable-silent-rules \
354         --disable-static \
355         --with-distro=pld \
356         --with-rootprefix= \
357         --with-rootlibdir=/%{_lib} \
358         --enable-split-usr
359
360 %{__make}
361 ./libtool --mode=link --tag=CC %{__cc} %{rpmcppflags} %{rpmcflags} -o systemd_booted %{rpmldflags} src/systemd_booted.c -L. -lsystemd-daemon
362
363 %install
364 rm -rf $RPM_BUILD_ROOT
365 install -d $RPM_BUILD_ROOT/var/lib/%{name}/coredump
366
367 %{__make} install \
368         DESTDIR=$RPM_BUILD_ROOT
369
370 ./libtool --mode=install install -p -m755 systemd_booted $RPM_BUILD_ROOT/bin/systemd_booted
371
372 # Main binary has been moved, but we don't want to break existing installs
373 ln -s ../lib/systemd/systemd $RPM_BUILD_ROOT/bin/systemd
374
375 # Create SysV compatibility symlinks. systemctl/systemd are smart
376 # enough to detect the way they were called
377 install -d $RPM_BUILD_ROOT/sbin
378 ln -s ../lib/systemd/systemd $RPM_BUILD_ROOT/sbin/init
379 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/halt
380 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/poweroff
381 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/reboot
382 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/runlevel
383 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/shutdown
384 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/telinit
385
386 ln -s ../modules $RPM_BUILD_ROOT%{_sysconfdir}/modules-load.d/modules.conf
387
388 # disable redundant SYSV services
389 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/allowlogin.service
390 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/console.service
391 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/cpusets.service
392 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/killall.service
393 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/netfs.service
394 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/random.service
395
396 # add static (non-NetworkManager) networking
397 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{systemdunitdir}/network.service
398
399 # install compatibility tmpfiles configs
400 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/compat-pld-media.conf
401 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/compat-pld-var-run.conf
402
403 # Install and enable storage subsystems support services (RAID, LVM, etc.)
404 cp -p %{SOURCE10} $RPM_BUILD_ROOT%{systemdunitdir}/pld-storage-init-late.service
405 cp -p %{SOURCE11} $RPM_BUILD_ROOT%{systemdunitdir}/pld-storage-init.service
406 cp -p %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/pld-wait-storage.service
407 install -p %{SOURCE13} $RPM_BUILD_ROOT/lib/systemd/pld-storage-init
408
409 ln -s ../pld-storage-init-late.service $RPM_BUILD_ROOT%{systemdunitdir}/local-fs.target.wants/pld-storage-init-late.service
410 ln -s ../pld-storage-init.service $RPM_BUILD_ROOT%{systemdunitdir}/local-fs.target.wants/pld-storage-init.service
411
412 # handled by rc-local sysv service, no need for generator
413 %{__rm} $RPM_BUILD_ROOT/lib/systemd/system-generators/systemd-rc-local-generator
414 %{__rm} $RPM_BUILD_ROOT%{systemdunitdir}/multi-user.target.wants/rc-local.service
415
416 # Make sure these directories are properly owned:
417 #       - halt,kexec,poweroff,reboot: generic ones used by ConsoleKit-systemd,
418 #       - syslog _might_ be used by some syslog implementation (none for now),
419 #       - isn't dbus populated by dbus-systemd only (so to be moved there)?
420 install -d $RPM_BUILD_ROOT%{systemdunitdir}/{dbus,halt,kexec,poweroff,reboot,syslog}.target.wants
421
422 # Create new-style configuration files so that we can ghost-own them
423 touch $RPM_BUILD_ROOT%{_sysconfdir}/{hostname,locale.conf,machine-id,machine-info,timezone,vconsole.conf}
424
425 # Install SysV conversion tool for systemd
426 install -p %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}
427
428 install -d $RPM_BUILD_ROOT/var/log
429 :> $RPM_BUILD_ROOT/var/log/btmp
430 :> $RPM_BUILD_ROOT/var/log/wtmp
431
432 %if %{without gtk}
433 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/systemadm.1*
434 %endif
435
436 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
437 %{__rm} $RPM_BUILD_ROOT/%{_lib}/security/pam_systemd.la
438 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
439
440 %clean
441 rm -rf $RPM_BUILD_ROOT
442
443 %post
444 /bin/systemd-machine-id-setup > /dev/null 2>&1 || :
445 /bin/systemctl daemon-reexec > /dev/null 2>&1 || :
446
447 %postun
448 if [ $1 -ge 1 ]; then
449         /bin/systemctl try-restart systemd-logind.service >/dev/null 2>&1 || :
450 fi
451
452 %post   libs -p /sbin/ldconfig
453 %postun libs -p /sbin/ldconfig
454
455 %post units
456 if [ $1 -eq 1 ]; then
457         # Try to read default runlevel from the old inittab if it exists
458         runlevel=$(/bin/awk -F ':' '$3 == "initdefault" && $1 !~ "^#" { print $2 }' /etc/inittab 2> /dev/null)
459         if [ -z "$runlevel" ] ; then
460                 target="%{systemdunitdir}/graphical.target"
461         else
462                 target="%{systemdunitdir}/runlevel$runlevel.target"
463         fi
464
465         # And symlink what we found to the new-style default.target
466         ln -s "$target" %{_sysconfdir}/systemd/system/default.target >/dev/null 2>&1 || :
467
468         # Setup hostname
469         [ -f /etc/sysconfig/network ] && . /etc/sysconfig/network
470         if [ -n "$HOSTNAME" -a "$HOSTNAME" != "pldmachine" ]; then
471                 [ -f /etc/hostname ] && mv -f /etc/hostname /etc/hostname.rpmsave
472                 echo $HOSTNAME > /etc/hostname
473                 chmod 644 /etc/hostname
474         fi
475
476         # Enable the services we install by default.
477         /bin/systemctl enable \
478                 getty@.service \
479                 network.service \
480                 remote-fs.target \
481                 systemd-readahead-replay.service \
482                 systemd-readahead-collect.service >/dev/null 2>&1 || :
483 fi
484
485 %preun units
486 if [ $1 -eq 0 ] ; then
487         /bin/systemctl disable \
488                 getty@.service \
489                 network.service \
490                 remote-fs.target \
491                 systemd-readahead-replay.service \
492                 systemd-readahead-collect.service >/dev/null 2>&1 || :
493
494         %{__rm} -f %{_sysconfdir}/systemd/system/default.target >/dev/null 2>&1 || :
495 fi
496
497 %postun units
498 if [ $1 -ge 1 ]; then
499         /bin/systemctl daemon-reload > /dev/null 2>&1 || :
500 fi
501
502 %triggerpostun units -- %{name}-units < 43-7
503 # Remove design fialures
504 rm -f %{_sysconfdir}/systemd/system/network.target.wants/ifcfg@*.service >/dev/null 2>&1 || :
505 rm -f %{_sysconfdir}/systemd/system/network.target.wants/network-post.service >/dev/null 2>&1 || :
506 rm -f %{_sysconfdir}/systemd/system/multi-user.target.wants/network-post.service >/dev/null 2>&1 || :
507 /bin/systemctl reenable network.service >/dev/null 2>&1 || :
508
509 %post no-compat-tmpfiles
510 %{__sed} -i -e '/^#/!s/^/# /g' %{_sysconfdir}/tmpfiles.d/compat-pld-var-run.conf
511
512 %files
513 %defattr(644,root,root,755)
514 %doc DISTRO_PORTING README TODO
515 /etc/dbus-1/system.d/org.freedesktop.hostname1.conf
516 /etc/dbus-1/system.d/org.freedesktop.locale1.conf
517 /etc/dbus-1/system.d/org.freedesktop.login1.conf
518 /etc/dbus-1/system.d/org.freedesktop.systemd1.conf
519 /etc/dbus-1/system.d/org.freedesktop.timedate1.conf
520 %ghost %config(noreplace) %{_sysconfdir}/machine-id
521 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hostname
522 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/locale.conf
523 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/machine-info
524 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/timezone
525 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/vconsole.conf
526 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/systemd/*.conf
527 %dir %{_sysconfdir}/systemd/user
528 %dir %{_sysconfdir}/systemd/system/*.target.wants
529 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/systemd/system/*.target.wants/*.service
530 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/systemd/system/*.target.wants/*.target
531 /etc/xdg/systemd
532 %attr(755,root,root) /bin/systemd
533 %attr(755,root,root) /bin/systemd-ask-password
534 %attr(755,root,root) /bin/systemd-journalctl
535 %attr(755,root,root) /bin/systemd-loginctl
536 %attr(755,root,root) /bin/systemd-machine-id-setup
537 %attr(755,root,root) /bin/systemd-notify
538 %attr(755,root,root) /bin/systemd-tty-ask-password-agent
539 %attr(755,root,root) %{_bindir}/systemd-cat
540 %attr(755,root,root) %{_bindir}/systemd-cgtop
541 %attr(755,root,root) %{_bindir}/systemd-cgls
542 %attr(755,root,root) %{_bindir}/systemd-nspawn
543 %attr(755,root,root) %{_bindir}/systemd-stdio-bridge
544 %attr(755,root,root) %{_bindir}/systemd-sysv-convert
545 %attr(755,root,root) /lib/systemd/pld-storage-init
546 %attr(755,root,root) /lib/systemd/systemd-*
547 %dir /lib/systemd/system-generators
548 %attr(755,root,root) /lib/systemd/systemd
549 %attr(755,root,root) /lib/systemd/system-generators/systemd-*-generator
550 %dir /lib/systemd/system-shutdown
551 /lib/udev/rules.d/99-systemd.rules
552 /lib/udev/rules.d/70-uaccess.rules
553 /lib/udev/rules.d/71-seat.rules
554 /lib/udev/rules.d/73-seat-late.rules
555 %dir %{_libexecdir}/systemd
556 %{_libexecdir}/systemd/user
557 %dir %{_libexecdir}/systemd/user-generators
558 %config(noreplace,missingok) %{_libexecdir}/tmpfiles.d/*.conf
559 %{_datadir}/dbus-1/interfaces/org.freedesktop.hostname1.xml
560 %{_datadir}/dbus-1/interfaces/org.freedesktop.locale1.xml
561 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.*.xml
562 %{_datadir}/dbus-1/interfaces/org.freedesktop.timedate1.xml
563 %{_datadir}/dbus-1/services/org.freedesktop.systemd1.service
564 %{_datadir}/dbus-1/system-services/org.freedesktop.hostname1.service
565 %{_datadir}/dbus-1/system-services/org.freedesktop.locale1.service
566 %{_datadir}/dbus-1/system-services/org.freedesktop.login1.service
567 %{_datadir}/dbus-1/system-services/org.freedesktop.systemd1.service
568 %{_datadir}/dbus-1/system-services/org.freedesktop.timedate1.service
569 %{_datadir}/polkit-1/actions/org.freedesktop.hostname1.policy
570 %{_datadir}/polkit-1/actions/org.freedesktop.locale1.policy
571 %{_datadir}/polkit-1/actions/org.freedesktop.login1.policy
572 %{_datadir}/polkit-1/actions/org.freedesktop.systemd1.policy
573 %{_datadir}/polkit-1/actions/org.freedesktop.timedate1.policy
574 %dir %{_datadir}/systemd
575 %{_datadir}/systemd/kbd-model-map
576 %{_mandir}/man1/systemd.1*
577 %{_mandir}/man1/systemd-*.1*
578 %{_mandir}/man5/binfmt.d.5*
579 %{_mandir}/man5/hostname.5*
580 %{_mandir}/man5/locale.conf.5*
581 %{_mandir}/man5/machine-id.5*
582 %{_mandir}/man5/machine-info.5*
583 %{_mandir}/man5/modules-load.d.5*
584 %{_mandir}/man5/os-release.5*
585 %{_mandir}/man5/sysctl.d.5*
586 %{_mandir}/man5/systemd.*.5*
587 %{_mandir}/man5/systemd-journald.conf.5*
588 %{_mandir}/man5/systemd-logind.conf.5*
589 %{_mandir}/man5/timezone.5*
590 %{_mandir}/man5/vconsole.conf.5*
591 %{_mandir}/man7/daemon.7*
592 %{_mandir}/man7/sd-daemon.7*
593 %{_mandir}/man7/sd-login.7*
594 %{_mandir}/man7/sd-readahead.7*
595 %{_mandir}/man7/systemd.special.7*
596 %dir /var/lib/%{name}
597 %dir /var/lib/%{name}/coredump
598 %attr(640,root,root) %ghost /var/log/btmp
599 %attr(664,root,utmp) %ghost /var/log/wtmp
600
601 %if %{with pam}
602 %attr(755,root,root) /%{_lib}/security/pam_systemd.so
603 %{_mandir}/man8/pam_systemd.8*
604 %endif
605
606 %files init
607 %defattr(644,root,root,755)
608 %attr(755,root,root) /sbin/halt
609 %attr(755,root,root) /sbin/init
610 %attr(755,root,root) /sbin/poweroff
611 %attr(755,root,root) /sbin/reboot
612 %attr(755,root,root) /sbin/runlevel
613 %attr(755,root,root) /sbin/shutdown
614 %attr(755,root,root) /sbin/telinit
615 %{_mandir}/man1/init.1
616 %{_mandir}/man8/halt.8*
617 %{_mandir}/man8/poweroff.8
618 %{_mandir}/man8/reboot.8
619 %{_mandir}/man8/runlevel.8*
620 %{_mandir}/man8/shutdown.8*
621 %{_mandir}/man8/telinit.8*
622
623 %files units
624 %defattr(644,root,root,755)
625 %dir %{_sysconfdir}/binfmt.d
626 %dir %{_sysconfdir}/modules-load.d
627 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/modules-load.d/modules.conf
628 %dir %{_sysconfdir}/sysctl.d
629 %dir %{_sysconfdir}/systemd
630 %dir %{_sysconfdir}/systemd/system
631 %dir %{_sysconfdir}/tmpfiles.d
632 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/tmpfiles.d/*.conf
633 %dir %{_libexecdir}/binfmt.d
634 %dir %{_libexecdir}/modules-load.d
635 %dir %{_libexecdir}/sysctl.d
636 %{_libexecdir}/sysctl.d/coredump.conf
637 %attr(755,root,root) /bin/systemctl
638 %attr(755,root,root) /bin/systemd-tmpfiles
639 %attr(755,root,root) /bin/systemd_booted
640 %{_mandir}/man1/systemctl.1*
641 %{_mandir}/man5/tmpfiles.d.5*
642 %{_mandir}/man8/systemd-tmpfiles.8*
643 %{_npkgconfigdir}/systemd.pc
644
645 %{systemdunitdir}/*.automount
646 %{systemdunitdir}/*.mount
647 %{systemdunitdir}/*.path
648 %{systemdunitdir}/*.service
649 %{systemdunitdir}/*.socket
650 %{systemdunitdir}/*.target
651 %{systemdunitdir}/*.timer
652 %if %{with plymouth}
653 %exclude %{systemdunitdir}/plymouth*.service
654 %exclude %{systemdunitdir}/systemd-ask-password-plymouth.*
655 %endif
656 %dir %{systemdunitdir}/basic.target.wants
657 %dir %{systemdunitdir}/dbus.target.wants
658 %dir %{systemdunitdir}/final.target.wants
659 %dir %{systemdunitdir}/graphical.target.wants
660 %dir %{systemdunitdir}/halt.target.wants
661 %dir %{systemdunitdir}/kexec.target.wants
662 %dir %{systemdunitdir}/local-fs.target.wants
663 %dir %{systemdunitdir}/multi-user.target.wants
664 %dir %{systemdunitdir}/poweroff.target.wants
665 %dir %{systemdunitdir}/reboot.target.wants
666 %dir %{systemdunitdir}/runlevel[12345].target.wants
667 %dir %{systemdunitdir}/shutdown.target.wants
668 %dir %{systemdunitdir}/sockets.target.wants
669 %dir %{systemdunitdir}/sysinit.target.wants
670 %dir %{systemdunitdir}/syslog.target.wants
671 %config(noreplace,missingok) %{systemdunitdir}/basic.target.wants/*
672 %config(noreplace,missingok) %{systemdunitdir}/final.target.wants/*
673 %config(noreplace,missingok) %{systemdunitdir}/graphical.target.wants/*
674 %config(noreplace,missingok) %{systemdunitdir}/local-fs.target.wants/*
675 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/getty.target
676 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/systemd-ask-password-wall.path
677 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/systemd-logind.service
678 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/systemd-user-sessions.service
679 %config(noreplace,missingok) %{systemdunitdir}/runlevel[12345].target.wants/*
680 %config(noreplace,missingok) %{systemdunitdir}/shutdown.target.wants/*
681 %config(noreplace,missingok) %{systemdunitdir}/sockets.target.wants/*
682 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/cryptsetup.target
683 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/dev-hugepages.mount
684 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/dev-mqueue.mount
685 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/proc-sys-fs-binfmt_misc.automount
686 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/sys-*.mount
687 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/systemd-*
688
689 %if %{with plymouth}
690 %files plymouth
691 %defattr(644,root,root,755)
692 %{systemdunitdir}/plymouth-halt.service
693 %{systemdunitdir}/plymouth-kexec.service
694 %{systemdunitdir}/plymouth-poweroff.service
695 %{systemdunitdir}/plymouth-quit-wait.service
696 %{systemdunitdir}/plymouth-quit.service
697 %{systemdunitdir}/plymouth-read-write.service
698 %{systemdunitdir}/plymouth-reboot.service
699 %{systemdunitdir}/plymouth-start.service
700 %{systemdunitdir}/systemd-ask-password-plymouth.path
701 %{systemdunitdir}/systemd-ask-password-plymouth.service
702 %config(noreplace,missingok) %{systemdunitdir}/halt.target.wants/plymouth-halt.service
703 %config(noreplace,missingok) %{systemdunitdir}/kexec.target.wants/plymouth-kexec.service
704 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/plymouth-quit.service
705 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/plymouth-quit-wait.service
706 %config(noreplace,missingok) %{systemdunitdir}/poweroff.target.wants/plymouth-poweroff.service
707 %config(noreplace,missingok) %{systemdunitdir}/reboot.target.wants/plymouth-reboot.service
708 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/plymouth-read-write.service
709 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/plymouth-start.service
710 %endif
711
712 %if %{with gtk}
713 %files gtk
714 %defattr(644,root,root,755)
715 %attr(755,root,root) %{_bindir}/systemadm
716 %attr(755,root,root) %{_bindir}/systemd-gnome-ask-password-agent
717 %{_mandir}/man1/systemadm.1*
718 %endif
719
720 %files analyze
721 %defattr(644,root,root,755)
722 %attr(755,root,root) %{_bindir}/systemd-analyze
723
724 %files libs
725 %defattr(644,root,root,755)
726 %attr(755,root,root) /%{_lib}/libsystemd-daemon.so.*.*.*
727 %attr(755,root,root) %ghost /%{_lib}/libsystemd-daemon.so.0
728 %attr(755,root,root) /%{_lib}/libsystemd-id128.so.*.*.*
729 %attr(755,root,root) %ghost /%{_lib}/libsystemd-id128.so.0
730 %attr(755,root,root) /%{_lib}/libsystemd-journal.so.*.*.*
731 %attr(755,root,root) %ghost /%{_lib}/libsystemd-journal.so.0
732 %attr(755,root,root) /%{_lib}/libsystemd-login.so.*.*.*
733 %attr(755,root,root) %ghost /%{_lib}/libsystemd-login.so.0
734
735 %files devel
736 %defattr(644,root,root,755)
737 %attr(755,root,root) %{_libdir}/libsystemd-daemon.so
738 %attr(755,root,root) %{_libdir}/libsystemd-id128.so
739 %attr(755,root,root) %{_libdir}/libsystemd-journal.so
740 %attr(755,root,root) %{_libdir}/libsystemd-login.so
741 %{_includedir}/%{name}
742 %{_pkgconfigdir}/libsystemd-daemon.pc
743 %{_pkgconfigdir}/libsystemd-id128.pc
744 %{_pkgconfigdir}/libsystemd-journal.pc
745 %{_pkgconfigdir}/libsystemd-login.pc
746 %{_mandir}/man3/sd_booted.3*
747 %{_mandir}/man3/sd_get_seats.3*
748 %{_mandir}/man3/sd_get_sessions.3*
749 %{_mandir}/man3/sd_get_uids.3*
750 %{_mandir}/man3/sd_is_fifo.3*
751 %{_mandir}/man3/sd_is_mq.3*
752 %{_mandir}/man3/sd_is_socket.3
753 %{_mandir}/man3/sd_is_socket_inet.3
754 %{_mandir}/man3/sd_is_socket_unix.3
755 %{_mandir}/man3/sd_listen_fds.3*
756 %{_mandir}/man3/sd_login_monitor_flush.3*
757 %{_mandir}/man3/sd_login_monitor_get_fd.3*
758 %{_mandir}/man3/sd_login_monitor_new.3*
759 %{_mandir}/man3/sd_login_monitor_unref.3*
760 %{_mandir}/man3/sd_notify.3*
761 %{_mandir}/man3/sd_notifyf.3
762 %{_mandir}/man3/sd_pid_get_owner_uid.3*
763 %{_mandir}/man3/sd_pid_get_session.3*
764 %{_mandir}/man3/sd_pid_get_unit.3*
765 %{_mandir}/man3/sd_readahead.3*
766 %{_mandir}/man3/sd_seat_can_multi_session.3*
767 %{_mandir}/man3/sd_seat_get_active.3*
768 %{_mandir}/man3/sd_seat_get_sessions.3*
769 %{_mandir}/man3/sd_session_get_class.3*
770 %{_mandir}/man3/sd_session_get_display.3*
771 %{_mandir}/man3/sd_session_get_seat.3*
772 %{_mandir}/man3/sd_session_get_service.3*
773 %{_mandir}/man3/sd_session_get_type.3*
774 %{_mandir}/man3/sd_session_get_uid.3*
775 %{_mandir}/man3/sd_session_is_active.3*
776 %{_mandir}/man3/sd_uid_get_seats.3*
777 %{_mandir}/man3/sd_uid_get_sessions.3*
778 %{_mandir}/man3/sd_uid_get_state.3*
779 %{_mandir}/man3/sd_uid_is_on_seat.3*
780
781 %files -n bash-completion-systemd
782 %defattr(644,root,root,755)
783 /etc/bash_completion.d/systemd-bash-completion.sh
784
785 %files no-compat-tmpfiles
786 %defattr(644,root,root,755)
787 # empty package
This page took 0.0800650000000001 seconds and 4 git commands to generate.