]> git.pld-linux.org Git - packages/systemd.git/blob - systemd.spec
- s/e/ę/
[packages/systemd.git] / systemd.spec
1 #
2 # TODO:
3 # - gtk BRs: libnotify 0.7 and gtk+3
4 # - subpackages: bash-autocompletion, dbus(?), gtk, others?
5 # - more BRs
6 #
7
8 %bcond_with     gtk     # build gtk tools
9
10 Summary:        systemd - a system and service manager for Linux
11 Summary(pl.UTF-8):      systemd - zarządca systemu i usług dla Linuksa
12 Name:           systemd
13 Version:        15
14 Release:        0.1
15 License:        GPL v2+
16 Group:          Base
17 Source0:        http://www.freedesktop.org/software/systemd/%{name}-%{version}.tar.bz2
18 # Source0-md5:  36011aa8593862ca78e3e909f6143570
19 URL:            http://www.freedesktop.org/wiki/Software/systemd
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 BuildRequires:  dbus-devel
23 %if %{with gtk}
24 BuildRequires:  libnotify-devel >= 0.7.0
25 %endif
26 BuildRequires:  libtool
27 BuildRequires:  udev-devel >= 160
28 BuildRequires:  vala >= 0.11
29 Provides:       SysVinit = 2.86-23
30 Provides:       virtual(init-daemon)
31 Obsoletes:      SysVinit
32 Obsoletes:      virtual(init-daemon)
33 Obsoletes:      vserver-SysVinit
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 systemd is a system and service manager for Linux, compatible with
38 SysV and LSB init scripts. systemd provides aggressive parallelization
39 capabilities, uses socket and D-Bus activation for starting services,
40 offers on-demand starting of daemons, keeps track of processes using
41 Linux cgroups, supports snapshotting and restoring of the system
42 state, maintains mount and automount points and implements an
43 elaborate transactional dependency-based service control logic. It can
44 work as a drop-in replacement for sysvinit.
45
46 %description -l pl.UTF-8
47 systemd jest zarządcą systemu i usług dla Linuksa, kompatybilny ze
48 skryptami SysV i LSB. systemd udostępnia rozbudowane zdolności
49 paralelizacji, do uruchamiania usług używa socketów oraz D-Busa,
50 oferuje uruchamianie usług na życzenie, monitoruje procesy używając
51 linuksowych cgroups, wspomaga zapisywanie (snapshot) i odczytywanie
52 (restore) stanu systemu, zarządza (auto)mount pointami oraz
53 implementuje starannie opracowaną transakcjonalną, bazującą na
54 zależnościach logikę kontroli usług. Może pracować jako zastępca dla
55 sysvinit.
56
57 %prep
58 %setup -q
59
60 %build
61 %{__autoconf}
62 %{__automake}
63 %configure \
64         --with-distro=other \
65         --%{?with_gtk:en}%{!?with_gtk:dis}able-gtk \
66         --with-syslog-service=syslog-ng \
67         --with-sysvinit-path=/etc/rc.d/init.d \
68         --with-sysvrcd-path=/etc/rc.d \
69         --with-rootdir=
70
71 %{__make}
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75
76 %{__make} install \
77         DESTDIR=$RPM_BUILD_ROOT
78
79 # Create SysV compatibility symlinks. systemctl/systemd are smart
80 # enough to detect in which way they are called.
81 install -d $RPM_BUILD_ROOT/sbin
82 ln -s ../bin/systemd $RPM_BUILD_ROOT/sbin/init
83 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/reboot
84 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/halt
85 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/poweroff
86 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/shutdown
87 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/telinit
88 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/runlevel
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %post
94 /bin/systemctl daemon-reexec > /dev/null 2>&1 || :
95 if [ $1 -eq 1 ] ; then
96         # Try to read default runlevel from the old inittab if it exists
97         runlevel=$(/bin/awk -F ':' '$3 == "initdefault" && $1 !~ "^#" { print $2 }' /etc/inittab 2> /dev/null)
98         if [ -z "$runlevel" ] ; then
99                 target="/lib/systemd/system/runlevel$runlevel.target"
100         else
101                 target="/lib/systemd/system/runlevel3.target"
102         fi
103
104         # And symlink what we found to the new-style default.target
105         /bin/ln -sf "$target" /etc/systemd/system/default.target > /dev/null 2>&1 || :
106         #/bin/systemctl enable SERVICES > /dev/null 2>&1 || :
107 fi
108
109 %preun
110 if [ $1 -eq 0 ] ; then
111         #/bin/systemctl disable SERVICES > /dev/null 2>&1 || :
112         /bin/rm -f /etc/systemd/system/default.target > /dev/null 2>&1 || :
113 fi
114
115 %postun
116 if [ $1 -ge 1 ] ; then
117         /bin/systemctl daemon-reload > /dev/null 2>&1 || :
118 fi
119
120 %files
121 %defattr(644,root,root,755)
122 %doc DISTRO_PORTING README TODO
123 %attr(755,root,root) /bin/systemctl
124 %attr(755,root,root) /bin/systemd
125 %attr(755,root,root) /bin/systemd-ask-password
126 %attr(755,root,root) %{_bindir}/systemd-cgls
127 %attr(755,root,root) /bin/systemd-notify
128 %attr(755,root,root) /bin/systemd-tty-ask-password-agent
129 /sbin/halt
130 /sbin/init
131 /sbin/poweroff
132 /sbin/reboot
133 /sbin/runlevel
134 /sbin/shutdown
135 /sbin/telinit
136 /lib/systemd/
137 /etc/dbus-1/system.d/org.freedesktop.systemd1.conf
138 %{_sysconfdir}/systemd
139 %{_sysconfdir}/tmpfiles.d
140 %{_sysconfdir}/xdg/systemd
141 /lib/udev/rules.d/99-systemd.rules
142 /%{_lib}/security/pam_systemd.la
143 %attr(755,root,root) /%{_lib}/security/pam_systemd.so
144 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Automount.xml
145 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Device.xml
146 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Job.xml
147 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Manager.xml
148 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Mount.xml
149 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Path.xml
150 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Service.xml
151 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Snapshot.xml
152 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Socket.xml
153 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Swap.xml
154 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Target.xml
155 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Timer.xml
156 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Unit.xml
157 %{_datadir}/dbus-1/services/org.freedesktop.systemd1.service
158 %{_datadir}/dbus-1/system-services/org.freedesktop.systemd1.service
159 %{_mandir}/man1/init.1
160 %{_mandir}/man1/systemadm.1*
161 %{_mandir}/man1/systemctl.1*
162 %{_mandir}/man1/systemd-cgls.1*
163 %{_mandir}/man1/systemd-notify.1*
164 %{_mandir}/man1/systemd.1*
165 %{_mandir}/man3/sd_booted.3*
166 %{_mandir}/man3/sd_is_fifo.3*
167 %{_mandir}/man3/sd_is_socket.3
168 %{_mandir}/man3/sd_is_socket_inet.3
169 %{_mandir}/man3/sd_is_socket_unix.3
170 %{_mandir}/man3/sd_listen_fds.3*
171 %{_mandir}/man3/sd_notify.3*
172 %{_mandir}/man3/sd_notifyf.3
173 %{_mandir}/man3/sd_readahead.3*
174 %{_mandir}/man5/hostname.5*
175 %{_mandir}/man5/locale.conf.5*
176 %{_mandir}/man5/modules-load.d.5*
177 %{_mandir}/man5/os-release.5*
178 %{_mandir}/man5/systemd.automount.5*
179 %{_mandir}/man5/systemd.conf.5*
180 %{_mandir}/man5/systemd.device.5*
181 %{_mandir}/man5/systemd.exec.5*
182 %{_mandir}/man5/systemd.mount.5*
183 %{_mandir}/man5/systemd.path.5*
184 %{_mandir}/man5/systemd.service.5*
185 %{_mandir}/man5/systemd.snapshot.5*
186 %{_mandir}/man5/systemd.socket.5*
187 %{_mandir}/man5/systemd.swap.5*
188 %{_mandir}/man5/systemd.target.5*
189 %{_mandir}/man5/systemd.timer.5*
190 %{_mandir}/man5/systemd.unit.5*
191 %{_mandir}/man5/tmpfiles.d.5*
192 %{_mandir}/man5/vconsole.conf.5*
193 %{_mandir}/man7/daemon.7*
194 %{_mandir}/man7/sd-daemon.7*
195 %{_mandir}/man7/sd-readahead.7*
196 %{_mandir}/man7/systemd.special.7*
197 %{_mandir}/man8/halt.8*
198 %{_mandir}/man8/pam_systemd.8*
199 %{_mandir}/man8/poweroff.8
200 %{_mandir}/man8/reboot.8
201 %{_mandir}/man8/runlevel.8*
202 %{_mandir}/man8/shutdown.8*
203 %{_mandir}/man8/telinit.8*
204 %{_datadir}/polkit-1/actions/org.freedesktop.systemd1.policy
205 %{_datadir}/systemd
This page took 0.31247 seconds and 4 git commands to generate.