]> git.pld-linux.org Git - packages/systemd.git/blob - systemd.spec
- removed pkgconfig from *-units R:
[packages/systemd.git] / systemd.spec
1 #
2 # TODO:
3 #       - remove compat-pld-var-run.tmpfiles and maybe tmpfiles-not-fatal.patch
4 #         after enough packages provide their own tmpfiles.d configs for
5 #         /var/run directories
6 #
7 # Conditional build:
8 %bcond_without  audit           # without audit support
9 %bcond_without  cryptsetup      # without cryptsetup support
10 %bcond_without  gtk             # build gtk tools
11 %bcond_without  pam             # PAM authentication support
12 %bcond_without  selinux         # without SELinux support
13 %bcond_without  tcpd            # libwrap (tcp_wrappers) support
14
15 Summary:        A System and Service Manager
16 Summary(pl.UTF-8):      systemd - zarządca systemu i usług dla Linuksa
17 Name:           systemd
18 Version:        39
19 Release:        2
20 License:        GPL v2+
21 Group:          Base
22 Source0:        http://www.freedesktop.org/software/systemd/%{name}-%{version}.tar.xz
23 # Source0-md5:  7179b34f6f6553d2a36551ac1dec5f0d
24 Source1:        %{name}-sysv-convert
25 Source2:        %{name}_booted.c
26 Source3:        ifup@.service
27 Source4:        network-post.service
28 Source5:        network.service
29 Source6:        compat-pld-media.tmpfiles
30 Source7:        compat-pld-var-run.tmpfiles
31 Patch0:         target-pld.patch
32 Patch1:         config-pld.patch
33 Patch2:         shut-sysv-up.patch
34 Patch3:         pld-sysv-network.patch
35 Patch4:         tmpfiles-not-fatal.patch
36 URL:            http://www.freedesktop.org/wiki/Software/systemd
37 BuildRequires:  acl-devel
38 %{?with_audit:BuildRequires:    audit-libs-devel}
39 BuildRequires:  autoconf >= 2.63
40 BuildRequires:  automake >= 1:1.11
41 %{?with_cryptsetup:BuildRequires:       cryptsetup-luks-devel}
42 BuildRequires:  dbus-devel >= 1.3.2
43 BuildRequires:  docbook-style-xsl
44 %if %{with gtk}
45 BuildRequires:  glib2-devel >= 1:2.26.1
46 BuildRequires:  gtk+2-devel >= 2:2.24.0
47 BuildRequires:  libgee-devel
48 BuildRequires:  libnotify-devel >= 0.7.0
49 %endif
50 BuildRequires:  gperf
51 BuildRequires:  intltool >= 0.40.0
52 BuildRequires:  libcap-devel
53 %{?with_selinux:BuildRequires:  libselinux-devel}
54 BuildRequires:  libtool >= 2:2.2
55 %{?with_tcpd:BuildRequires:     libwrap-devel}
56 BuildRequires:  libxslt-progs
57 BuildRequires:  m4
58 %{?with_pam:BuildRequires:      pam-devel}
59 BuildRequires:  pkgconfig >= 0.9.0
60 BuildRequires:  rpmbuild(macros) >= 1.527
61 BuildRequires:  udev-devel >= 1:172
62 # not required for building from release (which contains *.c for *.vala)
63 #BuildRequires: vala >= 0.10.0
64 BuildRequires:  xz-devel
65 Requires:       %{name}-libs = %{version}-%{release}
66 Requires:       %{name}-units = %{version}-%{release}
67 Requires:       SysVinit-tools
68 Requires:       agetty
69 Requires:       dbus >= 1.4.16-6
70 Requires:       filesystem >= 4.0-2
71 Requires:       rc-scripts >= 0.4.5.1-7
72 Requires:       setup >= 2.8.0-2
73 Requires:       udev-core >= 1:175-5
74 Requires:       udev-libs >= 1:172
75 Suggests:       ConsoleKit
76 Suggests:       fsck >= 2.20
77 Suggests:       nss_myhostname
78 # python modules required by systemd-analyze
79 Suggests:       %{name}-no-compat-tmpfiles
80 Suggests:       python-dbus
81 Suggests:       python-modules
82 Suggests:       service(klogd)
83 Suggests:       service(syslog)
84 Provides:       udev-acl
85 # systemd takes care of that and causes problems
86 Conflicts:      binfmt-detector
87 Conflicts:      upstart
88 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
89
90 %define         _libexecdir     %{_prefix}/lib
91
92 %description
93 systemd is a system and service manager for Linux, compatible with
94 SysV and LSB init scripts. systemd provides aggressive parallelization
95 capabilities, uses socket and D-Bus activation for starting services,
96 offers on-demand starting of daemons, keeps track of processes using
97 Linux cgroups, supports snapshotting and restoring of the system
98 state, maintains mount and automount points and implements an
99 elaborate transactional dependency-based service control logic. It can
100 work as a drop-in replacement for sysvinit.
101
102 %description -l pl.UTF-8
103 systemd jest zarządcą systemu i usług dla Linuksa, kompatybilny ze
104 skryptami SysV i LSB. systemd udostępnia rozbudowane zdolności
105 paralelizacji, do uruchamiania usług używa socketów oraz D-Busa,
106 oferuje uruchamianie usług na życzenie, monitoruje procesy używając
107 linuksowych cgroups, wspomaga zapisywanie (snapshot) i odczytywanie
108 (restore) stanu systemu, zarządza (auto)mount pointami oraz
109 implementuje starannie opracowaną transakcjonalną, bazującą na
110 zależnościach logikę kontroli usług. Może pracować jako zastępca dla
111 sysvinit.
112
113 %package init
114 Summary:        systemd /sbin/init and LSB/SysV compatibility symlinks
115 Summary(pl.UTF-8):      /sbin/init z systemd i dowiązania dla kompatybilności z LSB/SysV
116 Group:          Base
117 Requires:       systemd
118 Provides:       readahead = 1:1.5.7-3
119 Provides:       virtual(init-daemon)
120 Obsoletes:      SysVinit
121 Obsoletes:      readahead < 1:1.5.7-3
122 Obsoletes:      virtual(init-daemon)
123
124 %description init
125 Install this package when you are ready to final switch to systemd.
126
127 %description init -l pl.UTF-8
128 Ten pakiet należy zainstalować po przygotowaniu się do ostatecznego
129 przejścia na systemd.
130
131 %package units
132 Summary:        Configuration files, directories and installation tool for systemd
133 Summary(pl.UTF-8):      Pliki konfiguracyjne, katalogi i narzędzie instalacyjne dla systemd
134 Group:          Base
135 Requires(post): coreutils
136 Requires(post): gawk
137
138 %description units
139 Basic configuration files, directories and installation tool for the
140 systemd system and service manager.
141
142 This is common config, use %{_sysconfdir}/systemd/system to override.
143
144 %description units -l pl.UTF-8
145 Podstawowe pliki konfiguracyjne, katalogi i narzędzie instalacyjne dla
146 zarządcy systemu i usług systemd.
147
148 Ten pakiet zawiera ogólną konfigurację, ustawienia można nadpisać
149 poprzez katalog %{_sysconfdir}/systemd/system.
150
151 %package gtk
152 Summary:        Graphical frontend for systemd
153 Summary(pl.UTF-8):      Graficzny interfejs do systemd
154 Group:          Base
155 Requires:       %{name} = %{version}-%{release}
156 Requires:       polkit
157
158 %description gtk
159 Graphical front-end for systemd.
160
161 %description gtk -l pl.UTF-8
162 Graficzny interfejs do systemd.
163
164 %package libs
165 Summary:        Shared systemd libraries
166 Summary(pl.UTF-8):      Biblioteki współdzielone systemd
167 Group:          Libraries
168
169 %description libs
170 Shared systemd libraries.
171
172 %description libs -l pl.UTF-8
173 Biblioteki współdzielone systemd.
174
175 %package devel
176 Summary:        Header files for systemd libraries
177 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek systemd
178 Group:          Development/Libraries
179 Requires:       %{name}-libs = %{version}-%{release}
180
181 %description devel
182 Header files for systemd libraries.
183
184 %description devel -l pl.UTF-8
185 Pliki nagłówkowe bibliotek systemd.
186
187 %package -n bash-completion-systemd
188 Summary:        bash-completion for systemd
189 Summary(pl.UTF-8):      Bashowe dopełnianie składni dla systemd
190 Group:          Applications/Shells
191 Requires:       %{name}
192 Requires:       bash-completion
193
194 %description -n bash-completion-systemd
195 bash-completion for systemd.
196
197 %description -n bash-completion-systemd -l pl.UTF-8
198 Bashowe dopełnianie składni dla systemd
199
200 %package no-compat-tmpfiles
201 Summary:        Force update of packages that provide tmpfiles.d configuration
202 Group:          Base
203 Requires(post): sed > 4.0
204 Conflicts:      ConsoleKit-dirs < 0.4.5-7
205 Conflicts:      NetworkManager < 2:0.9.2.0-3
206 Conflicts:      Zope < 2.11.8-2
207 Conflicts:      amavisd-new < 1:2.7.0-1
208 Conflicts:      apache-base < 2.2.21-4
209 Conflicts:      apache-mod_bw < 0.92-3
210 Conflicts:      apache-mod_fastcgi < 2.4.6-6
211 Conflicts:      apache1-base < 1.3.42-5
212 Conflicts:      apache1-mod_fastcgi < 2.4.6-2
213 Conflicts:      asterisk < 10.0.1-2
214 Conflicts:      autossh-init < 1.4b-3
215 Conflicts:      balance < 3.54-2
216 Conflicts:      bind < 7:9.8.1.P1-4
217 Conflicts:      bopm < 3.1.3-4
218 Conflicts:      callweaver < 1.2.1-9
219 Conflicts:      cassandra-bin < 0.8.9-2
220 Conflicts:      clamav < 0.97.3-3
221 Conflicts:      cups < 1:1.5.0-10
222 Conflicts:      dbus < 1.4.16-4
223 Conflicts:      dovecot < 1:2.0.16-3
224 Conflicts:      dspam < 3.9.0-6
225 Conflicts:      fail2ban < 0.8.4-4
226 Conflicts:      filesystem < 4.0-3
227 Conflicts:      gammu-smsd < 1:1.31.0-3
228 Conflicts:      gdm < 2:3.2.1.1-9
229 Conflicts:      greylistd < 0.8.8-2
230 Conflicts:      inn < 2.4.6-7
231 Conflicts:      ipsec-tools < 0.8.0-3
232 Conflicts:      jabber-common < 0-9
233 Conflicts:      laptop-mode-tools < 1.58-2
234 Conflicts:      libgpod < 0.8.0-6
235 Conflicts:      libvirt-utils < 0.9.9-4
236 Conflicts:      lighttpd < 1.4.30-5
237 Conflicts:      lirc < 0.9.0-20
238 Conflicts:      mailman < 5:2.1.14-4
239 Conflicts:      memcached < 1.4.11-2
240 Conflicts:      mpd < 0.16.5-4
241 Conflicts:      mrtg < 2.17.0-3
242 Conflicts:      munin-common < 1.4.5-5
243 Conflicts:      nagios-nrpe < 2.13-2
244 Conflicts:      ndisc6-rdnssd < 1.0.1-3
245 Conflicts:      nscd < 6:2.14.1-5
246 Conflicts:      nss_ldapd-nslcd < 0.8.4-2
247 Conflicts:      openct < 0.6.20-3
248 Conflicts:      openl2tp < 1.8-3
249 Conflicts:      openldap-overlay-nssov < 2.4.28-4
250 Conflicts:      openldap-servers < 2.4.28-4
251 Conflicts:      openvpn < 2.2.2-2
252 Conflicts:      pam < 1:1.1.5-3
253 Conflicts:      pam-pam_mount < 2.12-3
254 Conflicts:      pam-pam_ssh < 1.97-2
255 Conflicts:      pcsc-lite < 1.8.1-2
256 Conflicts:      php-dirs < 1.2-3
257 Conflicts:      policyd < 2.0.10-3
258 Conflicts:      pound < 2.6-2
259 Conflicts:      pptp < 1.7.2-3
260 Conflicts:      proftpd-common < 2:1.3.4a-2
261 Conflicts:      pulseaudio-server < 1.1-2
262 Conflicts:      quagga < 0.99.20-3
263 Conflicts:      radvd < 1.8.5-2
264 Conflicts:      rc-scripts < 0.4.5.2-3
265 Conflicts:      red5 < 0.9.0-2
266 Conflicts:      redis-server < 2.4.2-4
267 Conflicts:      smokeping < 2.4.2-10
268 Conflicts:      smtp-gated < 1.4.17-2
269 Conflicts:      socat < 1.7.2.0-2
270 Conflicts:      speech-dispatcher < 0.7.1-2
271 Conflicts:      sphinx < 2.0.3-4
272 Conflicts:      splashutils < 1.5.4.3-3
273 Conflicts:      stunnel < 4.50-2
274 Conflicts:      sudo < 1:1.7.8p2-2
275 Conflicts:      tenshi < 0.12-2
276 Conflicts:      tor < 0.2.2.35-2
277 Conflicts:      ucarp < 1.5.2-3
278 Conflicts:      udisks < 1.0.4-3
279 Conflicts:      util-vserver < 0.30.216-1.pre3002.3
280 Conflicts:      vpnc < 0.5.3-2
281 Conflicts:      web2ldap < 1.1.0rc1-2
282 Conflicts:      wesnoth-server < 1:1.10-2
283 Conflicts:      wpa_supplicant < 0.7.3-10
284 Conflicts:      xl2tpd < 1.3.0-2
285
286 %description no-compat-tmpfiles
287 Force update of packages that provide tmpfiles.d configuration
288
289 %prep
290 %setup -q
291 %patch0 -p1
292 %patch1 -p1
293 #%patch2 -p1
294 %patch3 -p1
295 %patch4 -p1
296 cp -p %{SOURCE2} src/systemd_booted.c
297
298 %build
299 %{__aclocal} -I m4
300 %{__autoconf}
301 %{__autoheader}
302 %{__automake}
303 %configure \
304         %{__enable_disable audit} \
305         %{__enable_disable cryptsetup libcryptsetup} \
306         %{__enable_disable gtk} \
307         %{__enable_disable pam} \
308         %{__enable_disable selinux} \
309         %{__enable_disable tcpd tcpwrap} \
310         --disable-silent-rules \
311         --disable-static \
312         --with-distro=pld \
313         --with-rootprefix= \
314         --with-rootlibdir=/%{_lib}
315
316 %{__make}
317 ./libtool --mode=link --tag=CC %{__cc} %{rpmcppflags} %{rpmcflags} -o systemd_booted %{rpmldflags} src/systemd_booted.c -L. -lsystemd-daemon
318
319 %install
320 rm -rf $RPM_BUILD_ROOT
321
322 %{__make} install \
323         DESTDIR=$RPM_BUILD_ROOT
324
325 ./libtool --mode=install install -m755 systemd_booted $RPM_BUILD_ROOT/bin/systemd_booted
326
327 # Create SysV compatibility symlinks. systemctl/systemd are smart
328 # enough to detect the way they were called
329 install -d $RPM_BUILD_ROOT/sbin
330 ln -s ../bin/systemd $RPM_BUILD_ROOT/sbin/init
331 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/halt
332 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/poweroff
333 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/reboot
334 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/runlevel
335 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/shutdown
336 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/telinit
337
338 ln -s ../modules $RPM_BUILD_ROOT%{_sysconfdir}/modules-load.d/modules.conf
339 # disable random and console SYSV service 
340 ln -s /dev/null $RPM_BUILD_ROOT/lib/systemd/system/random.service
341 ln -s /dev/null $RPM_BUILD_ROOT/lib/systemd/system/console.service
342
343 # add static (non-NetworkManager) networking
344 install %{SOURCE3} $RPM_BUILD_ROOT/lib/systemd/system/ifup@.service
345 install %{SOURCE4} $RPM_BUILD_ROOT/lib/systemd/system/network-post.service
346 install %{SOURCE5} $RPM_BUILD_ROOT/lib/systemd/system/network.service
347
348 # install compatibility tmpfiles configs
349 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/compat-pld-media.conf
350 install %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/compat-pld-var-run.conf
351
352 # All wants links are created at %post to make sure they are not owned
353 # and hence overriden by rpm if the user deletes them (missingok?)
354 %{__rm} -r $RPM_BUILD_ROOT%{_sysconfdir}/systemd/system/*.target.wants
355
356 # it is in rc-scripts pkg
357 %{__rm} $RPM_BUILD_ROOT/lib/systemd/system/rc-local.service
358
359 # Make sure these directories are properly owned:
360 #       - halt,kexec,poweroff,reboot: generic ones used by ConsoleKit-systemd,
361 #       - syslog _might_ be used by some syslog implementation (none for now),
362 #       - isn't dbus populated by dbus-systemd only (so to be moved there)?
363 install -d $RPM_BUILD_ROOT/lib/systemd/system/{dbus,halt,kexec,poweroff,reboot,syslog}.target.wants
364
365 # Create new-style configuration files so that we can ghost-own them
366 touch $RPM_BUILD_ROOT%{_sysconfdir}/{hostname,locale.conf,machine-id,machine-info,os-release,timezone,vconsole.conf}
367
368 # Install SysV conversion tool for systemd
369 install -p %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}
370
371 install -d $RPM_BUILD_ROOT/var/log
372 :> $RPM_BUILD_ROOT/var/log/btmp
373 :> $RPM_BUILD_ROOT/var/log/wtmp
374
375 %if %{without gtk}
376 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/systemadm.1*
377 %endif
378
379 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
380 %{__rm} $RPM_BUILD_ROOT/%{_lib}/security/pam_systemd.la
381 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
382
383 %clean
384 rm -rf $RPM_BUILD_ROOT
385
386 %post
387 /bin/systemd-machine-id-setup > /dev/null 2>&1 || :
388 /bin/systemctl daemon-reexec > /dev/null 2>&1 || :
389
390 %postun
391 if [ $1 -ge 1 ]; then
392         /bin/systemctl try-restart systemd-logind.service >/dev/null 2>&1 || :
393 fi
394
395 %post   libs -p /sbin/ldconfig
396 %postun libs -p /sbin/ldconfig
397
398 %post units
399 if [ $1 -eq 1 ]; then
400         # Try to read default runlevel from the old inittab if it exists
401         runlevel=$(/bin/awk -F ':' '$3 == "initdefault" && $1 !~ "^#" { print $2 }' /etc/inittab 2> /dev/null)
402         if [ -z "$runlevel" ] ; then
403                 target="/lib/systemd/system/graphical.target"
404         else
405                 target="/lib/systemd/system/runlevel$runlevel.target"
406         fi
407
408         # And symlink what we found to the new-style default.target
409         ln -s "$target" %{_sysconfdir}/systemd/system/default.target >/dev/null 2>&1 || :
410
411         # Setup hostname
412         [ -f /etc/sysconfig/network ] && . /etc/sysconfig/network
413         if [ -n "$HOSTNAME" -a "$HOSTNAME" != "pldmachine" ]; then
414                 [ -f /etc/hostname ] && mv -f /etc/hostname /etc/hostname.rpmsave
415                 echo $HOSTNAME > /etc/hostname
416                 chmod 644 /etc/hostname
417         fi
418 fi
419 # Enable the services we install by default.
420 /bin/systemctl enable \
421         getty@.service \
422         network.service \
423         network-post.service \
424         remote-fs.target \
425         systemd-readahead-replay.service \
426         systemd-readahead-collect.service >/dev/null 2>&1 || :
427
428 # Find and enable all installed interfaces
429 mkdir -p %{_sysconfdir}/systemd/system/network.target.wants >/dev/null 2>&1 || :
430 for f in /etc/sysconfig/interfaces/ifcfg-* ; do
431         ff=$(basename $f)
432         ff=${ff##ifcfg-}
433         case "$ff" in
434         *.rpmorig|*.rpmnew|*.rpmsave|*~|*.orig)
435                 continue
436                 ;;
437         *)
438                 DEVICE="" ; ONBOOT="" ; USERS=""
439                 . $f 2>/dev/null
440                 [ ${USERS:-no} != no ] && continue
441                 if [ "$DEVICE" = "$ff" -a ${ONBOOT:-no} = "yes" ]; then
442                         ln -s /lib/systemd/system/ifup@.service \
443                                 %{_sysconfdir}/systemd/system/network.target.wants/ifcfg@$ff.service >/dev/null 2>&1 || :
444                 fi
445                 ;;
446         esac
447 done
448
449 %preun units
450 if [ $1 -eq 0 ] ; then
451         /bin/systemctl disable \
452                 getty@.service \
453                 network.service \
454                 network-post.service \
455                 remote-fs.target \
456                 systemd-readahead-replay.service \
457                 systemd-readahead-collect.service >/dev/null 2>&1 || :
458
459         %{__rm} -f %{_sysconfdir}/systemd/system/default.target >/dev/null 2>&1 || :
460         %{__rm} -f %{_sysconfdir}/systemd/system/network.target.wants/ifcfg@*.service >/dev/null 2>&1 || :
461 fi
462
463 %postun units
464 if [ $1 -ge 1 ]; then
465         /bin/systemctl daemon-reload > /dev/null 2>&1 || :
466 fi
467
468 %post no-compat-tmpfiles
469 %{__sed} -i -e 's/^/# /g' %{_sysconfdir}/tmpfiles.d/compat-pld-var-run.conf
470
471 %files
472 %defattr(644,root,root,755)
473 %doc DISTRO_PORTING README TODO
474 /etc/dbus-1/system.d/org.freedesktop.hostname1.conf
475 /etc/dbus-1/system.d/org.freedesktop.locale1.conf
476 /etc/dbus-1/system.d/org.freedesktop.login1.conf
477 /etc/dbus-1/system.d/org.freedesktop.systemd1.conf
478 /etc/dbus-1/system.d/org.freedesktop.timedate1.conf
479 %ghost %config(noreplace) %{_sysconfdir}/machine-id
480 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hostname
481 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/locale.conf
482 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/machine-info
483 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/os-release
484 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/timezone
485 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/vconsole.conf
486 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/systemd/*.conf
487 %dir %{_sysconfdir}/systemd/user
488 /etc/xdg/systemd
489 %attr(755,root,root) /bin/systemd
490 %attr(755,root,root) /bin/systemd-ask-password
491 %attr(755,root,root) /bin/systemd-journalctl
492 %attr(755,root,root) /bin/systemd-loginctl
493 %attr(755,root,root) /bin/systemd-machine-id-setup
494 %attr(755,root,root) /bin/systemd-notify
495 %attr(755,root,root) /bin/systemd-tty-ask-password-agent
496 %attr(755,root,root) %{_bindir}/systemd-analyze
497 %attr(755,root,root) %{_bindir}/systemd-cat
498 %attr(755,root,root) %{_bindir}/systemd-cgtop
499 %attr(755,root,root) %{_bindir}/systemd-cgls
500 %attr(755,root,root) %{_bindir}/systemd-nspawn
501 %attr(755,root,root) %{_bindir}/systemd-stdio-bridge
502 %attr(755,root,root) %{_bindir}/systemd-sysv-convert
503 %attr(755,root,root) /lib/systemd/systemd-*
504 %dir /lib/systemd/system-generators
505 %attr(755,root,root) /lib/systemd/system-generators/systemd-*-generator
506 %dir /lib/systemd/system-shutdown
507 /lib/udev/rules.d/99-systemd.rules
508 /lib/udev/rules.d/70-uaccess.rules
509 /lib/udev/rules.d/71-seat.rules
510 /lib/udev/rules.d/73-seat-late.rules
511 %dir %{_libexecdir}/systemd
512 %{_libexecdir}/systemd/user
513 %dir %{_libexecdir}/systemd/user-generators
514 %config(noreplace,missingok) %{_libexecdir}/tmpfiles.d/*.conf
515 %{_datadir}/dbus-1/interfaces/org.freedesktop.hostname1.xml
516 %{_datadir}/dbus-1/interfaces/org.freedesktop.locale1.xml
517 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.*.xml
518 %{_datadir}/dbus-1/interfaces/org.freedesktop.timedate1.xml
519 %{_datadir}/dbus-1/services/org.freedesktop.systemd1.service
520 %{_datadir}/dbus-1/system-services/org.freedesktop.hostname1.service
521 %{_datadir}/dbus-1/system-services/org.freedesktop.locale1.service
522 %{_datadir}/dbus-1/system-services/org.freedesktop.login1.service
523 %{_datadir}/dbus-1/system-services/org.freedesktop.systemd1.service
524 %{_datadir}/dbus-1/system-services/org.freedesktop.timedate1.service
525 %{_datadir}/polkit-1/actions/org.freedesktop.hostname1.policy
526 %{_datadir}/polkit-1/actions/org.freedesktop.locale1.policy
527 %{_datadir}/polkit-1/actions/org.freedesktop.login1.policy
528 %{_datadir}/polkit-1/actions/org.freedesktop.systemd1.policy
529 %{_datadir}/polkit-1/actions/org.freedesktop.timedate1.policy
530 %dir %{_datadir}/systemd
531 %{_datadir}/systemd/kbd-model-map
532 %{_mandir}/man1/systemd.1*
533 %{_mandir}/man1/systemd-*.1*
534 %{_mandir}/man3/sd_booted.3*
535 %{_mandir}/man3/sd_is_fifo.3*
536 %{_mandir}/man3/sd_is_socket.3
537 %{_mandir}/man3/sd_is_socket_inet.3
538 %{_mandir}/man3/sd_is_socket_unix.3
539 %{_mandir}/man3/sd_listen_fds.3*
540 %{_mandir}/man3/sd_notify.3*
541 %{_mandir}/man3/sd_notifyf.3
542 %{_mandir}/man3/sd_readahead.3*
543 %{_mandir}/man5/binfmt.d.5*
544 %{_mandir}/man5/hostname.5*
545 %{_mandir}/man5/locale.conf.5*
546 %{_mandir}/man5/machine-id.5*
547 %{_mandir}/man5/machine-info.5*
548 %{_mandir}/man5/modules-load.d.5*
549 %{_mandir}/man5/os-release.5*
550 %{_mandir}/man5/sysctl.d.5*
551 %{_mandir}/man5/systemd.*.5*
552 %{_mandir}/man5/systemd-logind.conf.5*
553 %{_mandir}/man5/timezone.5*
554 %{_mandir}/man5/vconsole.conf.5*
555 %{_mandir}/man7/daemon.7*
556 %{_mandir}/man7/sd-daemon.7*
557 %{_mandir}/man7/sd-login.7*
558 %{_mandir}/man7/sd-readahead.7*
559 %{_mandir}/man7/systemd.special.7*
560 %attr(640,root,root) %ghost /var/log/btmp
561 %attr(664,root,utmp) %ghost /var/log/wtmp
562
563 %if %{with pam}
564 %attr(755,root,root) /%{_lib}/security/pam_systemd.so
565 %{_mandir}/man8/pam_systemd.8*
566 %endif
567
568 %files init
569 %defattr(644,root,root,755)
570 %attr(755,root,root) /sbin/halt
571 %attr(755,root,root) /sbin/init
572 %attr(755,root,root) /sbin/poweroff
573 %attr(755,root,root) /sbin/reboot
574 %attr(755,root,root) /sbin/runlevel
575 %attr(755,root,root) /sbin/shutdown
576 %attr(755,root,root) /sbin/telinit
577 %{_mandir}/man1/init.1
578 %{_mandir}/man8/halt.8*
579 %{_mandir}/man8/poweroff.8
580 %{_mandir}/man8/reboot.8
581 %{_mandir}/man8/runlevel.8*
582 %{_mandir}/man8/shutdown.8*
583 %{_mandir}/man8/telinit.8*
584
585 %files units
586 %defattr(644,root,root,755)
587 %dir %{_sysconfdir}/binfmt.d
588 %dir %{_sysconfdir}/modules-load.d
589 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/modules-load.d/modules.conf
590 %dir %{_sysconfdir}/sysctl.d
591 %dir %{_sysconfdir}/systemd
592 %dir %{_sysconfdir}/systemd/system
593 %dir %{_sysconfdir}/tmpfiles.d
594 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/tmpfiles.d/*.conf
595 %dir %{_libexecdir}/binfmt.d
596 %dir %{_libexecdir}/modules-load.d
597 %dir %{_libexecdir}/sysctl.d
598 %{_libexecdir}/sysctl.d/coredump.conf
599 %attr(755,root,root) /bin/systemctl
600 %attr(755,root,root) /bin/systemd-tmpfiles
601 %attr(755,root,root) /bin/systemd_booted
602 %{_mandir}/man1/systemctl.1*
603 %{_mandir}/man5/tmpfiles.d.5*
604 %{_mandir}/man8/systemd-tmpfiles.8*
605 %{_npkgconfigdir}/systemd.pc
606
607 /lib/systemd/system/*.automount
608 /lib/systemd/system/*.mount
609 /lib/systemd/system/*.path
610 /lib/systemd/system/*.service
611 /lib/systemd/system/*.socket
612 /lib/systemd/system/*.target
613 /lib/systemd/system/*.timer
614 %dir /lib/systemd/system/*.wants
615 %config(noreplace,missingok) /lib/systemd/system/*.wants/*
616
617 %if %{with gtk}
618 %files gtk
619 %defattr(644,root,root,755)
620 %attr(755,root,root) %{_bindir}/systemadm
621 %attr(755,root,root) %{_bindir}/systemd-gnome-ask-password-agent
622 %{_mandir}/man1/systemadm.1*
623 %endif
624
625 %files libs
626 %defattr(644,root,root,755)
627 %attr(755,root,root) /%{_lib}/libsystemd-daemon.so.*.*.*
628 %attr(755,root,root) %ghost /%{_lib}/libsystemd-daemon.so.0
629 %attr(755,root,root) /%{_lib}/libsystemd-id128.so.*.*.*
630 %attr(755,root,root) %ghost /%{_lib}/libsystemd-id128.so.0
631 %attr(755,root,root) /%{_lib}/libsystemd-journal.so.*.*.*
632 %attr(755,root,root) %ghost /%{_lib}/libsystemd-journal.so.0
633 %attr(755,root,root) /%{_lib}/libsystemd-login.so.*.*.*
634 %attr(755,root,root) %ghost /%{_lib}/libsystemd-login.so.0
635
636 %files devel
637 %defattr(644,root,root,755)
638 %attr(755,root,root) %{_libdir}/libsystemd-daemon.so
639 %attr(755,root,root) %{_libdir}/libsystemd-id128.so
640 %attr(755,root,root) %{_libdir}/libsystemd-journal.so
641 %attr(755,root,root) %{_libdir}/libsystemd-login.so
642 %{_includedir}/%{name}
643 %{_pkgconfigdir}/libsystemd-daemon.pc
644 %{_pkgconfigdir}/libsystemd-id128.pc
645 %{_pkgconfigdir}/libsystemd-journal.pc
646 %{_pkgconfigdir}/libsystemd-login.pc
647 %{_mandir}/man3/sd_get_seats.3*
648 %{_mandir}/man3/sd_get_sessions.3*
649 %{_mandir}/man3/sd_get_uids.3*
650 %{_mandir}/man3/sd_is_mq.3*
651 %{_mandir}/man3/sd_login_monitor_flush.3*
652 %{_mandir}/man3/sd_login_monitor_get_fd.3*
653 %{_mandir}/man3/sd_login_monitor_new.3*
654 %{_mandir}/man3/sd_login_monitor_unref.3*
655 %{_mandir}/man3/sd_pid_get_owner_uid.3*
656 %{_mandir}/man3/sd_pid_get_session.3*
657 %{_mandir}/man3/sd_pid_get_unit.3*
658 %{_mandir}/man3/sd_seat_can_multi_session.3*
659 %{_mandir}/man3/sd_seat_get_active.3*
660 %{_mandir}/man3/sd_seat_get_sessions.3*
661 %{_mandir}/man3/sd_session_get_seat.3*
662 %{_mandir}/man3/sd_session_get_uid.3*
663 %{_mandir}/man3/sd_session_is_active.3*
664 %{_mandir}/man3/sd_uid_get_seats.3*
665 %{_mandir}/man3/sd_uid_get_sessions.3*
666 %{_mandir}/man3/sd_uid_get_state.3*
667 %{_mandir}/man3/sd_uid_is_on_seat.3*
668
669 %files -n bash-completion-systemd
670 %defattr(644,root,root,755)
671 /etc/bash_completion.d/systemd-bash-completion.sh
672
673 %files no-compat-tmpfiles
674 %defattr(644,root,root,755)
675 # empty package
This page took 0.075537 seconds and 4 git commands to generate.