]> git.pld-linux.org Git - packages/systemd.git/blob - systemd.spec
- rel 13
[packages/systemd.git] / systemd.spec
1 #
2 # Conditional build:
3 %bcond_without  audit           # without audit support
4 %bcond_without  cryptsetup      # without cryptsetup support
5 %bcond_without  gtk             # build gtk tools
6 %bcond_without  pam             # PAM authentication support
7 %bcond_without  selinux         # without SELinux support
8 %bcond_without  tcpd            # libwrap (tcp_wrappers) support
9
10 Summary:        A System and Service Manager
11 Summary(pl.UTF-8):      systemd - zarządca systemu i usług dla Linuksa
12 Name:           systemd
13 Version:        38
14 Release:        13
15 License:        GPL v2+
16 Group:          Base
17 Source0:        http://www.freedesktop.org/software/systemd/%{name}-%{version}.tar.xz
18 # Source0-md5:  68c66dce5a28c0efd7c210af5d11efed
19 Source1:        %{name}-sysv-convert
20 Source2:        systemd_booted.c
21 Source3:        ifup@.service
22 Source4:        network-post.service
23 Source5:        network.service
24 Source6:        compat-pld-media.tmpfiles
25 Source7:        compat-pld-var-run.tmpfiles
26 Patch0:         target-pld.patch
27 Patch1:         config-pld.patch
28 Patch2:         shut-sysv-up.patch
29 Patch3:         pld-sysv-network.patch
30 URL:            http://www.freedesktop.org/wiki/Software/systemd
31 BuildRequires:  acl-devel
32 %{?with_audit:BuildRequires:    audit-libs-devel}
33 BuildRequires:  autoconf >= 2.63
34 BuildRequires:  automake >= 1:1.11
35 %{?with_cryptsetup:BuildRequires:       cryptsetup-luks-devel}
36 BuildRequires:  dbus-devel >= 1.3.2
37 BuildRequires:  docbook-style-xsl
38 %if %{with gtk}
39 BuildRequires:  glib2-devel >= 1:2.26.1
40 BuildRequires:  gtk+2-devel >= 2:2.24.0
41 BuildRequires:  libgee-devel
42 BuildRequires:  libnotify-devel >= 0.7.0
43 %endif
44 BuildRequires:  gperf
45 BuildRequires:  intltool >= 0.40.0
46 BuildRequires:  libcap-devel
47 %{?with_selinux:BuildRequires:  libselinux-devel}
48 BuildRequires:  libtool >= 2:2.2
49 %{?with_tcpd:BuildRequires:     libwrap-devel}
50 BuildRequires:  libxslt-progs
51 BuildRequires:  m4
52 %{?with_pam:BuildRequires:      pam-devel}
53 BuildRequires:  pkgconfig >= 0.9.0
54 BuildRequires:  rpmbuild(macros) >= 1.527
55 BuildRequires:  udev-devel >= 172
56 # not required for building from release (which contains *.c for *.vala)
57 #BuildRequires: vala >= 0.10.0
58 Requires:       %{name}-libs = %{version}-%{release}
59 Requires:       %{name}-units = %{version}-%{release}
60 Requires:       SysVinit-tools
61 Requires:       agetty
62 Requires:       dbus >= 1.3.2
63 Requires:       dbus-systemd
64 Requires:       filesystem >= 4.0
65 Requires:       rc-scripts >= 0.4.5.1-7
66 Requires:       setup >= 2.8.0-2
67 Requires:       udev-core >= 1:172
68 Requires:       udev-systemd >= 1:172
69 Requires:       udev-libs >= 1:172
70 Suggests:       ConsoleKit-systemd
71 Suggests:       fsck >= 2.20
72 Suggests:       nss_myhostname
73 # python modules required by systemd-analyze
74 Suggests:       python-dbus
75 Suggests:       python-modules
76 Suggests:       service(syslog)
77 Provides:       udev-acl
78 Conflicts:      upstart
79 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
80
81 %define         _libexecdir     %{_prefix}/lib
82
83 %description
84 systemd is a system and service manager for Linux, compatible with
85 SysV and LSB init scripts. systemd provides aggressive parallelization
86 capabilities, uses socket and D-Bus activation for starting services,
87 offers on-demand starting of daemons, keeps track of processes using
88 Linux cgroups, supports snapshotting and restoring of the system
89 state, maintains mount and automount points and implements an
90 elaborate transactional dependency-based service control logic. It can
91 work as a drop-in replacement for sysvinit.
92
93 %description -l pl.UTF-8
94 systemd jest zarządcą systemu i usług dla Linuksa, kompatybilny ze
95 skryptami SysV i LSB. systemd udostępnia rozbudowane zdolności
96 paralelizacji, do uruchamiania usług używa socketów oraz D-Busa,
97 oferuje uruchamianie usług na życzenie, monitoruje procesy używając
98 linuksowych cgroups, wspomaga zapisywanie (snapshot) i odczytywanie
99 (restore) stanu systemu, zarządza (auto)mount pointami oraz
100 implementuje starannie opracowaną transakcjonalną, bazującą na
101 zależnościach logikę kontroli usług. Może pracować jako zastępca dla
102 sysvinit.
103
104 %package init
105 Summary:        systemd /sbin/init and LSB/SysV compatibility symlinks
106 Summary(pl.UTF-8):      /sbin/init z systemd i dowiązania dla kompatybilności z LSB/SysV
107 Group:          Base
108 Requires:       systemd
109 Provides:       readahead = 1:1.5.7-3
110 Provides:       virtual(init-daemon)
111 Obsoletes:      SysVinit
112 Obsoletes:      readahead < 1:1.5.7-3
113 Obsoletes:      virtual(init-daemon)
114
115 %description init
116 Install this package when you are ready to final switch to systemd.
117
118 %description init -l pl.UTF-8
119 Ten pakiet należy zainstalować po przygotowaniu się do ostatecznego
120 przejścia na systemd.
121
122 %package units
123 Summary:        Configuration files, directories and installation tool for systemd
124 Summary(pl.UTF-8):      Pliki konfiguracyjne, katalogi i narzędzie instalacyjne dla systemd
125 Group:          Base
126 Requires(post): coreutils
127 Requires(post): gawk
128 Requires:       pkgconfig
129
130 %description units
131 Basic configuration files, directories and installation tool for the
132 systemd system and service manager.
133
134 This is common config, use %{_sysconfdir}/systemd/system to override.
135
136 %description units -l pl.UTF-8
137 Podstawowe pliki konfiguracyjne, katalogi i narzędzie instalacyjne dla
138 zarządcy systemu i usług systemd.
139
140 Ten pakiet zawiera ogólną konfigurację, ustawienia można nadpisać
141 poprzez katalog %{_sysconfdir}/systemd/system.
142
143 %package gtk
144 Summary:        Graphical frontend for systemd
145 Summary(pl.UTF-8):      Graficzny interfejs do systemd
146 Group:          Base
147 Requires:       %{name} = %{version}-%{release}
148 Requires:       polkit
149
150 %description gtk
151 Graphical front-end for systemd.
152
153 %description gtk -l pl.UTF-8
154 Graficzny interfejs do systemd.
155
156 %package libs
157 Summary:        Shared systemd libraries
158 Summary(pl.UTF-8):      Biblioteki współdzielone systemd
159 Group:          Libraries
160
161 %description libs
162 Shared systemd libraries.
163
164 %description libs -l pl.UTF-8
165 Biblioteki współdzielone systemd.
166
167 %package devel
168 Summary:        Header files for systemd libraries
169 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek systemd
170 Group:          Development/Libraries
171 Requires:       %{name}-libs = %{version}-%{release}
172
173 %description devel
174 Header files for systemd libraries.
175
176 %description devel -l pl.UTF-8
177 Pliki nagłówkowe bibliotek systemd.
178
179 %package -n bash-completion-systemd
180 Summary:        bash-completion for systemd
181 Summary(pl.UTF-8):      Bashowe dopełnianie składni dla systemd
182 Group:          Applications/Shells
183 Requires:       %{name}
184 Requires:       bash-completion
185
186 %description -n bash-completion-systemd
187 bash-completion for systemd.
188
189 %description -n bash-completion-systemd -l pl.UTF-8
190 Bashowe dopełnianie składni dla systemd
191
192 %prep
193 %setup -q
194 %patch0 -p1
195 %patch1 -p1
196 %patch2 -p1
197 %patch3 -p1
198 cp -p %{SOURCE2} src/systemd_booted.c
199
200 %build
201 %{__aclocal} -I m4
202 %{__autoconf}
203 %{__autoheader}
204 %{__automake}
205 %configure \
206         %{__enable_disable audit} \
207         %{__enable_disable cryptsetup libcryptsetup} \
208         %{__enable_disable gtk} \
209         %{__enable_disable pam} \
210         %{__enable_disable selinux} \
211         %{__enable_disable tcpd tcpwrap} \
212         --disable-silent-rules \
213         --disable-static \
214         --with-distro=pld \
215         --with-rootprefix= \
216         --with-rootlibdir=/%{_lib}
217
218 %{__make}
219 ./libtool --mode=link --tag=CC %{__cc} %{rpmcppflags} %{rpmcflags} -o systemd_booted %{rpmldflags} src/systemd_booted.c -L. -lsystemd-daemon
220
221 %install
222 rm -rf $RPM_BUILD_ROOT
223
224 %{__make} install \
225         DESTDIR=$RPM_BUILD_ROOT
226
227 ./libtool --mode=install install -m755 systemd_booted $RPM_BUILD_ROOT/bin/systemd_booted
228
229 # Create SysV compatibility symlinks. systemctl/systemd are smart
230 # enough to detect the way they were called
231 install -d $RPM_BUILD_ROOT/sbin
232 ln -s ../bin/systemd $RPM_BUILD_ROOT/sbin/init
233 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/halt
234 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/poweroff
235 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/reboot
236 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/runlevel
237 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/shutdown
238 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/telinit
239
240 ln -s ../modules $RPM_BUILD_ROOT%{_sysconfdir}/modules-load.d/modules.conf
241 # disable random and console SYSV service 
242 ln -s /dev/null $RPM_BUILD_ROOT/lib/systemd/system/random.service
243 ln -s /dev/null $RPM_BUILD_ROOT/lib/systemd/system/console.service
244
245 # add static (non-NetworkManager) networking
246 install %{SOURCE3} $RPM_BUILD_ROOT/lib/systemd/system/ifup@.service
247 install %{SOURCE4} $RPM_BUILD_ROOT/lib/systemd/system/network-post.service
248 install %{SOURCE5} $RPM_BUILD_ROOT/lib/systemd/system/network.service
249
250 # install compatibility tmpfiles configs
251 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/compat-pld-media.conf
252 #install %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/compat-pld-var-run.conf
253
254 # All wants links are created at %post to make sure they are not owned
255 # and hence overriden by rpm if the user deletes them (missingok?)
256 %{__rm} -r $RPM_BUILD_ROOT%{_sysconfdir}/systemd/system/*.target.wants
257
258 # do not cover /var/run until packages need rpm-provided-only subdirectories
259 %{__rm} $RPM_BUILD_ROOT/lib/systemd/system/local-fs.target.wants/var-run.mount
260
261 # it is in rc-scripts pkg
262 %{__rm} $RPM_BUILD_ROOT/lib/systemd/system/rc-local.service
263
264 # Make sure these directories are properly owned:
265 #       - halt,kexec,poweroff,reboot: generic ones used by ConsoleKit-systemd,
266 #       - syslog _might_ be used by some syslog implementation (none for now),
267 #       - isn't dbus populated by dbus-systemd only (so to be moved there)?
268 install -d $RPM_BUILD_ROOT/lib/systemd/system/{dbus,halt,kexec,poweroff,reboot,syslog}.target.wants
269
270 # Create new-style configuration files so that we can ghost-own them
271 touch $RPM_BUILD_ROOT%{_sysconfdir}/{hostname,locale.conf,machine-id,machine-info,os-release,timezone,vconsole.conf}
272
273 # Install SysV conversion tool for systemd
274 install -p %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}
275
276 install -d $RPM_BUILD_ROOT/var/log
277 :> $RPM_BUILD_ROOT/var/log/btmp
278 :> $RPM_BUILD_ROOT/var/log/wtmp
279
280 %if %{without gtk}
281 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/systemadm.1*
282 %endif
283
284 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
285 %{__rm} $RPM_BUILD_ROOT/%{_lib}/security/pam_systemd.la
286 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
287
288 %clean
289 rm -rf $RPM_BUILD_ROOT
290
291 %post
292 /bin/systemd-machine-id-setup > /dev/null 2>&1 || :
293 /bin/systemctl daemon-reexec > /dev/null 2>&1 || :
294
295 %postun
296 if [ $1 -ge 1 ]; then
297         /bin/systemctl try-restart systemd-logind.service >/dev/null 2>&1 || :
298 fi
299
300 %post   libs -p /sbin/ldconfig
301 %postun libs -p /sbin/ldconfig
302
303 %post units
304 if [ $1 -eq 1 ]; then
305         # Try to read default runlevel from the old inittab if it exists
306         runlevel=$(/bin/awk -F ':' '$3 == "initdefault" && $1 !~ "^#" { print $2 }' /etc/inittab 2> /dev/null)
307         if [ -z "$runlevel" ] ; then
308                 target="/lib/systemd/system/graphical.target"
309         else
310                 target="/lib/systemd/system/runlevel$runlevel.target"
311         fi
312
313         # And symlink what we found to the new-style default.target
314         ln -s "$target" %{_sysconfdir}/systemd/system/default.target >/dev/null 2>&1 || :
315
316         # Setup hostname
317         [ -f /etc/sysconfig/network ] && . /etc/sysconfig/network
318         if [ -n "$HOSTNAME" -a "$HOSTNAME" != "pldmachine" ]; then
319                 [ -f /etc/hostname ] && mv -f /etc/hostname /etc/hostname.rpmsave
320                 echo $HOSTNAME > /etc/hostname
321                 chmod 644 /etc/hostname
322         fi
323 fi
324 # Enable the services we install by default.
325 /bin/systemctl enable \
326         getty@.service \
327         network.service \
328         network-post.service \
329         remote-fs.target \
330         systemd-readahead-replay.service \
331         systemd-readahead-collect.service >/dev/null 2>&1 || :
332
333 # Find and enable all installed interfaces
334 mkdir -p %{_sysconfdir}/systemd/system/network.target.wants >/dev/null 2>&1 || :
335 for f in /etc/sysconfig/interfaces/ifcfg-* ; do
336         ff=$(basename $f)
337         ff=${ff##ifcfg-}
338         case "$ff" in
339         *.rpmorig|*.rpmnew|*.rpmsave|*~|*.orig)
340                 continue
341                 ;;
342         *)
343                 DEVICE="" ; ONBOOT="" ; USERS=""
344                 . $f 2>/dev/null
345                 [ ${USERS:-no} != no ] && continue
346                 if [ "$DEVICE" = "$ff" -a ${ONBOOT:-no} = "yes" ]; then
347                         ln -s /lib/systemd/system/ifup@.service \
348                                 %{_sysconfdir}/systemd/system/network.target.wants/ifcfg@$ff.service >/dev/null 2>&1 || :
349                 fi
350                 ;;
351         esac
352 done
353
354 %preun units
355 if [ $1 -eq 0 ] ; then
356         /bin/systemctl disable \
357                 getty@.service \
358                 network.service \
359                 network-post.service \
360                 remote-fs.target \
361                 systemd-readahead-replay.service \
362                 systemd-readahead-collect.service >/dev/null 2>&1 || :
363
364         %{__rm} -f %{_sysconfdir}/systemd/system/default.target >/dev/null 2>&1 || :
365         %{__rm} -f %{_sysconfdir}/systemd/system/network.target.wants/ifcfg@*.service >/dev/null 2>&1 || :
366 fi
367
368 %postun units
369 if [ $1 -ge 1 ]; then
370         /bin/systemctl daemon-reload > /dev/null 2>&1 || :
371 fi
372
373 %files
374 %defattr(644,root,root,755)
375 %doc DISTRO_PORTING README TODO
376 /etc/dbus-1/system.d/org.freedesktop.hostname1.conf
377 /etc/dbus-1/system.d/org.freedesktop.locale1.conf
378 /etc/dbus-1/system.d/org.freedesktop.login1.conf
379 /etc/dbus-1/system.d/org.freedesktop.systemd1.conf
380 /etc/dbus-1/system.d/org.freedesktop.timedate1.conf
381 %ghost %config(noreplace) %{_sysconfdir}/machine-id
382 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hostname
383 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/locale.conf
384 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/machine-info
385 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/os-release
386 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/timezone
387 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/vconsole.conf
388 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/systemd/*.conf
389 %dir %{_sysconfdir}/systemd/user
390 /etc/xdg/systemd
391 %attr(755,root,root) /bin/systemd
392 %attr(755,root,root) /bin/systemd-ask-password
393 %attr(755,root,root) /bin/systemd-journalctl
394 %attr(755,root,root) /bin/systemd-loginctl
395 %attr(755,root,root) /bin/systemd-machine-id-setup
396 %attr(755,root,root) /bin/systemd-notify
397 %attr(755,root,root) /bin/systemd-tty-ask-password-agent
398 %attr(755,root,root) %{_bindir}/systemd-analyze
399 %attr(755,root,root) %{_bindir}/systemd-cgls
400 %attr(755,root,root) %{_bindir}/systemd-nspawn
401 %attr(755,root,root) %{_bindir}/systemd-stdio-bridge
402 %attr(755,root,root) %{_bindir}/systemd-sysv-convert
403 %attr(755,root,root) /lib/systemd/systemd-*
404 %dir /lib/systemd/system-generators
405 %attr(755,root,root) /lib/systemd/system-generators/systemd-*-generator
406 %dir /lib/systemd/system-shutdown
407 /lib/udev/rules.d/99-systemd.rules
408 /lib/udev/rules.d/70-uaccess.rules
409 /lib/udev/rules.d/71-seat.rules
410 /lib/udev/rules.d/73-seat-late.rules
411 %dir %{_libexecdir}/systemd
412 %{_libexecdir}/systemd/user
413 %dir %{_libexecdir}/systemd/user-generators
414 %config(noreplace,missingok) %{_libexecdir}/tmpfiles.d/*.conf
415 %{_datadir}/dbus-1/interfaces/org.freedesktop.hostname1.xml
416 %{_datadir}/dbus-1/interfaces/org.freedesktop.locale1.xml
417 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.*.xml
418 %{_datadir}/dbus-1/interfaces/org.freedesktop.timedate1.xml
419 %{_datadir}/dbus-1/services/org.freedesktop.systemd1.service
420 %{_datadir}/dbus-1/system-services/org.freedesktop.hostname1.service
421 %{_datadir}/dbus-1/system-services/org.freedesktop.locale1.service
422 %{_datadir}/dbus-1/system-services/org.freedesktop.login1.service
423 %{_datadir}/dbus-1/system-services/org.freedesktop.systemd1.service
424 %{_datadir}/dbus-1/system-services/org.freedesktop.timedate1.service
425 %{_datadir}/polkit-1/actions/org.freedesktop.hostname1.policy
426 %{_datadir}/polkit-1/actions/org.freedesktop.locale1.policy
427 %{_datadir}/polkit-1/actions/org.freedesktop.login1.policy
428 %{_datadir}/polkit-1/actions/org.freedesktop.systemd1.policy
429 %{_datadir}/polkit-1/actions/org.freedesktop.timedate1.policy
430 %dir %{_datadir}/systemd
431 %{_datadir}/systemd/kbd-model-map
432 %{_mandir}/man1/systemd.1*
433 %{_mandir}/man1/systemd-*.1*
434 %{_mandir}/man3/sd_booted.3*
435 %{_mandir}/man3/sd_is_fifo.3*
436 %{_mandir}/man3/sd_is_socket.3
437 %{_mandir}/man3/sd_is_socket_inet.3
438 %{_mandir}/man3/sd_is_socket_unix.3
439 %{_mandir}/man3/sd_listen_fds.3*
440 %{_mandir}/man3/sd_notify.3*
441 %{_mandir}/man3/sd_notifyf.3
442 %{_mandir}/man3/sd_readahead.3*
443 %{_mandir}/man5/binfmt.d.5*
444 %{_mandir}/man5/hostname.5*
445 %{_mandir}/man5/locale.conf.5*
446 %{_mandir}/man5/machine-id.5*
447 %{_mandir}/man5/machine-info.5*
448 %{_mandir}/man5/modules-load.d.5*
449 %{_mandir}/man5/os-release.5*
450 %{_mandir}/man5/sysctl.d.5*
451 %{_mandir}/man5/systemd.*.5*
452 %{_mandir}/man5/systemd-logind.conf.5*
453 %{_mandir}/man5/timezone.5*
454 %{_mandir}/man5/vconsole.conf.5*
455 %{_mandir}/man7/daemon.7*
456 %{_mandir}/man7/sd-daemon.7*
457 %{_mandir}/man7/sd-login.7*
458 %{_mandir}/man7/sd-readahead.7*
459 %{_mandir}/man7/systemd.special.7*
460 %attr(640,root,root) %ghost /var/log/btmp
461 %attr(664,root,utmp) %ghost /var/log/wtmp
462
463 %if %{with pam}
464 %attr(755,root,root) /%{_lib}/security/pam_systemd.so
465 %{_mandir}/man8/pam_systemd.8*
466 %endif
467
468 %files init
469 %defattr(644,root,root,755)
470 %attr(755,root,root) /sbin/halt
471 %attr(755,root,root) /sbin/init
472 %attr(755,root,root) /sbin/poweroff
473 %attr(755,root,root) /sbin/reboot
474 %attr(755,root,root) /sbin/runlevel
475 %attr(755,root,root) /sbin/shutdown
476 %attr(755,root,root) /sbin/telinit
477 %{_mandir}/man1/init.1
478 %{_mandir}/man8/halt.8*
479 %{_mandir}/man8/poweroff.8
480 %{_mandir}/man8/reboot.8
481 %{_mandir}/man8/runlevel.8*
482 %{_mandir}/man8/shutdown.8*
483 %{_mandir}/man8/telinit.8*
484
485 %files units
486 %defattr(644,root,root,755)
487 %dir %{_sysconfdir}/binfmt.d
488 %dir %{_sysconfdir}/modules-load.d
489 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/modules-load.d/modules.conf
490 %dir %{_sysconfdir}/sysctl.d
491 %dir %{_sysconfdir}/systemd
492 %dir %{_sysconfdir}/systemd/system
493 %dir %{_sysconfdir}/tmpfiles.d
494 %config(noreplace,missingok) %{_sysconfdir}/tmpfiles.d/*.conf
495 %dir %{_libexecdir}/binfmt.d
496 %dir %{_libexecdir}/modules-load.d
497 %dir %{_libexecdir}/sysctl.d
498 %attr(755,root,root) /bin/systemctl
499 %attr(755,root,root) /bin/systemd-tmpfiles
500 %attr(755,root,root) /bin/systemd_booted
501 %{_mandir}/man1/systemctl.1*
502 %{_mandir}/man5/tmpfiles.d.5*
503 %{_mandir}/man8/systemd-tmpfiles.8*
504 %{_npkgconfigdir}/systemd.pc
505
506 /lib/systemd/system/*.automount
507 /lib/systemd/system/*.mount
508 /lib/systemd/system/*.path
509 /lib/systemd/system/*.service
510 /lib/systemd/system/*.socket
511 /lib/systemd/system/*.target
512 /lib/systemd/system/*.timer
513 %dir /lib/systemd/system/*.wants
514 %config(noreplace,missingok) /lib/systemd/system/*.wants/*
515
516 %if %{with gtk}
517 %files gtk
518 %defattr(644,root,root,755)
519 %attr(755,root,root) %{_bindir}/systemadm
520 %attr(755,root,root) %{_bindir}/systemd-gnome-ask-password-agent
521 %{_mandir}/man1/systemadm.1*
522 %endif
523
524 %files libs
525 %defattr(644,root,root,755)
526 %attr(755,root,root) /%{_lib}/libsystemd-daemon.so.*.*.*
527 %attr(755,root,root) %ghost /%{_lib}/libsystemd-daemon.so.0
528 %attr(755,root,root) /%{_lib}/libsystemd-id128.so.*.*.*
529 %attr(755,root,root) %ghost /%{_lib}/libsystemd-id128.so.0
530 %attr(755,root,root) /%{_lib}/libsystemd-journal.so.*.*.*
531 %attr(755,root,root) %ghost /%{_lib}/libsystemd-journal.so.0
532 %attr(755,root,root) /%{_lib}/libsystemd-login.so.*.*.*
533 %attr(755,root,root) %ghost /%{_lib}/libsystemd-login.so.0
534
535 %files devel
536 %defattr(644,root,root,755)
537 %attr(755,root,root) %{_libdir}/libsystemd-daemon.so
538 %attr(755,root,root) %{_libdir}/libsystemd-id128.so
539 %attr(755,root,root) %{_libdir}/libsystemd-journal.so
540 %attr(755,root,root) %{_libdir}/libsystemd-login.so
541 %{_includedir}/%{name}
542 %{_pkgconfigdir}/libsystemd-daemon.pc
543 %{_pkgconfigdir}/libsystemd-id128.pc
544 %{_pkgconfigdir}/libsystemd-journal.pc
545 %{_pkgconfigdir}/libsystemd-login.pc
546 %{_mandir}/man3/sd_get_seats.3*
547 %{_mandir}/man3/sd_get_sessions.3*
548 %{_mandir}/man3/sd_get_uids.3*
549 %{_mandir}/man3/sd_is_mq.3*
550 %{_mandir}/man3/sd_login_monitor_flush.3*
551 %{_mandir}/man3/sd_login_monitor_get_fd.3*
552 %{_mandir}/man3/sd_login_monitor_new.3*
553 %{_mandir}/man3/sd_login_monitor_unref.3*
554 %{_mandir}/man3/sd_pid_get_owner_uid.3*
555 %{_mandir}/man3/sd_pid_get_session.3*
556 %{_mandir}/man3/sd_pid_get_unit.3*
557 %{_mandir}/man3/sd_seat_can_multi_session.3*
558 %{_mandir}/man3/sd_seat_get_active.3*
559 %{_mandir}/man3/sd_seat_get_sessions.3*
560 %{_mandir}/man3/sd_session_get_seat.3*
561 %{_mandir}/man3/sd_session_get_uid.3*
562 %{_mandir}/man3/sd_session_is_active.3*
563 %{_mandir}/man3/sd_uid_get_seats.3*
564 %{_mandir}/man3/sd_uid_get_sessions.3*
565 %{_mandir}/man3/sd_uid_get_state.3*
566 %{_mandir}/man3/sd_uid_is_on_seat.3*
567
568 %files -n bash-completion-systemd
569 %defattr(644,root,root,755)
570 /etc/bash_completion.d/systemd-bash-completion.sh
This page took 0.073977 seconds and 4 git commands to generate.