]> git.pld-linux.org Git - packages/systemd.git/blob - systemd.spec
- rel 14
[packages/systemd.git] / systemd.spec
1 # TODO:
2 #       - remove compat-pld-var-run.tmpfiles and maybe tmpfiles-not-fatal.patch
3 #         after enough packages provide their own tmpfiles.d configs for
4 #         /var/run directories
5 # - pldize vconsole setup:
6 #   - http://cgit.freedesktop.org/systemd/systemd/tree/src/vconsole/vconsole-setup.c
7 # - for systemd-45+
8 #   - restore var-{run,lock}: http://cgit.freedesktop.org/systemd/systemd/commit/?id=55d029addf7d97b15faacea597a4ff65542aaf0e
9 #   - WARNING: http://cgit.freedesktop.org/systemd/systemd/commit/?id=623ac9d2fce3170125ead9be20f56bfe68ea125e
10 #
11 # Conditional build:
12 %bcond_without  audit           # without audit support
13 %bcond_without  cryptsetup      # without cryptsetup support
14 %bcond_without  pam             # PAM authentication support
15 %bcond_without  plymouth        # do not install plymouth units
16 %bcond_without  selinux         # without SELinux support
17 %bcond_without  tcpd            # libwrap (tcp_wrappers) support
18
19 Summary:        A System and Service Manager
20 Summary(pl.UTF-8):      systemd - zarządca systemu i usług dla Linuksa
21 Name:           systemd
22 Version:        44
23 Release:        14
24 License:        GPL v2+
25 Group:          Base
26 Source0:        http://www.freedesktop.org/software/systemd/%{name}-%{version}.tar.xz
27 # Source0-md5:  11f44ff74c87850064e4351518bcff17
28 Source1:        %{name}-sysv-convert
29 Source2:        %{name}_booted.c
30 Source3:        network.service
31 Source5:        compat-pld-var-run.tmpfiles
32 Source10:       pld-storage-init-late.service
33 Source11:       pld-storage-init.service
34 Source12:       pld-wait-storage.service
35 Source13:       pld-storage-init.sh
36 Source14:       pld-clean-tmp.service
37 Source15:       pld-clean-tmp.sh
38 Patch0:         target-pld.patch
39 Patch1:         config-pld.patch
40 Patch2:         shut-sysv-up.patch
41 Patch3:         pld-sysv-network.patch
42 Patch4:         tmpfiles-not-fatal.patch
43 Patch5:         CVE-2012-1174.patch
44 Patch6:         ReleaseSession.patch
45 Patch7:         control-subcgroup.patch
46 Patch8:         kmsg-to-syslog.patch
47 URL:            http://www.freedesktop.org/wiki/Software/systemd
48 BuildRequires:  acl-devel
49 %{?with_audit:BuildRequires:    audit-libs-devel}
50 BuildRequires:  autoconf >= 2.63
51 BuildRequires:  automake >= 1:1.11
52 BuildRequires:  binutils >= 3:2.22.52.0.1-2
53 %{?with_cryptsetup:BuildRequires:       cryptsetup-luks-devel}
54 BuildRequires:  dbus-devel >= 1.3.2
55 BuildRequires:  docbook-style-xsl
56 BuildRequires:  gperf
57 BuildRequires:  intltool >= 0.40.0
58 BuildRequires:  kmod-devel >= 5
59 BuildRequires:  libcap-devel
60 %{?with_selinux:BuildRequires:  libselinux-devel >= 2.1.0}
61 BuildRequires:  libtool >= 2:2.2
62 %{?with_tcpd:BuildRequires:     libwrap-devel}
63 BuildRequires:  libxslt-progs
64 BuildRequires:  m4
65 %{?with_pam:BuildRequires:      pam-devel}
66 BuildRequires:  pkgconfig >= 0.9.0
67 BuildRequires:  rpmbuild(macros) >= 1.627
68 BuildRequires:  udev-devel >= 1:172
69 BuildRequires:  xz-devel
70 Requires:       %{name}-libs = %{version}-%{release}
71 Requires:       %{name}-units = %{version}-%{release}
72 Requires:       /etc/os-release
73 Requires:       SysVinit-tools
74 Requires:       agetty
75 Requires:       dbus >= 1.4.16-6
76 Requires:       filesystem >= 4.0-2
77 Requires:       libutempter
78 Requires:       rc-scripts >= 0.4.5.3-7
79 Requires:       setup >= 2.8.0-2
80 Requires:       udev-core >= 1:175-5
81 Requires:       udev-libs >= 1:172
82 Requires:       virtual(module-tools)
83 Suggests:       %{name}-no-compat-tmpfiles
84 Suggests:       ConsoleKit
85 Suggests:       fsck >= 2.20
86 Suggests:       kmod >= 5
87 Suggests:       nss_myhostname
88 Suggests:       service(klogd)
89 Suggests:       service(syslog)
90 Provides:       udev-acl
91 # systemd takes care of that and causes problems
92 Conflicts:      binfmt-detector
93 # sytemd wants pam with pam_systemd.so in system-auth...
94 Conflicts:      pam < 1:1.1.5-5
95 # ...and sudo hates it
96 Conflicts:      sudo < 1:1.7.8p2-4
97 # for prefdm script
98 Conflicts:      xinitrc-ng < 1.0
99 # systemd scripts use options not present in older versions
100 Conflicts:      kpartx < 0.4.9-7
101 Conflicts:      multipath-tools < 0.4.9-7
102 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
103
104 %define         _libexecdir     %{_prefix}/lib
105
106 %description
107 systemd is a system and service manager for Linux, compatible with
108 SysV and LSB init scripts. systemd provides aggressive parallelization
109 capabilities, uses socket and D-Bus activation for starting services,
110 offers on-demand starting of daemons, keeps track of processes using
111 Linux cgroups, supports snapshotting and restoring of the system
112 state, maintains mount and automount points and implements an
113 elaborate transactional dependency-based service control logic. It can
114 work as a drop-in replacement for sysvinit.
115
116 %description -l pl.UTF-8
117 systemd jest zarządcą systemu i usług dla Linuksa, kompatybilny ze
118 skryptami SysV i LSB. systemd udostępnia rozbudowane zdolności
119 paralelizacji, do uruchamiania usług używa socketów oraz D-Busa,
120 oferuje uruchamianie usług na życzenie, monitoruje procesy używając
121 linuksowych cgroups, wspomaga zapisywanie (snapshot) i odczytywanie
122 (restore) stanu systemu, zarządza (auto)mount pointami oraz
123 implementuje starannie opracowaną transakcjonalną, bazującą na
124 zależnościach logikę kontroli usług. Może pracować jako zastępca dla
125 sysvinit.
126
127 %package init
128 Summary:        systemd /sbin/init and LSB/SysV compatibility symlinks
129 Summary(pl.UTF-8):      /sbin/init z systemd i dowiązania dla kompatybilności z LSB/SysV
130 Group:          Base
131 Requires:       systemd
132 Provides:       readahead = 1:1.5.7-3
133 Provides:       virtual(init-daemon)
134 Obsoletes:      SysVinit
135 Obsoletes:      readahead < 1:1.5.7-3
136 Obsoletes:      virtual(init-daemon)
137 Conflicts:      upstart
138
139 %description init
140 Install this package when you are ready to final switch to systemd.
141
142 %description init -l pl.UTF-8
143 Ten pakiet należy zainstalować po przygotowaniu się do ostatecznego
144 przejścia na systemd.
145
146 %package units
147 Summary:        Configuration files, directories and installation tool for systemd
148 Summary(pl.UTF-8):      Pliki konfiguracyjne, katalogi i narzędzie instalacyjne dla systemd
149 Group:          Base
150 Requires(post): coreutils
151 Requires(post): /bin/awk
152
153 %description units
154 Basic configuration files, directories and installation tool for the
155 systemd system and service manager.
156
157 This is common config, use %{_sysconfdir}/systemd/system to override.
158
159 %description units -l pl.UTF-8
160 Podstawowe pliki konfiguracyjne, katalogi i narzędzie instalacyjne dla
161 zarządcy systemu i usług systemd.
162
163 Ten pakiet zawiera ogólną konfigurację, ustawienia można nadpisać
164 poprzez katalog %{_sysconfdir}/systemd/system.
165
166 %package plymouth
167 Summary:        Plymouth support units for systemd
168 Summary(pl.UTF-8):      Jednostki wspierające Plymouth dla systemd
169 Group:          Base
170 Requires:       %{name}-units = %{version}-%{release}
171 Requires:       plymouth
172
173 %description plymouth
174 Plymouth (graphical boot) support units for systemd.
175
176 %description plymouth -l pl.UTF-8
177 Jednostki wspierające Plymouth (graficzny start systemu) dla systemd.
178
179 %package analyze
180 Summary:        Tool for processing systemd profiling information
181 Group:          Base
182 Requires:       %{name} = %{version}-%{release}
183 Requires:       python-dbus
184 Requires:       python-modules
185 Requires:       python-pycairo
186 Conflicts:      %{name} < 44-3
187
188 %description analyze
189 'systemd-analyze blame' lists which systemd unit needed how much time
190 to finish initialization at boot. 'systemd-analyze plot' renders an
191 SVG visualizing the parallel start of units at boot.
192
193 %package libs
194 Summary:        Shared systemd libraries
195 Summary(pl.UTF-8):      Biblioteki współdzielone systemd
196 Group:          Libraries
197
198 %description libs
199 Shared systemd libraries.
200
201 %description libs -l pl.UTF-8
202 Biblioteki współdzielone systemd.
203
204 %package devel
205 Summary:        Header files for systemd libraries
206 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek systemd
207 Group:          Development/Libraries
208 Requires:       %{name}-libs = %{version}-%{release}
209
210 %description devel
211 Header files for systemd libraries.
212
213 %description devel -l pl.UTF-8
214 Pliki nagłówkowe bibliotek systemd.
215
216 %package -n bash-completion-systemd
217 Summary:        bash-completion for systemd
218 Summary(pl.UTF-8):      Bashowe dopełnianie składni dla systemd
219 Group:          Applications/Shells
220 Requires:       %{name} = %{version}
221 Requires:       bash-completion
222
223 %description -n bash-completion-systemd
224 bash-completion for systemd.
225
226 %description -n bash-completion-systemd -l pl.UTF-8
227 Bashowe dopełnianie składni dla systemd
228
229 %package no-compat-tmpfiles
230 Summary:        Force update of packages that provide tmpfiles.d configuration
231 Group:          Base
232 Requires:       %{name} = %{version}-%{release}
233 Requires(post): sed > 4.0
234 Conflicts:      ConsoleKit-dirs < 0.4.5-7
235 Conflicts:      NetworkManager < 2:0.9.2.0-3
236 Conflicts:      Zope < 2.11.8-2
237 Conflicts:      amavisd-new < 1:2.7.0-1
238 Conflicts:      apache-base < 2.2.21-4
239 Conflicts:      apache-mod_bw < 0.92-3
240 Conflicts:      apache-mod_fastcgi < 2.4.6-6
241 Conflicts:      apache1-base < 1.3.42-5
242 Conflicts:      apache1-mod_fastcgi < 2.4.6-2
243 Conflicts:      asterisk < 10.0.1-2
244 Conflicts:      autossh-init < 1.4b-3
245 Conflicts:      balance < 3.54-2
246 Conflicts:      bind < 7:9.8.1.P1-4
247 Conflicts:      bopm < 3.1.3-4
248 Conflicts:      callweaver < 1.2.1-9
249 Conflicts:      cassandra-bin < 0.8.9-2
250 Conflicts:      clamav < 0.97.3-3
251 Conflicts:      cups < 1:1.5.0-10
252 Conflicts:      dbus < 1.4.16-4
253 Conflicts:      dovecot < 1:2.0.16-3
254 Conflicts:      dspam < 3.9.0-6
255 Conflicts:      fail2ban < 0.8.4-4
256 Conflicts:      filesystem < 4.0-3
257 Conflicts:      gammu-smsd < 1:1.31.0-3
258 # Break gdm2.20 installs
259 #Conflicts:     gdm < 2:3.2.1.1-9
260 Conflicts:      greylistd < 0.8.8-2
261 Conflicts:      inn < 2.4.6-7
262 Conflicts:      ipsec-tools < 0.8.0-3
263 Conflicts:      jabber-common < 0-9
264 Conflicts:      laptop-mode-tools < 1.58-2
265 Conflicts:      libgpod < 0.8.0-6
266 Conflicts:      libvirt-utils < 0.9.9-4
267 Conflicts:      lighttpd < 1.4.30-5
268 Conflicts:      lirc < 0.9.0-20
269 Conflicts:      mailman < 5:2.1.14-4
270 Conflicts:      memcached < 1.4.11-2
271 Conflicts:      mpd < 0.16.5-4
272 Conflicts:      mrtg < 2.17.0-3
273 Conflicts:      munin-common < 1.4.5-5
274 Conflicts:      nagios-nrpe < 2.13-2
275 Conflicts:      ndisc6-rdnssd < 1.0.1-3
276 Conflicts:      nscd < 6:2.14.1-5
277 Conflicts:      nss_ldapd-nslcd < 0.8.4-2
278 Conflicts:      openct < 0.6.20-3
279 Conflicts:      openl2tp < 1.8-3
280 Conflicts:      openldap-overlay-nssov < 2.4.28-4
281 Conflicts:      openldap-servers < 2.4.28-4
282 Conflicts:      openvpn < 2.2.2-2
283 Conflicts:      pam-pam_mount < 2.12-3
284 Conflicts:      pam-pam_ssh < 1.97-2
285 Conflicts:      pcsc-lite < 1.8.1-2
286 Conflicts:      php-dirs < 1.2-3
287 Conflicts:      policyd < 2.0.10-3
288 Conflicts:      pound < 2.6-2
289 Conflicts:      pptp < 1.7.2-3
290 Conflicts:      proftpd-common < 2:1.3.4a-2
291 Conflicts:      pulseaudio-server < 1.1-2
292 Conflicts:      quagga < 0.99.20-3
293 Conflicts:      radvd < 1.8.5-2
294 Conflicts:      rc-scripts < 0.4.5.2-3
295 Conflicts:      red5 < 0.9.0-2
296 Conflicts:      redis-server < 2.4.2-4
297 Conflicts:      smokeping < 2.4.2-10
298 Conflicts:      smtp-gated < 1.4.17-2
299 Conflicts:      socat < 1.7.2.0-2
300 Conflicts:      speech-dispatcher < 0.7.1-2
301 Conflicts:      sphinx < 2.0.3-4
302 Conflicts:      splashutils < 1.5.4.3-3
303 Conflicts:      stunnel < 4.50-2
304 Conflicts:      tenshi < 0.12-2
305 Conflicts:      tor < 0.2.2.35-2
306 Conflicts:      ucarp < 1.5.2-3
307 Conflicts:      udisks < 1.0.4-3
308 Conflicts:      util-vserver < 0.30.216-1.pre3002.3
309 Conflicts:      vpnc < 0.5.3-2
310 Conflicts:      web2ldap < 1.1.0rc1-2
311 Conflicts:      wesnoth-server < 1:1.10-2
312 Conflicts:      wpa_supplicant < 0.7.3-10
313 Conflicts:      xl2tpd < 1.3.0-2
314
315 %description no-compat-tmpfiles
316 Force update of packages that provide tmpfiles.d configuration
317
318 %prep
319 %setup -q
320 %patch0 -p1
321 %patch1 -p1
322 %patch2 -p1
323 %patch3 -p1
324 %patch4 -p1
325 %patch5 -p1
326 %patch6 -p1
327 %patch7 -p1
328 %patch8 -p1
329 cp -p %{SOURCE2} src/systemd_booted.c
330
331 %build
332 %{__aclocal} -I m4
333 %{__autoconf}
334 %{__autoheader}
335 %{__automake}
336 %configure \
337         %{__enable_disable audit} \
338         %{__enable_disable cryptsetup libcryptsetup} \
339         --disable-gtk \
340         %{__enable_disable pam} \
341         %{__enable_disable plymouth} \
342         %{__enable_disable selinux} \
343         %{__enable_disable tcpd tcpwrap} \
344         --disable-silent-rules \
345         --disable-static \
346         --with-distro=pld \
347         --with-rootprefix= \
348         --with-rootlibdir=/%{_lib} \
349         --enable-split-usr
350
351 %{__make}
352 ./libtool --mode=link --tag=CC %{__cc} %{rpmcppflags} %{rpmcflags} -o systemd_booted %{rpmldflags} src/systemd_booted.c -L. -lsystemd-daemon
353
354 %install
355 rm -rf $RPM_BUILD_ROOT
356 install -d $RPM_BUILD_ROOT/var/lib/%{name}/coredump
357
358 %{__make} install \
359         DESTDIR=$RPM_BUILD_ROOT
360
361 ./libtool --mode=install install -p -m755 systemd_booted $RPM_BUILD_ROOT/bin/systemd_booted
362
363 # Main binary has been moved, but we don't want to break existing installs
364 ln -s ../lib/systemd/systemd $RPM_BUILD_ROOT/bin/systemd
365
366 # Create SysV compatibility symlinks. systemctl/systemd are smart
367 # enough to detect the way they were called
368 install -d $RPM_BUILD_ROOT/sbin
369 ln -s ../lib/systemd/systemd $RPM_BUILD_ROOT/sbin/init
370 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/halt
371 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/poweroff
372 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/reboot
373 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/runlevel
374 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/shutdown
375 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/telinit
376
377 ln -s ../modules $RPM_BUILD_ROOT%{_sysconfdir}/modules-load.d/modules.conf
378
379 # disable redundant SYSV services
380 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/allowlogin.service
381 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/console.service
382 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/cpusets.service
383 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/killall.service
384 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/netfs.service
385 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/random.service
386
387 # add static (non-NetworkManager) networking
388 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{systemdunitdir}/network.service
389
390 # install compatibility tmpfiles configs
391 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/compat-pld-var-run.conf
392
393 # Install and enable storage subsystems support services (RAID, LVM, etc.)
394 cp -p %{SOURCE10} $RPM_BUILD_ROOT%{systemdunitdir}/pld-storage-init-late.service
395 cp -p %{SOURCE11} $RPM_BUILD_ROOT%{systemdunitdir}/pld-storage-init.service
396 cp -p %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/pld-wait-storage.service
397 cp -p %{SOURCE14} $RPM_BUILD_ROOT%{systemdunitdir}/pld-clean-tmp.service
398 install -p %{SOURCE13} $RPM_BUILD_ROOT/lib/systemd/pld-storage-init
399 install -p %{SOURCE15} $RPM_BUILD_ROOT/lib/systemd/pld-clean-tmp
400
401 ln -s ../pld-storage-init-late.service $RPM_BUILD_ROOT%{systemdunitdir}/local-fs.target.wants
402 ln -s ../pld-storage-init.service $RPM_BUILD_ROOT%{systemdunitdir}/local-fs.target.wants
403 ln -s ../pld-clean-tmp.service $RPM_BUILD_ROOT%{systemdunitdir}/local-fs.target.wants
404
405 # handled by rc-local sysv service, no need for generator
406 %{__rm} $RPM_BUILD_ROOT/lib/systemd/system-generators/systemd-rc-local-generator
407
408 # Make sure these directories are properly owned:
409 #       - halt,kexec,poweroff,reboot: generic ones used by ConsoleKit-systemd,
410 #       - syslog _might_ be used by some syslog implementation (none for now),
411 #       - isn't dbus populated by dbus-systemd only (so to be moved there)?
412 install -d $RPM_BUILD_ROOT%{systemdunitdir}/{dbus,halt,kexec,poweroff,reboot,syslog}.target.wants
413
414 # Create new-style configuration files so that we can ghost-own them
415 touch $RPM_BUILD_ROOT%{_sysconfdir}/{hostname,locale.conf,machine-id,machine-info,timezone,vconsole.conf}
416
417 # Install SysV conversion tool for systemd
418 install -p %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}
419
420 install -d $RPM_BUILD_ROOT/var/log
421 :> $RPM_BUILD_ROOT/var/log/btmp
422 :> $RPM_BUILD_ROOT/var/log/wtmp
423
424 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/systemadm.1*
425
426 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
427 %{__rm} $RPM_BUILD_ROOT/%{_lib}/security/pam_systemd.la
428 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
429
430 %clean
431 rm -rf $RPM_BUILD_ROOT
432
433 %post
434 /bin/systemd-machine-id-setup > /dev/null 2>&1 || :
435 /bin/systemctl daemon-reexec > /dev/null 2>&1 || :
436
437 %postun
438 if [ $1 -ge 1 ]; then
439         /bin/systemctl try-restart systemd-logind.service >/dev/null 2>&1 || :
440 fi
441
442 %post   libs -p /sbin/ldconfig
443 %postun libs -p /sbin/ldconfig
444
445 %post units
446 if [ $1 -eq 1 ]; then
447         # Try to read default runlevel from the old inittab if it exists
448         runlevel=$(/bin/awk -F ':' '$3 == "initdefault" && $1 !~ "^#" { print $2 }' /etc/inittab 2> /dev/null)
449         if [ -z "$runlevel" ] ; then
450                 target="%{systemdunitdir}/graphical.target"
451         else
452                 target="%{systemdunitdir}/runlevel$runlevel.target"
453         fi
454
455         # And symlink what we found to the new-style default.target
456         ln -s "$target" %{_sysconfdir}/systemd/system/default.target >/dev/null 2>&1 || :
457
458         # Setup hostname
459         [ -f /etc/sysconfig/network ] && . /etc/sysconfig/network
460         if [ -n "$HOSTNAME" -a "$HOSTNAME" != "pldmachine" ]; then
461                 [ -f /etc/hostname ] && mv -f /etc/hostname /etc/hostname.rpmsave
462                 echo $HOSTNAME > /etc/hostname
463                 chmod 644 /etc/hostname
464         fi
465
466         # Enable the services we install by default.
467         /bin/systemctl enable \
468                 getty@.service \
469                 network.service \
470                 remote-fs.target \
471                 systemd-readahead-replay.service \
472                 systemd-readahead-collect.service >/dev/null 2>&1 || :
473 fi
474
475 %preun units
476 if [ $1 -eq 0 ] ; then
477         /bin/systemctl disable \
478                 getty@.service \
479                 network.service \
480                 remote-fs.target \
481                 systemd-readahead-replay.service \
482                 systemd-readahead-collect.service >/dev/null 2>&1 || :
483
484         %{__rm} -f %{_sysconfdir}/systemd/system/default.target >/dev/null 2>&1 || :
485 fi
486
487 %postun units
488 if [ $1 -ge 1 ]; then
489         /bin/systemctl daemon-reload > /dev/null 2>&1 || :
490 fi
491
492 %triggerpostun units -- %{name}-units < 43-7
493 # Remove design fialures
494 rm -f %{_sysconfdir}/systemd/system/network.target.wants/ifcfg@*.service >/dev/null 2>&1 || :
495 rm -f %{_sysconfdir}/systemd/system/network.target.wants/network-post.service >/dev/null 2>&1 || :
496 rm -f %{_sysconfdir}/systemd/system/multi-user.target.wants/network-post.service >/dev/null 2>&1 || :
497 /bin/systemctl reenable network.service >/dev/null 2>&1 || :
498
499 %post no-compat-tmpfiles
500 %{__sed} -i -e '/^#/!s/^/# /g' %{_sysconfdir}/tmpfiles.d/compat-pld-var-run.conf
501
502 %post plymouth
503 %systemd_reload
504
505 %postun plymouth
506 %systemd_reload
507
508 %files
509 %defattr(644,root,root,755)
510 %doc DISTRO_PORTING README TODO
511 /etc/dbus-1/system.d/org.freedesktop.hostname1.conf
512 /etc/dbus-1/system.d/org.freedesktop.locale1.conf
513 /etc/dbus-1/system.d/org.freedesktop.login1.conf
514 /etc/dbus-1/system.d/org.freedesktop.systemd1.conf
515 /etc/dbus-1/system.d/org.freedesktop.timedate1.conf
516 %ghost %config(noreplace) %{_sysconfdir}/machine-id
517 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hostname
518 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/locale.conf
519 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/machine-info
520 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/timezone
521 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/vconsole.conf
522 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/systemd/*.conf
523 %dir %{_sysconfdir}/systemd/user
524 %dir %{_sysconfdir}/systemd/system/*.target.wants
525 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/systemd/system/*.target.wants/*.service
526 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/systemd/system/*.target.wants/*.target
527 /etc/xdg/systemd
528 %attr(755,root,root) /bin/systemd
529 %attr(755,root,root) /bin/systemd-ask-password
530 %attr(755,root,root) /bin/systemd-journalctl
531 %attr(755,root,root) /bin/systemd-loginctl
532 %attr(755,root,root) /bin/systemd-machine-id-setup
533 %attr(755,root,root) /bin/systemd-notify
534 %attr(755,root,root) /bin/systemd-tty-ask-password-agent
535 %attr(755,root,root) %{_bindir}/systemd-cat
536 %attr(755,root,root) %{_bindir}/systemd-cgtop
537 %attr(755,root,root) %{_bindir}/systemd-cgls
538 %attr(755,root,root) %{_bindir}/systemd-nspawn
539 %attr(755,root,root) %{_bindir}/systemd-stdio-bridge
540 %attr(755,root,root) %{_bindir}/systemd-sysv-convert
541 %attr(755,root,root) /lib/systemd/pld-clean-tmp
542 %attr(755,root,root) /lib/systemd/pld-storage-init
543 %attr(755,root,root) /lib/systemd/systemd-*
544 %dir /lib/systemd/system-generators
545 %attr(755,root,root) /lib/systemd/systemd
546 %attr(755,root,root) /lib/systemd/system-generators/systemd-*-generator
547 %dir /lib/systemd/system-shutdown
548 /lib/udev/rules.d/99-systemd.rules
549 /lib/udev/rules.d/70-uaccess.rules
550 /lib/udev/rules.d/71-seat.rules
551 /lib/udev/rules.d/73-seat-late.rules
552 %dir %{_libexecdir}/systemd
553 %{_libexecdir}/systemd/user
554 %dir %{_libexecdir}/systemd/user-generators
555 %config(noreplace,missingok) %{_libexecdir}/tmpfiles.d/*.conf
556 %{_datadir}/dbus-1/interfaces/org.freedesktop.hostname1.xml
557 %{_datadir}/dbus-1/interfaces/org.freedesktop.locale1.xml
558 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.*.xml
559 %{_datadir}/dbus-1/interfaces/org.freedesktop.timedate1.xml
560 %{_datadir}/dbus-1/services/org.freedesktop.systemd1.service
561 %{_datadir}/dbus-1/system-services/org.freedesktop.hostname1.service
562 %{_datadir}/dbus-1/system-services/org.freedesktop.locale1.service
563 %{_datadir}/dbus-1/system-services/org.freedesktop.login1.service
564 %{_datadir}/dbus-1/system-services/org.freedesktop.systemd1.service
565 %{_datadir}/dbus-1/system-services/org.freedesktop.timedate1.service
566 %{_datadir}/polkit-1/actions/org.freedesktop.hostname1.policy
567 %{_datadir}/polkit-1/actions/org.freedesktop.locale1.policy
568 %{_datadir}/polkit-1/actions/org.freedesktop.login1.policy
569 %{_datadir}/polkit-1/actions/org.freedesktop.systemd1.policy
570 %{_datadir}/polkit-1/actions/org.freedesktop.timedate1.policy
571 %dir %{_datadir}/systemd
572 %{_datadir}/systemd/kbd-model-map
573 %{_mandir}/man1/systemd.1*
574 %{_mandir}/man1/systemd-*.1*
575 %{_mandir}/man5/binfmt.d.5*
576 %{_mandir}/man5/hostname.5*
577 %{_mandir}/man5/locale.conf.5*
578 %{_mandir}/man5/machine-id.5*
579 %{_mandir}/man5/machine-info.5*
580 %{_mandir}/man5/modules-load.d.5*
581 %{_mandir}/man5/os-release.5*
582 %{_mandir}/man5/sysctl.d.5*
583 %{_mandir}/man5/systemd.*.5*
584 %{_mandir}/man5/systemd-journald.conf.5*
585 %{_mandir}/man5/systemd-logind.conf.5*
586 %{_mandir}/man5/timezone.5*
587 %{_mandir}/man5/vconsole.conf.5*
588 %{_mandir}/man7/daemon.7*
589 %{_mandir}/man7/sd-daemon.7*
590 %{_mandir}/man7/sd-login.7*
591 %{_mandir}/man7/sd-readahead.7*
592 %{_mandir}/man7/systemd.special.7*
593 %dir /var/lib/%{name}
594 %dir /var/lib/%{name}/coredump
595 %attr(640,root,root) %ghost /var/log/btmp
596 %attr(664,root,utmp) %ghost /var/log/wtmp
597
598 %if %{with pam}
599 %attr(755,root,root) /%{_lib}/security/pam_systemd.so
600 %{_mandir}/man8/pam_systemd.8*
601 %endif
602
603 %files init
604 %defattr(644,root,root,755)
605 %attr(755,root,root) /sbin/halt
606 %attr(755,root,root) /sbin/init
607 %attr(755,root,root) /sbin/poweroff
608 %attr(755,root,root) /sbin/reboot
609 %attr(755,root,root) /sbin/runlevel
610 %attr(755,root,root) /sbin/shutdown
611 %attr(755,root,root) /sbin/telinit
612 %{_mandir}/man1/init.1
613 %{_mandir}/man8/halt.8*
614 %{_mandir}/man8/poweroff.8
615 %{_mandir}/man8/reboot.8
616 %{_mandir}/man8/runlevel.8*
617 %{_mandir}/man8/shutdown.8*
618 %{_mandir}/man8/telinit.8*
619
620 %files units
621 %defattr(644,root,root,755)
622 %dir %{_sysconfdir}/binfmt.d
623 %dir %{_sysconfdir}/modules-load.d
624 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/modules-load.d/modules.conf
625 %dir %{_sysconfdir}/sysctl.d
626 %dir %{_sysconfdir}/systemd
627 %dir %{_sysconfdir}/systemd/system
628 %dir %{_sysconfdir}/tmpfiles.d
629 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/tmpfiles.d/*.conf
630 %dir %{_libexecdir}/binfmt.d
631 %dir %{_libexecdir}/modules-load.d
632 %dir %{_libexecdir}/sysctl.d
633 # Don't package the kernel.core_pattern setting until systemd-coredump
634 # is a part of an actual systemd release and it's made clear how to
635 # get the core dumps out of the journal.
636 #%{_libexecdir}/sysctl.d/coredump.conf
637 %attr(755,root,root) /bin/systemctl
638 %attr(755,root,root) /bin/systemd-tmpfiles
639 %attr(755,root,root) /bin/systemd_booted
640 %{_mandir}/man1/systemctl.1*
641 %{_mandir}/man5/tmpfiles.d.5*
642 %{_mandir}/man8/systemd-tmpfiles.8*
643 %{_npkgconfigdir}/systemd.pc
644
645 %{systemdunitdir}/*.automount
646 %{systemdunitdir}/*.mount
647 %{systemdunitdir}/*.path
648 %{systemdunitdir}/*.service
649 %{systemdunitdir}/*.socket
650 %{systemdunitdir}/*.target
651 %{systemdunitdir}/*.timer
652 %if %{with plymouth}
653 %exclude %{systemdunitdir}/plymouth*.service
654 %exclude %{systemdunitdir}/systemd-ask-password-plymouth.*
655 %endif
656 %dir %{systemdunitdir}/basic.target.wants
657 %dir %{systemdunitdir}/dbus.target.wants
658 %dir %{systemdunitdir}/final.target.wants
659 %dir %{systemdunitdir}/graphical.target.wants
660 %dir %{systemdunitdir}/halt.target.wants
661 %dir %{systemdunitdir}/kexec.target.wants
662 %dir %{systemdunitdir}/local-fs.target.wants
663 %dir %{systemdunitdir}/multi-user.target.wants
664 %dir %{systemdunitdir}/poweroff.target.wants
665 %dir %{systemdunitdir}/reboot.target.wants
666 %dir %{systemdunitdir}/runlevel[12345].target.wants
667 %dir %{systemdunitdir}/shutdown.target.wants
668 %dir %{systemdunitdir}/sockets.target.wants
669 %dir %{systemdunitdir}/sysinit.target.wants
670 %dir %{systemdunitdir}/syslog.target.wants
671 %config(noreplace,missingok) %{systemdunitdir}/basic.target.wants/*
672 %config(noreplace,missingok) %{systemdunitdir}/final.target.wants/*
673 %config(noreplace,missingok) %{systemdunitdir}/graphical.target.wants/*
674 %config(noreplace,missingok) %{systemdunitdir}/local-fs.target.wants/*
675 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/getty.target
676 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/rc-local.service
677 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/systemd-ask-password-wall.path
678 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/systemd-logind.service
679 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/systemd-user-sessions.service
680 %config(noreplace,missingok) %{systemdunitdir}/runlevel[12345].target.wants/*
681 %config(noreplace,missingok) %{systemdunitdir}/shutdown.target.wants/*
682 %config(noreplace,missingok) %{systemdunitdir}/sockets.target.wants/*
683 %{?with_cryptsetup:%config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/cryptsetup.target}
684 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/dev-hugepages.mount
685 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/dev-mqueue.mount
686 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/proc-sys-fs-binfmt_misc.automount
687 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/sys-*.mount
688 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/systemd-*
689
690 %if %{with plymouth}
691 %files plymouth
692 %defattr(644,root,root,755)
693 %{systemdunitdir}/plymouth-halt.service
694 %{systemdunitdir}/plymouth-kexec.service
695 %{systemdunitdir}/plymouth-poweroff.service
696 %{systemdunitdir}/plymouth-quit-wait.service
697 %{systemdunitdir}/plymouth-quit.service
698 %{systemdunitdir}/plymouth-read-write.service
699 %{systemdunitdir}/plymouth-reboot.service
700 %{systemdunitdir}/plymouth-start.service
701 %{systemdunitdir}/systemd-ask-password-plymouth.path
702 %{systemdunitdir}/systemd-ask-password-plymouth.service
703 %config(noreplace,missingok) %{systemdunitdir}/halt.target.wants/plymouth-halt.service
704 %config(noreplace,missingok) %{systemdunitdir}/kexec.target.wants/plymouth-kexec.service
705 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/plymouth-quit.service
706 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/plymouth-quit-wait.service
707 %config(noreplace,missingok) %{systemdunitdir}/poweroff.target.wants/plymouth-poweroff.service
708 %config(noreplace,missingok) %{systemdunitdir}/reboot.target.wants/plymouth-reboot.service
709 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/plymouth-read-write.service
710 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/plymouth-start.service
711 %endif
712
713 %files analyze
714 %defattr(644,root,root,755)
715 %attr(755,root,root) %{_bindir}/systemd-analyze
716
717 %files libs
718 %defattr(644,root,root,755)
719 %attr(755,root,root) /%{_lib}/libsystemd-daemon.so.*.*.*
720 %attr(755,root,root) %ghost /%{_lib}/libsystemd-daemon.so.0
721 %attr(755,root,root) /%{_lib}/libsystemd-id128.so.*.*.*
722 %attr(755,root,root) %ghost /%{_lib}/libsystemd-id128.so.0
723 %attr(755,root,root) /%{_lib}/libsystemd-journal.so.*.*.*
724 %attr(755,root,root) %ghost /%{_lib}/libsystemd-journal.so.0
725 %attr(755,root,root) /%{_lib}/libsystemd-login.so.*.*.*
726 %attr(755,root,root) %ghost /%{_lib}/libsystemd-login.so.0
727
728 %files devel
729 %defattr(644,root,root,755)
730 %attr(755,root,root) %{_libdir}/libsystemd-daemon.so
731 %attr(755,root,root) %{_libdir}/libsystemd-id128.so
732 %attr(755,root,root) %{_libdir}/libsystemd-journal.so
733 %attr(755,root,root) %{_libdir}/libsystemd-login.so
734 %{_includedir}/%{name}
735 %{_pkgconfigdir}/libsystemd-daemon.pc
736 %{_pkgconfigdir}/libsystemd-id128.pc
737 %{_pkgconfigdir}/libsystemd-journal.pc
738 %{_pkgconfigdir}/libsystemd-login.pc
739 %{_mandir}/man3/sd_booted.3*
740 %{_mandir}/man3/sd_get_seats.3*
741 %{_mandir}/man3/sd_get_sessions.3*
742 %{_mandir}/man3/sd_get_uids.3*
743 %{_mandir}/man3/sd_is_fifo.3*
744 %{_mandir}/man3/sd_is_mq.3*
745 %{_mandir}/man3/sd_is_socket.3
746 %{_mandir}/man3/sd_is_socket_inet.3
747 %{_mandir}/man3/sd_is_socket_unix.3
748 %{_mandir}/man3/sd_listen_fds.3*
749 %{_mandir}/man3/sd_login_monitor_flush.3*
750 %{_mandir}/man3/sd_login_monitor_get_fd.3*
751 %{_mandir}/man3/sd_login_monitor_new.3*
752 %{_mandir}/man3/sd_login_monitor_unref.3*
753 %{_mandir}/man3/sd_notify.3*
754 %{_mandir}/man3/sd_notifyf.3
755 %{_mandir}/man3/sd_pid_get_owner_uid.3*
756 %{_mandir}/man3/sd_pid_get_session.3*
757 %{_mandir}/man3/sd_pid_get_unit.3*
758 %{_mandir}/man3/sd_readahead.3*
759 %{_mandir}/man3/sd_seat_can_multi_session.3*
760 %{_mandir}/man3/sd_seat_get_active.3*
761 %{_mandir}/man3/sd_seat_get_sessions.3*
762 %{_mandir}/man3/sd_session_get_class.3*
763 %{_mandir}/man3/sd_session_get_display.3*
764 %{_mandir}/man3/sd_session_get_seat.3*
765 %{_mandir}/man3/sd_session_get_service.3*
766 %{_mandir}/man3/sd_session_get_type.3*
767 %{_mandir}/man3/sd_session_get_uid.3*
768 %{_mandir}/man3/sd_session_is_active.3*
769 %{_mandir}/man3/sd_uid_get_seats.3*
770 %{_mandir}/man3/sd_uid_get_sessions.3*
771 %{_mandir}/man3/sd_uid_get_state.3*
772 %{_mandir}/man3/sd_uid_is_on_seat.3*
773
774 %files -n bash-completion-systemd
775 %defattr(644,root,root,755)
776 /etc/bash_completion.d/systemd-bash-completion.sh
777
778 %files no-compat-tmpfiles
779 %defattr(644,root,root,755)
780 # empty package
This page took 0.085923 seconds and 4 git commands to generate.