]> git.pld-linux.org Git - packages/systemd.git/blob - systemd.spec
- rc-scripts uses rc-local.service now (and masks local), no need to rename here
[packages/systemd.git] / systemd.spec
1 #
2 # TODO:
3 #       - remove compat-pld-var-run.tmpfiles and maybe tmpfiles-not-fatal.patch
4 #         after enough packages provide their own tmpfiles.d configs for
5 #         /var/run directories
6 #
7 # Conditional build:
8 %bcond_without  audit           # without audit support
9 %bcond_without  cryptsetup      # without cryptsetup support
10 %bcond_without  gtk             # build gtk tools
11 %bcond_without  pam             # PAM authentication support
12 %bcond_without  plymouth        # do not install plymouth units
13 %bcond_without  selinux         # without SELinux support
14 %bcond_without  tcpd            # libwrap (tcp_wrappers) support
15
16 Summary:        A System and Service Manager
17 Summary(pl.UTF-8):      systemd - zarządca systemu i usług dla Linuksa
18 Name:           systemd
19 Version:        44
20 Release:        4
21 License:        GPL v2+
22 Group:          Base
23 Source0:        http://www.freedesktop.org/software/systemd/%{name}-%{version}.tar.xz
24 # Source0-md5:  11f44ff74c87850064e4351518bcff17
25 Source1:        %{name}-sysv-convert
26 Source2:        %{name}_booted.c
27 Source3:        network.service
28 Source4:        compat-pld-media.tmpfiles
29 Source5:        compat-pld-var-run.tmpfiles
30 Source10:       pld-storage-init-late.service
31 Source11:       pld-storage-init.service
32 Source12:       pld-wait-storage.service
33 Source13:       pld-storage-init.sh
34 Patch0:         target-pld.patch
35 Patch1:         config-pld.patch
36 Patch2:         shut-sysv-up.patch
37 Patch3:         pld-sysv-network.patch
38 Patch4:         tmpfiles-not-fatal.patch
39 Patch5:         CVE-2012-1174.patch
40 URL:            http://www.freedesktop.org/wiki/Software/systemd
41 BuildRequires:  acl-devel
42 %{?with_audit:BuildRequires:    audit-libs-devel}
43 BuildRequires:  autoconf >= 2.63
44 BuildRequires:  automake >= 1:1.11
45 BuildRequires:  binutils >= 3:2.22.52.0.1-2
46 %{?with_cryptsetup:BuildRequires:       cryptsetup-luks-devel}
47 BuildRequires:  dbus-devel >= 1.3.2
48 BuildRequires:  docbook-style-xsl
49 BuildRequires:  gperf
50 BuildRequires:  intltool >= 0.40.0
51 BuildRequires:  kmod-devel >= 5
52 BuildRequires:  libcap-devel
53 %{?with_selinux:BuildRequires:  libselinux-devel >= 2.1.0}
54 BuildRequires:  libtool >= 2:2.2
55 %{?with_tcpd:BuildRequires:     libwrap-devel}
56 BuildRequires:  libxslt-progs
57 BuildRequires:  m4
58 %{?with_pam:BuildRequires:      pam-devel}
59 BuildRequires:  pkgconfig >= 0.9.0
60 BuildRequires:  rpmbuild(macros) >= 1.627
61 BuildRequires:  udev-devel >= 1:172
62 # not required for building from release (which contains *.c for *.vala)
63 #BuildRequires: vala >= 0.10.0
64 BuildRequires:  xz-devel
65 %if %{with gtk}
66 BuildRequires:  glib2-devel >= 1:2.26.1
67 BuildRequires:  gtk+2-devel >= 2:2.24.0
68 BuildRequires:  libgee-devel
69 BuildRequires:  libnotify-devel >= 0.7.0
70 %endif
71 Requires:       %{name}-libs = %{version}-%{release}
72 Requires:       %{name}-units = %{version}-%{release}
73 Requires:       /etc/os-release
74 Requires:       SysVinit-tools
75 Requires:       agetty
76 Requires:       dbus >= 1.4.16-6
77 Requires:       filesystem >= 4.0-2
78 Requires:       libutempter
79 Requires:       rc-scripts >= 0.4.5.3-7
80 Requires:       setup >= 2.8.0-2
81 Requires:       udev-core >= 1:175-5
82 Requires:       udev-libs >= 1:172
83 Requires:       virtual(module-tools)
84 Suggests:       %{name}-no-compat-tmpfiles
85 Suggests:       ConsoleKit
86 Suggests:       fsck >= 2.20
87 Suggests:       kmod >= 5
88 Suggests:       nss_myhostname
89 Suggests:       service(klogd)
90 Suggests:       service(syslog)
91 Provides:       udev-acl
92 # systemd takes care of that and causes problems
93 Conflicts:      binfmt-detector
94 # sytemd wants pam with pam_systemd.so in system-auth...
95 Conflicts:      pam < 1:1.1.5-5
96 # ...and sudo hates it
97 Conflicts:      sudo < 1:1.7.8p2-4
98 # for prefdm script
99 Conflicts:      xinitrc-ng < 1.0
100 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
101
102 %define         _libexecdir     %{_prefix}/lib
103
104 %description
105 systemd is a system and service manager for Linux, compatible with
106 SysV and LSB init scripts. systemd provides aggressive parallelization
107 capabilities, uses socket and D-Bus activation for starting services,
108 offers on-demand starting of daemons, keeps track of processes using
109 Linux cgroups, supports snapshotting and restoring of the system
110 state, maintains mount and automount points and implements an
111 elaborate transactional dependency-based service control logic. It can
112 work as a drop-in replacement for sysvinit.
113
114 %description -l pl.UTF-8
115 systemd jest zarządcą systemu i usług dla Linuksa, kompatybilny ze
116 skryptami SysV i LSB. systemd udostępnia rozbudowane zdolności
117 paralelizacji, do uruchamiania usług używa socketów oraz D-Busa,
118 oferuje uruchamianie usług na życzenie, monitoruje procesy używając
119 linuksowych cgroups, wspomaga zapisywanie (snapshot) i odczytywanie
120 (restore) stanu systemu, zarządza (auto)mount pointami oraz
121 implementuje starannie opracowaną transakcjonalną, bazującą na
122 zależnościach logikę kontroli usług. Może pracować jako zastępca dla
123 sysvinit.
124
125 %package init
126 Summary:        systemd /sbin/init and LSB/SysV compatibility symlinks
127 Summary(pl.UTF-8):      /sbin/init z systemd i dowiązania dla kompatybilności z LSB/SysV
128 Group:          Base
129 Requires:       systemd
130 Provides:       readahead = 1:1.5.7-3
131 Provides:       virtual(init-daemon)
132 Obsoletes:      SysVinit
133 Obsoletes:      readahead < 1:1.5.7-3
134 Obsoletes:      virtual(init-daemon)
135 Conflicts:      upstart
136
137 %description init
138 Install this package when you are ready to final switch to systemd.
139
140 %description init -l pl.UTF-8
141 Ten pakiet należy zainstalować po przygotowaniu się do ostatecznego
142 przejścia na systemd.
143
144 %package units
145 Summary:        Configuration files, directories and installation tool for systemd
146 Summary(pl.UTF-8):      Pliki konfiguracyjne, katalogi i narzędzie instalacyjne dla systemd
147 Group:          Base
148 Requires(post): coreutils
149 Requires(post): /bin/awk
150
151 %description units
152 Basic configuration files, directories and installation tool for the
153 systemd system and service manager.
154
155 This is common config, use %{_sysconfdir}/systemd/system to override.
156
157 %description units -l pl.UTF-8
158 Podstawowe pliki konfiguracyjne, katalogi i narzędzie instalacyjne dla
159 zarządcy systemu i usług systemd.
160
161 Ten pakiet zawiera ogólną konfigurację, ustawienia można nadpisać
162 poprzez katalog %{_sysconfdir}/systemd/system.
163
164 %package plymouth
165 Summary:        Plymouth support units for systemd
166 Summary(pl.UTF-8):      Jednostki wspierające Plymouth dla systemd
167 Group:          Base
168 Requires:       %{name}-units = %{version}-%{release}
169 Requires:       plymouth
170
171 %description plymouth
172 Plymouth (graphical boot) support units for systemd.
173
174 %description plymouth -l pl.UTF-8
175 Jednostki wspierające Plymouth (graficzny start systemu) dla systemd.
176
177 %package gtk
178 Summary:        Graphical frontend for systemd
179 Summary(pl.UTF-8):      Graficzny interfejs do systemd
180 Group:          Base
181 Requires:       %{name} = %{version}-%{release}
182 Requires:       polkit
183
184 %description gtk
185 Graphical front-end for systemd.
186
187 %description gtk -l pl.UTF-8
188 Graficzny interfejs do systemd.
189
190 %package analyze
191 Summary:        Tool for processing systemd profiling information
192 Group:          Base
193 Requires:       %{name} = %{version}-%{release}
194 Requires:       python-dbus
195 Requires:       python-modules
196 Requires:       python-pycairo
197 Conflicts:      %{name} < 44-3
198
199 %description analyze
200 'systemd-analyze blame' lists which systemd unit needed how much time
201 to finish initialization at boot. 'systemd-analyze plot' renders an
202 SVG visualizing the parallel start of units at boot.
203
204 %package libs
205 Summary:        Shared systemd libraries
206 Summary(pl.UTF-8):      Biblioteki współdzielone systemd
207 Group:          Libraries
208
209 %description libs
210 Shared systemd libraries.
211
212 %description libs -l pl.UTF-8
213 Biblioteki współdzielone systemd.
214
215 %package devel
216 Summary:        Header files for systemd libraries
217 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek systemd
218 Group:          Development/Libraries
219 Requires:       %{name}-libs = %{version}-%{release}
220
221 %description devel
222 Header files for systemd libraries.
223
224 %description devel -l pl.UTF-8
225 Pliki nagłówkowe bibliotek systemd.
226
227 %package -n bash-completion-systemd
228 Summary:        bash-completion for systemd
229 Summary(pl.UTF-8):      Bashowe dopełnianie składni dla systemd
230 Group:          Applications/Shells
231 Requires:       %{name}
232 Requires:       bash-completion
233
234 %description -n bash-completion-systemd
235 bash-completion for systemd.
236
237 %description -n bash-completion-systemd -l pl.UTF-8
238 Bashowe dopełnianie składni dla systemd
239
240 %package no-compat-tmpfiles
241 Summary:        Force update of packages that provide tmpfiles.d configuration
242 Group:          Base
243 Requires(post): sed > 4.0
244 Conflicts:      ConsoleKit-dirs < 0.4.5-7
245 Conflicts:      NetworkManager < 2:0.9.2.0-3
246 Conflicts:      Zope < 2.11.8-2
247 Conflicts:      amavisd-new < 1:2.7.0-1
248 Conflicts:      apache-base < 2.2.21-4
249 Conflicts:      apache-mod_bw < 0.92-3
250 Conflicts:      apache-mod_fastcgi < 2.4.6-6
251 Conflicts:      apache1-base < 1.3.42-5
252 Conflicts:      apache1-mod_fastcgi < 2.4.6-2
253 Conflicts:      asterisk < 10.0.1-2
254 Conflicts:      autossh-init < 1.4b-3
255 Conflicts:      balance < 3.54-2
256 Conflicts:      bind < 7:9.8.1.P1-4
257 Conflicts:      bopm < 3.1.3-4
258 Conflicts:      callweaver < 1.2.1-9
259 Conflicts:      cassandra-bin < 0.8.9-2
260 Conflicts:      clamav < 0.97.3-3
261 Conflicts:      cups < 1:1.5.0-10
262 Conflicts:      dbus < 1.4.16-4
263 Conflicts:      dovecot < 1:2.0.16-3
264 Conflicts:      dspam < 3.9.0-6
265 Conflicts:      fail2ban < 0.8.4-4
266 Conflicts:      filesystem < 4.0-3
267 Conflicts:      gammu-smsd < 1:1.31.0-3
268 # Break gdm2.20 installs
269 #Conflicts:     gdm < 2:3.2.1.1-9
270 Conflicts:      greylistd < 0.8.8-2
271 Conflicts:      inn < 2.4.6-7
272 Conflicts:      ipsec-tools < 0.8.0-3
273 Conflicts:      jabber-common < 0-9
274 Conflicts:      laptop-mode-tools < 1.58-2
275 Conflicts:      libgpod < 0.8.0-6
276 Conflicts:      libvirt-utils < 0.9.9-4
277 Conflicts:      lighttpd < 1.4.30-5
278 Conflicts:      lirc < 0.9.0-20
279 Conflicts:      mailman < 5:2.1.14-4
280 Conflicts:      memcached < 1.4.11-2
281 Conflicts:      mpd < 0.16.5-4
282 Conflicts:      mrtg < 2.17.0-3
283 Conflicts:      munin-common < 1.4.5-5
284 Conflicts:      nagios-nrpe < 2.13-2
285 Conflicts:      ndisc6-rdnssd < 1.0.1-3
286 Conflicts:      nscd < 6:2.14.1-5
287 Conflicts:      nss_ldapd-nslcd < 0.8.4-2
288 Conflicts:      openct < 0.6.20-3
289 Conflicts:      openl2tp < 1.8-3
290 Conflicts:      openldap-overlay-nssov < 2.4.28-4
291 Conflicts:      openldap-servers < 2.4.28-4
292 Conflicts:      openvpn < 2.2.2-2
293 Conflicts:      pam-pam_mount < 2.12-3
294 Conflicts:      pam-pam_ssh < 1.97-2
295 Conflicts:      pcsc-lite < 1.8.1-2
296 Conflicts:      php-dirs < 1.2-3
297 Conflicts:      policyd < 2.0.10-3
298 Conflicts:      pound < 2.6-2
299 Conflicts:      pptp < 1.7.2-3
300 Conflicts:      proftpd-common < 2:1.3.4a-2
301 Conflicts:      pulseaudio-server < 1.1-2
302 Conflicts:      quagga < 0.99.20-3
303 Conflicts:      radvd < 1.8.5-2
304 Conflicts:      rc-scripts < 0.4.5.2-3
305 Conflicts:      red5 < 0.9.0-2
306 Conflicts:      redis-server < 2.4.2-4
307 Conflicts:      smokeping < 2.4.2-10
308 Conflicts:      smtp-gated < 1.4.17-2
309 Conflicts:      socat < 1.7.2.0-2
310 Conflicts:      speech-dispatcher < 0.7.1-2
311 Conflicts:      sphinx < 2.0.3-4
312 Conflicts:      splashutils < 1.5.4.3-3
313 Conflicts:      stunnel < 4.50-2
314 Conflicts:      tenshi < 0.12-2
315 Conflicts:      tor < 0.2.2.35-2
316 Conflicts:      ucarp < 1.5.2-3
317 Conflicts:      udisks < 1.0.4-3
318 Conflicts:      util-vserver < 0.30.216-1.pre3002.3
319 Conflicts:      vpnc < 0.5.3-2
320 Conflicts:      web2ldap < 1.1.0rc1-2
321 Conflicts:      wesnoth-server < 1:1.10-2
322 Conflicts:      wpa_supplicant < 0.7.3-10
323 Conflicts:      xl2tpd < 1.3.0-2
324
325 %description no-compat-tmpfiles
326 Force update of packages that provide tmpfiles.d configuration
327
328 %prep
329 %setup -q
330 %patch0 -p1
331 %patch1 -p1
332 %patch2 -p1
333 %patch3 -p1
334 %patch4 -p1
335 %patch5 -p1
336 cp -p %{SOURCE2} src/systemd_booted.c
337
338 %build
339 %{__aclocal} -I m4
340 %{__autoconf}
341 %{__autoheader}
342 %{__automake}
343 %configure \
344         %{__enable_disable audit} \
345         %{__enable_disable cryptsetup libcryptsetup} \
346         %{__enable_disable gtk} \
347         %{__enable_disable pam} \
348         %{__enable_disable plymouth} \
349         %{__enable_disable selinux} \
350         %{__enable_disable tcpd tcpwrap} \
351         --disable-silent-rules \
352         --disable-static \
353         --with-distro=pld \
354         --with-rootprefix= \
355         --with-rootlibdir=/%{_lib} \
356         --enable-split-usr
357
358 %{__make}
359 ./libtool --mode=link --tag=CC %{__cc} %{rpmcppflags} %{rpmcflags} -o systemd_booted %{rpmldflags} src/systemd_booted.c -L. -lsystemd-daemon
360
361 %install
362 rm -rf $RPM_BUILD_ROOT
363 install -d $RPM_BUILD_ROOT/var/lib/%{name}/coredump
364
365 %{__make} install \
366         DESTDIR=$RPM_BUILD_ROOT
367
368 ./libtool --mode=install install -p -m755 systemd_booted $RPM_BUILD_ROOT/bin/systemd_booted
369
370 # Main binary has been moved, but we don't want to break existing installs
371 ln -s ../lib/systemd/systemd $RPM_BUILD_ROOT/bin/systemd
372
373 # Create SysV compatibility symlinks. systemctl/systemd are smart
374 # enough to detect the way they were called
375 install -d $RPM_BUILD_ROOT/sbin
376 ln -s ../lib/systemd/systemd $RPM_BUILD_ROOT/sbin/init
377 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/halt
378 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/poweroff
379 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/reboot
380 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/runlevel
381 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/shutdown
382 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/telinit
383
384 ln -s ../modules $RPM_BUILD_ROOT%{_sysconfdir}/modules-load.d/modules.conf
385
386 # disable redundant SYSV services
387 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/allowlogin.service
388 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/console.service
389 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/cpusets.service
390 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/killall.service
391 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/netfs.service
392 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/random.service
393
394 # add static (non-NetworkManager) networking
395 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{systemdunitdir}/network.service
396
397 # install compatibility tmpfiles configs
398 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/compat-pld-media.conf
399 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/compat-pld-var-run.conf
400
401 # Install and enable storage subsystems support services (RAID, LVM, etc.)
402 cp -p %{SOURCE10} $RPM_BUILD_ROOT%{systemdunitdir}/pld-storage-init-late.service
403 cp -p %{SOURCE11} $RPM_BUILD_ROOT%{systemdunitdir}/pld-storage-init.service
404 cp -p %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/pld-wait-storage.service
405 install -p %{SOURCE13} $RPM_BUILD_ROOT/lib/systemd/pld-storage-init
406
407 ln -s ../pld-storage-init-late.service $RPM_BUILD_ROOT%{systemdunitdir}/local-fs.target.wants/pld-storage-init-late.service
408 ln -s ../pld-storage-init.service $RPM_BUILD_ROOT%{systemdunitdir}/local-fs.target.wants/pld-storage-init.service
409
410 # handled by rc-local sysv service, no need for generator
411 %{__rm} $RPM_BUILD_ROOT/lib/systemd/system-generators/systemd-rc-local-generator
412 %{__rm} $RPM_BUILD_ROOT%{systemdunitdir}/multi-user.target.wants/rc-local.service
413
414 # Make sure these directories are properly owned:
415 #       - halt,kexec,poweroff,reboot: generic ones used by ConsoleKit-systemd,
416 #       - syslog _might_ be used by some syslog implementation (none for now),
417 #       - isn't dbus populated by dbus-systemd only (so to be moved there)?
418 install -d $RPM_BUILD_ROOT%{systemdunitdir}/{dbus,halt,kexec,poweroff,reboot,syslog}.target.wants
419
420 # Create new-style configuration files so that we can ghost-own them
421 touch $RPM_BUILD_ROOT%{_sysconfdir}/{hostname,locale.conf,machine-id,machine-info,timezone,vconsole.conf}
422
423 # Install SysV conversion tool for systemd
424 install -p %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}
425
426 install -d $RPM_BUILD_ROOT/var/log
427 :> $RPM_BUILD_ROOT/var/log/btmp
428 :> $RPM_BUILD_ROOT/var/log/wtmp
429
430 %if %{without gtk}
431 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/systemadm.1*
432 %endif
433
434 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
435 %{__rm} $RPM_BUILD_ROOT/%{_lib}/security/pam_systemd.la
436 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
437
438 %clean
439 rm -rf $RPM_BUILD_ROOT
440
441 %post
442 /bin/systemd-machine-id-setup > /dev/null 2>&1 || :
443 /bin/systemctl daemon-reexec > /dev/null 2>&1 || :
444
445 %postun
446 if [ $1 -ge 1 ]; then
447         /bin/systemctl try-restart systemd-logind.service >/dev/null 2>&1 || :
448 fi
449
450 %post   libs -p /sbin/ldconfig
451 %postun libs -p /sbin/ldconfig
452
453 %post units
454 if [ $1 -eq 1 ]; then
455         # Try to read default runlevel from the old inittab if it exists
456         runlevel=$(/bin/awk -F ':' '$3 == "initdefault" && $1 !~ "^#" { print $2 }' /etc/inittab 2> /dev/null)
457         if [ -z "$runlevel" ] ; then
458                 target="%{systemdunitdir}/graphical.target"
459         else
460                 target="%{systemdunitdir}/runlevel$runlevel.target"
461         fi
462
463         # And symlink what we found to the new-style default.target
464         ln -s "$target" %{_sysconfdir}/systemd/system/default.target >/dev/null 2>&1 || :
465
466         # Setup hostname
467         [ -f /etc/sysconfig/network ] && . /etc/sysconfig/network
468         if [ -n "$HOSTNAME" -a "$HOSTNAME" != "pldmachine" ]; then
469                 [ -f /etc/hostname ] && mv -f /etc/hostname /etc/hostname.rpmsave
470                 echo $HOSTNAME > /etc/hostname
471                 chmod 644 /etc/hostname
472         fi
473
474         # Enable the services we install by default.
475         /bin/systemctl enable \
476                 getty@.service \
477                 network.service \
478                 remote-fs.target \
479                 systemd-readahead-replay.service \
480                 systemd-readahead-collect.service >/dev/null 2>&1 || :
481 fi
482
483 %preun units
484 if [ $1 -eq 0 ] ; then
485         /bin/systemctl disable \
486                 getty@.service \
487                 network.service \
488                 remote-fs.target \
489                 systemd-readahead-replay.service \
490                 systemd-readahead-collect.service >/dev/null 2>&1 || :
491
492         %{__rm} -f %{_sysconfdir}/systemd/system/default.target >/dev/null 2>&1 || :
493 fi
494
495 %postun units
496 if [ $1 -ge 1 ]; then
497         /bin/systemctl daemon-reload > /dev/null 2>&1 || :
498 fi
499
500 %triggerpostun units -- %{name}-units < 43-7
501 # Remove design fialures
502 rm -f %{_sysconfdir}/systemd/system/network.target.wants/ifcfg@*.service >/dev/null 2>&1 || :
503 rm -f %{_sysconfdir}/systemd/system/network.target.wants/network-post.service >/dev/null 2>&1 || :
504 rm -f %{_sysconfdir}/systemd/system/multi-user.target.wants/network-post.service >/dev/null 2>&1 || :
505 /bin/systemctl reenable network.service >/dev/null 2>&1 || :
506
507 %post no-compat-tmpfiles
508 %{__sed} -i -e '/^#/!s/^/# /g' %{_sysconfdir}/tmpfiles.d/compat-pld-var-run.conf
509
510 %files
511 %defattr(644,root,root,755)
512 %doc DISTRO_PORTING README TODO
513 /etc/dbus-1/system.d/org.freedesktop.hostname1.conf
514 /etc/dbus-1/system.d/org.freedesktop.locale1.conf
515 /etc/dbus-1/system.d/org.freedesktop.login1.conf
516 /etc/dbus-1/system.d/org.freedesktop.systemd1.conf
517 /etc/dbus-1/system.d/org.freedesktop.timedate1.conf
518 %ghost %config(noreplace) %{_sysconfdir}/machine-id
519 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hostname
520 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/locale.conf
521 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/machine-info
522 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/timezone
523 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/vconsole.conf
524 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/systemd/*.conf
525 %dir %{_sysconfdir}/systemd/user
526 %dir %{_sysconfdir}/systemd/system/*.target.wants
527 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/systemd/system/*.target.wants/*.service
528 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/systemd/system/*.target.wants/*.target
529 /etc/xdg/systemd
530 %attr(755,root,root) /bin/systemd
531 %attr(755,root,root) /bin/systemd-ask-password
532 %attr(755,root,root) /bin/systemd-journalctl
533 %attr(755,root,root) /bin/systemd-loginctl
534 %attr(755,root,root) /bin/systemd-machine-id-setup
535 %attr(755,root,root) /bin/systemd-notify
536 %attr(755,root,root) /bin/systemd-tty-ask-password-agent
537 %attr(755,root,root) %{_bindir}/systemd-cat
538 %attr(755,root,root) %{_bindir}/systemd-cgtop
539 %attr(755,root,root) %{_bindir}/systemd-cgls
540 %attr(755,root,root) %{_bindir}/systemd-nspawn
541 %attr(755,root,root) %{_bindir}/systemd-stdio-bridge
542 %attr(755,root,root) %{_bindir}/systemd-sysv-convert
543 %attr(755,root,root) /lib/systemd/pld-storage-init
544 %attr(755,root,root) /lib/systemd/systemd-*
545 %dir /lib/systemd/system-generators
546 %attr(755,root,root) /lib/systemd/systemd
547 %attr(755,root,root) /lib/systemd/system-generators/systemd-*-generator
548 %dir /lib/systemd/system-shutdown
549 /lib/udev/rules.d/99-systemd.rules
550 /lib/udev/rules.d/70-uaccess.rules
551 /lib/udev/rules.d/71-seat.rules
552 /lib/udev/rules.d/73-seat-late.rules
553 %dir %{_libexecdir}/systemd
554 %{_libexecdir}/systemd/user
555 %dir %{_libexecdir}/systemd/user-generators
556 %config(noreplace,missingok) %{_libexecdir}/tmpfiles.d/*.conf
557 %{_datadir}/dbus-1/interfaces/org.freedesktop.hostname1.xml
558 %{_datadir}/dbus-1/interfaces/org.freedesktop.locale1.xml
559 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.*.xml
560 %{_datadir}/dbus-1/interfaces/org.freedesktop.timedate1.xml
561 %{_datadir}/dbus-1/services/org.freedesktop.systemd1.service
562 %{_datadir}/dbus-1/system-services/org.freedesktop.hostname1.service
563 %{_datadir}/dbus-1/system-services/org.freedesktop.locale1.service
564 %{_datadir}/dbus-1/system-services/org.freedesktop.login1.service
565 %{_datadir}/dbus-1/system-services/org.freedesktop.systemd1.service
566 %{_datadir}/dbus-1/system-services/org.freedesktop.timedate1.service
567 %{_datadir}/polkit-1/actions/org.freedesktop.hostname1.policy
568 %{_datadir}/polkit-1/actions/org.freedesktop.locale1.policy
569 %{_datadir}/polkit-1/actions/org.freedesktop.login1.policy
570 %{_datadir}/polkit-1/actions/org.freedesktop.systemd1.policy
571 %{_datadir}/polkit-1/actions/org.freedesktop.timedate1.policy
572 %dir %{_datadir}/systemd
573 %{_datadir}/systemd/kbd-model-map
574 %{_mandir}/man1/systemd.1*
575 %{_mandir}/man1/systemd-*.1*
576 %{_mandir}/man5/binfmt.d.5*
577 %{_mandir}/man5/hostname.5*
578 %{_mandir}/man5/locale.conf.5*
579 %{_mandir}/man5/machine-id.5*
580 %{_mandir}/man5/machine-info.5*
581 %{_mandir}/man5/modules-load.d.5*
582 %{_mandir}/man5/os-release.5*
583 %{_mandir}/man5/sysctl.d.5*
584 %{_mandir}/man5/systemd.*.5*
585 %{_mandir}/man5/systemd-journald.conf.5*
586 %{_mandir}/man5/systemd-logind.conf.5*
587 %{_mandir}/man5/timezone.5*
588 %{_mandir}/man5/vconsole.conf.5*
589 %{_mandir}/man7/daemon.7*
590 %{_mandir}/man7/sd-daemon.7*
591 %{_mandir}/man7/sd-login.7*
592 %{_mandir}/man7/sd-readahead.7*
593 %{_mandir}/man7/systemd.special.7*
594 %dir /var/lib/%{name}
595 %dir /var/lib/%{name}/coredump
596 %attr(640,root,root) %ghost /var/log/btmp
597 %attr(664,root,utmp) %ghost /var/log/wtmp
598
599 %if %{with pam}
600 %attr(755,root,root) /%{_lib}/security/pam_systemd.so
601 %{_mandir}/man8/pam_systemd.8*
602 %endif
603
604 %files init
605 %defattr(644,root,root,755)
606 %attr(755,root,root) /sbin/halt
607 %attr(755,root,root) /sbin/init
608 %attr(755,root,root) /sbin/poweroff
609 %attr(755,root,root) /sbin/reboot
610 %attr(755,root,root) /sbin/runlevel
611 %attr(755,root,root) /sbin/shutdown
612 %attr(755,root,root) /sbin/telinit
613 %{_mandir}/man1/init.1
614 %{_mandir}/man8/halt.8*
615 %{_mandir}/man8/poweroff.8
616 %{_mandir}/man8/reboot.8
617 %{_mandir}/man8/runlevel.8*
618 %{_mandir}/man8/shutdown.8*
619 %{_mandir}/man8/telinit.8*
620
621 %files units
622 %defattr(644,root,root,755)
623 %dir %{_sysconfdir}/binfmt.d
624 %dir %{_sysconfdir}/modules-load.d
625 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/modules-load.d/modules.conf
626 %dir %{_sysconfdir}/sysctl.d
627 %dir %{_sysconfdir}/systemd
628 %dir %{_sysconfdir}/systemd/system
629 %dir %{_sysconfdir}/tmpfiles.d
630 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/tmpfiles.d/*.conf
631 %dir %{_libexecdir}/binfmt.d
632 %dir %{_libexecdir}/modules-load.d
633 %dir %{_libexecdir}/sysctl.d
634 %{_libexecdir}/sysctl.d/coredump.conf
635 %attr(755,root,root) /bin/systemctl
636 %attr(755,root,root) /bin/systemd-tmpfiles
637 %attr(755,root,root) /bin/systemd_booted
638 %{_mandir}/man1/systemctl.1*
639 %{_mandir}/man5/tmpfiles.d.5*
640 %{_mandir}/man8/systemd-tmpfiles.8*
641 %{_npkgconfigdir}/systemd.pc
642
643 %{systemdunitdir}/*.automount
644 %{systemdunitdir}/*.mount
645 %{systemdunitdir}/*.path
646 %{systemdunitdir}/*.service
647 %{systemdunitdir}/*.socket
648 %{systemdunitdir}/*.target
649 %{systemdunitdir}/*.timer
650 %if %{with plymouth}
651 %exclude %{systemdunitdir}/plymouth*.service
652 %exclude %{systemdunitdir}/systemd-ask-password-plymouth.*
653 %endif
654 %dir %{systemdunitdir}/basic.target.wants
655 %dir %{systemdunitdir}/dbus.target.wants
656 %dir %{systemdunitdir}/final.target.wants
657 %dir %{systemdunitdir}/graphical.target.wants
658 %dir %{systemdunitdir}/halt.target.wants
659 %dir %{systemdunitdir}/kexec.target.wants
660 %dir %{systemdunitdir}/local-fs.target.wants
661 %dir %{systemdunitdir}/multi-user.target.wants
662 %dir %{systemdunitdir}/poweroff.target.wants
663 %dir %{systemdunitdir}/reboot.target.wants
664 %dir %{systemdunitdir}/runlevel[12345].target.wants
665 %dir %{systemdunitdir}/shutdown.target.wants
666 %dir %{systemdunitdir}/sockets.target.wants
667 %dir %{systemdunitdir}/sysinit.target.wants
668 %dir %{systemdunitdir}/syslog.target.wants
669 %config(noreplace,missingok) %{systemdunitdir}/basic.target.wants/*
670 %config(noreplace,missingok) %{systemdunitdir}/final.target.wants/*
671 %config(noreplace,missingok) %{systemdunitdir}/graphical.target.wants/*
672 %config(noreplace,missingok) %{systemdunitdir}/local-fs.target.wants/*
673 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/getty.target
674 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/rc-local.service
675 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/systemd-ask-password-wall.path
676 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/systemd-logind.service
677 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/systemd-user-sessions.service
678 %config(noreplace,missingok) %{systemdunitdir}/runlevel[12345].target.wants/*
679 %config(noreplace,missingok) %{systemdunitdir}/shutdown.target.wants/*
680 %config(noreplace,missingok) %{systemdunitdir}/sockets.target.wants/*
681 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/cryptsetup.target
682 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/dev-hugepages.mount
683 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/dev-mqueue.mount
684 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/proc-sys-fs-binfmt_misc.automount
685 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/sys-*.mount
686 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/systemd-*
687
688 %if %{with plymouth}
689 %files plymouth
690 %defattr(644,root,root,755)
691 %{systemdunitdir}/plymouth-halt.service
692 %{systemdunitdir}/plymouth-kexec.service
693 %{systemdunitdir}/plymouth-poweroff.service
694 %{systemdunitdir}/plymouth-quit-wait.service
695 %{systemdunitdir}/plymouth-quit.service
696 %{systemdunitdir}/plymouth-read-write.service
697 %{systemdunitdir}/plymouth-reboot.service
698 %{systemdunitdir}/plymouth-start.service
699 %{systemdunitdir}/systemd-ask-password-plymouth.path
700 %{systemdunitdir}/systemd-ask-password-plymouth.service
701 %config(noreplace,missingok) %{systemdunitdir}/halt.target.wants/plymouth-halt.service
702 %config(noreplace,missingok) %{systemdunitdir}/kexec.target.wants/plymouth-kexec.service
703 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/plymouth-quit.service
704 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/plymouth-quit-wait.service
705 %config(noreplace,missingok) %{systemdunitdir}/poweroff.target.wants/plymouth-poweroff.service
706 %config(noreplace,missingok) %{systemdunitdir}/reboot.target.wants/plymouth-reboot.service
707 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/plymouth-read-write.service
708 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/plymouth-start.service
709 %endif
710
711 %if %{with gtk}
712 %files gtk
713 %defattr(644,root,root,755)
714 %attr(755,root,root) %{_bindir}/systemadm
715 %attr(755,root,root) %{_bindir}/systemd-gnome-ask-password-agent
716 %{_mandir}/man1/systemadm.1*
717 %endif
718
719 %files analyze
720 %defattr(644,root,root,755)
721 %attr(755,root,root) %{_bindir}/systemd-analyze
722
723 %files libs
724 %defattr(644,root,root,755)
725 %attr(755,root,root) /%{_lib}/libsystemd-daemon.so.*.*.*
726 %attr(755,root,root) %ghost /%{_lib}/libsystemd-daemon.so.0
727 %attr(755,root,root) /%{_lib}/libsystemd-id128.so.*.*.*
728 %attr(755,root,root) %ghost /%{_lib}/libsystemd-id128.so.0
729 %attr(755,root,root) /%{_lib}/libsystemd-journal.so.*.*.*
730 %attr(755,root,root) %ghost /%{_lib}/libsystemd-journal.so.0
731 %attr(755,root,root) /%{_lib}/libsystemd-login.so.*.*.*
732 %attr(755,root,root) %ghost /%{_lib}/libsystemd-login.so.0
733
734 %files devel
735 %defattr(644,root,root,755)
736 %attr(755,root,root) %{_libdir}/libsystemd-daemon.so
737 %attr(755,root,root) %{_libdir}/libsystemd-id128.so
738 %attr(755,root,root) %{_libdir}/libsystemd-journal.so
739 %attr(755,root,root) %{_libdir}/libsystemd-login.so
740 %{_includedir}/%{name}
741 %{_pkgconfigdir}/libsystemd-daemon.pc
742 %{_pkgconfigdir}/libsystemd-id128.pc
743 %{_pkgconfigdir}/libsystemd-journal.pc
744 %{_pkgconfigdir}/libsystemd-login.pc
745 %{_mandir}/man3/sd_booted.3*
746 %{_mandir}/man3/sd_get_seats.3*
747 %{_mandir}/man3/sd_get_sessions.3*
748 %{_mandir}/man3/sd_get_uids.3*
749 %{_mandir}/man3/sd_is_fifo.3*
750 %{_mandir}/man3/sd_is_mq.3*
751 %{_mandir}/man3/sd_is_socket.3
752 %{_mandir}/man3/sd_is_socket_inet.3
753 %{_mandir}/man3/sd_is_socket_unix.3
754 %{_mandir}/man3/sd_listen_fds.3*
755 %{_mandir}/man3/sd_login_monitor_flush.3*
756 %{_mandir}/man3/sd_login_monitor_get_fd.3*
757 %{_mandir}/man3/sd_login_monitor_new.3*
758 %{_mandir}/man3/sd_login_monitor_unref.3*
759 %{_mandir}/man3/sd_notify.3*
760 %{_mandir}/man3/sd_notifyf.3
761 %{_mandir}/man3/sd_pid_get_owner_uid.3*
762 %{_mandir}/man3/sd_pid_get_session.3*
763 %{_mandir}/man3/sd_pid_get_unit.3*
764 %{_mandir}/man3/sd_readahead.3*
765 %{_mandir}/man3/sd_seat_can_multi_session.3*
766 %{_mandir}/man3/sd_seat_get_active.3*
767 %{_mandir}/man3/sd_seat_get_sessions.3*
768 %{_mandir}/man3/sd_session_get_class.3*
769 %{_mandir}/man3/sd_session_get_display.3*
770 %{_mandir}/man3/sd_session_get_seat.3*
771 %{_mandir}/man3/sd_session_get_service.3*
772 %{_mandir}/man3/sd_session_get_type.3*
773 %{_mandir}/man3/sd_session_get_uid.3*
774 %{_mandir}/man3/sd_session_is_active.3*
775 %{_mandir}/man3/sd_uid_get_seats.3*
776 %{_mandir}/man3/sd_uid_get_sessions.3*
777 %{_mandir}/man3/sd_uid_get_state.3*
778 %{_mandir}/man3/sd_uid_is_on_seat.3*
779
780 %files -n bash-completion-systemd
781 %defattr(644,root,root,755)
782 /etc/bash_completion.d/systemd-bash-completion.sh
783
784 %files no-compat-tmpfiles
785 %defattr(644,root,root,755)
786 # empty package
This page took 0.145336 seconds and 4 git commands to generate.