]> git.pld-linux.org Git - packages/systemd.git/blob - systemd.spec
- move back tmpfiles to /usr/lib, looks like systemd does the right thing
[packages/systemd.git] / systemd.spec
1 #
2 # TODO:
3 #       - remove compat-pld-var-run.tmpfiles and maybe tmpfiles-not-fatal.patch
4 #         after enough packages provide their own tmpfiles.d configs for
5 #         /var/run directories
6 #
7 # Conditional build:
8 %bcond_without  audit           # without audit support
9 %bcond_without  cryptsetup      # without cryptsetup support
10 %bcond_without  gtk             # build gtk tools
11 %bcond_without  pam             # PAM authentication support
12 %bcond_without  selinux         # without SELinux support
13 %bcond_without  tcpd            # libwrap (tcp_wrappers) support
14
15 Summary:        A System and Service Manager
16 Summary(pl.UTF-8):      systemd - zarządca systemu i usług dla Linuksa
17 Name:           systemd
18 Version:        39
19 Release:        0.1
20 License:        GPL v2+
21 Group:          Base
22 Source0:        http://www.freedesktop.org/software/systemd/%{name}-%{version}.tar.xz
23 # Source0-md5:  7179b34f6f6553d2a36551ac1dec5f0d
24 Source1:        %{name}-sysv-convert
25 Source2:        systemd_booted.c
26 Source3:        ifup@.service
27 Source4:        network-post.service
28 Source5:        network.service
29 Source6:        compat-pld-media.tmpfiles
30 Source7:        compat-pld-var-run.tmpfiles
31 Patch0:         target-pld.patch
32 Patch1:         config-pld.patch
33 Patch2:         shut-sysv-up.patch
34 Patch3:         pld-sysv-network.patch
35 Patch4:         tmpfiles-not-fatal.patch
36 URL:            http://www.freedesktop.org/wiki/Software/systemd
37 BuildRequires:  acl-devel
38 %{?with_audit:BuildRequires:    audit-libs-devel}
39 BuildRequires:  autoconf >= 2.63
40 BuildRequires:  automake >= 1:1.11
41 %{?with_cryptsetup:BuildRequires:       cryptsetup-luks-devel}
42 BuildRequires:  dbus-devel >= 1.3.2
43 BuildRequires:  docbook-style-xsl
44 %if %{with gtk}
45 BuildRequires:  glib2-devel >= 1:2.26.1
46 BuildRequires:  gtk+2-devel >= 2:2.24.0
47 BuildRequires:  libgee-devel
48 BuildRequires:  libnotify-devel >= 0.7.0
49 %endif
50 BuildRequires:  gperf
51 BuildRequires:  intltool >= 0.40.0
52 BuildRequires:  libcap-devel
53 %{?with_selinux:BuildRequires:  libselinux-devel}
54 BuildRequires:  libtool >= 2:2.2
55 %{?with_tcpd:BuildRequires:     libwrap-devel}
56 BuildRequires:  libxslt-progs
57 BuildRequires:  m4
58 %{?with_pam:BuildRequires:      pam-devel}
59 BuildRequires:  pkgconfig >= 0.9.0
60 BuildRequires:  rpmbuild(macros) >= 1.527
61 BuildRequires:  udev-devel >= 172
62 # not required for building from release (which contains *.c for *.vala)
63 #BuildRequires: vala >= 0.10.0
64 Requires:       %{name}-libs = %{version}-%{release}
65 Requires:       %{name}-units = %{version}-%{release}
66 Requires:       SysVinit-tools
67 Requires:       agetty
68 Requires:       dbus >= 1.3.2
69 Requires:       dbus-systemd
70 Requires:       filesystem >= 4.0-2
71 Requires:       rc-scripts >= 0.4.5.1-7
72 Requires:       setup >= 2.8.0-2
73 Requires:       udev-core >= 1:172
74 Requires:       udev-systemd >= 1:172
75 Requires:       udev-libs >= 1:172
76 Suggests:       ConsoleKit-systemd
77 Suggests:       fsck >= 2.20
78 Suggests:       nss_myhostname
79 # python modules required by systemd-analyze
80 Suggests:       python-dbus
81 Suggests:       python-modules
82 Suggests:       service(syslog)
83 Provides:       udev-acl
84 Conflicts:      upstart
85 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
86
87 %define         _libexecdir     %{_prefix}/lib
88
89 %description
90 systemd is a system and service manager for Linux, compatible with
91 SysV and LSB init scripts. systemd provides aggressive parallelization
92 capabilities, uses socket and D-Bus activation for starting services,
93 offers on-demand starting of daemons, keeps track of processes using
94 Linux cgroups, supports snapshotting and restoring of the system
95 state, maintains mount and automount points and implements an
96 elaborate transactional dependency-based service control logic. It can
97 work as a drop-in replacement for sysvinit.
98
99 %description -l pl.UTF-8
100 systemd jest zarządcą systemu i usług dla Linuksa, kompatybilny ze
101 skryptami SysV i LSB. systemd udostępnia rozbudowane zdolności
102 paralelizacji, do uruchamiania usług używa socketów oraz D-Busa,
103 oferuje uruchamianie usług na życzenie, monitoruje procesy używając
104 linuksowych cgroups, wspomaga zapisywanie (snapshot) i odczytywanie
105 (restore) stanu systemu, zarządza (auto)mount pointami oraz
106 implementuje starannie opracowaną transakcjonalną, bazującą na
107 zależnościach logikę kontroli usług. Może pracować jako zastępca dla
108 sysvinit.
109
110 %package init
111 Summary:        systemd /sbin/init and LSB/SysV compatibility symlinks
112 Summary(pl.UTF-8):      /sbin/init z systemd i dowiązania dla kompatybilności z LSB/SysV
113 Group:          Base
114 Requires:       systemd
115 Provides:       readahead = 1:1.5.7-3
116 Provides:       virtual(init-daemon)
117 Obsoletes:      SysVinit
118 Obsoletes:      readahead < 1:1.5.7-3
119 Obsoletes:      virtual(init-daemon)
120
121 %description init
122 Install this package when you are ready to final switch to systemd.
123
124 %description init -l pl.UTF-8
125 Ten pakiet należy zainstalować po przygotowaniu się do ostatecznego
126 przejścia na systemd.
127
128 %package units
129 Summary:        Configuration files, directories and installation tool for systemd
130 Summary(pl.UTF-8):      Pliki konfiguracyjne, katalogi i narzędzie instalacyjne dla systemd
131 Group:          Base
132 Requires(post): coreutils
133 Requires(post): gawk
134 Requires:       pkgconfig
135
136 %description units
137 Basic configuration files, directories and installation tool for the
138 systemd system and service manager.
139
140 This is common config, use %{_sysconfdir}/systemd/system to override.
141
142 %description units -l pl.UTF-8
143 Podstawowe pliki konfiguracyjne, katalogi i narzędzie instalacyjne dla
144 zarządcy systemu i usług systemd.
145
146 Ten pakiet zawiera ogólną konfigurację, ustawienia można nadpisać
147 poprzez katalog %{_sysconfdir}/systemd/system.
148
149 %package gtk
150 Summary:        Graphical frontend for systemd
151 Summary(pl.UTF-8):      Graficzny interfejs do systemd
152 Group:          Base
153 Requires:       %{name} = %{version}-%{release}
154 Requires:       polkit
155
156 %description gtk
157 Graphical front-end for systemd.
158
159 %description gtk -l pl.UTF-8
160 Graficzny interfejs do systemd.
161
162 %package libs
163 Summary:        Shared systemd libraries
164 Summary(pl.UTF-8):      Biblioteki współdzielone systemd
165 Group:          Libraries
166
167 %description libs
168 Shared systemd libraries.
169
170 %description libs -l pl.UTF-8
171 Biblioteki współdzielone systemd.
172
173 %package devel
174 Summary:        Header files for systemd libraries
175 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek systemd
176 Group:          Development/Libraries
177 Requires:       %{name}-libs = %{version}-%{release}
178
179 %description devel
180 Header files for systemd libraries.
181
182 %description devel -l pl.UTF-8
183 Pliki nagłówkowe bibliotek systemd.
184
185 %package -n bash-completion-systemd
186 Summary:        bash-completion for systemd
187 Summary(pl.UTF-8):      Bashowe dopełnianie składni dla systemd
188 Group:          Applications/Shells
189 Requires:       %{name}
190 Requires:       bash-completion
191
192 %description -n bash-completion-systemd
193 bash-completion for systemd.
194
195 %description -n bash-completion-systemd -l pl.UTF-8
196 Bashowe dopełnianie składni dla systemd
197
198 %prep
199 %setup -q
200 %patch0 -p1
201 %patch1 -p1
202 #%patch2 -p1
203 %patch3 -p1
204 %patch4 -p1
205 cp -p %{SOURCE2} src/systemd_booted.c
206
207 %build
208 %{__aclocal} -I m4
209 %{__autoconf}
210 %{__autoheader}
211 %{__automake}
212 %configure \
213         %{__enable_disable audit} \
214         %{__enable_disable cryptsetup libcryptsetup} \
215         %{__enable_disable gtk} \
216         %{__enable_disable pam} \
217         %{__enable_disable selinux} \
218         %{__enable_disable tcpd tcpwrap} \
219         --disable-silent-rules \
220         --disable-static \
221         --with-distro=pld \
222         --with-rootprefix= \
223         --with-rootlibdir=/%{_lib}
224
225 %{__make}
226 ./libtool --mode=link --tag=CC %{__cc} %{rpmcppflags} %{rpmcflags} -o systemd_booted %{rpmldflags} src/systemd_booted.c -L. -lsystemd-daemon
227
228 %install
229 rm -rf $RPM_BUILD_ROOT
230
231 %{__make} install \
232         DESTDIR=$RPM_BUILD_ROOT
233
234 ./libtool --mode=install install -m755 systemd_booted $RPM_BUILD_ROOT/bin/systemd_booted
235
236 # Create SysV compatibility symlinks. systemctl/systemd are smart
237 # enough to detect the way they were called
238 install -d $RPM_BUILD_ROOT/sbin
239 ln -s ../bin/systemd $RPM_BUILD_ROOT/sbin/init
240 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/halt
241 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/poweroff
242 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/reboot
243 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/runlevel
244 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/shutdown
245 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/telinit
246
247 ln -s ../modules $RPM_BUILD_ROOT%{_sysconfdir}/modules-load.d/modules.conf
248 # disable random and console SYSV service 
249 ln -s /dev/null $RPM_BUILD_ROOT/lib/systemd/system/random.service
250 ln -s /dev/null $RPM_BUILD_ROOT/lib/systemd/system/console.service
251
252 # add static (non-NetworkManager) networking
253 install %{SOURCE3} $RPM_BUILD_ROOT/lib/systemd/system/ifup@.service
254 install %{SOURCE4} $RPM_BUILD_ROOT/lib/systemd/system/network-post.service
255 install %{SOURCE5} $RPM_BUILD_ROOT/lib/systemd/system/network.service
256
257 # install compatibility tmpfiles configs
258 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/compat-pld-media.conf
259 install %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/compat-pld-var-run.conf
260
261 # All wants links are created at %post to make sure they are not owned
262 # and hence overriden by rpm if the user deletes them (missingok?)
263 %{__rm} -r $RPM_BUILD_ROOT%{_sysconfdir}/systemd/system/*.target.wants
264
265 # it is in rc-scripts pkg
266 %{__rm} $RPM_BUILD_ROOT/lib/systemd/system/rc-local.service
267
268 # Make sure these directories are properly owned:
269 #       - halt,kexec,poweroff,reboot: generic ones used by ConsoleKit-systemd,
270 #       - syslog _might_ be used by some syslog implementation (none for now),
271 #       - isn't dbus populated by dbus-systemd only (so to be moved there)?
272 install -d $RPM_BUILD_ROOT/lib/systemd/system/{dbus,halt,kexec,poweroff,reboot,syslog}.target.wants
273
274 # Create new-style configuration files so that we can ghost-own them
275 touch $RPM_BUILD_ROOT%{_sysconfdir}/{hostname,locale.conf,machine-id,machine-info,os-release,timezone,vconsole.conf}
276
277 # Install SysV conversion tool for systemd
278 install -p %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}
279
280 install -d $RPM_BUILD_ROOT/var/log
281 :> $RPM_BUILD_ROOT/var/log/btmp
282 :> $RPM_BUILD_ROOT/var/log/wtmp
283
284 %if %{without gtk}
285 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/systemadm.1*
286 %endif
287
288 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
289 %{__rm} $RPM_BUILD_ROOT/%{_lib}/security/pam_systemd.la
290 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
291
292 %clean
293 rm -rf $RPM_BUILD_ROOT
294
295 %post
296 /bin/systemd-machine-id-setup > /dev/null 2>&1 || :
297 /bin/systemctl daemon-reexec > /dev/null 2>&1 || :
298
299 %postun
300 if [ $1 -ge 1 ]; then
301         /bin/systemctl try-restart systemd-logind.service >/dev/null 2>&1 || :
302 fi
303
304 %post   libs -p /sbin/ldconfig
305 %postun libs -p /sbin/ldconfig
306
307 %post units
308 if [ $1 -eq 1 ]; then
309         # Try to read default runlevel from the old inittab if it exists
310         runlevel=$(/bin/awk -F ':' '$3 == "initdefault" && $1 !~ "^#" { print $2 }' /etc/inittab 2> /dev/null)
311         if [ -z "$runlevel" ] ; then
312                 target="/lib/systemd/system/graphical.target"
313         else
314                 target="/lib/systemd/system/runlevel$runlevel.target"
315         fi
316
317         # And symlink what we found to the new-style default.target
318         ln -s "$target" %{_sysconfdir}/systemd/system/default.target >/dev/null 2>&1 || :
319
320         # Setup hostname
321         [ -f /etc/sysconfig/network ] && . /etc/sysconfig/network
322         if [ -n "$HOSTNAME" -a "$HOSTNAME" != "pldmachine" ]; then
323                 [ -f /etc/hostname ] && mv -f /etc/hostname /etc/hostname.rpmsave
324                 echo $HOSTNAME > /etc/hostname
325                 chmod 644 /etc/hostname
326         fi
327 fi
328 # Enable the services we install by default.
329 /bin/systemctl enable \
330         getty@.service \
331         network.service \
332         network-post.service \
333         remote-fs.target \
334         systemd-readahead-replay.service \
335         systemd-readahead-collect.service >/dev/null 2>&1 || :
336
337 # Find and enable all installed interfaces
338 mkdir -p %{_sysconfdir}/systemd/system/network.target.wants >/dev/null 2>&1 || :
339 for f in /etc/sysconfig/interfaces/ifcfg-* ; do
340         ff=$(basename $f)
341         ff=${ff##ifcfg-}
342         case "$ff" in
343         *.rpmorig|*.rpmnew|*.rpmsave|*~|*.orig)
344                 continue
345                 ;;
346         *)
347                 DEVICE="" ; ONBOOT="" ; USERS=""
348                 . $f 2>/dev/null
349                 [ ${USERS:-no} != no ] && continue
350                 if [ "$DEVICE" = "$ff" -a ${ONBOOT:-no} = "yes" ]; then
351                         ln -s /lib/systemd/system/ifup@.service \
352                                 %{_sysconfdir}/systemd/system/network.target.wants/ifcfg@$ff.service >/dev/null 2>&1 || :
353                 fi
354                 ;;
355         esac
356 done
357
358 %preun units
359 if [ $1 -eq 0 ] ; then
360         /bin/systemctl disable \
361                 getty@.service \
362                 network.service \
363                 network-post.service \
364                 remote-fs.target \
365                 systemd-readahead-replay.service \
366                 systemd-readahead-collect.service >/dev/null 2>&1 || :
367
368         %{__rm} -f %{_sysconfdir}/systemd/system/default.target >/dev/null 2>&1 || :
369         %{__rm} -f %{_sysconfdir}/systemd/system/network.target.wants/ifcfg@*.service >/dev/null 2>&1 || :
370 fi
371
372 %postun units
373 if [ $1 -ge 1 ]; then
374         /bin/systemctl daemon-reload > /dev/null 2>&1 || :
375 fi
376
377 %files
378 %defattr(644,root,root,755)
379 %doc DISTRO_PORTING README TODO
380 /etc/dbus-1/system.d/org.freedesktop.hostname1.conf
381 /etc/dbus-1/system.d/org.freedesktop.locale1.conf
382 /etc/dbus-1/system.d/org.freedesktop.login1.conf
383 /etc/dbus-1/system.d/org.freedesktop.systemd1.conf
384 /etc/dbus-1/system.d/org.freedesktop.timedate1.conf
385 %ghost %config(noreplace) %{_sysconfdir}/machine-id
386 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hostname
387 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/locale.conf
388 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/machine-info
389 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/os-release
390 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/timezone
391 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/vconsole.conf
392 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/systemd/*.conf
393 %dir %{_sysconfdir}/systemd/user
394 /etc/xdg/systemd
395 %attr(755,root,root) /bin/systemd
396 %attr(755,root,root) /bin/systemd-ask-password
397 %attr(755,root,root) /bin/systemd-journalctl
398 %attr(755,root,root) /bin/systemd-loginctl
399 %attr(755,root,root) /bin/systemd-machine-id-setup
400 %attr(755,root,root) /bin/systemd-notify
401 %attr(755,root,root) /bin/systemd-tty-ask-password-agent
402 %attr(755,root,root) %{_bindir}/systemd-analyze
403 %attr(755,root,root) %{_bindir}/systemd-cat
404 %attr(755,root,root) %{_bindir}/systemd-cgtop
405 %attr(755,root,root) %{_bindir}/systemd-cgls
406 %attr(755,root,root) %{_bindir}/systemd-nspawn
407 %attr(755,root,root) %{_bindir}/systemd-stdio-bridge
408 %attr(755,root,root) %{_bindir}/systemd-sysv-convert
409 %attr(755,root,root) /lib/systemd/systemd-*
410 %dir /lib/systemd/system-generators
411 %attr(755,root,root) /lib/systemd/system-generators/systemd-*-generator
412 %dir /lib/systemd/system-shutdown
413 /lib/udev/rules.d/99-systemd.rules
414 /lib/udev/rules.d/70-uaccess.rules
415 /lib/udev/rules.d/71-seat.rules
416 /lib/udev/rules.d/73-seat-late.rules
417 %dir %{_libexecdir}/systemd
418 %{_libexecdir}/systemd/user
419 %dir %{_libexecdir}/systemd/user-generators
420 %config(noreplace,missingok) %{_libexecdir}/tmpfiles.d/*.conf
421 %{_datadir}/dbus-1/interfaces/org.freedesktop.hostname1.xml
422 %{_datadir}/dbus-1/interfaces/org.freedesktop.locale1.xml
423 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.*.xml
424 %{_datadir}/dbus-1/interfaces/org.freedesktop.timedate1.xml
425 %{_datadir}/dbus-1/services/org.freedesktop.systemd1.service
426 %{_datadir}/dbus-1/system-services/org.freedesktop.hostname1.service
427 %{_datadir}/dbus-1/system-services/org.freedesktop.locale1.service
428 %{_datadir}/dbus-1/system-services/org.freedesktop.login1.service
429 %{_datadir}/dbus-1/system-services/org.freedesktop.systemd1.service
430 %{_datadir}/dbus-1/system-services/org.freedesktop.timedate1.service
431 %{_datadir}/polkit-1/actions/org.freedesktop.hostname1.policy
432 %{_datadir}/polkit-1/actions/org.freedesktop.locale1.policy
433 %{_datadir}/polkit-1/actions/org.freedesktop.login1.policy
434 %{_datadir}/polkit-1/actions/org.freedesktop.systemd1.policy
435 %{_datadir}/polkit-1/actions/org.freedesktop.timedate1.policy
436 %dir %{_datadir}/systemd
437 %{_datadir}/systemd/kbd-model-map
438 %{_mandir}/man1/systemd.1*
439 %{_mandir}/man1/systemd-*.1*
440 %{_mandir}/man3/sd_booted.3*
441 %{_mandir}/man3/sd_is_fifo.3*
442 %{_mandir}/man3/sd_is_socket.3
443 %{_mandir}/man3/sd_is_socket_inet.3
444 %{_mandir}/man3/sd_is_socket_unix.3
445 %{_mandir}/man3/sd_listen_fds.3*
446 %{_mandir}/man3/sd_notify.3*
447 %{_mandir}/man3/sd_notifyf.3
448 %{_mandir}/man3/sd_readahead.3*
449 %{_mandir}/man5/binfmt.d.5*
450 %{_mandir}/man5/hostname.5*
451 %{_mandir}/man5/locale.conf.5*
452 %{_mandir}/man5/machine-id.5*
453 %{_mandir}/man5/machine-info.5*
454 %{_mandir}/man5/modules-load.d.5*
455 %{_mandir}/man5/os-release.5*
456 %{_mandir}/man5/sysctl.d.5*
457 %{_mandir}/man5/systemd.*.5*
458 %{_mandir}/man5/systemd-logind.conf.5*
459 %{_mandir}/man5/timezone.5*
460 %{_mandir}/man5/vconsole.conf.5*
461 %{_mandir}/man7/daemon.7*
462 %{_mandir}/man7/sd-daemon.7*
463 %{_mandir}/man7/sd-login.7*
464 %{_mandir}/man7/sd-readahead.7*
465 %{_mandir}/man7/systemd.special.7*
466 %attr(640,root,root) %ghost /var/log/btmp
467 %attr(664,root,utmp) %ghost /var/log/wtmp
468
469 %if %{with pam}
470 %attr(755,root,root) /%{_lib}/security/pam_systemd.so
471 %{_mandir}/man8/pam_systemd.8*
472 %endif
473
474 %files init
475 %defattr(644,root,root,755)
476 %attr(755,root,root) /sbin/halt
477 %attr(755,root,root) /sbin/init
478 %attr(755,root,root) /sbin/poweroff
479 %attr(755,root,root) /sbin/reboot
480 %attr(755,root,root) /sbin/runlevel
481 %attr(755,root,root) /sbin/shutdown
482 %attr(755,root,root) /sbin/telinit
483 %{_mandir}/man1/init.1
484 %{_mandir}/man8/halt.8*
485 %{_mandir}/man8/poweroff.8
486 %{_mandir}/man8/reboot.8
487 %{_mandir}/man8/runlevel.8*
488 %{_mandir}/man8/shutdown.8*
489 %{_mandir}/man8/telinit.8*
490
491 %files units
492 %defattr(644,root,root,755)
493 %dir %{_sysconfdir}/binfmt.d
494 %dir %{_sysconfdir}/modules-load.d
495 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/modules-load.d/modules.conf
496 %dir %{_sysconfdir}/sysctl.d
497 %dir %{_sysconfdir}/systemd
498 %dir %{_sysconfdir}/systemd/system
499 %dir %{_sysconfdir}/tmpfiles.d
500 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/tmpfiles.d/*.conf
501 %dir %{_libexecdir}/binfmt.d
502 %dir %{_libexecdir}/modules-load.d
503 %dir %{_libexecdir}/sysctl.d
504 %{_libexecdir}/sysctl.d/coredump.conf
505 %attr(755,root,root) /bin/systemctl
506 %attr(755,root,root) /bin/systemd-tmpfiles
507 %attr(755,root,root) /bin/systemd_booted
508 %{_mandir}/man1/systemctl.1*
509 %{_mandir}/man5/tmpfiles.d.5*
510 %{_mandir}/man8/systemd-tmpfiles.8*
511 %{_npkgconfigdir}/systemd.pc
512
513 /lib/systemd/system/*.automount
514 /lib/systemd/system/*.mount
515 /lib/systemd/system/*.path
516 /lib/systemd/system/*.service
517 /lib/systemd/system/*.socket
518 /lib/systemd/system/*.target
519 /lib/systemd/system/*.timer
520 %dir /lib/systemd/system/*.wants
521 %config(noreplace,missingok) /lib/systemd/system/*.wants/*
522
523 %if %{with gtk}
524 %files gtk
525 %defattr(644,root,root,755)
526 %attr(755,root,root) %{_bindir}/systemadm
527 %attr(755,root,root) %{_bindir}/systemd-gnome-ask-password-agent
528 %{_mandir}/man1/systemadm.1*
529 %endif
530
531 %files libs
532 %defattr(644,root,root,755)
533 %attr(755,root,root) /%{_lib}/libsystemd-daemon.so.*.*.*
534 %attr(755,root,root) %ghost /%{_lib}/libsystemd-daemon.so.0
535 %attr(755,root,root) /%{_lib}/libsystemd-id128.so.*.*.*
536 %attr(755,root,root) %ghost /%{_lib}/libsystemd-id128.so.0
537 %attr(755,root,root) /%{_lib}/libsystemd-journal.so.*.*.*
538 %attr(755,root,root) %ghost /%{_lib}/libsystemd-journal.so.0
539 %attr(755,root,root) /%{_lib}/libsystemd-login.so.*.*.*
540 %attr(755,root,root) %ghost /%{_lib}/libsystemd-login.so.0
541
542 %files devel
543 %defattr(644,root,root,755)
544 %attr(755,root,root) %{_libdir}/libsystemd-daemon.so
545 %attr(755,root,root) %{_libdir}/libsystemd-id128.so
546 %attr(755,root,root) %{_libdir}/libsystemd-journal.so
547 %attr(755,root,root) %{_libdir}/libsystemd-login.so
548 %{_includedir}/%{name}
549 %{_pkgconfigdir}/libsystemd-daemon.pc
550 %{_pkgconfigdir}/libsystemd-id128.pc
551 %{_pkgconfigdir}/libsystemd-journal.pc
552 %{_pkgconfigdir}/libsystemd-login.pc
553 %{_mandir}/man3/sd_get_seats.3*
554 %{_mandir}/man3/sd_get_sessions.3*
555 %{_mandir}/man3/sd_get_uids.3*
556 %{_mandir}/man3/sd_is_mq.3*
557 %{_mandir}/man3/sd_login_monitor_flush.3*
558 %{_mandir}/man3/sd_login_monitor_get_fd.3*
559 %{_mandir}/man3/sd_login_monitor_new.3*
560 %{_mandir}/man3/sd_login_monitor_unref.3*
561 %{_mandir}/man3/sd_pid_get_owner_uid.3*
562 %{_mandir}/man3/sd_pid_get_session.3*
563 %{_mandir}/man3/sd_pid_get_unit.3*
564 %{_mandir}/man3/sd_seat_can_multi_session.3*
565 %{_mandir}/man3/sd_seat_get_active.3*
566 %{_mandir}/man3/sd_seat_get_sessions.3*
567 %{_mandir}/man3/sd_session_get_seat.3*
568 %{_mandir}/man3/sd_session_get_uid.3*
569 %{_mandir}/man3/sd_session_is_active.3*
570 %{_mandir}/man3/sd_uid_get_seats.3*
571 %{_mandir}/man3/sd_uid_get_sessions.3*
572 %{_mandir}/man3/sd_uid_get_state.3*
573 %{_mandir}/man3/sd_uid_is_on_seat.3*
574
575 %files -n bash-completion-systemd
576 %defattr(644,root,root,755)
577 /etc/bash_completion.d/systemd-bash-completion.sh
This page took 0.089345 seconds and 4 git commands to generate.