]> git.pld-linux.org Git - packages/systemd.git/blob - systemd.spec
- rel 2
[packages/systemd.git] / systemd.spec
1 #
2 # TODO:
3 #       - remove compat-pld-var-run.tmpfiles and maybe tmpfiles-not-fatal.patch
4 #         after enough packages provide their own tmpfiles.d configs for
5 #         /var/run directories
6 #
7 # Conditional build:
8 %bcond_without  audit           # without audit support
9 %bcond_without  cryptsetup      # without cryptsetup support
10 %bcond_without  gtk             # build gtk tools
11 %bcond_without  pam             # PAM authentication support
12 %bcond_with     plymouth        # plymouth support
13 %bcond_without  selinux         # without SELinux support
14 %bcond_without  tcpd            # libwrap (tcp_wrappers) support
15
16 Summary:        A System and Service Manager
17 Summary(pl.UTF-8):      systemd - zarządca systemu i usług dla Linuksa
18 Name:           systemd
19 Version:        43
20 Release:        2
21 License:        GPL v2+
22 Group:          Base
23 Source0:        http://www.freedesktop.org/software/systemd/%{name}-%{version}.tar.xz
24 # Source0-md5:  446cc6db7625617af67e2d8e5f503a49
25 Source1:        %{name}-sysv-convert
26 Source2:        %{name}_booted.c
27 Source3:        ifup@.service
28 Source4:        network-post.service
29 Source5:        network.service
30 Source6:        compat-pld-media.tmpfiles
31 Source7:        compat-pld-var-run.tmpfiles
32 Patch0:         target-pld.patch
33 Patch1:         config-pld.patch
34 Patch2:         shut-sysv-up.patch
35 Patch3:         pld-sysv-network.patch
36 Patch4:         tmpfiles-not-fatal.patch
37 URL:            http://www.freedesktop.org/wiki/Software/systemd
38 BuildRequires:  acl-devel
39 %{?with_audit:BuildRequires:    audit-libs-devel}
40 BuildRequires:  autoconf >= 2.63
41 BuildRequires:  automake >= 1:1.11
42 %{?with_cryptsetup:BuildRequires:       cryptsetup-luks-devel}
43 BuildRequires:  dbus-devel >= 1.3.2
44 BuildRequires:  docbook-style-xsl
45 %if %{with gtk}
46 BuildRequires:  glib2-devel >= 1:2.26.1
47 BuildRequires:  gtk+2-devel >= 2:2.24.0
48 BuildRequires:  libgee-devel
49 BuildRequires:  libnotify-devel >= 0.7.0
50 %endif
51 BuildRequires:  binutils >= 3:2.22.52.0.1-2
52 BuildRequires:  gperf
53 BuildRequires:  intltool >= 0.40.0
54 BuildRequires:  kmod-devel >= 5
55 BuildRequires:  libcap-devel
56 %{?with_selinux:BuildRequires:  libselinux-devel}
57 BuildRequires:  libtool >= 2:2.2
58 %{?with_tcpd:BuildRequires:     libwrap-devel}
59 BuildRequires:  libxslt-progs
60 BuildRequires:  m4
61 %{?with_pam:BuildRequires:      pam-devel}
62 %{?with_plymouth:BuildRequires: plymouth-devel}
63 BuildRequires:  pkgconfig >= 0.9.0
64 BuildRequires:  rpmbuild(macros) >= 1.627
65 BuildRequires:  udev-devel >= 1:172
66 # not required for building from release (which contains *.c for *.vala)
67 #BuildRequires: vala >= 0.10.0
68 BuildRequires:  xz-devel
69 Requires:       %{name}-libs = %{version}-%{release}
70 Requires:       %{name}-units = %{version}-%{release}
71 Requires:       /etc/os-release
72 Requires:       SysVinit-tools
73 Requires:       agetty
74 Requires:       dbus >= 1.4.16-6
75 Requires:       filesystem >= 4.0-2
76 Requires:       rc-scripts >= 0.4.5.1-7
77 Requires:       setup >= 2.8.0-2
78 Requires:       udev-core >= 1:175-5
79 Requires:       udev-libs >= 1:172
80 Requires:       virtual(module-tools)
81 Suggests:       ConsoleKit
82 Suggests:       fsck >= 2.20
83 Suggests:       kmod >= 5
84 Suggests:       nss_myhostname
85 # python modules required by systemd-analyze
86 Suggests:       %{name}-no-compat-tmpfiles
87 Suggests:       python-dbus
88 Suggests:       python-modules
89 Suggests:       service(klogd)
90 Suggests:       service(syslog)
91 Provides:       udev-acl
92 # systemd takes care of that and causes problems
93 Conflicts:      binfmt-detector
94 # sytemd wants pam with pam_systemd.so in system-auth...
95 Conflicts:      pam < 1:1.1.5-5
96 # ...and sudo hates it
97 Conflicts:      sudo < 1:1.7.8p2-4
98 Conflicts:      upstart
99 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
100
101 %define         _libexecdir     %{_prefix}/lib
102
103 %description
104 systemd is a system and service manager for Linux, compatible with
105 SysV and LSB init scripts. systemd provides aggressive parallelization
106 capabilities, uses socket and D-Bus activation for starting services,
107 offers on-demand starting of daemons, keeps track of processes using
108 Linux cgroups, supports snapshotting and restoring of the system
109 state, maintains mount and automount points and implements an
110 elaborate transactional dependency-based service control logic. It can
111 work as a drop-in replacement for sysvinit.
112
113 %description -l pl.UTF-8
114 systemd jest zarządcą systemu i usług dla Linuksa, kompatybilny ze
115 skryptami SysV i LSB. systemd udostępnia rozbudowane zdolności
116 paralelizacji, do uruchamiania usług używa socketów oraz D-Busa,
117 oferuje uruchamianie usług na życzenie, monitoruje procesy używając
118 linuksowych cgroups, wspomaga zapisywanie (snapshot) i odczytywanie
119 (restore) stanu systemu, zarządza (auto)mount pointami oraz
120 implementuje starannie opracowaną transakcjonalną, bazującą na
121 zależnościach logikę kontroli usług. Może pracować jako zastępca dla
122 sysvinit.
123
124 %package init
125 Summary:        systemd /sbin/init and LSB/SysV compatibility symlinks
126 Summary(pl.UTF-8):      /sbin/init z systemd i dowiązania dla kompatybilności z LSB/SysV
127 Group:          Base
128 Requires:       systemd
129 Provides:       readahead = 1:1.5.7-3
130 Provides:       virtual(init-daemon)
131 Obsoletes:      SysVinit
132 Obsoletes:      readahead < 1:1.5.7-3
133 Obsoletes:      virtual(init-daemon)
134
135 %description init
136 Install this package when you are ready to final switch to systemd.
137
138 %description init -l pl.UTF-8
139 Ten pakiet należy zainstalować po przygotowaniu się do ostatecznego
140 przejścia na systemd.
141
142 %package units
143 Summary:        Configuration files, directories and installation tool for systemd
144 Summary(pl.UTF-8):      Pliki konfiguracyjne, katalogi i narzędzie instalacyjne dla systemd
145 Group:          Base
146 Requires(post): coreutils
147 Requires(post): /bin/awk
148
149 %description units
150 Basic configuration files, directories and installation tool for the
151 systemd system and service manager.
152
153 This is common config, use %{_sysconfdir}/systemd/system to override.
154
155 %description units -l pl.UTF-8
156 Podstawowe pliki konfiguracyjne, katalogi i narzędzie instalacyjne dla
157 zarządcy systemu i usług systemd.
158
159 Ten pakiet zawiera ogólną konfigurację, ustawienia można nadpisać
160 poprzez katalog %{_sysconfdir}/systemd/system.
161
162 %package gtk
163 Summary:        Graphical frontend for systemd
164 Summary(pl.UTF-8):      Graficzny interfejs do systemd
165 Group:          Base
166 Requires:       %{name} = %{version}-%{release}
167 Requires:       polkit
168
169 %description gtk
170 Graphical front-end for systemd.
171
172 %description gtk -l pl.UTF-8
173 Graficzny interfejs do systemd.
174
175 %package libs
176 Summary:        Shared systemd libraries
177 Summary(pl.UTF-8):      Biblioteki współdzielone systemd
178 Group:          Libraries
179
180 %description libs
181 Shared systemd libraries.
182
183 %description libs -l pl.UTF-8
184 Biblioteki współdzielone systemd.
185
186 %package devel
187 Summary:        Header files for systemd libraries
188 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek systemd
189 Group:          Development/Libraries
190 Requires:       %{name}-libs = %{version}-%{release}
191
192 %description devel
193 Header files for systemd libraries.
194
195 %description devel -l pl.UTF-8
196 Pliki nagłówkowe bibliotek systemd.
197
198 %package -n bash-completion-systemd
199 Summary:        bash-completion for systemd
200 Summary(pl.UTF-8):      Bashowe dopełnianie składni dla systemd
201 Group:          Applications/Shells
202 Requires:       %{name}
203 Requires:       bash-completion
204
205 %description -n bash-completion-systemd
206 bash-completion for systemd.
207
208 %description -n bash-completion-systemd -l pl.UTF-8
209 Bashowe dopełnianie składni dla systemd
210
211 %package no-compat-tmpfiles
212 Summary:        Force update of packages that provide tmpfiles.d configuration
213 Group:          Base
214 Requires(post): sed > 4.0
215 Conflicts:      ConsoleKit-dirs < 0.4.5-7
216 Conflicts:      NetworkManager < 2:0.9.2.0-3
217 Conflicts:      Zope < 2.11.8-2
218 Conflicts:      amavisd-new < 1:2.7.0-1
219 Conflicts:      apache-base < 2.2.21-4
220 Conflicts:      apache-mod_bw < 0.92-3
221 Conflicts:      apache-mod_fastcgi < 2.4.6-6
222 Conflicts:      apache1-base < 1.3.42-5
223 Conflicts:      apache1-mod_fastcgi < 2.4.6-2
224 Conflicts:      asterisk < 10.0.1-2
225 Conflicts:      autossh-init < 1.4b-3
226 Conflicts:      balance < 3.54-2
227 Conflicts:      bind < 7:9.8.1.P1-4
228 Conflicts:      bopm < 3.1.3-4
229 Conflicts:      callweaver < 1.2.1-9
230 Conflicts:      cassandra-bin < 0.8.9-2
231 Conflicts:      clamav < 0.97.3-3
232 Conflicts:      cups < 1:1.5.0-10
233 Conflicts:      dbus < 1.4.16-4
234 Conflicts:      dovecot < 1:2.0.16-3
235 Conflicts:      dspam < 3.9.0-6
236 Conflicts:      fail2ban < 0.8.4-4
237 Conflicts:      filesystem < 4.0-3
238 Conflicts:      gammu-smsd < 1:1.31.0-3
239 # Break gdm2.20 installs
240 #Conflicts:     gdm < 2:3.2.1.1-9
241 Conflicts:      greylistd < 0.8.8-2
242 Conflicts:      inn < 2.4.6-7
243 Conflicts:      ipsec-tools < 0.8.0-3
244 Conflicts:      jabber-common < 0-9
245 Conflicts:      laptop-mode-tools < 1.58-2
246 Conflicts:      libgpod < 0.8.0-6
247 Conflicts:      libvirt-utils < 0.9.9-4
248 Conflicts:      lighttpd < 1.4.30-5
249 Conflicts:      lirc < 0.9.0-20
250 Conflicts:      mailman < 5:2.1.14-4
251 Conflicts:      memcached < 1.4.11-2
252 Conflicts:      mpd < 0.16.5-4
253 Conflicts:      mrtg < 2.17.0-3
254 Conflicts:      munin-common < 1.4.5-5
255 Conflicts:      nagios-nrpe < 2.13-2
256 Conflicts:      ndisc6-rdnssd < 1.0.1-3
257 Conflicts:      nscd < 6:2.14.1-5
258 Conflicts:      nss_ldapd-nslcd < 0.8.4-2
259 Conflicts:      openct < 0.6.20-3
260 Conflicts:      openl2tp < 1.8-3
261 Conflicts:      openldap-overlay-nssov < 2.4.28-4
262 Conflicts:      openldap-servers < 2.4.28-4
263 Conflicts:      openvpn < 2.2.2-2
264 Conflicts:      pam-pam_mount < 2.12-3
265 Conflicts:      pam-pam_ssh < 1.97-2
266 Conflicts:      pcsc-lite < 1.8.1-2
267 Conflicts:      php-dirs < 1.2-3
268 Conflicts:      policyd < 2.0.10-3
269 Conflicts:      pound < 2.6-2
270 Conflicts:      pptp < 1.7.2-3
271 Conflicts:      proftpd-common < 2:1.3.4a-2
272 Conflicts:      pulseaudio-server < 1.1-2
273 Conflicts:      quagga < 0.99.20-3
274 Conflicts:      radvd < 1.8.5-2
275 Conflicts:      rc-scripts < 0.4.5.2-3
276 Conflicts:      red5 < 0.9.0-2
277 Conflicts:      redis-server < 2.4.2-4
278 Conflicts:      smokeping < 2.4.2-10
279 Conflicts:      smtp-gated < 1.4.17-2
280 Conflicts:      socat < 1.7.2.0-2
281 Conflicts:      speech-dispatcher < 0.7.1-2
282 Conflicts:      sphinx < 2.0.3-4
283 Conflicts:      splashutils < 1.5.4.3-3
284 Conflicts:      stunnel < 4.50-2
285 Conflicts:      tenshi < 0.12-2
286 Conflicts:      tor < 0.2.2.35-2
287 Conflicts:      ucarp < 1.5.2-3
288 Conflicts:      udisks < 1.0.4-3
289 Conflicts:      util-vserver < 0.30.216-1.pre3002.3
290 Conflicts:      vpnc < 0.5.3-2
291 Conflicts:      web2ldap < 1.1.0rc1-2
292 Conflicts:      wesnoth-server < 1:1.10-2
293 Conflicts:      wpa_supplicant < 0.7.3-10
294 Conflicts:      xl2tpd < 1.3.0-2
295
296 %description no-compat-tmpfiles
297 Force update of packages that provide tmpfiles.d configuration
298
299 %prep
300 %setup -q
301 %patch0 -p1
302 %patch1 -p1
303 %patch2 -p1
304 %patch3 -p1
305 %patch4 -p1
306 cp -p %{SOURCE2} src/systemd_booted.c
307
308 %build
309 %{__aclocal} -I m4
310 %{__autoconf}
311 %{__autoheader}
312 %{__automake}
313 %configure \
314         %{__enable_disable audit} \
315         %{__enable_disable cryptsetup libcryptsetup} \
316         %{__enable_disable gtk} \
317         %{__enable_disable pam} \
318         %{__enable_disable plymouth} \
319         %{__enable_disable selinux} \
320         %{__enable_disable tcpd tcpwrap} \
321         --disable-silent-rules \
322         --disable-static \
323         --with-distro=pld \
324         --with-rootprefix= \
325         --with-rootlibdir=/%{_lib} \
326         --enable-split-usr
327
328 %{__make}
329 ./libtool --mode=link --tag=CC %{__cc} %{rpmcppflags} %{rpmcflags} -o systemd_booted %{rpmldflags} src/systemd_booted.c -L. -lsystemd-daemon
330
331 %install
332 rm -rf $RPM_BUILD_ROOT
333
334 %{__make} install \
335         DESTDIR=$RPM_BUILD_ROOT
336
337 ./libtool --mode=install install -m755 systemd_booted $RPM_BUILD_ROOT/bin/systemd_booted
338
339 # Main binary has been moved, but we don't want to break existing installs
340 ln -s ../lib/systemd/systemd $RPM_BUILD_ROOT/bin/systemd
341
342 # Create SysV compatibility symlinks. systemctl/systemd are smart
343 # enough to detect the way they were called
344 install -d $RPM_BUILD_ROOT/sbin
345 ln -s ../lib/systemd/systemd $RPM_BUILD_ROOT/sbin/init
346 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/halt
347 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/poweroff
348 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/reboot
349 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/runlevel
350 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/shutdown
351 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/telinit
352
353 ln -s ../modules $RPM_BUILD_ROOT%{_sysconfdir}/modules-load.d/modules.conf
354 # disable random and console SYSV service
355 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/random.service
356 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/console.service
357
358 # add static (non-NetworkManager) networking
359 install %{SOURCE3} $RPM_BUILD_ROOT%{systemdunitdir}/ifup@.service
360 install %{SOURCE4} $RPM_BUILD_ROOT%{systemdunitdir}/network-post.service
361 install %{SOURCE5} $RPM_BUILD_ROOT%{systemdunitdir}/network.service
362
363 # install compatibility tmpfiles configs
364 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/compat-pld-media.conf
365 install %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/compat-pld-var-run.conf
366
367 # All wants links are created at %post to make sure they are not owned
368 # and hence overriden by rpm if the user deletes them (missingok?)
369 %{__rm} -r $RPM_BUILD_ROOT%{_sysconfdir}/systemd/system/*.target.wants
370
371 # it is in rc-scripts pkg
372 %{__rm} $RPM_BUILD_ROOT%{systemdunitdir}/rc-local.service
373
374 # Make sure these directories are properly owned:
375 #       - halt,kexec,poweroff,reboot: generic ones used by ConsoleKit-systemd,
376 #       - syslog _might_ be used by some syslog implementation (none for now),
377 #       - isn't dbus populated by dbus-systemd only (so to be moved there)?
378 install -d $RPM_BUILD_ROOT%{systemdunitdir}/{dbus,halt,kexec,poweroff,reboot,syslog}.target.wants
379
380 # Create new-style configuration files so that we can ghost-own them
381 touch $RPM_BUILD_ROOT%{_sysconfdir}/{hostname,locale.conf,machine-id,machine-info,timezone,vconsole.conf}
382
383 # Install SysV conversion tool for systemd
384 install -p %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}
385
386 install -d $RPM_BUILD_ROOT/var/log
387 :> $RPM_BUILD_ROOT/var/log/btmp
388 :> $RPM_BUILD_ROOT/var/log/wtmp
389
390 %if %{without gtk}
391 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/systemadm.1*
392 %endif
393
394 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
395 %{__rm} $RPM_BUILD_ROOT/%{_lib}/security/pam_systemd.la
396 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
397
398 %clean
399 rm -rf $RPM_BUILD_ROOT
400
401 %post
402 /bin/systemd-machine-id-setup > /dev/null 2>&1 || :
403 /bin/systemctl daemon-reexec > /dev/null 2>&1 || :
404
405 %postun
406 if [ $1 -ge 1 ]; then
407         /bin/systemctl try-restart systemd-logind.service >/dev/null 2>&1 || :
408 fi
409
410 %post   libs -p /sbin/ldconfig
411 %postun libs -p /sbin/ldconfig
412
413 %post units
414 if [ $1 -eq 1 ]; then
415         # Try to read default runlevel from the old inittab if it exists
416         runlevel=$(/bin/awk -F ':' '$3 == "initdefault" && $1 !~ "^#" { print $2 }' /etc/inittab 2> /dev/null)
417         if [ -z "$runlevel" ] ; then
418                 target="%{systemdunitdir}/graphical.target"
419         else
420                 target="%{systemdunitdir}/runlevel$runlevel.target"
421         fi
422
423         # And symlink what we found to the new-style default.target
424         ln -s "$target" %{_sysconfdir}/systemd/system/default.target >/dev/null 2>&1 || :
425
426         # Setup hostname
427         [ -f /etc/sysconfig/network ] && . /etc/sysconfig/network
428         if [ -n "$HOSTNAME" -a "$HOSTNAME" != "pldmachine" ]; then
429                 [ -f /etc/hostname ] && mv -f /etc/hostname /etc/hostname.rpmsave
430                 echo $HOSTNAME > /etc/hostname
431                 chmod 644 /etc/hostname
432         fi
433 fi
434 # Enable the services we install by default.
435 /bin/systemctl enable \
436         getty@.service \
437         network.service \
438         network-post.service \
439         remote-fs.target \
440         systemd-readahead-replay.service \
441         systemd-readahead-collect.service >/dev/null 2>&1 || :
442
443 # Find and enable all installed interfaces
444 mkdir -p %{_sysconfdir}/systemd/system/network.target.wants >/dev/null 2>&1 || :
445 for f in /etc/sysconfig/interfaces/ifcfg-* ; do
446         ff=$(basename $f)
447         ff=${ff##ifcfg-}
448         case "$ff" in
449         *.rpmorig|*.rpmnew|*.rpmsave|*~|*.orig)
450                 continue
451                 ;;
452         *)
453                 DEVICE="" ; ONBOOT="" ; USERS=""
454                 . $f 2>/dev/null
455                 [ ${USERS:-no} != no ] && continue
456                 if [ "$DEVICE" = "$ff" -a ${ONBOOT:-no} = "yes" ]; then
457                         ln -s %{systemdunitdir}/ifup@.service \
458                                 %{_sysconfdir}/systemd/system/network.target.wants/ifcfg@$ff.service >/dev/null 2>&1 || :
459                 fi
460                 ;;
461         esac
462 done
463
464 %preun units
465 if [ $1 -eq 0 ] ; then
466         /bin/systemctl disable \
467                 getty@.service \
468                 network.service \
469                 network-post.service \
470                 remote-fs.target \
471                 systemd-readahead-replay.service \
472                 systemd-readahead-collect.service >/dev/null 2>&1 || :
473
474         %{__rm} -f %{_sysconfdir}/systemd/system/default.target >/dev/null 2>&1 || :
475         %{__rm} -f %{_sysconfdir}/systemd/system/network.target.wants/ifcfg@*.service >/dev/null 2>&1 || :
476 fi
477
478 %postun units
479 if [ $1 -ge 1 ]; then
480         /bin/systemctl daemon-reload > /dev/null 2>&1 || :
481 fi
482
483 %post no-compat-tmpfiles
484 %{__sed} -i -e '/^#/!s/^/# /g' %{_sysconfdir}/tmpfiles.d/compat-pld-var-run.conf
485
486 %files
487 %defattr(644,root,root,755)
488 %doc DISTRO_PORTING README TODO
489 /etc/dbus-1/system.d/org.freedesktop.hostname1.conf
490 /etc/dbus-1/system.d/org.freedesktop.locale1.conf
491 /etc/dbus-1/system.d/org.freedesktop.login1.conf
492 /etc/dbus-1/system.d/org.freedesktop.systemd1.conf
493 /etc/dbus-1/system.d/org.freedesktop.timedate1.conf
494 %ghost %config(noreplace) %{_sysconfdir}/machine-id
495 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hostname
496 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/locale.conf
497 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/machine-info
498 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/timezone
499 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/vconsole.conf
500 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/systemd/*.conf
501 %dir %{_sysconfdir}/systemd/user
502 /etc/xdg/systemd
503 %attr(755,root,root) /bin/systemd
504 %attr(755,root,root) /bin/systemd-ask-password
505 %attr(755,root,root) /bin/systemd-journalctl
506 %attr(755,root,root) /bin/systemd-loginctl
507 %attr(755,root,root) /bin/systemd-machine-id-setup
508 %attr(755,root,root) /bin/systemd-notify
509 %attr(755,root,root) /bin/systemd-tty-ask-password-agent
510 %attr(755,root,root) %{_bindir}/systemd-analyze
511 %attr(755,root,root) %{_bindir}/systemd-cat
512 %attr(755,root,root) %{_bindir}/systemd-cgtop
513 %attr(755,root,root) %{_bindir}/systemd-cgls
514 %attr(755,root,root) %{_bindir}/systemd-nspawn
515 %attr(755,root,root) %{_bindir}/systemd-stdio-bridge
516 %attr(755,root,root) %{_bindir}/systemd-sysv-convert
517 %attr(755,root,root) /lib/systemd/systemd-*
518 %dir /lib/systemd/system-generators
519 %attr(755,root,root) /lib/systemd/systemd
520 %attr(755,root,root) /lib/systemd/system-generators/systemd-*-generator
521 %dir /lib/systemd/system-shutdown
522 /lib/udev/rules.d/99-systemd.rules
523 /lib/udev/rules.d/70-uaccess.rules
524 /lib/udev/rules.d/71-seat.rules
525 /lib/udev/rules.d/73-seat-late.rules
526 %dir %{_libexecdir}/systemd
527 %{_libexecdir}/systemd/user
528 %dir %{_libexecdir}/systemd/user-generators
529 %config(noreplace,missingok) %{_libexecdir}/tmpfiles.d/*.conf
530 %{_datadir}/dbus-1/interfaces/org.freedesktop.hostname1.xml
531 %{_datadir}/dbus-1/interfaces/org.freedesktop.locale1.xml
532 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.*.xml
533 %{_datadir}/dbus-1/interfaces/org.freedesktop.timedate1.xml
534 %{_datadir}/dbus-1/services/org.freedesktop.systemd1.service
535 %{_datadir}/dbus-1/system-services/org.freedesktop.hostname1.service
536 %{_datadir}/dbus-1/system-services/org.freedesktop.locale1.service
537 %{_datadir}/dbus-1/system-services/org.freedesktop.login1.service
538 %{_datadir}/dbus-1/system-services/org.freedesktop.systemd1.service
539 %{_datadir}/dbus-1/system-services/org.freedesktop.timedate1.service
540 %{_datadir}/polkit-1/actions/org.freedesktop.hostname1.policy
541 %{_datadir}/polkit-1/actions/org.freedesktop.locale1.policy
542 %{_datadir}/polkit-1/actions/org.freedesktop.login1.policy
543 %{_datadir}/polkit-1/actions/org.freedesktop.systemd1.policy
544 %{_datadir}/polkit-1/actions/org.freedesktop.timedate1.policy
545 %dir %{_datadir}/systemd
546 %{_datadir}/systemd/kbd-model-map
547 %{_mandir}/man1/systemd.1*
548 %{_mandir}/man1/systemd-*.1*
549 %{_mandir}/man3/sd_booted.3*
550 %{_mandir}/man3/sd_is_fifo.3*
551 %{_mandir}/man3/sd_is_socket.3
552 %{_mandir}/man3/sd_is_socket_inet.3
553 %{_mandir}/man3/sd_is_socket_unix.3
554 %{_mandir}/man3/sd_listen_fds.3*
555 %{_mandir}/man3/sd_notify.3*
556 %{_mandir}/man3/sd_notifyf.3
557 %{_mandir}/man3/sd_readahead.3*
558 %{_mandir}/man5/binfmt.d.5*
559 %{_mandir}/man5/hostname.5*
560 %{_mandir}/man5/locale.conf.5*
561 %{_mandir}/man5/machine-id.5*
562 %{_mandir}/man5/machine-info.5*
563 %{_mandir}/man5/modules-load.d.5*
564 %{_mandir}/man5/os-release.5*
565 %{_mandir}/man5/sysctl.d.5*
566 %{_mandir}/man5/systemd.*.5*
567 %{_mandir}/man5/systemd-logind.conf.5*
568 %{_mandir}/man5/timezone.5*
569 %{_mandir}/man5/vconsole.conf.5*
570 %{_mandir}/man7/daemon.7*
571 %{_mandir}/man7/sd-daemon.7*
572 %{_mandir}/man7/sd-login.7*
573 %{_mandir}/man7/sd-readahead.7*
574 %{_mandir}/man7/systemd.special.7*
575 %attr(640,root,root) %ghost /var/log/btmp
576 %attr(664,root,utmp) %ghost /var/log/wtmp
577
578 %if %{with pam}
579 %attr(755,root,root) /%{_lib}/security/pam_systemd.so
580 %{_mandir}/man8/pam_systemd.8*
581 %endif
582
583 %files init
584 %defattr(644,root,root,755)
585 %attr(755,root,root) /sbin/halt
586 %attr(755,root,root) /sbin/init
587 %attr(755,root,root) /sbin/poweroff
588 %attr(755,root,root) /sbin/reboot
589 %attr(755,root,root) /sbin/runlevel
590 %attr(755,root,root) /sbin/shutdown
591 %attr(755,root,root) /sbin/telinit
592 %{_mandir}/man1/init.1
593 %{_mandir}/man8/halt.8*
594 %{_mandir}/man8/poweroff.8
595 %{_mandir}/man8/reboot.8
596 %{_mandir}/man8/runlevel.8*
597 %{_mandir}/man8/shutdown.8*
598 %{_mandir}/man8/telinit.8*
599
600 %files units
601 %defattr(644,root,root,755)
602 %dir %{_sysconfdir}/binfmt.d
603 %dir %{_sysconfdir}/modules-load.d
604 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/modules-load.d/modules.conf
605 %dir %{_sysconfdir}/sysctl.d
606 %dir %{_sysconfdir}/systemd
607 %dir %{_sysconfdir}/systemd/system
608 %dir %{_sysconfdir}/tmpfiles.d
609 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/tmpfiles.d/*.conf
610 %dir %{_libexecdir}/binfmt.d
611 %dir %{_libexecdir}/modules-load.d
612 %dir %{_libexecdir}/sysctl.d
613 %{_libexecdir}/sysctl.d/coredump.conf
614 %attr(755,root,root) /bin/systemctl
615 %attr(755,root,root) /bin/systemd-tmpfiles
616 %attr(755,root,root) /bin/systemd_booted
617 %{_mandir}/man1/systemctl.1*
618 %{_mandir}/man5/tmpfiles.d.5*
619 %{_mandir}/man8/systemd-tmpfiles.8*
620 %{_npkgconfigdir}/systemd.pc
621
622 %{systemdunitdir}/*.automount
623 %{systemdunitdir}/*.mount
624 %{systemdunitdir}/*.path
625 %{systemdunitdir}/*.service
626 %{systemdunitdir}/*.socket
627 %{systemdunitdir}/*.target
628 %{systemdunitdir}/*.timer
629 %dir %{systemdunitdir}/*.wants
630 %config(noreplace,missingok) %{systemdunitdir}/*.wants/*
631
632 %if %{with gtk}
633 %files gtk
634 %defattr(644,root,root,755)
635 %attr(755,root,root) %{_bindir}/systemadm
636 %attr(755,root,root) %{_bindir}/systemd-gnome-ask-password-agent
637 %{_mandir}/man1/systemadm.1*
638 %endif
639
640 %files libs
641 %defattr(644,root,root,755)
642 %attr(755,root,root) /%{_lib}/libsystemd-daemon.so.*.*.*
643 %attr(755,root,root) %ghost /%{_lib}/libsystemd-daemon.so.0
644 %attr(755,root,root) /%{_lib}/libsystemd-id128.so.*.*.*
645 %attr(755,root,root) %ghost /%{_lib}/libsystemd-id128.so.0
646 %attr(755,root,root) /%{_lib}/libsystemd-journal.so.*.*.*
647 %attr(755,root,root) %ghost /%{_lib}/libsystemd-journal.so.0
648 %attr(755,root,root) /%{_lib}/libsystemd-login.so.*.*.*
649 %attr(755,root,root) %ghost /%{_lib}/libsystemd-login.so.0
650
651 %files devel
652 %defattr(644,root,root,755)
653 %attr(755,root,root) %{_libdir}/libsystemd-daemon.so
654 %attr(755,root,root) %{_libdir}/libsystemd-id128.so
655 %attr(755,root,root) %{_libdir}/libsystemd-journal.so
656 %attr(755,root,root) %{_libdir}/libsystemd-login.so
657 %{_includedir}/%{name}
658 %{_pkgconfigdir}/libsystemd-daemon.pc
659 %{_pkgconfigdir}/libsystemd-id128.pc
660 %{_pkgconfigdir}/libsystemd-journal.pc
661 %{_pkgconfigdir}/libsystemd-login.pc
662 %{_mandir}/man3/sd_get_seats.3*
663 %{_mandir}/man3/sd_get_sessions.3*
664 %{_mandir}/man3/sd_get_uids.3*
665 %{_mandir}/man3/sd_is_mq.3*
666 %{_mandir}/man3/sd_login_monitor_flush.3*
667 %{_mandir}/man3/sd_login_monitor_get_fd.3*
668 %{_mandir}/man3/sd_login_monitor_new.3*
669 %{_mandir}/man3/sd_login_monitor_unref.3*
670 %{_mandir}/man3/sd_pid_get_owner_uid.3*
671 %{_mandir}/man3/sd_pid_get_session.3*
672 %{_mandir}/man3/sd_pid_get_unit.3*
673 %{_mandir}/man3/sd_seat_can_multi_session.3*
674 %{_mandir}/man3/sd_seat_get_active.3*
675 %{_mandir}/man3/sd_seat_get_sessions.3*
676 %{_mandir}/man3/sd_session_get_seat.3*
677 %{_mandir}/man3/sd_session_get_uid.3*
678 %{_mandir}/man3/sd_session_is_active.3*
679 %{_mandir}/man3/sd_uid_get_seats.3*
680 %{_mandir}/man3/sd_uid_get_sessions.3*
681 %{_mandir}/man3/sd_uid_get_state.3*
682 %{_mandir}/man3/sd_uid_is_on_seat.3*
683
684 %files -n bash-completion-systemd
685 %defattr(644,root,root,755)
686 /etc/bash_completion.d/systemd-bash-completion.sh
687
688 %files no-compat-tmpfiles
689 %defattr(644,root,root,755)
690 # empty package
This page took 0.141263 seconds and 4 git commands to generate.