]> git.pld-linux.org Git - packages/systemd.git/blob - systemd.spec
- -gtk split off to systemd-ui project
[packages/systemd.git] / systemd.spec
1 #
2 # TODO:
3 #       - remove compat-pld-var-run.tmpfiles and maybe tmpfiles-not-fatal.patch
4 #         after enough packages provide their own tmpfiles.d configs for
5 #         /var/run directories
6 #
7 # Conditional build:
8 %bcond_without  audit           # without audit support
9 %bcond_without  cryptsetup      # without cryptsetup support
10 %bcond_without  pam             # PAM authentication support
11 %bcond_without  plymouth        # do not install plymouth units
12 %bcond_without  selinux         # without SELinux support
13 %bcond_without  tcpd            # libwrap (tcp_wrappers) support
14
15 Summary:        A System and Service Manager
16 Summary(pl.UTF-8):      systemd - zarządca systemu i usług dla Linuksa
17 Name:           systemd
18 Version:        44
19 Release:        5
20 License:        GPL v2+
21 Group:          Base
22 Source0:        http://www.freedesktop.org/software/systemd/%{name}-%{version}.tar.xz
23 # Source0-md5:  11f44ff74c87850064e4351518bcff17
24 Source1:        %{name}-sysv-convert
25 Source2:        %{name}_booted.c
26 Source3:        network.service
27 Source4:        compat-pld-media.tmpfiles
28 Source5:        compat-pld-var-run.tmpfiles
29 Source10:       pld-storage-init-late.service
30 Source11:       pld-storage-init.service
31 Source12:       pld-wait-storage.service
32 Source13:       pld-storage-init.sh
33 Patch0:         target-pld.patch
34 Patch1:         config-pld.patch
35 Patch2:         shut-sysv-up.patch
36 Patch3:         pld-sysv-network.patch
37 Patch4:         tmpfiles-not-fatal.patch
38 Patch5:         CVE-2012-1174.patch
39 URL:            http://www.freedesktop.org/wiki/Software/systemd
40 BuildRequires:  acl-devel
41 %{?with_audit:BuildRequires:    audit-libs-devel}
42 BuildRequires:  autoconf >= 2.63
43 BuildRequires:  automake >= 1:1.11
44 BuildRequires:  binutils >= 3:2.22.52.0.1-2
45 %{?with_cryptsetup:BuildRequires:       cryptsetup-luks-devel}
46 BuildRequires:  dbus-devel >= 1.3.2
47 BuildRequires:  docbook-style-xsl
48 BuildRequires:  gperf
49 BuildRequires:  intltool >= 0.40.0
50 BuildRequires:  kmod-devel >= 5
51 BuildRequires:  libcap-devel
52 %{?with_selinux:BuildRequires:  libselinux-devel >= 2.1.0}
53 BuildRequires:  libtool >= 2:2.2
54 %{?with_tcpd:BuildRequires:     libwrap-devel}
55 BuildRequires:  libxslt-progs
56 BuildRequires:  m4
57 %{?with_pam:BuildRequires:      pam-devel}
58 BuildRequires:  pkgconfig >= 0.9.0
59 BuildRequires:  rpmbuild(macros) >= 1.627
60 BuildRequires:  udev-devel >= 1:172
61 # not required for building from release (which contains *.c for *.vala)
62 #BuildRequires: vala >= 0.10.0
63 BuildRequires:  xz-devel
64 Requires:       %{name}-libs = %{version}-%{release}
65 Requires:       %{name}-units = %{version}-%{release}
66 Requires:       /etc/os-release
67 Requires:       SysVinit-tools
68 Requires:       agetty
69 Requires:       dbus >= 1.4.16-6
70 Requires:       filesystem >= 4.0-2
71 Requires:       libutempter
72 Requires:       rc-scripts >= 0.4.5.3-7
73 Requires:       setup >= 2.8.0-2
74 Requires:       udev-core >= 1:175-5
75 Requires:       udev-libs >= 1:172
76 Requires:       virtual(module-tools)
77 Suggests:       %{name}-no-compat-tmpfiles
78 Suggests:       ConsoleKit
79 Suggests:       fsck >= 2.20
80 Suggests:       kmod >= 5
81 Suggests:       nss_myhostname
82 Suggests:       service(klogd)
83 Suggests:       service(syslog)
84 Provides:       udev-acl
85 # systemd takes care of that and causes problems
86 Conflicts:      binfmt-detector
87 # sytemd wants pam with pam_systemd.so in system-auth...
88 Conflicts:      pam < 1:1.1.5-5
89 # ...and sudo hates it
90 Conflicts:      sudo < 1:1.7.8p2-4
91 # for prefdm script
92 Conflicts:      xinitrc-ng < 1.0
93 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
94
95 %define         _libexecdir     %{_prefix}/lib
96
97 %description
98 systemd is a system and service manager for Linux, compatible with
99 SysV and LSB init scripts. systemd provides aggressive parallelization
100 capabilities, uses socket and D-Bus activation for starting services,
101 offers on-demand starting of daemons, keeps track of processes using
102 Linux cgroups, supports snapshotting and restoring of the system
103 state, maintains mount and automount points and implements an
104 elaborate transactional dependency-based service control logic. It can
105 work as a drop-in replacement for sysvinit.
106
107 %description -l pl.UTF-8
108 systemd jest zarządcą systemu i usług dla Linuksa, kompatybilny ze
109 skryptami SysV i LSB. systemd udostępnia rozbudowane zdolności
110 paralelizacji, do uruchamiania usług używa socketów oraz D-Busa,
111 oferuje uruchamianie usług na życzenie, monitoruje procesy używając
112 linuksowych cgroups, wspomaga zapisywanie (snapshot) i odczytywanie
113 (restore) stanu systemu, zarządza (auto)mount pointami oraz
114 implementuje starannie opracowaną transakcjonalną, bazującą na
115 zależnościach logikę kontroli usług. Może pracować jako zastępca dla
116 sysvinit.
117
118 %package init
119 Summary:        systemd /sbin/init and LSB/SysV compatibility symlinks
120 Summary(pl.UTF-8):      /sbin/init z systemd i dowiązania dla kompatybilności z LSB/SysV
121 Group:          Base
122 Requires:       systemd
123 Provides:       readahead = 1:1.5.7-3
124 Provides:       virtual(init-daemon)
125 Obsoletes:      SysVinit
126 Obsoletes:      readahead < 1:1.5.7-3
127 Obsoletes:      virtual(init-daemon)
128 Conflicts:      upstart
129
130 %description init
131 Install this package when you are ready to final switch to systemd.
132
133 %description init -l pl.UTF-8
134 Ten pakiet należy zainstalować po przygotowaniu się do ostatecznego
135 przejścia na systemd.
136
137 %package units
138 Summary:        Configuration files, directories and installation tool for systemd
139 Summary(pl.UTF-8):      Pliki konfiguracyjne, katalogi i narzędzie instalacyjne dla systemd
140 Group:          Base
141 Requires(post): coreutils
142 Requires(post): /bin/awk
143
144 %description units
145 Basic configuration files, directories and installation tool for the
146 systemd system and service manager.
147
148 This is common config, use %{_sysconfdir}/systemd/system to override.
149
150 %description units -l pl.UTF-8
151 Podstawowe pliki konfiguracyjne, katalogi i narzędzie instalacyjne dla
152 zarządcy systemu i usług systemd.
153
154 Ten pakiet zawiera ogólną konfigurację, ustawienia można nadpisać
155 poprzez katalog %{_sysconfdir}/systemd/system.
156
157 %package plymouth
158 Summary:        Plymouth support units for systemd
159 Summary(pl.UTF-8):      Jednostki wspierające Plymouth dla systemd
160 Group:          Base
161 Requires:       %{name}-units = %{version}-%{release}
162 Requires:       plymouth
163
164 %description plymouth
165 Plymouth (graphical boot) support units for systemd.
166
167 %description plymouth -l pl.UTF-8
168 Jednostki wspierające Plymouth (graficzny start systemu) dla systemd.
169
170 %package analyze
171 Summary:        Tool for processing systemd profiling information
172 Group:          Base
173 Requires:       %{name} = %{version}-%{release}
174 Requires:       python-dbus
175 Requires:       python-modules
176 Requires:       python-pycairo
177 Conflicts:      %{name} < 44-3
178
179 %description analyze
180 'systemd-analyze blame' lists which systemd unit needed how much time
181 to finish initialization at boot. 'systemd-analyze plot' renders an
182 SVG visualizing the parallel start of units at boot.
183
184 %package libs
185 Summary:        Shared systemd libraries
186 Summary(pl.UTF-8):      Biblioteki współdzielone systemd
187 Group:          Libraries
188
189 %description libs
190 Shared systemd libraries.
191
192 %description libs -l pl.UTF-8
193 Biblioteki współdzielone systemd.
194
195 %package devel
196 Summary:        Header files for systemd libraries
197 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek systemd
198 Group:          Development/Libraries
199 Requires:       %{name}-libs = %{version}-%{release}
200
201 %description devel
202 Header files for systemd libraries.
203
204 %description devel -l pl.UTF-8
205 Pliki nagłówkowe bibliotek systemd.
206
207 %package -n bash-completion-systemd
208 Summary:        bash-completion for systemd
209 Summary(pl.UTF-8):      Bashowe dopełnianie składni dla systemd
210 Group:          Applications/Shells
211 Requires:       %{name}
212 Requires:       bash-completion
213
214 %description -n bash-completion-systemd
215 bash-completion for systemd.
216
217 %description -n bash-completion-systemd -l pl.UTF-8
218 Bashowe dopełnianie składni dla systemd
219
220 %package no-compat-tmpfiles
221 Summary:        Force update of packages that provide tmpfiles.d configuration
222 Group:          Base
223 Requires(post): sed > 4.0
224 Conflicts:      ConsoleKit-dirs < 0.4.5-7
225 Conflicts:      NetworkManager < 2:0.9.2.0-3
226 Conflicts:      Zope < 2.11.8-2
227 Conflicts:      amavisd-new < 1:2.7.0-1
228 Conflicts:      apache-base < 2.2.21-4
229 Conflicts:      apache-mod_bw < 0.92-3
230 Conflicts:      apache-mod_fastcgi < 2.4.6-6
231 Conflicts:      apache1-base < 1.3.42-5
232 Conflicts:      apache1-mod_fastcgi < 2.4.6-2
233 Conflicts:      asterisk < 10.0.1-2
234 Conflicts:      autossh-init < 1.4b-3
235 Conflicts:      balance < 3.54-2
236 Conflicts:      bind < 7:9.8.1.P1-4
237 Conflicts:      bopm < 3.1.3-4
238 Conflicts:      callweaver < 1.2.1-9
239 Conflicts:      cassandra-bin < 0.8.9-2
240 Conflicts:      clamav < 0.97.3-3
241 Conflicts:      cups < 1:1.5.0-10
242 Conflicts:      dbus < 1.4.16-4
243 Conflicts:      dovecot < 1:2.0.16-3
244 Conflicts:      dspam < 3.9.0-6
245 Conflicts:      fail2ban < 0.8.4-4
246 Conflicts:      filesystem < 4.0-3
247 Conflicts:      gammu-smsd < 1:1.31.0-3
248 # Break gdm2.20 installs
249 #Conflicts:     gdm < 2:3.2.1.1-9
250 Conflicts:      greylistd < 0.8.8-2
251 Conflicts:      inn < 2.4.6-7
252 Conflicts:      ipsec-tools < 0.8.0-3
253 Conflicts:      jabber-common < 0-9
254 Conflicts:      laptop-mode-tools < 1.58-2
255 Conflicts:      libgpod < 0.8.0-6
256 Conflicts:      libvirt-utils < 0.9.9-4
257 Conflicts:      lighttpd < 1.4.30-5
258 Conflicts:      lirc < 0.9.0-20
259 Conflicts:      mailman < 5:2.1.14-4
260 Conflicts:      memcached < 1.4.11-2
261 Conflicts:      mpd < 0.16.5-4
262 Conflicts:      mrtg < 2.17.0-3
263 Conflicts:      munin-common < 1.4.5-5
264 Conflicts:      nagios-nrpe < 2.13-2
265 Conflicts:      ndisc6-rdnssd < 1.0.1-3
266 Conflicts:      nscd < 6:2.14.1-5
267 Conflicts:      nss_ldapd-nslcd < 0.8.4-2
268 Conflicts:      openct < 0.6.20-3
269 Conflicts:      openl2tp < 1.8-3
270 Conflicts:      openldap-overlay-nssov < 2.4.28-4
271 Conflicts:      openldap-servers < 2.4.28-4
272 Conflicts:      openvpn < 2.2.2-2
273 Conflicts:      pam-pam_mount < 2.12-3
274 Conflicts:      pam-pam_ssh < 1.97-2
275 Conflicts:      pcsc-lite < 1.8.1-2
276 Conflicts:      php-dirs < 1.2-3
277 Conflicts:      policyd < 2.0.10-3
278 Conflicts:      pound < 2.6-2
279 Conflicts:      pptp < 1.7.2-3
280 Conflicts:      proftpd-common < 2:1.3.4a-2
281 Conflicts:      pulseaudio-server < 1.1-2
282 Conflicts:      quagga < 0.99.20-3
283 Conflicts:      radvd < 1.8.5-2
284 Conflicts:      rc-scripts < 0.4.5.2-3
285 Conflicts:      red5 < 0.9.0-2
286 Conflicts:      redis-server < 2.4.2-4
287 Conflicts:      smokeping < 2.4.2-10
288 Conflicts:      smtp-gated < 1.4.17-2
289 Conflicts:      socat < 1.7.2.0-2
290 Conflicts:      speech-dispatcher < 0.7.1-2
291 Conflicts:      sphinx < 2.0.3-4
292 Conflicts:      splashutils < 1.5.4.3-3
293 Conflicts:      stunnel < 4.50-2
294 Conflicts:      tenshi < 0.12-2
295 Conflicts:      tor < 0.2.2.35-2
296 Conflicts:      ucarp < 1.5.2-3
297 Conflicts:      udisks < 1.0.4-3
298 Conflicts:      util-vserver < 0.30.216-1.pre3002.3
299 Conflicts:      vpnc < 0.5.3-2
300 Conflicts:      web2ldap < 1.1.0rc1-2
301 Conflicts:      wesnoth-server < 1:1.10-2
302 Conflicts:      wpa_supplicant < 0.7.3-10
303 Conflicts:      xl2tpd < 1.3.0-2
304
305 %description no-compat-tmpfiles
306 Force update of packages that provide tmpfiles.d configuration
307
308 %prep
309 %setup -q
310 %patch0 -p1
311 %patch1 -p1
312 %patch2 -p1
313 %patch3 -p1
314 %patch4 -p1
315 %patch5 -p1
316 cp -p %{SOURCE2} src/systemd_booted.c
317
318 %build
319 %{__aclocal} -I m4
320 %{__autoconf}
321 %{__autoheader}
322 %{__automake}
323 %configure \
324         %{__enable_disable audit} \
325         %{__enable_disable cryptsetup libcryptsetup} \
326         --disable-gtk \
327         %{__enable_disable pam} \
328         %{__enable_disable plymouth} \
329         %{__enable_disable selinux} \
330         %{__enable_disable tcpd tcpwrap} \
331         --disable-silent-rules \
332         --disable-static \
333         --with-distro=pld \
334         --with-rootprefix= \
335         --with-rootlibdir=/%{_lib} \
336         --enable-split-usr
337
338 %{__make}
339 ./libtool --mode=link --tag=CC %{__cc} %{rpmcppflags} %{rpmcflags} -o systemd_booted %{rpmldflags} src/systemd_booted.c -L. -lsystemd-daemon
340
341 %install
342 rm -rf $RPM_BUILD_ROOT
343 install -d $RPM_BUILD_ROOT/var/lib/%{name}/coredump
344
345 %{__make} install \
346         DESTDIR=$RPM_BUILD_ROOT
347
348 ./libtool --mode=install install -p -m755 systemd_booted $RPM_BUILD_ROOT/bin/systemd_booted
349
350 # Main binary has been moved, but we don't want to break existing installs
351 ln -s ../lib/systemd/systemd $RPM_BUILD_ROOT/bin/systemd
352
353 # Create SysV compatibility symlinks. systemctl/systemd are smart
354 # enough to detect the way they were called
355 install -d $RPM_BUILD_ROOT/sbin
356 ln -s ../lib/systemd/systemd $RPM_BUILD_ROOT/sbin/init
357 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/halt
358 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/poweroff
359 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/reboot
360 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/runlevel
361 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/shutdown
362 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/telinit
363
364 ln -s ../modules $RPM_BUILD_ROOT%{_sysconfdir}/modules-load.d/modules.conf
365
366 # disable redundant SYSV services
367 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/allowlogin.service
368 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/console.service
369 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/cpusets.service
370 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/killall.service
371 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/netfs.service
372 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/random.service
373
374 # add static (non-NetworkManager) networking
375 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{systemdunitdir}/network.service
376
377 # install compatibility tmpfiles configs
378 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/compat-pld-media.conf
379 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/compat-pld-var-run.conf
380
381 # Install and enable storage subsystems support services (RAID, LVM, etc.)
382 cp -p %{SOURCE10} $RPM_BUILD_ROOT%{systemdunitdir}/pld-storage-init-late.service
383 cp -p %{SOURCE11} $RPM_BUILD_ROOT%{systemdunitdir}/pld-storage-init.service
384 cp -p %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/pld-wait-storage.service
385 install -p %{SOURCE13} $RPM_BUILD_ROOT/lib/systemd/pld-storage-init
386
387 ln -s ../pld-storage-init-late.service $RPM_BUILD_ROOT%{systemdunitdir}/local-fs.target.wants/pld-storage-init-late.service
388 ln -s ../pld-storage-init.service $RPM_BUILD_ROOT%{systemdunitdir}/local-fs.target.wants/pld-storage-init.service
389
390 # handled by rc-local sysv service, no need for generator
391 %{__rm} $RPM_BUILD_ROOT/lib/systemd/system-generators/systemd-rc-local-generator
392
393 # Make sure these directories are properly owned:
394 #       - halt,kexec,poweroff,reboot: generic ones used by ConsoleKit-systemd,
395 #       - syslog _might_ be used by some syslog implementation (none for now),
396 #       - isn't dbus populated by dbus-systemd only (so to be moved there)?
397 install -d $RPM_BUILD_ROOT%{systemdunitdir}/{dbus,halt,kexec,poweroff,reboot,syslog}.target.wants
398
399 # Create new-style configuration files so that we can ghost-own them
400 touch $RPM_BUILD_ROOT%{_sysconfdir}/{hostname,locale.conf,machine-id,machine-info,timezone,vconsole.conf}
401
402 # Install SysV conversion tool for systemd
403 install -p %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}
404
405 install -d $RPM_BUILD_ROOT/var/log
406 :> $RPM_BUILD_ROOT/var/log/btmp
407 :> $RPM_BUILD_ROOT/var/log/wtmp
408
409 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/systemadm.1*
410
411 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
412 %{__rm} $RPM_BUILD_ROOT/%{_lib}/security/pam_systemd.la
413 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
414
415 %clean
416 rm -rf $RPM_BUILD_ROOT
417
418 %post
419 /bin/systemd-machine-id-setup > /dev/null 2>&1 || :
420 /bin/systemctl daemon-reexec > /dev/null 2>&1 || :
421
422 %postun
423 if [ $1 -ge 1 ]; then
424         /bin/systemctl try-restart systemd-logind.service >/dev/null 2>&1 || :
425 fi
426
427 %post   libs -p /sbin/ldconfig
428 %postun libs -p /sbin/ldconfig
429
430 %post units
431 if [ $1 -eq 1 ]; then
432         # Try to read default runlevel from the old inittab if it exists
433         runlevel=$(/bin/awk -F ':' '$3 == "initdefault" && $1 !~ "^#" { print $2 }' /etc/inittab 2> /dev/null)
434         if [ -z "$runlevel" ] ; then
435                 target="%{systemdunitdir}/graphical.target"
436         else
437                 target="%{systemdunitdir}/runlevel$runlevel.target"
438         fi
439
440         # And symlink what we found to the new-style default.target
441         ln -s "$target" %{_sysconfdir}/systemd/system/default.target >/dev/null 2>&1 || :
442
443         # Setup hostname
444         [ -f /etc/sysconfig/network ] && . /etc/sysconfig/network
445         if [ -n "$HOSTNAME" -a "$HOSTNAME" != "pldmachine" ]; then
446                 [ -f /etc/hostname ] && mv -f /etc/hostname /etc/hostname.rpmsave
447                 echo $HOSTNAME > /etc/hostname
448                 chmod 644 /etc/hostname
449         fi
450
451         # Enable the services we install by default.
452         /bin/systemctl enable \
453                 getty@.service \
454                 network.service \
455                 remote-fs.target \
456                 systemd-readahead-replay.service \
457                 systemd-readahead-collect.service >/dev/null 2>&1 || :
458 fi
459
460 %preun units
461 if [ $1 -eq 0 ] ; then
462         /bin/systemctl disable \
463                 getty@.service \
464                 network.service \
465                 remote-fs.target \
466                 systemd-readahead-replay.service \
467                 systemd-readahead-collect.service >/dev/null 2>&1 || :
468
469         %{__rm} -f %{_sysconfdir}/systemd/system/default.target >/dev/null 2>&1 || :
470 fi
471
472 %postun units
473 if [ $1 -ge 1 ]; then
474         /bin/systemctl daemon-reload > /dev/null 2>&1 || :
475 fi
476
477 %triggerpostun units -- %{name}-units < 43-7
478 # Remove design fialures
479 rm -f %{_sysconfdir}/systemd/system/network.target.wants/ifcfg@*.service >/dev/null 2>&1 || :
480 rm -f %{_sysconfdir}/systemd/system/network.target.wants/network-post.service >/dev/null 2>&1 || :
481 rm -f %{_sysconfdir}/systemd/system/multi-user.target.wants/network-post.service >/dev/null 2>&1 || :
482 /bin/systemctl reenable network.service >/dev/null 2>&1 || :
483
484 %post no-compat-tmpfiles
485 %{__sed} -i -e '/^#/!s/^/# /g' %{_sysconfdir}/tmpfiles.d/compat-pld-var-run.conf
486
487 %files
488 %defattr(644,root,root,755)
489 %doc DISTRO_PORTING README TODO
490 /etc/dbus-1/system.d/org.freedesktop.hostname1.conf
491 /etc/dbus-1/system.d/org.freedesktop.locale1.conf
492 /etc/dbus-1/system.d/org.freedesktop.login1.conf
493 /etc/dbus-1/system.d/org.freedesktop.systemd1.conf
494 /etc/dbus-1/system.d/org.freedesktop.timedate1.conf
495 %ghost %config(noreplace) %{_sysconfdir}/machine-id
496 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hostname
497 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/locale.conf
498 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/machine-info
499 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/timezone
500 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/vconsole.conf
501 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/systemd/*.conf
502 %dir %{_sysconfdir}/systemd/user
503 %dir %{_sysconfdir}/systemd/system/*.target.wants
504 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/systemd/system/*.target.wants/*.service
505 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/systemd/system/*.target.wants/*.target
506 /etc/xdg/systemd
507 %attr(755,root,root) /bin/systemd
508 %attr(755,root,root) /bin/systemd-ask-password
509 %attr(755,root,root) /bin/systemd-journalctl
510 %attr(755,root,root) /bin/systemd-loginctl
511 %attr(755,root,root) /bin/systemd-machine-id-setup
512 %attr(755,root,root) /bin/systemd-notify
513 %attr(755,root,root) /bin/systemd-tty-ask-password-agent
514 %attr(755,root,root) %{_bindir}/systemd-cat
515 %attr(755,root,root) %{_bindir}/systemd-cgtop
516 %attr(755,root,root) %{_bindir}/systemd-cgls
517 %attr(755,root,root) %{_bindir}/systemd-nspawn
518 %attr(755,root,root) %{_bindir}/systemd-stdio-bridge
519 %attr(755,root,root) %{_bindir}/systemd-sysv-convert
520 %attr(755,root,root) /lib/systemd/pld-storage-init
521 %attr(755,root,root) /lib/systemd/systemd-*
522 %dir /lib/systemd/system-generators
523 %attr(755,root,root) /lib/systemd/systemd
524 %attr(755,root,root) /lib/systemd/system-generators/systemd-*-generator
525 %dir /lib/systemd/system-shutdown
526 /lib/udev/rules.d/99-systemd.rules
527 /lib/udev/rules.d/70-uaccess.rules
528 /lib/udev/rules.d/71-seat.rules
529 /lib/udev/rules.d/73-seat-late.rules
530 %dir %{_libexecdir}/systemd
531 %{_libexecdir}/systemd/user
532 %dir %{_libexecdir}/systemd/user-generators
533 %config(noreplace,missingok) %{_libexecdir}/tmpfiles.d/*.conf
534 %{_datadir}/dbus-1/interfaces/org.freedesktop.hostname1.xml
535 %{_datadir}/dbus-1/interfaces/org.freedesktop.locale1.xml
536 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.*.xml
537 %{_datadir}/dbus-1/interfaces/org.freedesktop.timedate1.xml
538 %{_datadir}/dbus-1/services/org.freedesktop.systemd1.service
539 %{_datadir}/dbus-1/system-services/org.freedesktop.hostname1.service
540 %{_datadir}/dbus-1/system-services/org.freedesktop.locale1.service
541 %{_datadir}/dbus-1/system-services/org.freedesktop.login1.service
542 %{_datadir}/dbus-1/system-services/org.freedesktop.systemd1.service
543 %{_datadir}/dbus-1/system-services/org.freedesktop.timedate1.service
544 %{_datadir}/polkit-1/actions/org.freedesktop.hostname1.policy
545 %{_datadir}/polkit-1/actions/org.freedesktop.locale1.policy
546 %{_datadir}/polkit-1/actions/org.freedesktop.login1.policy
547 %{_datadir}/polkit-1/actions/org.freedesktop.systemd1.policy
548 %{_datadir}/polkit-1/actions/org.freedesktop.timedate1.policy
549 %dir %{_datadir}/systemd
550 %{_datadir}/systemd/kbd-model-map
551 %{_mandir}/man1/systemd.1*
552 %{_mandir}/man1/systemd-*.1*
553 %{_mandir}/man5/binfmt.d.5*
554 %{_mandir}/man5/hostname.5*
555 %{_mandir}/man5/locale.conf.5*
556 %{_mandir}/man5/machine-id.5*
557 %{_mandir}/man5/machine-info.5*
558 %{_mandir}/man5/modules-load.d.5*
559 %{_mandir}/man5/os-release.5*
560 %{_mandir}/man5/sysctl.d.5*
561 %{_mandir}/man5/systemd.*.5*
562 %{_mandir}/man5/systemd-journald.conf.5*
563 %{_mandir}/man5/systemd-logind.conf.5*
564 %{_mandir}/man5/timezone.5*
565 %{_mandir}/man5/vconsole.conf.5*
566 %{_mandir}/man7/daemon.7*
567 %{_mandir}/man7/sd-daemon.7*
568 %{_mandir}/man7/sd-login.7*
569 %{_mandir}/man7/sd-readahead.7*
570 %{_mandir}/man7/systemd.special.7*
571 %dir /var/lib/%{name}
572 %dir /var/lib/%{name}/coredump
573 %attr(640,root,root) %ghost /var/log/btmp
574 %attr(664,root,utmp) %ghost /var/log/wtmp
575
576 %if %{with pam}
577 %attr(755,root,root) /%{_lib}/security/pam_systemd.so
578 %{_mandir}/man8/pam_systemd.8*
579 %endif
580
581 %files init
582 %defattr(644,root,root,755)
583 %attr(755,root,root) /sbin/halt
584 %attr(755,root,root) /sbin/init
585 %attr(755,root,root) /sbin/poweroff
586 %attr(755,root,root) /sbin/reboot
587 %attr(755,root,root) /sbin/runlevel
588 %attr(755,root,root) /sbin/shutdown
589 %attr(755,root,root) /sbin/telinit
590 %{_mandir}/man1/init.1
591 %{_mandir}/man8/halt.8*
592 %{_mandir}/man8/poweroff.8
593 %{_mandir}/man8/reboot.8
594 %{_mandir}/man8/runlevel.8*
595 %{_mandir}/man8/shutdown.8*
596 %{_mandir}/man8/telinit.8*
597
598 %files units
599 %defattr(644,root,root,755)
600 %dir %{_sysconfdir}/binfmt.d
601 %dir %{_sysconfdir}/modules-load.d
602 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/modules-load.d/modules.conf
603 %dir %{_sysconfdir}/sysctl.d
604 %dir %{_sysconfdir}/systemd
605 %dir %{_sysconfdir}/systemd/system
606 %dir %{_sysconfdir}/tmpfiles.d
607 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/tmpfiles.d/*.conf
608 %dir %{_libexecdir}/binfmt.d
609 %dir %{_libexecdir}/modules-load.d
610 %dir %{_libexecdir}/sysctl.d
611 %{_libexecdir}/sysctl.d/coredump.conf
612 %attr(755,root,root) /bin/systemctl
613 %attr(755,root,root) /bin/systemd-tmpfiles
614 %attr(755,root,root) /bin/systemd_booted
615 %{_mandir}/man1/systemctl.1*
616 %{_mandir}/man5/tmpfiles.d.5*
617 %{_mandir}/man8/systemd-tmpfiles.8*
618 %{_npkgconfigdir}/systemd.pc
619
620 %{systemdunitdir}/*.automount
621 %{systemdunitdir}/*.mount
622 %{systemdunitdir}/*.path
623 %{systemdunitdir}/*.service
624 %{systemdunitdir}/*.socket
625 %{systemdunitdir}/*.target
626 %{systemdunitdir}/*.timer
627 %if %{with plymouth}
628 %exclude %{systemdunitdir}/plymouth*.service
629 %exclude %{systemdunitdir}/systemd-ask-password-plymouth.*
630 %endif
631 %dir %{systemdunitdir}/basic.target.wants
632 %dir %{systemdunitdir}/dbus.target.wants
633 %dir %{systemdunitdir}/final.target.wants
634 %dir %{systemdunitdir}/graphical.target.wants
635 %dir %{systemdunitdir}/halt.target.wants
636 %dir %{systemdunitdir}/kexec.target.wants
637 %dir %{systemdunitdir}/local-fs.target.wants
638 %dir %{systemdunitdir}/multi-user.target.wants
639 %dir %{systemdunitdir}/poweroff.target.wants
640 %dir %{systemdunitdir}/reboot.target.wants
641 %dir %{systemdunitdir}/runlevel[12345].target.wants
642 %dir %{systemdunitdir}/shutdown.target.wants
643 %dir %{systemdunitdir}/sockets.target.wants
644 %dir %{systemdunitdir}/sysinit.target.wants
645 %dir %{systemdunitdir}/syslog.target.wants
646 %config(noreplace,missingok) %{systemdunitdir}/basic.target.wants/*
647 %config(noreplace,missingok) %{systemdunitdir}/final.target.wants/*
648 %config(noreplace,missingok) %{systemdunitdir}/graphical.target.wants/*
649 %config(noreplace,missingok) %{systemdunitdir}/local-fs.target.wants/*
650 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/getty.target
651 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/rc-local.service
652 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/systemd-ask-password-wall.path
653 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/systemd-logind.service
654 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/systemd-user-sessions.service
655 %config(noreplace,missingok) %{systemdunitdir}/runlevel[12345].target.wants/*
656 %config(noreplace,missingok) %{systemdunitdir}/shutdown.target.wants/*
657 %config(noreplace,missingok) %{systemdunitdir}/sockets.target.wants/*
658 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/cryptsetup.target
659 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/dev-hugepages.mount
660 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/dev-mqueue.mount
661 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/proc-sys-fs-binfmt_misc.automount
662 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/sys-*.mount
663 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/systemd-*
664
665 %if %{with plymouth}
666 %files plymouth
667 %defattr(644,root,root,755)
668 %{systemdunitdir}/plymouth-halt.service
669 %{systemdunitdir}/plymouth-kexec.service
670 %{systemdunitdir}/plymouth-poweroff.service
671 %{systemdunitdir}/plymouth-quit-wait.service
672 %{systemdunitdir}/plymouth-quit.service
673 %{systemdunitdir}/plymouth-read-write.service
674 %{systemdunitdir}/plymouth-reboot.service
675 %{systemdunitdir}/plymouth-start.service
676 %{systemdunitdir}/systemd-ask-password-plymouth.path
677 %{systemdunitdir}/systemd-ask-password-plymouth.service
678 %config(noreplace,missingok) %{systemdunitdir}/halt.target.wants/plymouth-halt.service
679 %config(noreplace,missingok) %{systemdunitdir}/kexec.target.wants/plymouth-kexec.service
680 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/plymouth-quit.service
681 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/plymouth-quit-wait.service
682 %config(noreplace,missingok) %{systemdunitdir}/poweroff.target.wants/plymouth-poweroff.service
683 %config(noreplace,missingok) %{systemdunitdir}/reboot.target.wants/plymouth-reboot.service
684 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/plymouth-read-write.service
685 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/plymouth-start.service
686 %endif
687
688 %files analyze
689 %defattr(644,root,root,755)
690 %attr(755,root,root) %{_bindir}/systemd-analyze
691
692 %files libs
693 %defattr(644,root,root,755)
694 %attr(755,root,root) /%{_lib}/libsystemd-daemon.so.*.*.*
695 %attr(755,root,root) %ghost /%{_lib}/libsystemd-daemon.so.0
696 %attr(755,root,root) /%{_lib}/libsystemd-id128.so.*.*.*
697 %attr(755,root,root) %ghost /%{_lib}/libsystemd-id128.so.0
698 %attr(755,root,root) /%{_lib}/libsystemd-journal.so.*.*.*
699 %attr(755,root,root) %ghost /%{_lib}/libsystemd-journal.so.0
700 %attr(755,root,root) /%{_lib}/libsystemd-login.so.*.*.*
701 %attr(755,root,root) %ghost /%{_lib}/libsystemd-login.so.0
702
703 %files devel
704 %defattr(644,root,root,755)
705 %attr(755,root,root) %{_libdir}/libsystemd-daemon.so
706 %attr(755,root,root) %{_libdir}/libsystemd-id128.so
707 %attr(755,root,root) %{_libdir}/libsystemd-journal.so
708 %attr(755,root,root) %{_libdir}/libsystemd-login.so
709 %{_includedir}/%{name}
710 %{_pkgconfigdir}/libsystemd-daemon.pc
711 %{_pkgconfigdir}/libsystemd-id128.pc
712 %{_pkgconfigdir}/libsystemd-journal.pc
713 %{_pkgconfigdir}/libsystemd-login.pc
714 %{_mandir}/man3/sd_booted.3*
715 %{_mandir}/man3/sd_get_seats.3*
716 %{_mandir}/man3/sd_get_sessions.3*
717 %{_mandir}/man3/sd_get_uids.3*
718 %{_mandir}/man3/sd_is_fifo.3*
719 %{_mandir}/man3/sd_is_mq.3*
720 %{_mandir}/man3/sd_is_socket.3
721 %{_mandir}/man3/sd_is_socket_inet.3
722 %{_mandir}/man3/sd_is_socket_unix.3
723 %{_mandir}/man3/sd_listen_fds.3*
724 %{_mandir}/man3/sd_login_monitor_flush.3*
725 %{_mandir}/man3/sd_login_monitor_get_fd.3*
726 %{_mandir}/man3/sd_login_monitor_new.3*
727 %{_mandir}/man3/sd_login_monitor_unref.3*
728 %{_mandir}/man3/sd_notify.3*
729 %{_mandir}/man3/sd_notifyf.3
730 %{_mandir}/man3/sd_pid_get_owner_uid.3*
731 %{_mandir}/man3/sd_pid_get_session.3*
732 %{_mandir}/man3/sd_pid_get_unit.3*
733 %{_mandir}/man3/sd_readahead.3*
734 %{_mandir}/man3/sd_seat_can_multi_session.3*
735 %{_mandir}/man3/sd_seat_get_active.3*
736 %{_mandir}/man3/sd_seat_get_sessions.3*
737 %{_mandir}/man3/sd_session_get_class.3*
738 %{_mandir}/man3/sd_session_get_display.3*
739 %{_mandir}/man3/sd_session_get_seat.3*
740 %{_mandir}/man3/sd_session_get_service.3*
741 %{_mandir}/man3/sd_session_get_type.3*
742 %{_mandir}/man3/sd_session_get_uid.3*
743 %{_mandir}/man3/sd_session_is_active.3*
744 %{_mandir}/man3/sd_uid_get_seats.3*
745 %{_mandir}/man3/sd_uid_get_sessions.3*
746 %{_mandir}/man3/sd_uid_get_state.3*
747 %{_mandir}/man3/sd_uid_is_on_seat.3*
748
749 %files -n bash-completion-systemd
750 %defattr(644,root,root,755)
751 /etc/bash_completion.d/systemd-bash-completion.sh
752
753 %files no-compat-tmpfiles
754 %defattr(644,root,root,755)
755 # empty package
This page took 1.75432 seconds and 4 git commands to generate.