]> git.pld-linux.org Git - packages/systemd.git/blob - systemd.spec
- Obsoletes SysVinit
[packages/systemd.git] / systemd.spec
1 #
2 # TODO:
3 # - gtk BRs: libnotify 0.7 and gtk+3
4 # - subpackages: bash-autocompletion, dbus(?), gtk, others?
5 # - more BRs
6 #
7
8 %bcond_with     gtk     # build gtk tools
9
10 Summary:        systemd - a system and service manager for Linux
11 Summary(pl.UTF-8):      systemd - zarządca systemu i usług dla Linuksa
12 Name:           systemd
13 Version:        15
14 Release:        0.1
15 License:        GPL v2+
16 Group:          Base
17 Source0:        http://www.freedesktop.org/software/systemd/%{name}-%{version}.tar.bz2
18 # Source0-md5:  36011aa8593862ca78e3e909f6143570
19 URL:            http://www.freedesktop.org/wiki/Software/systemd
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 BuildRequires:  dbus-devel
23 %if %{with gtk}
24 BuildRequires:  libnotify-devel >= 0.7.0
25 %endif
26 BuildRequires:  libtool
27 BuildRequires:  udev-devel >= 160
28 BuildRequires:  vala >= 0.11
29 Obsoletes:      SysVinit
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 systemd is a system and service manager for Linux, compatible with
34 SysV and LSB init scripts. systemd provides aggressive parallelization
35 capabilities, uses socket and D-Bus activation for starting services,
36 offers on-demand starting of daemons, keeps track of processes using
37 Linux cgroups, supports snapshotting and restoring of the system
38 state, maintains mount and automount points and implements an
39 elaborate transactional dependency-based service control logic. It can
40 work as a drop-in replacement for sysvinit.
41
42 %description -l pl.UTF-8
43 systemd jest zarządcą systemu i usług dla Linuksa, kompatybilny ze
44 skryptami SysV i LSB. systemd udostępnia rozbudowane zdolności
45 paralelizacji, do uruchamiania usług używa socketów oraz D-Busa,
46 oferuje uruchamianie usług na życzenie, monitoruje procesy używając
47 linuksowych cgroups, wspomaga zapisywanie (snapshot) i odczytywanie
48 (restore) stanu systemu, zarządza (auto)mount pointami oraz
49 implementuje starannie opracowaną transakcjonalną, bazującą na
50 zależnościach logikę kontroli usług. Może pracować jako zastepca dla
51 sysvinit.
52
53 %prep
54 %setup -q
55
56 %build
57 %{__autoconf}
58 %{__automake}
59 %configure \
60         --with-distro=other \
61         --%{?with_gtk:en}%{!?with_gtk:dis}able-gtk \
62         --with-syslog-service=syslog-ng \
63         --with-sysvinit-path=/etc/rc.d/init.d \
64         --with-sysvrcd-path=/etc/rc.d \
65         --with-rootdir=/usr
66
67 %{__make}
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71
72 %{__make} install \
73         DESTDIR=$RPM_BUILD_ROOT
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %files
79 %defattr(644,root,root,755)
80 %doc DISTRO_PORTING README TODO
81 %attr(755,root,root) %{_bindir}/systemctl
82 %attr(755,root,root) %{_bindir}/systemd
83 %attr(755,root,root) %{_bindir}/systemd-ask-password
84 %attr(755,root,root) %{_bindir}/systemd-cgls
85 %attr(755,root,root) %{_bindir}/systemd-notify
86 %attr(755,root,root) %{_bindir}/systemd-tty-ask-password-agent
87 %{_prefix}/lib/systemd/
88 /etc/dbus-1/system.d/org.freedesktop.systemd1.conf
89 %{_sysconfdir}/systemd
90 %{_sysconfdir}/tmpfiles.d
91 %{_sysconfdir}/xdg/systemd
92 /lib/udev/rules.d/99-systemd.rules
93 /%{_lib}/security/pam_systemd.la
94 %attr(755,root,root) /%{_lib}/security/pam_systemd.so
95 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Automount.xml
96 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Device.xml
97 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Job.xml
98 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Manager.xml
99 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Mount.xml
100 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Path.xml
101 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Service.xml
102 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Snapshot.xml
103 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Socket.xml
104 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Swap.xml
105 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Target.xml
106 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Timer.xml
107 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Unit.xml
108 %{_datadir}/dbus-1/services/org.freedesktop.systemd1.service
109 %{_datadir}/dbus-1/system-services/org.freedesktop.systemd1.service
110 %{_mandir}/man1/init.1
111 %{_mandir}/man1/systemadm.1*
112 %{_mandir}/man1/systemctl.1*
113 %{_mandir}/man1/systemd-cgls.1*
114 %{_mandir}/man1/systemd-notify.1*
115 %{_mandir}/man1/systemd.1*
116 %{_mandir}/man3/sd_booted.3*
117 %{_mandir}/man3/sd_is_fifo.3*
118 %{_mandir}/man3/sd_is_socket.3
119 %{_mandir}/man3/sd_is_socket_inet.3
120 %{_mandir}/man3/sd_is_socket_unix.3
121 %{_mandir}/man3/sd_listen_fds.3*
122 %{_mandir}/man3/sd_notify.3*
123 %{_mandir}/man3/sd_notifyf.3
124 %{_mandir}/man3/sd_readahead.3*
125 %{_mandir}/man5/hostname.5*
126 %{_mandir}/man5/locale.conf.5*
127 %{_mandir}/man5/modules-load.d.5*
128 %{_mandir}/man5/os-release.5*
129 %{_mandir}/man5/systemd.automount.5*
130 %{_mandir}/man5/systemd.conf.5*
131 %{_mandir}/man5/systemd.device.5*
132 %{_mandir}/man5/systemd.exec.5*
133 %{_mandir}/man5/systemd.mount.5*
134 %{_mandir}/man5/systemd.path.5*
135 %{_mandir}/man5/systemd.service.5*
136 %{_mandir}/man5/systemd.snapshot.5*
137 %{_mandir}/man5/systemd.socket.5*
138 %{_mandir}/man5/systemd.swap.5*
139 %{_mandir}/man5/systemd.target.5*
140 %{_mandir}/man5/systemd.timer.5*
141 %{_mandir}/man5/systemd.unit.5*
142 %{_mandir}/man5/tmpfiles.d.5*
143 %{_mandir}/man5/vconsole.conf.5*
144 %{_mandir}/man7/daemon.7*
145 %{_mandir}/man7/sd-daemon.7*
146 %{_mandir}/man7/sd-readahead.7*
147 %{_mandir}/man7/systemd.special.7*
148 %{_mandir}/man8/halt.8*
149 %{_mandir}/man8/pam_systemd.8*
150 %{_mandir}/man8/poweroff.8
151 %{_mandir}/man8/reboot.8
152 %{_mandir}/man8/runlevel.8*
153 %{_mandir}/man8/shutdown.8*
154 %{_mandir}/man8/telinit.8*
155 %{_datadir}/polkit-1/actions/org.freedesktop.systemd1.policy
156 %{_datadir}/systemd
This page took 0.040033 seconds and 4 git commands to generate.