]> git.pld-linux.org Git - packages/systemd.git/blob - systemd.spec
- udev epoch, BR: xz-devel
[packages/systemd.git] / systemd.spec
1 #
2 # TODO:
3 #       - remove compat-pld-var-run.tmpfiles and maybe tmpfiles-not-fatal.patch
4 #         after enough packages provide their own tmpfiles.d configs for
5 #         /var/run directories
6 #
7 # Conditional build:
8 %bcond_without  audit           # without audit support
9 %bcond_without  cryptsetup      # without cryptsetup support
10 %bcond_without  gtk             # build gtk tools
11 %bcond_without  pam             # PAM authentication support
12 %bcond_without  selinux         # without SELinux support
13 %bcond_without  tcpd            # libwrap (tcp_wrappers) support
14
15 Summary:        A System and Service Manager
16 Summary(pl.UTF-8):      systemd - zarządca systemu i usług dla Linuksa
17 Name:           systemd
18 Version:        39
19 Release:        0.1
20 License:        GPL v2+
21 Group:          Base
22 Source0:        http://www.freedesktop.org/software/systemd/%{name}-%{version}.tar.xz
23 # Source0-md5:  7179b34f6f6553d2a36551ac1dec5f0d
24 Source1:        %{name}-sysv-convert
25 Source2:        systemd_booted.c
26 Source3:        ifup@.service
27 Source4:        network-post.service
28 Source5:        network.service
29 Source6:        compat-pld-media.tmpfiles
30 Source7:        compat-pld-var-run.tmpfiles
31 Patch0:         target-pld.patch
32 Patch1:         config-pld.patch
33 Patch2:         shut-sysv-up.patch
34 Patch3:         pld-sysv-network.patch
35 Patch4:         tmpfiles-not-fatal.patch
36 URL:            http://www.freedesktop.org/wiki/Software/systemd
37 BuildRequires:  acl-devel
38 %{?with_audit:BuildRequires:    audit-libs-devel}
39 BuildRequires:  autoconf >= 2.63
40 BuildRequires:  automake >= 1:1.11
41 %{?with_cryptsetup:BuildRequires:       cryptsetup-luks-devel}
42 BuildRequires:  dbus-devel >= 1.3.2
43 BuildRequires:  docbook-style-xsl
44 %if %{with gtk}
45 BuildRequires:  glib2-devel >= 1:2.26.1
46 BuildRequires:  gtk+2-devel >= 2:2.24.0
47 BuildRequires:  libgee-devel
48 BuildRequires:  libnotify-devel >= 0.7.0
49 %endif
50 BuildRequires:  gperf
51 BuildRequires:  intltool >= 0.40.0
52 BuildRequires:  libcap-devel
53 %{?with_selinux:BuildRequires:  libselinux-devel}
54 BuildRequires:  libtool >= 2:2.2
55 %{?with_tcpd:BuildRequires:     libwrap-devel}
56 BuildRequires:  libxslt-progs
57 BuildRequires:  m4
58 %{?with_pam:BuildRequires:      pam-devel}
59 BuildRequires:  pkgconfig >= 0.9.0
60 BuildRequires:  rpmbuild(macros) >= 1.527
61 BuildRequires:  udev-devel >= 1:172
62 # not required for building from release (which contains *.c for *.vala)
63 #BuildRequires: vala >= 0.10.0
64 BuildRequires:  xz-devel
65 Requires:       %{name}-libs = %{version}-%{release}
66 Requires:       %{name}-units = %{version}-%{release}
67 Requires:       SysVinit-tools
68 Requires:       agetty
69 Requires:       dbus >= 1.3.2
70 Requires:       dbus-systemd
71 Requires:       filesystem >= 4.0-2
72 Requires:       rc-scripts >= 0.4.5.1-7
73 Requires:       setup >= 2.8.0-2
74 Requires:       udev-core >= 1:172
75 Requires:       udev-systemd >= 1:172
76 Requires:       udev-libs >= 1:172
77 Suggests:       ConsoleKit-systemd
78 Suggests:       fsck >= 2.20
79 Suggests:       nss_myhostname
80 # python modules required by systemd-analyze
81 Suggests:       python-dbus
82 Suggests:       python-modules
83 Suggests:       service(syslog)
84 Provides:       udev-acl
85 Conflicts:      upstart
86 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
87
88 %define         _libexecdir     %{_prefix}/lib
89
90 %description
91 systemd is a system and service manager for Linux, compatible with
92 SysV and LSB init scripts. systemd provides aggressive parallelization
93 capabilities, uses socket and D-Bus activation for starting services,
94 offers on-demand starting of daemons, keeps track of processes using
95 Linux cgroups, supports snapshotting and restoring of the system
96 state, maintains mount and automount points and implements an
97 elaborate transactional dependency-based service control logic. It can
98 work as a drop-in replacement for sysvinit.
99
100 %description -l pl.UTF-8
101 systemd jest zarządcą systemu i usług dla Linuksa, kompatybilny ze
102 skryptami SysV i LSB. systemd udostępnia rozbudowane zdolności
103 paralelizacji, do uruchamiania usług używa socketów oraz D-Busa,
104 oferuje uruchamianie usług na życzenie, monitoruje procesy używając
105 linuksowych cgroups, wspomaga zapisywanie (snapshot) i odczytywanie
106 (restore) stanu systemu, zarządza (auto)mount pointami oraz
107 implementuje starannie opracowaną transakcjonalną, bazującą na
108 zależnościach logikę kontroli usług. Może pracować jako zastępca dla
109 sysvinit.
110
111 %package init
112 Summary:        systemd /sbin/init and LSB/SysV compatibility symlinks
113 Summary(pl.UTF-8):      /sbin/init z systemd i dowiązania dla kompatybilności z LSB/SysV
114 Group:          Base
115 Requires:       systemd
116 Provides:       readahead = 1:1.5.7-3
117 Provides:       virtual(init-daemon)
118 Obsoletes:      SysVinit
119 Obsoletes:      readahead < 1:1.5.7-3
120 Obsoletes:      virtual(init-daemon)
121
122 %description init
123 Install this package when you are ready to final switch to systemd.
124
125 %description init -l pl.UTF-8
126 Ten pakiet należy zainstalować po przygotowaniu się do ostatecznego
127 przejścia na systemd.
128
129 %package units
130 Summary:        Configuration files, directories and installation tool for systemd
131 Summary(pl.UTF-8):      Pliki konfiguracyjne, katalogi i narzędzie instalacyjne dla systemd
132 Group:          Base
133 Requires(post): coreutils
134 Requires(post): gawk
135 Requires:       pkgconfig
136
137 %description units
138 Basic configuration files, directories and installation tool for the
139 systemd system and service manager.
140
141 This is common config, use %{_sysconfdir}/systemd/system to override.
142
143 %description units -l pl.UTF-8
144 Podstawowe pliki konfiguracyjne, katalogi i narzędzie instalacyjne dla
145 zarządcy systemu i usług systemd.
146
147 Ten pakiet zawiera ogólną konfigurację, ustawienia można nadpisać
148 poprzez katalog %{_sysconfdir}/systemd/system.
149
150 %package gtk
151 Summary:        Graphical frontend for systemd
152 Summary(pl.UTF-8):      Graficzny interfejs do systemd
153 Group:          Base
154 Requires:       %{name} = %{version}-%{release}
155 Requires:       polkit
156
157 %description gtk
158 Graphical front-end for systemd.
159
160 %description gtk -l pl.UTF-8
161 Graficzny interfejs do systemd.
162
163 %package libs
164 Summary:        Shared systemd libraries
165 Summary(pl.UTF-8):      Biblioteki współdzielone systemd
166 Group:          Libraries
167
168 %description libs
169 Shared systemd libraries.
170
171 %description libs -l pl.UTF-8
172 Biblioteki współdzielone systemd.
173
174 %package devel
175 Summary:        Header files for systemd libraries
176 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek systemd
177 Group:          Development/Libraries
178 Requires:       %{name}-libs = %{version}-%{release}
179
180 %description devel
181 Header files for systemd libraries.
182
183 %description devel -l pl.UTF-8
184 Pliki nagłówkowe bibliotek systemd.
185
186 %package -n bash-completion-systemd
187 Summary:        bash-completion for systemd
188 Summary(pl.UTF-8):      Bashowe dopełnianie składni dla systemd
189 Group:          Applications/Shells
190 Requires:       %{name}
191 Requires:       bash-completion
192
193 %description -n bash-completion-systemd
194 bash-completion for systemd.
195
196 %description -n bash-completion-systemd -l pl.UTF-8
197 Bashowe dopełnianie składni dla systemd
198
199 %prep
200 %setup -q
201 %patch0 -p1
202 %patch1 -p1
203 #%patch2 -p1
204 %patch3 -p1
205 %patch4 -p1
206 cp -p %{SOURCE2} src/systemd_booted.c
207
208 %build
209 %{__aclocal} -I m4
210 %{__autoconf}
211 %{__autoheader}
212 %{__automake}
213 %configure \
214         %{__enable_disable audit} \
215         %{__enable_disable cryptsetup libcryptsetup} \
216         %{__enable_disable gtk} \
217         %{__enable_disable pam} \
218         %{__enable_disable selinux} \
219         %{__enable_disable tcpd tcpwrap} \
220         --disable-silent-rules \
221         --disable-static \
222         --with-distro=pld \
223         --with-rootprefix= \
224         --with-rootlibdir=/%{_lib}
225
226 %{__make}
227 ./libtool --mode=link --tag=CC %{__cc} %{rpmcppflags} %{rpmcflags} -o systemd_booted %{rpmldflags} src/systemd_booted.c -L. -lsystemd-daemon
228
229 %install
230 rm -rf $RPM_BUILD_ROOT
231
232 %{__make} install \
233         DESTDIR=$RPM_BUILD_ROOT
234
235 ./libtool --mode=install install -m755 systemd_booted $RPM_BUILD_ROOT/bin/systemd_booted
236
237 # Create SysV compatibility symlinks. systemctl/systemd are smart
238 # enough to detect the way they were called
239 install -d $RPM_BUILD_ROOT/sbin
240 ln -s ../bin/systemd $RPM_BUILD_ROOT/sbin/init
241 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/halt
242 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/poweroff
243 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/reboot
244 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/runlevel
245 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/shutdown
246 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/telinit
247
248 ln -s ../modules $RPM_BUILD_ROOT%{_sysconfdir}/modules-load.d/modules.conf
249 # disable random and console SYSV service 
250 ln -s /dev/null $RPM_BUILD_ROOT/lib/systemd/system/random.service
251 ln -s /dev/null $RPM_BUILD_ROOT/lib/systemd/system/console.service
252
253 # add static (non-NetworkManager) networking
254 install %{SOURCE3} $RPM_BUILD_ROOT/lib/systemd/system/ifup@.service
255 install %{SOURCE4} $RPM_BUILD_ROOT/lib/systemd/system/network-post.service
256 install %{SOURCE5} $RPM_BUILD_ROOT/lib/systemd/system/network.service
257
258 # install compatibility tmpfiles configs
259 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/compat-pld-media.conf
260 install %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/compat-pld-var-run.conf
261
262 # All wants links are created at %post to make sure they are not owned
263 # and hence overriden by rpm if the user deletes them (missingok?)
264 %{__rm} -r $RPM_BUILD_ROOT%{_sysconfdir}/systemd/system/*.target.wants
265
266 # it is in rc-scripts pkg
267 %{__rm} $RPM_BUILD_ROOT/lib/systemd/system/rc-local.service
268
269 # Make sure these directories are properly owned:
270 #       - halt,kexec,poweroff,reboot: generic ones used by ConsoleKit-systemd,
271 #       - syslog _might_ be used by some syslog implementation (none for now),
272 #       - isn't dbus populated by dbus-systemd only (so to be moved there)?
273 install -d $RPM_BUILD_ROOT/lib/systemd/system/{dbus,halt,kexec,poweroff,reboot,syslog}.target.wants
274
275 # Create new-style configuration files so that we can ghost-own them
276 touch $RPM_BUILD_ROOT%{_sysconfdir}/{hostname,locale.conf,machine-id,machine-info,os-release,timezone,vconsole.conf}
277
278 # Install SysV conversion tool for systemd
279 install -p %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}
280
281 install -d $RPM_BUILD_ROOT/var/log
282 :> $RPM_BUILD_ROOT/var/log/btmp
283 :> $RPM_BUILD_ROOT/var/log/wtmp
284
285 %if %{without gtk}
286 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/systemadm.1*
287 %endif
288
289 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
290 %{__rm} $RPM_BUILD_ROOT/%{_lib}/security/pam_systemd.la
291 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
292
293 %clean
294 rm -rf $RPM_BUILD_ROOT
295
296 %post
297 /bin/systemd-machine-id-setup > /dev/null 2>&1 || :
298 /bin/systemctl daemon-reexec > /dev/null 2>&1 || :
299
300 %postun
301 if [ $1 -ge 1 ]; then
302         /bin/systemctl try-restart systemd-logind.service >/dev/null 2>&1 || :
303 fi
304
305 %post   libs -p /sbin/ldconfig
306 %postun libs -p /sbin/ldconfig
307
308 %post units
309 if [ $1 -eq 1 ]; then
310         # Try to read default runlevel from the old inittab if it exists
311         runlevel=$(/bin/awk -F ':' '$3 == "initdefault" && $1 !~ "^#" { print $2 }' /etc/inittab 2> /dev/null)
312         if [ -z "$runlevel" ] ; then
313                 target="/lib/systemd/system/graphical.target"
314         else
315                 target="/lib/systemd/system/runlevel$runlevel.target"
316         fi
317
318         # And symlink what we found to the new-style default.target
319         ln -s "$target" %{_sysconfdir}/systemd/system/default.target >/dev/null 2>&1 || :
320
321         # Setup hostname
322         [ -f /etc/sysconfig/network ] && . /etc/sysconfig/network
323         if [ -n "$HOSTNAME" -a "$HOSTNAME" != "pldmachine" ]; then
324                 [ -f /etc/hostname ] && mv -f /etc/hostname /etc/hostname.rpmsave
325                 echo $HOSTNAME > /etc/hostname
326                 chmod 644 /etc/hostname
327         fi
328 fi
329 # Enable the services we install by default.
330 /bin/systemctl enable \
331         getty@.service \
332         network.service \
333         network-post.service \
334         remote-fs.target \
335         systemd-readahead-replay.service \
336         systemd-readahead-collect.service >/dev/null 2>&1 || :
337
338 # Find and enable all installed interfaces
339 mkdir -p %{_sysconfdir}/systemd/system/network.target.wants >/dev/null 2>&1 || :
340 for f in /etc/sysconfig/interfaces/ifcfg-* ; do
341         ff=$(basename $f)
342         ff=${ff##ifcfg-}
343         case "$ff" in
344         *.rpmorig|*.rpmnew|*.rpmsave|*~|*.orig)
345                 continue
346                 ;;
347         *)
348                 DEVICE="" ; ONBOOT="" ; USERS=""
349                 . $f 2>/dev/null
350                 [ ${USERS:-no} != no ] && continue
351                 if [ "$DEVICE" = "$ff" -a ${ONBOOT:-no} = "yes" ]; then
352                         ln -s /lib/systemd/system/ifup@.service \
353                                 %{_sysconfdir}/systemd/system/network.target.wants/ifcfg@$ff.service >/dev/null 2>&1 || :
354                 fi
355                 ;;
356         esac
357 done
358
359 %preun units
360 if [ $1 -eq 0 ] ; then
361         /bin/systemctl disable \
362                 getty@.service \
363                 network.service \
364                 network-post.service \
365                 remote-fs.target \
366                 systemd-readahead-replay.service \
367                 systemd-readahead-collect.service >/dev/null 2>&1 || :
368
369         %{__rm} -f %{_sysconfdir}/systemd/system/default.target >/dev/null 2>&1 || :
370         %{__rm} -f %{_sysconfdir}/systemd/system/network.target.wants/ifcfg@*.service >/dev/null 2>&1 || :
371 fi
372
373 %postun units
374 if [ $1 -ge 1 ]; then
375         /bin/systemctl daemon-reload > /dev/null 2>&1 || :
376 fi
377
378 %files
379 %defattr(644,root,root,755)
380 %doc DISTRO_PORTING README TODO
381 /etc/dbus-1/system.d/org.freedesktop.hostname1.conf
382 /etc/dbus-1/system.d/org.freedesktop.locale1.conf
383 /etc/dbus-1/system.d/org.freedesktop.login1.conf
384 /etc/dbus-1/system.d/org.freedesktop.systemd1.conf
385 /etc/dbus-1/system.d/org.freedesktop.timedate1.conf
386 %ghost %config(noreplace) %{_sysconfdir}/machine-id
387 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hostname
388 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/locale.conf
389 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/machine-info
390 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/os-release
391 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/timezone
392 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/vconsole.conf
393 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/systemd/*.conf
394 %dir %{_sysconfdir}/systemd/user
395 /etc/xdg/systemd
396 %attr(755,root,root) /bin/systemd
397 %attr(755,root,root) /bin/systemd-ask-password
398 %attr(755,root,root) /bin/systemd-journalctl
399 %attr(755,root,root) /bin/systemd-loginctl
400 %attr(755,root,root) /bin/systemd-machine-id-setup
401 %attr(755,root,root) /bin/systemd-notify
402 %attr(755,root,root) /bin/systemd-tty-ask-password-agent
403 %attr(755,root,root) %{_bindir}/systemd-analyze
404 %attr(755,root,root) %{_bindir}/systemd-cat
405 %attr(755,root,root) %{_bindir}/systemd-cgtop
406 %attr(755,root,root) %{_bindir}/systemd-cgls
407 %attr(755,root,root) %{_bindir}/systemd-nspawn
408 %attr(755,root,root) %{_bindir}/systemd-stdio-bridge
409 %attr(755,root,root) %{_bindir}/systemd-sysv-convert
410 %attr(755,root,root) /lib/systemd/systemd-*
411 %dir /lib/systemd/system-generators
412 %attr(755,root,root) /lib/systemd/system-generators/systemd-*-generator
413 %dir /lib/systemd/system-shutdown
414 /lib/udev/rules.d/99-systemd.rules
415 /lib/udev/rules.d/70-uaccess.rules
416 /lib/udev/rules.d/71-seat.rules
417 /lib/udev/rules.d/73-seat-late.rules
418 %dir %{_libexecdir}/systemd
419 %{_libexecdir}/systemd/user
420 %dir %{_libexecdir}/systemd/user-generators
421 %config(noreplace,missingok) %{_libexecdir}/tmpfiles.d/*.conf
422 %{_datadir}/dbus-1/interfaces/org.freedesktop.hostname1.xml
423 %{_datadir}/dbus-1/interfaces/org.freedesktop.locale1.xml
424 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.*.xml
425 %{_datadir}/dbus-1/interfaces/org.freedesktop.timedate1.xml
426 %{_datadir}/dbus-1/services/org.freedesktop.systemd1.service
427 %{_datadir}/dbus-1/system-services/org.freedesktop.hostname1.service
428 %{_datadir}/dbus-1/system-services/org.freedesktop.locale1.service
429 %{_datadir}/dbus-1/system-services/org.freedesktop.login1.service
430 %{_datadir}/dbus-1/system-services/org.freedesktop.systemd1.service
431 %{_datadir}/dbus-1/system-services/org.freedesktop.timedate1.service
432 %{_datadir}/polkit-1/actions/org.freedesktop.hostname1.policy
433 %{_datadir}/polkit-1/actions/org.freedesktop.locale1.policy
434 %{_datadir}/polkit-1/actions/org.freedesktop.login1.policy
435 %{_datadir}/polkit-1/actions/org.freedesktop.systemd1.policy
436 %{_datadir}/polkit-1/actions/org.freedesktop.timedate1.policy
437 %dir %{_datadir}/systemd
438 %{_datadir}/systemd/kbd-model-map
439 %{_mandir}/man1/systemd.1*
440 %{_mandir}/man1/systemd-*.1*
441 %{_mandir}/man3/sd_booted.3*
442 %{_mandir}/man3/sd_is_fifo.3*
443 %{_mandir}/man3/sd_is_socket.3
444 %{_mandir}/man3/sd_is_socket_inet.3
445 %{_mandir}/man3/sd_is_socket_unix.3
446 %{_mandir}/man3/sd_listen_fds.3*
447 %{_mandir}/man3/sd_notify.3*
448 %{_mandir}/man3/sd_notifyf.3
449 %{_mandir}/man3/sd_readahead.3*
450 %{_mandir}/man5/binfmt.d.5*
451 %{_mandir}/man5/hostname.5*
452 %{_mandir}/man5/locale.conf.5*
453 %{_mandir}/man5/machine-id.5*
454 %{_mandir}/man5/machine-info.5*
455 %{_mandir}/man5/modules-load.d.5*
456 %{_mandir}/man5/os-release.5*
457 %{_mandir}/man5/sysctl.d.5*
458 %{_mandir}/man5/systemd.*.5*
459 %{_mandir}/man5/systemd-logind.conf.5*
460 %{_mandir}/man5/timezone.5*
461 %{_mandir}/man5/vconsole.conf.5*
462 %{_mandir}/man7/daemon.7*
463 %{_mandir}/man7/sd-daemon.7*
464 %{_mandir}/man7/sd-login.7*
465 %{_mandir}/man7/sd-readahead.7*
466 %{_mandir}/man7/systemd.special.7*
467 %attr(640,root,root) %ghost /var/log/btmp
468 %attr(664,root,utmp) %ghost /var/log/wtmp
469
470 %if %{with pam}
471 %attr(755,root,root) /%{_lib}/security/pam_systemd.so
472 %{_mandir}/man8/pam_systemd.8*
473 %endif
474
475 %files init
476 %defattr(644,root,root,755)
477 %attr(755,root,root) /sbin/halt
478 %attr(755,root,root) /sbin/init
479 %attr(755,root,root) /sbin/poweroff
480 %attr(755,root,root) /sbin/reboot
481 %attr(755,root,root) /sbin/runlevel
482 %attr(755,root,root) /sbin/shutdown
483 %attr(755,root,root) /sbin/telinit
484 %{_mandir}/man1/init.1
485 %{_mandir}/man8/halt.8*
486 %{_mandir}/man8/poweroff.8
487 %{_mandir}/man8/reboot.8
488 %{_mandir}/man8/runlevel.8*
489 %{_mandir}/man8/shutdown.8*
490 %{_mandir}/man8/telinit.8*
491
492 %files units
493 %defattr(644,root,root,755)
494 %dir %{_sysconfdir}/binfmt.d
495 %dir %{_sysconfdir}/modules-load.d
496 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/modules-load.d/modules.conf
497 %dir %{_sysconfdir}/sysctl.d
498 %dir %{_sysconfdir}/systemd
499 %dir %{_sysconfdir}/systemd/system
500 %dir %{_sysconfdir}/tmpfiles.d
501 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/tmpfiles.d/*.conf
502 %dir %{_libexecdir}/binfmt.d
503 %dir %{_libexecdir}/modules-load.d
504 %dir %{_libexecdir}/sysctl.d
505 %{_libexecdir}/sysctl.d/coredump.conf
506 %attr(755,root,root) /bin/systemctl
507 %attr(755,root,root) /bin/systemd-tmpfiles
508 %attr(755,root,root) /bin/systemd_booted
509 %{_mandir}/man1/systemctl.1*
510 %{_mandir}/man5/tmpfiles.d.5*
511 %{_mandir}/man8/systemd-tmpfiles.8*
512 %{_npkgconfigdir}/systemd.pc
513
514 /lib/systemd/system/*.automount
515 /lib/systemd/system/*.mount
516 /lib/systemd/system/*.path
517 /lib/systemd/system/*.service
518 /lib/systemd/system/*.socket
519 /lib/systemd/system/*.target
520 /lib/systemd/system/*.timer
521 %dir /lib/systemd/system/*.wants
522 %config(noreplace,missingok) /lib/systemd/system/*.wants/*
523
524 %if %{with gtk}
525 %files gtk
526 %defattr(644,root,root,755)
527 %attr(755,root,root) %{_bindir}/systemadm
528 %attr(755,root,root) %{_bindir}/systemd-gnome-ask-password-agent
529 %{_mandir}/man1/systemadm.1*
530 %endif
531
532 %files libs
533 %defattr(644,root,root,755)
534 %attr(755,root,root) /%{_lib}/libsystemd-daemon.so.*.*.*
535 %attr(755,root,root) %ghost /%{_lib}/libsystemd-daemon.so.0
536 %attr(755,root,root) /%{_lib}/libsystemd-id128.so.*.*.*
537 %attr(755,root,root) %ghost /%{_lib}/libsystemd-id128.so.0
538 %attr(755,root,root) /%{_lib}/libsystemd-journal.so.*.*.*
539 %attr(755,root,root) %ghost /%{_lib}/libsystemd-journal.so.0
540 %attr(755,root,root) /%{_lib}/libsystemd-login.so.*.*.*
541 %attr(755,root,root) %ghost /%{_lib}/libsystemd-login.so.0
542
543 %files devel
544 %defattr(644,root,root,755)
545 %attr(755,root,root) %{_libdir}/libsystemd-daemon.so
546 %attr(755,root,root) %{_libdir}/libsystemd-id128.so
547 %attr(755,root,root) %{_libdir}/libsystemd-journal.so
548 %attr(755,root,root) %{_libdir}/libsystemd-login.so
549 %{_includedir}/%{name}
550 %{_pkgconfigdir}/libsystemd-daemon.pc
551 %{_pkgconfigdir}/libsystemd-id128.pc
552 %{_pkgconfigdir}/libsystemd-journal.pc
553 %{_pkgconfigdir}/libsystemd-login.pc
554 %{_mandir}/man3/sd_get_seats.3*
555 %{_mandir}/man3/sd_get_sessions.3*
556 %{_mandir}/man3/sd_get_uids.3*
557 %{_mandir}/man3/sd_is_mq.3*
558 %{_mandir}/man3/sd_login_monitor_flush.3*
559 %{_mandir}/man3/sd_login_monitor_get_fd.3*
560 %{_mandir}/man3/sd_login_monitor_new.3*
561 %{_mandir}/man3/sd_login_monitor_unref.3*
562 %{_mandir}/man3/sd_pid_get_owner_uid.3*
563 %{_mandir}/man3/sd_pid_get_session.3*
564 %{_mandir}/man3/sd_pid_get_unit.3*
565 %{_mandir}/man3/sd_seat_can_multi_session.3*
566 %{_mandir}/man3/sd_seat_get_active.3*
567 %{_mandir}/man3/sd_seat_get_sessions.3*
568 %{_mandir}/man3/sd_session_get_seat.3*
569 %{_mandir}/man3/sd_session_get_uid.3*
570 %{_mandir}/man3/sd_session_is_active.3*
571 %{_mandir}/man3/sd_uid_get_seats.3*
572 %{_mandir}/man3/sd_uid_get_sessions.3*
573 %{_mandir}/man3/sd_uid_get_state.3*
574 %{_mandir}/man3/sd_uid_is_on_seat.3*
575
576 %files -n bash-completion-systemd
577 %defattr(644,root,root,755)
578 /etc/bash_completion.d/systemd-bash-completion.sh
This page took 0.093867 seconds and 4 git commands to generate.