]> git.pld-linux.org Git - packages/systemd.git/blob - systemd.spec
- add handler for $CLEAN_TMP
[packages/systemd.git] / systemd.spec
1 #
2 # TODO:
3 #       - remove compat-pld-var-run.tmpfiles and maybe tmpfiles-not-fatal.patch
4 #         after enough packages provide their own tmpfiles.d configs for
5 #         /var/run directories
6 #
7 # Conditional build:
8 %bcond_without  audit           # without audit support
9 %bcond_without  cryptsetup      # without cryptsetup support
10 %bcond_without  pam             # PAM authentication support
11 %bcond_without  plymouth        # do not install plymouth units
12 %bcond_without  selinux         # without SELinux support
13 %bcond_without  tcpd            # libwrap (tcp_wrappers) support
14
15 Summary:        A System and Service Manager
16 Summary(pl.UTF-8):      systemd - zarządca systemu i usług dla Linuksa
17 Name:           systemd
18 Version:        44
19 Release:        7
20 License:        GPL v2+
21 Group:          Base
22 Source0:        http://www.freedesktop.org/software/systemd/%{name}-%{version}.tar.xz
23 # Source0-md5:  11f44ff74c87850064e4351518bcff17
24 Source1:        %{name}-sysv-convert
25 Source2:        %{name}_booted.c
26 Source3:        network.service
27 Source4:        compat-pld-media.tmpfiles
28 Source5:        compat-pld-var-run.tmpfiles
29 Source10:       pld-storage-init-late.service
30 Source11:       pld-storage-init.service
31 Source12:       pld-wait-storage.service
32 Source13:       pld-storage-init.sh
33 Source14:       pld-clean-tmp.service
34 Source15:       pld-clean-tmp.sh
35 Patch0:         target-pld.patch
36 Patch1:         config-pld.patch
37 Patch2:         shut-sysv-up.patch
38 Patch3:         pld-sysv-network.patch
39 Patch4:         tmpfiles-not-fatal.patch
40 Patch5:         CVE-2012-1174.patch
41 URL:            http://www.freedesktop.org/wiki/Software/systemd
42 BuildRequires:  acl-devel
43 %{?with_audit:BuildRequires:    audit-libs-devel}
44 BuildRequires:  autoconf >= 2.63
45 BuildRequires:  automake >= 1:1.11
46 BuildRequires:  binutils >= 3:2.22.52.0.1-2
47 %{?with_cryptsetup:BuildRequires:       cryptsetup-luks-devel}
48 BuildRequires:  dbus-devel >= 1.3.2
49 BuildRequires:  docbook-style-xsl
50 BuildRequires:  gperf
51 BuildRequires:  intltool >= 0.40.0
52 BuildRequires:  kmod-devel >= 5
53 BuildRequires:  libcap-devel
54 %{?with_selinux:BuildRequires:  libselinux-devel >= 2.1.0}
55 BuildRequires:  libtool >= 2:2.2
56 %{?with_tcpd:BuildRequires:     libwrap-devel}
57 BuildRequires:  libxslt-progs
58 BuildRequires:  m4
59 %{?with_pam:BuildRequires:      pam-devel}
60 BuildRequires:  pkgconfig >= 0.9.0
61 BuildRequires:  rpmbuild(macros) >= 1.627
62 BuildRequires:  udev-devel >= 1:172
63 BuildRequires:  xz-devel
64 Requires:       %{name}-libs = %{version}-%{release}
65 Requires:       %{name}-units = %{version}-%{release}
66 Requires:       /etc/os-release
67 Requires:       SysVinit-tools
68 Requires:       agetty
69 Requires:       dbus >= 1.4.16-6
70 Requires:       filesystem >= 4.0-2
71 Requires:       libutempter
72 Requires:       rc-scripts >= 0.4.5.3-7
73 Requires:       setup >= 2.8.0-2
74 Requires:       udev-core >= 1:175-5
75 Requires:       udev-libs >= 1:172
76 Requires:       virtual(module-tools)
77 Suggests:       %{name}-no-compat-tmpfiles
78 Suggests:       ConsoleKit
79 Suggests:       fsck >= 2.20
80 Suggests:       kmod >= 5
81 Suggests:       nss_myhostname
82 Suggests:       service(klogd)
83 Suggests:       service(syslog)
84 Provides:       udev-acl
85 # systemd takes care of that and causes problems
86 Conflicts:      binfmt-detector
87 # sytemd wants pam with pam_systemd.so in system-auth...
88 Conflicts:      pam < 1:1.1.5-5
89 # ...and sudo hates it
90 Conflicts:      sudo < 1:1.7.8p2-4
91 # for prefdm script
92 Conflicts:      xinitrc-ng < 1.0
93 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
94
95 %define         _libexecdir     %{_prefix}/lib
96
97 %description
98 systemd is a system and service manager for Linux, compatible with
99 SysV and LSB init scripts. systemd provides aggressive parallelization
100 capabilities, uses socket and D-Bus activation for starting services,
101 offers on-demand starting of daemons, keeps track of processes using
102 Linux cgroups, supports snapshotting and restoring of the system
103 state, maintains mount and automount points and implements an
104 elaborate transactional dependency-based service control logic. It can
105 work as a drop-in replacement for sysvinit.
106
107 %description -l pl.UTF-8
108 systemd jest zarządcą systemu i usług dla Linuksa, kompatybilny ze
109 skryptami SysV i LSB. systemd udostępnia rozbudowane zdolności
110 paralelizacji, do uruchamiania usług używa socketów oraz D-Busa,
111 oferuje uruchamianie usług na życzenie, monitoruje procesy używając
112 linuksowych cgroups, wspomaga zapisywanie (snapshot) i odczytywanie
113 (restore) stanu systemu, zarządza (auto)mount pointami oraz
114 implementuje starannie opracowaną transakcjonalną, bazującą na
115 zależnościach logikę kontroli usług. Może pracować jako zastępca dla
116 sysvinit.
117
118 %package init
119 Summary:        systemd /sbin/init and LSB/SysV compatibility symlinks
120 Summary(pl.UTF-8):      /sbin/init z systemd i dowiązania dla kompatybilności z LSB/SysV
121 Group:          Base
122 Requires:       systemd
123 Provides:       readahead = 1:1.5.7-3
124 Provides:       virtual(init-daemon)
125 Obsoletes:      SysVinit
126 Obsoletes:      readahead < 1:1.5.7-3
127 Obsoletes:      virtual(init-daemon)
128 Conflicts:      upstart
129
130 %description init
131 Install this package when you are ready to final switch to systemd.
132
133 %description init -l pl.UTF-8
134 Ten pakiet należy zainstalować po przygotowaniu się do ostatecznego
135 przejścia na systemd.
136
137 %package units
138 Summary:        Configuration files, directories and installation tool for systemd
139 Summary(pl.UTF-8):      Pliki konfiguracyjne, katalogi i narzędzie instalacyjne dla systemd
140 Group:          Base
141 Requires(post): coreutils
142 Requires(post): /bin/awk
143
144 %description units
145 Basic configuration files, directories and installation tool for the
146 systemd system and service manager.
147
148 This is common config, use %{_sysconfdir}/systemd/system to override.
149
150 %description units -l pl.UTF-8
151 Podstawowe pliki konfiguracyjne, katalogi i narzędzie instalacyjne dla
152 zarządcy systemu i usług systemd.
153
154 Ten pakiet zawiera ogólną konfigurację, ustawienia można nadpisać
155 poprzez katalog %{_sysconfdir}/systemd/system.
156
157 %package plymouth
158 Summary:        Plymouth support units for systemd
159 Summary(pl.UTF-8):      Jednostki wspierające Plymouth dla systemd
160 Group:          Base
161 Requires:       %{name}-units = %{version}-%{release}
162 Requires:       plymouth
163
164 %description plymouth
165 Plymouth (graphical boot) support units for systemd.
166
167 %description plymouth -l pl.UTF-8
168 Jednostki wspierające Plymouth (graficzny start systemu) dla systemd.
169
170 %package analyze
171 Summary:        Tool for processing systemd profiling information
172 Group:          Base
173 Requires:       %{name} = %{version}-%{release}
174 Requires:       python-dbus
175 Requires:       python-modules
176 Requires:       python-pycairo
177 Conflicts:      %{name} < 44-3
178
179 %description analyze
180 'systemd-analyze blame' lists which systemd unit needed how much time
181 to finish initialization at boot. 'systemd-analyze plot' renders an
182 SVG visualizing the parallel start of units at boot.
183
184 %package libs
185 Summary:        Shared systemd libraries
186 Summary(pl.UTF-8):      Biblioteki współdzielone systemd
187 Group:          Libraries
188
189 %description libs
190 Shared systemd libraries.
191
192 %description libs -l pl.UTF-8
193 Biblioteki współdzielone systemd.
194
195 %package devel
196 Summary:        Header files for systemd libraries
197 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek systemd
198 Group:          Development/Libraries
199 Requires:       %{name}-libs = %{version}-%{release}
200
201 %description devel
202 Header files for systemd libraries.
203
204 %description devel -l pl.UTF-8
205 Pliki nagłówkowe bibliotek systemd.
206
207 %package -n bash-completion-systemd
208 Summary:        bash-completion for systemd
209 Summary(pl.UTF-8):      Bashowe dopełnianie składni dla systemd
210 Group:          Applications/Shells
211 Requires:       %{name}
212 Requires:       bash-completion
213
214 %description -n bash-completion-systemd
215 bash-completion for systemd.
216
217 %description -n bash-completion-systemd -l pl.UTF-8
218 Bashowe dopełnianie składni dla systemd
219
220 %package no-compat-tmpfiles
221 Summary:        Force update of packages that provide tmpfiles.d configuration
222 Group:          Base
223 Requires(post): sed > 4.0
224 Conflicts:      ConsoleKit-dirs < 0.4.5-7
225 Conflicts:      NetworkManager < 2:0.9.2.0-3
226 Conflicts:      Zope < 2.11.8-2
227 Conflicts:      amavisd-new < 1:2.7.0-1
228 Conflicts:      apache-base < 2.2.21-4
229 Conflicts:      apache-mod_bw < 0.92-3
230 Conflicts:      apache-mod_fastcgi < 2.4.6-6
231 Conflicts:      apache1-base < 1.3.42-5
232 Conflicts:      apache1-mod_fastcgi < 2.4.6-2
233 Conflicts:      asterisk < 10.0.1-2
234 Conflicts:      autossh-init < 1.4b-3
235 Conflicts:      balance < 3.54-2
236 Conflicts:      bind < 7:9.8.1.P1-4
237 Conflicts:      bopm < 3.1.3-4
238 Conflicts:      callweaver < 1.2.1-9
239 Conflicts:      cassandra-bin < 0.8.9-2
240 Conflicts:      clamav < 0.97.3-3
241 Conflicts:      cups < 1:1.5.0-10
242 Conflicts:      dbus < 1.4.16-4
243 Conflicts:      dovecot < 1:2.0.16-3
244 Conflicts:      dspam < 3.9.0-6
245 Conflicts:      fail2ban < 0.8.4-4
246 Conflicts:      filesystem < 4.0-3
247 Conflicts:      gammu-smsd < 1:1.31.0-3
248 # Break gdm2.20 installs
249 #Conflicts:     gdm < 2:3.2.1.1-9
250 Conflicts:      greylistd < 0.8.8-2
251 Conflicts:      inn < 2.4.6-7
252 Conflicts:      ipsec-tools < 0.8.0-3
253 Conflicts:      jabber-common < 0-9
254 Conflicts:      laptop-mode-tools < 1.58-2
255 Conflicts:      libgpod < 0.8.0-6
256 Conflicts:      libvirt-utils < 0.9.9-4
257 Conflicts:      lighttpd < 1.4.30-5
258 Conflicts:      lirc < 0.9.0-20
259 Conflicts:      mailman < 5:2.1.14-4
260 Conflicts:      memcached < 1.4.11-2
261 Conflicts:      mpd < 0.16.5-4
262 Conflicts:      mrtg < 2.17.0-3
263 Conflicts:      munin-common < 1.4.5-5
264 Conflicts:      nagios-nrpe < 2.13-2
265 Conflicts:      ndisc6-rdnssd < 1.0.1-3
266 Conflicts:      nscd < 6:2.14.1-5
267 Conflicts:      nss_ldapd-nslcd < 0.8.4-2
268 Conflicts:      openct < 0.6.20-3
269 Conflicts:      openl2tp < 1.8-3
270 Conflicts:      openldap-overlay-nssov < 2.4.28-4
271 Conflicts:      openldap-servers < 2.4.28-4
272 Conflicts:      openvpn < 2.2.2-2
273 Conflicts:      pam-pam_mount < 2.12-3
274 Conflicts:      pam-pam_ssh < 1.97-2
275 Conflicts:      pcsc-lite < 1.8.1-2
276 Conflicts:      php-dirs < 1.2-3
277 Conflicts:      policyd < 2.0.10-3
278 Conflicts:      pound < 2.6-2
279 Conflicts:      pptp < 1.7.2-3
280 Conflicts:      proftpd-common < 2:1.3.4a-2
281 Conflicts:      pulseaudio-server < 1.1-2
282 Conflicts:      quagga < 0.99.20-3
283 Conflicts:      radvd < 1.8.5-2
284 Conflicts:      rc-scripts < 0.4.5.2-3
285 Conflicts:      red5 < 0.9.0-2
286 Conflicts:      redis-server < 2.4.2-4
287 Conflicts:      smokeping < 2.4.2-10
288 Conflicts:      smtp-gated < 1.4.17-2
289 Conflicts:      socat < 1.7.2.0-2
290 Conflicts:      speech-dispatcher < 0.7.1-2
291 Conflicts:      sphinx < 2.0.3-4
292 Conflicts:      splashutils < 1.5.4.3-3
293 Conflicts:      stunnel < 4.50-2
294 Conflicts:      tenshi < 0.12-2
295 Conflicts:      tor < 0.2.2.35-2
296 Conflicts:      ucarp < 1.5.2-3
297 Conflicts:      udisks < 1.0.4-3
298 Conflicts:      util-vserver < 0.30.216-1.pre3002.3
299 Conflicts:      vpnc < 0.5.3-2
300 Conflicts:      web2ldap < 1.1.0rc1-2
301 Conflicts:      wesnoth-server < 1:1.10-2
302 Conflicts:      wpa_supplicant < 0.7.3-10
303 Conflicts:      xl2tpd < 1.3.0-2
304
305 %description no-compat-tmpfiles
306 Force update of packages that provide tmpfiles.d configuration
307
308 %prep
309 %setup -q
310 %patch0 -p1
311 %patch1 -p1
312 %patch2 -p1
313 %patch3 -p1
314 %patch4 -p1
315 %patch5 -p1
316 cp -p %{SOURCE2} src/systemd_booted.c
317
318 %build
319 %{__aclocal} -I m4
320 %{__autoconf}
321 %{__autoheader}
322 %{__automake}
323 %configure \
324         %{__enable_disable audit} \
325         %{__enable_disable cryptsetup libcryptsetup} \
326         --disable-gtk \
327         %{__enable_disable pam} \
328         %{__enable_disable plymouth} \
329         %{__enable_disable selinux} \
330         %{__enable_disable tcpd tcpwrap} \
331         --disable-silent-rules \
332         --disable-static \
333         --with-distro=pld \
334         --with-rootprefix= \
335         --with-rootlibdir=/%{_lib} \
336         --enable-split-usr
337
338 %{__make}
339 ./libtool --mode=link --tag=CC %{__cc} %{rpmcppflags} %{rpmcflags} -o systemd_booted %{rpmldflags} src/systemd_booted.c -L. -lsystemd-daemon
340
341 %install
342 rm -rf $RPM_BUILD_ROOT
343 install -d $RPM_BUILD_ROOT/var/lib/%{name}/coredump
344
345 %{__make} install \
346         DESTDIR=$RPM_BUILD_ROOT
347
348 ./libtool --mode=install install -p -m755 systemd_booted $RPM_BUILD_ROOT/bin/systemd_booted
349
350 # Main binary has been moved, but we don't want to break existing installs
351 ln -s ../lib/systemd/systemd $RPM_BUILD_ROOT/bin/systemd
352
353 # Create SysV compatibility symlinks. systemctl/systemd are smart
354 # enough to detect the way they were called
355 install -d $RPM_BUILD_ROOT/sbin
356 ln -s ../lib/systemd/systemd $RPM_BUILD_ROOT/sbin/init
357 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/halt
358 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/poweroff
359 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/reboot
360 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/runlevel
361 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/shutdown
362 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/telinit
363
364 ln -s ../modules $RPM_BUILD_ROOT%{_sysconfdir}/modules-load.d/modules.conf
365
366 # disable redundant SYSV services
367 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/allowlogin.service
368 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/console.service
369 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/cpusets.service
370 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/killall.service
371 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/netfs.service
372 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/random.service
373
374 # add static (non-NetworkManager) networking
375 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{systemdunitdir}/network.service
376
377 # install compatibility tmpfiles configs
378 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/compat-pld-media.conf
379 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/compat-pld-var-run.conf
380
381 # Install and enable storage subsystems support services (RAID, LVM, etc.)
382 cp -p %{SOURCE10} $RPM_BUILD_ROOT%{systemdunitdir}/pld-storage-init-late.service
383 cp -p %{SOURCE11} $RPM_BUILD_ROOT%{systemdunitdir}/pld-storage-init.service
384 cp -p %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/pld-wait-storage.service
385 cp -p %{SOURCE14} $RPM_BUILD_ROOT%{systemdunitdir}/pld-clean-tmp.service
386 install -p %{SOURCE13} $RPM_BUILD_ROOT/lib/systemd/pld-storage-init
387 install -p %{SOURCE15} $RPM_BUILD_ROOT/lib/systemd/pld-clean-tmp
388
389 ln -s ../pld-storage-init-late.service $RPM_BUILD_ROOT%{systemdunitdir}/local-fs.target.wants
390 ln -s ../pld-storage-init.service $RPM_BUILD_ROOT%{systemdunitdir}/local-fs.target.wants
391 ln -s ../pld-clean-tmp.service $RPM_BUILD_ROOT%{systemdunitdir}/local-fs.target.wants
392
393 # handled by rc-local sysv service, no need for generator
394 %{__rm} $RPM_BUILD_ROOT/lib/systemd/system-generators/systemd-rc-local-generator
395
396 # Make sure these directories are properly owned:
397 #       - halt,kexec,poweroff,reboot: generic ones used by ConsoleKit-systemd,
398 #       - syslog _might_ be used by some syslog implementation (none for now),
399 #       - isn't dbus populated by dbus-systemd only (so to be moved there)?
400 install -d $RPM_BUILD_ROOT%{systemdunitdir}/{dbus,halt,kexec,poweroff,reboot,syslog}.target.wants
401
402 # Create new-style configuration files so that we can ghost-own them
403 touch $RPM_BUILD_ROOT%{_sysconfdir}/{hostname,locale.conf,machine-id,machine-info,timezone,vconsole.conf}
404
405 # Install SysV conversion tool for systemd
406 install -p %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}
407
408 install -d $RPM_BUILD_ROOT/var/log
409 :> $RPM_BUILD_ROOT/var/log/btmp
410 :> $RPM_BUILD_ROOT/var/log/wtmp
411
412 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/systemadm.1*
413
414 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
415 %{__rm} $RPM_BUILD_ROOT/%{_lib}/security/pam_systemd.la
416 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
417
418 %clean
419 rm -rf $RPM_BUILD_ROOT
420
421 %post
422 /bin/systemd-machine-id-setup > /dev/null 2>&1 || :
423 /bin/systemctl daemon-reexec > /dev/null 2>&1 || :
424
425 %postun
426 if [ $1 -ge 1 ]; then
427         /bin/systemctl try-restart systemd-logind.service >/dev/null 2>&1 || :
428 fi
429
430 %post   libs -p /sbin/ldconfig
431 %postun libs -p /sbin/ldconfig
432
433 %post units
434 if [ $1 -eq 1 ]; then
435         # Try to read default runlevel from the old inittab if it exists
436         runlevel=$(/bin/awk -F ':' '$3 == "initdefault" && $1 !~ "^#" { print $2 }' /etc/inittab 2> /dev/null)
437         if [ -z "$runlevel" ] ; then
438                 target="%{systemdunitdir}/graphical.target"
439         else
440                 target="%{systemdunitdir}/runlevel$runlevel.target"
441         fi
442
443         # And symlink what we found to the new-style default.target
444         ln -s "$target" %{_sysconfdir}/systemd/system/default.target >/dev/null 2>&1 || :
445
446         # Setup hostname
447         [ -f /etc/sysconfig/network ] && . /etc/sysconfig/network
448         if [ -n "$HOSTNAME" -a "$HOSTNAME" != "pldmachine" ]; then
449                 [ -f /etc/hostname ] && mv -f /etc/hostname /etc/hostname.rpmsave
450                 echo $HOSTNAME > /etc/hostname
451                 chmod 644 /etc/hostname
452         fi
453
454         # Enable the services we install by default.
455         /bin/systemctl enable \
456                 getty@.service \
457                 network.service \
458                 remote-fs.target \
459                 systemd-readahead-replay.service \
460                 systemd-readahead-collect.service >/dev/null 2>&1 || :
461 fi
462
463 %preun units
464 if [ $1 -eq 0 ] ; then
465         /bin/systemctl disable \
466                 getty@.service \
467                 network.service \
468                 remote-fs.target \
469                 systemd-readahead-replay.service \
470                 systemd-readahead-collect.service >/dev/null 2>&1 || :
471
472         %{__rm} -f %{_sysconfdir}/systemd/system/default.target >/dev/null 2>&1 || :
473 fi
474
475 %postun units
476 if [ $1 -ge 1 ]; then
477         /bin/systemctl daemon-reload > /dev/null 2>&1 || :
478 fi
479
480 %triggerpostun units -- %{name}-units < 43-7
481 # Remove design fialures
482 rm -f %{_sysconfdir}/systemd/system/network.target.wants/ifcfg@*.service >/dev/null 2>&1 || :
483 rm -f %{_sysconfdir}/systemd/system/network.target.wants/network-post.service >/dev/null 2>&1 || :
484 rm -f %{_sysconfdir}/systemd/system/multi-user.target.wants/network-post.service >/dev/null 2>&1 || :
485 /bin/systemctl reenable network.service >/dev/null 2>&1 || :
486
487 %post no-compat-tmpfiles
488 %{__sed} -i -e '/^#/!s/^/# /g' %{_sysconfdir}/tmpfiles.d/compat-pld-var-run.conf
489
490 %post plymouth
491 %systemd_reload
492
493 %postun plymouth
494 %systemd_reload
495
496 %files
497 %defattr(644,root,root,755)
498 %doc DISTRO_PORTING README TODO
499 /etc/dbus-1/system.d/org.freedesktop.hostname1.conf
500 /etc/dbus-1/system.d/org.freedesktop.locale1.conf
501 /etc/dbus-1/system.d/org.freedesktop.login1.conf
502 /etc/dbus-1/system.d/org.freedesktop.systemd1.conf
503 /etc/dbus-1/system.d/org.freedesktop.timedate1.conf
504 %ghost %config(noreplace) %{_sysconfdir}/machine-id
505 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hostname
506 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/locale.conf
507 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/machine-info
508 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/timezone
509 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/vconsole.conf
510 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/systemd/*.conf
511 %dir %{_sysconfdir}/systemd/user
512 %dir %{_sysconfdir}/systemd/system/*.target.wants
513 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/systemd/system/*.target.wants/*.service
514 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/systemd/system/*.target.wants/*.target
515 /etc/xdg/systemd
516 %attr(755,root,root) /bin/systemd
517 %attr(755,root,root) /bin/systemd-ask-password
518 %attr(755,root,root) /bin/systemd-journalctl
519 %attr(755,root,root) /bin/systemd-loginctl
520 %attr(755,root,root) /bin/systemd-machine-id-setup
521 %attr(755,root,root) /bin/systemd-notify
522 %attr(755,root,root) /bin/systemd-tty-ask-password-agent
523 %attr(755,root,root) %{_bindir}/systemd-cat
524 %attr(755,root,root) %{_bindir}/systemd-cgtop
525 %attr(755,root,root) %{_bindir}/systemd-cgls
526 %attr(755,root,root) %{_bindir}/systemd-nspawn
527 %attr(755,root,root) %{_bindir}/systemd-stdio-bridge
528 %attr(755,root,root) %{_bindir}/systemd-sysv-convert
529 %attr(755,root,root) /lib/systemd/pld-storage-init
530 %attr(755,root,root) /lib/systemd/systemd-*
531 %dir /lib/systemd/system-generators
532 %attr(755,root,root) /lib/systemd/systemd
533 %attr(755,root,root) /lib/systemd/system-generators/systemd-*-generator
534 %dir /lib/systemd/system-shutdown
535 /lib/udev/rules.d/99-systemd.rules
536 /lib/udev/rules.d/70-uaccess.rules
537 /lib/udev/rules.d/71-seat.rules
538 /lib/udev/rules.d/73-seat-late.rules
539 %dir %{_libexecdir}/systemd
540 %{_libexecdir}/systemd/user
541 %dir %{_libexecdir}/systemd/user-generators
542 %config(noreplace,missingok) %{_libexecdir}/tmpfiles.d/*.conf
543 %{_datadir}/dbus-1/interfaces/org.freedesktop.hostname1.xml
544 %{_datadir}/dbus-1/interfaces/org.freedesktop.locale1.xml
545 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.*.xml
546 %{_datadir}/dbus-1/interfaces/org.freedesktop.timedate1.xml
547 %{_datadir}/dbus-1/services/org.freedesktop.systemd1.service
548 %{_datadir}/dbus-1/system-services/org.freedesktop.hostname1.service
549 %{_datadir}/dbus-1/system-services/org.freedesktop.locale1.service
550 %{_datadir}/dbus-1/system-services/org.freedesktop.login1.service
551 %{_datadir}/dbus-1/system-services/org.freedesktop.systemd1.service
552 %{_datadir}/dbus-1/system-services/org.freedesktop.timedate1.service
553 %{_datadir}/polkit-1/actions/org.freedesktop.hostname1.policy
554 %{_datadir}/polkit-1/actions/org.freedesktop.locale1.policy
555 %{_datadir}/polkit-1/actions/org.freedesktop.login1.policy
556 %{_datadir}/polkit-1/actions/org.freedesktop.systemd1.policy
557 %{_datadir}/polkit-1/actions/org.freedesktop.timedate1.policy
558 %dir %{_datadir}/systemd
559 %{_datadir}/systemd/kbd-model-map
560 %{_mandir}/man1/systemd.1*
561 %{_mandir}/man1/systemd-*.1*
562 %{_mandir}/man5/binfmt.d.5*
563 %{_mandir}/man5/hostname.5*
564 %{_mandir}/man5/locale.conf.5*
565 %{_mandir}/man5/machine-id.5*
566 %{_mandir}/man5/machine-info.5*
567 %{_mandir}/man5/modules-load.d.5*
568 %{_mandir}/man5/os-release.5*
569 %{_mandir}/man5/sysctl.d.5*
570 %{_mandir}/man5/systemd.*.5*
571 %{_mandir}/man5/systemd-journald.conf.5*
572 %{_mandir}/man5/systemd-logind.conf.5*
573 %{_mandir}/man5/timezone.5*
574 %{_mandir}/man5/vconsole.conf.5*
575 %{_mandir}/man7/daemon.7*
576 %{_mandir}/man7/sd-daemon.7*
577 %{_mandir}/man7/sd-login.7*
578 %{_mandir}/man7/sd-readahead.7*
579 %{_mandir}/man7/systemd.special.7*
580 %dir /var/lib/%{name}
581 %dir /var/lib/%{name}/coredump
582 %attr(640,root,root) %ghost /var/log/btmp
583 %attr(664,root,utmp) %ghost /var/log/wtmp
584
585 %if %{with pam}
586 %attr(755,root,root) /%{_lib}/security/pam_systemd.so
587 %{_mandir}/man8/pam_systemd.8*
588 %endif
589
590 %files init
591 %defattr(644,root,root,755)
592 %attr(755,root,root) /sbin/halt
593 %attr(755,root,root) /sbin/init
594 %attr(755,root,root) /sbin/poweroff
595 %attr(755,root,root) /sbin/reboot
596 %attr(755,root,root) /sbin/runlevel
597 %attr(755,root,root) /sbin/shutdown
598 %attr(755,root,root) /sbin/telinit
599 %{_mandir}/man1/init.1
600 %{_mandir}/man8/halt.8*
601 %{_mandir}/man8/poweroff.8
602 %{_mandir}/man8/reboot.8
603 %{_mandir}/man8/runlevel.8*
604 %{_mandir}/man8/shutdown.8*
605 %{_mandir}/man8/telinit.8*
606
607 %files units
608 %defattr(644,root,root,755)
609 %dir %{_sysconfdir}/binfmt.d
610 %dir %{_sysconfdir}/modules-load.d
611 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/modules-load.d/modules.conf
612 %dir %{_sysconfdir}/sysctl.d
613 %dir %{_sysconfdir}/systemd
614 %dir %{_sysconfdir}/systemd/system
615 %dir %{_sysconfdir}/tmpfiles.d
616 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/tmpfiles.d/*.conf
617 %dir %{_libexecdir}/binfmt.d
618 %dir %{_libexecdir}/modules-load.d
619 %dir %{_libexecdir}/sysctl.d
620 %{_libexecdir}/sysctl.d/coredump.conf
621 %attr(755,root,root) /bin/systemctl
622 %attr(755,root,root) /bin/systemd-tmpfiles
623 %attr(755,root,root) /bin/systemd_booted
624 %{_mandir}/man1/systemctl.1*
625 %{_mandir}/man5/tmpfiles.d.5*
626 %{_mandir}/man8/systemd-tmpfiles.8*
627 %{_npkgconfigdir}/systemd.pc
628
629 %{systemdunitdir}/*.automount
630 %{systemdunitdir}/*.mount
631 %{systemdunitdir}/*.path
632 %{systemdunitdir}/*.service
633 %{systemdunitdir}/*.socket
634 %{systemdunitdir}/*.target
635 %{systemdunitdir}/*.timer
636 %if %{with plymouth}
637 %exclude %{systemdunitdir}/plymouth*.service
638 %exclude %{systemdunitdir}/systemd-ask-password-plymouth.*
639 %endif
640 %dir %{systemdunitdir}/basic.target.wants
641 %dir %{systemdunitdir}/dbus.target.wants
642 %dir %{systemdunitdir}/final.target.wants
643 %dir %{systemdunitdir}/graphical.target.wants
644 %dir %{systemdunitdir}/halt.target.wants
645 %dir %{systemdunitdir}/kexec.target.wants
646 %dir %{systemdunitdir}/local-fs.target.wants
647 %dir %{systemdunitdir}/multi-user.target.wants
648 %dir %{systemdunitdir}/poweroff.target.wants
649 %dir %{systemdunitdir}/reboot.target.wants
650 %dir %{systemdunitdir}/runlevel[12345].target.wants
651 %dir %{systemdunitdir}/shutdown.target.wants
652 %dir %{systemdunitdir}/sockets.target.wants
653 %dir %{systemdunitdir}/sysinit.target.wants
654 %dir %{systemdunitdir}/syslog.target.wants
655 %config(noreplace,missingok) %{systemdunitdir}/basic.target.wants/*
656 %config(noreplace,missingok) %{systemdunitdir}/final.target.wants/*
657 %config(noreplace,missingok) %{systemdunitdir}/graphical.target.wants/*
658 %config(noreplace,missingok) %{systemdunitdir}/local-fs.target.wants/*
659 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/getty.target
660 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/rc-local.service
661 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/systemd-ask-password-wall.path
662 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/systemd-logind.service
663 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/systemd-user-sessions.service
664 %config(noreplace,missingok) %{systemdunitdir}/runlevel[12345].target.wants/*
665 %config(noreplace,missingok) %{systemdunitdir}/shutdown.target.wants/*
666 %config(noreplace,missingok) %{systemdunitdir}/sockets.target.wants/*
667 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/cryptsetup.target
668 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/dev-hugepages.mount
669 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/dev-mqueue.mount
670 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/proc-sys-fs-binfmt_misc.automount
671 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/sys-*.mount
672 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/systemd-*
673
674 %if %{with plymouth}
675 %files plymouth
676 %defattr(644,root,root,755)
677 %{systemdunitdir}/plymouth-halt.service
678 %{systemdunitdir}/plymouth-kexec.service
679 %{systemdunitdir}/plymouth-poweroff.service
680 %{systemdunitdir}/plymouth-quit-wait.service
681 %{systemdunitdir}/plymouth-quit.service
682 %{systemdunitdir}/plymouth-read-write.service
683 %{systemdunitdir}/plymouth-reboot.service
684 %{systemdunitdir}/plymouth-start.service
685 %{systemdunitdir}/systemd-ask-password-plymouth.path
686 %{systemdunitdir}/systemd-ask-password-plymouth.service
687 %config(noreplace,missingok) %{systemdunitdir}/halt.target.wants/plymouth-halt.service
688 %config(noreplace,missingok) %{systemdunitdir}/kexec.target.wants/plymouth-kexec.service
689 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/plymouth-quit.service
690 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/plymouth-quit-wait.service
691 %config(noreplace,missingok) %{systemdunitdir}/poweroff.target.wants/plymouth-poweroff.service
692 %config(noreplace,missingok) %{systemdunitdir}/reboot.target.wants/plymouth-reboot.service
693 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/plymouth-read-write.service
694 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/plymouth-start.service
695 %endif
696
697 %files analyze
698 %defattr(644,root,root,755)
699 %attr(755,root,root) %{_bindir}/systemd-analyze
700
701 %files libs
702 %defattr(644,root,root,755)
703 %attr(755,root,root) /%{_lib}/libsystemd-daemon.so.*.*.*
704 %attr(755,root,root) %ghost /%{_lib}/libsystemd-daemon.so.0
705 %attr(755,root,root) /%{_lib}/libsystemd-id128.so.*.*.*
706 %attr(755,root,root) %ghost /%{_lib}/libsystemd-id128.so.0
707 %attr(755,root,root) /%{_lib}/libsystemd-journal.so.*.*.*
708 %attr(755,root,root) %ghost /%{_lib}/libsystemd-journal.so.0
709 %attr(755,root,root) /%{_lib}/libsystemd-login.so.*.*.*
710 %attr(755,root,root) %ghost /%{_lib}/libsystemd-login.so.0
711
712 %files devel
713 %defattr(644,root,root,755)
714 %attr(755,root,root) %{_libdir}/libsystemd-daemon.so
715 %attr(755,root,root) %{_libdir}/libsystemd-id128.so
716 %attr(755,root,root) %{_libdir}/libsystemd-journal.so
717 %attr(755,root,root) %{_libdir}/libsystemd-login.so
718 %{_includedir}/%{name}
719 %{_pkgconfigdir}/libsystemd-daemon.pc
720 %{_pkgconfigdir}/libsystemd-id128.pc
721 %{_pkgconfigdir}/libsystemd-journal.pc
722 %{_pkgconfigdir}/libsystemd-login.pc
723 %{_mandir}/man3/sd_booted.3*
724 %{_mandir}/man3/sd_get_seats.3*
725 %{_mandir}/man3/sd_get_sessions.3*
726 %{_mandir}/man3/sd_get_uids.3*
727 %{_mandir}/man3/sd_is_fifo.3*
728 %{_mandir}/man3/sd_is_mq.3*
729 %{_mandir}/man3/sd_is_socket.3
730 %{_mandir}/man3/sd_is_socket_inet.3
731 %{_mandir}/man3/sd_is_socket_unix.3
732 %{_mandir}/man3/sd_listen_fds.3*
733 %{_mandir}/man3/sd_login_monitor_flush.3*
734 %{_mandir}/man3/sd_login_monitor_get_fd.3*
735 %{_mandir}/man3/sd_login_monitor_new.3*
736 %{_mandir}/man3/sd_login_monitor_unref.3*
737 %{_mandir}/man3/sd_notify.3*
738 %{_mandir}/man3/sd_notifyf.3
739 %{_mandir}/man3/sd_pid_get_owner_uid.3*
740 %{_mandir}/man3/sd_pid_get_session.3*
741 %{_mandir}/man3/sd_pid_get_unit.3*
742 %{_mandir}/man3/sd_readahead.3*
743 %{_mandir}/man3/sd_seat_can_multi_session.3*
744 %{_mandir}/man3/sd_seat_get_active.3*
745 %{_mandir}/man3/sd_seat_get_sessions.3*
746 %{_mandir}/man3/sd_session_get_class.3*
747 %{_mandir}/man3/sd_session_get_display.3*
748 %{_mandir}/man3/sd_session_get_seat.3*
749 %{_mandir}/man3/sd_session_get_service.3*
750 %{_mandir}/man3/sd_session_get_type.3*
751 %{_mandir}/man3/sd_session_get_uid.3*
752 %{_mandir}/man3/sd_session_is_active.3*
753 %{_mandir}/man3/sd_uid_get_seats.3*
754 %{_mandir}/man3/sd_uid_get_sessions.3*
755 %{_mandir}/man3/sd_uid_get_state.3*
756 %{_mandir}/man3/sd_uid_is_on_seat.3*
757
758 %files -n bash-completion-systemd
759 %defattr(644,root,root,755)
760 /etc/bash_completion.d/systemd-bash-completion.sh
761
762 %files no-compat-tmpfiles
763 %defattr(644,root,root,755)
764 # empty package
This page took 0.121922 seconds and 4 git commands to generate.