]> git.pld-linux.org Git - packages/systemd.git/blob - systemd.spec
- systemd-analyze to subpackage; python as dependency is no longer pulled
[packages/systemd.git] / systemd.spec
1 #
2 # TODO:
3 #       - remove compat-pld-var-run.tmpfiles and maybe tmpfiles-not-fatal.patch
4 #         after enough packages provide their own tmpfiles.d configs for
5 #         /var/run directories
6 #
7 # Conditional build:
8 %bcond_without  audit           # without audit support
9 %bcond_without  cryptsetup      # without cryptsetup support
10 %bcond_without  gtk             # build gtk tools
11 %bcond_without  pam             # PAM authentication support
12 %bcond_with     plymouth        # plymouth support
13 %bcond_without  selinux         # without SELinux support
14 %bcond_without  tcpd            # libwrap (tcp_wrappers) support
15
16 Summary:        A System and Service Manager
17 Summary(pl.UTF-8):      systemd - zarządca systemu i usług dla Linuksa
18 Name:           systemd
19 Version:        44
20 Release:        3
21 License:        GPL v2+
22 Group:          Base
23 Source0:        http://www.freedesktop.org/software/systemd/%{name}-%{version}.tar.xz
24 # Source0-md5:  11f44ff74c87850064e4351518bcff17
25 Source1:        %{name}-sysv-convert
26 Source2:        %{name}_booted.c
27 Source3:        network.service
28 Source4:        compat-pld-media.tmpfiles
29 Source5:        compat-pld-var-run.tmpfiles
30 Source10:       pld-storage-init-late.service
31 Source11:       pld-storage-init.service
32 Source12:       pld-wait-storage.service
33 Source13:       pld-storage-init.sh
34 Patch0:         target-pld.patch
35 Patch1:         config-pld.patch
36 Patch2:         shut-sysv-up.patch
37 Patch3:         pld-sysv-network.patch
38 Patch4:         tmpfiles-not-fatal.patch
39 Patch5:         CVE-2012-1174.patch
40 URL:            http://www.freedesktop.org/wiki/Software/systemd
41 BuildRequires:  acl-devel
42 %{?with_audit:BuildRequires:    audit-libs-devel}
43 BuildRequires:  autoconf >= 2.63
44 BuildRequires:  automake >= 1:1.11
45 BuildRequires:  binutils >= 3:2.22.52.0.1-2
46 %{?with_cryptsetup:BuildRequires:       cryptsetup-luks-devel}
47 BuildRequires:  dbus-devel >= 1.3.2
48 BuildRequires:  docbook-style-xsl
49 BuildRequires:  gperf
50 BuildRequires:  intltool >= 0.40.0
51 BuildRequires:  kmod-devel >= 5
52 BuildRequires:  libcap-devel
53 %{?with_selinux:BuildRequires:  libselinux-devel >= 2.1.0}
54 BuildRequires:  libtool >= 2:2.2
55 %{?with_tcpd:BuildRequires:     libwrap-devel}
56 BuildRequires:  libxslt-progs
57 BuildRequires:  m4
58 %{?with_pam:BuildRequires:      pam-devel}
59 BuildRequires:  pkgconfig >= 0.9.0
60 BuildRequires:  rpmbuild(macros) >= 1.627
61 BuildRequires:  udev-devel >= 1:172
62 # not required for building from release (which contains *.c for *.vala)
63 #BuildRequires: vala >= 0.10.0
64 BuildRequires:  xz-devel
65 %if %{with gtk}
66 BuildRequires:  glib2-devel >= 1:2.26.1
67 BuildRequires:  gtk+2-devel >= 2:2.24.0
68 BuildRequires:  libgee-devel
69 BuildRequires:  libnotify-devel >= 0.7.0
70 %endif
71 Requires:       %{name}-libs = %{version}-%{release}
72 Requires:       %{name}-units = %{version}-%{release}
73 Requires:       /etc/os-release
74 Requires:       SysVinit-tools
75 Requires:       agetty
76 Requires:       dbus >= 1.4.16-6
77 Requires:       filesystem >= 4.0-2
78 Requires:       libutempter
79 Requires:       rc-scripts >= 0.4.5.1-7
80 Requires:       setup >= 2.8.0-2
81 Requires:       udev-core >= 1:175-5
82 Requires:       udev-libs >= 1:172
83 Requires:       virtual(module-tools)
84 Suggests:       %{name}-no-compat-tmpfiles
85 Suggests:       ConsoleKit
86 Suggests:       fsck >= 2.20
87 Suggests:       kmod >= 5
88 Suggests:       nss_myhostname
89 Suggests:       service(klogd)
90 Suggests:       service(syslog)
91 Provides:       udev-acl
92 # systemd takes care of that and causes problems
93 Conflicts:      binfmt-detector
94 # sytemd wants pam with pam_systemd.so in system-auth...
95 Conflicts:      pam < 1:1.1.5-5
96 # ...and sudo hates it
97 Conflicts:      sudo < 1:1.7.8p2-4
98 # for prefdm script
99 Conflicts:      xinitrc-ng < 1.0
100 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
101
102 %define         _libexecdir     %{_prefix}/lib
103
104 %description
105 systemd is a system and service manager for Linux, compatible with
106 SysV and LSB init scripts. systemd provides aggressive parallelization
107 capabilities, uses socket and D-Bus activation for starting services,
108 offers on-demand starting of daemons, keeps track of processes using
109 Linux cgroups, supports snapshotting and restoring of the system
110 state, maintains mount and automount points and implements an
111 elaborate transactional dependency-based service control logic. It can
112 work as a drop-in replacement for sysvinit.
113
114 %description -l pl.UTF-8
115 systemd jest zarządcą systemu i usług dla Linuksa, kompatybilny ze
116 skryptami SysV i LSB. systemd udostępnia rozbudowane zdolności
117 paralelizacji, do uruchamiania usług używa socketów oraz D-Busa,
118 oferuje uruchamianie usług na życzenie, monitoruje procesy używając
119 linuksowych cgroups, wspomaga zapisywanie (snapshot) i odczytywanie
120 (restore) stanu systemu, zarządza (auto)mount pointami oraz
121 implementuje starannie opracowaną transakcjonalną, bazującą na
122 zależnościach logikę kontroli usług. Może pracować jako zastępca dla
123 sysvinit.
124
125 %package init
126 Summary:        systemd /sbin/init and LSB/SysV compatibility symlinks
127 Summary(pl.UTF-8):      /sbin/init z systemd i dowiązania dla kompatybilności z LSB/SysV
128 Group:          Base
129 Requires:       systemd
130 Provides:       readahead = 1:1.5.7-3
131 Provides:       virtual(init-daemon)
132 Obsoletes:      SysVinit
133 Obsoletes:      readahead < 1:1.5.7-3
134 Obsoletes:      virtual(init-daemon)
135 Conflicts:      upstart
136
137 %description init
138 Install this package when you are ready to final switch to systemd.
139
140 %description init -l pl.UTF-8
141 Ten pakiet należy zainstalować po przygotowaniu się do ostatecznego
142 przejścia na systemd.
143
144 %package units
145 Summary:        Configuration files, directories and installation tool for systemd
146 Summary(pl.UTF-8):      Pliki konfiguracyjne, katalogi i narzędzie instalacyjne dla systemd
147 Group:          Base
148 Requires(post): coreutils
149 Requires(post): /bin/awk
150
151 %description units
152 Basic configuration files, directories and installation tool for the
153 systemd system and service manager.
154
155 This is common config, use %{_sysconfdir}/systemd/system to override.
156
157 %description units -l pl.UTF-8
158 Podstawowe pliki konfiguracyjne, katalogi i narzędzie instalacyjne dla
159 zarządcy systemu i usług systemd.
160
161 Ten pakiet zawiera ogólną konfigurację, ustawienia można nadpisać
162 poprzez katalog %{_sysconfdir}/systemd/system.
163
164 %package plymouth
165 Summary:        Plymouth support units for systemd
166 Summary(pl.UTF-8):      Jednostki wspierające Plymouth dla systemd
167 Group:          Base
168 Requires:       %{name}-units = %{version}-%{release}
169
170 %description plymouth
171 Plymouth (graphical boot) support units for systemd.
172
173 %description plymouth -l pl.UTF-8
174 Jednostki wspierające Plymouth (graficzny start systemu) dla systemd.
175
176 %package gtk
177 Summary:        Graphical frontend for systemd
178 Summary(pl.UTF-8):      Graficzny interfejs do systemd
179 Group:          Base
180 Requires:       %{name} = %{version}-%{release}
181 Requires:       polkit
182
183 %description gtk
184 Graphical front-end for systemd.
185
186 %description gtk -l pl.UTF-8
187 Graficzny interfejs do systemd.
188
189 %package analyze
190 Summary:        Tool for processing systemd profiling information
191 Group:          Base
192 Requires:       %{name} = %{version}-%{release}
193 Requires:       python-dbus
194 Requires:       python-modules
195 Requires:       python-pycairo
196 Conflicts:      %{name} < 44-3
197
198 %description analyze
199 'systemd-analyze blame' lists which systemd unit needed how much time
200 to finish initialization at boot. 'systemd-analyze plot' renders an
201 SVG visualizing the parallel start of units at boot.
202
203 %package libs
204 Summary:        Shared systemd libraries
205 Summary(pl.UTF-8):      Biblioteki współdzielone systemd
206 Group:          Libraries
207
208 %description libs
209 Shared systemd libraries.
210
211 %description libs -l pl.UTF-8
212 Biblioteki współdzielone systemd.
213
214 %package devel
215 Summary:        Header files for systemd libraries
216 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek systemd
217 Group:          Development/Libraries
218 Requires:       %{name}-libs = %{version}-%{release}
219
220 %description devel
221 Header files for systemd libraries.
222
223 %description devel -l pl.UTF-8
224 Pliki nagłówkowe bibliotek systemd.
225
226 %package -n bash-completion-systemd
227 Summary:        bash-completion for systemd
228 Summary(pl.UTF-8):      Bashowe dopełnianie składni dla systemd
229 Group:          Applications/Shells
230 Requires:       %{name}
231 Requires:       bash-completion
232
233 %description -n bash-completion-systemd
234 bash-completion for systemd.
235
236 %description -n bash-completion-systemd -l pl.UTF-8
237 Bashowe dopełnianie składni dla systemd
238
239 %package no-compat-tmpfiles
240 Summary:        Force update of packages that provide tmpfiles.d configuration
241 Group:          Base
242 Requires(post): sed > 4.0
243 Conflicts:      ConsoleKit-dirs < 0.4.5-7
244 Conflicts:      NetworkManager < 2:0.9.2.0-3
245 Conflicts:      Zope < 2.11.8-2
246 Conflicts:      amavisd-new < 1:2.7.0-1
247 Conflicts:      apache-base < 2.2.21-4
248 Conflicts:      apache-mod_bw < 0.92-3
249 Conflicts:      apache-mod_fastcgi < 2.4.6-6
250 Conflicts:      apache1-base < 1.3.42-5
251 Conflicts:      apache1-mod_fastcgi < 2.4.6-2
252 Conflicts:      asterisk < 10.0.1-2
253 Conflicts:      autossh-init < 1.4b-3
254 Conflicts:      balance < 3.54-2
255 Conflicts:      bind < 7:9.8.1.P1-4
256 Conflicts:      bopm < 3.1.3-4
257 Conflicts:      callweaver < 1.2.1-9
258 Conflicts:      cassandra-bin < 0.8.9-2
259 Conflicts:      clamav < 0.97.3-3
260 Conflicts:      cups < 1:1.5.0-10
261 Conflicts:      dbus < 1.4.16-4
262 Conflicts:      dovecot < 1:2.0.16-3
263 Conflicts:      dspam < 3.9.0-6
264 Conflicts:      fail2ban < 0.8.4-4
265 Conflicts:      filesystem < 4.0-3
266 Conflicts:      gammu-smsd < 1:1.31.0-3
267 # Break gdm2.20 installs
268 #Conflicts:     gdm < 2:3.2.1.1-9
269 Conflicts:      greylistd < 0.8.8-2
270 Conflicts:      inn < 2.4.6-7
271 Conflicts:      ipsec-tools < 0.8.0-3
272 Conflicts:      jabber-common < 0-9
273 Conflicts:      laptop-mode-tools < 1.58-2
274 Conflicts:      libgpod < 0.8.0-6
275 Conflicts:      libvirt-utils < 0.9.9-4
276 Conflicts:      lighttpd < 1.4.30-5
277 Conflicts:      lirc < 0.9.0-20
278 Conflicts:      mailman < 5:2.1.14-4
279 Conflicts:      memcached < 1.4.11-2
280 Conflicts:      mpd < 0.16.5-4
281 Conflicts:      mrtg < 2.17.0-3
282 Conflicts:      munin-common < 1.4.5-5
283 Conflicts:      nagios-nrpe < 2.13-2
284 Conflicts:      ndisc6-rdnssd < 1.0.1-3
285 Conflicts:      nscd < 6:2.14.1-5
286 Conflicts:      nss_ldapd-nslcd < 0.8.4-2
287 Conflicts:      openct < 0.6.20-3
288 Conflicts:      openl2tp < 1.8-3
289 Conflicts:      openldap-overlay-nssov < 2.4.28-4
290 Conflicts:      openldap-servers < 2.4.28-4
291 Conflicts:      openvpn < 2.2.2-2
292 Conflicts:      pam-pam_mount < 2.12-3
293 Conflicts:      pam-pam_ssh < 1.97-2
294 Conflicts:      pcsc-lite < 1.8.1-2
295 Conflicts:      php-dirs < 1.2-3
296 Conflicts:      policyd < 2.0.10-3
297 Conflicts:      pound < 2.6-2
298 Conflicts:      pptp < 1.7.2-3
299 Conflicts:      proftpd-common < 2:1.3.4a-2
300 Conflicts:      pulseaudio-server < 1.1-2
301 Conflicts:      quagga < 0.99.20-3
302 Conflicts:      radvd < 1.8.5-2
303 Conflicts:      rc-scripts < 0.4.5.2-3
304 Conflicts:      red5 < 0.9.0-2
305 Conflicts:      redis-server < 2.4.2-4
306 Conflicts:      smokeping < 2.4.2-10
307 Conflicts:      smtp-gated < 1.4.17-2
308 Conflicts:      socat < 1.7.2.0-2
309 Conflicts:      speech-dispatcher < 0.7.1-2
310 Conflicts:      sphinx < 2.0.3-4
311 Conflicts:      splashutils < 1.5.4.3-3
312 Conflicts:      stunnel < 4.50-2
313 Conflicts:      tenshi < 0.12-2
314 Conflicts:      tor < 0.2.2.35-2
315 Conflicts:      ucarp < 1.5.2-3
316 Conflicts:      udisks < 1.0.4-3
317 Conflicts:      util-vserver < 0.30.216-1.pre3002.3
318 Conflicts:      vpnc < 0.5.3-2
319 Conflicts:      web2ldap < 1.1.0rc1-2
320 Conflicts:      wesnoth-server < 1:1.10-2
321 Conflicts:      wpa_supplicant < 0.7.3-10
322 Conflicts:      xl2tpd < 1.3.0-2
323
324 %description no-compat-tmpfiles
325 Force update of packages that provide tmpfiles.d configuration
326
327 %prep
328 %setup -q
329 %patch0 -p1
330 %patch1 -p1
331 %patch2 -p1
332 %patch3 -p1
333 %patch4 -p1
334 %patch5 -p1
335 cp -p %{SOURCE2} src/systemd_booted.c
336
337 %build
338 %{__aclocal} -I m4
339 %{__autoconf}
340 %{__autoheader}
341 %{__automake}
342 %configure \
343         %{__enable_disable audit} \
344         %{__enable_disable cryptsetup libcryptsetup} \
345         %{__enable_disable gtk} \
346         %{__enable_disable pam} \
347         %{__enable_disable plymouth} \
348         %{__enable_disable selinux} \
349         %{__enable_disable tcpd tcpwrap} \
350         --disable-silent-rules \
351         --disable-static \
352         --with-distro=pld \
353         --with-rootprefix= \
354         --with-rootlibdir=/%{_lib} \
355         --enable-split-usr
356
357 %{__make}
358 ./libtool --mode=link --tag=CC %{__cc} %{rpmcppflags} %{rpmcflags} -o systemd_booted %{rpmldflags} src/systemd_booted.c -L. -lsystemd-daemon
359
360 %install
361 rm -rf $RPM_BUILD_ROOT
362 install -d $RPM_BUILD_ROOT/var/lib/%{name}/coredump
363
364 %{__make} install \
365         DESTDIR=$RPM_BUILD_ROOT
366
367 ./libtool --mode=install install -m755 systemd_booted $RPM_BUILD_ROOT/bin/systemd_booted
368
369 # Main binary has been moved, but we don't want to break existing installs
370 ln -s ../lib/systemd/systemd $RPM_BUILD_ROOT/bin/systemd
371
372 # Create SysV compatibility symlinks. systemctl/systemd are smart
373 # enough to detect the way they were called
374 install -d $RPM_BUILD_ROOT/sbin
375 ln -s ../lib/systemd/systemd $RPM_BUILD_ROOT/sbin/init
376 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/halt
377 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/poweroff
378 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/reboot
379 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/runlevel
380 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/shutdown
381 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/telinit
382
383 ln -s ../modules $RPM_BUILD_ROOT%{_sysconfdir}/modules-load.d/modules.conf
384
385 # disable redundant SYSV services
386 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/allowlogin.service
387 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/console.service
388 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/cpusets.service
389 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/killall.service
390 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/netfs.service
391 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/random.service
392
393 # add static (non-NetworkManager) networking
394 install %{SOURCE3} $RPM_BUILD_ROOT%{systemdunitdir}/network.service
395
396 # install compatibility tmpfiles configs
397 install %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/compat-pld-media.conf
398 install %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/compat-pld-var-run.conf
399
400 # Install and enable storage subsystems support services (RAID, LVM, etc.)
401 install %{SOURCE10} $RPM_BUILD_ROOT%{systemdunitdir}/pld-storage-init-late.service
402 install %{SOURCE11} $RPM_BUILD_ROOT%{systemdunitdir}/pld-storage-init.service
403 install %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/pld-wait-storage.service
404 install %{SOURCE13} $RPM_BUILD_ROOT/lib/systemd/pld-storage-init
405
406 ln -s ../pld-storage-init-late.service $RPM_BUILD_ROOT%{systemdunitdir}/local-fs.target.wants/pld-storage-init-late.service
407 ln -s ../pld-storage-init.service $RPM_BUILD_ROOT%{systemdunitdir}/local-fs.target.wants/pld-storage-init.service
408
409 # Make sure these directories are properly owned:
410 #       - halt,kexec,poweroff,reboot: generic ones used by ConsoleKit-systemd,
411 #       - syslog _might_ be used by some syslog implementation (none for now),
412 #       - isn't dbus populated by dbus-systemd only (so to be moved there)?
413 install -d $RPM_BUILD_ROOT%{systemdunitdir}/{dbus,halt,kexec,poweroff,reboot,syslog}.target.wants
414
415 # Create new-style configuration files so that we can ghost-own them
416 touch $RPM_BUILD_ROOT%{_sysconfdir}/{hostname,locale.conf,machine-id,machine-info,timezone,vconsole.conf}
417
418 # Install SysV conversion tool for systemd
419 install -p %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}
420
421 install -d $RPM_BUILD_ROOT/var/log
422 :> $RPM_BUILD_ROOT/var/log/btmp
423 :> $RPM_BUILD_ROOT/var/log/wtmp
424
425 %if %{without gtk}
426 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/systemadm.1*
427 %endif
428
429 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
430 %{__rm} $RPM_BUILD_ROOT/%{_lib}/security/pam_systemd.la
431 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
432
433 %clean
434 rm -rf $RPM_BUILD_ROOT
435
436 %post
437 /bin/systemd-machine-id-setup > /dev/null 2>&1 || :
438 /bin/systemctl daemon-reexec > /dev/null 2>&1 || :
439
440 %postun
441 if [ $1 -ge 1 ]; then
442         /bin/systemctl try-restart systemd-logind.service >/dev/null 2>&1 || :
443 fi
444
445 %post   libs -p /sbin/ldconfig
446 %postun libs -p /sbin/ldconfig
447
448 %post units
449 if [ $1 -eq 1 ]; then
450         # Try to read default runlevel from the old inittab if it exists
451         runlevel=$(/bin/awk -F ':' '$3 == "initdefault" && $1 !~ "^#" { print $2 }' /etc/inittab 2> /dev/null)
452         if [ -z "$runlevel" ] ; then
453                 target="%{systemdunitdir}/graphical.target"
454         else
455                 target="%{systemdunitdir}/runlevel$runlevel.target"
456         fi
457
458         # And symlink what we found to the new-style default.target
459         ln -s "$target" %{_sysconfdir}/systemd/system/default.target >/dev/null 2>&1 || :
460
461         # Setup hostname
462         [ -f /etc/sysconfig/network ] && . /etc/sysconfig/network
463         if [ -n "$HOSTNAME" -a "$HOSTNAME" != "pldmachine" ]; then
464                 [ -f /etc/hostname ] && mv -f /etc/hostname /etc/hostname.rpmsave
465                 echo $HOSTNAME > /etc/hostname
466                 chmod 644 /etc/hostname
467         fi
468
469         # Enable the services we install by default.
470         /bin/systemctl enable \
471                 getty@.service \
472                 network.service \
473                 remote-fs.target \
474                 systemd-readahead-replay.service \
475                 systemd-readahead-collect.service >/dev/null 2>&1 || :
476 fi
477
478 %preun units
479 if [ $1 -eq 0 ] ; then
480         /bin/systemctl disable \
481                 getty@.service \
482                 network.service \
483                 remote-fs.target \
484                 systemd-readahead-replay.service \
485                 systemd-readahead-collect.service >/dev/null 2>&1 || :
486
487         %{__rm} -f %{_sysconfdir}/systemd/system/default.target >/dev/null 2>&1 || :
488 fi
489
490 %postun units
491 if [ $1 -ge 1 ]; then
492         /bin/systemctl daemon-reload > /dev/null 2>&1 || :
493 fi
494
495 %triggerpostun units -- %{name}-units < 43-7
496 # Remove design fialures
497 rm -f %{_sysconfdir}/systemd/system/network.target.wants/ifcfg@*.service >/dev/null 2>&1 || :
498 rm -f %{_sysconfdir}/systemd/system/network.target.wants/network-post.service >/dev/null 2>&1 || :
499 rm -f %{_sysconfdir}/systemd/system/multi-user.target.wants/network-post.service >/dev/null 2>&1 || :
500 /bin/systemctl reenable network.service >/dev/null 2>&1 || :
501
502 %post no-compat-tmpfiles
503 %{__sed} -i -e '/^#/!s/^/# /g' %{_sysconfdir}/tmpfiles.d/compat-pld-var-run.conf
504
505 %files
506 %defattr(644,root,root,755)
507 %doc DISTRO_PORTING README TODO
508 /etc/dbus-1/system.d/org.freedesktop.hostname1.conf
509 /etc/dbus-1/system.d/org.freedesktop.locale1.conf
510 /etc/dbus-1/system.d/org.freedesktop.login1.conf
511 /etc/dbus-1/system.d/org.freedesktop.systemd1.conf
512 /etc/dbus-1/system.d/org.freedesktop.timedate1.conf
513 %ghost %config(noreplace) %{_sysconfdir}/machine-id
514 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hostname
515 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/locale.conf
516 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/machine-info
517 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/timezone
518 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/vconsole.conf
519 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/systemd/*.conf
520 %dir %{_sysconfdir}/systemd/user
521 %dir %{_sysconfdir}/systemd/system/*.target.wants
522 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/systemd/system/*.target.wants/*.service
523 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/systemd/system/*.target.wants/*.target
524 /etc/xdg/systemd
525 %attr(755,root,root) /bin/systemd
526 %attr(755,root,root) /bin/systemd-ask-password
527 %attr(755,root,root) /bin/systemd-journalctl
528 %attr(755,root,root) /bin/systemd-loginctl
529 %attr(755,root,root) /bin/systemd-machine-id-setup
530 %attr(755,root,root) /bin/systemd-notify
531 %attr(755,root,root) /bin/systemd-tty-ask-password-agent
532 %attr(755,root,root) %{_bindir}/systemd-cat
533 %attr(755,root,root) %{_bindir}/systemd-cgtop
534 %attr(755,root,root) %{_bindir}/systemd-cgls
535 %attr(755,root,root) %{_bindir}/systemd-nspawn
536 %attr(755,root,root) %{_bindir}/systemd-stdio-bridge
537 %attr(755,root,root) %{_bindir}/systemd-sysv-convert
538 %attr(755,root,root) /lib/systemd/pld-storage-init
539 %attr(755,root,root) /lib/systemd/systemd-*
540 %dir /lib/systemd/system-generators
541 %attr(755,root,root) /lib/systemd/systemd
542 %attr(755,root,root) /lib/systemd/system-generators/systemd-*-generator
543 %dir /lib/systemd/system-shutdown
544 /lib/udev/rules.d/99-systemd.rules
545 /lib/udev/rules.d/70-uaccess.rules
546 /lib/udev/rules.d/71-seat.rules
547 /lib/udev/rules.d/73-seat-late.rules
548 %dir %{_libexecdir}/systemd
549 %{_libexecdir}/systemd/user
550 %dir %{_libexecdir}/systemd/user-generators
551 %config(noreplace,missingok) %{_libexecdir}/tmpfiles.d/*.conf
552 %{_datadir}/dbus-1/interfaces/org.freedesktop.hostname1.xml
553 %{_datadir}/dbus-1/interfaces/org.freedesktop.locale1.xml
554 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.*.xml
555 %{_datadir}/dbus-1/interfaces/org.freedesktop.timedate1.xml
556 %{_datadir}/dbus-1/services/org.freedesktop.systemd1.service
557 %{_datadir}/dbus-1/system-services/org.freedesktop.hostname1.service
558 %{_datadir}/dbus-1/system-services/org.freedesktop.locale1.service
559 %{_datadir}/dbus-1/system-services/org.freedesktop.login1.service
560 %{_datadir}/dbus-1/system-services/org.freedesktop.systemd1.service
561 %{_datadir}/dbus-1/system-services/org.freedesktop.timedate1.service
562 %{_datadir}/polkit-1/actions/org.freedesktop.hostname1.policy
563 %{_datadir}/polkit-1/actions/org.freedesktop.locale1.policy
564 %{_datadir}/polkit-1/actions/org.freedesktop.login1.policy
565 %{_datadir}/polkit-1/actions/org.freedesktop.systemd1.policy
566 %{_datadir}/polkit-1/actions/org.freedesktop.timedate1.policy
567 %dir %{_datadir}/systemd
568 %{_datadir}/systemd/kbd-model-map
569 %{_mandir}/man1/systemd.1*
570 %{_mandir}/man1/systemd-*.1*
571 %{_mandir}/man5/binfmt.d.5*
572 %{_mandir}/man5/hostname.5*
573 %{_mandir}/man5/locale.conf.5*
574 %{_mandir}/man5/machine-id.5*
575 %{_mandir}/man5/machine-info.5*
576 %{_mandir}/man5/modules-load.d.5*
577 %{_mandir}/man5/os-release.5*
578 %{_mandir}/man5/sysctl.d.5*
579 %{_mandir}/man5/systemd.*.5*
580 %{_mandir}/man5/systemd-journald.conf.5*
581 %{_mandir}/man5/systemd-logind.conf.5*
582 %{_mandir}/man5/timezone.5*
583 %{_mandir}/man5/vconsole.conf.5*
584 %{_mandir}/man7/daemon.7*
585 %{_mandir}/man7/sd-daemon.7*
586 %{_mandir}/man7/sd-login.7*
587 %{_mandir}/man7/sd-readahead.7*
588 %{_mandir}/man7/systemd.special.7*
589 %dir /var/lib/%{name}
590 %dir /var/lib/%{name}/coredump
591 %attr(640,root,root) %ghost /var/log/btmp
592 %attr(664,root,utmp) %ghost /var/log/wtmp
593
594 %if %{with pam}
595 %attr(755,root,root) /%{_lib}/security/pam_systemd.so
596 %{_mandir}/man8/pam_systemd.8*
597 %endif
598
599 %files init
600 %defattr(644,root,root,755)
601 %attr(755,root,root) /sbin/halt
602 %attr(755,root,root) /sbin/init
603 %attr(755,root,root) /sbin/poweroff
604 %attr(755,root,root) /sbin/reboot
605 %attr(755,root,root) /sbin/runlevel
606 %attr(755,root,root) /sbin/shutdown
607 %attr(755,root,root) /sbin/telinit
608 %{_mandir}/man1/init.1
609 %{_mandir}/man8/halt.8*
610 %{_mandir}/man8/poweroff.8
611 %{_mandir}/man8/reboot.8
612 %{_mandir}/man8/runlevel.8*
613 %{_mandir}/man8/shutdown.8*
614 %{_mandir}/man8/telinit.8*
615
616 %files units
617 %defattr(644,root,root,755)
618 %dir %{_sysconfdir}/binfmt.d
619 %dir %{_sysconfdir}/modules-load.d
620 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/modules-load.d/modules.conf
621 %dir %{_sysconfdir}/sysctl.d
622 %dir %{_sysconfdir}/systemd
623 %dir %{_sysconfdir}/systemd/system
624 %dir %{_sysconfdir}/tmpfiles.d
625 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/tmpfiles.d/*.conf
626 %dir %{_libexecdir}/binfmt.d
627 %dir %{_libexecdir}/modules-load.d
628 %dir %{_libexecdir}/sysctl.d
629 %{_libexecdir}/sysctl.d/coredump.conf
630 %attr(755,root,root) /bin/systemctl
631 %attr(755,root,root) /bin/systemd-tmpfiles
632 %attr(755,root,root) /bin/systemd_booted
633 %{_mandir}/man1/systemctl.1*
634 %{_mandir}/man5/tmpfiles.d.5*
635 %{_mandir}/man8/systemd-tmpfiles.8*
636 %{_npkgconfigdir}/systemd.pc
637
638 %{systemdunitdir}/*.automount
639 %{systemdunitdir}/*.mount
640 %{systemdunitdir}/*.path
641 %{systemdunitdir}/*.service
642 %{systemdunitdir}/*.socket
643 %{systemdunitdir}/*.target
644 %{systemdunitdir}/*.timer
645 %if %{with plymouth}
646 %exclude %{systemdunitdir}/plymouth*.service
647 %exclude %{systemdunitdir}/systemd-ask-password-plymouth.*
648 %endif
649 %dir %{systemdunitdir}/basic.target.wants
650 %dir %{systemdunitdir}/dbus.target.wants
651 %dir %{systemdunitdir}/final.target.wants
652 %dir %{systemdunitdir}/graphical.target.wants
653 %dir %{systemdunitdir}/halt.target.wants
654 %dir %{systemdunitdir}/kexec.target.wants
655 %dir %{systemdunitdir}/local-fs.target.wants
656 %dir %{systemdunitdir}/multi-user.target.wants
657 %dir %{systemdunitdir}/poweroff.target.wants
658 %dir %{systemdunitdir}/reboot.target.wants
659 %dir %{systemdunitdir}/runlevel[12345].target.wants
660 %dir %{systemdunitdir}/shutdown.target.wants
661 %dir %{systemdunitdir}/sockets.target.wants
662 %dir %{systemdunitdir}/sysinit.target.wants
663 %dir %{systemdunitdir}/syslog.target.wants
664 %config(noreplace,missingok) %{systemdunitdir}/basic.target.wants/*
665 %config(noreplace,missingok) %{systemdunitdir}/final.target.wants/*
666 %config(noreplace,missingok) %{systemdunitdir}/graphical.target.wants/*
667 %config(noreplace,missingok) %{systemdunitdir}/local-fs.target.wants/*
668 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/getty.target
669 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/rc-local.service
670 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/systemd-ask-password-wall.path
671 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/systemd-logind.service
672 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/systemd-user-sessions.service
673 %config(noreplace,missingok) %{systemdunitdir}/runlevel[12345].target.wants/*
674 %config(noreplace,missingok) %{systemdunitdir}/shutdown.target.wants/*
675 %config(noreplace,missingok) %{systemdunitdir}/sockets.target.wants/*
676 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/cryptsetup.target
677 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/dev-hugepages.mount
678 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/dev-mqueue.mount
679 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/proc-sys-fs-binfmt_misc.automount
680 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/sys-*.mount
681 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/systemd-*
682
683 %if %{with plymouth}
684 %files plymouth
685 %defattr(644,root,root,755)
686 %{systemdunitdir}/plymouth-halt.service
687 %{systemdunitdir}/plymouth-kexec.service
688 %{systemdunitdir}/plymouth-poweroff.service
689 %{systemdunitdir}/plymouth-quit-wait.service
690 %{systemdunitdir}/plymouth-quit.service
691 %{systemdunitdir}/plymouth-read-write.service
692 %{systemdunitdir}/plymouth-reboot.service
693 %{systemdunitdir}/plymouth-start.service
694 %{systemdunitdir}/systemd-ask-password-plymouth.path
695 %{systemdunitdir}/systemd-ask-password-plymouth.service
696 %config(noreplace,missingok) %{systemdunitdir}/halt.target.wants/plymouth-halt.service
697 %config(noreplace,missingok) %{systemdunitdir}/kexec.target.wants/plymouth-kexec.service
698 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/plymouth-quit.service
699 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/plymouth-quit-wait.service
700 %config(noreplace,missingok) %{systemdunitdir}/poweroff.target.wants/plymouth-poweroff.service
701 %config(noreplace,missingok) %{systemdunitdir}/reboot.target.wants/plymouth-reboot.service
702 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/plymouth-read-write.service
703 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/plymouth-start.service
704 %endif
705
706 %if %{with gtk}
707 %files gtk
708 %defattr(644,root,root,755)
709 %attr(755,root,root) %{_bindir}/systemadm
710 %attr(755,root,root) %{_bindir}/systemd-gnome-ask-password-agent
711 %{_mandir}/man1/systemadm.1*
712 %endif
713
714 %files analyze
715 %defattr(644,root,root,755)
716 %attr(755,root,root) %{_bindir}/systemd-analyze
717
718 %files libs
719 %defattr(644,root,root,755)
720 %attr(755,root,root) /%{_lib}/libsystemd-daemon.so.*.*.*
721 %attr(755,root,root) %ghost /%{_lib}/libsystemd-daemon.so.0
722 %attr(755,root,root) /%{_lib}/libsystemd-id128.so.*.*.*
723 %attr(755,root,root) %ghost /%{_lib}/libsystemd-id128.so.0
724 %attr(755,root,root) /%{_lib}/libsystemd-journal.so.*.*.*
725 %attr(755,root,root) %ghost /%{_lib}/libsystemd-journal.so.0
726 %attr(755,root,root) /%{_lib}/libsystemd-login.so.*.*.*
727 %attr(755,root,root) %ghost /%{_lib}/libsystemd-login.so.0
728
729 %files devel
730 %defattr(644,root,root,755)
731 %attr(755,root,root) %{_libdir}/libsystemd-daemon.so
732 %attr(755,root,root) %{_libdir}/libsystemd-id128.so
733 %attr(755,root,root) %{_libdir}/libsystemd-journal.so
734 %attr(755,root,root) %{_libdir}/libsystemd-login.so
735 %{_includedir}/%{name}
736 %{_pkgconfigdir}/libsystemd-daemon.pc
737 %{_pkgconfigdir}/libsystemd-id128.pc
738 %{_pkgconfigdir}/libsystemd-journal.pc
739 %{_pkgconfigdir}/libsystemd-login.pc
740 %{_mandir}/man3/sd_booted.3*
741 %{_mandir}/man3/sd_get_seats.3*
742 %{_mandir}/man3/sd_get_sessions.3*
743 %{_mandir}/man3/sd_get_uids.3*
744 %{_mandir}/man3/sd_is_fifo.3*
745 %{_mandir}/man3/sd_is_mq.3*
746 %{_mandir}/man3/sd_is_socket.3
747 %{_mandir}/man3/sd_is_socket_inet.3
748 %{_mandir}/man3/sd_is_socket_unix.3
749 %{_mandir}/man3/sd_listen_fds.3*
750 %{_mandir}/man3/sd_login_monitor_flush.3*
751 %{_mandir}/man3/sd_login_monitor_get_fd.3*
752 %{_mandir}/man3/sd_login_monitor_new.3*
753 %{_mandir}/man3/sd_login_monitor_unref.3*
754 %{_mandir}/man3/sd_notify.3*
755 %{_mandir}/man3/sd_notifyf.3
756 %{_mandir}/man3/sd_pid_get_owner_uid.3*
757 %{_mandir}/man3/sd_pid_get_session.3*
758 %{_mandir}/man3/sd_pid_get_unit.3*
759 %{_mandir}/man3/sd_readahead.3*
760 %{_mandir}/man3/sd_seat_can_multi_session.3*
761 %{_mandir}/man3/sd_seat_get_active.3*
762 %{_mandir}/man3/sd_seat_get_sessions.3*
763 %{_mandir}/man3/sd_session_get_class.3*
764 %{_mandir}/man3/sd_session_get_display.3*
765 %{_mandir}/man3/sd_session_get_seat.3*
766 %{_mandir}/man3/sd_session_get_service.3*
767 %{_mandir}/man3/sd_session_get_type.3*
768 %{_mandir}/man3/sd_session_get_uid.3*
769 %{_mandir}/man3/sd_session_is_active.3*
770 %{_mandir}/man3/sd_uid_get_seats.3*
771 %{_mandir}/man3/sd_uid_get_sessions.3*
772 %{_mandir}/man3/sd_uid_get_state.3*
773 %{_mandir}/man3/sd_uid_is_on_seat.3*
774
775 %files -n bash-completion-systemd
776 %defattr(644,root,root,755)
777 /etc/bash_completion.d/systemd-bash-completion.sh
778
779 %files no-compat-tmpfiles
780 %defattr(644,root,root,755)
781 # empty package
This page took 0.083523 seconds and 4 git commands to generate.