]> git.pld-linux.org Git - packages/systemd.git/blob - systemd.spec
- 42
[packages/systemd.git] / systemd.spec
1 #
2 # TODO:
3 #       - remove compat-pld-var-run.tmpfiles and maybe tmpfiles-not-fatal.patch
4 #         after enough packages provide their own tmpfiles.d configs for
5 #         /var/run directories
6 #
7 # Conditional build:
8 %bcond_without  audit           # without audit support
9 %bcond_without  cryptsetup      # without cryptsetup support
10 %bcond_without  gtk             # build gtk tools
11 %bcond_without  pam             # PAM authentication support
12 %bcond_with     plymouth        # plymouth support
13 %bcond_without  selinux         # without SELinux support
14 %bcond_without  tcpd            # libwrap (tcp_wrappers) support
15
16 Summary:        A System and Service Manager
17 Summary(pl.UTF-8):      systemd - zarządca systemu i usług dla Linuksa
18 Name:           systemd
19 Version:        42
20 Release:        0.1
21 License:        GPL v2+
22 Group:          Base
23 Source0:        http://www.freedesktop.org/software/systemd/%{name}-%{version}.tar.xz
24 # Source0-md5:  7686b44e368d2523901d3e903ed4dcea
25 Source1:        %{name}-sysv-convert
26 Source2:        %{name}_booted.c
27 Source3:        ifup@.service
28 Source4:        network-post.service
29 Source5:        network.service
30 Source6:        compat-pld-media.tmpfiles
31 Source7:        compat-pld-var-run.tmpfiles
32 Patch0:         target-pld.patch
33 Patch1:         config-pld.patch
34 Patch2:         shut-sysv-up.patch
35 Patch3:         pld-sysv-network.patch
36 Patch4:         tmpfiles-not-fatal.patch
37 URL:            http://www.freedesktop.org/wiki/Software/systemd
38 BuildRequires:  acl-devel
39 %{?with_audit:BuildRequires:    audit-libs-devel}
40 BuildRequires:  autoconf >= 2.63
41 BuildRequires:  automake >= 1:1.11
42 %{?with_cryptsetup:BuildRequires:       cryptsetup-luks-devel}
43 BuildRequires:  dbus-devel >= 1.3.2
44 BuildRequires:  docbook-style-xsl
45 %if %{with gtk}
46 BuildRequires:  glib2-devel >= 1:2.26.1
47 BuildRequires:  gtk+2-devel >= 2:2.24.0
48 BuildRequires:  libgee-devel
49 BuildRequires:  libnotify-devel >= 0.7.0
50 %endif
51 BuildRequires:  binutils >= 3:2.22.52.0.1-2
52 BuildRequires:  gperf
53 BuildRequires:  intltool >= 0.40.0
54 BuildRequires:  kmod-devel >= 5
55 BuildRequires:  libcap-devel
56 %{?with_selinux:BuildRequires:  libselinux-devel}
57 BuildRequires:  libtool >= 2:2.2
58 %{?with_tcpd:BuildRequires:     libwrap-devel}
59 BuildRequires:  libxslt-progs
60 BuildRequires:  m4
61 %{?with_pam:BuildRequires:      pam-devel}
62 %{?with_plymouth:BuildRequires: plymouth-devel}
63 BuildRequires:  pkgconfig >= 0.9.0
64 BuildRequires:  rpmbuild(macros) >= 1.627
65 BuildRequires:  udev-devel >= 1:172
66 # not required for building from release (which contains *.c for *.vala)
67 #BuildRequires: vala >= 0.10.0
68 BuildRequires:  xz-devel
69 Requires:       %{name}-libs = %{version}-%{release}
70 Requires:       %{name}-units = %{version}-%{release}
71 Requires:       SysVinit-tools
72 Requires:       agetty
73 Requires:       dbus >= 1.4.16-6
74 Requires:       filesystem >= 4.0-2
75 Requires:       kmod >= 5
76 Requires:       rc-scripts >= 0.4.5.1-7
77 Requires:       setup >= 2.8.0-2
78 Requires:       udev-core >= 1:175-5
79 Requires:       udev-libs >= 1:172
80 Suggests:       ConsoleKit
81 Suggests:       fsck >= 2.20
82 Suggests:       nss_myhostname
83 # python modules required by systemd-analyze
84 Suggests:       %{name}-no-compat-tmpfiles
85 Suggests:       python-dbus
86 Suggests:       python-modules
87 Suggests:       service(klogd)
88 Suggests:       service(syslog)
89 Provides:       udev-acl
90 # systemd takes care of that and causes problems
91 Conflicts:      binfmt-detector
92 # sytemd wants pam with pam_systemd.so in system-auth 
93 Conflicts:      pam < 1:1.1.5-5
94 Conflicts:      upstart
95 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
96
97 %define         _libexecdir     %{_prefix}/lib
98
99 %description
100 systemd is a system and service manager for Linux, compatible with
101 SysV and LSB init scripts. systemd provides aggressive parallelization
102 capabilities, uses socket and D-Bus activation for starting services,
103 offers on-demand starting of daemons, keeps track of processes using
104 Linux cgroups, supports snapshotting and restoring of the system
105 state, maintains mount and automount points and implements an
106 elaborate transactional dependency-based service control logic. It can
107 work as a drop-in replacement for sysvinit.
108
109 %description -l pl.UTF-8
110 systemd jest zarządcą systemu i usług dla Linuksa, kompatybilny ze
111 skryptami SysV i LSB. systemd udostępnia rozbudowane zdolności
112 paralelizacji, do uruchamiania usług używa socketów oraz D-Busa,
113 oferuje uruchamianie usług na życzenie, monitoruje procesy używając
114 linuksowych cgroups, wspomaga zapisywanie (snapshot) i odczytywanie
115 (restore) stanu systemu, zarządza (auto)mount pointami oraz
116 implementuje starannie opracowaną transakcjonalną, bazującą na
117 zależnościach logikę kontroli usług. Może pracować jako zastępca dla
118 sysvinit.
119
120 %package init
121 Summary:        systemd /sbin/init and LSB/SysV compatibility symlinks
122 Summary(pl.UTF-8):      /sbin/init z systemd i dowiązania dla kompatybilności z LSB/SysV
123 Group:          Base
124 Requires:       systemd
125 Provides:       readahead = 1:1.5.7-3
126 Provides:       virtual(init-daemon)
127 Obsoletes:      SysVinit
128 Obsoletes:      readahead < 1:1.5.7-3
129 Obsoletes:      virtual(init-daemon)
130
131 %description init
132 Install this package when you are ready to final switch to systemd.
133
134 %description init -l pl.UTF-8
135 Ten pakiet należy zainstalować po przygotowaniu się do ostatecznego
136 przejścia na systemd.
137
138 %package units
139 Summary:        Configuration files, directories and installation tool for systemd
140 Summary(pl.UTF-8):      Pliki konfiguracyjne, katalogi i narzędzie instalacyjne dla systemd
141 Group:          Base
142 Requires(post): coreutils
143 Requires(post): gawk
144
145 %description units
146 Basic configuration files, directories and installation tool for the
147 systemd system and service manager.
148
149 This is common config, use %{_sysconfdir}/systemd/system to override.
150
151 %description units -l pl.UTF-8
152 Podstawowe pliki konfiguracyjne, katalogi i narzędzie instalacyjne dla
153 zarządcy systemu i usług systemd.
154
155 Ten pakiet zawiera ogólną konfigurację, ustawienia można nadpisać
156 poprzez katalog %{_sysconfdir}/systemd/system.
157
158 %package gtk
159 Summary:        Graphical frontend for systemd
160 Summary(pl.UTF-8):      Graficzny interfejs do systemd
161 Group:          Base
162 Requires:       %{name} = %{version}-%{release}
163 Requires:       polkit
164
165 %description gtk
166 Graphical front-end for systemd.
167
168 %description gtk -l pl.UTF-8
169 Graficzny interfejs do systemd.
170
171 %package libs
172 Summary:        Shared systemd libraries
173 Summary(pl.UTF-8):      Biblioteki współdzielone systemd
174 Group:          Libraries
175
176 %description libs
177 Shared systemd libraries.
178
179 %description libs -l pl.UTF-8
180 Biblioteki współdzielone systemd.
181
182 %package devel
183 Summary:        Header files for systemd libraries
184 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek systemd
185 Group:          Development/Libraries
186 Requires:       %{name}-libs = %{version}-%{release}
187
188 %description devel
189 Header files for systemd libraries.
190
191 %description devel -l pl.UTF-8
192 Pliki nagłówkowe bibliotek systemd.
193
194 %package -n bash-completion-systemd
195 Summary:        bash-completion for systemd
196 Summary(pl.UTF-8):      Bashowe dopełnianie składni dla systemd
197 Group:          Applications/Shells
198 Requires:       %{name}
199 Requires:       bash-completion
200
201 %description -n bash-completion-systemd
202 bash-completion for systemd.
203
204 %description -n bash-completion-systemd -l pl.UTF-8
205 Bashowe dopełnianie składni dla systemd
206
207 %package no-compat-tmpfiles
208 Summary:        Force update of packages that provide tmpfiles.d configuration
209 Group:          Base
210 Requires(post): sed > 4.0
211 Conflicts:      ConsoleKit-dirs < 0.4.5-7
212 Conflicts:      NetworkManager < 2:0.9.2.0-3
213 Conflicts:      Zope < 2.11.8-2
214 Conflicts:      amavisd-new < 1:2.7.0-1
215 Conflicts:      apache-base < 2.2.21-4
216 Conflicts:      apache-mod_bw < 0.92-3
217 Conflicts:      apache-mod_fastcgi < 2.4.6-6
218 Conflicts:      apache1-base < 1.3.42-5
219 Conflicts:      apache1-mod_fastcgi < 2.4.6-2
220 Conflicts:      asterisk < 10.0.1-2
221 Conflicts:      autossh-init < 1.4b-3
222 Conflicts:      balance < 3.54-2
223 Conflicts:      bind < 7:9.8.1.P1-4
224 Conflicts:      bopm < 3.1.3-4
225 Conflicts:      callweaver < 1.2.1-9
226 Conflicts:      cassandra-bin < 0.8.9-2
227 Conflicts:      clamav < 0.97.3-3
228 Conflicts:      cups < 1:1.5.0-10
229 Conflicts:      dbus < 1.4.16-4
230 Conflicts:      dovecot < 1:2.0.16-3
231 Conflicts:      dspam < 3.9.0-6
232 Conflicts:      fail2ban < 0.8.4-4
233 Conflicts:      filesystem < 4.0-3
234 Conflicts:      gammu-smsd < 1:1.31.0-3
235 Conflicts:      gdm < 2:3.2.1.1-9
236 Conflicts:      greylistd < 0.8.8-2
237 Conflicts:      inn < 2.4.6-7
238 Conflicts:      ipsec-tools < 0.8.0-3
239 Conflicts:      jabber-common < 0-9
240 Conflicts:      laptop-mode-tools < 1.58-2
241 Conflicts:      libgpod < 0.8.0-6
242 Conflicts:      libvirt-utils < 0.9.9-4
243 Conflicts:      lighttpd < 1.4.30-5
244 Conflicts:      lirc < 0.9.0-20
245 Conflicts:      mailman < 5:2.1.14-4
246 Conflicts:      memcached < 1.4.11-2
247 Conflicts:      mpd < 0.16.5-4
248 Conflicts:      mrtg < 2.17.0-3
249 Conflicts:      munin-common < 1.4.5-5
250 Conflicts:      nagios-nrpe < 2.13-2
251 Conflicts:      ndisc6-rdnssd < 1.0.1-3
252 Conflicts:      nscd < 6:2.14.1-5
253 Conflicts:      nss_ldapd-nslcd < 0.8.4-2
254 Conflicts:      openct < 0.6.20-3
255 Conflicts:      openl2tp < 1.8-3
256 Conflicts:      openldap-overlay-nssov < 2.4.28-4
257 Conflicts:      openldap-servers < 2.4.28-4
258 Conflicts:      openvpn < 2.2.2-2
259 Conflicts:      pam-pam_mount < 2.12-3
260 Conflicts:      pam-pam_ssh < 1.97-2
261 Conflicts:      pcsc-lite < 1.8.1-2
262 Conflicts:      php-dirs < 1.2-3
263 Conflicts:      policyd < 2.0.10-3
264 Conflicts:      pound < 2.6-2
265 Conflicts:      pptp < 1.7.2-3
266 Conflicts:      proftpd-common < 2:1.3.4a-2
267 Conflicts:      pulseaudio-server < 1.1-2
268 Conflicts:      quagga < 0.99.20-3
269 Conflicts:      radvd < 1.8.5-2
270 Conflicts:      rc-scripts < 0.4.5.2-3
271 Conflicts:      red5 < 0.9.0-2
272 Conflicts:      redis-server < 2.4.2-4
273 Conflicts:      smokeping < 2.4.2-10
274 Conflicts:      smtp-gated < 1.4.17-2
275 Conflicts:      socat < 1.7.2.0-2
276 Conflicts:      speech-dispatcher < 0.7.1-2
277 Conflicts:      sphinx < 2.0.3-4
278 Conflicts:      splashutils < 1.5.4.3-3
279 Conflicts:      stunnel < 4.50-2
280 Conflicts:      sudo < 1:1.7.8p2-2
281 Conflicts:      tenshi < 0.12-2
282 Conflicts:      tor < 0.2.2.35-2
283 Conflicts:      ucarp < 1.5.2-3
284 Conflicts:      udisks < 1.0.4-3
285 Conflicts:      util-vserver < 0.30.216-1.pre3002.3
286 Conflicts:      vpnc < 0.5.3-2
287 Conflicts:      web2ldap < 1.1.0rc1-2
288 Conflicts:      wesnoth-server < 1:1.10-2
289 Conflicts:      wpa_supplicant < 0.7.3-10
290 Conflicts:      xl2tpd < 1.3.0-2
291
292 %description no-compat-tmpfiles
293 Force update of packages that provide tmpfiles.d configuration
294
295 %prep
296 %setup -q
297 %patch0 -p1
298 %patch1 -p1
299 #%patch2 -p1
300 %patch3 -p1
301 %patch4 -p1
302 cp -p %{SOURCE2} src/systemd_booted.c
303
304 %build
305 %{__aclocal} -I m4
306 %{__autoconf}
307 %{__autoheader}
308 %{__automake}
309 %configure \
310         %{__enable_disable audit} \
311         %{__enable_disable cryptsetup libcryptsetup} \
312         %{__enable_disable gtk} \
313         %{__enable_disable pam} \
314         %{__enable_disable plymouth} \
315         %{__enable_disable selinux} \
316         %{__enable_disable tcpd tcpwrap} \
317         --disable-silent-rules \
318         --disable-static \
319         --with-distro=pld \
320         --with-rootprefix= \
321         --with-rootlibdir=/%{_lib} \
322         --enable-split-usr
323
324 %{__make}
325 ./libtool --mode=link --tag=CC %{__cc} %{rpmcppflags} %{rpmcflags} -o systemd_booted %{rpmldflags} src/systemd_booted.c -L. -lsystemd-daemon
326
327 %install
328 rm -rf $RPM_BUILD_ROOT
329
330 %{__make} install \
331         DESTDIR=$RPM_BUILD_ROOT
332
333 ./libtool --mode=install install -m755 systemd_booted $RPM_BUILD_ROOT/bin/systemd_booted
334
335 # Main binary has been moved, but we don't want to break existing installs
336 ln -s ../lib/systemd/systemd $RPM_BUILD_ROOT/bin/systemd
337
338 # Create SysV compatibility symlinks. systemctl/systemd are smart
339 # enough to detect the way they were called
340 install -d $RPM_BUILD_ROOT/sbin
341 ln -s ../lib/systemd/systemd $RPM_BUILD_ROOT/sbin/init
342 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/halt
343 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/poweroff
344 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/reboot
345 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/runlevel
346 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/shutdown
347 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/telinit
348
349 ln -s ../modules $RPM_BUILD_ROOT%{_sysconfdir}/modules-load.d/modules.conf
350 # disable random and console SYSV service
351 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/random.service
352 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/console.service
353
354 # add static (non-NetworkManager) networking
355 install %{SOURCE3} $RPM_BUILD_ROOT%{systemdunitdir}/ifup@.service
356 install %{SOURCE4} $RPM_BUILD_ROOT%{systemdunitdir}/network-post.service
357 install %{SOURCE5} $RPM_BUILD_ROOT%{systemdunitdir}/network.service
358
359 # install compatibility tmpfiles configs
360 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/compat-pld-media.conf
361 install %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/compat-pld-var-run.conf
362
363 # All wants links are created at %post to make sure they are not owned
364 # and hence overriden by rpm if the user deletes them (missingok?)
365 %{__rm} -r $RPM_BUILD_ROOT%{_sysconfdir}/systemd/system/*.target.wants
366
367 # it is in rc-scripts pkg
368 %{__rm} $RPM_BUILD_ROOT%{systemdunitdir}/rc-local.service
369
370 # Make sure these directories are properly owned:
371 #       - halt,kexec,poweroff,reboot: generic ones used by ConsoleKit-systemd,
372 #       - syslog _might_ be used by some syslog implementation (none for now),
373 #       - isn't dbus populated by dbus-systemd only (so to be moved there)?
374 install -d $RPM_BUILD_ROOT%{systemdunitdir}/{dbus,halt,kexec,poweroff,reboot,syslog}.target.wants
375
376 # Create new-style configuration files so that we can ghost-own them
377 touch $RPM_BUILD_ROOT%{_sysconfdir}/{hostname,locale.conf,machine-id,machine-info,os-release,timezone,vconsole.conf}
378
379 # Install SysV conversion tool for systemd
380 install -p %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}
381
382 install -d $RPM_BUILD_ROOT/var/log
383 :> $RPM_BUILD_ROOT/var/log/btmp
384 :> $RPM_BUILD_ROOT/var/log/wtmp
385
386 %if %{without gtk}
387 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/systemadm.1*
388 %endif
389
390 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
391 %{__rm} $RPM_BUILD_ROOT/%{_lib}/security/pam_systemd.la
392 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
393
394 %clean
395 rm -rf $RPM_BUILD_ROOT
396
397 %post
398 /bin/systemd-machine-id-setup > /dev/null 2>&1 || :
399 /bin/systemctl daemon-reexec > /dev/null 2>&1 || :
400
401 %postun
402 if [ $1 -ge 1 ]; then
403         /bin/systemctl try-restart systemd-logind.service >/dev/null 2>&1 || :
404 fi
405
406 %post   libs -p /sbin/ldconfig
407 %postun libs -p /sbin/ldconfig
408
409 %post units
410 if [ $1 -eq 1 ]; then
411         # Try to read default runlevel from the old inittab if it exists
412         runlevel=$(/bin/awk -F ':' '$3 == "initdefault" && $1 !~ "^#" { print $2 }' /etc/inittab 2> /dev/null)
413         if [ -z "$runlevel" ] ; then
414                 target="%{systemdunitdir}/graphical.target"
415         else
416                 target="%{systemdunitdir}/runlevel$runlevel.target"
417         fi
418
419         # And symlink what we found to the new-style default.target
420         ln -s "$target" %{_sysconfdir}/systemd/system/default.target >/dev/null 2>&1 || :
421
422         # Setup hostname
423         [ -f /etc/sysconfig/network ] && . /etc/sysconfig/network
424         if [ -n "$HOSTNAME" -a "$HOSTNAME" != "pldmachine" ]; then
425                 [ -f /etc/hostname ] && mv -f /etc/hostname /etc/hostname.rpmsave
426                 echo $HOSTNAME > /etc/hostname
427                 chmod 644 /etc/hostname
428         fi
429 fi
430 # Enable the services we install by default.
431 /bin/systemctl enable \
432         getty@.service \
433         network.service \
434         network-post.service \
435         remote-fs.target \
436         systemd-readahead-replay.service \
437         systemd-readahead-collect.service >/dev/null 2>&1 || :
438
439 # Find and enable all installed interfaces
440 mkdir -p %{_sysconfdir}/systemd/system/network.target.wants >/dev/null 2>&1 || :
441 for f in /etc/sysconfig/interfaces/ifcfg-* ; do
442         ff=$(basename $f)
443         ff=${ff##ifcfg-}
444         case "$ff" in
445         *.rpmorig|*.rpmnew|*.rpmsave|*~|*.orig)
446                 continue
447                 ;;
448         *)
449                 DEVICE="" ; ONBOOT="" ; USERS=""
450                 . $f 2>/dev/null
451                 [ ${USERS:-no} != no ] && continue
452                 if [ "$DEVICE" = "$ff" -a ${ONBOOT:-no} = "yes" ]; then
453                         ln -s %{systemdunitdir}/ifup@.service \
454                                 %{_sysconfdir}/systemd/system/network.target.wants/ifcfg@$ff.service >/dev/null 2>&1 || :
455                 fi
456                 ;;
457         esac
458 done
459
460 %preun units
461 if [ $1 -eq 0 ] ; then
462         /bin/systemctl disable \
463                 getty@.service \
464                 network.service \
465                 network-post.service \
466                 remote-fs.target \
467                 systemd-readahead-replay.service \
468                 systemd-readahead-collect.service >/dev/null 2>&1 || :
469
470         %{__rm} -f %{_sysconfdir}/systemd/system/default.target >/dev/null 2>&1 || :
471         %{__rm} -f %{_sysconfdir}/systemd/system/network.target.wants/ifcfg@*.service >/dev/null 2>&1 || :
472 fi
473
474 %postun units
475 if [ $1 -ge 1 ]; then
476         /bin/systemctl daemon-reload > /dev/null 2>&1 || :
477 fi
478
479 %post no-compat-tmpfiles
480 %{__sed} -i -e 's/^/# /g' %{_sysconfdir}/tmpfiles.d/compat-pld-var-run.conf
481
482 %files
483 %defattr(644,root,root,755)
484 %doc DISTRO_PORTING README TODO
485 /etc/dbus-1/system.d/org.freedesktop.hostname1.conf
486 /etc/dbus-1/system.d/org.freedesktop.locale1.conf
487 /etc/dbus-1/system.d/org.freedesktop.login1.conf
488 /etc/dbus-1/system.d/org.freedesktop.systemd1.conf
489 /etc/dbus-1/system.d/org.freedesktop.timedate1.conf
490 %ghost %config(noreplace) %{_sysconfdir}/machine-id
491 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hostname
492 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/locale.conf
493 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/machine-info
494 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/os-release
495 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/timezone
496 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/vconsole.conf
497 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/systemd/*.conf
498 %dir %{_sysconfdir}/systemd/user
499 /etc/xdg/systemd
500 %attr(755,root,root) /bin/systemd
501 %attr(755,root,root) /bin/systemd-ask-password
502 %attr(755,root,root) /bin/systemd-journalctl
503 %attr(755,root,root) /bin/systemd-loginctl
504 %attr(755,root,root) /bin/systemd-machine-id-setup
505 %attr(755,root,root) /bin/systemd-notify
506 %attr(755,root,root) /bin/systemd-tty-ask-password-agent
507 %attr(755,root,root) %{_bindir}/systemd-analyze
508 %attr(755,root,root) %{_bindir}/systemd-cat
509 %attr(755,root,root) %{_bindir}/systemd-cgtop
510 %attr(755,root,root) %{_bindir}/systemd-cgls
511 %attr(755,root,root) %{_bindir}/systemd-nspawn
512 %attr(755,root,root) %{_bindir}/systemd-stdio-bridge
513 %attr(755,root,root) %{_bindir}/systemd-sysv-convert
514 %attr(755,root,root) /lib/systemd/systemd-*
515 %dir /lib/systemd/system-generators
516 %attr(755,root,root) /lib/systemd/systemd
517 %attr(755,root,root) /lib/systemd/system-generators/systemd-*-generator
518 %dir /lib/systemd/system-shutdown
519 /lib/udev/rules.d/99-systemd.rules
520 /lib/udev/rules.d/70-uaccess.rules
521 /lib/udev/rules.d/71-seat.rules
522 /lib/udev/rules.d/73-seat-late.rules
523 %dir %{_libexecdir}/systemd
524 %{_libexecdir}/systemd/user
525 %dir %{_libexecdir}/systemd/user-generators
526 %config(noreplace,missingok) %{_libexecdir}/tmpfiles.d/*.conf
527 %{_datadir}/dbus-1/interfaces/org.freedesktop.hostname1.xml
528 %{_datadir}/dbus-1/interfaces/org.freedesktop.locale1.xml
529 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.*.xml
530 %{_datadir}/dbus-1/interfaces/org.freedesktop.timedate1.xml
531 %{_datadir}/dbus-1/services/org.freedesktop.systemd1.service
532 %{_datadir}/dbus-1/system-services/org.freedesktop.hostname1.service
533 %{_datadir}/dbus-1/system-services/org.freedesktop.locale1.service
534 %{_datadir}/dbus-1/system-services/org.freedesktop.login1.service
535 %{_datadir}/dbus-1/system-services/org.freedesktop.systemd1.service
536 %{_datadir}/dbus-1/system-services/org.freedesktop.timedate1.service
537 %{_datadir}/polkit-1/actions/org.freedesktop.hostname1.policy
538 %{_datadir}/polkit-1/actions/org.freedesktop.locale1.policy
539 %{_datadir}/polkit-1/actions/org.freedesktop.login1.policy
540 %{_datadir}/polkit-1/actions/org.freedesktop.systemd1.policy
541 %{_datadir}/polkit-1/actions/org.freedesktop.timedate1.policy
542 %dir %{_datadir}/systemd
543 %{_datadir}/systemd/kbd-model-map
544 %{_mandir}/man1/systemd.1*
545 %{_mandir}/man1/systemd-*.1*
546 %{_mandir}/man3/sd_booted.3*
547 %{_mandir}/man3/sd_is_fifo.3*
548 %{_mandir}/man3/sd_is_socket.3
549 %{_mandir}/man3/sd_is_socket_inet.3
550 %{_mandir}/man3/sd_is_socket_unix.3
551 %{_mandir}/man3/sd_listen_fds.3*
552 %{_mandir}/man3/sd_notify.3*
553 %{_mandir}/man3/sd_notifyf.3
554 %{_mandir}/man3/sd_readahead.3*
555 %{_mandir}/man5/binfmt.d.5*
556 %{_mandir}/man5/hostname.5*
557 %{_mandir}/man5/locale.conf.5*
558 %{_mandir}/man5/machine-id.5*
559 %{_mandir}/man5/machine-info.5*
560 %{_mandir}/man5/modules-load.d.5*
561 %{_mandir}/man5/os-release.5*
562 %{_mandir}/man5/sysctl.d.5*
563 %{_mandir}/man5/systemd.*.5*
564 %{_mandir}/man5/systemd-logind.conf.5*
565 %{_mandir}/man5/timezone.5*
566 %{_mandir}/man5/vconsole.conf.5*
567 %{_mandir}/man7/daemon.7*
568 %{_mandir}/man7/sd-daemon.7*
569 %{_mandir}/man7/sd-login.7*
570 %{_mandir}/man7/sd-readahead.7*
571 %{_mandir}/man7/systemd.special.7*
572 %attr(640,root,root) %ghost /var/log/btmp
573 %attr(664,root,utmp) %ghost /var/log/wtmp
574
575 %if %{with pam}
576 %attr(755,root,root) /%{_lib}/security/pam_systemd.so
577 %{_mandir}/man8/pam_systemd.8*
578 %endif
579
580 %files init
581 %defattr(644,root,root,755)
582 %attr(755,root,root) /sbin/halt
583 %attr(755,root,root) /sbin/init
584 %attr(755,root,root) /sbin/poweroff
585 %attr(755,root,root) /sbin/reboot
586 %attr(755,root,root) /sbin/runlevel
587 %attr(755,root,root) /sbin/shutdown
588 %attr(755,root,root) /sbin/telinit
589 %{_mandir}/man1/init.1
590 %{_mandir}/man8/halt.8*
591 %{_mandir}/man8/poweroff.8
592 %{_mandir}/man8/reboot.8
593 %{_mandir}/man8/runlevel.8*
594 %{_mandir}/man8/shutdown.8*
595 %{_mandir}/man8/telinit.8*
596
597 %files units
598 %defattr(644,root,root,755)
599 %dir %{_sysconfdir}/binfmt.d
600 %dir %{_sysconfdir}/modules-load.d
601 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/modules-load.d/modules.conf
602 %dir %{_sysconfdir}/sysctl.d
603 %dir %{_sysconfdir}/systemd
604 %dir %{_sysconfdir}/systemd/system
605 %dir %{_sysconfdir}/tmpfiles.d
606 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/tmpfiles.d/*.conf
607 %dir %{_libexecdir}/binfmt.d
608 %dir %{_libexecdir}/modules-load.d
609 %dir %{_libexecdir}/sysctl.d
610 %{_libexecdir}/sysctl.d/coredump.conf
611 %attr(755,root,root) /bin/systemctl
612 %attr(755,root,root) /bin/systemd-tmpfiles
613 %attr(755,root,root) /bin/systemd_booted
614 %{_mandir}/man1/systemctl.1*
615 %{_mandir}/man5/tmpfiles.d.5*
616 %{_mandir}/man8/systemd-tmpfiles.8*
617 %{_npkgconfigdir}/systemd.pc
618
619 %{systemdunitdir}/*.automount
620 %{systemdunitdir}/*.mount
621 %{systemdunitdir}/*.path
622 %{systemdunitdir}/*.service
623 %{systemdunitdir}/*.socket
624 %{systemdunitdir}/*.target
625 %{systemdunitdir}/*.timer
626 %dir %{systemdunitdir}/*.wants
627 %config(noreplace,missingok) %{systemdunitdir}/*.wants/*
628
629 %if %{with gtk}
630 %files gtk
631 %defattr(644,root,root,755)
632 %attr(755,root,root) %{_bindir}/systemadm
633 %attr(755,root,root) %{_bindir}/systemd-gnome-ask-password-agent
634 %{_mandir}/man1/systemadm.1*
635 %endif
636
637 %files libs
638 %defattr(644,root,root,755)
639 %attr(755,root,root) /%{_lib}/libsystemd-daemon.so.*.*.*
640 %attr(755,root,root) %ghost /%{_lib}/libsystemd-daemon.so.0
641 %attr(755,root,root) /%{_lib}/libsystemd-id128.so.*.*.*
642 %attr(755,root,root) %ghost /%{_lib}/libsystemd-id128.so.0
643 %attr(755,root,root) /%{_lib}/libsystemd-journal.so.*.*.*
644 %attr(755,root,root) %ghost /%{_lib}/libsystemd-journal.so.0
645 %attr(755,root,root) /%{_lib}/libsystemd-login.so.*.*.*
646 %attr(755,root,root) %ghost /%{_lib}/libsystemd-login.so.0
647
648 %files devel
649 %defattr(644,root,root,755)
650 %attr(755,root,root) %{_libdir}/libsystemd-daemon.so
651 %attr(755,root,root) %{_libdir}/libsystemd-id128.so
652 %attr(755,root,root) %{_libdir}/libsystemd-journal.so
653 %attr(755,root,root) %{_libdir}/libsystemd-login.so
654 %{_includedir}/%{name}
655 %{_pkgconfigdir}/libsystemd-daemon.pc
656 %{_pkgconfigdir}/libsystemd-id128.pc
657 %{_pkgconfigdir}/libsystemd-journal.pc
658 %{_pkgconfigdir}/libsystemd-login.pc
659 %{_mandir}/man3/sd_get_seats.3*
660 %{_mandir}/man3/sd_get_sessions.3*
661 %{_mandir}/man3/sd_get_uids.3*
662 %{_mandir}/man3/sd_is_mq.3*
663 %{_mandir}/man3/sd_login_monitor_flush.3*
664 %{_mandir}/man3/sd_login_monitor_get_fd.3*
665 %{_mandir}/man3/sd_login_monitor_new.3*
666 %{_mandir}/man3/sd_login_monitor_unref.3*
667 %{_mandir}/man3/sd_pid_get_owner_uid.3*
668 %{_mandir}/man3/sd_pid_get_session.3*
669 %{_mandir}/man3/sd_pid_get_unit.3*
670 %{_mandir}/man3/sd_seat_can_multi_session.3*
671 %{_mandir}/man3/sd_seat_get_active.3*
672 %{_mandir}/man3/sd_seat_get_sessions.3*
673 %{_mandir}/man3/sd_session_get_seat.3*
674 %{_mandir}/man3/sd_session_get_uid.3*
675 %{_mandir}/man3/sd_session_is_active.3*
676 %{_mandir}/man3/sd_uid_get_seats.3*
677 %{_mandir}/man3/sd_uid_get_sessions.3*
678 %{_mandir}/man3/sd_uid_get_state.3*
679 %{_mandir}/man3/sd_uid_is_on_seat.3*
680
681 %files -n bash-completion-systemd
682 %defattr(644,root,root,755)
683 /etc/bash_completion.d/systemd-bash-completion.sh
684
685 %files no-compat-tmpfiles
686 %defattr(644,root,root,755)
687 # empty package
This page took 0.076462 seconds and 4 git commands to generate.