]> git.pld-linux.org Git - packages/systemd.git/blob - systemd.spec
- rel 13
[packages/systemd.git] / systemd.spec
1 # TODO:
2 #       - remove compat-pld-var-run.tmpfiles and maybe tmpfiles-not-fatal.patch
3 #         after enough packages provide their own tmpfiles.d configs for
4 #         /var/run directories
5 # - pldize vconsole setup:
6 #   - http://cgit.freedesktop.org/systemd/systemd/tree/src/vconsole/vconsole-setup.c
7 # - for systemd-45+
8 #   - restore var-{run,lock}: http://cgit.freedesktop.org/systemd/systemd/commit/?id=55d029addf7d97b15faacea597a4ff65542aaf0e
9 #   - WARNING: http://cgit.freedesktop.org/systemd/systemd/commit/?id=623ac9d2fce3170125ead9be20f56bfe68ea125e
10 #
11 # Conditional build:
12 %bcond_without  audit           # without audit support
13 %bcond_without  cryptsetup      # without cryptsetup support
14 %bcond_without  pam             # PAM authentication support
15 %bcond_without  plymouth        # do not install plymouth units
16 %bcond_without  selinux         # without SELinux support
17 %bcond_without  tcpd            # libwrap (tcp_wrappers) support
18
19 Summary:        A System and Service Manager
20 Summary(pl.UTF-8):      systemd - zarządca systemu i usług dla Linuksa
21 Name:           systemd
22 Version:        44
23 Release:        13
24 License:        GPL v2+
25 Group:          Base
26 Source0:        http://www.freedesktop.org/software/systemd/%{name}-%{version}.tar.xz
27 # Source0-md5:  11f44ff74c87850064e4351518bcff17
28 Source1:        %{name}-sysv-convert
29 Source2:        %{name}_booted.c
30 Source3:        network.service
31 Source4:        compat-pld-media.tmpfiles
32 Source5:        compat-pld-var-run.tmpfiles
33 Source10:       pld-storage-init-late.service
34 Source11:       pld-storage-init.service
35 Source12:       pld-wait-storage.service
36 Source13:       pld-storage-init.sh
37 Source14:       pld-clean-tmp.service
38 Source15:       pld-clean-tmp.sh
39 Patch0:         target-pld.patch
40 Patch1:         config-pld.patch
41 Patch2:         shut-sysv-up.patch
42 Patch3:         pld-sysv-network.patch
43 Patch4:         tmpfiles-not-fatal.patch
44 Patch5:         CVE-2012-1174.patch
45 Patch6:         ReleaseSession.patch
46 Patch7:         control-subcgroup.patch
47 Patch8:         kmsg-to-syslog.patch
48 URL:            http://www.freedesktop.org/wiki/Software/systemd
49 BuildRequires:  acl-devel
50 %{?with_audit:BuildRequires:    audit-libs-devel}
51 BuildRequires:  autoconf >= 2.63
52 BuildRequires:  automake >= 1:1.11
53 BuildRequires:  binutils >= 3:2.22.52.0.1-2
54 %{?with_cryptsetup:BuildRequires:       cryptsetup-luks-devel}
55 BuildRequires:  dbus-devel >= 1.3.2
56 BuildRequires:  docbook-style-xsl
57 BuildRequires:  gperf
58 BuildRequires:  intltool >= 0.40.0
59 BuildRequires:  kmod-devel >= 5
60 BuildRequires:  libcap-devel
61 %{?with_selinux:BuildRequires:  libselinux-devel >= 2.1.0}
62 BuildRequires:  libtool >= 2:2.2
63 %{?with_tcpd:BuildRequires:     libwrap-devel}
64 BuildRequires:  libxslt-progs
65 BuildRequires:  m4
66 %{?with_pam:BuildRequires:      pam-devel}
67 BuildRequires:  pkgconfig >= 0.9.0
68 BuildRequires:  rpmbuild(macros) >= 1.627
69 BuildRequires:  udev-devel >= 1:172
70 BuildRequires:  xz-devel
71 Requires:       %{name}-libs = %{version}-%{release}
72 Requires:       %{name}-units = %{version}-%{release}
73 Requires:       /etc/os-release
74 Requires:       SysVinit-tools
75 Requires:       agetty
76 Requires:       dbus >= 1.4.16-6
77 Requires:       filesystem >= 4.0-2
78 Requires:       libutempter
79 Requires:       rc-scripts >= 0.4.5.3-7
80 Requires:       setup >= 2.8.0-2
81 Requires:       udev-core >= 1:175-5
82 Requires:       udev-libs >= 1:172
83 Requires:       virtual(module-tools)
84 Suggests:       %{name}-no-compat-tmpfiles
85 Suggests:       ConsoleKit
86 Suggests:       fsck >= 2.20
87 Suggests:       kmod >= 5
88 Suggests:       nss_myhostname
89 Suggests:       service(klogd)
90 Suggests:       service(syslog)
91 Provides:       udev-acl
92 # systemd takes care of that and causes problems
93 Conflicts:      binfmt-detector
94 # sytemd wants pam with pam_systemd.so in system-auth...
95 Conflicts:      pam < 1:1.1.5-5
96 # ...and sudo hates it
97 Conflicts:      sudo < 1:1.7.8p2-4
98 # for prefdm script
99 Conflicts:      xinitrc-ng < 1.0
100 # systemd scripts use options not present in older versions
101 Conflicts:      kpartx < 0.4.9-7
102 Conflicts:      multipath-tools < 0.4.9-7
103 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
104
105 %define         _libexecdir     %{_prefix}/lib
106
107 %description
108 systemd is a system and service manager for Linux, compatible with
109 SysV and LSB init scripts. systemd provides aggressive parallelization
110 capabilities, uses socket and D-Bus activation for starting services,
111 offers on-demand starting of daemons, keeps track of processes using
112 Linux cgroups, supports snapshotting and restoring of the system
113 state, maintains mount and automount points and implements an
114 elaborate transactional dependency-based service control logic. It can
115 work as a drop-in replacement for sysvinit.
116
117 %description -l pl.UTF-8
118 systemd jest zarządcą systemu i usług dla Linuksa, kompatybilny ze
119 skryptami SysV i LSB. systemd udostępnia rozbudowane zdolności
120 paralelizacji, do uruchamiania usług używa socketów oraz D-Busa,
121 oferuje uruchamianie usług na życzenie, monitoruje procesy używając
122 linuksowych cgroups, wspomaga zapisywanie (snapshot) i odczytywanie
123 (restore) stanu systemu, zarządza (auto)mount pointami oraz
124 implementuje starannie opracowaną transakcjonalną, bazującą na
125 zależnościach logikę kontroli usług. Może pracować jako zastępca dla
126 sysvinit.
127
128 %package init
129 Summary:        systemd /sbin/init and LSB/SysV compatibility symlinks
130 Summary(pl.UTF-8):      /sbin/init z systemd i dowiązania dla kompatybilności z LSB/SysV
131 Group:          Base
132 Requires:       systemd
133 Provides:       readahead = 1:1.5.7-3
134 Provides:       virtual(init-daemon)
135 Obsoletes:      SysVinit
136 Obsoletes:      readahead < 1:1.5.7-3
137 Obsoletes:      virtual(init-daemon)
138 Conflicts:      upstart
139
140 %description init
141 Install this package when you are ready to final switch to systemd.
142
143 %description init -l pl.UTF-8
144 Ten pakiet należy zainstalować po przygotowaniu się do ostatecznego
145 przejścia na systemd.
146
147 %package units
148 Summary:        Configuration files, directories and installation tool for systemd
149 Summary(pl.UTF-8):      Pliki konfiguracyjne, katalogi i narzędzie instalacyjne dla systemd
150 Group:          Base
151 Requires(post): coreutils
152 Requires(post): /bin/awk
153
154 %description units
155 Basic configuration files, directories and installation tool for the
156 systemd system and service manager.
157
158 This is common config, use %{_sysconfdir}/systemd/system to override.
159
160 %description units -l pl.UTF-8
161 Podstawowe pliki konfiguracyjne, katalogi i narzędzie instalacyjne dla
162 zarządcy systemu i usług systemd.
163
164 Ten pakiet zawiera ogólną konfigurację, ustawienia można nadpisać
165 poprzez katalog %{_sysconfdir}/systemd/system.
166
167 %package plymouth
168 Summary:        Plymouth support units for systemd
169 Summary(pl.UTF-8):      Jednostki wspierające Plymouth dla systemd
170 Group:          Base
171 Requires:       %{name}-units = %{version}-%{release}
172 Requires:       plymouth
173
174 %description plymouth
175 Plymouth (graphical boot) support units for systemd.
176
177 %description plymouth -l pl.UTF-8
178 Jednostki wspierające Plymouth (graficzny start systemu) dla systemd.
179
180 %package analyze
181 Summary:        Tool for processing systemd profiling information
182 Group:          Base
183 Requires:       %{name} = %{version}-%{release}
184 Requires:       python-dbus
185 Requires:       python-modules
186 Requires:       python-pycairo
187 Conflicts:      %{name} < 44-3
188
189 %description analyze
190 'systemd-analyze blame' lists which systemd unit needed how much time
191 to finish initialization at boot. 'systemd-analyze plot' renders an
192 SVG visualizing the parallel start of units at boot.
193
194 %package libs
195 Summary:        Shared systemd libraries
196 Summary(pl.UTF-8):      Biblioteki współdzielone systemd
197 Group:          Libraries
198
199 %description libs
200 Shared systemd libraries.
201
202 %description libs -l pl.UTF-8
203 Biblioteki współdzielone systemd.
204
205 %package devel
206 Summary:        Header files for systemd libraries
207 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek systemd
208 Group:          Development/Libraries
209 Requires:       %{name}-libs = %{version}-%{release}
210
211 %description devel
212 Header files for systemd libraries.
213
214 %description devel -l pl.UTF-8
215 Pliki nagłówkowe bibliotek systemd.
216
217 %package -n bash-completion-systemd
218 Summary:        bash-completion for systemd
219 Summary(pl.UTF-8):      Bashowe dopełnianie składni dla systemd
220 Group:          Applications/Shells
221 Requires:       %{name} = %{version}
222 Requires:       bash-completion
223
224 %description -n bash-completion-systemd
225 bash-completion for systemd.
226
227 %description -n bash-completion-systemd -l pl.UTF-8
228 Bashowe dopełnianie składni dla systemd
229
230 %package no-compat-tmpfiles
231 Summary:        Force update of packages that provide tmpfiles.d configuration
232 Group:          Base
233 Requires:       %{name} = %{version}-%{release}
234 Requires(post): sed > 4.0
235 Conflicts:      ConsoleKit-dirs < 0.4.5-7
236 Conflicts:      NetworkManager < 2:0.9.2.0-3
237 Conflicts:      Zope < 2.11.8-2
238 Conflicts:      amavisd-new < 1:2.7.0-1
239 Conflicts:      apache-base < 2.2.21-4
240 Conflicts:      apache-mod_bw < 0.92-3
241 Conflicts:      apache-mod_fastcgi < 2.4.6-6
242 Conflicts:      apache1-base < 1.3.42-5
243 Conflicts:      apache1-mod_fastcgi < 2.4.6-2
244 Conflicts:      asterisk < 10.0.1-2
245 Conflicts:      autossh-init < 1.4b-3
246 Conflicts:      balance < 3.54-2
247 Conflicts:      bind < 7:9.8.1.P1-4
248 Conflicts:      bopm < 3.1.3-4
249 Conflicts:      callweaver < 1.2.1-9
250 Conflicts:      cassandra-bin < 0.8.9-2
251 Conflicts:      clamav < 0.97.3-3
252 Conflicts:      cups < 1:1.5.0-10
253 Conflicts:      dbus < 1.4.16-4
254 Conflicts:      dovecot < 1:2.0.16-3
255 Conflicts:      dspam < 3.9.0-6
256 Conflicts:      fail2ban < 0.8.4-4
257 Conflicts:      filesystem < 4.0-3
258 Conflicts:      gammu-smsd < 1:1.31.0-3
259 # Break gdm2.20 installs
260 #Conflicts:     gdm < 2:3.2.1.1-9
261 Conflicts:      greylistd < 0.8.8-2
262 Conflicts:      inn < 2.4.6-7
263 Conflicts:      ipsec-tools < 0.8.0-3
264 Conflicts:      jabber-common < 0-9
265 Conflicts:      laptop-mode-tools < 1.58-2
266 Conflicts:      libgpod < 0.8.0-6
267 Conflicts:      libvirt-utils < 0.9.9-4
268 Conflicts:      lighttpd < 1.4.30-5
269 Conflicts:      lirc < 0.9.0-20
270 Conflicts:      mailman < 5:2.1.14-4
271 Conflicts:      memcached < 1.4.11-2
272 Conflicts:      mpd < 0.16.5-4
273 Conflicts:      mrtg < 2.17.0-3
274 Conflicts:      munin-common < 1.4.5-5
275 Conflicts:      nagios-nrpe < 2.13-2
276 Conflicts:      ndisc6-rdnssd < 1.0.1-3
277 Conflicts:      nscd < 6:2.14.1-5
278 Conflicts:      nss_ldapd-nslcd < 0.8.4-2
279 Conflicts:      openct < 0.6.20-3
280 Conflicts:      openl2tp < 1.8-3
281 Conflicts:      openldap-overlay-nssov < 2.4.28-4
282 Conflicts:      openldap-servers < 2.4.28-4
283 Conflicts:      openvpn < 2.2.2-2
284 Conflicts:      pam-pam_mount < 2.12-3
285 Conflicts:      pam-pam_ssh < 1.97-2
286 Conflicts:      pcsc-lite < 1.8.1-2
287 Conflicts:      php-dirs < 1.2-3
288 Conflicts:      policyd < 2.0.10-3
289 Conflicts:      pound < 2.6-2
290 Conflicts:      pptp < 1.7.2-3
291 Conflicts:      proftpd-common < 2:1.3.4a-2
292 Conflicts:      pulseaudio-server < 1.1-2
293 Conflicts:      quagga < 0.99.20-3
294 Conflicts:      radvd < 1.8.5-2
295 Conflicts:      rc-scripts < 0.4.5.2-3
296 Conflicts:      red5 < 0.9.0-2
297 Conflicts:      redis-server < 2.4.2-4
298 Conflicts:      smokeping < 2.4.2-10
299 Conflicts:      smtp-gated < 1.4.17-2
300 Conflicts:      socat < 1.7.2.0-2
301 Conflicts:      speech-dispatcher < 0.7.1-2
302 Conflicts:      sphinx < 2.0.3-4
303 Conflicts:      splashutils < 1.5.4.3-3
304 Conflicts:      stunnel < 4.50-2
305 Conflicts:      tenshi < 0.12-2
306 Conflicts:      tor < 0.2.2.35-2
307 Conflicts:      ucarp < 1.5.2-3
308 Conflicts:      udisks < 1.0.4-3
309 Conflicts:      util-vserver < 0.30.216-1.pre3002.3
310 Conflicts:      vpnc < 0.5.3-2
311 Conflicts:      web2ldap < 1.1.0rc1-2
312 Conflicts:      wesnoth-server < 1:1.10-2
313 Conflicts:      wpa_supplicant < 0.7.3-10
314 Conflicts:      xl2tpd < 1.3.0-2
315
316 %description no-compat-tmpfiles
317 Force update of packages that provide tmpfiles.d configuration
318
319 %prep
320 %setup -q
321 %patch0 -p1
322 %patch1 -p1
323 %patch2 -p1
324 %patch3 -p1
325 %patch4 -p1
326 %patch5 -p1
327 %patch6 -p1
328 %patch7 -p1
329 %patch8 -p1
330 cp -p %{SOURCE2} src/systemd_booted.c
331
332 %build
333 %{__aclocal} -I m4
334 %{__autoconf}
335 %{__autoheader}
336 %{__automake}
337 %configure \
338         %{__enable_disable audit} \
339         %{__enable_disable cryptsetup libcryptsetup} \
340         --disable-gtk \
341         %{__enable_disable pam} \
342         %{__enable_disable plymouth} \
343         %{__enable_disable selinux} \
344         %{__enable_disable tcpd tcpwrap} \
345         --disable-silent-rules \
346         --disable-static \
347         --with-distro=pld \
348         --with-rootprefix= \
349         --with-rootlibdir=/%{_lib} \
350         --enable-split-usr
351
352 %{__make}
353 ./libtool --mode=link --tag=CC %{__cc} %{rpmcppflags} %{rpmcflags} -o systemd_booted %{rpmldflags} src/systemd_booted.c -L. -lsystemd-daemon
354
355 %install
356 rm -rf $RPM_BUILD_ROOT
357 install -d $RPM_BUILD_ROOT/var/lib/%{name}/coredump
358
359 %{__make} install \
360         DESTDIR=$RPM_BUILD_ROOT
361
362 ./libtool --mode=install install -p -m755 systemd_booted $RPM_BUILD_ROOT/bin/systemd_booted
363
364 # Main binary has been moved, but we don't want to break existing installs
365 ln -s ../lib/systemd/systemd $RPM_BUILD_ROOT/bin/systemd
366
367 # Create SysV compatibility symlinks. systemctl/systemd are smart
368 # enough to detect the way they were called
369 install -d $RPM_BUILD_ROOT/sbin
370 ln -s ../lib/systemd/systemd $RPM_BUILD_ROOT/sbin/init
371 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/halt
372 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/poweroff
373 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/reboot
374 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/runlevel
375 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/shutdown
376 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/telinit
377
378 ln -s ../modules $RPM_BUILD_ROOT%{_sysconfdir}/modules-load.d/modules.conf
379
380 # disable redundant SYSV services
381 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/allowlogin.service
382 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/console.service
383 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/cpusets.service
384 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/killall.service
385 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/netfs.service
386 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/random.service
387
388 # add static (non-NetworkManager) networking
389 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{systemdunitdir}/network.service
390
391 # install compatibility tmpfiles configs
392 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/compat-pld-media.conf
393 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/compat-pld-var-run.conf
394
395 # Install and enable storage subsystems support services (RAID, LVM, etc.)
396 cp -p %{SOURCE10} $RPM_BUILD_ROOT%{systemdunitdir}/pld-storage-init-late.service
397 cp -p %{SOURCE11} $RPM_BUILD_ROOT%{systemdunitdir}/pld-storage-init.service
398 cp -p %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/pld-wait-storage.service
399 cp -p %{SOURCE14} $RPM_BUILD_ROOT%{systemdunitdir}/pld-clean-tmp.service
400 install -p %{SOURCE13} $RPM_BUILD_ROOT/lib/systemd/pld-storage-init
401 install -p %{SOURCE15} $RPM_BUILD_ROOT/lib/systemd/pld-clean-tmp
402
403 ln -s ../pld-storage-init-late.service $RPM_BUILD_ROOT%{systemdunitdir}/local-fs.target.wants
404 ln -s ../pld-storage-init.service $RPM_BUILD_ROOT%{systemdunitdir}/local-fs.target.wants
405 ln -s ../pld-clean-tmp.service $RPM_BUILD_ROOT%{systemdunitdir}/local-fs.target.wants
406
407 # handled by rc-local sysv service, no need for generator
408 %{__rm} $RPM_BUILD_ROOT/lib/systemd/system-generators/systemd-rc-local-generator
409
410 # Make sure these directories are properly owned:
411 #       - halt,kexec,poweroff,reboot: generic ones used by ConsoleKit-systemd,
412 #       - syslog _might_ be used by some syslog implementation (none for now),
413 #       - isn't dbus populated by dbus-systemd only (so to be moved there)?
414 install -d $RPM_BUILD_ROOT%{systemdunitdir}/{dbus,halt,kexec,poweroff,reboot,syslog}.target.wants
415
416 # Create new-style configuration files so that we can ghost-own them
417 touch $RPM_BUILD_ROOT%{_sysconfdir}/{hostname,locale.conf,machine-id,machine-info,timezone,vconsole.conf}
418
419 # Install SysV conversion tool for systemd
420 install -p %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}
421
422 install -d $RPM_BUILD_ROOT/var/log
423 :> $RPM_BUILD_ROOT/var/log/btmp
424 :> $RPM_BUILD_ROOT/var/log/wtmp
425
426 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/systemadm.1*
427
428 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
429 %{__rm} $RPM_BUILD_ROOT/%{_lib}/security/pam_systemd.la
430 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
431
432 %clean
433 rm -rf $RPM_BUILD_ROOT
434
435 %post
436 /bin/systemd-machine-id-setup > /dev/null 2>&1 || :
437 /bin/systemctl daemon-reexec > /dev/null 2>&1 || :
438
439 %postun
440 if [ $1 -ge 1 ]; then
441         /bin/systemctl try-restart systemd-logind.service >/dev/null 2>&1 || :
442 fi
443
444 %post   libs -p /sbin/ldconfig
445 %postun libs -p /sbin/ldconfig
446
447 %post units
448 if [ $1 -eq 1 ]; then
449         # Try to read default runlevel from the old inittab if it exists
450         runlevel=$(/bin/awk -F ':' '$3 == "initdefault" && $1 !~ "^#" { print $2 }' /etc/inittab 2> /dev/null)
451         if [ -z "$runlevel" ] ; then
452                 target="%{systemdunitdir}/graphical.target"
453         else
454                 target="%{systemdunitdir}/runlevel$runlevel.target"
455         fi
456
457         # And symlink what we found to the new-style default.target
458         ln -s "$target" %{_sysconfdir}/systemd/system/default.target >/dev/null 2>&1 || :
459
460         # Setup hostname
461         [ -f /etc/sysconfig/network ] && . /etc/sysconfig/network
462         if [ -n "$HOSTNAME" -a "$HOSTNAME" != "pldmachine" ]; then
463                 [ -f /etc/hostname ] && mv -f /etc/hostname /etc/hostname.rpmsave
464                 echo $HOSTNAME > /etc/hostname
465                 chmod 644 /etc/hostname
466         fi
467
468         # Enable the services we install by default.
469         /bin/systemctl enable \
470                 getty@.service \
471                 network.service \
472                 remote-fs.target \
473                 systemd-readahead-replay.service \
474                 systemd-readahead-collect.service >/dev/null 2>&1 || :
475 fi
476
477 %preun units
478 if [ $1 -eq 0 ] ; then
479         /bin/systemctl disable \
480                 getty@.service \
481                 network.service \
482                 remote-fs.target \
483                 systemd-readahead-replay.service \
484                 systemd-readahead-collect.service >/dev/null 2>&1 || :
485
486         %{__rm} -f %{_sysconfdir}/systemd/system/default.target >/dev/null 2>&1 || :
487 fi
488
489 %postun units
490 if [ $1 -ge 1 ]; then
491         /bin/systemctl daemon-reload > /dev/null 2>&1 || :
492 fi
493
494 %triggerpostun units -- %{name}-units < 43-7
495 # Remove design fialures
496 rm -f %{_sysconfdir}/systemd/system/network.target.wants/ifcfg@*.service >/dev/null 2>&1 || :
497 rm -f %{_sysconfdir}/systemd/system/network.target.wants/network-post.service >/dev/null 2>&1 || :
498 rm -f %{_sysconfdir}/systemd/system/multi-user.target.wants/network-post.service >/dev/null 2>&1 || :
499 /bin/systemctl reenable network.service >/dev/null 2>&1 || :
500
501 %post no-compat-tmpfiles
502 %{__sed} -i -e '/^#/!s/^/# /g' %{_sysconfdir}/tmpfiles.d/compat-pld-var-run.conf
503
504 %post plymouth
505 %systemd_reload
506
507 %postun plymouth
508 %systemd_reload
509
510 %files
511 %defattr(644,root,root,755)
512 %doc DISTRO_PORTING README TODO
513 /etc/dbus-1/system.d/org.freedesktop.hostname1.conf
514 /etc/dbus-1/system.d/org.freedesktop.locale1.conf
515 /etc/dbus-1/system.d/org.freedesktop.login1.conf
516 /etc/dbus-1/system.d/org.freedesktop.systemd1.conf
517 /etc/dbus-1/system.d/org.freedesktop.timedate1.conf
518 %ghost %config(noreplace) %{_sysconfdir}/machine-id
519 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hostname
520 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/locale.conf
521 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/machine-info
522 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/timezone
523 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/vconsole.conf
524 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/systemd/*.conf
525 %dir %{_sysconfdir}/systemd/user
526 %dir %{_sysconfdir}/systemd/system/*.target.wants
527 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/systemd/system/*.target.wants/*.service
528 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/systemd/system/*.target.wants/*.target
529 /etc/xdg/systemd
530 %attr(755,root,root) /bin/systemd
531 %attr(755,root,root) /bin/systemd-ask-password
532 %attr(755,root,root) /bin/systemd-journalctl
533 %attr(755,root,root) /bin/systemd-loginctl
534 %attr(755,root,root) /bin/systemd-machine-id-setup
535 %attr(755,root,root) /bin/systemd-notify
536 %attr(755,root,root) /bin/systemd-tty-ask-password-agent
537 %attr(755,root,root) %{_bindir}/systemd-cat
538 %attr(755,root,root) %{_bindir}/systemd-cgtop
539 %attr(755,root,root) %{_bindir}/systemd-cgls
540 %attr(755,root,root) %{_bindir}/systemd-nspawn
541 %attr(755,root,root) %{_bindir}/systemd-stdio-bridge
542 %attr(755,root,root) %{_bindir}/systemd-sysv-convert
543 %attr(755,root,root) /lib/systemd/pld-clean-tmp
544 %attr(755,root,root) /lib/systemd/pld-storage-init
545 %attr(755,root,root) /lib/systemd/systemd-*
546 %dir /lib/systemd/system-generators
547 %attr(755,root,root) /lib/systemd/systemd
548 %attr(755,root,root) /lib/systemd/system-generators/systemd-*-generator
549 %dir /lib/systemd/system-shutdown
550 /lib/udev/rules.d/99-systemd.rules
551 /lib/udev/rules.d/70-uaccess.rules
552 /lib/udev/rules.d/71-seat.rules
553 /lib/udev/rules.d/73-seat-late.rules
554 %dir %{_libexecdir}/systemd
555 %{_libexecdir}/systemd/user
556 %dir %{_libexecdir}/systemd/user-generators
557 %config(noreplace,missingok) %{_libexecdir}/tmpfiles.d/*.conf
558 %{_datadir}/dbus-1/interfaces/org.freedesktop.hostname1.xml
559 %{_datadir}/dbus-1/interfaces/org.freedesktop.locale1.xml
560 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.*.xml
561 %{_datadir}/dbus-1/interfaces/org.freedesktop.timedate1.xml
562 %{_datadir}/dbus-1/services/org.freedesktop.systemd1.service
563 %{_datadir}/dbus-1/system-services/org.freedesktop.hostname1.service
564 %{_datadir}/dbus-1/system-services/org.freedesktop.locale1.service
565 %{_datadir}/dbus-1/system-services/org.freedesktop.login1.service
566 %{_datadir}/dbus-1/system-services/org.freedesktop.systemd1.service
567 %{_datadir}/dbus-1/system-services/org.freedesktop.timedate1.service
568 %{_datadir}/polkit-1/actions/org.freedesktop.hostname1.policy
569 %{_datadir}/polkit-1/actions/org.freedesktop.locale1.policy
570 %{_datadir}/polkit-1/actions/org.freedesktop.login1.policy
571 %{_datadir}/polkit-1/actions/org.freedesktop.systemd1.policy
572 %{_datadir}/polkit-1/actions/org.freedesktop.timedate1.policy
573 %dir %{_datadir}/systemd
574 %{_datadir}/systemd/kbd-model-map
575 %{_mandir}/man1/systemd.1*
576 %{_mandir}/man1/systemd-*.1*
577 %{_mandir}/man5/binfmt.d.5*
578 %{_mandir}/man5/hostname.5*
579 %{_mandir}/man5/locale.conf.5*
580 %{_mandir}/man5/machine-id.5*
581 %{_mandir}/man5/machine-info.5*
582 %{_mandir}/man5/modules-load.d.5*
583 %{_mandir}/man5/os-release.5*
584 %{_mandir}/man5/sysctl.d.5*
585 %{_mandir}/man5/systemd.*.5*
586 %{_mandir}/man5/systemd-journald.conf.5*
587 %{_mandir}/man5/systemd-logind.conf.5*
588 %{_mandir}/man5/timezone.5*
589 %{_mandir}/man5/vconsole.conf.5*
590 %{_mandir}/man7/daemon.7*
591 %{_mandir}/man7/sd-daemon.7*
592 %{_mandir}/man7/sd-login.7*
593 %{_mandir}/man7/sd-readahead.7*
594 %{_mandir}/man7/systemd.special.7*
595 %dir /var/lib/%{name}
596 %dir /var/lib/%{name}/coredump
597 %attr(640,root,root) %ghost /var/log/btmp
598 %attr(664,root,utmp) %ghost /var/log/wtmp
599
600 %if %{with pam}
601 %attr(755,root,root) /%{_lib}/security/pam_systemd.so
602 %{_mandir}/man8/pam_systemd.8*
603 %endif
604
605 %files init
606 %defattr(644,root,root,755)
607 %attr(755,root,root) /sbin/halt
608 %attr(755,root,root) /sbin/init
609 %attr(755,root,root) /sbin/poweroff
610 %attr(755,root,root) /sbin/reboot
611 %attr(755,root,root) /sbin/runlevel
612 %attr(755,root,root) /sbin/shutdown
613 %attr(755,root,root) /sbin/telinit
614 %{_mandir}/man1/init.1
615 %{_mandir}/man8/halt.8*
616 %{_mandir}/man8/poweroff.8
617 %{_mandir}/man8/reboot.8
618 %{_mandir}/man8/runlevel.8*
619 %{_mandir}/man8/shutdown.8*
620 %{_mandir}/man8/telinit.8*
621
622 %files units
623 %defattr(644,root,root,755)
624 %dir %{_sysconfdir}/binfmt.d
625 %dir %{_sysconfdir}/modules-load.d
626 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/modules-load.d/modules.conf
627 %dir %{_sysconfdir}/sysctl.d
628 %dir %{_sysconfdir}/systemd
629 %dir %{_sysconfdir}/systemd/system
630 %dir %{_sysconfdir}/tmpfiles.d
631 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/tmpfiles.d/*.conf
632 %dir %{_libexecdir}/binfmt.d
633 %dir %{_libexecdir}/modules-load.d
634 %dir %{_libexecdir}/sysctl.d
635 # Don't package the kernel.core_pattern setting until systemd-coredump
636 # is a part of an actual systemd release and it's made clear how to
637 # get the core dumps out of the journal.
638 #%{_libexecdir}/sysctl.d/coredump.conf
639 %attr(755,root,root) /bin/systemctl
640 %attr(755,root,root) /bin/systemd-tmpfiles
641 %attr(755,root,root) /bin/systemd_booted
642 %{_mandir}/man1/systemctl.1*
643 %{_mandir}/man5/tmpfiles.d.5*
644 %{_mandir}/man8/systemd-tmpfiles.8*
645 %{_npkgconfigdir}/systemd.pc
646
647 %{systemdunitdir}/*.automount
648 %{systemdunitdir}/*.mount
649 %{systemdunitdir}/*.path
650 %{systemdunitdir}/*.service
651 %{systemdunitdir}/*.socket
652 %{systemdunitdir}/*.target
653 %{systemdunitdir}/*.timer
654 %if %{with plymouth}
655 %exclude %{systemdunitdir}/plymouth*.service
656 %exclude %{systemdunitdir}/systemd-ask-password-plymouth.*
657 %endif
658 %dir %{systemdunitdir}/basic.target.wants
659 %dir %{systemdunitdir}/dbus.target.wants
660 %dir %{systemdunitdir}/final.target.wants
661 %dir %{systemdunitdir}/graphical.target.wants
662 %dir %{systemdunitdir}/halt.target.wants
663 %dir %{systemdunitdir}/kexec.target.wants
664 %dir %{systemdunitdir}/local-fs.target.wants
665 %dir %{systemdunitdir}/multi-user.target.wants
666 %dir %{systemdunitdir}/poweroff.target.wants
667 %dir %{systemdunitdir}/reboot.target.wants
668 %dir %{systemdunitdir}/runlevel[12345].target.wants
669 %dir %{systemdunitdir}/shutdown.target.wants
670 %dir %{systemdunitdir}/sockets.target.wants
671 %dir %{systemdunitdir}/sysinit.target.wants
672 %dir %{systemdunitdir}/syslog.target.wants
673 %config(noreplace,missingok) %{systemdunitdir}/basic.target.wants/*
674 %config(noreplace,missingok) %{systemdunitdir}/final.target.wants/*
675 %config(noreplace,missingok) %{systemdunitdir}/graphical.target.wants/*
676 %config(noreplace,missingok) %{systemdunitdir}/local-fs.target.wants/*
677 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/getty.target
678 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/rc-local.service
679 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/systemd-ask-password-wall.path
680 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/systemd-logind.service
681 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/systemd-user-sessions.service
682 %config(noreplace,missingok) %{systemdunitdir}/runlevel[12345].target.wants/*
683 %config(noreplace,missingok) %{systemdunitdir}/shutdown.target.wants/*
684 %config(noreplace,missingok) %{systemdunitdir}/sockets.target.wants/*
685 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/cryptsetup.target
686 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/dev-hugepages.mount
687 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/dev-mqueue.mount
688 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/proc-sys-fs-binfmt_misc.automount
689 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/sys-*.mount
690 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/systemd-*
691
692 %if %{with plymouth}
693 %files plymouth
694 %defattr(644,root,root,755)
695 %{systemdunitdir}/plymouth-halt.service
696 %{systemdunitdir}/plymouth-kexec.service
697 %{systemdunitdir}/plymouth-poweroff.service
698 %{systemdunitdir}/plymouth-quit-wait.service
699 %{systemdunitdir}/plymouth-quit.service
700 %{systemdunitdir}/plymouth-read-write.service
701 %{systemdunitdir}/plymouth-reboot.service
702 %{systemdunitdir}/plymouth-start.service
703 %{systemdunitdir}/systemd-ask-password-plymouth.path
704 %{systemdunitdir}/systemd-ask-password-plymouth.service
705 %config(noreplace,missingok) %{systemdunitdir}/halt.target.wants/plymouth-halt.service
706 %config(noreplace,missingok) %{systemdunitdir}/kexec.target.wants/plymouth-kexec.service
707 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/plymouth-quit.service
708 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/plymouth-quit-wait.service
709 %config(noreplace,missingok) %{systemdunitdir}/poweroff.target.wants/plymouth-poweroff.service
710 %config(noreplace,missingok) %{systemdunitdir}/reboot.target.wants/plymouth-reboot.service
711 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/plymouth-read-write.service
712 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/plymouth-start.service
713 %endif
714
715 %files analyze
716 %defattr(644,root,root,755)
717 %attr(755,root,root) %{_bindir}/systemd-analyze
718
719 %files libs
720 %defattr(644,root,root,755)
721 %attr(755,root,root) /%{_lib}/libsystemd-daemon.so.*.*.*
722 %attr(755,root,root) %ghost /%{_lib}/libsystemd-daemon.so.0
723 %attr(755,root,root) /%{_lib}/libsystemd-id128.so.*.*.*
724 %attr(755,root,root) %ghost /%{_lib}/libsystemd-id128.so.0
725 %attr(755,root,root) /%{_lib}/libsystemd-journal.so.*.*.*
726 %attr(755,root,root) %ghost /%{_lib}/libsystemd-journal.so.0
727 %attr(755,root,root) /%{_lib}/libsystemd-login.so.*.*.*
728 %attr(755,root,root) %ghost /%{_lib}/libsystemd-login.so.0
729
730 %files devel
731 %defattr(644,root,root,755)
732 %attr(755,root,root) %{_libdir}/libsystemd-daemon.so
733 %attr(755,root,root) %{_libdir}/libsystemd-id128.so
734 %attr(755,root,root) %{_libdir}/libsystemd-journal.so
735 %attr(755,root,root) %{_libdir}/libsystemd-login.so
736 %{_includedir}/%{name}
737 %{_pkgconfigdir}/libsystemd-daemon.pc
738 %{_pkgconfigdir}/libsystemd-id128.pc
739 %{_pkgconfigdir}/libsystemd-journal.pc
740 %{_pkgconfigdir}/libsystemd-login.pc
741 %{_mandir}/man3/sd_booted.3*
742 %{_mandir}/man3/sd_get_seats.3*
743 %{_mandir}/man3/sd_get_sessions.3*
744 %{_mandir}/man3/sd_get_uids.3*
745 %{_mandir}/man3/sd_is_fifo.3*
746 %{_mandir}/man3/sd_is_mq.3*
747 %{_mandir}/man3/sd_is_socket.3
748 %{_mandir}/man3/sd_is_socket_inet.3
749 %{_mandir}/man3/sd_is_socket_unix.3
750 %{_mandir}/man3/sd_listen_fds.3*
751 %{_mandir}/man3/sd_login_monitor_flush.3*
752 %{_mandir}/man3/sd_login_monitor_get_fd.3*
753 %{_mandir}/man3/sd_login_monitor_new.3*
754 %{_mandir}/man3/sd_login_monitor_unref.3*
755 %{_mandir}/man3/sd_notify.3*
756 %{_mandir}/man3/sd_notifyf.3
757 %{_mandir}/man3/sd_pid_get_owner_uid.3*
758 %{_mandir}/man3/sd_pid_get_session.3*
759 %{_mandir}/man3/sd_pid_get_unit.3*
760 %{_mandir}/man3/sd_readahead.3*
761 %{_mandir}/man3/sd_seat_can_multi_session.3*
762 %{_mandir}/man3/sd_seat_get_active.3*
763 %{_mandir}/man3/sd_seat_get_sessions.3*
764 %{_mandir}/man3/sd_session_get_class.3*
765 %{_mandir}/man3/sd_session_get_display.3*
766 %{_mandir}/man3/sd_session_get_seat.3*
767 %{_mandir}/man3/sd_session_get_service.3*
768 %{_mandir}/man3/sd_session_get_type.3*
769 %{_mandir}/man3/sd_session_get_uid.3*
770 %{_mandir}/man3/sd_session_is_active.3*
771 %{_mandir}/man3/sd_uid_get_seats.3*
772 %{_mandir}/man3/sd_uid_get_sessions.3*
773 %{_mandir}/man3/sd_uid_get_state.3*
774 %{_mandir}/man3/sd_uid_is_on_seat.3*
775
776 %files -n bash-completion-systemd
777 %defattr(644,root,root,755)
778 /etc/bash_completion.d/systemd-bash-completion.sh
779
780 %files no-compat-tmpfiles
781 %defattr(644,root,root,755)
782 # empty package
This page took 0.087793 seconds and 4 git commands to generate.