]> git.pld-linux.org Git - packages/systemd.git/blob - systemd.spec
- conflicts binfmt-detector
[packages/systemd.git] / systemd.spec
1 #
2 # TODO:
3 #       - remove compat-pld-var-run.tmpfiles and maybe tmpfiles-not-fatal.patch
4 #         after enough packages provide their own tmpfiles.d configs for
5 #         /var/run directories
6 #
7 # Conditional build:
8 %bcond_without  audit           # without audit support
9 %bcond_without  cryptsetup      # without cryptsetup support
10 %bcond_without  gtk             # build gtk tools
11 %bcond_without  pam             # PAM authentication support
12 %bcond_without  selinux         # without SELinux support
13 %bcond_without  tcpd            # libwrap (tcp_wrappers) support
14
15 Summary:        A System and Service Manager
16 Summary(pl.UTF-8):      systemd - zarządca systemu i usług dla Linuksa
17 Name:           systemd
18 Version:        39
19 Release:        1
20 License:        GPL v2+
21 Group:          Base
22 Source0:        http://www.freedesktop.org/software/systemd/%{name}-%{version}.tar.xz
23 # Source0-md5:  7179b34f6f6553d2a36551ac1dec5f0d
24 Source1:        %{name}-sysv-convert
25 Source2:        systemd_booted.c
26 Source3:        ifup@.service
27 Source4:        network-post.service
28 Source5:        network.service
29 Source6:        compat-pld-media.tmpfiles
30 Source7:        compat-pld-var-run.tmpfiles
31 Patch0:         target-pld.patch
32 Patch1:         config-pld.patch
33 Patch2:         shut-sysv-up.patch
34 Patch3:         pld-sysv-network.patch
35 Patch4:         tmpfiles-not-fatal.patch
36 URL:            http://www.freedesktop.org/wiki/Software/systemd
37 BuildRequires:  acl-devel
38 %{?with_audit:BuildRequires:    audit-libs-devel}
39 BuildRequires:  autoconf >= 2.63
40 BuildRequires:  automake >= 1:1.11
41 %{?with_cryptsetup:BuildRequires:       cryptsetup-luks-devel}
42 BuildRequires:  dbus-devel >= 1.3.2
43 BuildRequires:  docbook-style-xsl
44 %if %{with gtk}
45 BuildRequires:  glib2-devel >= 1:2.26.1
46 BuildRequires:  gtk+2-devel >= 2:2.24.0
47 BuildRequires:  libgee-devel
48 BuildRequires:  libnotify-devel >= 0.7.0
49 %endif
50 BuildRequires:  gperf
51 BuildRequires:  intltool >= 0.40.0
52 BuildRequires:  libcap-devel
53 %{?with_selinux:BuildRequires:  libselinux-devel}
54 BuildRequires:  libtool >= 2:2.2
55 %{?with_tcpd:BuildRequires:     libwrap-devel}
56 BuildRequires:  libxslt-progs
57 BuildRequires:  m4
58 %{?with_pam:BuildRequires:      pam-devel}
59 BuildRequires:  pkgconfig >= 0.9.0
60 BuildRequires:  rpmbuild(macros) >= 1.527
61 BuildRequires:  udev-devel >= 1:172
62 # not required for building from release (which contains *.c for *.vala)
63 #BuildRequires: vala >= 0.10.0
64 BuildRequires:  xz-devel
65 Requires:       %{name}-libs = %{version}-%{release}
66 Requires:       %{name}-units = %{version}-%{release}
67 Requires:       SysVinit-tools
68 Requires:       agetty
69 Requires:       dbus >= 1.3.2
70 Requires:       dbus-systemd
71 Requires:       filesystem >= 4.0-2
72 Requires:       rc-scripts >= 0.4.5.1-7
73 Requires:       setup >= 2.8.0-2
74 Requires:       udev-core >= 1:172
75 Requires:       udev-systemd >= 1:172
76 Requires:       udev-libs >= 1:172
77 Suggests:       ConsoleKit-systemd
78 Suggests:       fsck >= 2.20
79 Suggests:       nss_myhostname
80 # python modules required by systemd-analyze
81 Suggests:       python-dbus
82 Suggests:       python-modules
83 Suggests:       service(klogd)
84 Suggests:       service(syslog)
85 Suggests:       %{name}-no-compat-tmpfiles
86 Provides:       udev-acl
87 # systemd takes care of that and causes problems
88 Conflicts:      binfmt-detector
89 Conflicts:      upstart
90 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
91
92 %define         _libexecdir     %{_prefix}/lib
93
94 %description
95 systemd is a system and service manager for Linux, compatible with
96 SysV and LSB init scripts. systemd provides aggressive parallelization
97 capabilities, uses socket and D-Bus activation for starting services,
98 offers on-demand starting of daemons, keeps track of processes using
99 Linux cgroups, supports snapshotting and restoring of the system
100 state, maintains mount and automount points and implements an
101 elaborate transactional dependency-based service control logic. It can
102 work as a drop-in replacement for sysvinit.
103
104 %description -l pl.UTF-8
105 systemd jest zarządcą systemu i usług dla Linuksa, kompatybilny ze
106 skryptami SysV i LSB. systemd udostępnia rozbudowane zdolności
107 paralelizacji, do uruchamiania usług używa socketów oraz D-Busa,
108 oferuje uruchamianie usług na życzenie, monitoruje procesy używając
109 linuksowych cgroups, wspomaga zapisywanie (snapshot) i odczytywanie
110 (restore) stanu systemu, zarządza (auto)mount pointami oraz
111 implementuje starannie opracowaną transakcjonalną, bazującą na
112 zależnościach logikę kontroli usług. Może pracować jako zastępca dla
113 sysvinit.
114
115 %package init
116 Summary:        systemd /sbin/init and LSB/SysV compatibility symlinks
117 Summary(pl.UTF-8):      /sbin/init z systemd i dowiązania dla kompatybilności z LSB/SysV
118 Group:          Base
119 Requires:       systemd
120 Provides:       readahead = 1:1.5.7-3
121 Provides:       virtual(init-daemon)
122 Obsoletes:      SysVinit
123 Obsoletes:      readahead < 1:1.5.7-3
124 Obsoletes:      virtual(init-daemon)
125
126 %description init
127 Install this package when you are ready to final switch to systemd.
128
129 %description init -l pl.UTF-8
130 Ten pakiet należy zainstalować po przygotowaniu się do ostatecznego
131 przejścia na systemd.
132
133 %package units
134 Summary:        Configuration files, directories and installation tool for systemd
135 Summary(pl.UTF-8):      Pliki konfiguracyjne, katalogi i narzędzie instalacyjne dla systemd
136 Group:          Base
137 Requires(post): coreutils
138 Requires(post): gawk
139 Requires:       pkgconfig
140
141 %description units
142 Basic configuration files, directories and installation tool for the
143 systemd system and service manager.
144
145 This is common config, use %{_sysconfdir}/systemd/system to override.
146
147 %description units -l pl.UTF-8
148 Podstawowe pliki konfiguracyjne, katalogi i narzędzie instalacyjne dla
149 zarządcy systemu i usług systemd.
150
151 Ten pakiet zawiera ogólną konfigurację, ustawienia można nadpisać
152 poprzez katalog %{_sysconfdir}/systemd/system.
153
154 %package gtk
155 Summary:        Graphical frontend for systemd
156 Summary(pl.UTF-8):      Graficzny interfejs do systemd
157 Group:          Base
158 Requires:       %{name} = %{version}-%{release}
159 Requires:       polkit
160
161 %description gtk
162 Graphical front-end for systemd.
163
164 %description gtk -l pl.UTF-8
165 Graficzny interfejs do systemd.
166
167 %package libs
168 Summary:        Shared systemd libraries
169 Summary(pl.UTF-8):      Biblioteki współdzielone systemd
170 Group:          Libraries
171
172 %description libs
173 Shared systemd libraries.
174
175 %description libs -l pl.UTF-8
176 Biblioteki współdzielone systemd.
177
178 %package devel
179 Summary:        Header files for systemd libraries
180 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek systemd
181 Group:          Development/Libraries
182 Requires:       %{name}-libs = %{version}-%{release}
183
184 %description devel
185 Header files for systemd libraries.
186
187 %description devel -l pl.UTF-8
188 Pliki nagłówkowe bibliotek systemd.
189
190 %package -n bash-completion-systemd
191 Summary:        bash-completion for systemd
192 Summary(pl.UTF-8):      Bashowe dopełnianie składni dla systemd
193 Group:          Applications/Shells
194 Requires:       %{name}
195 Requires:       bash-completion
196
197 %description -n bash-completion-systemd
198 bash-completion for systemd.
199
200 %description -n bash-completion-systemd -l pl.UTF-8
201 Bashowe dopełnianie składni dla systemd
202
203 %package no-compat-tmpfiles
204 Summary:        Force update of packages that provide tmpfiles.d configuration
205 Group:          Base
206 Requires(post): sed > 4.0
207 Conflicts:      ConsoleKit-dirs < 0.4.5-7
208 Conflicts:      NetworkManager < 2:0.9.2.0-3
209 Conflicts:      Zope < 2.11.8-2
210 Conflicts:      amavisd-new < 1:2.7.0-1
211 Conflicts:      apache1-base < 1.3.42-5
212 Conflicts:      apache1-mod_fastcgi < 2.4.6-2
213 Conflicts:      apache-base < 2.2.21-4
214 Conflicts:      apache-mod_bw < 0.92-3
215 Conflicts:      apache-mod_fastcgi < 2.4.6-6
216 Conflicts:      asterisk < 10.0.1-2
217 Conflicts:      autossh-init < 1.4b-3
218 Conflicts:      balance < 3.54-2
219 Conflicts:      bind < 7:9.8.1.P1-4
220 Conflicts:      bopm < 3.1.3-4
221 Conflicts:      callweaver < 1.2.1-9
222 Conflicts:      cassandra-bin < 0.8.9-2
223 Conflicts:      clamav < 0.97.3-3
224 Conflicts:      cups < 1:1.5.0-10
225 Conflicts:      dbus < 1.4.16-4
226 Conflicts:      dovecot < 1:2.0.16-3
227 Conflicts:      dspam < 3.9.0-6
228 Conflicts:      fail2ban < 0.8.4-4
229 Conflicts:      filesystem < 4.0-3
230 Conflicts:      gammu-smsd < 1:1.31.0-3
231 Conflicts:      gdm < 2:3.2.1.1-9
232 Conflicts:      greylistd < 0.8.8-2
233 Conflicts:      inn < 2.4.6-7
234 Conflicts:      ipsec-tools < 0.8.0-3
235 Conflicts:      jabber-common < 0-9
236 Conflicts:      laptop-mode-tools < 1.58-2
237 Conflicts:      libgpod < 0.8.0-6
238 Conflicts:      libvirt-utils < 0.9.9-4
239 Conflicts:      lighttpd < 1.4.30-5
240 Conflicts:      lirc < 0.9.0-20
241 Conflicts:      mailman < 5:2.1.14-4
242 Conflicts:      memcached < 1.4.11-2
243 Conflicts:      mpd < 0.16.5-4
244 Conflicts:      mrtg < 2.17.0-3
245 Conflicts:      munin-common < 1.4.5-5
246 Conflicts:      nagios-nrpe < 2.13-2
247 Conflicts:      ndisc6-rdnssd < 1.0.1-3
248 Conflicts:      nscd < 6:2.14.1-5
249 Conflicts:      nss_ldapd-nslcd < 0.8.4-2
250 Conflicts:      openct < 0.6.20-3
251 Conflicts:      openl2tp < 1.8-3
252 Conflicts:      openldap-overlay-nssov < 2.4.28-4
253 Conflicts:      openldap-servers < 2.4.28-4
254 Conflicts:      openvpn < 2.2.2-2
255 Conflicts:      pam < 1:1.1.5-3
256 Conflicts:      pam-pam_mount < 2.12-3
257 Conflicts:      pam-pam_ssh < 1.97-2
258 Conflicts:      pcsc-lite < 1.8.1-2
259 Conflicts:      php-dirs < 1.2-3
260 Conflicts:      policyd < 2.0.10-3
261 Conflicts:      pound < 2.6-2
262 Conflicts:      pptp < 1.7.2-3
263 Conflicts:      proftpd-common < 2:1.3.4a-2
264 Conflicts:      pulseaudio-server < 1.1-2
265 Conflicts:      quagga < 0.99.20-3
266 Conflicts:      radvd < 1.8.5-2
267 Conflicts:      rc-scripts < 0.4.5.2-3
268 Conflicts:      red5 < 0.9.0-2
269 Conflicts:      redis-server < 2.4.2-4
270 Conflicts:      smokeping < 2.4.2-10
271 Conflicts:      smtp-gated < 1.4.17-2
272 Conflicts:      socat < 1.7.2.0-2
273 Conflicts:      speech-dispatcher < 0.7.1-2
274 Conflicts:      sphinx < 2.0.3-4
275 Conflicts:      splashutils < 1.5.4.3-3
276 Conflicts:      stunnel < 4.50-2
277 Conflicts:      sudo < 1:1.7.8p2-2
278 Conflicts:      tenshi < 0.12-2
279 Conflicts:      tor < 0.2.2.35-2
280 Conflicts:      ucarp < 1.5.2-3
281 Conflicts:      udisks < 1.0.4-3
282 Conflicts:      util-vserver < 0.30.216-1.pre3002.3
283 Conflicts:      vpnc < 0.5.3-2
284 Conflicts:      web2ldap < 1.1.0rc1-2
285 Conflicts:      wesnoth-server < 1:1.10-2
286 Conflicts:      wpa_supplicant < 0.7.3-10
287 Conflicts:      xl2tpd < 1.3.0-2
288
289 %description no-compat-tmpfiles
290 Force update of packages that provide tmpfiles.d configuration
291
292 %prep
293 %setup -q
294 %patch0 -p1
295 %patch1 -p1
296 #%patch2 -p1
297 %patch3 -p1
298 %patch4 -p1
299 cp -p %{SOURCE2} src/systemd_booted.c
300
301 %build
302 %{__aclocal} -I m4
303 %{__autoconf}
304 %{__autoheader}
305 %{__automake}
306 %configure \
307         %{__enable_disable audit} \
308         %{__enable_disable cryptsetup libcryptsetup} \
309         %{__enable_disable gtk} \
310         %{__enable_disable pam} \
311         %{__enable_disable selinux} \
312         %{__enable_disable tcpd tcpwrap} \
313         --disable-silent-rules \
314         --disable-static \
315         --with-distro=pld \
316         --with-rootprefix= \
317         --with-rootlibdir=/%{_lib}
318
319 %{__make}
320 ./libtool --mode=link --tag=CC %{__cc} %{rpmcppflags} %{rpmcflags} -o systemd_booted %{rpmldflags} src/systemd_booted.c -L. -lsystemd-daemon
321
322 %install
323 rm -rf $RPM_BUILD_ROOT
324
325 %{__make} install \
326         DESTDIR=$RPM_BUILD_ROOT
327
328 ./libtool --mode=install install -m755 systemd_booted $RPM_BUILD_ROOT/bin/systemd_booted
329
330 # Create SysV compatibility symlinks. systemctl/systemd are smart
331 # enough to detect the way they were called
332 install -d $RPM_BUILD_ROOT/sbin
333 ln -s ../bin/systemd $RPM_BUILD_ROOT/sbin/init
334 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/halt
335 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/poweroff
336 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/reboot
337 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/runlevel
338 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/shutdown
339 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/telinit
340
341 ln -s ../modules $RPM_BUILD_ROOT%{_sysconfdir}/modules-load.d/modules.conf
342 # disable random and console SYSV service 
343 ln -s /dev/null $RPM_BUILD_ROOT/lib/systemd/system/random.service
344 ln -s /dev/null $RPM_BUILD_ROOT/lib/systemd/system/console.service
345
346 # add static (non-NetworkManager) networking
347 install %{SOURCE3} $RPM_BUILD_ROOT/lib/systemd/system/ifup@.service
348 install %{SOURCE4} $RPM_BUILD_ROOT/lib/systemd/system/network-post.service
349 install %{SOURCE5} $RPM_BUILD_ROOT/lib/systemd/system/network.service
350
351 # install compatibility tmpfiles configs
352 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/compat-pld-media.conf
353 install %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/compat-pld-var-run.conf
354
355 # All wants links are created at %post to make sure they are not owned
356 # and hence overriden by rpm if the user deletes them (missingok?)
357 %{__rm} -r $RPM_BUILD_ROOT%{_sysconfdir}/systemd/system/*.target.wants
358
359 # it is in rc-scripts pkg
360 %{__rm} $RPM_BUILD_ROOT/lib/systemd/system/rc-local.service
361
362 # Make sure these directories are properly owned:
363 #       - halt,kexec,poweroff,reboot: generic ones used by ConsoleKit-systemd,
364 #       - syslog _might_ be used by some syslog implementation (none for now),
365 #       - isn't dbus populated by dbus-systemd only (so to be moved there)?
366 install -d $RPM_BUILD_ROOT/lib/systemd/system/{dbus,halt,kexec,poweroff,reboot,syslog}.target.wants
367
368 # Create new-style configuration files so that we can ghost-own them
369 touch $RPM_BUILD_ROOT%{_sysconfdir}/{hostname,locale.conf,machine-id,machine-info,os-release,timezone,vconsole.conf}
370
371 # Install SysV conversion tool for systemd
372 install -p %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}
373
374 install -d $RPM_BUILD_ROOT/var/log
375 :> $RPM_BUILD_ROOT/var/log/btmp
376 :> $RPM_BUILD_ROOT/var/log/wtmp
377
378 %if %{without gtk}
379 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/systemadm.1*
380 %endif
381
382 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
383 %{__rm} $RPM_BUILD_ROOT/%{_lib}/security/pam_systemd.la
384 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
385
386 %clean
387 rm -rf $RPM_BUILD_ROOT
388
389 %post
390 /bin/systemd-machine-id-setup > /dev/null 2>&1 || :
391 /bin/systemctl daemon-reexec > /dev/null 2>&1 || :
392
393 %postun
394 if [ $1 -ge 1 ]; then
395         /bin/systemctl try-restart systemd-logind.service >/dev/null 2>&1 || :
396 fi
397
398 %post   libs -p /sbin/ldconfig
399 %postun libs -p /sbin/ldconfig
400
401 %post units
402 if [ $1 -eq 1 ]; then
403         # Try to read default runlevel from the old inittab if it exists
404         runlevel=$(/bin/awk -F ':' '$3 == "initdefault" && $1 !~ "^#" { print $2 }' /etc/inittab 2> /dev/null)
405         if [ -z "$runlevel" ] ; then
406                 target="/lib/systemd/system/graphical.target"
407         else
408                 target="/lib/systemd/system/runlevel$runlevel.target"
409         fi
410
411         # And symlink what we found to the new-style default.target
412         ln -s "$target" %{_sysconfdir}/systemd/system/default.target >/dev/null 2>&1 || :
413
414         # Setup hostname
415         [ -f /etc/sysconfig/network ] && . /etc/sysconfig/network
416         if [ -n "$HOSTNAME" -a "$HOSTNAME" != "pldmachine" ]; then
417                 [ -f /etc/hostname ] && mv -f /etc/hostname /etc/hostname.rpmsave
418                 echo $HOSTNAME > /etc/hostname
419                 chmod 644 /etc/hostname
420         fi
421 fi
422 # Enable the services we install by default.
423 /bin/systemctl enable \
424         getty@.service \
425         network.service \
426         network-post.service \
427         remote-fs.target \
428         systemd-readahead-replay.service \
429         systemd-readahead-collect.service >/dev/null 2>&1 || :
430
431 # Find and enable all installed interfaces
432 mkdir -p %{_sysconfdir}/systemd/system/network.target.wants >/dev/null 2>&1 || :
433 for f in /etc/sysconfig/interfaces/ifcfg-* ; do
434         ff=$(basename $f)
435         ff=${ff##ifcfg-}
436         case "$ff" in
437         *.rpmorig|*.rpmnew|*.rpmsave|*~|*.orig)
438                 continue
439                 ;;
440         *)
441                 DEVICE="" ; ONBOOT="" ; USERS=""
442                 . $f 2>/dev/null
443                 [ ${USERS:-no} != no ] && continue
444                 if [ "$DEVICE" = "$ff" -a ${ONBOOT:-no} = "yes" ]; then
445                         ln -s /lib/systemd/system/ifup@.service \
446                                 %{_sysconfdir}/systemd/system/network.target.wants/ifcfg@$ff.service >/dev/null 2>&1 || :
447                 fi
448                 ;;
449         esac
450 done
451
452 %preun units
453 if [ $1 -eq 0 ] ; then
454         /bin/systemctl disable \
455                 getty@.service \
456                 network.service \
457                 network-post.service \
458                 remote-fs.target \
459                 systemd-readahead-replay.service \
460                 systemd-readahead-collect.service >/dev/null 2>&1 || :
461
462         %{__rm} -f %{_sysconfdir}/systemd/system/default.target >/dev/null 2>&1 || :
463         %{__rm} -f %{_sysconfdir}/systemd/system/network.target.wants/ifcfg@*.service >/dev/null 2>&1 || :
464 fi
465
466 %postun units
467 if [ $1 -ge 1 ]; then
468         /bin/systemctl daemon-reload > /dev/null 2>&1 || :
469 fi
470
471 %post no-compat-tmpfiles
472 %{__sed} -i -e 's/^/# /g' %{_sysconfdir}/tmpfiles.d/compat-pld-var-run.conf
473
474 %files
475 %defattr(644,root,root,755)
476 %doc DISTRO_PORTING README TODO
477 /etc/dbus-1/system.d/org.freedesktop.hostname1.conf
478 /etc/dbus-1/system.d/org.freedesktop.locale1.conf
479 /etc/dbus-1/system.d/org.freedesktop.login1.conf
480 /etc/dbus-1/system.d/org.freedesktop.systemd1.conf
481 /etc/dbus-1/system.d/org.freedesktop.timedate1.conf
482 %ghost %config(noreplace) %{_sysconfdir}/machine-id
483 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hostname
484 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/locale.conf
485 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/machine-info
486 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/os-release
487 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/timezone
488 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/vconsole.conf
489 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/systemd/*.conf
490 %dir %{_sysconfdir}/systemd/user
491 /etc/xdg/systemd
492 %attr(755,root,root) /bin/systemd
493 %attr(755,root,root) /bin/systemd-ask-password
494 %attr(755,root,root) /bin/systemd-journalctl
495 %attr(755,root,root) /bin/systemd-loginctl
496 %attr(755,root,root) /bin/systemd-machine-id-setup
497 %attr(755,root,root) /bin/systemd-notify
498 %attr(755,root,root) /bin/systemd-tty-ask-password-agent
499 %attr(755,root,root) %{_bindir}/systemd-analyze
500 %attr(755,root,root) %{_bindir}/systemd-cat
501 %attr(755,root,root) %{_bindir}/systemd-cgtop
502 %attr(755,root,root) %{_bindir}/systemd-cgls
503 %attr(755,root,root) %{_bindir}/systemd-nspawn
504 %attr(755,root,root) %{_bindir}/systemd-stdio-bridge
505 %attr(755,root,root) %{_bindir}/systemd-sysv-convert
506 %attr(755,root,root) /lib/systemd/systemd-*
507 %dir /lib/systemd/system-generators
508 %attr(755,root,root) /lib/systemd/system-generators/systemd-*-generator
509 %dir /lib/systemd/system-shutdown
510 /lib/udev/rules.d/99-systemd.rules
511 /lib/udev/rules.d/70-uaccess.rules
512 /lib/udev/rules.d/71-seat.rules
513 /lib/udev/rules.d/73-seat-late.rules
514 %dir %{_libexecdir}/systemd
515 %{_libexecdir}/systemd/user
516 %dir %{_libexecdir}/systemd/user-generators
517 %config(noreplace,missingok) %{_libexecdir}/tmpfiles.d/*.conf
518 %{_datadir}/dbus-1/interfaces/org.freedesktop.hostname1.xml
519 %{_datadir}/dbus-1/interfaces/org.freedesktop.locale1.xml
520 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.*.xml
521 %{_datadir}/dbus-1/interfaces/org.freedesktop.timedate1.xml
522 %{_datadir}/dbus-1/services/org.freedesktop.systemd1.service
523 %{_datadir}/dbus-1/system-services/org.freedesktop.hostname1.service
524 %{_datadir}/dbus-1/system-services/org.freedesktop.locale1.service
525 %{_datadir}/dbus-1/system-services/org.freedesktop.login1.service
526 %{_datadir}/dbus-1/system-services/org.freedesktop.systemd1.service
527 %{_datadir}/dbus-1/system-services/org.freedesktop.timedate1.service
528 %{_datadir}/polkit-1/actions/org.freedesktop.hostname1.policy
529 %{_datadir}/polkit-1/actions/org.freedesktop.locale1.policy
530 %{_datadir}/polkit-1/actions/org.freedesktop.login1.policy
531 %{_datadir}/polkit-1/actions/org.freedesktop.systemd1.policy
532 %{_datadir}/polkit-1/actions/org.freedesktop.timedate1.policy
533 %dir %{_datadir}/systemd
534 %{_datadir}/systemd/kbd-model-map
535 %{_mandir}/man1/systemd.1*
536 %{_mandir}/man1/systemd-*.1*
537 %{_mandir}/man3/sd_booted.3*
538 %{_mandir}/man3/sd_is_fifo.3*
539 %{_mandir}/man3/sd_is_socket.3
540 %{_mandir}/man3/sd_is_socket_inet.3
541 %{_mandir}/man3/sd_is_socket_unix.3
542 %{_mandir}/man3/sd_listen_fds.3*
543 %{_mandir}/man3/sd_notify.3*
544 %{_mandir}/man3/sd_notifyf.3
545 %{_mandir}/man3/sd_readahead.3*
546 %{_mandir}/man5/binfmt.d.5*
547 %{_mandir}/man5/hostname.5*
548 %{_mandir}/man5/locale.conf.5*
549 %{_mandir}/man5/machine-id.5*
550 %{_mandir}/man5/machine-info.5*
551 %{_mandir}/man5/modules-load.d.5*
552 %{_mandir}/man5/os-release.5*
553 %{_mandir}/man5/sysctl.d.5*
554 %{_mandir}/man5/systemd.*.5*
555 %{_mandir}/man5/systemd-logind.conf.5*
556 %{_mandir}/man5/timezone.5*
557 %{_mandir}/man5/vconsole.conf.5*
558 %{_mandir}/man7/daemon.7*
559 %{_mandir}/man7/sd-daemon.7*
560 %{_mandir}/man7/sd-login.7*
561 %{_mandir}/man7/sd-readahead.7*
562 %{_mandir}/man7/systemd.special.7*
563 %attr(640,root,root) %ghost /var/log/btmp
564 %attr(664,root,utmp) %ghost /var/log/wtmp
565
566 %if %{with pam}
567 %attr(755,root,root) /%{_lib}/security/pam_systemd.so
568 %{_mandir}/man8/pam_systemd.8*
569 %endif
570
571 %files init
572 %defattr(644,root,root,755)
573 %attr(755,root,root) /sbin/halt
574 %attr(755,root,root) /sbin/init
575 %attr(755,root,root) /sbin/poweroff
576 %attr(755,root,root) /sbin/reboot
577 %attr(755,root,root) /sbin/runlevel
578 %attr(755,root,root) /sbin/shutdown
579 %attr(755,root,root) /sbin/telinit
580 %{_mandir}/man1/init.1
581 %{_mandir}/man8/halt.8*
582 %{_mandir}/man8/poweroff.8
583 %{_mandir}/man8/reboot.8
584 %{_mandir}/man8/runlevel.8*
585 %{_mandir}/man8/shutdown.8*
586 %{_mandir}/man8/telinit.8*
587
588 %files units
589 %defattr(644,root,root,755)
590 %dir %{_sysconfdir}/binfmt.d
591 %dir %{_sysconfdir}/modules-load.d
592 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/modules-load.d/modules.conf
593 %dir %{_sysconfdir}/sysctl.d
594 %dir %{_sysconfdir}/systemd
595 %dir %{_sysconfdir}/systemd/system
596 %dir %{_sysconfdir}/tmpfiles.d
597 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/tmpfiles.d/*.conf
598 %dir %{_libexecdir}/binfmt.d
599 %dir %{_libexecdir}/modules-load.d
600 %dir %{_libexecdir}/sysctl.d
601 %{_libexecdir}/sysctl.d/coredump.conf
602 %attr(755,root,root) /bin/systemctl
603 %attr(755,root,root) /bin/systemd-tmpfiles
604 %attr(755,root,root) /bin/systemd_booted
605 %{_mandir}/man1/systemctl.1*
606 %{_mandir}/man5/tmpfiles.d.5*
607 %{_mandir}/man8/systemd-tmpfiles.8*
608 %{_npkgconfigdir}/systemd.pc
609
610 /lib/systemd/system/*.automount
611 /lib/systemd/system/*.mount
612 /lib/systemd/system/*.path
613 /lib/systemd/system/*.service
614 /lib/systemd/system/*.socket
615 /lib/systemd/system/*.target
616 /lib/systemd/system/*.timer
617 %dir /lib/systemd/system/*.wants
618 %config(noreplace,missingok) /lib/systemd/system/*.wants/*
619
620 %if %{with gtk}
621 %files gtk
622 %defattr(644,root,root,755)
623 %attr(755,root,root) %{_bindir}/systemadm
624 %attr(755,root,root) %{_bindir}/systemd-gnome-ask-password-agent
625 %{_mandir}/man1/systemadm.1*
626 %endif
627
628 %files libs
629 %defattr(644,root,root,755)
630 %attr(755,root,root) /%{_lib}/libsystemd-daemon.so.*.*.*
631 %attr(755,root,root) %ghost /%{_lib}/libsystemd-daemon.so.0
632 %attr(755,root,root) /%{_lib}/libsystemd-id128.so.*.*.*
633 %attr(755,root,root) %ghost /%{_lib}/libsystemd-id128.so.0
634 %attr(755,root,root) /%{_lib}/libsystemd-journal.so.*.*.*
635 %attr(755,root,root) %ghost /%{_lib}/libsystemd-journal.so.0
636 %attr(755,root,root) /%{_lib}/libsystemd-login.so.*.*.*
637 %attr(755,root,root) %ghost /%{_lib}/libsystemd-login.so.0
638
639 %files devel
640 %defattr(644,root,root,755)
641 %attr(755,root,root) %{_libdir}/libsystemd-daemon.so
642 %attr(755,root,root) %{_libdir}/libsystemd-id128.so
643 %attr(755,root,root) %{_libdir}/libsystemd-journal.so
644 %attr(755,root,root) %{_libdir}/libsystemd-login.so
645 %{_includedir}/%{name}
646 %{_pkgconfigdir}/libsystemd-daemon.pc
647 %{_pkgconfigdir}/libsystemd-id128.pc
648 %{_pkgconfigdir}/libsystemd-journal.pc
649 %{_pkgconfigdir}/libsystemd-login.pc
650 %{_mandir}/man3/sd_get_seats.3*
651 %{_mandir}/man3/sd_get_sessions.3*
652 %{_mandir}/man3/sd_get_uids.3*
653 %{_mandir}/man3/sd_is_mq.3*
654 %{_mandir}/man3/sd_login_monitor_flush.3*
655 %{_mandir}/man3/sd_login_monitor_get_fd.3*
656 %{_mandir}/man3/sd_login_monitor_new.3*
657 %{_mandir}/man3/sd_login_monitor_unref.3*
658 %{_mandir}/man3/sd_pid_get_owner_uid.3*
659 %{_mandir}/man3/sd_pid_get_session.3*
660 %{_mandir}/man3/sd_pid_get_unit.3*
661 %{_mandir}/man3/sd_seat_can_multi_session.3*
662 %{_mandir}/man3/sd_seat_get_active.3*
663 %{_mandir}/man3/sd_seat_get_sessions.3*
664 %{_mandir}/man3/sd_session_get_seat.3*
665 %{_mandir}/man3/sd_session_get_uid.3*
666 %{_mandir}/man3/sd_session_is_active.3*
667 %{_mandir}/man3/sd_uid_get_seats.3*
668 %{_mandir}/man3/sd_uid_get_sessions.3*
669 %{_mandir}/man3/sd_uid_get_state.3*
670 %{_mandir}/man3/sd_uid_is_on_seat.3*
671
672 %files -n bash-completion-systemd
673 %defattr(644,root,root,755)
674 /etc/bash_completion.d/systemd-bash-completion.sh
675
676 %files no-compat-tmpfiles
677 %defattr(644,root,root,755)
678 # empty package
This page took 0.071214 seconds and 4 git commands to generate.