]> git.pld-linux.org Git - packages/systemd.git/blob - systemd.spec
- rel 4
[packages/systemd.git] / systemd.spec
1 #
2 # TODO:
3 #       - remove compat-pld-var-run.tmpfiles and maybe tmpfiles-not-fatal.patch
4 #         after enough packages provide their own tmpfiles.d configs for
5 #         /var/run directories
6 #
7 # Conditional build:
8 %bcond_without  audit           # without audit support
9 %bcond_without  cryptsetup      # without cryptsetup support
10 %bcond_without  gtk             # build gtk tools
11 %bcond_without  pam             # PAM authentication support
12 %bcond_without  selinux         # without SELinux support
13 %bcond_without  tcpd            # libwrap (tcp_wrappers) support
14
15 Summary:        A System and Service Manager
16 Summary(pl.UTF-8):      systemd - zarządca systemu i usług dla Linuksa
17 Name:           systemd
18 Version:        39
19 Release:        4
20 License:        GPL v2+
21 Group:          Base
22 Source0:        http://www.freedesktop.org/software/systemd/%{name}-%{version}.tar.xz
23 # Source0-md5:  7179b34f6f6553d2a36551ac1dec5f0d
24 Source1:        %{name}-sysv-convert
25 Source2:        %{name}_booted.c
26 Source3:        ifup@.service
27 Source4:        network-post.service
28 Source5:        network.service
29 Source6:        compat-pld-media.tmpfiles
30 Source7:        compat-pld-var-run.tmpfiles
31 Patch0:         target-pld.patch
32 Patch1:         config-pld.patch
33 Patch2:         shut-sysv-up.patch
34 Patch3:         pld-sysv-network.patch
35 Patch4:         tmpfiles-not-fatal.patch
36 URL:            http://www.freedesktop.org/wiki/Software/systemd
37 BuildRequires:  acl-devel
38 %{?with_audit:BuildRequires:    audit-libs-devel}
39 BuildRequires:  autoconf >= 2.63
40 BuildRequires:  automake >= 1:1.11
41 %{?with_cryptsetup:BuildRequires:       cryptsetup-luks-devel}
42 BuildRequires:  dbus-devel >= 1.3.2
43 BuildRequires:  docbook-style-xsl
44 %if %{with gtk}
45 BuildRequires:  glib2-devel >= 1:2.26.1
46 BuildRequires:  gtk+2-devel >= 2:2.24.0
47 BuildRequires:  libgee-devel
48 BuildRequires:  libnotify-devel >= 0.7.0
49 %endif
50 BuildRequires:  binutils >= 3:2.22.52.0.1-2
51 BuildRequires:  gperf
52 BuildRequires:  intltool >= 0.40.0
53 BuildRequires:  libcap-devel
54 %{?with_selinux:BuildRequires:  libselinux-devel}
55 BuildRequires:  libtool >= 2:2.2
56 %{?with_tcpd:BuildRequires:     libwrap-devel}
57 BuildRequires:  libxslt-progs
58 BuildRequires:  m4
59 %{?with_pam:BuildRequires:      pam-devel}
60 BuildRequires:  pkgconfig >= 0.9.0
61 BuildRequires:  rpmbuild(macros) >= 1.627
62 BuildRequires:  udev-devel >= 1:172
63 # not required for building from release (which contains *.c for *.vala)
64 #BuildRequires: vala >= 0.10.0
65 BuildRequires:  xz-devel
66 Requires:       %{name}-libs = %{version}-%{release}
67 Requires:       %{name}-units = %{version}-%{release}
68 Requires:       SysVinit-tools
69 Requires:       agetty
70 Requires:       dbus >= 1.4.16-6
71 Requires:       filesystem >= 4.0-2
72 Requires:       rc-scripts >= 0.4.5.1-7
73 Requires:       setup >= 2.8.0-2
74 Requires:       udev-core >= 1:175-5
75 Requires:       udev-libs >= 1:172
76 Suggests:       ConsoleKit
77 Suggests:       fsck >= 2.20
78 Suggests:       nss_myhostname
79 # python modules required by systemd-analyze
80 Suggests:       %{name}-no-compat-tmpfiles
81 Suggests:       python-dbus
82 Suggests:       python-modules
83 Suggests:       service(klogd)
84 Suggests:       service(syslog)
85 Provides:       udev-acl
86 # systemd takes care of that and causes problems
87 Conflicts:      binfmt-detector
88 # sytemd wants pam with pam_systemd.so in system-auth 
89 Conflicts:      pam < 1:1.1.5-5
90 Conflicts:      upstart
91 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
92
93 %define         _libexecdir     %{_prefix}/lib
94
95 %description
96 systemd is a system and service manager for Linux, compatible with
97 SysV and LSB init scripts. systemd provides aggressive parallelization
98 capabilities, uses socket and D-Bus activation for starting services,
99 offers on-demand starting of daemons, keeps track of processes using
100 Linux cgroups, supports snapshotting and restoring of the system
101 state, maintains mount and automount points and implements an
102 elaborate transactional dependency-based service control logic. It can
103 work as a drop-in replacement for sysvinit.
104
105 %description -l pl.UTF-8
106 systemd jest zarządcą systemu i usług dla Linuksa, kompatybilny ze
107 skryptami SysV i LSB. systemd udostępnia rozbudowane zdolności
108 paralelizacji, do uruchamiania usług używa socketów oraz D-Busa,
109 oferuje uruchamianie usług na życzenie, monitoruje procesy używając
110 linuksowych cgroups, wspomaga zapisywanie (snapshot) i odczytywanie
111 (restore) stanu systemu, zarządza (auto)mount pointami oraz
112 implementuje starannie opracowaną transakcjonalną, bazującą na
113 zależnościach logikę kontroli usług. Może pracować jako zastępca dla
114 sysvinit.
115
116 %package init
117 Summary:        systemd /sbin/init and LSB/SysV compatibility symlinks
118 Summary(pl.UTF-8):      /sbin/init z systemd i dowiązania dla kompatybilności z LSB/SysV
119 Group:          Base
120 Requires:       systemd
121 Provides:       readahead = 1:1.5.7-3
122 Provides:       virtual(init-daemon)
123 Obsoletes:      SysVinit
124 Obsoletes:      readahead < 1:1.5.7-3
125 Obsoletes:      virtual(init-daemon)
126
127 %description init
128 Install this package when you are ready to final switch to systemd.
129
130 %description init -l pl.UTF-8
131 Ten pakiet należy zainstalować po przygotowaniu się do ostatecznego
132 przejścia na systemd.
133
134 %package units
135 Summary:        Configuration files, directories and installation tool for systemd
136 Summary(pl.UTF-8):      Pliki konfiguracyjne, katalogi i narzędzie instalacyjne dla systemd
137 Group:          Base
138 Requires(post): coreutils
139 Requires(post): gawk
140
141 %description units
142 Basic configuration files, directories and installation tool for the
143 systemd system and service manager.
144
145 This is common config, use %{_sysconfdir}/systemd/system to override.
146
147 %description units -l pl.UTF-8
148 Podstawowe pliki konfiguracyjne, katalogi i narzędzie instalacyjne dla
149 zarządcy systemu i usług systemd.
150
151 Ten pakiet zawiera ogólną konfigurację, ustawienia można nadpisać
152 poprzez katalog %{_sysconfdir}/systemd/system.
153
154 %package gtk
155 Summary:        Graphical frontend for systemd
156 Summary(pl.UTF-8):      Graficzny interfejs do systemd
157 Group:          Base
158 Requires:       %{name} = %{version}-%{release}
159 Requires:       polkit
160
161 %description gtk
162 Graphical front-end for systemd.
163
164 %description gtk -l pl.UTF-8
165 Graficzny interfejs do systemd.
166
167 %package libs
168 Summary:        Shared systemd libraries
169 Summary(pl.UTF-8):      Biblioteki współdzielone systemd
170 Group:          Libraries
171
172 %description libs
173 Shared systemd libraries.
174
175 %description libs -l pl.UTF-8
176 Biblioteki współdzielone systemd.
177
178 %package devel
179 Summary:        Header files for systemd libraries
180 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek systemd
181 Group:          Development/Libraries
182 Requires:       %{name}-libs = %{version}-%{release}
183
184 %description devel
185 Header files for systemd libraries.
186
187 %description devel -l pl.UTF-8
188 Pliki nagłówkowe bibliotek systemd.
189
190 %package -n bash-completion-systemd
191 Summary:        bash-completion for systemd
192 Summary(pl.UTF-8):      Bashowe dopełnianie składni dla systemd
193 Group:          Applications/Shells
194 Requires:       %{name}
195 Requires:       bash-completion
196
197 %description -n bash-completion-systemd
198 bash-completion for systemd.
199
200 %description -n bash-completion-systemd -l pl.UTF-8
201 Bashowe dopełnianie składni dla systemd
202
203 %package no-compat-tmpfiles
204 Summary:        Force update of packages that provide tmpfiles.d configuration
205 Group:          Base
206 Requires(post): sed > 4.0
207 Conflicts:      ConsoleKit-dirs < 0.4.5-7
208 Conflicts:      NetworkManager < 2:0.9.2.0-3
209 Conflicts:      Zope < 2.11.8-2
210 Conflicts:      amavisd-new < 1:2.7.0-1
211 Conflicts:      apache-base < 2.2.21-4
212 Conflicts:      apache-mod_bw < 0.92-3
213 Conflicts:      apache-mod_fastcgi < 2.4.6-6
214 Conflicts:      apache1-base < 1.3.42-5
215 Conflicts:      apache1-mod_fastcgi < 2.4.6-2
216 Conflicts:      asterisk < 10.0.1-2
217 Conflicts:      autossh-init < 1.4b-3
218 Conflicts:      balance < 3.54-2
219 Conflicts:      bind < 7:9.8.1.P1-4
220 Conflicts:      bopm < 3.1.3-4
221 Conflicts:      callweaver < 1.2.1-9
222 Conflicts:      cassandra-bin < 0.8.9-2
223 Conflicts:      clamav < 0.97.3-3
224 Conflicts:      cups < 1:1.5.0-10
225 Conflicts:      dbus < 1.4.16-4
226 Conflicts:      dovecot < 1:2.0.16-3
227 Conflicts:      dspam < 3.9.0-6
228 Conflicts:      fail2ban < 0.8.4-4
229 Conflicts:      filesystem < 4.0-3
230 Conflicts:      gammu-smsd < 1:1.31.0-3
231 Conflicts:      gdm < 2:3.2.1.1-9
232 Conflicts:      greylistd < 0.8.8-2
233 Conflicts:      inn < 2.4.6-7
234 Conflicts:      ipsec-tools < 0.8.0-3
235 Conflicts:      jabber-common < 0-9
236 Conflicts:      laptop-mode-tools < 1.58-2
237 Conflicts:      libgpod < 0.8.0-6
238 Conflicts:      libvirt-utils < 0.9.9-4
239 Conflicts:      lighttpd < 1.4.30-5
240 Conflicts:      lirc < 0.9.0-20
241 Conflicts:      mailman < 5:2.1.14-4
242 Conflicts:      memcached < 1.4.11-2
243 Conflicts:      mpd < 0.16.5-4
244 Conflicts:      mrtg < 2.17.0-3
245 Conflicts:      munin-common < 1.4.5-5
246 Conflicts:      nagios-nrpe < 2.13-2
247 Conflicts:      ndisc6-rdnssd < 1.0.1-3
248 Conflicts:      nscd < 6:2.14.1-5
249 Conflicts:      nss_ldapd-nslcd < 0.8.4-2
250 Conflicts:      openct < 0.6.20-3
251 Conflicts:      openl2tp < 1.8-3
252 Conflicts:      openldap-overlay-nssov < 2.4.28-4
253 Conflicts:      openldap-servers < 2.4.28-4
254 Conflicts:      openvpn < 2.2.2-2
255 Conflicts:      pam-pam_mount < 2.12-3
256 Conflicts:      pam-pam_ssh < 1.97-2
257 Conflicts:      pcsc-lite < 1.8.1-2
258 Conflicts:      php-dirs < 1.2-3
259 Conflicts:      policyd < 2.0.10-3
260 Conflicts:      pound < 2.6-2
261 Conflicts:      pptp < 1.7.2-3
262 Conflicts:      proftpd-common < 2:1.3.4a-2
263 Conflicts:      pulseaudio-server < 1.1-2
264 Conflicts:      quagga < 0.99.20-3
265 Conflicts:      radvd < 1.8.5-2
266 Conflicts:      rc-scripts < 0.4.5.2-3
267 Conflicts:      red5 < 0.9.0-2
268 Conflicts:      redis-server < 2.4.2-4
269 Conflicts:      smokeping < 2.4.2-10
270 Conflicts:      smtp-gated < 1.4.17-2
271 Conflicts:      socat < 1.7.2.0-2
272 Conflicts:      speech-dispatcher < 0.7.1-2
273 Conflicts:      sphinx < 2.0.3-4
274 Conflicts:      splashutils < 1.5.4.3-3
275 Conflicts:      stunnel < 4.50-2
276 Conflicts:      sudo < 1:1.7.8p2-2
277 Conflicts:      tenshi < 0.12-2
278 Conflicts:      tor < 0.2.2.35-2
279 Conflicts:      ucarp < 1.5.2-3
280 Conflicts:      udisks < 1.0.4-3
281 Conflicts:      util-vserver < 0.30.216-1.pre3002.3
282 Conflicts:      vpnc < 0.5.3-2
283 Conflicts:      web2ldap < 1.1.0rc1-2
284 Conflicts:      wesnoth-server < 1:1.10-2
285 Conflicts:      wpa_supplicant < 0.7.3-10
286 Conflicts:      xl2tpd < 1.3.0-2
287
288 %description no-compat-tmpfiles
289 Force update of packages that provide tmpfiles.d configuration
290
291 %prep
292 %setup -q
293 %patch0 -p1
294 %patch1 -p1
295 #%patch2 -p1
296 %patch3 -p1
297 %patch4 -p1
298 cp -p %{SOURCE2} src/systemd_booted.c
299
300 %build
301 %{__aclocal} -I m4
302 %{__autoconf}
303 %{__autoheader}
304 %{__automake}
305 %configure \
306         %{__enable_disable audit} \
307         %{__enable_disable cryptsetup libcryptsetup} \
308         %{__enable_disable gtk} \
309         %{__enable_disable pam} \
310         %{__enable_disable selinux} \
311         %{__enable_disable tcpd tcpwrap} \
312         --disable-silent-rules \
313         --disable-static \
314         --with-distro=pld \
315         --with-rootprefix= \
316         --with-rootlibdir=/%{_lib}
317
318 %{__make}
319 ./libtool --mode=link --tag=CC %{__cc} %{rpmcppflags} %{rpmcflags} -o systemd_booted %{rpmldflags} src/systemd_booted.c -L. -lsystemd-daemon
320
321 %install
322 rm -rf $RPM_BUILD_ROOT
323
324 %{__make} install \
325         DESTDIR=$RPM_BUILD_ROOT
326
327 ./libtool --mode=install install -m755 systemd_booted $RPM_BUILD_ROOT/bin/systemd_booted
328
329 # Create SysV compatibility symlinks. systemctl/systemd are smart
330 # enough to detect the way they were called
331 install -d $RPM_BUILD_ROOT/sbin
332 ln -s ../bin/systemd $RPM_BUILD_ROOT/sbin/init
333 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/halt
334 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/poweroff
335 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/reboot
336 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/runlevel
337 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/shutdown
338 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/telinit
339
340 ln -s ../modules $RPM_BUILD_ROOT%{_sysconfdir}/modules-load.d/modules.conf
341 # disable random and console SYSV service
342 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/random.service
343 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/console.service
344
345 # add static (non-NetworkManager) networking
346 install %{SOURCE3} $RPM_BUILD_ROOT%{systemdunitdir}/ifup@.service
347 install %{SOURCE4} $RPM_BUILD_ROOT%{systemdunitdir}/network-post.service
348 install %{SOURCE5} $RPM_BUILD_ROOT%{systemdunitdir}/network.service
349
350 # install compatibility tmpfiles configs
351 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/compat-pld-media.conf
352 install %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/compat-pld-var-run.conf
353
354 # All wants links are created at %post to make sure they are not owned
355 # and hence overriden by rpm if the user deletes them (missingok?)
356 %{__rm} -r $RPM_BUILD_ROOT%{_sysconfdir}/systemd/system/*.target.wants
357
358 # it is in rc-scripts pkg
359 %{__rm} $RPM_BUILD_ROOT%{systemdunitdir}/rc-local.service
360
361 # Make sure these directories are properly owned:
362 #       - halt,kexec,poweroff,reboot: generic ones used by ConsoleKit-systemd,
363 #       - syslog _might_ be used by some syslog implementation (none for now),
364 #       - isn't dbus populated by dbus-systemd only (so to be moved there)?
365 install -d $RPM_BUILD_ROOT%{systemdunitdir}/{dbus,halt,kexec,poweroff,reboot,syslog}.target.wants
366
367 # Create new-style configuration files so that we can ghost-own them
368 touch $RPM_BUILD_ROOT%{_sysconfdir}/{hostname,locale.conf,machine-id,machine-info,os-release,timezone,vconsole.conf}
369
370 # Install SysV conversion tool for systemd
371 install -p %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}
372
373 install -d $RPM_BUILD_ROOT/var/log
374 :> $RPM_BUILD_ROOT/var/log/btmp
375 :> $RPM_BUILD_ROOT/var/log/wtmp
376
377 %if %{without gtk}
378 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/systemadm.1*
379 %endif
380
381 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
382 %{__rm} $RPM_BUILD_ROOT/%{_lib}/security/pam_systemd.la
383 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
384
385 %clean
386 rm -rf $RPM_BUILD_ROOT
387
388 %post
389 /bin/systemd-machine-id-setup > /dev/null 2>&1 || :
390 /bin/systemctl daemon-reexec > /dev/null 2>&1 || :
391
392 %postun
393 if [ $1 -ge 1 ]; then
394         /bin/systemctl try-restart systemd-logind.service >/dev/null 2>&1 || :
395 fi
396
397 %post   libs -p /sbin/ldconfig
398 %postun libs -p /sbin/ldconfig
399
400 %post units
401 if [ $1 -eq 1 ]; then
402         # Try to read default runlevel from the old inittab if it exists
403         runlevel=$(/bin/awk -F ':' '$3 == "initdefault" && $1 !~ "^#" { print $2 }' /etc/inittab 2> /dev/null)
404         if [ -z "$runlevel" ] ; then
405                 target="%{systemdunitdir}/graphical.target"
406         else
407                 target="%{systemdunitdir}/runlevel$runlevel.target"
408         fi
409
410         # And symlink what we found to the new-style default.target
411         ln -s "$target" %{_sysconfdir}/systemd/system/default.target >/dev/null 2>&1 || :
412
413         # Setup hostname
414         [ -f /etc/sysconfig/network ] && . /etc/sysconfig/network
415         if [ -n "$HOSTNAME" -a "$HOSTNAME" != "pldmachine" ]; then
416                 [ -f /etc/hostname ] && mv -f /etc/hostname /etc/hostname.rpmsave
417                 echo $HOSTNAME > /etc/hostname
418                 chmod 644 /etc/hostname
419         fi
420 fi
421 # Enable the services we install by default.
422 /bin/systemctl enable \
423         getty@.service \
424         network.service \
425         network-post.service \
426         remote-fs.target \
427         systemd-readahead-replay.service \
428         systemd-readahead-collect.service >/dev/null 2>&1 || :
429
430 # Find and enable all installed interfaces
431 mkdir -p %{_sysconfdir}/systemd/system/network.target.wants >/dev/null 2>&1 || :
432 for f in /etc/sysconfig/interfaces/ifcfg-* ; do
433         ff=$(basename $f)
434         ff=${ff##ifcfg-}
435         case "$ff" in
436         *.rpmorig|*.rpmnew|*.rpmsave|*~|*.orig)
437                 continue
438                 ;;
439         *)
440                 DEVICE="" ; ONBOOT="" ; USERS=""
441                 . $f 2>/dev/null
442                 [ ${USERS:-no} != no ] && continue
443                 if [ "$DEVICE" = "$ff" -a ${ONBOOT:-no} = "yes" ]; then
444                         ln -s %{systemdunitdir}/ifup@.service \
445                                 %{_sysconfdir}/systemd/system/network.target.wants/ifcfg@$ff.service >/dev/null 2>&1 || :
446                 fi
447                 ;;
448         esac
449 done
450
451 %preun units
452 if [ $1 -eq 0 ] ; then
453         /bin/systemctl disable \
454                 getty@.service \
455                 network.service \
456                 network-post.service \
457                 remote-fs.target \
458                 systemd-readahead-replay.service \
459                 systemd-readahead-collect.service >/dev/null 2>&1 || :
460
461         %{__rm} -f %{_sysconfdir}/systemd/system/default.target >/dev/null 2>&1 || :
462         %{__rm} -f %{_sysconfdir}/systemd/system/network.target.wants/ifcfg@*.service >/dev/null 2>&1 || :
463 fi
464
465 %postun units
466 if [ $1 -ge 1 ]; then
467         /bin/systemctl daemon-reload > /dev/null 2>&1 || :
468 fi
469
470 %post no-compat-tmpfiles
471 %{__sed} -i -e 's/^/# /g' %{_sysconfdir}/tmpfiles.d/compat-pld-var-run.conf
472
473 %files
474 %defattr(644,root,root,755)
475 %doc DISTRO_PORTING README TODO
476 /etc/dbus-1/system.d/org.freedesktop.hostname1.conf
477 /etc/dbus-1/system.d/org.freedesktop.locale1.conf
478 /etc/dbus-1/system.d/org.freedesktop.login1.conf
479 /etc/dbus-1/system.d/org.freedesktop.systemd1.conf
480 /etc/dbus-1/system.d/org.freedesktop.timedate1.conf
481 %ghost %config(noreplace) %{_sysconfdir}/machine-id
482 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hostname
483 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/locale.conf
484 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/machine-info
485 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/os-release
486 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/timezone
487 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/vconsole.conf
488 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/systemd/*.conf
489 %dir %{_sysconfdir}/systemd/user
490 /etc/xdg/systemd
491 %attr(755,root,root) /bin/systemd
492 %attr(755,root,root) /bin/systemd-ask-password
493 %attr(755,root,root) /bin/systemd-journalctl
494 %attr(755,root,root) /bin/systemd-loginctl
495 %attr(755,root,root) /bin/systemd-machine-id-setup
496 %attr(755,root,root) /bin/systemd-notify
497 %attr(755,root,root) /bin/systemd-tty-ask-password-agent
498 %attr(755,root,root) %{_bindir}/systemd-analyze
499 %attr(755,root,root) %{_bindir}/systemd-cat
500 %attr(755,root,root) %{_bindir}/systemd-cgtop
501 %attr(755,root,root) %{_bindir}/systemd-cgls
502 %attr(755,root,root) %{_bindir}/systemd-nspawn
503 %attr(755,root,root) %{_bindir}/systemd-stdio-bridge
504 %attr(755,root,root) %{_bindir}/systemd-sysv-convert
505 %attr(755,root,root) /lib/systemd/systemd-*
506 %dir /lib/systemd/system-generators
507 %attr(755,root,root) /lib/systemd/system-generators/systemd-*-generator
508 %dir /lib/systemd/system-shutdown
509 /lib/udev/rules.d/99-systemd.rules
510 /lib/udev/rules.d/70-uaccess.rules
511 /lib/udev/rules.d/71-seat.rules
512 /lib/udev/rules.d/73-seat-late.rules
513 %dir %{_libexecdir}/systemd
514 %{_libexecdir}/systemd/user
515 %dir %{_libexecdir}/systemd/user-generators
516 %config(noreplace,missingok) %{_libexecdir}/tmpfiles.d/*.conf
517 %{_datadir}/dbus-1/interfaces/org.freedesktop.hostname1.xml
518 %{_datadir}/dbus-1/interfaces/org.freedesktop.locale1.xml
519 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.*.xml
520 %{_datadir}/dbus-1/interfaces/org.freedesktop.timedate1.xml
521 %{_datadir}/dbus-1/services/org.freedesktop.systemd1.service
522 %{_datadir}/dbus-1/system-services/org.freedesktop.hostname1.service
523 %{_datadir}/dbus-1/system-services/org.freedesktop.locale1.service
524 %{_datadir}/dbus-1/system-services/org.freedesktop.login1.service
525 %{_datadir}/dbus-1/system-services/org.freedesktop.systemd1.service
526 %{_datadir}/dbus-1/system-services/org.freedesktop.timedate1.service
527 %{_datadir}/polkit-1/actions/org.freedesktop.hostname1.policy
528 %{_datadir}/polkit-1/actions/org.freedesktop.locale1.policy
529 %{_datadir}/polkit-1/actions/org.freedesktop.login1.policy
530 %{_datadir}/polkit-1/actions/org.freedesktop.systemd1.policy
531 %{_datadir}/polkit-1/actions/org.freedesktop.timedate1.policy
532 %dir %{_datadir}/systemd
533 %{_datadir}/systemd/kbd-model-map
534 %{_mandir}/man1/systemd.1*
535 %{_mandir}/man1/systemd-*.1*
536 %{_mandir}/man3/sd_booted.3*
537 %{_mandir}/man3/sd_is_fifo.3*
538 %{_mandir}/man3/sd_is_socket.3
539 %{_mandir}/man3/sd_is_socket_inet.3
540 %{_mandir}/man3/sd_is_socket_unix.3
541 %{_mandir}/man3/sd_listen_fds.3*
542 %{_mandir}/man3/sd_notify.3*
543 %{_mandir}/man3/sd_notifyf.3
544 %{_mandir}/man3/sd_readahead.3*
545 %{_mandir}/man5/binfmt.d.5*
546 %{_mandir}/man5/hostname.5*
547 %{_mandir}/man5/locale.conf.5*
548 %{_mandir}/man5/machine-id.5*
549 %{_mandir}/man5/machine-info.5*
550 %{_mandir}/man5/modules-load.d.5*
551 %{_mandir}/man5/os-release.5*
552 %{_mandir}/man5/sysctl.d.5*
553 %{_mandir}/man5/systemd.*.5*
554 %{_mandir}/man5/systemd-logind.conf.5*
555 %{_mandir}/man5/timezone.5*
556 %{_mandir}/man5/vconsole.conf.5*
557 %{_mandir}/man7/daemon.7*
558 %{_mandir}/man7/sd-daemon.7*
559 %{_mandir}/man7/sd-login.7*
560 %{_mandir}/man7/sd-readahead.7*
561 %{_mandir}/man7/systemd.special.7*
562 %attr(640,root,root) %ghost /var/log/btmp
563 %attr(664,root,utmp) %ghost /var/log/wtmp
564
565 %if %{with pam}
566 %attr(755,root,root) /%{_lib}/security/pam_systemd.so
567 %{_mandir}/man8/pam_systemd.8*
568 %endif
569
570 %files init
571 %defattr(644,root,root,755)
572 %attr(755,root,root) /sbin/halt
573 %attr(755,root,root) /sbin/init
574 %attr(755,root,root) /sbin/poweroff
575 %attr(755,root,root) /sbin/reboot
576 %attr(755,root,root) /sbin/runlevel
577 %attr(755,root,root) /sbin/shutdown
578 %attr(755,root,root) /sbin/telinit
579 %{_mandir}/man1/init.1
580 %{_mandir}/man8/halt.8*
581 %{_mandir}/man8/poweroff.8
582 %{_mandir}/man8/reboot.8
583 %{_mandir}/man8/runlevel.8*
584 %{_mandir}/man8/shutdown.8*
585 %{_mandir}/man8/telinit.8*
586
587 %files units
588 %defattr(644,root,root,755)
589 %dir %{_sysconfdir}/binfmt.d
590 %dir %{_sysconfdir}/modules-load.d
591 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/modules-load.d/modules.conf
592 %dir %{_sysconfdir}/sysctl.d
593 %dir %{_sysconfdir}/systemd
594 %dir %{_sysconfdir}/systemd/system
595 %dir %{_sysconfdir}/tmpfiles.d
596 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/tmpfiles.d/*.conf
597 %dir %{_libexecdir}/binfmt.d
598 %dir %{_libexecdir}/modules-load.d
599 %dir %{_libexecdir}/sysctl.d
600 %{_libexecdir}/sysctl.d/coredump.conf
601 %attr(755,root,root) /bin/systemctl
602 %attr(755,root,root) /bin/systemd-tmpfiles
603 %attr(755,root,root) /bin/systemd_booted
604 %{_mandir}/man1/systemctl.1*
605 %{_mandir}/man5/tmpfiles.d.5*
606 %{_mandir}/man8/systemd-tmpfiles.8*
607 %{_npkgconfigdir}/systemd.pc
608
609 %{systemdunitdir}/*.automount
610 %{systemdunitdir}/*.mount
611 %{systemdunitdir}/*.path
612 %{systemdunitdir}/*.service
613 %{systemdunitdir}/*.socket
614 %{systemdunitdir}/*.target
615 %{systemdunitdir}/*.timer
616 %dir %{systemdunitdir}/*.wants
617 %config(noreplace,missingok) %{systemdunitdir}/*.wants/*
618
619 %if %{with gtk}
620 %files gtk
621 %defattr(644,root,root,755)
622 %attr(755,root,root) %{_bindir}/systemadm
623 %attr(755,root,root) %{_bindir}/systemd-gnome-ask-password-agent
624 %{_mandir}/man1/systemadm.1*
625 %endif
626
627 %files libs
628 %defattr(644,root,root,755)
629 %attr(755,root,root) /%{_lib}/libsystemd-daemon.so.*.*.*
630 %attr(755,root,root) %ghost /%{_lib}/libsystemd-daemon.so.0
631 %attr(755,root,root) /%{_lib}/libsystemd-id128.so.*.*.*
632 %attr(755,root,root) %ghost /%{_lib}/libsystemd-id128.so.0
633 %attr(755,root,root) /%{_lib}/libsystemd-journal.so.*.*.*
634 %attr(755,root,root) %ghost /%{_lib}/libsystemd-journal.so.0
635 %attr(755,root,root) /%{_lib}/libsystemd-login.so.*.*.*
636 %attr(755,root,root) %ghost /%{_lib}/libsystemd-login.so.0
637
638 %files devel
639 %defattr(644,root,root,755)
640 %attr(755,root,root) %{_libdir}/libsystemd-daemon.so
641 %attr(755,root,root) %{_libdir}/libsystemd-id128.so
642 %attr(755,root,root) %{_libdir}/libsystemd-journal.so
643 %attr(755,root,root) %{_libdir}/libsystemd-login.so
644 %{_includedir}/%{name}
645 %{_pkgconfigdir}/libsystemd-daemon.pc
646 %{_pkgconfigdir}/libsystemd-id128.pc
647 %{_pkgconfigdir}/libsystemd-journal.pc
648 %{_pkgconfigdir}/libsystemd-login.pc
649 %{_mandir}/man3/sd_get_seats.3*
650 %{_mandir}/man3/sd_get_sessions.3*
651 %{_mandir}/man3/sd_get_uids.3*
652 %{_mandir}/man3/sd_is_mq.3*
653 %{_mandir}/man3/sd_login_monitor_flush.3*
654 %{_mandir}/man3/sd_login_monitor_get_fd.3*
655 %{_mandir}/man3/sd_login_monitor_new.3*
656 %{_mandir}/man3/sd_login_monitor_unref.3*
657 %{_mandir}/man3/sd_pid_get_owner_uid.3*
658 %{_mandir}/man3/sd_pid_get_session.3*
659 %{_mandir}/man3/sd_pid_get_unit.3*
660 %{_mandir}/man3/sd_seat_can_multi_session.3*
661 %{_mandir}/man3/sd_seat_get_active.3*
662 %{_mandir}/man3/sd_seat_get_sessions.3*
663 %{_mandir}/man3/sd_session_get_seat.3*
664 %{_mandir}/man3/sd_session_get_uid.3*
665 %{_mandir}/man3/sd_session_is_active.3*
666 %{_mandir}/man3/sd_uid_get_seats.3*
667 %{_mandir}/man3/sd_uid_get_sessions.3*
668 %{_mandir}/man3/sd_uid_get_state.3*
669 %{_mandir}/man3/sd_uid_is_on_seat.3*
670
671 %files -n bash-completion-systemd
672 %defattr(644,root,root,755)
673 /etc/bash_completion.d/systemd-bash-completion.sh
674
675 %files no-compat-tmpfiles
676 %defattr(644,root,root,755)
677 # empty package
This page took 0.074119 seconds and 4 git commands to generate.