]> git.pld-linux.org Git - packages/systemd.git/blob - systemd.spec
- up to 44
[packages/systemd.git] / systemd.spec
1 #
2 # TODO:
3 #       - remove compat-pld-var-run.tmpfiles and maybe tmpfiles-not-fatal.patch
4 #         after enough packages provide their own tmpfiles.d configs for
5 #         /var/run directories
6 #
7 # Conditional build:
8 %bcond_without  audit           # without audit support
9 %bcond_without  cryptsetup      # without cryptsetup support
10 %bcond_without  gtk             # build gtk tools
11 %bcond_without  pam             # PAM authentication support
12 %bcond_with     plymouth        # plymouth support
13 %bcond_without  selinux         # without SELinux support
14 %bcond_without  tcpd            # libwrap (tcp_wrappers) support
15
16 Summary:        A System and Service Manager
17 Summary(pl.UTF-8):      systemd - zarządca systemu i usług dla Linuksa
18 Name:           systemd
19 Version:        44
20 Release:        1
21 License:        GPL v2+
22 Group:          Base
23 Source0:        http://www.freedesktop.org/software/systemd/%{name}-%{version}.tar.xz
24 # Source0-md5:  11f44ff74c87850064e4351518bcff17
25 Source1:        %{name}-sysv-convert
26 Source2:        %{name}_booted.c
27 Source3:        network.service
28 Source4:        compat-pld-media.tmpfiles
29 Source5:        compat-pld-var-run.tmpfiles
30 Source10:       pld-storage-init-late.service
31 Source11:       pld-storage-init.service
32 Source12:       pld-wait-storage.service
33 Source13:       pld-storage-init.sh
34 Patch0:         target-pld.patch
35 Patch1:         config-pld.patch
36 Patch2:         shut-sysv-up.patch
37 Patch3:         pld-sysv-network.patch
38 Patch4:         tmpfiles-not-fatal.patch
39 Patch5:         CVE-2012-1174.patch
40 URL:            http://www.freedesktop.org/wiki/Software/systemd
41 BuildRequires:  acl-devel
42 %{?with_audit:BuildRequires:    audit-libs-devel}
43 BuildRequires:  autoconf >= 2.63
44 BuildRequires:  automake >= 1:1.11
45 BuildRequires:  binutils >= 3:2.22.52.0.1-2
46 %{?with_cryptsetup:BuildRequires:       cryptsetup-luks-devel}
47 BuildRequires:  dbus-devel >= 1.3.2
48 BuildRequires:  docbook-style-xsl
49 BuildRequires:  gperf
50 BuildRequires:  intltool >= 0.40.0
51 BuildRequires:  kmod-devel >= 5
52 BuildRequires:  libcap-devel
53 %{?with_selinux:BuildRequires:  libselinux-devel >= 2.1.0}
54 BuildRequires:  libtool >= 2:2.2
55 %{?with_tcpd:BuildRequires:     libwrap-devel}
56 BuildRequires:  libxslt-progs
57 BuildRequires:  m4
58 %{?with_pam:BuildRequires:      pam-devel}
59 BuildRequires:  pkgconfig >= 0.9.0
60 BuildRequires:  rpmbuild(macros) >= 1.627
61 BuildRequires:  udev-devel >= 1:172
62 # not required for building from release (which contains *.c for *.vala)
63 #BuildRequires: vala >= 0.10.0
64 BuildRequires:  xz-devel
65 %if %{with gtk}
66 BuildRequires:  glib2-devel >= 1:2.26.1
67 BuildRequires:  gtk+2-devel >= 2:2.24.0
68 BuildRequires:  libgee-devel
69 BuildRequires:  libnotify-devel >= 0.7.0
70 %endif
71 Requires:       %{name}-libs = %{version}-%{release}
72 Requires:       %{name}-units = %{version}-%{release}
73 Requires:       /etc/os-release
74 Requires:       SysVinit-tools
75 Requires:       agetty
76 Requires:       dbus >= 1.4.16-6
77 Requires:       filesystem >= 4.0-2
78 Requires:       rc-scripts >= 0.4.5.1-7
79 Requires:       setup >= 2.8.0-2
80 Requires:       udev-core >= 1:175-5
81 Requires:       udev-libs >= 1:172
82 Requires:       virtual(module-tools)
83 Suggests:       ConsoleKit
84 Suggests:       fsck >= 2.20
85 Suggests:       kmod >= 5
86 Suggests:       nss_myhostname
87 # python modules required by systemd-analyze
88 Suggests:       %{name}-no-compat-tmpfiles
89 Suggests:       python-dbus
90 Suggests:       python-modules
91 Suggests:       service(klogd)
92 Suggests:       service(syslog)
93 Provides:       udev-acl
94 # systemd takes care of that and causes problems
95 Conflicts:      binfmt-detector
96 # sytemd wants pam with pam_systemd.so in system-auth...
97 Conflicts:      pam < 1:1.1.5-5
98 # ...and sudo hates it
99 Conflicts:      sudo < 1:1.7.8p2-4
100 # for prefdm script
101 Conflicts:      xinitrc-ng < 1.0
102 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
103
104 %define         _libexecdir     %{_prefix}/lib
105
106 %description
107 systemd is a system and service manager for Linux, compatible with
108 SysV and LSB init scripts. systemd provides aggressive parallelization
109 capabilities, uses socket and D-Bus activation for starting services,
110 offers on-demand starting of daemons, keeps track of processes using
111 Linux cgroups, supports snapshotting and restoring of the system
112 state, maintains mount and automount points and implements an
113 elaborate transactional dependency-based service control logic. It can
114 work as a drop-in replacement for sysvinit.
115
116 %description -l pl.UTF-8
117 systemd jest zarządcą systemu i usług dla Linuksa, kompatybilny ze
118 skryptami SysV i LSB. systemd udostępnia rozbudowane zdolności
119 paralelizacji, do uruchamiania usług używa socketów oraz D-Busa,
120 oferuje uruchamianie usług na życzenie, monitoruje procesy używając
121 linuksowych cgroups, wspomaga zapisywanie (snapshot) i odczytywanie
122 (restore) stanu systemu, zarządza (auto)mount pointami oraz
123 implementuje starannie opracowaną transakcjonalną, bazującą na
124 zależnościach logikę kontroli usług. Może pracować jako zastępca dla
125 sysvinit.
126
127 %package init
128 Summary:        systemd /sbin/init and LSB/SysV compatibility symlinks
129 Summary(pl.UTF-8):      /sbin/init z systemd i dowiązania dla kompatybilności z LSB/SysV
130 Group:          Base
131 Requires:       systemd
132 Provides:       readahead = 1:1.5.7-3
133 Provides:       virtual(init-daemon)
134 Obsoletes:      SysVinit
135 Obsoletes:      readahead < 1:1.5.7-3
136 Obsoletes:      virtual(init-daemon)
137 Conflicts:      upstart
138
139 %description init
140 Install this package when you are ready to final switch to systemd.
141
142 %description init -l pl.UTF-8
143 Ten pakiet należy zainstalować po przygotowaniu się do ostatecznego
144 przejścia na systemd.
145
146 %package units
147 Summary:        Configuration files, directories and installation tool for systemd
148 Summary(pl.UTF-8):      Pliki konfiguracyjne, katalogi i narzędzie instalacyjne dla systemd
149 Group:          Base
150 Requires(post): coreutils
151 Requires(post): /bin/awk
152
153 %description units
154 Basic configuration files, directories and installation tool for the
155 systemd system and service manager.
156
157 This is common config, use %{_sysconfdir}/systemd/system to override.
158
159 %description units -l pl.UTF-8
160 Podstawowe pliki konfiguracyjne, katalogi i narzędzie instalacyjne dla
161 zarządcy systemu i usług systemd.
162
163 Ten pakiet zawiera ogólną konfigurację, ustawienia można nadpisać
164 poprzez katalog %{_sysconfdir}/systemd/system.
165
166 %package plymouth
167 Summary:        Plymouth support units for systemd
168 Summary(pl.UTF-8):      Jednostki wspierające Plymouth dla systemd
169 Group:          Base
170 Requires:       %{name}-units = %{version}-%{release}
171
172 %description plymouth
173 Plymouth (graphical boot) support units for systemd.
174
175 %description plymouth -l pl.UTF-8
176 Jednostki wspierające Plymouth (graficzny start systemu) dla systemd.
177
178 %package gtk
179 Summary:        Graphical frontend for systemd
180 Summary(pl.UTF-8):      Graficzny interfejs do systemd
181 Group:          Base
182 Requires:       %{name} = %{version}-%{release}
183 Requires:       polkit
184
185 %description gtk
186 Graphical front-end for systemd.
187
188 %description gtk -l pl.UTF-8
189 Graficzny interfejs do systemd.
190
191 %package libs
192 Summary:        Shared systemd libraries
193 Summary(pl.UTF-8):      Biblioteki współdzielone systemd
194 Group:          Libraries
195
196 %description libs
197 Shared systemd libraries.
198
199 %description libs -l pl.UTF-8
200 Biblioteki współdzielone systemd.
201
202 %package devel
203 Summary:        Header files for systemd libraries
204 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek systemd
205 Group:          Development/Libraries
206 Requires:       %{name}-libs = %{version}-%{release}
207
208 %description devel
209 Header files for systemd libraries.
210
211 %description devel -l pl.UTF-8
212 Pliki nagłówkowe bibliotek systemd.
213
214 %package -n bash-completion-systemd
215 Summary:        bash-completion for systemd
216 Summary(pl.UTF-8):      Bashowe dopełnianie składni dla systemd
217 Group:          Applications/Shells
218 Requires:       %{name}
219 Requires:       bash-completion
220
221 %description -n bash-completion-systemd
222 bash-completion for systemd.
223
224 %description -n bash-completion-systemd -l pl.UTF-8
225 Bashowe dopełnianie składni dla systemd
226
227 %package no-compat-tmpfiles
228 Summary:        Force update of packages that provide tmpfiles.d configuration
229 Group:          Base
230 Requires(post): sed > 4.0
231 Conflicts:      ConsoleKit-dirs < 0.4.5-7
232 Conflicts:      NetworkManager < 2:0.9.2.0-3
233 Conflicts:      Zope < 2.11.8-2
234 Conflicts:      amavisd-new < 1:2.7.0-1
235 Conflicts:      apache-base < 2.2.21-4
236 Conflicts:      apache-mod_bw < 0.92-3
237 Conflicts:      apache-mod_fastcgi < 2.4.6-6
238 Conflicts:      apache1-base < 1.3.42-5
239 Conflicts:      apache1-mod_fastcgi < 2.4.6-2
240 Conflicts:      asterisk < 10.0.1-2
241 Conflicts:      autossh-init < 1.4b-3
242 Conflicts:      balance < 3.54-2
243 Conflicts:      bind < 7:9.8.1.P1-4
244 Conflicts:      bopm < 3.1.3-4
245 Conflicts:      callweaver < 1.2.1-9
246 Conflicts:      cassandra-bin < 0.8.9-2
247 Conflicts:      clamav < 0.97.3-3
248 Conflicts:      cups < 1:1.5.0-10
249 Conflicts:      dbus < 1.4.16-4
250 Conflicts:      dovecot < 1:2.0.16-3
251 Conflicts:      dspam < 3.9.0-6
252 Conflicts:      fail2ban < 0.8.4-4
253 Conflicts:      filesystem < 4.0-3
254 Conflicts:      gammu-smsd < 1:1.31.0-3
255 # Break gdm2.20 installs
256 #Conflicts:     gdm < 2:3.2.1.1-9
257 Conflicts:      greylistd < 0.8.8-2
258 Conflicts:      inn < 2.4.6-7
259 Conflicts:      ipsec-tools < 0.8.0-3
260 Conflicts:      jabber-common < 0-9
261 Conflicts:      laptop-mode-tools < 1.58-2
262 Conflicts:      libgpod < 0.8.0-6
263 Conflicts:      libvirt-utils < 0.9.9-4
264 Conflicts:      lighttpd < 1.4.30-5
265 Conflicts:      lirc < 0.9.0-20
266 Conflicts:      mailman < 5:2.1.14-4
267 Conflicts:      memcached < 1.4.11-2
268 Conflicts:      mpd < 0.16.5-4
269 Conflicts:      mrtg < 2.17.0-3
270 Conflicts:      munin-common < 1.4.5-5
271 Conflicts:      nagios-nrpe < 2.13-2
272 Conflicts:      ndisc6-rdnssd < 1.0.1-3
273 Conflicts:      nscd < 6:2.14.1-5
274 Conflicts:      nss_ldapd-nslcd < 0.8.4-2
275 Conflicts:      openct < 0.6.20-3
276 Conflicts:      openl2tp < 1.8-3
277 Conflicts:      openldap-overlay-nssov < 2.4.28-4
278 Conflicts:      openldap-servers < 2.4.28-4
279 Conflicts:      openvpn < 2.2.2-2
280 Conflicts:      pam-pam_mount < 2.12-3
281 Conflicts:      pam-pam_ssh < 1.97-2
282 Conflicts:      pcsc-lite < 1.8.1-2
283 Conflicts:      php-dirs < 1.2-3
284 Conflicts:      policyd < 2.0.10-3
285 Conflicts:      pound < 2.6-2
286 Conflicts:      pptp < 1.7.2-3
287 Conflicts:      proftpd-common < 2:1.3.4a-2
288 Conflicts:      pulseaudio-server < 1.1-2
289 Conflicts:      quagga < 0.99.20-3
290 Conflicts:      radvd < 1.8.5-2
291 Conflicts:      rc-scripts < 0.4.5.2-3
292 Conflicts:      red5 < 0.9.0-2
293 Conflicts:      redis-server < 2.4.2-4
294 Conflicts:      smokeping < 2.4.2-10
295 Conflicts:      smtp-gated < 1.4.17-2
296 Conflicts:      socat < 1.7.2.0-2
297 Conflicts:      speech-dispatcher < 0.7.1-2
298 Conflicts:      sphinx < 2.0.3-4
299 Conflicts:      splashutils < 1.5.4.3-3
300 Conflicts:      stunnel < 4.50-2
301 Conflicts:      tenshi < 0.12-2
302 Conflicts:      tor < 0.2.2.35-2
303 Conflicts:      ucarp < 1.5.2-3
304 Conflicts:      udisks < 1.0.4-3
305 Conflicts:      util-vserver < 0.30.216-1.pre3002.3
306 Conflicts:      vpnc < 0.5.3-2
307 Conflicts:      web2ldap < 1.1.0rc1-2
308 Conflicts:      wesnoth-server < 1:1.10-2
309 Conflicts:      wpa_supplicant < 0.7.3-10
310 Conflicts:      xl2tpd < 1.3.0-2
311
312 %description no-compat-tmpfiles
313 Force update of packages that provide tmpfiles.d configuration
314
315 %prep
316 %setup -q
317 %patch0 -p1
318 %patch1 -p1
319 %patch2 -p1
320 %patch3 -p1
321 %patch4 -p1
322 %patch5 -p1
323 cp -p %{SOURCE2} src/systemd_booted.c
324
325 %build
326 %{__aclocal} -I m4
327 %{__autoconf}
328 %{__autoheader}
329 %{__automake}
330 %configure \
331         %{__enable_disable audit} \
332         %{__enable_disable cryptsetup libcryptsetup} \
333         %{__enable_disable gtk} \
334         %{__enable_disable pam} \
335         %{__enable_disable plymouth} \
336         %{__enable_disable selinux} \
337         %{__enable_disable tcpd tcpwrap} \
338         --disable-silent-rules \
339         --disable-static \
340         --with-distro=pld \
341         --with-rootprefix= \
342         --with-rootlibdir=/%{_lib} \
343         --enable-split-usr
344
345 %{__make}
346 ./libtool --mode=link --tag=CC %{__cc} %{rpmcppflags} %{rpmcflags} -o systemd_booted %{rpmldflags} src/systemd_booted.c -L. -lsystemd-daemon
347
348 %install
349 rm -rf $RPM_BUILD_ROOT
350
351 %{__make} install \
352         DESTDIR=$RPM_BUILD_ROOT
353
354 ./libtool --mode=install install -m755 systemd_booted $RPM_BUILD_ROOT/bin/systemd_booted
355
356 # Main binary has been moved, but we don't want to break existing installs
357 ln -s ../lib/systemd/systemd $RPM_BUILD_ROOT/bin/systemd
358
359 # Create SysV compatibility symlinks. systemctl/systemd are smart
360 # enough to detect the way they were called
361 install -d $RPM_BUILD_ROOT/sbin
362 ln -s ../lib/systemd/systemd $RPM_BUILD_ROOT/sbin/init
363 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/halt
364 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/poweroff
365 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/reboot
366 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/runlevel
367 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/shutdown
368 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/telinit
369
370 ln -s ../modules $RPM_BUILD_ROOT%{_sysconfdir}/modules-load.d/modules.conf
371
372 # disable redundant SYSV services
373 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/allowlogin.service
374 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/console.service
375 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/cpusets.service
376 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/killall.service
377 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/netfs.service
378 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/random.service
379
380 # add static (non-NetworkManager) networking
381 install %{SOURCE3} $RPM_BUILD_ROOT%{systemdunitdir}/network.service
382
383 # install compatibility tmpfiles configs
384 install %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/compat-pld-media.conf
385 install %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/compat-pld-var-run.conf
386
387 # Install and enable storage subsystems support services (RAID, LVM, etc.)
388 install %{SOURCE10} $RPM_BUILD_ROOT%{systemdunitdir}/pld-storage-init-late.service
389 install %{SOURCE11} $RPM_BUILD_ROOT%{systemdunitdir}/pld-storage-init.service
390 install %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/pld-wait-storage.service
391 install %{SOURCE13} $RPM_BUILD_ROOT/lib/systemd/pld-storage-init
392
393 ln -s ../pld-storage-init-late.service $RPM_BUILD_ROOT%{systemdunitdir}/local-fs.target.wants/pld-storage-init-late.service
394 ln -s ../pld-storage-init.service $RPM_BUILD_ROOT%{systemdunitdir}/local-fs.target.wants/pld-storage-init.service
395
396 # Make sure these directories are properly owned:
397 #       - halt,kexec,poweroff,reboot: generic ones used by ConsoleKit-systemd,
398 #       - syslog _might_ be used by some syslog implementation (none for now),
399 #       - isn't dbus populated by dbus-systemd only (so to be moved there)?
400 install -d $RPM_BUILD_ROOT%{systemdunitdir}/{dbus,halt,kexec,poweroff,reboot,syslog}.target.wants
401
402 # Create new-style configuration files so that we can ghost-own them
403 touch $RPM_BUILD_ROOT%{_sysconfdir}/{hostname,locale.conf,machine-id,machine-info,timezone,vconsole.conf}
404
405 # Install SysV conversion tool for systemd
406 install -p %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}
407
408 install -d $RPM_BUILD_ROOT/var/log
409 :> $RPM_BUILD_ROOT/var/log/btmp
410 :> $RPM_BUILD_ROOT/var/log/wtmp
411
412 %if %{without gtk}
413 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/systemadm.1*
414 %endif
415
416 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
417 %{__rm} $RPM_BUILD_ROOT/%{_lib}/security/pam_systemd.la
418 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
419
420 %clean
421 rm -rf $RPM_BUILD_ROOT
422
423 %post
424 /bin/systemd-machine-id-setup > /dev/null 2>&1 || :
425 /bin/systemctl daemon-reexec > /dev/null 2>&1 || :
426
427 %postun
428 if [ $1 -ge 1 ]; then
429         /bin/systemctl try-restart systemd-logind.service >/dev/null 2>&1 || :
430 fi
431
432 %post   libs -p /sbin/ldconfig
433 %postun libs -p /sbin/ldconfig
434
435 %post units
436 if [ $1 -eq 1 ]; then
437         # Try to read default runlevel from the old inittab if it exists
438         runlevel=$(/bin/awk -F ':' '$3 == "initdefault" && $1 !~ "^#" { print $2 }' /etc/inittab 2> /dev/null)
439         if [ -z "$runlevel" ] ; then
440                 target="%{systemdunitdir}/graphical.target"
441         else
442                 target="%{systemdunitdir}/runlevel$runlevel.target"
443         fi
444
445         # And symlink what we found to the new-style default.target
446         ln -s "$target" %{_sysconfdir}/systemd/system/default.target >/dev/null 2>&1 || :
447
448         # Setup hostname
449         [ -f /etc/sysconfig/network ] && . /etc/sysconfig/network
450         if [ -n "$HOSTNAME" -a "$HOSTNAME" != "pldmachine" ]; then
451                 [ -f /etc/hostname ] && mv -f /etc/hostname /etc/hostname.rpmsave
452                 echo $HOSTNAME > /etc/hostname
453                 chmod 644 /etc/hostname
454         fi
455
456         # Enable the services we install by default.
457         /bin/systemctl enable \
458                 getty@.service \
459                 network.service \
460                 remote-fs.target \
461                 systemd-readahead-replay.service \
462                 systemd-readahead-collect.service >/dev/null 2>&1 || :
463 fi
464
465 %preun units
466 if [ $1 -eq 0 ] ; then
467         /bin/systemctl disable \
468                 getty@.service \
469                 network.service \
470                 remote-fs.target \
471                 systemd-readahead-replay.service \
472                 systemd-readahead-collect.service >/dev/null 2>&1 || :
473
474         %{__rm} -f %{_sysconfdir}/systemd/system/default.target >/dev/null 2>&1 || :
475 fi
476
477 %postun units
478 if [ $1 -ge 1 ]; then
479         /bin/systemctl daemon-reload > /dev/null 2>&1 || :
480 fi
481
482 %triggerpostun units -- %{name}-units < 43-7
483 # Remove design fialures
484 rm -f %{_sysconfdir}/systemd/system/network.target.wants/ifcfg@*.service >/dev/null 2>&1 || :
485 rm -f %{_sysconfdir}/systemd/system/network.target.wants/network-post.service >/dev/null 2>&1 || :
486 rm -f %{_sysconfdir}/systemd/system/multi-user.target.wants/network-post.service >/dev/null 2>&1 || :
487 /bin/systemctl reenable network.service >/dev/null 2>&1 || :
488
489 %post no-compat-tmpfiles
490 %{__sed} -i -e '/^#/!s/^/# /g' %{_sysconfdir}/tmpfiles.d/compat-pld-var-run.conf
491
492 %files
493 %defattr(644,root,root,755)
494 %doc DISTRO_PORTING README TODO
495 /etc/dbus-1/system.d/org.freedesktop.hostname1.conf
496 /etc/dbus-1/system.d/org.freedesktop.locale1.conf
497 /etc/dbus-1/system.d/org.freedesktop.login1.conf
498 /etc/dbus-1/system.d/org.freedesktop.systemd1.conf
499 /etc/dbus-1/system.d/org.freedesktop.timedate1.conf
500 %ghost %config(noreplace) %{_sysconfdir}/machine-id
501 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hostname
502 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/locale.conf
503 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/machine-info
504 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/timezone
505 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/vconsole.conf
506 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/systemd/*.conf
507 %dir %{_sysconfdir}/systemd/user
508 %dir %{_sysconfdir}/systemd/system/*.target.wants
509 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/systemd/system/*.target.wants/*.service
510 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/systemd/system/*.target.wants/*.target
511 /etc/xdg/systemd
512 %attr(755,root,root) /bin/systemd
513 %attr(755,root,root) /bin/systemd-ask-password
514 %attr(755,root,root) /bin/systemd-journalctl
515 %attr(755,root,root) /bin/systemd-loginctl
516 %attr(755,root,root) /bin/systemd-machine-id-setup
517 %attr(755,root,root) /bin/systemd-notify
518 %attr(755,root,root) /bin/systemd-tty-ask-password-agent
519 %attr(755,root,root) %{_bindir}/systemd-analyze
520 %attr(755,root,root) %{_bindir}/systemd-cat
521 %attr(755,root,root) %{_bindir}/systemd-cgtop
522 %attr(755,root,root) %{_bindir}/systemd-cgls
523 %attr(755,root,root) %{_bindir}/systemd-nspawn
524 %attr(755,root,root) %{_bindir}/systemd-stdio-bridge
525 %attr(755,root,root) %{_bindir}/systemd-sysv-convert
526 %attr(755,root,root) /lib/systemd/pld-storage-init
527 %attr(755,root,root) /lib/systemd/systemd-*
528 %dir /lib/systemd/system-generators
529 %attr(755,root,root) /lib/systemd/systemd
530 %attr(755,root,root) /lib/systemd/system-generators/systemd-*-generator
531 %dir /lib/systemd/system-shutdown
532 /lib/udev/rules.d/99-systemd.rules
533 /lib/udev/rules.d/70-uaccess.rules
534 /lib/udev/rules.d/71-seat.rules
535 /lib/udev/rules.d/73-seat-late.rules
536 %dir %{_libexecdir}/systemd
537 %{_libexecdir}/systemd/user
538 %dir %{_libexecdir}/systemd/user-generators
539 %config(noreplace,missingok) %{_libexecdir}/tmpfiles.d/*.conf
540 %{_datadir}/dbus-1/interfaces/org.freedesktop.hostname1.xml
541 %{_datadir}/dbus-1/interfaces/org.freedesktop.locale1.xml
542 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.*.xml
543 %{_datadir}/dbus-1/interfaces/org.freedesktop.timedate1.xml
544 %{_datadir}/dbus-1/services/org.freedesktop.systemd1.service
545 %{_datadir}/dbus-1/system-services/org.freedesktop.hostname1.service
546 %{_datadir}/dbus-1/system-services/org.freedesktop.locale1.service
547 %{_datadir}/dbus-1/system-services/org.freedesktop.login1.service
548 %{_datadir}/dbus-1/system-services/org.freedesktop.systemd1.service
549 %{_datadir}/dbus-1/system-services/org.freedesktop.timedate1.service
550 %{_datadir}/polkit-1/actions/org.freedesktop.hostname1.policy
551 %{_datadir}/polkit-1/actions/org.freedesktop.locale1.policy
552 %{_datadir}/polkit-1/actions/org.freedesktop.login1.policy
553 %{_datadir}/polkit-1/actions/org.freedesktop.systemd1.policy
554 %{_datadir}/polkit-1/actions/org.freedesktop.timedate1.policy
555 %dir %{_datadir}/systemd
556 %{_datadir}/systemd/kbd-model-map
557 %{_mandir}/man1/systemd.1*
558 %{_mandir}/man1/systemd-*.1*
559 %{_mandir}/man5/binfmt.d.5*
560 %{_mandir}/man5/hostname.5*
561 %{_mandir}/man5/locale.conf.5*
562 %{_mandir}/man5/machine-id.5*
563 %{_mandir}/man5/machine-info.5*
564 %{_mandir}/man5/modules-load.d.5*
565 %{_mandir}/man5/os-release.5*
566 %{_mandir}/man5/sysctl.d.5*
567 %{_mandir}/man5/systemd.*.5*
568 %{_mandir}/man5/systemd-journald.conf.5*
569 %{_mandir}/man5/systemd-logind.conf.5*
570 %{_mandir}/man5/timezone.5*
571 %{_mandir}/man5/vconsole.conf.5*
572 %{_mandir}/man7/daemon.7*
573 %{_mandir}/man7/sd-daemon.7*
574 %{_mandir}/man7/sd-login.7*
575 %{_mandir}/man7/sd-readahead.7*
576 %{_mandir}/man7/systemd.special.7*
577 %attr(640,root,root) %ghost /var/log/btmp
578 %attr(664,root,utmp) %ghost /var/log/wtmp
579
580 %if %{with pam}
581 %attr(755,root,root) /%{_lib}/security/pam_systemd.so
582 %{_mandir}/man8/pam_systemd.8*
583 %endif
584
585 %files init
586 %defattr(644,root,root,755)
587 %attr(755,root,root) /sbin/halt
588 %attr(755,root,root) /sbin/init
589 %attr(755,root,root) /sbin/poweroff
590 %attr(755,root,root) /sbin/reboot
591 %attr(755,root,root) /sbin/runlevel
592 %attr(755,root,root) /sbin/shutdown
593 %attr(755,root,root) /sbin/telinit
594 %{_mandir}/man1/init.1
595 %{_mandir}/man8/halt.8*
596 %{_mandir}/man8/poweroff.8
597 %{_mandir}/man8/reboot.8
598 %{_mandir}/man8/runlevel.8*
599 %{_mandir}/man8/shutdown.8*
600 %{_mandir}/man8/telinit.8*
601
602 %files units
603 %defattr(644,root,root,755)
604 %dir %{_sysconfdir}/binfmt.d
605 %dir %{_sysconfdir}/modules-load.d
606 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/modules-load.d/modules.conf
607 %dir %{_sysconfdir}/sysctl.d
608 %dir %{_sysconfdir}/systemd
609 %dir %{_sysconfdir}/systemd/system
610 %dir %{_sysconfdir}/tmpfiles.d
611 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/tmpfiles.d/*.conf
612 %dir %{_libexecdir}/binfmt.d
613 %dir %{_libexecdir}/modules-load.d
614 %dir %{_libexecdir}/sysctl.d
615 %{_libexecdir}/sysctl.d/coredump.conf
616 %attr(755,root,root) /bin/systemctl
617 %attr(755,root,root) /bin/systemd-tmpfiles
618 %attr(755,root,root) /bin/systemd_booted
619 %{_mandir}/man1/systemctl.1*
620 %{_mandir}/man5/tmpfiles.d.5*
621 %{_mandir}/man8/systemd-tmpfiles.8*
622 %{_npkgconfigdir}/systemd.pc
623
624 %{systemdunitdir}/*.automount
625 %{systemdunitdir}/*.mount
626 %{systemdunitdir}/*.path
627 %{systemdunitdir}/*.service
628 %{systemdunitdir}/*.socket
629 %{systemdunitdir}/*.target
630 %{systemdunitdir}/*.timer
631 %if %{with plymouth}
632 %exclude %{systemdunitdir}/plymouth*.service
633 %exclude %{systemdunitdir}/systemd-ask-password-plymouth.*
634 %endif
635 %dir %{systemdunitdir}/basic.target.wants
636 %dir %{systemdunitdir}/dbus.target.wants
637 %dir %{systemdunitdir}/final.target.wants
638 %dir %{systemdunitdir}/graphical.target.wants
639 %dir %{systemdunitdir}/halt.target.wants
640 %dir %{systemdunitdir}/kexec.target.wants
641 %dir %{systemdunitdir}/local-fs.target.wants
642 %dir %{systemdunitdir}/multi-user.target.wants
643 %dir %{systemdunitdir}/poweroff.target.wants
644 %dir %{systemdunitdir}/reboot.target.wants
645 %dir %{systemdunitdir}/runlevel[12345].target.wants
646 %dir %{systemdunitdir}/shutdown.target.wants
647 %dir %{systemdunitdir}/sockets.target.wants
648 %dir %{systemdunitdir}/sysinit.target.wants
649 %dir %{systemdunitdir}/syslog.target.wants
650 %config(noreplace,missingok) %{systemdunitdir}/basic.target.wants/*
651 %config(noreplace,missingok) %{systemdunitdir}/final.target.wants/*
652 %config(noreplace,missingok) %{systemdunitdir}/graphical.target.wants/*
653 %config(noreplace,missingok) %{systemdunitdir}/local-fs.target.wants/*
654 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/getty.target
655 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/rc-local.service
656 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/systemd-ask-password-wall.path
657 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/systemd-logind.service
658 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/systemd-user-sessions.service
659 %config(noreplace,missingok) %{systemdunitdir}/runlevel[12345].target.wants/*
660 %config(noreplace,missingok) %{systemdunitdir}/shutdown.target.wants/*
661 %config(noreplace,missingok) %{systemdunitdir}/sockets.target.wants/*
662 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/cryptsetup.target
663 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/dev-hugepages.mount
664 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/dev-mqueue.mount
665 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/proc-sys-fs-binfmt_misc.automount
666 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/sys-*.mount
667 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/systemd-*
668
669 %if %{with plymouth}
670 %files plymouth
671 %defattr(644,root,root,755)
672 %{systemdunitdir}/plymouth-halt.service
673 %{systemdunitdir}/plymouth-kexec.service
674 %{systemdunitdir}/plymouth-poweroff.service
675 %{systemdunitdir}/plymouth-quit-wait.service
676 %{systemdunitdir}/plymouth-quit.service
677 %{systemdunitdir}/plymouth-read-write.service
678 %{systemdunitdir}/plymouth-reboot.service
679 %{systemdunitdir}/plymouth-start.service
680 %{systemdunitdir}/systemd-ask-password-plymouth.path
681 %{systemdunitdir}/systemd-ask-password-plymouth.service
682 %config(noreplace,missingok) %{systemdunitdir}/halt.target.wants/plymouth-halt.service
683 %config(noreplace,missingok) %{systemdunitdir}/kexec.target.wants/plymouth-kexec.service
684 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/plymouth-quit.service
685 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/plymouth-quit-wait.service
686 %config(noreplace,missingok) %{systemdunitdir}/poweroff.target.wants/plymouth-poweroff.service
687 %config(noreplace,missingok) %{systemdunitdir}/reboot.target.wants/plymouth-reboot.service
688 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/plymouth-read-write.service
689 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/plymouth-start.service
690 %endif
691
692 %if %{with gtk}
693 %files gtk
694 %defattr(644,root,root,755)
695 %attr(755,root,root) %{_bindir}/systemadm
696 %attr(755,root,root) %{_bindir}/systemd-gnome-ask-password-agent
697 %{_mandir}/man1/systemadm.1*
698 %endif
699
700 %files libs
701 %defattr(644,root,root,755)
702 %attr(755,root,root) /%{_lib}/libsystemd-daemon.so.*.*.*
703 %attr(755,root,root) %ghost /%{_lib}/libsystemd-daemon.so.0
704 %attr(755,root,root) /%{_lib}/libsystemd-id128.so.*.*.*
705 %attr(755,root,root) %ghost /%{_lib}/libsystemd-id128.so.0
706 %attr(755,root,root) /%{_lib}/libsystemd-journal.so.*.*.*
707 %attr(755,root,root) %ghost /%{_lib}/libsystemd-journal.so.0
708 %attr(755,root,root) /%{_lib}/libsystemd-login.so.*.*.*
709 %attr(755,root,root) %ghost /%{_lib}/libsystemd-login.so.0
710
711 %files devel
712 %defattr(644,root,root,755)
713 %attr(755,root,root) %{_libdir}/libsystemd-daemon.so
714 %attr(755,root,root) %{_libdir}/libsystemd-id128.so
715 %attr(755,root,root) %{_libdir}/libsystemd-journal.so
716 %attr(755,root,root) %{_libdir}/libsystemd-login.so
717 %{_includedir}/%{name}
718 %{_pkgconfigdir}/libsystemd-daemon.pc
719 %{_pkgconfigdir}/libsystemd-id128.pc
720 %{_pkgconfigdir}/libsystemd-journal.pc
721 %{_pkgconfigdir}/libsystemd-login.pc
722 %{_mandir}/man3/sd_booted.3*
723 %{_mandir}/man3/sd_get_seats.3*
724 %{_mandir}/man3/sd_get_sessions.3*
725 %{_mandir}/man3/sd_get_uids.3*
726 %{_mandir}/man3/sd_is_fifo.3*
727 %{_mandir}/man3/sd_is_mq.3*
728 %{_mandir}/man3/sd_is_socket.3
729 %{_mandir}/man3/sd_is_socket_inet.3
730 %{_mandir}/man3/sd_is_socket_unix.3
731 %{_mandir}/man3/sd_listen_fds.3*
732 %{_mandir}/man3/sd_login_monitor_flush.3*
733 %{_mandir}/man3/sd_login_monitor_get_fd.3*
734 %{_mandir}/man3/sd_login_monitor_new.3*
735 %{_mandir}/man3/sd_login_monitor_unref.3*
736 %{_mandir}/man3/sd_notify.3*
737 %{_mandir}/man3/sd_notifyf.3
738 %{_mandir}/man3/sd_pid_get_owner_uid.3*
739 %{_mandir}/man3/sd_pid_get_session.3*
740 %{_mandir}/man3/sd_pid_get_unit.3*
741 %{_mandir}/man3/sd_readahead.3*
742 %{_mandir}/man3/sd_seat_can_multi_session.3*
743 %{_mandir}/man3/sd_seat_get_active.3*
744 %{_mandir}/man3/sd_seat_get_sessions.3*
745 %{_mandir}/man3/sd_session_get_class.3*
746 %{_mandir}/man3/sd_session_get_display.3*
747 %{_mandir}/man3/sd_session_get_seat.3*
748 %{_mandir}/man3/sd_session_get_service.3*
749 %{_mandir}/man3/sd_session_get_type.3*
750 %{_mandir}/man3/sd_session_get_uid.3*
751 %{_mandir}/man3/sd_session_is_active.3*
752 %{_mandir}/man3/sd_uid_get_seats.3*
753 %{_mandir}/man3/sd_uid_get_sessions.3*
754 %{_mandir}/man3/sd_uid_get_state.3*
755 %{_mandir}/man3/sd_uid_is_on_seat.3*
756
757 %files -n bash-completion-systemd
758 %defattr(644,root,root,755)
759 /etc/bash_completion.d/systemd-bash-completion.sh
760
761 %files no-compat-tmpfiles
762 %defattr(644,root,root,755)
763 # empty package
This page took 0.231925 seconds and 4 git commands to generate.