]> git.pld-linux.org Git - packages/systemd.git/blob - systemd.spec
- future todo
[packages/systemd.git] / systemd.spec
1 # TODO:
2 #       - remove compat-pld-var-run.tmpfiles and maybe tmpfiles-not-fatal.patch
3 #         after enough packages provide their own tmpfiles.d configs for
4 #         /var/run directories
5 # - for systemd-45+
6 #   - restore var-{run,lock}: http://cgit.freedesktop.org/systemd/systemd/commit/?id=55d029addf7d97b15faacea597a4ff65542aaf0e
7 #   - WARNING: http://cgit.freedesktop.org/systemd/systemd/commit/?id=623ac9d2fce3170125ead9be20f56bfe68ea125e
8 #
9 # Conditional build:
10 %bcond_without  audit           # without audit support
11 %bcond_without  cryptsetup      # without cryptsetup support
12 %bcond_without  pam             # PAM authentication support
13 %bcond_without  plymouth        # do not install plymouth units
14 %bcond_without  selinux         # without SELinux support
15 %bcond_without  tcpd            # libwrap (tcp_wrappers) support
16
17 Summary:        A System and Service Manager
18 Summary(pl.UTF-8):      systemd - zarządca systemu i usług dla Linuksa
19 Name:           systemd
20 Version:        44
21 Release:        11
22 License:        GPL v2+
23 Group:          Base
24 Source0:        http://www.freedesktop.org/software/systemd/%{name}-%{version}.tar.xz
25 # Source0-md5:  11f44ff74c87850064e4351518bcff17
26 Source1:        %{name}-sysv-convert
27 Source2:        %{name}_booted.c
28 Source3:        network.service
29 Source4:        compat-pld-media.tmpfiles
30 Source5:        compat-pld-var-run.tmpfiles
31 Source10:       pld-storage-init-late.service
32 Source11:       pld-storage-init.service
33 Source12:       pld-wait-storage.service
34 Source13:       pld-storage-init.sh
35 Source14:       pld-clean-tmp.service
36 Source15:       pld-clean-tmp.sh
37 Patch0:         target-pld.patch
38 Patch1:         config-pld.patch
39 Patch2:         shut-sysv-up.patch
40 Patch3:         pld-sysv-network.patch
41 Patch4:         tmpfiles-not-fatal.patch
42 Patch5:         CVE-2012-1174.patch
43 Patch6:         dont-trash-X-sessions.patch
44 Patch7:         ReleaseSession.patch
45 URL:            http://www.freedesktop.org/wiki/Software/systemd
46 BuildRequires:  acl-devel
47 %{?with_audit:BuildRequires:    audit-libs-devel}
48 BuildRequires:  autoconf >= 2.63
49 BuildRequires:  automake >= 1:1.11
50 BuildRequires:  binutils >= 3:2.22.52.0.1-2
51 %{?with_cryptsetup:BuildRequires:       cryptsetup-luks-devel}
52 BuildRequires:  dbus-devel >= 1.3.2
53 BuildRequires:  docbook-style-xsl
54 BuildRequires:  gperf
55 BuildRequires:  intltool >= 0.40.0
56 BuildRequires:  kmod-devel >= 5
57 BuildRequires:  libcap-devel
58 %{?with_selinux:BuildRequires:  libselinux-devel >= 2.1.0}
59 BuildRequires:  libtool >= 2:2.2
60 %{?with_tcpd:BuildRequires:     libwrap-devel}
61 BuildRequires:  libxslt-progs
62 BuildRequires:  m4
63 %{?with_pam:BuildRequires:      pam-devel}
64 BuildRequires:  pkgconfig >= 0.9.0
65 BuildRequires:  rpmbuild(macros) >= 1.627
66 BuildRequires:  udev-devel >= 1:172
67 BuildRequires:  xz-devel
68 Requires:       %{name}-libs = %{version}-%{release}
69 Requires:       %{name}-units = %{version}-%{release}
70 Requires:       /etc/os-release
71 Requires:       SysVinit-tools
72 Requires:       agetty
73 Requires:       dbus >= 1.4.16-6
74 Requires:       filesystem >= 4.0-2
75 Requires:       libutempter
76 Requires:       rc-scripts >= 0.4.5.3-7
77 Requires:       setup >= 2.8.0-2
78 Requires:       udev-core >= 1:175-5
79 Requires:       udev-libs >= 1:172
80 Requires:       virtual(module-tools)
81 Suggests:       %{name}-no-compat-tmpfiles
82 Suggests:       ConsoleKit
83 Suggests:       fsck >= 2.20
84 Suggests:       kmod >= 5
85 Suggests:       nss_myhostname
86 Suggests:       service(klogd)
87 Suggests:       service(syslog)
88 Provides:       udev-acl
89 # systemd takes care of that and causes problems
90 Conflicts:      binfmt-detector
91 # sytemd wants pam with pam_systemd.so in system-auth...
92 Conflicts:      pam < 1:1.1.5-5
93 # ...and sudo hates it
94 Conflicts:      sudo < 1:1.7.8p2-4
95 # for prefdm script
96 Conflicts:      xinitrc-ng < 1.0
97 # systemd scripts use options not present in older versions
98 Conflicts:      kpartx < 0.4.9-7
99 Conflicts:      multipath-tools < 0.4.9-7
100 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
101
102 %define         _libexecdir     %{_prefix}/lib
103
104 %description
105 systemd is a system and service manager for Linux, compatible with
106 SysV and LSB init scripts. systemd provides aggressive parallelization
107 capabilities, uses socket and D-Bus activation for starting services,
108 offers on-demand starting of daemons, keeps track of processes using
109 Linux cgroups, supports snapshotting and restoring of the system
110 state, maintains mount and automount points and implements an
111 elaborate transactional dependency-based service control logic. It can
112 work as a drop-in replacement for sysvinit.
113
114 %description -l pl.UTF-8
115 systemd jest zarządcą systemu i usług dla Linuksa, kompatybilny ze
116 skryptami SysV i LSB. systemd udostępnia rozbudowane zdolności
117 paralelizacji, do uruchamiania usług używa socketów oraz D-Busa,
118 oferuje uruchamianie usług na życzenie, monitoruje procesy używając
119 linuksowych cgroups, wspomaga zapisywanie (snapshot) i odczytywanie
120 (restore) stanu systemu, zarządza (auto)mount pointami oraz
121 implementuje starannie opracowaną transakcjonalną, bazującą na
122 zależnościach logikę kontroli usług. Może pracować jako zastępca dla
123 sysvinit.
124
125 %package init
126 Summary:        systemd /sbin/init and LSB/SysV compatibility symlinks
127 Summary(pl.UTF-8):      /sbin/init z systemd i dowiązania dla kompatybilności z LSB/SysV
128 Group:          Base
129 Requires:       systemd
130 Provides:       readahead = 1:1.5.7-3
131 Provides:       virtual(init-daemon)
132 Obsoletes:      SysVinit
133 Obsoletes:      readahead < 1:1.5.7-3
134 Obsoletes:      virtual(init-daemon)
135 Conflicts:      upstart
136
137 %description init
138 Install this package when you are ready to final switch to systemd.
139
140 %description init -l pl.UTF-8
141 Ten pakiet należy zainstalować po przygotowaniu się do ostatecznego
142 przejścia na systemd.
143
144 %package units
145 Summary:        Configuration files, directories and installation tool for systemd
146 Summary(pl.UTF-8):      Pliki konfiguracyjne, katalogi i narzędzie instalacyjne dla systemd
147 Group:          Base
148 Requires(post): coreutils
149 Requires(post): /bin/awk
150
151 %description units
152 Basic configuration files, directories and installation tool for the
153 systemd system and service manager.
154
155 This is common config, use %{_sysconfdir}/systemd/system to override.
156
157 %description units -l pl.UTF-8
158 Podstawowe pliki konfiguracyjne, katalogi i narzędzie instalacyjne dla
159 zarządcy systemu i usług systemd.
160
161 Ten pakiet zawiera ogólną konfigurację, ustawienia można nadpisać
162 poprzez katalog %{_sysconfdir}/systemd/system.
163
164 %package plymouth
165 Summary:        Plymouth support units for systemd
166 Summary(pl.UTF-8):      Jednostki wspierające Plymouth dla systemd
167 Group:          Base
168 Requires:       %{name}-units = %{version}-%{release}
169 Requires:       plymouth
170
171 %description plymouth
172 Plymouth (graphical boot) support units for systemd.
173
174 %description plymouth -l pl.UTF-8
175 Jednostki wspierające Plymouth (graficzny start systemu) dla systemd.
176
177 %package analyze
178 Summary:        Tool for processing systemd profiling information
179 Group:          Base
180 Requires:       %{name} = %{version}-%{release}
181 Requires:       python-dbus
182 Requires:       python-modules
183 Requires:       python-pycairo
184 Conflicts:      %{name} < 44-3
185
186 %description analyze
187 'systemd-analyze blame' lists which systemd unit needed how much time
188 to finish initialization at boot. 'systemd-analyze plot' renders an
189 SVG visualizing the parallel start of units at boot.
190
191 %package libs
192 Summary:        Shared systemd libraries
193 Summary(pl.UTF-8):      Biblioteki współdzielone systemd
194 Group:          Libraries
195
196 %description libs
197 Shared systemd libraries.
198
199 %description libs -l pl.UTF-8
200 Biblioteki współdzielone systemd.
201
202 %package devel
203 Summary:        Header files for systemd libraries
204 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek systemd
205 Group:          Development/Libraries
206 Requires:       %{name}-libs = %{version}-%{release}
207
208 %description devel
209 Header files for systemd libraries.
210
211 %description devel -l pl.UTF-8
212 Pliki nagłówkowe bibliotek systemd.
213
214 %package -n bash-completion-systemd
215 Summary:        bash-completion for systemd
216 Summary(pl.UTF-8):      Bashowe dopełnianie składni dla systemd
217 Group:          Applications/Shells
218 Requires:       %{name} = %{version}
219 Requires:       bash-completion
220
221 %description -n bash-completion-systemd
222 bash-completion for systemd.
223
224 %description -n bash-completion-systemd -l pl.UTF-8
225 Bashowe dopełnianie składni dla systemd
226
227 %package no-compat-tmpfiles
228 Summary:        Force update of packages that provide tmpfiles.d configuration
229 Group:          Base
230 Requires:       %{name} = %{version}-%{release}
231 Requires(post): sed > 4.0
232 Conflicts:      ConsoleKit-dirs < 0.4.5-7
233 Conflicts:      NetworkManager < 2:0.9.2.0-3
234 Conflicts:      Zope < 2.11.8-2
235 Conflicts:      amavisd-new < 1:2.7.0-1
236 Conflicts:      apache-base < 2.2.21-4
237 Conflicts:      apache-mod_bw < 0.92-3
238 Conflicts:      apache-mod_fastcgi < 2.4.6-6
239 Conflicts:      apache1-base < 1.3.42-5
240 Conflicts:      apache1-mod_fastcgi < 2.4.6-2
241 Conflicts:      asterisk < 10.0.1-2
242 Conflicts:      autossh-init < 1.4b-3
243 Conflicts:      balance < 3.54-2
244 Conflicts:      bind < 7:9.8.1.P1-4
245 Conflicts:      bopm < 3.1.3-4
246 Conflicts:      callweaver < 1.2.1-9
247 Conflicts:      cassandra-bin < 0.8.9-2
248 Conflicts:      clamav < 0.97.3-3
249 Conflicts:      cups < 1:1.5.0-10
250 Conflicts:      dbus < 1.4.16-4
251 Conflicts:      dovecot < 1:2.0.16-3
252 Conflicts:      dspam < 3.9.0-6
253 Conflicts:      fail2ban < 0.8.4-4
254 Conflicts:      filesystem < 4.0-3
255 Conflicts:      gammu-smsd < 1:1.31.0-3
256 # Break gdm2.20 installs
257 #Conflicts:     gdm < 2:3.2.1.1-9
258 Conflicts:      greylistd < 0.8.8-2
259 Conflicts:      inn < 2.4.6-7
260 Conflicts:      ipsec-tools < 0.8.0-3
261 Conflicts:      jabber-common < 0-9
262 Conflicts:      laptop-mode-tools < 1.58-2
263 Conflicts:      libgpod < 0.8.0-6
264 Conflicts:      libvirt-utils < 0.9.9-4
265 Conflicts:      lighttpd < 1.4.30-5
266 Conflicts:      lirc < 0.9.0-20
267 Conflicts:      mailman < 5:2.1.14-4
268 Conflicts:      memcached < 1.4.11-2
269 Conflicts:      mpd < 0.16.5-4
270 Conflicts:      mrtg < 2.17.0-3
271 Conflicts:      munin-common < 1.4.5-5
272 Conflicts:      nagios-nrpe < 2.13-2
273 Conflicts:      ndisc6-rdnssd < 1.0.1-3
274 Conflicts:      nscd < 6:2.14.1-5
275 Conflicts:      nss_ldapd-nslcd < 0.8.4-2
276 Conflicts:      openct < 0.6.20-3
277 Conflicts:      openl2tp < 1.8-3
278 Conflicts:      openldap-overlay-nssov < 2.4.28-4
279 Conflicts:      openldap-servers < 2.4.28-4
280 Conflicts:      openvpn < 2.2.2-2
281 Conflicts:      pam-pam_mount < 2.12-3
282 Conflicts:      pam-pam_ssh < 1.97-2
283 Conflicts:      pcsc-lite < 1.8.1-2
284 Conflicts:      php-dirs < 1.2-3
285 Conflicts:      policyd < 2.0.10-3
286 Conflicts:      pound < 2.6-2
287 Conflicts:      pptp < 1.7.2-3
288 Conflicts:      proftpd-common < 2:1.3.4a-2
289 Conflicts:      pulseaudio-server < 1.1-2
290 Conflicts:      quagga < 0.99.20-3
291 Conflicts:      radvd < 1.8.5-2
292 Conflicts:      rc-scripts < 0.4.5.2-3
293 Conflicts:      red5 < 0.9.0-2
294 Conflicts:      redis-server < 2.4.2-4
295 Conflicts:      smokeping < 2.4.2-10
296 Conflicts:      smtp-gated < 1.4.17-2
297 Conflicts:      socat < 1.7.2.0-2
298 Conflicts:      speech-dispatcher < 0.7.1-2
299 Conflicts:      sphinx < 2.0.3-4
300 Conflicts:      splashutils < 1.5.4.3-3
301 Conflicts:      stunnel < 4.50-2
302 Conflicts:      tenshi < 0.12-2
303 Conflicts:      tor < 0.2.2.35-2
304 Conflicts:      ucarp < 1.5.2-3
305 Conflicts:      udisks < 1.0.4-3
306 Conflicts:      util-vserver < 0.30.216-1.pre3002.3
307 Conflicts:      vpnc < 0.5.3-2
308 Conflicts:      web2ldap < 1.1.0rc1-2
309 Conflicts:      wesnoth-server < 1:1.10-2
310 Conflicts:      wpa_supplicant < 0.7.3-10
311 Conflicts:      xl2tpd < 1.3.0-2
312
313 %description no-compat-tmpfiles
314 Force update of packages that provide tmpfiles.d configuration
315
316 %prep
317 %setup -q
318 %patch0 -p1
319 %patch1 -p1
320 %patch2 -p1
321 %patch3 -p1
322 %patch4 -p1
323 %patch5 -p1
324 %patch6 -p1
325 %patch7 -p1
326 cp -p %{SOURCE2} src/systemd_booted.c
327
328 %build
329 %{__aclocal} -I m4
330 %{__autoconf}
331 %{__autoheader}
332 %{__automake}
333 %configure \
334         %{__enable_disable audit} \
335         %{__enable_disable cryptsetup libcryptsetup} \
336         --disable-gtk \
337         %{__enable_disable pam} \
338         %{__enable_disable plymouth} \
339         %{__enable_disable selinux} \
340         %{__enable_disable tcpd tcpwrap} \
341         --disable-silent-rules \
342         --disable-static \
343         --with-distro=pld \
344         --with-rootprefix= \
345         --with-rootlibdir=/%{_lib} \
346         --enable-split-usr
347
348 %{__make}
349 ./libtool --mode=link --tag=CC %{__cc} %{rpmcppflags} %{rpmcflags} -o systemd_booted %{rpmldflags} src/systemd_booted.c -L. -lsystemd-daemon
350
351 %install
352 rm -rf $RPM_BUILD_ROOT
353 install -d $RPM_BUILD_ROOT/var/lib/%{name}/coredump
354
355 %{__make} install \
356         DESTDIR=$RPM_BUILD_ROOT
357
358 ./libtool --mode=install install -p -m755 systemd_booted $RPM_BUILD_ROOT/bin/systemd_booted
359
360 # Main binary has been moved, but we don't want to break existing installs
361 ln -s ../lib/systemd/systemd $RPM_BUILD_ROOT/bin/systemd
362
363 # Create SysV compatibility symlinks. systemctl/systemd are smart
364 # enough to detect the way they were called
365 install -d $RPM_BUILD_ROOT/sbin
366 ln -s ../lib/systemd/systemd $RPM_BUILD_ROOT/sbin/init
367 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/halt
368 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/poweroff
369 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/reboot
370 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/runlevel
371 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/shutdown
372 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/telinit
373
374 ln -s ../modules $RPM_BUILD_ROOT%{_sysconfdir}/modules-load.d/modules.conf
375
376 # disable redundant SYSV services
377 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/allowlogin.service
378 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/console.service
379 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/cpusets.service
380 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/killall.service
381 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/netfs.service
382 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/random.service
383
384 # add static (non-NetworkManager) networking
385 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{systemdunitdir}/network.service
386
387 # install compatibility tmpfiles configs
388 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/compat-pld-media.conf
389 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/compat-pld-var-run.conf
390
391 # Install and enable storage subsystems support services (RAID, LVM, etc.)
392 cp -p %{SOURCE10} $RPM_BUILD_ROOT%{systemdunitdir}/pld-storage-init-late.service
393 cp -p %{SOURCE11} $RPM_BUILD_ROOT%{systemdunitdir}/pld-storage-init.service
394 cp -p %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/pld-wait-storage.service
395 cp -p %{SOURCE14} $RPM_BUILD_ROOT%{systemdunitdir}/pld-clean-tmp.service
396 install -p %{SOURCE13} $RPM_BUILD_ROOT/lib/systemd/pld-storage-init
397 install -p %{SOURCE15} $RPM_BUILD_ROOT/lib/systemd/pld-clean-tmp
398
399 ln -s ../pld-storage-init-late.service $RPM_BUILD_ROOT%{systemdunitdir}/local-fs.target.wants
400 ln -s ../pld-storage-init.service $RPM_BUILD_ROOT%{systemdunitdir}/local-fs.target.wants
401 ln -s ../pld-clean-tmp.service $RPM_BUILD_ROOT%{systemdunitdir}/local-fs.target.wants
402
403 # handled by rc-local sysv service, no need for generator
404 %{__rm} $RPM_BUILD_ROOT/lib/systemd/system-generators/systemd-rc-local-generator
405
406 # Make sure these directories are properly owned:
407 #       - halt,kexec,poweroff,reboot: generic ones used by ConsoleKit-systemd,
408 #       - syslog _might_ be used by some syslog implementation (none for now),
409 #       - isn't dbus populated by dbus-systemd only (so to be moved there)?
410 install -d $RPM_BUILD_ROOT%{systemdunitdir}/{dbus,halt,kexec,poweroff,reboot,syslog}.target.wants
411
412 # Create new-style configuration files so that we can ghost-own them
413 touch $RPM_BUILD_ROOT%{_sysconfdir}/{hostname,locale.conf,machine-id,machine-info,timezone,vconsole.conf}
414
415 # Install SysV conversion tool for systemd
416 install -p %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}
417
418 install -d $RPM_BUILD_ROOT/var/log
419 :> $RPM_BUILD_ROOT/var/log/btmp
420 :> $RPM_BUILD_ROOT/var/log/wtmp
421
422 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/systemadm.1*
423
424 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
425 %{__rm} $RPM_BUILD_ROOT/%{_lib}/security/pam_systemd.la
426 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
427
428 %clean
429 rm -rf $RPM_BUILD_ROOT
430
431 %post
432 /bin/systemd-machine-id-setup > /dev/null 2>&1 || :
433 /bin/systemctl daemon-reexec > /dev/null 2>&1 || :
434
435 %postun
436 if [ $1 -ge 1 ]; then
437         /bin/systemctl try-restart systemd-logind.service >/dev/null 2>&1 || :
438 fi
439
440 %post   libs -p /sbin/ldconfig
441 %postun libs -p /sbin/ldconfig
442
443 %post units
444 if [ $1 -eq 1 ]; then
445         # Try to read default runlevel from the old inittab if it exists
446         runlevel=$(/bin/awk -F ':' '$3 == "initdefault" && $1 !~ "^#" { print $2 }' /etc/inittab 2> /dev/null)
447         if [ -z "$runlevel" ] ; then
448                 target="%{systemdunitdir}/graphical.target"
449         else
450                 target="%{systemdunitdir}/runlevel$runlevel.target"
451         fi
452
453         # And symlink what we found to the new-style default.target
454         ln -s "$target" %{_sysconfdir}/systemd/system/default.target >/dev/null 2>&1 || :
455
456         # Setup hostname
457         [ -f /etc/sysconfig/network ] && . /etc/sysconfig/network
458         if [ -n "$HOSTNAME" -a "$HOSTNAME" != "pldmachine" ]; then
459                 [ -f /etc/hostname ] && mv -f /etc/hostname /etc/hostname.rpmsave
460                 echo $HOSTNAME > /etc/hostname
461                 chmod 644 /etc/hostname
462         fi
463
464         # Enable the services we install by default.
465         /bin/systemctl enable \
466                 getty@.service \
467                 network.service \
468                 remote-fs.target \
469                 systemd-readahead-replay.service \
470                 systemd-readahead-collect.service >/dev/null 2>&1 || :
471 fi
472
473 %preun units
474 if [ $1 -eq 0 ] ; then
475         /bin/systemctl disable \
476                 getty@.service \
477                 network.service \
478                 remote-fs.target \
479                 systemd-readahead-replay.service \
480                 systemd-readahead-collect.service >/dev/null 2>&1 || :
481
482         %{__rm} -f %{_sysconfdir}/systemd/system/default.target >/dev/null 2>&1 || :
483 fi
484
485 %postun units
486 if [ $1 -ge 1 ]; then
487         /bin/systemctl daemon-reload > /dev/null 2>&1 || :
488 fi
489
490 %triggerpostun units -- %{name}-units < 43-7
491 # Remove design fialures
492 rm -f %{_sysconfdir}/systemd/system/network.target.wants/ifcfg@*.service >/dev/null 2>&1 || :
493 rm -f %{_sysconfdir}/systemd/system/network.target.wants/network-post.service >/dev/null 2>&1 || :
494 rm -f %{_sysconfdir}/systemd/system/multi-user.target.wants/network-post.service >/dev/null 2>&1 || :
495 /bin/systemctl reenable network.service >/dev/null 2>&1 || :
496
497 %post no-compat-tmpfiles
498 %{__sed} -i -e '/^#/!s/^/# /g' %{_sysconfdir}/tmpfiles.d/compat-pld-var-run.conf
499
500 %post plymouth
501 %systemd_reload
502
503 %postun plymouth
504 %systemd_reload
505
506 %files
507 %defattr(644,root,root,755)
508 %doc DISTRO_PORTING README TODO
509 /etc/dbus-1/system.d/org.freedesktop.hostname1.conf
510 /etc/dbus-1/system.d/org.freedesktop.locale1.conf
511 /etc/dbus-1/system.d/org.freedesktop.login1.conf
512 /etc/dbus-1/system.d/org.freedesktop.systemd1.conf
513 /etc/dbus-1/system.d/org.freedesktop.timedate1.conf
514 %ghost %config(noreplace) %{_sysconfdir}/machine-id
515 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hostname
516 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/locale.conf
517 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/machine-info
518 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/timezone
519 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/vconsole.conf
520 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/systemd/*.conf
521 %dir %{_sysconfdir}/systemd/user
522 %dir %{_sysconfdir}/systemd/system/*.target.wants
523 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/systemd/system/*.target.wants/*.service
524 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/systemd/system/*.target.wants/*.target
525 /etc/xdg/systemd
526 %attr(755,root,root) /bin/systemd
527 %attr(755,root,root) /bin/systemd-ask-password
528 %attr(755,root,root) /bin/systemd-journalctl
529 %attr(755,root,root) /bin/systemd-loginctl
530 %attr(755,root,root) /bin/systemd-machine-id-setup
531 %attr(755,root,root) /bin/systemd-notify
532 %attr(755,root,root) /bin/systemd-tty-ask-password-agent
533 %attr(755,root,root) %{_bindir}/systemd-cat
534 %attr(755,root,root) %{_bindir}/systemd-cgtop
535 %attr(755,root,root) %{_bindir}/systemd-cgls
536 %attr(755,root,root) %{_bindir}/systemd-nspawn
537 %attr(755,root,root) %{_bindir}/systemd-stdio-bridge
538 %attr(755,root,root) %{_bindir}/systemd-sysv-convert
539 %attr(755,root,root) /lib/systemd/pld-clean-tmp
540 %attr(755,root,root) /lib/systemd/pld-storage-init
541 %attr(755,root,root) /lib/systemd/systemd-*
542 %dir /lib/systemd/system-generators
543 %attr(755,root,root) /lib/systemd/systemd
544 %attr(755,root,root) /lib/systemd/system-generators/systemd-*-generator
545 %dir /lib/systemd/system-shutdown
546 /lib/udev/rules.d/99-systemd.rules
547 /lib/udev/rules.d/70-uaccess.rules
548 /lib/udev/rules.d/71-seat.rules
549 /lib/udev/rules.d/73-seat-late.rules
550 %dir %{_libexecdir}/systemd
551 %{_libexecdir}/systemd/user
552 %dir %{_libexecdir}/systemd/user-generators
553 %config(noreplace,missingok) %{_libexecdir}/tmpfiles.d/*.conf
554 %{_datadir}/dbus-1/interfaces/org.freedesktop.hostname1.xml
555 %{_datadir}/dbus-1/interfaces/org.freedesktop.locale1.xml
556 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.*.xml
557 %{_datadir}/dbus-1/interfaces/org.freedesktop.timedate1.xml
558 %{_datadir}/dbus-1/services/org.freedesktop.systemd1.service
559 %{_datadir}/dbus-1/system-services/org.freedesktop.hostname1.service
560 %{_datadir}/dbus-1/system-services/org.freedesktop.locale1.service
561 %{_datadir}/dbus-1/system-services/org.freedesktop.login1.service
562 %{_datadir}/dbus-1/system-services/org.freedesktop.systemd1.service
563 %{_datadir}/dbus-1/system-services/org.freedesktop.timedate1.service
564 %{_datadir}/polkit-1/actions/org.freedesktop.hostname1.policy
565 %{_datadir}/polkit-1/actions/org.freedesktop.locale1.policy
566 %{_datadir}/polkit-1/actions/org.freedesktop.login1.policy
567 %{_datadir}/polkit-1/actions/org.freedesktop.systemd1.policy
568 %{_datadir}/polkit-1/actions/org.freedesktop.timedate1.policy
569 %dir %{_datadir}/systemd
570 %{_datadir}/systemd/kbd-model-map
571 %{_mandir}/man1/systemd.1*
572 %{_mandir}/man1/systemd-*.1*
573 %{_mandir}/man5/binfmt.d.5*
574 %{_mandir}/man5/hostname.5*
575 %{_mandir}/man5/locale.conf.5*
576 %{_mandir}/man5/machine-id.5*
577 %{_mandir}/man5/machine-info.5*
578 %{_mandir}/man5/modules-load.d.5*
579 %{_mandir}/man5/os-release.5*
580 %{_mandir}/man5/sysctl.d.5*
581 %{_mandir}/man5/systemd.*.5*
582 %{_mandir}/man5/systemd-journald.conf.5*
583 %{_mandir}/man5/systemd-logind.conf.5*
584 %{_mandir}/man5/timezone.5*
585 %{_mandir}/man5/vconsole.conf.5*
586 %{_mandir}/man7/daemon.7*
587 %{_mandir}/man7/sd-daemon.7*
588 %{_mandir}/man7/sd-login.7*
589 %{_mandir}/man7/sd-readahead.7*
590 %{_mandir}/man7/systemd.special.7*
591 %dir /var/lib/%{name}
592 %dir /var/lib/%{name}/coredump
593 %attr(640,root,root) %ghost /var/log/btmp
594 %attr(664,root,utmp) %ghost /var/log/wtmp
595
596 %if %{with pam}
597 %attr(755,root,root) /%{_lib}/security/pam_systemd.so
598 %{_mandir}/man8/pam_systemd.8*
599 %endif
600
601 %files init
602 %defattr(644,root,root,755)
603 %attr(755,root,root) /sbin/halt
604 %attr(755,root,root) /sbin/init
605 %attr(755,root,root) /sbin/poweroff
606 %attr(755,root,root) /sbin/reboot
607 %attr(755,root,root) /sbin/runlevel
608 %attr(755,root,root) /sbin/shutdown
609 %attr(755,root,root) /sbin/telinit
610 %{_mandir}/man1/init.1
611 %{_mandir}/man8/halt.8*
612 %{_mandir}/man8/poweroff.8
613 %{_mandir}/man8/reboot.8
614 %{_mandir}/man8/runlevel.8*
615 %{_mandir}/man8/shutdown.8*
616 %{_mandir}/man8/telinit.8*
617
618 %files units
619 %defattr(644,root,root,755)
620 %dir %{_sysconfdir}/binfmt.d
621 %dir %{_sysconfdir}/modules-load.d
622 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/modules-load.d/modules.conf
623 %dir %{_sysconfdir}/sysctl.d
624 %dir %{_sysconfdir}/systemd
625 %dir %{_sysconfdir}/systemd/system
626 %dir %{_sysconfdir}/tmpfiles.d
627 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/tmpfiles.d/*.conf
628 %dir %{_libexecdir}/binfmt.d
629 %dir %{_libexecdir}/modules-load.d
630 %dir %{_libexecdir}/sysctl.d
631 %{_libexecdir}/sysctl.d/coredump.conf
632 %attr(755,root,root) /bin/systemctl
633 %attr(755,root,root) /bin/systemd-tmpfiles
634 %attr(755,root,root) /bin/systemd_booted
635 %{_mandir}/man1/systemctl.1*
636 %{_mandir}/man5/tmpfiles.d.5*
637 %{_mandir}/man8/systemd-tmpfiles.8*
638 %{_npkgconfigdir}/systemd.pc
639
640 %{systemdunitdir}/*.automount
641 %{systemdunitdir}/*.mount
642 %{systemdunitdir}/*.path
643 %{systemdunitdir}/*.service
644 %{systemdunitdir}/*.socket
645 %{systemdunitdir}/*.target
646 %{systemdunitdir}/*.timer
647 %if %{with plymouth}
648 %exclude %{systemdunitdir}/plymouth*.service
649 %exclude %{systemdunitdir}/systemd-ask-password-plymouth.*
650 %endif
651 %dir %{systemdunitdir}/basic.target.wants
652 %dir %{systemdunitdir}/dbus.target.wants
653 %dir %{systemdunitdir}/final.target.wants
654 %dir %{systemdunitdir}/graphical.target.wants
655 %dir %{systemdunitdir}/halt.target.wants
656 %dir %{systemdunitdir}/kexec.target.wants
657 %dir %{systemdunitdir}/local-fs.target.wants
658 %dir %{systemdunitdir}/multi-user.target.wants
659 %dir %{systemdunitdir}/poweroff.target.wants
660 %dir %{systemdunitdir}/reboot.target.wants
661 %dir %{systemdunitdir}/runlevel[12345].target.wants
662 %dir %{systemdunitdir}/shutdown.target.wants
663 %dir %{systemdunitdir}/sockets.target.wants
664 %dir %{systemdunitdir}/sysinit.target.wants
665 %dir %{systemdunitdir}/syslog.target.wants
666 %config(noreplace,missingok) %{systemdunitdir}/basic.target.wants/*
667 %config(noreplace,missingok) %{systemdunitdir}/final.target.wants/*
668 %config(noreplace,missingok) %{systemdunitdir}/graphical.target.wants/*
669 %config(noreplace,missingok) %{systemdunitdir}/local-fs.target.wants/*
670 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/getty.target
671 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/rc-local.service
672 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/systemd-ask-password-wall.path
673 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/systemd-logind.service
674 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/systemd-user-sessions.service
675 %config(noreplace,missingok) %{systemdunitdir}/runlevel[12345].target.wants/*
676 %config(noreplace,missingok) %{systemdunitdir}/shutdown.target.wants/*
677 %config(noreplace,missingok) %{systemdunitdir}/sockets.target.wants/*
678 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/cryptsetup.target
679 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/dev-hugepages.mount
680 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/dev-mqueue.mount
681 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/proc-sys-fs-binfmt_misc.automount
682 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/sys-*.mount
683 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/systemd-*
684
685 %if %{with plymouth}
686 %files plymouth
687 %defattr(644,root,root,755)
688 %{systemdunitdir}/plymouth-halt.service
689 %{systemdunitdir}/plymouth-kexec.service
690 %{systemdunitdir}/plymouth-poweroff.service
691 %{systemdunitdir}/plymouth-quit-wait.service
692 %{systemdunitdir}/plymouth-quit.service
693 %{systemdunitdir}/plymouth-read-write.service
694 %{systemdunitdir}/plymouth-reboot.service
695 %{systemdunitdir}/plymouth-start.service
696 %{systemdunitdir}/systemd-ask-password-plymouth.path
697 %{systemdunitdir}/systemd-ask-password-plymouth.service
698 %config(noreplace,missingok) %{systemdunitdir}/halt.target.wants/plymouth-halt.service
699 %config(noreplace,missingok) %{systemdunitdir}/kexec.target.wants/plymouth-kexec.service
700 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/plymouth-quit.service
701 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/plymouth-quit-wait.service
702 %config(noreplace,missingok) %{systemdunitdir}/poweroff.target.wants/plymouth-poweroff.service
703 %config(noreplace,missingok) %{systemdunitdir}/reboot.target.wants/plymouth-reboot.service
704 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/plymouth-read-write.service
705 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/plymouth-start.service
706 %endif
707
708 %files analyze
709 %defattr(644,root,root,755)
710 %attr(755,root,root) %{_bindir}/systemd-analyze
711
712 %files libs
713 %defattr(644,root,root,755)
714 %attr(755,root,root) /%{_lib}/libsystemd-daemon.so.*.*.*
715 %attr(755,root,root) %ghost /%{_lib}/libsystemd-daemon.so.0
716 %attr(755,root,root) /%{_lib}/libsystemd-id128.so.*.*.*
717 %attr(755,root,root) %ghost /%{_lib}/libsystemd-id128.so.0
718 %attr(755,root,root) /%{_lib}/libsystemd-journal.so.*.*.*
719 %attr(755,root,root) %ghost /%{_lib}/libsystemd-journal.so.0
720 %attr(755,root,root) /%{_lib}/libsystemd-login.so.*.*.*
721 %attr(755,root,root) %ghost /%{_lib}/libsystemd-login.so.0
722
723 %files devel
724 %defattr(644,root,root,755)
725 %attr(755,root,root) %{_libdir}/libsystemd-daemon.so
726 %attr(755,root,root) %{_libdir}/libsystemd-id128.so
727 %attr(755,root,root) %{_libdir}/libsystemd-journal.so
728 %attr(755,root,root) %{_libdir}/libsystemd-login.so
729 %{_includedir}/%{name}
730 %{_pkgconfigdir}/libsystemd-daemon.pc
731 %{_pkgconfigdir}/libsystemd-id128.pc
732 %{_pkgconfigdir}/libsystemd-journal.pc
733 %{_pkgconfigdir}/libsystemd-login.pc
734 %{_mandir}/man3/sd_booted.3*
735 %{_mandir}/man3/sd_get_seats.3*
736 %{_mandir}/man3/sd_get_sessions.3*
737 %{_mandir}/man3/sd_get_uids.3*
738 %{_mandir}/man3/sd_is_fifo.3*
739 %{_mandir}/man3/sd_is_mq.3*
740 %{_mandir}/man3/sd_is_socket.3
741 %{_mandir}/man3/sd_is_socket_inet.3
742 %{_mandir}/man3/sd_is_socket_unix.3
743 %{_mandir}/man3/sd_listen_fds.3*
744 %{_mandir}/man3/sd_login_monitor_flush.3*
745 %{_mandir}/man3/sd_login_monitor_get_fd.3*
746 %{_mandir}/man3/sd_login_monitor_new.3*
747 %{_mandir}/man3/sd_login_monitor_unref.3*
748 %{_mandir}/man3/sd_notify.3*
749 %{_mandir}/man3/sd_notifyf.3
750 %{_mandir}/man3/sd_pid_get_owner_uid.3*
751 %{_mandir}/man3/sd_pid_get_session.3*
752 %{_mandir}/man3/sd_pid_get_unit.3*
753 %{_mandir}/man3/sd_readahead.3*
754 %{_mandir}/man3/sd_seat_can_multi_session.3*
755 %{_mandir}/man3/sd_seat_get_active.3*
756 %{_mandir}/man3/sd_seat_get_sessions.3*
757 %{_mandir}/man3/sd_session_get_class.3*
758 %{_mandir}/man3/sd_session_get_display.3*
759 %{_mandir}/man3/sd_session_get_seat.3*
760 %{_mandir}/man3/sd_session_get_service.3*
761 %{_mandir}/man3/sd_session_get_type.3*
762 %{_mandir}/man3/sd_session_get_uid.3*
763 %{_mandir}/man3/sd_session_is_active.3*
764 %{_mandir}/man3/sd_uid_get_seats.3*
765 %{_mandir}/man3/sd_uid_get_sessions.3*
766 %{_mandir}/man3/sd_uid_get_state.3*
767 %{_mandir}/man3/sd_uid_is_on_seat.3*
768
769 %files -n bash-completion-systemd
770 %defattr(644,root,root,755)
771 /etc/bash_completion.d/systemd-bash-completion.sh
772
773 %files no-compat-tmpfiles
774 %defattr(644,root,root,755)
775 # empty package
This page took 0.10339 seconds and 4 git commands to generate.