]> git.pld-linux.org Git - packages/systemd.git/blob - systemd.spec
4ab2615b4c23a290ae7d7e2c1f53f47d919b6377
[packages/systemd.git] / systemd.spec
1 #
2 # TODO:
3 #       - remove compat-pld-var-run.tmpfiles and maybe tmpfiles-not-fatal.patch
4 #         after enough packages provide their own tmpfiles.d configs for
5 #         /var/run directories
6 #
7 # Conditional build:
8 %bcond_without  audit           # without audit support
9 %bcond_without  cryptsetup      # without cryptsetup support
10 %bcond_without  pam             # PAM authentication support
11 %bcond_without  plymouth        # do not install plymouth units
12 %bcond_without  selinux         # without SELinux support
13 %bcond_without  tcpd            # libwrap (tcp_wrappers) support
14
15 Summary:        A System and Service Manager
16 Summary(pl.UTF-8):      systemd - zarządca systemu i usług dla Linuksa
17 Name:           systemd
18 Version:        44
19 Release:        10
20 License:        GPL v2+
21 Group:          Base
22 Source0:        http://www.freedesktop.org/software/systemd/%{name}-%{version}.tar.xz
23 # Source0-md5:  11f44ff74c87850064e4351518bcff17
24 Source1:        %{name}-sysv-convert
25 Source2:        %{name}_booted.c
26 Source3:        network.service
27 Source4:        compat-pld-media.tmpfiles
28 Source5:        compat-pld-var-run.tmpfiles
29 Source10:       pld-storage-init-late.service
30 Source11:       pld-storage-init.service
31 Source12:       pld-wait-storage.service
32 Source13:       pld-storage-init.sh
33 Source14:       pld-clean-tmp.service
34 Source15:       pld-clean-tmp.sh
35 Patch0:         target-pld.patch
36 Patch1:         config-pld.patch
37 Patch2:         shut-sysv-up.patch
38 Patch3:         pld-sysv-network.patch
39 Patch4:         tmpfiles-not-fatal.patch
40 Patch5:         CVE-2012-1174.patch
41 Patch6:         dont-trash-X-sessions.patch
42 Patch7:         ReleaseSession.patch
43 URL:            http://www.freedesktop.org/wiki/Software/systemd
44 BuildRequires:  acl-devel
45 %{?with_audit:BuildRequires:    audit-libs-devel}
46 BuildRequires:  autoconf >= 2.63
47 BuildRequires:  automake >= 1:1.11
48 BuildRequires:  binutils >= 3:2.22.52.0.1-2
49 %{?with_cryptsetup:BuildRequires:       cryptsetup-luks-devel}
50 BuildRequires:  dbus-devel >= 1.3.2
51 BuildRequires:  docbook-style-xsl
52 BuildRequires:  gperf
53 BuildRequires:  intltool >= 0.40.0
54 BuildRequires:  kmod-devel >= 5
55 BuildRequires:  libcap-devel
56 %{?with_selinux:BuildRequires:  libselinux-devel >= 2.1.0}
57 BuildRequires:  libtool >= 2:2.2
58 %{?with_tcpd:BuildRequires:     libwrap-devel}
59 BuildRequires:  libxslt-progs
60 BuildRequires:  m4
61 %{?with_pam:BuildRequires:      pam-devel}
62 BuildRequires:  pkgconfig >= 0.9.0
63 BuildRequires:  rpmbuild(macros) >= 1.627
64 BuildRequires:  udev-devel >= 1:172
65 BuildRequires:  xz-devel
66 Requires:       %{name}-libs = %{version}-%{release}
67 Requires:       %{name}-units = %{version}-%{release}
68 Requires:       /etc/os-release
69 Requires:       SysVinit-tools
70 Requires:       agetty
71 Requires:       dbus >= 1.4.16-6
72 Requires:       filesystem >= 4.0-2
73 Requires:       libutempter
74 Requires:       rc-scripts >= 0.4.5.3-7
75 Requires:       setup >= 2.8.0-2
76 Requires:       udev-core >= 1:175-5
77 Requires:       udev-libs >= 1:172
78 Requires:       virtual(module-tools)
79 Suggests:       %{name}-no-compat-tmpfiles
80 Suggests:       ConsoleKit
81 Suggests:       fsck >= 2.20
82 Suggests:       kmod >= 5
83 Suggests:       nss_myhostname
84 Suggests:       service(klogd)
85 Suggests:       service(syslog)
86 Provides:       udev-acl
87 # systemd takes care of that and causes problems
88 Conflicts:      binfmt-detector
89 # sytemd wants pam with pam_systemd.so in system-auth...
90 Conflicts:      pam < 1:1.1.5-5
91 # ...and sudo hates it
92 Conflicts:      sudo < 1:1.7.8p2-4
93 # for prefdm script
94 Conflicts:      xinitrc-ng < 1.0
95 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
96
97 %define         _libexecdir     %{_prefix}/lib
98
99 %description
100 systemd is a system and service manager for Linux, compatible with
101 SysV and LSB init scripts. systemd provides aggressive parallelization
102 capabilities, uses socket and D-Bus activation for starting services,
103 offers on-demand starting of daemons, keeps track of processes using
104 Linux cgroups, supports snapshotting and restoring of the system
105 state, maintains mount and automount points and implements an
106 elaborate transactional dependency-based service control logic. It can
107 work as a drop-in replacement for sysvinit.
108
109 %description -l pl.UTF-8
110 systemd jest zarządcą systemu i usług dla Linuksa, kompatybilny ze
111 skryptami SysV i LSB. systemd udostępnia rozbudowane zdolności
112 paralelizacji, do uruchamiania usług używa socketów oraz D-Busa,
113 oferuje uruchamianie usług na życzenie, monitoruje procesy używając
114 linuksowych cgroups, wspomaga zapisywanie (snapshot) i odczytywanie
115 (restore) stanu systemu, zarządza (auto)mount pointami oraz
116 implementuje starannie opracowaną transakcjonalną, bazującą na
117 zależnościach logikę kontroli usług. Może pracować jako zastępca dla
118 sysvinit.
119
120 %package init
121 Summary:        systemd /sbin/init and LSB/SysV compatibility symlinks
122 Summary(pl.UTF-8):      /sbin/init z systemd i dowiązania dla kompatybilności z LSB/SysV
123 Group:          Base
124 Requires:       systemd
125 Provides:       readahead = 1:1.5.7-3
126 Provides:       virtual(init-daemon)
127 Obsoletes:      SysVinit
128 Obsoletes:      readahead < 1:1.5.7-3
129 Obsoletes:      virtual(init-daemon)
130 Conflicts:      upstart
131
132 %description init
133 Install this package when you are ready to final switch to systemd.
134
135 %description init -l pl.UTF-8
136 Ten pakiet należy zainstalować po przygotowaniu się do ostatecznego
137 przejścia na systemd.
138
139 %package units
140 Summary:        Configuration files, directories and installation tool for systemd
141 Summary(pl.UTF-8):      Pliki konfiguracyjne, katalogi i narzędzie instalacyjne dla systemd
142 Group:          Base
143 Requires(post): coreutils
144 Requires(post): /bin/awk
145
146 %description units
147 Basic configuration files, directories and installation tool for the
148 systemd system and service manager.
149
150 This is common config, use %{_sysconfdir}/systemd/system to override.
151
152 %description units -l pl.UTF-8
153 Podstawowe pliki konfiguracyjne, katalogi i narzędzie instalacyjne dla
154 zarządcy systemu i usług systemd.
155
156 Ten pakiet zawiera ogólną konfigurację, ustawienia można nadpisać
157 poprzez katalog %{_sysconfdir}/systemd/system.
158
159 %package plymouth
160 Summary:        Plymouth support units for systemd
161 Summary(pl.UTF-8):      Jednostki wspierające Plymouth dla systemd
162 Group:          Base
163 Requires:       %{name}-units = %{version}-%{release}
164 Requires:       plymouth
165
166 %description plymouth
167 Plymouth (graphical boot) support units for systemd.
168
169 %description plymouth -l pl.UTF-8
170 Jednostki wspierające Plymouth (graficzny start systemu) dla systemd.
171
172 %package analyze
173 Summary:        Tool for processing systemd profiling information
174 Group:          Base
175 Requires:       %{name} = %{version}-%{release}
176 Requires:       python-dbus
177 Requires:       python-modules
178 Requires:       python-pycairo
179 Conflicts:      %{name} < 44-3
180
181 %description analyze
182 'systemd-analyze blame' lists which systemd unit needed how much time
183 to finish initialization at boot. 'systemd-analyze plot' renders an
184 SVG visualizing the parallel start of units at boot.
185
186 %package libs
187 Summary:        Shared systemd libraries
188 Summary(pl.UTF-8):      Biblioteki współdzielone systemd
189 Group:          Libraries
190
191 %description libs
192 Shared systemd libraries.
193
194 %description libs -l pl.UTF-8
195 Biblioteki współdzielone systemd.
196
197 %package devel
198 Summary:        Header files for systemd libraries
199 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek systemd
200 Group:          Development/Libraries
201 Requires:       %{name}-libs = %{version}-%{release}
202
203 %description devel
204 Header files for systemd libraries.
205
206 %description devel -l pl.UTF-8
207 Pliki nagłówkowe bibliotek systemd.
208
209 %package -n bash-completion-systemd
210 Summary:        bash-completion for systemd
211 Summary(pl.UTF-8):      Bashowe dopełnianie składni dla systemd
212 Group:          Applications/Shells
213 Requires:       %{name} = %{version}
214 Requires:       bash-completion
215
216 %description -n bash-completion-systemd
217 bash-completion for systemd.
218
219 %description -n bash-completion-systemd -l pl.UTF-8
220 Bashowe dopełnianie składni dla systemd
221
222 %package no-compat-tmpfiles
223 Summary:        Force update of packages that provide tmpfiles.d configuration
224 Group:          Base
225 Requires:       %{name} = %{version}-%{release}
226 Requires(post): sed > 4.0
227 Conflicts:      ConsoleKit-dirs < 0.4.5-7
228 Conflicts:      NetworkManager < 2:0.9.2.0-3
229 Conflicts:      Zope < 2.11.8-2
230 Conflicts:      amavisd-new < 1:2.7.0-1
231 Conflicts:      apache-base < 2.2.21-4
232 Conflicts:      apache-mod_bw < 0.92-3
233 Conflicts:      apache-mod_fastcgi < 2.4.6-6
234 Conflicts:      apache1-base < 1.3.42-5
235 Conflicts:      apache1-mod_fastcgi < 2.4.6-2
236 Conflicts:      asterisk < 10.0.1-2
237 Conflicts:      autossh-init < 1.4b-3
238 Conflicts:      balance < 3.54-2
239 Conflicts:      bind < 7:9.8.1.P1-4
240 Conflicts:      bopm < 3.1.3-4
241 Conflicts:      callweaver < 1.2.1-9
242 Conflicts:      cassandra-bin < 0.8.9-2
243 Conflicts:      clamav < 0.97.3-3
244 Conflicts:      cups < 1:1.5.0-10
245 Conflicts:      dbus < 1.4.16-4
246 Conflicts:      dovecot < 1:2.0.16-3
247 Conflicts:      dspam < 3.9.0-6
248 Conflicts:      fail2ban < 0.8.4-4
249 Conflicts:      filesystem < 4.0-3
250 Conflicts:      gammu-smsd < 1:1.31.0-3
251 # Break gdm2.20 installs
252 #Conflicts:     gdm < 2:3.2.1.1-9
253 Conflicts:      greylistd < 0.8.8-2
254 Conflicts:      inn < 2.4.6-7
255 Conflicts:      ipsec-tools < 0.8.0-3
256 Conflicts:      jabber-common < 0-9
257 Conflicts:      laptop-mode-tools < 1.58-2
258 Conflicts:      libgpod < 0.8.0-6
259 Conflicts:      libvirt-utils < 0.9.9-4
260 Conflicts:      lighttpd < 1.4.30-5
261 Conflicts:      lirc < 0.9.0-20
262 Conflicts:      mailman < 5:2.1.14-4
263 Conflicts:      memcached < 1.4.11-2
264 Conflicts:      mpd < 0.16.5-4
265 Conflicts:      mrtg < 2.17.0-3
266 Conflicts:      munin-common < 1.4.5-5
267 Conflicts:      nagios-nrpe < 2.13-2
268 Conflicts:      ndisc6-rdnssd < 1.0.1-3
269 Conflicts:      nscd < 6:2.14.1-5
270 Conflicts:      nss_ldapd-nslcd < 0.8.4-2
271 Conflicts:      openct < 0.6.20-3
272 Conflicts:      openl2tp < 1.8-3
273 Conflicts:      openldap-overlay-nssov < 2.4.28-4
274 Conflicts:      openldap-servers < 2.4.28-4
275 Conflicts:      openvpn < 2.2.2-2
276 Conflicts:      pam-pam_mount < 2.12-3
277 Conflicts:      pam-pam_ssh < 1.97-2
278 Conflicts:      pcsc-lite < 1.8.1-2
279 Conflicts:      php-dirs < 1.2-3
280 Conflicts:      policyd < 2.0.10-3
281 Conflicts:      pound < 2.6-2
282 Conflicts:      pptp < 1.7.2-3
283 Conflicts:      proftpd-common < 2:1.3.4a-2
284 Conflicts:      pulseaudio-server < 1.1-2
285 Conflicts:      quagga < 0.99.20-3
286 Conflicts:      radvd < 1.8.5-2
287 Conflicts:      rc-scripts < 0.4.5.2-3
288 Conflicts:      red5 < 0.9.0-2
289 Conflicts:      redis-server < 2.4.2-4
290 Conflicts:      smokeping < 2.4.2-10
291 Conflicts:      smtp-gated < 1.4.17-2
292 Conflicts:      socat < 1.7.2.0-2
293 Conflicts:      speech-dispatcher < 0.7.1-2
294 Conflicts:      sphinx < 2.0.3-4
295 Conflicts:      splashutils < 1.5.4.3-3
296 Conflicts:      stunnel < 4.50-2
297 Conflicts:      tenshi < 0.12-2
298 Conflicts:      tor < 0.2.2.35-2
299 Conflicts:      ucarp < 1.5.2-3
300 Conflicts:      udisks < 1.0.4-3
301 Conflicts:      util-vserver < 0.30.216-1.pre3002.3
302 Conflicts:      vpnc < 0.5.3-2
303 Conflicts:      web2ldap < 1.1.0rc1-2
304 Conflicts:      wesnoth-server < 1:1.10-2
305 Conflicts:      wpa_supplicant < 0.7.3-10
306 Conflicts:      xl2tpd < 1.3.0-2
307
308 %description no-compat-tmpfiles
309 Force update of packages that provide tmpfiles.d configuration
310
311 %prep
312 %setup -q
313 %patch0 -p1
314 %patch1 -p1
315 %patch2 -p1
316 %patch3 -p1
317 %patch4 -p1
318 %patch5 -p1
319 %patch6 -p1
320 %patch7 -p1
321 cp -p %{SOURCE2} src/systemd_booted.c
322
323 %build
324 %{__aclocal} -I m4
325 %{__autoconf}
326 %{__autoheader}
327 %{__automake}
328 %configure \
329         %{__enable_disable audit} \
330         %{__enable_disable cryptsetup libcryptsetup} \
331         --disable-gtk \
332         %{__enable_disable pam} \
333         %{__enable_disable plymouth} \
334         %{__enable_disable selinux} \
335         %{__enable_disable tcpd tcpwrap} \
336         --disable-silent-rules \
337         --disable-static \
338         --with-distro=pld \
339         --with-rootprefix= \
340         --with-rootlibdir=/%{_lib} \
341         --enable-split-usr
342
343 %{__make}
344 ./libtool --mode=link --tag=CC %{__cc} %{rpmcppflags} %{rpmcflags} -o systemd_booted %{rpmldflags} src/systemd_booted.c -L. -lsystemd-daemon
345
346 %install
347 rm -rf $RPM_BUILD_ROOT
348 install -d $RPM_BUILD_ROOT/var/lib/%{name}/coredump
349
350 %{__make} install \
351         DESTDIR=$RPM_BUILD_ROOT
352
353 ./libtool --mode=install install -p -m755 systemd_booted $RPM_BUILD_ROOT/bin/systemd_booted
354
355 # Main binary has been moved, but we don't want to break existing installs
356 ln -s ../lib/systemd/systemd $RPM_BUILD_ROOT/bin/systemd
357
358 # Create SysV compatibility symlinks. systemctl/systemd are smart
359 # enough to detect the way they were called
360 install -d $RPM_BUILD_ROOT/sbin
361 ln -s ../lib/systemd/systemd $RPM_BUILD_ROOT/sbin/init
362 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/halt
363 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/poweroff
364 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/reboot
365 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/runlevel
366 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/shutdown
367 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/telinit
368
369 ln -s ../modules $RPM_BUILD_ROOT%{_sysconfdir}/modules-load.d/modules.conf
370
371 # disable redundant SYSV services
372 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/allowlogin.service
373 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/console.service
374 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/cpusets.service
375 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/killall.service
376 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/netfs.service
377 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/random.service
378
379 # add static (non-NetworkManager) networking
380 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{systemdunitdir}/network.service
381
382 # install compatibility tmpfiles configs
383 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/compat-pld-media.conf
384 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/compat-pld-var-run.conf
385
386 # Install and enable storage subsystems support services (RAID, LVM, etc.)
387 cp -p %{SOURCE10} $RPM_BUILD_ROOT%{systemdunitdir}/pld-storage-init-late.service
388 cp -p %{SOURCE11} $RPM_BUILD_ROOT%{systemdunitdir}/pld-storage-init.service
389 cp -p %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/pld-wait-storage.service
390 cp -p %{SOURCE14} $RPM_BUILD_ROOT%{systemdunitdir}/pld-clean-tmp.service
391 install -p %{SOURCE13} $RPM_BUILD_ROOT/lib/systemd/pld-storage-init
392 install -p %{SOURCE15} $RPM_BUILD_ROOT/lib/systemd/pld-clean-tmp
393
394 ln -s ../pld-storage-init-late.service $RPM_BUILD_ROOT%{systemdunitdir}/local-fs.target.wants
395 ln -s ../pld-storage-init.service $RPM_BUILD_ROOT%{systemdunitdir}/local-fs.target.wants
396 ln -s ../pld-clean-tmp.service $RPM_BUILD_ROOT%{systemdunitdir}/local-fs.target.wants
397
398 # handled by rc-local sysv service, no need for generator
399 %{__rm} $RPM_BUILD_ROOT/lib/systemd/system-generators/systemd-rc-local-generator
400
401 # Make sure these directories are properly owned:
402 #       - halt,kexec,poweroff,reboot: generic ones used by ConsoleKit-systemd,
403 #       - syslog _might_ be used by some syslog implementation (none for now),
404 #       - isn't dbus populated by dbus-systemd only (so to be moved there)?
405 install -d $RPM_BUILD_ROOT%{systemdunitdir}/{dbus,halt,kexec,poweroff,reboot,syslog}.target.wants
406
407 # Create new-style configuration files so that we can ghost-own them
408 touch $RPM_BUILD_ROOT%{_sysconfdir}/{hostname,locale.conf,machine-id,machine-info,timezone,vconsole.conf}
409
410 # Install SysV conversion tool for systemd
411 install -p %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}
412
413 install -d $RPM_BUILD_ROOT/var/log
414 :> $RPM_BUILD_ROOT/var/log/btmp
415 :> $RPM_BUILD_ROOT/var/log/wtmp
416
417 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/systemadm.1*
418
419 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
420 %{__rm} $RPM_BUILD_ROOT/%{_lib}/security/pam_systemd.la
421 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
422
423 %clean
424 rm -rf $RPM_BUILD_ROOT
425
426 %post
427 /bin/systemd-machine-id-setup > /dev/null 2>&1 || :
428 /bin/systemctl daemon-reexec > /dev/null 2>&1 || :
429
430 %postun
431 if [ $1 -ge 1 ]; then
432         /bin/systemctl try-restart systemd-logind.service >/dev/null 2>&1 || :
433 fi
434
435 %post   libs -p /sbin/ldconfig
436 %postun libs -p /sbin/ldconfig
437
438 %post units
439 if [ $1 -eq 1 ]; then
440         # Try to read default runlevel from the old inittab if it exists
441         runlevel=$(/bin/awk -F ':' '$3 == "initdefault" && $1 !~ "^#" { print $2 }' /etc/inittab 2> /dev/null)
442         if [ -z "$runlevel" ] ; then
443                 target="%{systemdunitdir}/graphical.target"
444         else
445                 target="%{systemdunitdir}/runlevel$runlevel.target"
446         fi
447
448         # And symlink what we found to the new-style default.target
449         ln -s "$target" %{_sysconfdir}/systemd/system/default.target >/dev/null 2>&1 || :
450
451         # Setup hostname
452         [ -f /etc/sysconfig/network ] && . /etc/sysconfig/network
453         if [ -n "$HOSTNAME" -a "$HOSTNAME" != "pldmachine" ]; then
454                 [ -f /etc/hostname ] && mv -f /etc/hostname /etc/hostname.rpmsave
455                 echo $HOSTNAME > /etc/hostname
456                 chmod 644 /etc/hostname
457         fi
458
459         # Enable the services we install by default.
460         /bin/systemctl enable \
461                 getty@.service \
462                 network.service \
463                 remote-fs.target \
464                 systemd-readahead-replay.service \
465                 systemd-readahead-collect.service >/dev/null 2>&1 || :
466 fi
467
468 %preun units
469 if [ $1 -eq 0 ] ; then
470         /bin/systemctl disable \
471                 getty@.service \
472                 network.service \
473                 remote-fs.target \
474                 systemd-readahead-replay.service \
475                 systemd-readahead-collect.service >/dev/null 2>&1 || :
476
477         %{__rm} -f %{_sysconfdir}/systemd/system/default.target >/dev/null 2>&1 || :
478 fi
479
480 %postun units
481 if [ $1 -ge 1 ]; then
482         /bin/systemctl daemon-reload > /dev/null 2>&1 || :
483 fi
484
485 %triggerpostun units -- %{name}-units < 43-7
486 # Remove design fialures
487 rm -f %{_sysconfdir}/systemd/system/network.target.wants/ifcfg@*.service >/dev/null 2>&1 || :
488 rm -f %{_sysconfdir}/systemd/system/network.target.wants/network-post.service >/dev/null 2>&1 || :
489 rm -f %{_sysconfdir}/systemd/system/multi-user.target.wants/network-post.service >/dev/null 2>&1 || :
490 /bin/systemctl reenable network.service >/dev/null 2>&1 || :
491
492 %post no-compat-tmpfiles
493 %{__sed} -i -e '/^#/!s/^/# /g' %{_sysconfdir}/tmpfiles.d/compat-pld-var-run.conf
494
495 %post plymouth
496 %systemd_reload
497
498 %postun plymouth
499 %systemd_reload
500
501 %files
502 %defattr(644,root,root,755)
503 %doc DISTRO_PORTING README TODO
504 /etc/dbus-1/system.d/org.freedesktop.hostname1.conf
505 /etc/dbus-1/system.d/org.freedesktop.locale1.conf
506 /etc/dbus-1/system.d/org.freedesktop.login1.conf
507 /etc/dbus-1/system.d/org.freedesktop.systemd1.conf
508 /etc/dbus-1/system.d/org.freedesktop.timedate1.conf
509 %ghost %config(noreplace) %{_sysconfdir}/machine-id
510 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hostname
511 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/locale.conf
512 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/machine-info
513 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/timezone
514 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/vconsole.conf
515 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/systemd/*.conf
516 %dir %{_sysconfdir}/systemd/user
517 %dir %{_sysconfdir}/systemd/system/*.target.wants
518 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/systemd/system/*.target.wants/*.service
519 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/systemd/system/*.target.wants/*.target
520 /etc/xdg/systemd
521 %attr(755,root,root) /bin/systemd
522 %attr(755,root,root) /bin/systemd-ask-password
523 %attr(755,root,root) /bin/systemd-journalctl
524 %attr(755,root,root) /bin/systemd-loginctl
525 %attr(755,root,root) /bin/systemd-machine-id-setup
526 %attr(755,root,root) /bin/systemd-notify
527 %attr(755,root,root) /bin/systemd-tty-ask-password-agent
528 %attr(755,root,root) %{_bindir}/systemd-cat
529 %attr(755,root,root) %{_bindir}/systemd-cgtop
530 %attr(755,root,root) %{_bindir}/systemd-cgls
531 %attr(755,root,root) %{_bindir}/systemd-nspawn
532 %attr(755,root,root) %{_bindir}/systemd-stdio-bridge
533 %attr(755,root,root) %{_bindir}/systemd-sysv-convert
534 %attr(755,root,root) /lib/systemd/pld-clean-tmp
535 %attr(755,root,root) /lib/systemd/pld-storage-init
536 %attr(755,root,root) /lib/systemd/systemd-*
537 %dir /lib/systemd/system-generators
538 %attr(755,root,root) /lib/systemd/systemd
539 %attr(755,root,root) /lib/systemd/system-generators/systemd-*-generator
540 %dir /lib/systemd/system-shutdown
541 /lib/udev/rules.d/99-systemd.rules
542 /lib/udev/rules.d/70-uaccess.rules
543 /lib/udev/rules.d/71-seat.rules
544 /lib/udev/rules.d/73-seat-late.rules
545 %dir %{_libexecdir}/systemd
546 %{_libexecdir}/systemd/user
547 %dir %{_libexecdir}/systemd/user-generators
548 %config(noreplace,missingok) %{_libexecdir}/tmpfiles.d/*.conf
549 %{_datadir}/dbus-1/interfaces/org.freedesktop.hostname1.xml
550 %{_datadir}/dbus-1/interfaces/org.freedesktop.locale1.xml
551 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.*.xml
552 %{_datadir}/dbus-1/interfaces/org.freedesktop.timedate1.xml
553 %{_datadir}/dbus-1/services/org.freedesktop.systemd1.service
554 %{_datadir}/dbus-1/system-services/org.freedesktop.hostname1.service
555 %{_datadir}/dbus-1/system-services/org.freedesktop.locale1.service
556 %{_datadir}/dbus-1/system-services/org.freedesktop.login1.service
557 %{_datadir}/dbus-1/system-services/org.freedesktop.systemd1.service
558 %{_datadir}/dbus-1/system-services/org.freedesktop.timedate1.service
559 %{_datadir}/polkit-1/actions/org.freedesktop.hostname1.policy
560 %{_datadir}/polkit-1/actions/org.freedesktop.locale1.policy
561 %{_datadir}/polkit-1/actions/org.freedesktop.login1.policy
562 %{_datadir}/polkit-1/actions/org.freedesktop.systemd1.policy
563 %{_datadir}/polkit-1/actions/org.freedesktop.timedate1.policy
564 %dir %{_datadir}/systemd
565 %{_datadir}/systemd/kbd-model-map
566 %{_mandir}/man1/systemd.1*
567 %{_mandir}/man1/systemd-*.1*
568 %{_mandir}/man5/binfmt.d.5*
569 %{_mandir}/man5/hostname.5*
570 %{_mandir}/man5/locale.conf.5*
571 %{_mandir}/man5/machine-id.5*
572 %{_mandir}/man5/machine-info.5*
573 %{_mandir}/man5/modules-load.d.5*
574 %{_mandir}/man5/os-release.5*
575 %{_mandir}/man5/sysctl.d.5*
576 %{_mandir}/man5/systemd.*.5*
577 %{_mandir}/man5/systemd-journald.conf.5*
578 %{_mandir}/man5/systemd-logind.conf.5*
579 %{_mandir}/man5/timezone.5*
580 %{_mandir}/man5/vconsole.conf.5*
581 %{_mandir}/man7/daemon.7*
582 %{_mandir}/man7/sd-daemon.7*
583 %{_mandir}/man7/sd-login.7*
584 %{_mandir}/man7/sd-readahead.7*
585 %{_mandir}/man7/systemd.special.7*
586 %dir /var/lib/%{name}
587 %dir /var/lib/%{name}/coredump
588 %attr(640,root,root) %ghost /var/log/btmp
589 %attr(664,root,utmp) %ghost /var/log/wtmp
590
591 %if %{with pam}
592 %attr(755,root,root) /%{_lib}/security/pam_systemd.so
593 %{_mandir}/man8/pam_systemd.8*
594 %endif
595
596 %files init
597 %defattr(644,root,root,755)
598 %attr(755,root,root) /sbin/halt
599 %attr(755,root,root) /sbin/init
600 %attr(755,root,root) /sbin/poweroff
601 %attr(755,root,root) /sbin/reboot
602 %attr(755,root,root) /sbin/runlevel
603 %attr(755,root,root) /sbin/shutdown
604 %attr(755,root,root) /sbin/telinit
605 %{_mandir}/man1/init.1
606 %{_mandir}/man8/halt.8*
607 %{_mandir}/man8/poweroff.8
608 %{_mandir}/man8/reboot.8
609 %{_mandir}/man8/runlevel.8*
610 %{_mandir}/man8/shutdown.8*
611 %{_mandir}/man8/telinit.8*
612
613 %files units
614 %defattr(644,root,root,755)
615 %dir %{_sysconfdir}/binfmt.d
616 %dir %{_sysconfdir}/modules-load.d
617 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/modules-load.d/modules.conf
618 %dir %{_sysconfdir}/sysctl.d
619 %dir %{_sysconfdir}/systemd
620 %dir %{_sysconfdir}/systemd/system
621 %dir %{_sysconfdir}/tmpfiles.d
622 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/tmpfiles.d/*.conf
623 %dir %{_libexecdir}/binfmt.d
624 %dir %{_libexecdir}/modules-load.d
625 %dir %{_libexecdir}/sysctl.d
626 %{_libexecdir}/sysctl.d/coredump.conf
627 %attr(755,root,root) /bin/systemctl
628 %attr(755,root,root) /bin/systemd-tmpfiles
629 %attr(755,root,root) /bin/systemd_booted
630 %{_mandir}/man1/systemctl.1*
631 %{_mandir}/man5/tmpfiles.d.5*
632 %{_mandir}/man8/systemd-tmpfiles.8*
633 %{_npkgconfigdir}/systemd.pc
634
635 %{systemdunitdir}/*.automount
636 %{systemdunitdir}/*.mount
637 %{systemdunitdir}/*.path
638 %{systemdunitdir}/*.service
639 %{systemdunitdir}/*.socket
640 %{systemdunitdir}/*.target
641 %{systemdunitdir}/*.timer
642 %if %{with plymouth}
643 %exclude %{systemdunitdir}/plymouth*.service
644 %exclude %{systemdunitdir}/systemd-ask-password-plymouth.*
645 %endif
646 %dir %{systemdunitdir}/basic.target.wants
647 %dir %{systemdunitdir}/dbus.target.wants
648 %dir %{systemdunitdir}/final.target.wants
649 %dir %{systemdunitdir}/graphical.target.wants
650 %dir %{systemdunitdir}/halt.target.wants
651 %dir %{systemdunitdir}/kexec.target.wants
652 %dir %{systemdunitdir}/local-fs.target.wants
653 %dir %{systemdunitdir}/multi-user.target.wants
654 %dir %{systemdunitdir}/poweroff.target.wants
655 %dir %{systemdunitdir}/reboot.target.wants
656 %dir %{systemdunitdir}/runlevel[12345].target.wants
657 %dir %{systemdunitdir}/shutdown.target.wants
658 %dir %{systemdunitdir}/sockets.target.wants
659 %dir %{systemdunitdir}/sysinit.target.wants
660 %dir %{systemdunitdir}/syslog.target.wants
661 %config(noreplace,missingok) %{systemdunitdir}/basic.target.wants/*
662 %config(noreplace,missingok) %{systemdunitdir}/final.target.wants/*
663 %config(noreplace,missingok) %{systemdunitdir}/graphical.target.wants/*
664 %config(noreplace,missingok) %{systemdunitdir}/local-fs.target.wants/*
665 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/getty.target
666 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/rc-local.service
667 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/systemd-ask-password-wall.path
668 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/systemd-logind.service
669 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/systemd-user-sessions.service
670 %config(noreplace,missingok) %{systemdunitdir}/runlevel[12345].target.wants/*
671 %config(noreplace,missingok) %{systemdunitdir}/shutdown.target.wants/*
672 %config(noreplace,missingok) %{systemdunitdir}/sockets.target.wants/*
673 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/cryptsetup.target
674 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/dev-hugepages.mount
675 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/dev-mqueue.mount
676 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/proc-sys-fs-binfmt_misc.automount
677 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/sys-*.mount
678 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/systemd-*
679
680 %if %{with plymouth}
681 %files plymouth
682 %defattr(644,root,root,755)
683 %{systemdunitdir}/plymouth-halt.service
684 %{systemdunitdir}/plymouth-kexec.service
685 %{systemdunitdir}/plymouth-poweroff.service
686 %{systemdunitdir}/plymouth-quit-wait.service
687 %{systemdunitdir}/plymouth-quit.service
688 %{systemdunitdir}/plymouth-read-write.service
689 %{systemdunitdir}/plymouth-reboot.service
690 %{systemdunitdir}/plymouth-start.service
691 %{systemdunitdir}/systemd-ask-password-plymouth.path
692 %{systemdunitdir}/systemd-ask-password-plymouth.service
693 %config(noreplace,missingok) %{systemdunitdir}/halt.target.wants/plymouth-halt.service
694 %config(noreplace,missingok) %{systemdunitdir}/kexec.target.wants/plymouth-kexec.service
695 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/plymouth-quit.service
696 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/plymouth-quit-wait.service
697 %config(noreplace,missingok) %{systemdunitdir}/poweroff.target.wants/plymouth-poweroff.service
698 %config(noreplace,missingok) %{systemdunitdir}/reboot.target.wants/plymouth-reboot.service
699 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/plymouth-read-write.service
700 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/plymouth-start.service
701 %endif
702
703 %files analyze
704 %defattr(644,root,root,755)
705 %attr(755,root,root) %{_bindir}/systemd-analyze
706
707 %files libs
708 %defattr(644,root,root,755)
709 %attr(755,root,root) /%{_lib}/libsystemd-daemon.so.*.*.*
710 %attr(755,root,root) %ghost /%{_lib}/libsystemd-daemon.so.0
711 %attr(755,root,root) /%{_lib}/libsystemd-id128.so.*.*.*
712 %attr(755,root,root) %ghost /%{_lib}/libsystemd-id128.so.0
713 %attr(755,root,root) /%{_lib}/libsystemd-journal.so.*.*.*
714 %attr(755,root,root) %ghost /%{_lib}/libsystemd-journal.so.0
715 %attr(755,root,root) /%{_lib}/libsystemd-login.so.*.*.*
716 %attr(755,root,root) %ghost /%{_lib}/libsystemd-login.so.0
717
718 %files devel
719 %defattr(644,root,root,755)
720 %attr(755,root,root) %{_libdir}/libsystemd-daemon.so
721 %attr(755,root,root) %{_libdir}/libsystemd-id128.so
722 %attr(755,root,root) %{_libdir}/libsystemd-journal.so
723 %attr(755,root,root) %{_libdir}/libsystemd-login.so
724 %{_includedir}/%{name}
725 %{_pkgconfigdir}/libsystemd-daemon.pc
726 %{_pkgconfigdir}/libsystemd-id128.pc
727 %{_pkgconfigdir}/libsystemd-journal.pc
728 %{_pkgconfigdir}/libsystemd-login.pc
729 %{_mandir}/man3/sd_booted.3*
730 %{_mandir}/man3/sd_get_seats.3*
731 %{_mandir}/man3/sd_get_sessions.3*
732 %{_mandir}/man3/sd_get_uids.3*
733 %{_mandir}/man3/sd_is_fifo.3*
734 %{_mandir}/man3/sd_is_mq.3*
735 %{_mandir}/man3/sd_is_socket.3
736 %{_mandir}/man3/sd_is_socket_inet.3
737 %{_mandir}/man3/sd_is_socket_unix.3
738 %{_mandir}/man3/sd_listen_fds.3*
739 %{_mandir}/man3/sd_login_monitor_flush.3*
740 %{_mandir}/man3/sd_login_monitor_get_fd.3*
741 %{_mandir}/man3/sd_login_monitor_new.3*
742 %{_mandir}/man3/sd_login_monitor_unref.3*
743 %{_mandir}/man3/sd_notify.3*
744 %{_mandir}/man3/sd_notifyf.3
745 %{_mandir}/man3/sd_pid_get_owner_uid.3*
746 %{_mandir}/man3/sd_pid_get_session.3*
747 %{_mandir}/man3/sd_pid_get_unit.3*
748 %{_mandir}/man3/sd_readahead.3*
749 %{_mandir}/man3/sd_seat_can_multi_session.3*
750 %{_mandir}/man3/sd_seat_get_active.3*
751 %{_mandir}/man3/sd_seat_get_sessions.3*
752 %{_mandir}/man3/sd_session_get_class.3*
753 %{_mandir}/man3/sd_session_get_display.3*
754 %{_mandir}/man3/sd_session_get_seat.3*
755 %{_mandir}/man3/sd_session_get_service.3*
756 %{_mandir}/man3/sd_session_get_type.3*
757 %{_mandir}/man3/sd_session_get_uid.3*
758 %{_mandir}/man3/sd_session_is_active.3*
759 %{_mandir}/man3/sd_uid_get_seats.3*
760 %{_mandir}/man3/sd_uid_get_sessions.3*
761 %{_mandir}/man3/sd_uid_get_state.3*
762 %{_mandir}/man3/sd_uid_is_on_seat.3*
763
764 %files -n bash-completion-systemd
765 %defattr(644,root,root,755)
766 /etc/bash_completion.d/systemd-bash-completion.sh
767
768 %files no-compat-tmpfiles
769 %defattr(644,root,root,755)
770 # empty package
This page took 0.11319 seconds and 3 git commands to generate.