]> git.pld-linux.org Git - packages/systemd.git/blob - systemd.spec
147f9dd42cd3dfff169646e6628572953d827912
[packages/systemd.git] / systemd.spec
1 #
2 # TODO:
3 #       - remove compat-pld-var-run.tmpfiles and maybe tmpfiles-not-fatal.patch
4 #         after enough packages provide their own tmpfiles.d configs for
5 #         /var/run directories
6 #
7 # Conditional build:
8 %bcond_without  audit           # without audit support
9 %bcond_without  cryptsetup      # without cryptsetup support
10 %bcond_without  gtk             # build gtk tools
11 %bcond_without  pam             # PAM authentication support
12 %bcond_without  selinux         # without SELinux support
13 %bcond_without  tcpd            # libwrap (tcp_wrappers) support
14
15 Summary:        A System and Service Manager
16 Summary(pl.UTF-8):      systemd - zarządca systemu i usług dla Linuksa
17 Name:           systemd
18 Version:        39
19 Release:        3
20 License:        GPL v2+
21 Group:          Base
22 Source0:        http://www.freedesktop.org/software/systemd/%{name}-%{version}.tar.xz
23 # Source0-md5:  7179b34f6f6553d2a36551ac1dec5f0d
24 Source1:        %{name}-sysv-convert
25 Source2:        %{name}_booted.c
26 Source3:        ifup@.service
27 Source4:        network-post.service
28 Source5:        network.service
29 Source6:        compat-pld-media.tmpfiles
30 Source7:        compat-pld-var-run.tmpfiles
31 Patch0:         target-pld.patch
32 Patch1:         config-pld.patch
33 Patch2:         shut-sysv-up.patch
34 Patch3:         pld-sysv-network.patch
35 Patch4:         tmpfiles-not-fatal.patch
36 URL:            http://www.freedesktop.org/wiki/Software/systemd
37 BuildRequires:  acl-devel
38 %{?with_audit:BuildRequires:    audit-libs-devel}
39 BuildRequires:  autoconf >= 2.63
40 BuildRequires:  automake >= 1:1.11
41 %{?with_cryptsetup:BuildRequires:       cryptsetup-luks-devel}
42 BuildRequires:  dbus-devel >= 1.3.2
43 BuildRequires:  docbook-style-xsl
44 %if %{with gtk}
45 BuildRequires:  glib2-devel >= 1:2.26.1
46 BuildRequires:  gtk+2-devel >= 2:2.24.0
47 BuildRequires:  libgee-devel
48 BuildRequires:  libnotify-devel >= 0.7.0
49 %endif
50 BuildRequires:  binutils >= 3:2.22.52.0.1-2
51 BuildRequires:  gperf
52 BuildRequires:  intltool >= 0.40.0
53 BuildRequires:  libcap-devel
54 %{?with_selinux:BuildRequires:  libselinux-devel}
55 BuildRequires:  libtool >= 2:2.2
56 %{?with_tcpd:BuildRequires:     libwrap-devel}
57 BuildRequires:  libxslt-progs
58 BuildRequires:  m4
59 %{?with_pam:BuildRequires:      pam-devel}
60 BuildRequires:  pkgconfig >= 0.9.0
61 BuildRequires:  rpmbuild(macros) >= 1.627
62 BuildRequires:  udev-devel >= 1:172
63 # not required for building from release (which contains *.c for *.vala)
64 #BuildRequires: vala >= 0.10.0
65 BuildRequires:  xz-devel
66 Requires:       %{name}-libs = %{version}-%{release}
67 Requires:       %{name}-units = %{version}-%{release}
68 Requires:       SysVinit-tools
69 Requires:       agetty
70 Requires:       dbus >= 1.4.16-6
71 Requires:       filesystem >= 4.0-2
72 Requires:       rc-scripts >= 0.4.5.1-7
73 Requires:       setup >= 2.8.0-2
74 Requires:       udev-core >= 1:175-5
75 Requires:       udev-libs >= 1:172
76 Suggests:       ConsoleKit
77 Suggests:       fsck >= 2.20
78 Suggests:       nss_myhostname
79 # python modules required by systemd-analyze
80 Suggests:       %{name}-no-compat-tmpfiles
81 Suggests:       python-dbus
82 Suggests:       python-modules
83 Suggests:       service(klogd)
84 Suggests:       service(syslog)
85 Provides:       udev-acl
86 # systemd takes care of that and causes problems
87 Conflicts:      binfmt-detector
88 Conflicts:      upstart
89 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
90
91 %define         _libexecdir     %{_prefix}/lib
92
93 %description
94 systemd is a system and service manager for Linux, compatible with
95 SysV and LSB init scripts. systemd provides aggressive parallelization
96 capabilities, uses socket and D-Bus activation for starting services,
97 offers on-demand starting of daemons, keeps track of processes using
98 Linux cgroups, supports snapshotting and restoring of the system
99 state, maintains mount and automount points and implements an
100 elaborate transactional dependency-based service control logic. It can
101 work as a drop-in replacement for sysvinit.
102
103 %description -l pl.UTF-8
104 systemd jest zarządcą systemu i usług dla Linuksa, kompatybilny ze
105 skryptami SysV i LSB. systemd udostępnia rozbudowane zdolności
106 paralelizacji, do uruchamiania usług używa socketów oraz D-Busa,
107 oferuje uruchamianie usług na życzenie, monitoruje procesy używając
108 linuksowych cgroups, wspomaga zapisywanie (snapshot) i odczytywanie
109 (restore) stanu systemu, zarządza (auto)mount pointami oraz
110 implementuje starannie opracowaną transakcjonalną, bazującą na
111 zależnościach logikę kontroli usług. Może pracować jako zastępca dla
112 sysvinit.
113
114 %package init
115 Summary:        systemd /sbin/init and LSB/SysV compatibility symlinks
116 Summary(pl.UTF-8):      /sbin/init z systemd i dowiązania dla kompatybilności z LSB/SysV
117 Group:          Base
118 Requires:       systemd
119 Provides:       readahead = 1:1.5.7-3
120 Provides:       virtual(init-daemon)
121 Obsoletes:      SysVinit
122 Obsoletes:      readahead < 1:1.5.7-3
123 Obsoletes:      virtual(init-daemon)
124
125 %description init
126 Install this package when you are ready to final switch to systemd.
127
128 %description init -l pl.UTF-8
129 Ten pakiet należy zainstalować po przygotowaniu się do ostatecznego
130 przejścia na systemd.
131
132 %package units
133 Summary:        Configuration files, directories and installation tool for systemd
134 Summary(pl.UTF-8):      Pliki konfiguracyjne, katalogi i narzędzie instalacyjne dla systemd
135 Group:          Base
136 Requires(post): coreutils
137 Requires(post): gawk
138
139 %description units
140 Basic configuration files, directories and installation tool for the
141 systemd system and service manager.
142
143 This is common config, use %{_sysconfdir}/systemd/system to override.
144
145 %description units -l pl.UTF-8
146 Podstawowe pliki konfiguracyjne, katalogi i narzędzie instalacyjne dla
147 zarządcy systemu i usług systemd.
148
149 Ten pakiet zawiera ogólną konfigurację, ustawienia można nadpisać
150 poprzez katalog %{_sysconfdir}/systemd/system.
151
152 %package gtk
153 Summary:        Graphical frontend for systemd
154 Summary(pl.UTF-8):      Graficzny interfejs do systemd
155 Group:          Base
156 Requires:       %{name} = %{version}-%{release}
157 Requires:       polkit
158
159 %description gtk
160 Graphical front-end for systemd.
161
162 %description gtk -l pl.UTF-8
163 Graficzny interfejs do systemd.
164
165 %package libs
166 Summary:        Shared systemd libraries
167 Summary(pl.UTF-8):      Biblioteki współdzielone systemd
168 Group:          Libraries
169
170 %description libs
171 Shared systemd libraries.
172
173 %description libs -l pl.UTF-8
174 Biblioteki współdzielone systemd.
175
176 %package devel
177 Summary:        Header files for systemd libraries
178 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek systemd
179 Group:          Development/Libraries
180 Requires:       %{name}-libs = %{version}-%{release}
181
182 %description devel
183 Header files for systemd libraries.
184
185 %description devel -l pl.UTF-8
186 Pliki nagłówkowe bibliotek systemd.
187
188 %package -n bash-completion-systemd
189 Summary:        bash-completion for systemd
190 Summary(pl.UTF-8):      Bashowe dopełnianie składni dla systemd
191 Group:          Applications/Shells
192 Requires:       %{name}
193 Requires:       bash-completion
194
195 %description -n bash-completion-systemd
196 bash-completion for systemd.
197
198 %description -n bash-completion-systemd -l pl.UTF-8
199 Bashowe dopełnianie składni dla systemd
200
201 %package no-compat-tmpfiles
202 Summary:        Force update of packages that provide tmpfiles.d configuration
203 Group:          Base
204 Requires(post): sed > 4.0
205 Conflicts:      ConsoleKit-dirs < 0.4.5-7
206 Conflicts:      NetworkManager < 2:0.9.2.0-3
207 Conflicts:      Zope < 2.11.8-2
208 Conflicts:      amavisd-new < 1:2.7.0-1
209 Conflicts:      apache-base < 2.2.21-4
210 Conflicts:      apache-mod_bw < 0.92-3
211 Conflicts:      apache-mod_fastcgi < 2.4.6-6
212 Conflicts:      apache1-base < 1.3.42-5
213 Conflicts:      apache1-mod_fastcgi < 2.4.6-2
214 Conflicts:      asterisk < 10.0.1-2
215 Conflicts:      autossh-init < 1.4b-3
216 Conflicts:      balance < 3.54-2
217 Conflicts:      bind < 7:9.8.1.P1-4
218 Conflicts:      bopm < 3.1.3-4
219 Conflicts:      callweaver < 1.2.1-9
220 Conflicts:      cassandra-bin < 0.8.9-2
221 Conflicts:      clamav < 0.97.3-3
222 Conflicts:      cups < 1:1.5.0-10
223 Conflicts:      dbus < 1.4.16-4
224 Conflicts:      dovecot < 1:2.0.16-3
225 Conflicts:      dspam < 3.9.0-6
226 Conflicts:      fail2ban < 0.8.4-4
227 Conflicts:      filesystem < 4.0-3
228 Conflicts:      gammu-smsd < 1:1.31.0-3
229 Conflicts:      gdm < 2:3.2.1.1-9
230 Conflicts:      greylistd < 0.8.8-2
231 Conflicts:      inn < 2.4.6-7
232 Conflicts:      ipsec-tools < 0.8.0-3
233 Conflicts:      jabber-common < 0-9
234 Conflicts:      laptop-mode-tools < 1.58-2
235 Conflicts:      libgpod < 0.8.0-6
236 Conflicts:      libvirt-utils < 0.9.9-4
237 Conflicts:      lighttpd < 1.4.30-5
238 Conflicts:      lirc < 0.9.0-20
239 Conflicts:      mailman < 5:2.1.14-4
240 Conflicts:      memcached < 1.4.11-2
241 Conflicts:      mpd < 0.16.5-4
242 Conflicts:      mrtg < 2.17.0-3
243 Conflicts:      munin-common < 1.4.5-5
244 Conflicts:      nagios-nrpe < 2.13-2
245 Conflicts:      ndisc6-rdnssd < 1.0.1-3
246 Conflicts:      nscd < 6:2.14.1-5
247 Conflicts:      nss_ldapd-nslcd < 0.8.4-2
248 Conflicts:      openct < 0.6.20-3
249 Conflicts:      openl2tp < 1.8-3
250 Conflicts:      openldap-overlay-nssov < 2.4.28-4
251 Conflicts:      openldap-servers < 2.4.28-4
252 Conflicts:      openvpn < 2.2.2-2
253 Conflicts:      pam < 1:1.1.5-3
254 Conflicts:      pam-pam_mount < 2.12-3
255 Conflicts:      pam-pam_ssh < 1.97-2
256 Conflicts:      pcsc-lite < 1.8.1-2
257 Conflicts:      php-dirs < 1.2-3
258 Conflicts:      policyd < 2.0.10-3
259 Conflicts:      pound < 2.6-2
260 Conflicts:      pptp < 1.7.2-3
261 Conflicts:      proftpd-common < 2:1.3.4a-2
262 Conflicts:      pulseaudio-server < 1.1-2
263 Conflicts:      quagga < 0.99.20-3
264 Conflicts:      radvd < 1.8.5-2
265 Conflicts:      rc-scripts < 0.4.5.2-3
266 Conflicts:      red5 < 0.9.0-2
267 Conflicts:      redis-server < 2.4.2-4
268 Conflicts:      smokeping < 2.4.2-10
269 Conflicts:      smtp-gated < 1.4.17-2
270 Conflicts:      socat < 1.7.2.0-2
271 Conflicts:      speech-dispatcher < 0.7.1-2
272 Conflicts:      sphinx < 2.0.3-4
273 Conflicts:      splashutils < 1.5.4.3-3
274 Conflicts:      stunnel < 4.50-2
275 Conflicts:      sudo < 1:1.7.8p2-2
276 Conflicts:      tenshi < 0.12-2
277 Conflicts:      tor < 0.2.2.35-2
278 Conflicts:      ucarp < 1.5.2-3
279 Conflicts:      udisks < 1.0.4-3
280 Conflicts:      util-vserver < 0.30.216-1.pre3002.3
281 Conflicts:      vpnc < 0.5.3-2
282 Conflicts:      web2ldap < 1.1.0rc1-2
283 Conflicts:      wesnoth-server < 1:1.10-2
284 Conflicts:      wpa_supplicant < 0.7.3-10
285 Conflicts:      xl2tpd < 1.3.0-2
286
287 %description no-compat-tmpfiles
288 Force update of packages that provide tmpfiles.d configuration
289
290 %prep
291 %setup -q
292 %patch0 -p1
293 %patch1 -p1
294 #%patch2 -p1
295 %patch3 -p1
296 %patch4 -p1
297 cp -p %{SOURCE2} src/systemd_booted.c
298
299 %build
300 %{__aclocal} -I m4
301 %{__autoconf}
302 %{__autoheader}
303 %{__automake}
304 %configure \
305         %{__enable_disable audit} \
306         %{__enable_disable cryptsetup libcryptsetup} \
307         %{__enable_disable gtk} \
308         %{__enable_disable pam} \
309         %{__enable_disable selinux} \
310         %{__enable_disable tcpd tcpwrap} \
311         --disable-silent-rules \
312         --disable-static \
313         --with-distro=pld \
314         --with-rootprefix= \
315         --with-rootlibdir=/%{_lib}
316
317 %{__make}
318 ./libtool --mode=link --tag=CC %{__cc} %{rpmcppflags} %{rpmcflags} -o systemd_booted %{rpmldflags} src/systemd_booted.c -L. -lsystemd-daemon
319
320 %install
321 rm -rf $RPM_BUILD_ROOT
322
323 %{__make} install \
324         DESTDIR=$RPM_BUILD_ROOT
325
326 ./libtool --mode=install install -m755 systemd_booted $RPM_BUILD_ROOT/bin/systemd_booted
327
328 # Create SysV compatibility symlinks. systemctl/systemd are smart
329 # enough to detect the way they were called
330 install -d $RPM_BUILD_ROOT/sbin
331 ln -s ../bin/systemd $RPM_BUILD_ROOT/sbin/init
332 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/halt
333 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/poweroff
334 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/reboot
335 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/runlevel
336 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/shutdown
337 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/telinit
338
339 ln -s ../modules $RPM_BUILD_ROOT%{_sysconfdir}/modules-load.d/modules.conf
340 # disable random and console SYSV service
341 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/random.service
342 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/console.service
343
344 # add static (non-NetworkManager) networking
345 install %{SOURCE3} $RPM_BUILD_ROOT%{systemdunitdir}/ifup@.service
346 install %{SOURCE4} $RPM_BUILD_ROOT%{systemdunitdir}/network-post.service
347 install %{SOURCE5} $RPM_BUILD_ROOT%{systemdunitdir}/network.service
348
349 # install compatibility tmpfiles configs
350 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/compat-pld-media.conf
351 install %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/compat-pld-var-run.conf
352
353 # All wants links are created at %post to make sure they are not owned
354 # and hence overriden by rpm if the user deletes them (missingok?)
355 %{__rm} -r $RPM_BUILD_ROOT%{_sysconfdir}/systemd/system/*.target.wants
356
357 # it is in rc-scripts pkg
358 %{__rm} $RPM_BUILD_ROOT%{systemdunitdir}/rc-local.service
359
360 # Make sure these directories are properly owned:
361 #       - halt,kexec,poweroff,reboot: generic ones used by ConsoleKit-systemd,
362 #       - syslog _might_ be used by some syslog implementation (none for now),
363 #       - isn't dbus populated by dbus-systemd only (so to be moved there)?
364 install -d $RPM_BUILD_ROOT%{systemdunitdir}/{dbus,halt,kexec,poweroff,reboot,syslog}.target.wants
365
366 # Create new-style configuration files so that we can ghost-own them
367 touch $RPM_BUILD_ROOT%{_sysconfdir}/{hostname,locale.conf,machine-id,machine-info,os-release,timezone,vconsole.conf}
368
369 # Install SysV conversion tool for systemd
370 install -p %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}
371
372 install -d $RPM_BUILD_ROOT/var/log
373 :> $RPM_BUILD_ROOT/var/log/btmp
374 :> $RPM_BUILD_ROOT/var/log/wtmp
375
376 %if %{without gtk}
377 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/systemadm.1*
378 %endif
379
380 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
381 %{__rm} $RPM_BUILD_ROOT/%{_lib}/security/pam_systemd.la
382 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
383
384 %clean
385 rm -rf $RPM_BUILD_ROOT
386
387 %post
388 /bin/systemd-machine-id-setup > /dev/null 2>&1 || :
389 /bin/systemctl daemon-reexec > /dev/null 2>&1 || :
390
391 %postun
392 if [ $1 -ge 1 ]; then
393         /bin/systemctl try-restart systemd-logind.service >/dev/null 2>&1 || :
394 fi
395
396 %post   libs -p /sbin/ldconfig
397 %postun libs -p /sbin/ldconfig
398
399 %post units
400 if [ $1 -eq 1 ]; then
401         # Try to read default runlevel from the old inittab if it exists
402         runlevel=$(/bin/awk -F ':' '$3 == "initdefault" && $1 !~ "^#" { print $2 }' /etc/inittab 2> /dev/null)
403         if [ -z "$runlevel" ] ; then
404                 target="%{systemdunitdir}/graphical.target"
405         else
406                 target="%{systemdunitdir}/runlevel$runlevel.target"
407         fi
408
409         # And symlink what we found to the new-style default.target
410         ln -s "$target" %{_sysconfdir}/systemd/system/default.target >/dev/null 2>&1 || :
411
412         # Setup hostname
413         [ -f /etc/sysconfig/network ] && . /etc/sysconfig/network
414         if [ -n "$HOSTNAME" -a "$HOSTNAME" != "pldmachine" ]; then
415                 [ -f /etc/hostname ] && mv -f /etc/hostname /etc/hostname.rpmsave
416                 echo $HOSTNAME > /etc/hostname
417                 chmod 644 /etc/hostname
418         fi
419 fi
420 # Enable the services we install by default.
421 /bin/systemctl enable \
422         getty@.service \
423         network.service \
424         network-post.service \
425         remote-fs.target \
426         systemd-readahead-replay.service \
427         systemd-readahead-collect.service >/dev/null 2>&1 || :
428
429 # Find and enable all installed interfaces
430 mkdir -p %{_sysconfdir}/systemd/system/network.target.wants >/dev/null 2>&1 || :
431 for f in /etc/sysconfig/interfaces/ifcfg-* ; do
432         ff=$(basename $f)
433         ff=${ff##ifcfg-}
434         case "$ff" in
435         *.rpmorig|*.rpmnew|*.rpmsave|*~|*.orig)
436                 continue
437                 ;;
438         *)
439                 DEVICE="" ; ONBOOT="" ; USERS=""
440                 . $f 2>/dev/null
441                 [ ${USERS:-no} != no ] && continue
442                 if [ "$DEVICE" = "$ff" -a ${ONBOOT:-no} = "yes" ]; then
443                         ln -s %{systemdunitdir}/ifup@.service \
444                                 %{_sysconfdir}/systemd/system/network.target.wants/ifcfg@$ff.service >/dev/null 2>&1 || :
445                 fi
446                 ;;
447         esac
448 done
449
450 %preun units
451 if [ $1 -eq 0 ] ; then
452         /bin/systemctl disable \
453                 getty@.service \
454                 network.service \
455                 network-post.service \
456                 remote-fs.target \
457                 systemd-readahead-replay.service \
458                 systemd-readahead-collect.service >/dev/null 2>&1 || :
459
460         %{__rm} -f %{_sysconfdir}/systemd/system/default.target >/dev/null 2>&1 || :
461         %{__rm} -f %{_sysconfdir}/systemd/system/network.target.wants/ifcfg@*.service >/dev/null 2>&1 || :
462 fi
463
464 %postun units
465 if [ $1 -ge 1 ]; then
466         /bin/systemctl daemon-reload > /dev/null 2>&1 || :
467 fi
468
469 %post no-compat-tmpfiles
470 %{__sed} -i -e 's/^/# /g' %{_sysconfdir}/tmpfiles.d/compat-pld-var-run.conf
471
472 %files
473 %defattr(644,root,root,755)
474 %doc DISTRO_PORTING README TODO
475 /etc/dbus-1/system.d/org.freedesktop.hostname1.conf
476 /etc/dbus-1/system.d/org.freedesktop.locale1.conf
477 /etc/dbus-1/system.d/org.freedesktop.login1.conf
478 /etc/dbus-1/system.d/org.freedesktop.systemd1.conf
479 /etc/dbus-1/system.d/org.freedesktop.timedate1.conf
480 %ghost %config(noreplace) %{_sysconfdir}/machine-id
481 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hostname
482 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/locale.conf
483 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/machine-info
484 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/os-release
485 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/timezone
486 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/vconsole.conf
487 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/systemd/*.conf
488 %dir %{_sysconfdir}/systemd/user
489 /etc/xdg/systemd
490 %attr(755,root,root) /bin/systemd
491 %attr(755,root,root) /bin/systemd-ask-password
492 %attr(755,root,root) /bin/systemd-journalctl
493 %attr(755,root,root) /bin/systemd-loginctl
494 %attr(755,root,root) /bin/systemd-machine-id-setup
495 %attr(755,root,root) /bin/systemd-notify
496 %attr(755,root,root) /bin/systemd-tty-ask-password-agent
497 %attr(755,root,root) %{_bindir}/systemd-analyze
498 %attr(755,root,root) %{_bindir}/systemd-cat
499 %attr(755,root,root) %{_bindir}/systemd-cgtop
500 %attr(755,root,root) %{_bindir}/systemd-cgls
501 %attr(755,root,root) %{_bindir}/systemd-nspawn
502 %attr(755,root,root) %{_bindir}/systemd-stdio-bridge
503 %attr(755,root,root) %{_bindir}/systemd-sysv-convert
504 %attr(755,root,root) /lib/systemd/systemd-*
505 %dir /lib/systemd/system-generators
506 %attr(755,root,root) /lib/systemd/system-generators/systemd-*-generator
507 %dir /lib/systemd/system-shutdown
508 /lib/udev/rules.d/99-systemd.rules
509 /lib/udev/rules.d/70-uaccess.rules
510 /lib/udev/rules.d/71-seat.rules
511 /lib/udev/rules.d/73-seat-late.rules
512 %dir %{_libexecdir}/systemd
513 %{_libexecdir}/systemd/user
514 %dir %{_libexecdir}/systemd/user-generators
515 %config(noreplace,missingok) %{_libexecdir}/tmpfiles.d/*.conf
516 %{_datadir}/dbus-1/interfaces/org.freedesktop.hostname1.xml
517 %{_datadir}/dbus-1/interfaces/org.freedesktop.locale1.xml
518 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.*.xml
519 %{_datadir}/dbus-1/interfaces/org.freedesktop.timedate1.xml
520 %{_datadir}/dbus-1/services/org.freedesktop.systemd1.service
521 %{_datadir}/dbus-1/system-services/org.freedesktop.hostname1.service
522 %{_datadir}/dbus-1/system-services/org.freedesktop.locale1.service
523 %{_datadir}/dbus-1/system-services/org.freedesktop.login1.service
524 %{_datadir}/dbus-1/system-services/org.freedesktop.systemd1.service
525 %{_datadir}/dbus-1/system-services/org.freedesktop.timedate1.service
526 %{_datadir}/polkit-1/actions/org.freedesktop.hostname1.policy
527 %{_datadir}/polkit-1/actions/org.freedesktop.locale1.policy
528 %{_datadir}/polkit-1/actions/org.freedesktop.login1.policy
529 %{_datadir}/polkit-1/actions/org.freedesktop.systemd1.policy
530 %{_datadir}/polkit-1/actions/org.freedesktop.timedate1.policy
531 %dir %{_datadir}/systemd
532 %{_datadir}/systemd/kbd-model-map
533 %{_mandir}/man1/systemd.1*
534 %{_mandir}/man1/systemd-*.1*
535 %{_mandir}/man3/sd_booted.3*
536 %{_mandir}/man3/sd_is_fifo.3*
537 %{_mandir}/man3/sd_is_socket.3
538 %{_mandir}/man3/sd_is_socket_inet.3
539 %{_mandir}/man3/sd_is_socket_unix.3
540 %{_mandir}/man3/sd_listen_fds.3*
541 %{_mandir}/man3/sd_notify.3*
542 %{_mandir}/man3/sd_notifyf.3
543 %{_mandir}/man3/sd_readahead.3*
544 %{_mandir}/man5/binfmt.d.5*
545 %{_mandir}/man5/hostname.5*
546 %{_mandir}/man5/locale.conf.5*
547 %{_mandir}/man5/machine-id.5*
548 %{_mandir}/man5/machine-info.5*
549 %{_mandir}/man5/modules-load.d.5*
550 %{_mandir}/man5/os-release.5*
551 %{_mandir}/man5/sysctl.d.5*
552 %{_mandir}/man5/systemd.*.5*
553 %{_mandir}/man5/systemd-logind.conf.5*
554 %{_mandir}/man5/timezone.5*
555 %{_mandir}/man5/vconsole.conf.5*
556 %{_mandir}/man7/daemon.7*
557 %{_mandir}/man7/sd-daemon.7*
558 %{_mandir}/man7/sd-login.7*
559 %{_mandir}/man7/sd-readahead.7*
560 %{_mandir}/man7/systemd.special.7*
561 %attr(640,root,root) %ghost /var/log/btmp
562 %attr(664,root,utmp) %ghost /var/log/wtmp
563
564 %if %{with pam}
565 %attr(755,root,root) /%{_lib}/security/pam_systemd.so
566 %{_mandir}/man8/pam_systemd.8*
567 %endif
568
569 %files init
570 %defattr(644,root,root,755)
571 %attr(755,root,root) /sbin/halt
572 %attr(755,root,root) /sbin/init
573 %attr(755,root,root) /sbin/poweroff
574 %attr(755,root,root) /sbin/reboot
575 %attr(755,root,root) /sbin/runlevel
576 %attr(755,root,root) /sbin/shutdown
577 %attr(755,root,root) /sbin/telinit
578 %{_mandir}/man1/init.1
579 %{_mandir}/man8/halt.8*
580 %{_mandir}/man8/poweroff.8
581 %{_mandir}/man8/reboot.8
582 %{_mandir}/man8/runlevel.8*
583 %{_mandir}/man8/shutdown.8*
584 %{_mandir}/man8/telinit.8*
585
586 %files units
587 %defattr(644,root,root,755)
588 %dir %{_sysconfdir}/binfmt.d
589 %dir %{_sysconfdir}/modules-load.d
590 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/modules-load.d/modules.conf
591 %dir %{_sysconfdir}/sysctl.d
592 %dir %{_sysconfdir}/systemd
593 %dir %{_sysconfdir}/systemd/system
594 %dir %{_sysconfdir}/tmpfiles.d
595 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/tmpfiles.d/*.conf
596 %dir %{_libexecdir}/binfmt.d
597 %dir %{_libexecdir}/modules-load.d
598 %dir %{_libexecdir}/sysctl.d
599 %{_libexecdir}/sysctl.d/coredump.conf
600 %attr(755,root,root) /bin/systemctl
601 %attr(755,root,root) /bin/systemd-tmpfiles
602 %attr(755,root,root) /bin/systemd_booted
603 %{_mandir}/man1/systemctl.1*
604 %{_mandir}/man5/tmpfiles.d.5*
605 %{_mandir}/man8/systemd-tmpfiles.8*
606 %{_npkgconfigdir}/systemd.pc
607
608 %{systemdunitdir}/*.automount
609 %{systemdunitdir}/*.mount
610 %{systemdunitdir}/*.path
611 %{systemdunitdir}/*.service
612 %{systemdunitdir}/*.socket
613 %{systemdunitdir}/*.target
614 %{systemdunitdir}/*.timer
615 %dir %{systemdunitdir}/*.wants
616 %config(noreplace,missingok) %{systemdunitdir}/*.wants/*
617
618 %if %{with gtk}
619 %files gtk
620 %defattr(644,root,root,755)
621 %attr(755,root,root) %{_bindir}/systemadm
622 %attr(755,root,root) %{_bindir}/systemd-gnome-ask-password-agent
623 %{_mandir}/man1/systemadm.1*
624 %endif
625
626 %files libs
627 %defattr(644,root,root,755)
628 %attr(755,root,root) /%{_lib}/libsystemd-daemon.so.*.*.*
629 %attr(755,root,root) %ghost /%{_lib}/libsystemd-daemon.so.0
630 %attr(755,root,root) /%{_lib}/libsystemd-id128.so.*.*.*
631 %attr(755,root,root) %ghost /%{_lib}/libsystemd-id128.so.0
632 %attr(755,root,root) /%{_lib}/libsystemd-journal.so.*.*.*
633 %attr(755,root,root) %ghost /%{_lib}/libsystemd-journal.so.0
634 %attr(755,root,root) /%{_lib}/libsystemd-login.so.*.*.*
635 %attr(755,root,root) %ghost /%{_lib}/libsystemd-login.so.0
636
637 %files devel
638 %defattr(644,root,root,755)
639 %attr(755,root,root) %{_libdir}/libsystemd-daemon.so
640 %attr(755,root,root) %{_libdir}/libsystemd-id128.so
641 %attr(755,root,root) %{_libdir}/libsystemd-journal.so
642 %attr(755,root,root) %{_libdir}/libsystemd-login.so
643 %{_includedir}/%{name}
644 %{_pkgconfigdir}/libsystemd-daemon.pc
645 %{_pkgconfigdir}/libsystemd-id128.pc
646 %{_pkgconfigdir}/libsystemd-journal.pc
647 %{_pkgconfigdir}/libsystemd-login.pc
648 %{_mandir}/man3/sd_get_seats.3*
649 %{_mandir}/man3/sd_get_sessions.3*
650 %{_mandir}/man3/sd_get_uids.3*
651 %{_mandir}/man3/sd_is_mq.3*
652 %{_mandir}/man3/sd_login_monitor_flush.3*
653 %{_mandir}/man3/sd_login_monitor_get_fd.3*
654 %{_mandir}/man3/sd_login_monitor_new.3*
655 %{_mandir}/man3/sd_login_monitor_unref.3*
656 %{_mandir}/man3/sd_pid_get_owner_uid.3*
657 %{_mandir}/man3/sd_pid_get_session.3*
658 %{_mandir}/man3/sd_pid_get_unit.3*
659 %{_mandir}/man3/sd_seat_can_multi_session.3*
660 %{_mandir}/man3/sd_seat_get_active.3*
661 %{_mandir}/man3/sd_seat_get_sessions.3*
662 %{_mandir}/man3/sd_session_get_seat.3*
663 %{_mandir}/man3/sd_session_get_uid.3*
664 %{_mandir}/man3/sd_session_is_active.3*
665 %{_mandir}/man3/sd_uid_get_seats.3*
666 %{_mandir}/man3/sd_uid_get_sessions.3*
667 %{_mandir}/man3/sd_uid_get_state.3*
668 %{_mandir}/man3/sd_uid_is_on_seat.3*
669
670 %files -n bash-completion-systemd
671 %defattr(644,root,root,755)
672 /etc/bash_completion.d/systemd-bash-completion.sh
673
674 %files no-compat-tmpfiles
675 %defattr(644,root,root,755)
676 # empty package
This page took 0.203268 seconds and 3 git commands to generate.