]> git.pld-linux.org Git - packages/systemd.git/blob - systemd.spec
0468d35969bb89fb5c8c31a8a83099677fba2e55
[packages/systemd.git] / systemd.spec
1 # TODO:
2 #       - remove compat-pld-var-run.tmpfiles and maybe tmpfiles-not-fatal.patch
3 #         after enough packages provide their own tmpfiles.d configs for
4 #         /var/run directories
5 # - for systemd-45+
6 #   - restore var-{run,lock}: http://cgit.freedesktop.org/systemd/systemd/commit/?id=55d029addf7d97b15faacea597a4ff65542aaf0e
7 #   - WARNING: http://cgit.freedesktop.org/systemd/systemd/commit/?id=623ac9d2fce3170125ead9be20f56bfe68ea125e
8 #
9 # Conditional build:
10 %bcond_without  audit           # without audit support
11 %bcond_without  cryptsetup      # without cryptsetup support
12 %bcond_without  pam             # PAM authentication support
13 %bcond_without  plymouth        # do not install plymouth units
14 %bcond_without  selinux         # without SELinux support
15 %bcond_without  tcpd            # libwrap (tcp_wrappers) support
16
17 Summary:        A System and Service Manager
18 Summary(pl.UTF-8):      systemd - zarządca systemu i usług dla Linuksa
19 Name:           systemd
20 Version:        44
21 Release:        11
22 License:        GPL v2+
23 Group:          Base
24 Source0:        http://www.freedesktop.org/software/systemd/%{name}-%{version}.tar.xz
25 # Source0-md5:  11f44ff74c87850064e4351518bcff17
26 Source1:        %{name}-sysv-convert
27 Source2:        %{name}_booted.c
28 Source3:        network.service
29 Source4:        compat-pld-media.tmpfiles
30 Source5:        compat-pld-var-run.tmpfiles
31 Source10:       pld-storage-init-late.service
32 Source11:       pld-storage-init.service
33 Source12:       pld-wait-storage.service
34 Source13:       pld-storage-init.sh
35 Source14:       pld-clean-tmp.service
36 Source15:       pld-clean-tmp.sh
37 Patch0:         target-pld.patch
38 Patch1:         config-pld.patch
39 Patch2:         shut-sysv-up.patch
40 Patch3:         pld-sysv-network.patch
41 Patch4:         tmpfiles-not-fatal.patch
42 Patch5:         CVE-2012-1174.patch
43 Patch6:         ReleaseSession.patch
44 URL:            http://www.freedesktop.org/wiki/Software/systemd
45 BuildRequires:  acl-devel
46 %{?with_audit:BuildRequires:    audit-libs-devel}
47 BuildRequires:  autoconf >= 2.63
48 BuildRequires:  automake >= 1:1.11
49 BuildRequires:  binutils >= 3:2.22.52.0.1-2
50 %{?with_cryptsetup:BuildRequires:       cryptsetup-luks-devel}
51 BuildRequires:  dbus-devel >= 1.3.2
52 BuildRequires:  docbook-style-xsl
53 BuildRequires:  gperf
54 BuildRequires:  intltool >= 0.40.0
55 BuildRequires:  kmod-devel >= 5
56 BuildRequires:  libcap-devel
57 %{?with_selinux:BuildRequires:  libselinux-devel >= 2.1.0}
58 BuildRequires:  libtool >= 2:2.2
59 %{?with_tcpd:BuildRequires:     libwrap-devel}
60 BuildRequires:  libxslt-progs
61 BuildRequires:  m4
62 %{?with_pam:BuildRequires:      pam-devel}
63 BuildRequires:  pkgconfig >= 0.9.0
64 BuildRequires:  rpmbuild(macros) >= 1.627
65 BuildRequires:  udev-devel >= 1:172
66 BuildRequires:  xz-devel
67 Requires:       %{name}-libs = %{version}-%{release}
68 Requires:       %{name}-units = %{version}-%{release}
69 Requires:       /etc/os-release
70 Requires:       SysVinit-tools
71 Requires:       agetty
72 Requires:       dbus >= 1.4.16-6
73 Requires:       filesystem >= 4.0-2
74 Requires:       libutempter
75 Requires:       rc-scripts >= 0.4.5.3-7
76 Requires:       setup >= 2.8.0-2
77 Requires:       udev-core >= 1:175-5
78 Requires:       udev-libs >= 1:172
79 Requires:       virtual(module-tools)
80 Suggests:       %{name}-no-compat-tmpfiles
81 Suggests:       ConsoleKit
82 Suggests:       fsck >= 2.20
83 Suggests:       kmod >= 5
84 Suggests:       nss_myhostname
85 Suggests:       service(klogd)
86 Suggests:       service(syslog)
87 Provides:       udev-acl
88 # systemd takes care of that and causes problems
89 Conflicts:      binfmt-detector
90 # sytemd wants pam with pam_systemd.so in system-auth...
91 Conflicts:      pam < 1:1.1.5-5
92 # ...and sudo hates it
93 Conflicts:      sudo < 1:1.7.8p2-4
94 # for prefdm script
95 Conflicts:      xinitrc-ng < 1.0
96 # systemd scripts use options not present in older versions
97 Conflicts:      kpartx < 0.4.9-7
98 Conflicts:      multipath-tools < 0.4.9-7
99 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
100
101 %define         _libexecdir     %{_prefix}/lib
102
103 %description
104 systemd is a system and service manager for Linux, compatible with
105 SysV and LSB init scripts. systemd provides aggressive parallelization
106 capabilities, uses socket and D-Bus activation for starting services,
107 offers on-demand starting of daemons, keeps track of processes using
108 Linux cgroups, supports snapshotting and restoring of the system
109 state, maintains mount and automount points and implements an
110 elaborate transactional dependency-based service control logic. It can
111 work as a drop-in replacement for sysvinit.
112
113 %description -l pl.UTF-8
114 systemd jest zarządcą systemu i usług dla Linuksa, kompatybilny ze
115 skryptami SysV i LSB. systemd udostępnia rozbudowane zdolności
116 paralelizacji, do uruchamiania usług używa socketów oraz D-Busa,
117 oferuje uruchamianie usług na życzenie, monitoruje procesy używając
118 linuksowych cgroups, wspomaga zapisywanie (snapshot) i odczytywanie
119 (restore) stanu systemu, zarządza (auto)mount pointami oraz
120 implementuje starannie opracowaną transakcjonalną, bazującą na
121 zależnościach logikę kontroli usług. Może pracować jako zastępca dla
122 sysvinit.
123
124 %package init
125 Summary:        systemd /sbin/init and LSB/SysV compatibility symlinks
126 Summary(pl.UTF-8):      /sbin/init z systemd i dowiązania dla kompatybilności z LSB/SysV
127 Group:          Base
128 Requires:       systemd
129 Provides:       readahead = 1:1.5.7-3
130 Provides:       virtual(init-daemon)
131 Obsoletes:      SysVinit
132 Obsoletes:      readahead < 1:1.5.7-3
133 Obsoletes:      virtual(init-daemon)
134 Conflicts:      upstart
135
136 %description init
137 Install this package when you are ready to final switch to systemd.
138
139 %description init -l pl.UTF-8
140 Ten pakiet należy zainstalować po przygotowaniu się do ostatecznego
141 przejścia na systemd.
142
143 %package units
144 Summary:        Configuration files, directories and installation tool for systemd
145 Summary(pl.UTF-8):      Pliki konfiguracyjne, katalogi i narzędzie instalacyjne dla systemd
146 Group:          Base
147 Requires(post): coreutils
148 Requires(post): /bin/awk
149
150 %description units
151 Basic configuration files, directories and installation tool for the
152 systemd system and service manager.
153
154 This is common config, use %{_sysconfdir}/systemd/system to override.
155
156 %description units -l pl.UTF-8
157 Podstawowe pliki konfiguracyjne, katalogi i narzędzie instalacyjne dla
158 zarządcy systemu i usług systemd.
159
160 Ten pakiet zawiera ogólną konfigurację, ustawienia można nadpisać
161 poprzez katalog %{_sysconfdir}/systemd/system.
162
163 %package plymouth
164 Summary:        Plymouth support units for systemd
165 Summary(pl.UTF-8):      Jednostki wspierające Plymouth dla systemd
166 Group:          Base
167 Requires:       %{name}-units = %{version}-%{release}
168 Requires:       plymouth
169
170 %description plymouth
171 Plymouth (graphical boot) support units for systemd.
172
173 %description plymouth -l pl.UTF-8
174 Jednostki wspierające Plymouth (graficzny start systemu) dla systemd.
175
176 %package analyze
177 Summary:        Tool for processing systemd profiling information
178 Group:          Base
179 Requires:       %{name} = %{version}-%{release}
180 Requires:       python-dbus
181 Requires:       python-modules
182 Requires:       python-pycairo
183 Conflicts:      %{name} < 44-3
184
185 %description analyze
186 'systemd-analyze blame' lists which systemd unit needed how much time
187 to finish initialization at boot. 'systemd-analyze plot' renders an
188 SVG visualizing the parallel start of units at boot.
189
190 %package libs
191 Summary:        Shared systemd libraries
192 Summary(pl.UTF-8):      Biblioteki współdzielone systemd
193 Group:          Libraries
194
195 %description libs
196 Shared systemd libraries.
197
198 %description libs -l pl.UTF-8
199 Biblioteki współdzielone systemd.
200
201 %package devel
202 Summary:        Header files for systemd libraries
203 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek systemd
204 Group:          Development/Libraries
205 Requires:       %{name}-libs = %{version}-%{release}
206
207 %description devel
208 Header files for systemd libraries.
209
210 %description devel -l pl.UTF-8
211 Pliki nagłówkowe bibliotek systemd.
212
213 %package -n bash-completion-systemd
214 Summary:        bash-completion for systemd
215 Summary(pl.UTF-8):      Bashowe dopełnianie składni dla systemd
216 Group:          Applications/Shells
217 Requires:       %{name} = %{version}
218 Requires:       bash-completion
219
220 %description -n bash-completion-systemd
221 bash-completion for systemd.
222
223 %description -n bash-completion-systemd -l pl.UTF-8
224 Bashowe dopełnianie składni dla systemd
225
226 %package no-compat-tmpfiles
227 Summary:        Force update of packages that provide tmpfiles.d configuration
228 Group:          Base
229 Requires:       %{name} = %{version}-%{release}
230 Requires(post): sed > 4.0
231 Conflicts:      ConsoleKit-dirs < 0.4.5-7
232 Conflicts:      NetworkManager < 2:0.9.2.0-3
233 Conflicts:      Zope < 2.11.8-2
234 Conflicts:      amavisd-new < 1:2.7.0-1
235 Conflicts:      apache-base < 2.2.21-4
236 Conflicts:      apache-mod_bw < 0.92-3
237 Conflicts:      apache-mod_fastcgi < 2.4.6-6
238 Conflicts:      apache1-base < 1.3.42-5
239 Conflicts:      apache1-mod_fastcgi < 2.4.6-2
240 Conflicts:      asterisk < 10.0.1-2
241 Conflicts:      autossh-init < 1.4b-3
242 Conflicts:      balance < 3.54-2
243 Conflicts:      bind < 7:9.8.1.P1-4
244 Conflicts:      bopm < 3.1.3-4
245 Conflicts:      callweaver < 1.2.1-9
246 Conflicts:      cassandra-bin < 0.8.9-2
247 Conflicts:      clamav < 0.97.3-3
248 Conflicts:      cups < 1:1.5.0-10
249 Conflicts:      dbus < 1.4.16-4
250 Conflicts:      dovecot < 1:2.0.16-3
251 Conflicts:      dspam < 3.9.0-6
252 Conflicts:      fail2ban < 0.8.4-4
253 Conflicts:      filesystem < 4.0-3
254 Conflicts:      gammu-smsd < 1:1.31.0-3
255 # Break gdm2.20 installs
256 #Conflicts:     gdm < 2:3.2.1.1-9
257 Conflicts:      greylistd < 0.8.8-2
258 Conflicts:      inn < 2.4.6-7
259 Conflicts:      ipsec-tools < 0.8.0-3
260 Conflicts:      jabber-common < 0-9
261 Conflicts:      laptop-mode-tools < 1.58-2
262 Conflicts:      libgpod < 0.8.0-6
263 Conflicts:      libvirt-utils < 0.9.9-4
264 Conflicts:      lighttpd < 1.4.30-5
265 Conflicts:      lirc < 0.9.0-20
266 Conflicts:      mailman < 5:2.1.14-4
267 Conflicts:      memcached < 1.4.11-2
268 Conflicts:      mpd < 0.16.5-4
269 Conflicts:      mrtg < 2.17.0-3
270 Conflicts:      munin-common < 1.4.5-5
271 Conflicts:      nagios-nrpe < 2.13-2
272 Conflicts:      ndisc6-rdnssd < 1.0.1-3
273 Conflicts:      nscd < 6:2.14.1-5
274 Conflicts:      nss_ldapd-nslcd < 0.8.4-2
275 Conflicts:      openct < 0.6.20-3
276 Conflicts:      openl2tp < 1.8-3
277 Conflicts:      openldap-overlay-nssov < 2.4.28-4
278 Conflicts:      openldap-servers < 2.4.28-4
279 Conflicts:      openvpn < 2.2.2-2
280 Conflicts:      pam-pam_mount < 2.12-3
281 Conflicts:      pam-pam_ssh < 1.97-2
282 Conflicts:      pcsc-lite < 1.8.1-2
283 Conflicts:      php-dirs < 1.2-3
284 Conflicts:      policyd < 2.0.10-3
285 Conflicts:      pound < 2.6-2
286 Conflicts:      pptp < 1.7.2-3
287 Conflicts:      proftpd-common < 2:1.3.4a-2
288 Conflicts:      pulseaudio-server < 1.1-2
289 Conflicts:      quagga < 0.99.20-3
290 Conflicts:      radvd < 1.8.5-2
291 Conflicts:      rc-scripts < 0.4.5.2-3
292 Conflicts:      red5 < 0.9.0-2
293 Conflicts:      redis-server < 2.4.2-4
294 Conflicts:      smokeping < 2.4.2-10
295 Conflicts:      smtp-gated < 1.4.17-2
296 Conflicts:      socat < 1.7.2.0-2
297 Conflicts:      speech-dispatcher < 0.7.1-2
298 Conflicts:      sphinx < 2.0.3-4
299 Conflicts:      splashutils < 1.5.4.3-3
300 Conflicts:      stunnel < 4.50-2
301 Conflicts:      tenshi < 0.12-2
302 Conflicts:      tor < 0.2.2.35-2
303 Conflicts:      ucarp < 1.5.2-3
304 Conflicts:      udisks < 1.0.4-3
305 Conflicts:      util-vserver < 0.30.216-1.pre3002.3
306 Conflicts:      vpnc < 0.5.3-2
307 Conflicts:      web2ldap < 1.1.0rc1-2
308 Conflicts:      wesnoth-server < 1:1.10-2
309 Conflicts:      wpa_supplicant < 0.7.3-10
310 Conflicts:      xl2tpd < 1.3.0-2
311
312 %description no-compat-tmpfiles
313 Force update of packages that provide tmpfiles.d configuration
314
315 %prep
316 %setup -q
317 %patch0 -p1
318 %patch1 -p1
319 %patch2 -p1
320 %patch3 -p1
321 %patch4 -p1
322 %patch5 -p1
323 %patch6 -p1
324 cp -p %{SOURCE2} src/systemd_booted.c
325
326 %build
327 %{__aclocal} -I m4
328 %{__autoconf}
329 %{__autoheader}
330 %{__automake}
331 %configure \
332         %{__enable_disable audit} \
333         %{__enable_disable cryptsetup libcryptsetup} \
334         --disable-gtk \
335         %{__enable_disable pam} \
336         %{__enable_disable plymouth} \
337         %{__enable_disable selinux} \
338         %{__enable_disable tcpd tcpwrap} \
339         --disable-silent-rules \
340         --disable-static \
341         --with-distro=pld \
342         --with-rootprefix= \
343         --with-rootlibdir=/%{_lib} \
344         --enable-split-usr
345
346 %{__make}
347 ./libtool --mode=link --tag=CC %{__cc} %{rpmcppflags} %{rpmcflags} -o systemd_booted %{rpmldflags} src/systemd_booted.c -L. -lsystemd-daemon
348
349 %install
350 rm -rf $RPM_BUILD_ROOT
351 install -d $RPM_BUILD_ROOT/var/lib/%{name}/coredump
352
353 %{__make} install \
354         DESTDIR=$RPM_BUILD_ROOT
355
356 ./libtool --mode=install install -p -m755 systemd_booted $RPM_BUILD_ROOT/bin/systemd_booted
357
358 # Main binary has been moved, but we don't want to break existing installs
359 ln -s ../lib/systemd/systemd $RPM_BUILD_ROOT/bin/systemd
360
361 # Create SysV compatibility symlinks. systemctl/systemd are smart
362 # enough to detect the way they were called
363 install -d $RPM_BUILD_ROOT/sbin
364 ln -s ../lib/systemd/systemd $RPM_BUILD_ROOT/sbin/init
365 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/halt
366 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/poweroff
367 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/reboot
368 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/runlevel
369 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/shutdown
370 ln -s ../bin/systemctl $RPM_BUILD_ROOT/sbin/telinit
371
372 ln -s ../modules $RPM_BUILD_ROOT%{_sysconfdir}/modules-load.d/modules.conf
373
374 # disable redundant SYSV services
375 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/allowlogin.service
376 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/console.service
377 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/cpusets.service
378 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/killall.service
379 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/netfs.service
380 ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/random.service
381
382 # add static (non-NetworkManager) networking
383 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{systemdunitdir}/network.service
384
385 # install compatibility tmpfiles configs
386 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/compat-pld-media.conf
387 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/compat-pld-var-run.conf
388
389 # Install and enable storage subsystems support services (RAID, LVM, etc.)
390 cp -p %{SOURCE10} $RPM_BUILD_ROOT%{systemdunitdir}/pld-storage-init-late.service
391 cp -p %{SOURCE11} $RPM_BUILD_ROOT%{systemdunitdir}/pld-storage-init.service
392 cp -p %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/pld-wait-storage.service
393 cp -p %{SOURCE14} $RPM_BUILD_ROOT%{systemdunitdir}/pld-clean-tmp.service
394 install -p %{SOURCE13} $RPM_BUILD_ROOT/lib/systemd/pld-storage-init
395 install -p %{SOURCE15} $RPM_BUILD_ROOT/lib/systemd/pld-clean-tmp
396
397 ln -s ../pld-storage-init-late.service $RPM_BUILD_ROOT%{systemdunitdir}/local-fs.target.wants
398 ln -s ../pld-storage-init.service $RPM_BUILD_ROOT%{systemdunitdir}/local-fs.target.wants
399 ln -s ../pld-clean-tmp.service $RPM_BUILD_ROOT%{systemdunitdir}/local-fs.target.wants
400
401 # handled by rc-local sysv service, no need for generator
402 %{__rm} $RPM_BUILD_ROOT/lib/systemd/system-generators/systemd-rc-local-generator
403
404 # Make sure these directories are properly owned:
405 #       - halt,kexec,poweroff,reboot: generic ones used by ConsoleKit-systemd,
406 #       - syslog _might_ be used by some syslog implementation (none for now),
407 #       - isn't dbus populated by dbus-systemd only (so to be moved there)?
408 install -d $RPM_BUILD_ROOT%{systemdunitdir}/{dbus,halt,kexec,poweroff,reboot,syslog}.target.wants
409
410 # Create new-style configuration files so that we can ghost-own them
411 touch $RPM_BUILD_ROOT%{_sysconfdir}/{hostname,locale.conf,machine-id,machine-info,timezone,vconsole.conf}
412
413 # Install SysV conversion tool for systemd
414 install -p %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}
415
416 install -d $RPM_BUILD_ROOT/var/log
417 :> $RPM_BUILD_ROOT/var/log/btmp
418 :> $RPM_BUILD_ROOT/var/log/wtmp
419
420 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/systemadm.1*
421
422 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
423 %{__rm} $RPM_BUILD_ROOT/%{_lib}/security/pam_systemd.la
424 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
425
426 %clean
427 rm -rf $RPM_BUILD_ROOT
428
429 %post
430 /bin/systemd-machine-id-setup > /dev/null 2>&1 || :
431 /bin/systemctl daemon-reexec > /dev/null 2>&1 || :
432
433 %postun
434 if [ $1 -ge 1 ]; then
435         /bin/systemctl try-restart systemd-logind.service >/dev/null 2>&1 || :
436 fi
437
438 %post   libs -p /sbin/ldconfig
439 %postun libs -p /sbin/ldconfig
440
441 %post units
442 if [ $1 -eq 1 ]; then
443         # Try to read default runlevel from the old inittab if it exists
444         runlevel=$(/bin/awk -F ':' '$3 == "initdefault" && $1 !~ "^#" { print $2 }' /etc/inittab 2> /dev/null)
445         if [ -z "$runlevel" ] ; then
446                 target="%{systemdunitdir}/graphical.target"
447         else
448                 target="%{systemdunitdir}/runlevel$runlevel.target"
449         fi
450
451         # And symlink what we found to the new-style default.target
452         ln -s "$target" %{_sysconfdir}/systemd/system/default.target >/dev/null 2>&1 || :
453
454         # Setup hostname
455         [ -f /etc/sysconfig/network ] && . /etc/sysconfig/network
456         if [ -n "$HOSTNAME" -a "$HOSTNAME" != "pldmachine" ]; then
457                 [ -f /etc/hostname ] && mv -f /etc/hostname /etc/hostname.rpmsave
458                 echo $HOSTNAME > /etc/hostname
459                 chmod 644 /etc/hostname
460         fi
461
462         # Enable the services we install by default.
463         /bin/systemctl enable \
464                 getty@.service \
465                 network.service \
466                 remote-fs.target \
467                 systemd-readahead-replay.service \
468                 systemd-readahead-collect.service >/dev/null 2>&1 || :
469 fi
470
471 %preun units
472 if [ $1 -eq 0 ] ; then
473         /bin/systemctl disable \
474                 getty@.service \
475                 network.service \
476                 remote-fs.target \
477                 systemd-readahead-replay.service \
478                 systemd-readahead-collect.service >/dev/null 2>&1 || :
479
480         %{__rm} -f %{_sysconfdir}/systemd/system/default.target >/dev/null 2>&1 || :
481 fi
482
483 %postun units
484 if [ $1 -ge 1 ]; then
485         /bin/systemctl daemon-reload > /dev/null 2>&1 || :
486 fi
487
488 %triggerpostun units -- %{name}-units < 43-7
489 # Remove design fialures
490 rm -f %{_sysconfdir}/systemd/system/network.target.wants/ifcfg@*.service >/dev/null 2>&1 || :
491 rm -f %{_sysconfdir}/systemd/system/network.target.wants/network-post.service >/dev/null 2>&1 || :
492 rm -f %{_sysconfdir}/systemd/system/multi-user.target.wants/network-post.service >/dev/null 2>&1 || :
493 /bin/systemctl reenable network.service >/dev/null 2>&1 || :
494
495 %post no-compat-tmpfiles
496 %{__sed} -i -e '/^#/!s/^/# /g' %{_sysconfdir}/tmpfiles.d/compat-pld-var-run.conf
497
498 %post plymouth
499 %systemd_reload
500
501 %postun plymouth
502 %systemd_reload
503
504 %files
505 %defattr(644,root,root,755)
506 %doc DISTRO_PORTING README TODO
507 /etc/dbus-1/system.d/org.freedesktop.hostname1.conf
508 /etc/dbus-1/system.d/org.freedesktop.locale1.conf
509 /etc/dbus-1/system.d/org.freedesktop.login1.conf
510 /etc/dbus-1/system.d/org.freedesktop.systemd1.conf
511 /etc/dbus-1/system.d/org.freedesktop.timedate1.conf
512 %ghost %config(noreplace) %{_sysconfdir}/machine-id
513 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hostname
514 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/locale.conf
515 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/machine-info
516 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/timezone
517 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/vconsole.conf
518 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/systemd/*.conf
519 %dir %{_sysconfdir}/systemd/user
520 %dir %{_sysconfdir}/systemd/system/*.target.wants
521 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/systemd/system/*.target.wants/*.service
522 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/systemd/system/*.target.wants/*.target
523 /etc/xdg/systemd
524 %attr(755,root,root) /bin/systemd
525 %attr(755,root,root) /bin/systemd-ask-password
526 %attr(755,root,root) /bin/systemd-journalctl
527 %attr(755,root,root) /bin/systemd-loginctl
528 %attr(755,root,root) /bin/systemd-machine-id-setup
529 %attr(755,root,root) /bin/systemd-notify
530 %attr(755,root,root) /bin/systemd-tty-ask-password-agent
531 %attr(755,root,root) %{_bindir}/systemd-cat
532 %attr(755,root,root) %{_bindir}/systemd-cgtop
533 %attr(755,root,root) %{_bindir}/systemd-cgls
534 %attr(755,root,root) %{_bindir}/systemd-nspawn
535 %attr(755,root,root) %{_bindir}/systemd-stdio-bridge
536 %attr(755,root,root) %{_bindir}/systemd-sysv-convert
537 %attr(755,root,root) /lib/systemd/pld-clean-tmp
538 %attr(755,root,root) /lib/systemd/pld-storage-init
539 %attr(755,root,root) /lib/systemd/systemd-*
540 %dir /lib/systemd/system-generators
541 %attr(755,root,root) /lib/systemd/systemd
542 %attr(755,root,root) /lib/systemd/system-generators/systemd-*-generator
543 %dir /lib/systemd/system-shutdown
544 /lib/udev/rules.d/99-systemd.rules
545 /lib/udev/rules.d/70-uaccess.rules
546 /lib/udev/rules.d/71-seat.rules
547 /lib/udev/rules.d/73-seat-late.rules
548 %dir %{_libexecdir}/systemd
549 %{_libexecdir}/systemd/user
550 %dir %{_libexecdir}/systemd/user-generators
551 %config(noreplace,missingok) %{_libexecdir}/tmpfiles.d/*.conf
552 %{_datadir}/dbus-1/interfaces/org.freedesktop.hostname1.xml
553 %{_datadir}/dbus-1/interfaces/org.freedesktop.locale1.xml
554 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.*.xml
555 %{_datadir}/dbus-1/interfaces/org.freedesktop.timedate1.xml
556 %{_datadir}/dbus-1/services/org.freedesktop.systemd1.service
557 %{_datadir}/dbus-1/system-services/org.freedesktop.hostname1.service
558 %{_datadir}/dbus-1/system-services/org.freedesktop.locale1.service
559 %{_datadir}/dbus-1/system-services/org.freedesktop.login1.service
560 %{_datadir}/dbus-1/system-services/org.freedesktop.systemd1.service
561 %{_datadir}/dbus-1/system-services/org.freedesktop.timedate1.service
562 %{_datadir}/polkit-1/actions/org.freedesktop.hostname1.policy
563 %{_datadir}/polkit-1/actions/org.freedesktop.locale1.policy
564 %{_datadir}/polkit-1/actions/org.freedesktop.login1.policy
565 %{_datadir}/polkit-1/actions/org.freedesktop.systemd1.policy
566 %{_datadir}/polkit-1/actions/org.freedesktop.timedate1.policy
567 %dir %{_datadir}/systemd
568 %{_datadir}/systemd/kbd-model-map
569 %{_mandir}/man1/systemd.1*
570 %{_mandir}/man1/systemd-*.1*
571 %{_mandir}/man5/binfmt.d.5*
572 %{_mandir}/man5/hostname.5*
573 %{_mandir}/man5/locale.conf.5*
574 %{_mandir}/man5/machine-id.5*
575 %{_mandir}/man5/machine-info.5*
576 %{_mandir}/man5/modules-load.d.5*
577 %{_mandir}/man5/os-release.5*
578 %{_mandir}/man5/sysctl.d.5*
579 %{_mandir}/man5/systemd.*.5*
580 %{_mandir}/man5/systemd-journald.conf.5*
581 %{_mandir}/man5/systemd-logind.conf.5*
582 %{_mandir}/man5/timezone.5*
583 %{_mandir}/man5/vconsole.conf.5*
584 %{_mandir}/man7/daemon.7*
585 %{_mandir}/man7/sd-daemon.7*
586 %{_mandir}/man7/sd-login.7*
587 %{_mandir}/man7/sd-readahead.7*
588 %{_mandir}/man7/systemd.special.7*
589 %dir /var/lib/%{name}
590 %dir /var/lib/%{name}/coredump
591 %attr(640,root,root) %ghost /var/log/btmp
592 %attr(664,root,utmp) %ghost /var/log/wtmp
593
594 %if %{with pam}
595 %attr(755,root,root) /%{_lib}/security/pam_systemd.so
596 %{_mandir}/man8/pam_systemd.8*
597 %endif
598
599 %files init
600 %defattr(644,root,root,755)
601 %attr(755,root,root) /sbin/halt
602 %attr(755,root,root) /sbin/init
603 %attr(755,root,root) /sbin/poweroff
604 %attr(755,root,root) /sbin/reboot
605 %attr(755,root,root) /sbin/runlevel
606 %attr(755,root,root) /sbin/shutdown
607 %attr(755,root,root) /sbin/telinit
608 %{_mandir}/man1/init.1
609 %{_mandir}/man8/halt.8*
610 %{_mandir}/man8/poweroff.8
611 %{_mandir}/man8/reboot.8
612 %{_mandir}/man8/runlevel.8*
613 %{_mandir}/man8/shutdown.8*
614 %{_mandir}/man8/telinit.8*
615
616 %files units
617 %defattr(644,root,root,755)
618 %dir %{_sysconfdir}/binfmt.d
619 %dir %{_sysconfdir}/modules-load.d
620 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/modules-load.d/modules.conf
621 %dir %{_sysconfdir}/sysctl.d
622 %dir %{_sysconfdir}/systemd
623 %dir %{_sysconfdir}/systemd/system
624 %dir %{_sysconfdir}/tmpfiles.d
625 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/tmpfiles.d/*.conf
626 %dir %{_libexecdir}/binfmt.d
627 %dir %{_libexecdir}/modules-load.d
628 %dir %{_libexecdir}/sysctl.d
629 %{_libexecdir}/sysctl.d/coredump.conf
630 %attr(755,root,root) /bin/systemctl
631 %attr(755,root,root) /bin/systemd-tmpfiles
632 %attr(755,root,root) /bin/systemd_booted
633 %{_mandir}/man1/systemctl.1*
634 %{_mandir}/man5/tmpfiles.d.5*
635 %{_mandir}/man8/systemd-tmpfiles.8*
636 %{_npkgconfigdir}/systemd.pc
637
638 %{systemdunitdir}/*.automount
639 %{systemdunitdir}/*.mount
640 %{systemdunitdir}/*.path
641 %{systemdunitdir}/*.service
642 %{systemdunitdir}/*.socket
643 %{systemdunitdir}/*.target
644 %{systemdunitdir}/*.timer
645 %if %{with plymouth}
646 %exclude %{systemdunitdir}/plymouth*.service
647 %exclude %{systemdunitdir}/systemd-ask-password-plymouth.*
648 %endif
649 %dir %{systemdunitdir}/basic.target.wants
650 %dir %{systemdunitdir}/dbus.target.wants
651 %dir %{systemdunitdir}/final.target.wants
652 %dir %{systemdunitdir}/graphical.target.wants
653 %dir %{systemdunitdir}/halt.target.wants
654 %dir %{systemdunitdir}/kexec.target.wants
655 %dir %{systemdunitdir}/local-fs.target.wants
656 %dir %{systemdunitdir}/multi-user.target.wants
657 %dir %{systemdunitdir}/poweroff.target.wants
658 %dir %{systemdunitdir}/reboot.target.wants
659 %dir %{systemdunitdir}/runlevel[12345].target.wants
660 %dir %{systemdunitdir}/shutdown.target.wants
661 %dir %{systemdunitdir}/sockets.target.wants
662 %dir %{systemdunitdir}/sysinit.target.wants
663 %dir %{systemdunitdir}/syslog.target.wants
664 %config(noreplace,missingok) %{systemdunitdir}/basic.target.wants/*
665 %config(noreplace,missingok) %{systemdunitdir}/final.target.wants/*
666 %config(noreplace,missingok) %{systemdunitdir}/graphical.target.wants/*
667 %config(noreplace,missingok) %{systemdunitdir}/local-fs.target.wants/*
668 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/getty.target
669 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/rc-local.service
670 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/systemd-ask-password-wall.path
671 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/systemd-logind.service
672 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/systemd-user-sessions.service
673 %config(noreplace,missingok) %{systemdunitdir}/runlevel[12345].target.wants/*
674 %config(noreplace,missingok) %{systemdunitdir}/shutdown.target.wants/*
675 %config(noreplace,missingok) %{systemdunitdir}/sockets.target.wants/*
676 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/cryptsetup.target
677 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/dev-hugepages.mount
678 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/dev-mqueue.mount
679 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/proc-sys-fs-binfmt_misc.automount
680 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/sys-*.mount
681 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/systemd-*
682
683 %if %{with plymouth}
684 %files plymouth
685 %defattr(644,root,root,755)
686 %{systemdunitdir}/plymouth-halt.service
687 %{systemdunitdir}/plymouth-kexec.service
688 %{systemdunitdir}/plymouth-poweroff.service
689 %{systemdunitdir}/plymouth-quit-wait.service
690 %{systemdunitdir}/plymouth-quit.service
691 %{systemdunitdir}/plymouth-read-write.service
692 %{systemdunitdir}/plymouth-reboot.service
693 %{systemdunitdir}/plymouth-start.service
694 %{systemdunitdir}/systemd-ask-password-plymouth.path
695 %{systemdunitdir}/systemd-ask-password-plymouth.service
696 %config(noreplace,missingok) %{systemdunitdir}/halt.target.wants/plymouth-halt.service
697 %config(noreplace,missingok) %{systemdunitdir}/kexec.target.wants/plymouth-kexec.service
698 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/plymouth-quit.service
699 %config(noreplace,missingok) %{systemdunitdir}/multi-user.target.wants/plymouth-quit-wait.service
700 %config(noreplace,missingok) %{systemdunitdir}/poweroff.target.wants/plymouth-poweroff.service
701 %config(noreplace,missingok) %{systemdunitdir}/reboot.target.wants/plymouth-reboot.service
702 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/plymouth-read-write.service
703 %config(noreplace,missingok) %{systemdunitdir}/sysinit.target.wants/plymouth-start.service
704 %endif
705
706 %files analyze
707 %defattr(644,root,root,755)
708 %attr(755,root,root) %{_bindir}/systemd-analyze
709
710 %files libs
711 %defattr(644,root,root,755)
712 %attr(755,root,root) /%{_lib}/libsystemd-daemon.so.*.*.*
713 %attr(755,root,root) %ghost /%{_lib}/libsystemd-daemon.so.0
714 %attr(755,root,root) /%{_lib}/libsystemd-id128.so.*.*.*
715 %attr(755,root,root) %ghost /%{_lib}/libsystemd-id128.so.0
716 %attr(755,root,root) /%{_lib}/libsystemd-journal.so.*.*.*
717 %attr(755,root,root) %ghost /%{_lib}/libsystemd-journal.so.0
718 %attr(755,root,root) /%{_lib}/libsystemd-login.so.*.*.*
719 %attr(755,root,root) %ghost /%{_lib}/libsystemd-login.so.0
720
721 %files devel
722 %defattr(644,root,root,755)
723 %attr(755,root,root) %{_libdir}/libsystemd-daemon.so
724 %attr(755,root,root) %{_libdir}/libsystemd-id128.so
725 %attr(755,root,root) %{_libdir}/libsystemd-journal.so
726 %attr(755,root,root) %{_libdir}/libsystemd-login.so
727 %{_includedir}/%{name}
728 %{_pkgconfigdir}/libsystemd-daemon.pc
729 %{_pkgconfigdir}/libsystemd-id128.pc
730 %{_pkgconfigdir}/libsystemd-journal.pc
731 %{_pkgconfigdir}/libsystemd-login.pc
732 %{_mandir}/man3/sd_booted.3*
733 %{_mandir}/man3/sd_get_seats.3*
734 %{_mandir}/man3/sd_get_sessions.3*
735 %{_mandir}/man3/sd_get_uids.3*
736 %{_mandir}/man3/sd_is_fifo.3*
737 %{_mandir}/man3/sd_is_mq.3*
738 %{_mandir}/man3/sd_is_socket.3
739 %{_mandir}/man3/sd_is_socket_inet.3
740 %{_mandir}/man3/sd_is_socket_unix.3
741 %{_mandir}/man3/sd_listen_fds.3*
742 %{_mandir}/man3/sd_login_monitor_flush.3*
743 %{_mandir}/man3/sd_login_monitor_get_fd.3*
744 %{_mandir}/man3/sd_login_monitor_new.3*
745 %{_mandir}/man3/sd_login_monitor_unref.3*
746 %{_mandir}/man3/sd_notify.3*
747 %{_mandir}/man3/sd_notifyf.3
748 %{_mandir}/man3/sd_pid_get_owner_uid.3*
749 %{_mandir}/man3/sd_pid_get_session.3*
750 %{_mandir}/man3/sd_pid_get_unit.3*
751 %{_mandir}/man3/sd_readahead.3*
752 %{_mandir}/man3/sd_seat_can_multi_session.3*
753 %{_mandir}/man3/sd_seat_get_active.3*
754 %{_mandir}/man3/sd_seat_get_sessions.3*
755 %{_mandir}/man3/sd_session_get_class.3*
756 %{_mandir}/man3/sd_session_get_display.3*
757 %{_mandir}/man3/sd_session_get_seat.3*
758 %{_mandir}/man3/sd_session_get_service.3*
759 %{_mandir}/man3/sd_session_get_type.3*
760 %{_mandir}/man3/sd_session_get_uid.3*
761 %{_mandir}/man3/sd_session_is_active.3*
762 %{_mandir}/man3/sd_uid_get_seats.3*
763 %{_mandir}/man3/sd_uid_get_sessions.3*
764 %{_mandir}/man3/sd_uid_get_state.3*
765 %{_mandir}/man3/sd_uid_is_on_seat.3*
766
767 %files -n bash-completion-systemd
768 %defattr(644,root,root,755)
769 /etc/bash_completion.d/systemd-bash-completion.sh
770
771 %files no-compat-tmpfiles
772 %defattr(644,root,root,755)
773 # empty package
This page took 0.135956 seconds and 3 git commands to generate.