]> git.pld-linux.org Git - packages/systemd.git/blob - systemd.spec
- add TODO
[packages/systemd.git] / systemd.spec
1 #
2 # TODO:
3 # - gtk BRs: libnotify 0.7 and gtk+3
4 # - subpackages: bash-autocompletion, dbus(?), gtk, others?
5 # - more BRs
6 #
7
8 %bcond_with     gtk     # build gtk tools
9
10 Summary:        systemd - a system and service manager for Linux
11 Summary(pl.UTF-8):      systemd - zarządca systemu i usług dla Linuksa
12 Name:           systemd
13 Version:        15
14 Release:        0.1
15 License:        GPL v2+
16 Group:          Base
17 Source0:        http://www.freedesktop.org/software/systemd/%{name}-%{version}.tar.bz2
18 # Source0-md5:  36011aa8593862ca78e3e909f6143570
19 URL:            http://www.freedesktop.org/wiki/Software/systemd
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 BuildRequires:  dbus-devel
23 %if %{with gtk}
24 BuildRequires:  libnotify-devel >= 0.7.0
25 %endif
26 BuildRequires:  libtool
27 BuildRequires:  udev-devel >= 160
28 BuildRequires:  vala >= 0.11
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 systemd is a system and service manager for Linux, compatible with
33 SysV and LSB init scripts. systemd provides aggressive parallelization
34 capabilities, uses socket and D-Bus activation for starting services,
35 offers on-demand starting of daemons, keeps track of processes using
36 Linux cgroups, supports snapshotting and restoring of the system
37 state, maintains mount and automount points and implements an
38 elaborate transactional dependency-based service control logic. It can
39 work as a drop-in replacement for sysvinit.
40
41 %description -l pl.UTF-8
42 systemd jest zarządcą systemu i usług dla Linuksa, kompatybilny ze
43 skryptami SysV i LSB. systemd udostępnia rozbudowane zdolności
44 paralelizacji, do uruchamiania usług używa socketów oraz D-Busa,
45 oferuje uruchamianie usług na życzenie, monitoruje procesy używając
46 linuksowych cgroups, wspomaga zapisywanie (snapshot) i odczytywanie
47 (restore) stanu systemu, zarządza (auto)mount pointami oraz
48 implementuje starannie opracowaną transakcjonalną, bazującą na
49 zależnościach logikę kontroli usług. Może pracować jako zastepca dla
50 sysvinit.
51
52 %prep
53 %setup -q
54
55 %build
56 %{__autoconf}
57 %{__automake}
58 %configure \
59         --with-distro=other \
60         --%{?with_gtk:en}%{!?with_gtk:dis}able-gtk \
61         --with-syslog-service=syslog-ng \
62         --with-sysvinit-path=/etc/rc.d/init.d \
63         --with-sysvrcd-path=/etc/rc.d \
64         --with-rootdir=/usr
65
66 %{__make}
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70
71 %{__make} install \
72         DESTDIR=$RPM_BUILD_ROOT
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %files
78 %defattr(644,root,root,755)
79 %doc DISTRO_PORTING README TODO
80 %attr(755,root,root) %{_bindir}/systemctl
81 %attr(755,root,root) %{_bindir}/systemd
82 %attr(755,root,root) %{_bindir}/systemd-ask-password
83 %attr(755,root,root) %{_bindir}/systemd-cgls
84 %attr(755,root,root) %{_bindir}/systemd-notify
85 %attr(755,root,root) %{_bindir}/systemd-tty-ask-password-agent
86 %{_prefix}/lib/systemd/
87 /etc/dbus-1/system.d/org.freedesktop.systemd1.conf
88 %{_sysconfdir}/systemd/system.conf
89 %{_sysconfdir}/systemd/system/getty.target.wants/getty@tty1.service
90 %{_sysconfdir}/systemd/system/getty.target.wants/getty@tty2.service
91 %{_sysconfdir}/systemd/system/getty.target.wants/getty@tty3.service
92 %{_sysconfdir}/systemd/system/getty.target.wants/getty@tty4.service
93 %{_sysconfdir}/systemd/system/getty.target.wants/getty@tty5.service
94 %{_sysconfdir}/systemd/system/getty.target.wants/getty@tty6.service
95 %{_sysconfdir}/systemd/system/local-fs.target.wants/quotacheck.service
96 %{_sysconfdir}/systemd/system/local-fs.target.wants/quotaon.service
97 %{_sysconfdir}/systemd/system/multi-user.target.wants/remote-fs.target
98 %{_sysconfdir}/systemd/system/sysinit.target.wants/hwclock-load.service
99 %{_sysconfdir}/tmpfiles.d/systemd.conf
100 %{_sysconfdir}/tmpfiles.d/x11.conf
101 %{_sysconfdir}/xdg/systemd/user
102 /lib/udev/rules.d/99-systemd.rules
103 %{_lib}/security/pam_systemd.la
104 %attr(755,root,root) %{_lib}/security/pam_systemd.so
105 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Automount.xml
106 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Device.xml
107 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Job.xml
108 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Manager.xml
109 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Mount.xml
110 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Path.xml
111 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Service.xml
112 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Snapshot.xml
113 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Socket.xml
114 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Swap.xml
115 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Target.xml
116 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Timer.xml
117 %{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.Unit.xml
118 %{_datadir}/dbus-1/services/org.freedesktop.systemd1.service
119 %{_datadir}/dbus-1/system-services/org.freedesktop.systemd1.service
120 %{_mandir}/man1/init.1
121 %{_mandir}/man1/systemadm.1*
122 %{_mandir}/man1/systemctl.1*
123 %{_mandir}/man1/systemd-cgls.1*
124 %{_mandir}/man1/systemd-notify.1*
125 %{_mandir}/man1/systemd.1*
126 %{_mandir}/man3/sd_booted.3*
127 %{_mandir}/man3/sd_is_fifo.3*
128 %{_mandir}/man3/sd_is_socket.3
129 %{_mandir}/man3/sd_is_socket_inet.3
130 %{_mandir}/man3/sd_is_socket_unix.3
131 %{_mandir}/man3/sd_listen_fds.3*
132 %{_mandir}/man3/sd_notify.3*
133 %{_mandir}/man3/sd_notifyf.3
134 %{_mandir}/man3/sd_readahead.3*
135 %{_mandir}/man5/hostname.5*
136 %{_mandir}/man5/locale.conf.5*
137 %{_mandir}/man5/modules-load.d.5*
138 %{_mandir}/man5/os-release.5*
139 %{_mandir}/man5/systemd.automount.5*
140 %{_mandir}/man5/systemd.conf.5*
141 %{_mandir}/man5/systemd.device.5*
142 %{_mandir}/man5/systemd.exec.5*
143 %{_mandir}/man5/systemd.mount.5*
144 %{_mandir}/man5/systemd.path.5*
145 %{_mandir}/man5/systemd.service.5*
146 %{_mandir}/man5/systemd.snapshot.5*
147 %{_mandir}/man5/systemd.socket.5*
148 %{_mandir}/man5/systemd.swap.5*
149 %{_mandir}/man5/systemd.target.5*
150 %{_mandir}/man5/systemd.timer.5*
151 %{_mandir}/man5/systemd.unit.5*
152 %{_mandir}/man5/tmpfiles.d.5*
153 %{_mandir}/man5/vconsole.conf.5*
154 %{_mandir}/man7/daemon.7*
155 %{_mandir}/man7/sd-daemon.7*
156 %{_mandir}/man7/sd-readahead.7*
157 %{_mandir}/man7/systemd.special.7*
158 %{_mandir}/man8/halt.8*
159 %{_mandir}/man8/pam_systemd.8*
160 %{_mandir}/man8/poweroff.8
161 %{_mandir}/man8/reboot.8
162 %{_mandir}/man8/runlevel.8*
163 %{_mandir}/man8/shutdown.8*
164 %{_mandir}/man8/telinit.8*
165 %{_datadir}/polkit-1/actions/org.freedesktop.systemd1.policy
166 %{_datadir}/systemd
This page took 0.044153 seconds and 3 git commands to generate.