]> git.pld-linux.org Git - packages/sysprof.git/blob - sysprof.spec
- release 2 (by relup.sh)
[packages/sysprof.git] / sysprof.spec
1 #
2 # Conditional build:
3 %bcond_without  sysprofd        # daemon to run UI without root permissions
4 #
5 Summary:        Sampling CPU profiler for Linux
6 Summary(pl.UTF-8):      Próbkujący profiler procesora dla Linuksa
7 Name:           sysprof
8 Version:        3.30.2
9 Release:        2
10 License:        GPL v3+
11 Group:          Applications/System
12 Source0:        http://ftp.gnome.org/pub/GNOME/sources/sysprof/3.30/%{name}-%{version}.tar.xz
13 # Source0-md5:  80cb47906eced2e7b9976bf00deec323
14 URL:            http://sysprof.com/
15 BuildRequires:  appstream-glib-devel
16 # -std=gnu11 + C11 atomics
17 BuildRequires:  gcc >= 6:4.9
18 BuildRequires:  gdk-pixbuf2-devel >= 2.0
19 BuildRequires:  gettext-tools >= 0.19.6
20 BuildRequires:  glib2-devel >= 1:2.44.0
21 BuildRequires:  gobject-introspection-devel >= 1.42.0
22 BuildRequires:  gtk+3-devel >= 3.22
23 BuildRequires:  libstdc++-devel >= 6:4.3
24 BuildRequires:  pango-devel
25 BuildRequires:  pkgconfig >= 1:0.22
26 %{?with_sysprofd:BuildRequires: polkit-devel}
27 BuildRequires:  rpmbuild(macros) >= 1.644
28 %{?with_sysprofd:BuildRequires: systemd-devel >= 1:222}
29 BuildRequires:  tar >= 1:1.22
30 BuildRequires:  vala
31 BuildRequires:  xz
32 BuildRequires:  yelp-tools
33 Requires:       %{name}-libs = %{version}-%{release}
34 %{?with_sysprofd:Requires:      systemd-units >= 1:222}
35 Requires:       uname(release) >= 2.6.31
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 Sysprof is a sampling CPU profiler for Linux that uses a kernel module
40 to profile the entire system, not just a single application. Sysprof
41 handles shared libraries and applications do not need to be
42 recompiled. In fact they don't even have to be restarted.
43
44 Just insert the kernel module and start sysprof.
45
46 %description -l pl.UTF-8
47 Sysprof to próbkujący profiler procesora dla Linuksa wykorzystujący
48 moduł jądra do profilowania całego systemu, nie tylko pojedynczej
49 aplikacji. Sysprof obsługuje biblioteki współdzielone, a aplikacje nie
50 wymagają rekompilacji. Właściwie nawet nie trzeba ich restartować.
51
52 Wystarczy załadować moduł jądra i uruchomić sysprof.
53
54 %package libs
55 Summary:        The sysprof profiler library
56 Summary(pl.UTF-8):      Biblioteka profilera sysprof
57 Group:          Libraries
58 Requires:       glib2 >= 1:2.44.0
59
60 %description libs
61 The sysprof profiler library.
62
63 %description libs -l pl.UTF-8
64 Biblioteka profilera sysprof.
65
66 %package devel
67 Summary:        Header files for sysprof library
68 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki sysprof
69 Group:          Development/Libraries
70 Requires:       %{name}-libs = %{version}-%{release}
71 Requires:       glib2-devel >= 1:2.44.0
72
73 %description devel
74 Header files for sysprof library.
75
76 %description devel -l pl.UTF-8
77 Pliki nagłówkowe biblioteki sysprof.
78
79 %package ui
80 Summary:        The sysprof graphical user interface
81 Summary(pl.UTF-8):      Graficzny interfejs użytkownika profilera sysprof
82 Group:          Applications/System
83 Requires(post,postun):  desktop-file-utils
84 Requires(post,postun):  glib2 >= 1:2.44.0
85 Requires(post,postun):  gtk-update-icon-cache
86 Requires:       %{name} = %{version}-%{release}
87 Requires:       %{name}-ui-libs = %{version}-%{release}
88 Requires:       hicolor-icon-theme
89 Requires:       shared-mime-info
90
91 %description ui
92 The sysprof graphical user interface.
93
94 %description ui -l pl.UTF-8
95 Graficzny interfejs użytkownika profilera sysprof.
96
97 %package ui-libs
98 Summary:        The sysprof library containing reusable GTK+ widgets
99 Summary(pl.UTF-8):      Biblioteka sysprofa zawierająca widgety GTK+ wielokrotnego użytku
100 Group:          X11/Libraries
101 Requires:       %{name}-libs = %{version}-%{release}
102 Requires:       gtk+3 >= 3.22
103
104 %description ui-libs
105 The sysprof library containing reusable GTK+ widgets.
106
107 %description ui-libs -l pl.UTF-8
108 Biblioteka sysprofa zawierająca widgety GTK+ wielokrotnego użytku.
109
110 %package ui-devel
111 Summary:        Header files for sysprof-ui library
112 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki sysprof-ui
113 Group:          X11/Development/Libraries
114 Requires:       %{name}-devel = %{version}-%{release}
115 Requires:       %{name}-ui-libs = %{version}-%{release}
116 Requires:       gtk+3-devel >= 3.22
117
118 %description ui-devel
119 Header files for sysprof-ui library.
120
121 %description ui-devel -l pl.UTF-8
122 Pliki nagłówkowe biblioteki sysprof-ui.
123
124 %prep
125 %setup -q
126
127 %build
128 %meson build \
129         %{?with_sysprofd:-Dwith_sysprofd=bundled}
130
131 %meson_build -C build
132
133 %install
134 rm -rf $RPM_BUILD_ROOT
135
136 %meson_install -C build
137
138 %find_lang %{name} -o %{name}-ui.lang --with-gnome --without-mo
139 %find_lang %{name}
140
141 %clean
142 rm -rf $RPM_BUILD_ROOT
143
144 %if %{with sysprofd}
145 %post
146 %systemd_post sysprof2.service
147
148 %preun
149 %systemd_preun sysprof2.service
150
151 %postun
152 %systemd_reload
153 %endif
154
155 %post   libs -p /sbin/ldconfig
156 %postun libs -p /sbin/ldconfig
157
158 %post ui
159 %glib_compile_schemas
160 %update_icon_cache hicolor
161 %update_mime_database
162 %update_desktop_database
163
164 %postun ui
165 %glib_compile_schemas
166 %update_icon_cache hicolor
167 %update_mime_database
168 %update_desktop_database
169
170 %post   ui-libs -p /sbin/ldconfig
171 %postun ui-libs -p /sbin/ldconfig
172
173 %files -f %{name}.lang
174 %defattr(644,root,root,755)
175 %doc AUTHORS NEWS TODO
176 %attr(755,root,root) %{_bindir}/sysprof-cli
177 %if %{with sysprofd}
178 %dir %{_libexecdir}/sysprof
179 %attr(755,root,root) %{_libexecdir}/sysprof/sysprofd
180 %{systemdunitdir}/sysprof2.service
181 %{_datadir}/dbus-1/system-services/org.gnome.Sysprof2.service
182 %{_datadir}/dbus-1/system.d/org.gnome.Sysprof2.conf
183 %{_datadir}/polkit-1/actions/org.gnome.sysprof2.policy
184 %endif
185
186 %files libs
187 %defattr(644,root,root,755)
188 %attr(755,root,root) %{_libdir}/libsysprof-2.so
189
190 %files devel
191 %defattr(644,root,root,755)
192 %{_libdir}/libsysprof-capture-2.a
193 %dir %{_includedir}/sysprof-2
194 %{_includedir}/sysprof-2/sp-kallsyms.h
195 %{_includedir}/sysprof-2/sp-address.h
196 %{_includedir}/sysprof-2/sp-clock.h
197 %{_includedir}/sysprof-2/sp-error.h
198 %{_includedir}/sysprof-2/sysprof.h
199 %{_includedir}/sysprof-2/sysprof-capture.h
200 %{_includedir}/sysprof-2/sysprof-version.h
201 %dir %{_includedir}/sysprof-2/callgraph
202 %{_includedir}/sysprof-2/callgraph/sp-callgraph-profile.h
203 %dir %{_includedir}/sysprof-2/capture
204 %{_includedir}/sysprof-2/capture/sp-capture-condition.h
205 %{_includedir}/sysprof-2/capture/sp-capture-cursor.h
206 %{_includedir}/sysprof-2/capture/sp-capture-reader.h
207 %{_includedir}/sysprof-2/capture/sp-capture-types.h
208 %{_includedir}/sysprof-2/capture/sp-capture-writer.h
209 %dir %{_includedir}/sysprof-2/profiler
210 %{_includedir}/sysprof-2/profiler/sp-local-profiler.h
211 %{_includedir}/sysprof-2/profiler/sp-profile.h
212 %{_includedir}/sysprof-2/profiler/sp-profiler.h
213 %dir %{_includedir}/sysprof-2/sources
214 %{_includedir}/sysprof-2/sources/sp-gjs-source.h
215 %{_includedir}/sysprof-2/sources/sp-hostinfo-source.h
216 %{_includedir}/sysprof-2/sources/sp-perf-source.h
217 %{_includedir}/sysprof-2/sources/sp-proc-source.h
218 %{_includedir}/sysprof-2/sources/sp-source.h
219 %dir %{_includedir}/sysprof-2/symbols
220 %{_includedir}/sysprof-2/symbols/sp-elf-symbol-resolver.h
221 %{_includedir}/sysprof-2/symbols/sp-jitmap-symbol-resolver.h
222 %{_includedir}/sysprof-2/symbols/sp-kernel-symbol-resolver.h
223 %{_includedir}/sysprof-2/symbols/sp-kernel-symbol.h
224 %{_includedir}/sysprof-2/symbols/sp-symbol-dirs.h
225 %{_includedir}/sysprof-2/symbols/sp-symbol-resolver.h
226 %dir %{_includedir}/sysprof-2/util
227 %{_includedir}/sysprof-2/util/sp-map-lookaside.h
228 %{_includedir}/sysprof-2/util/sp-model-filter.h
229 %{_includedir}/sysprof-2/util/sp-process-model-item.h
230 %{_includedir}/sysprof-2/util/sp-process-model.h
231 %{_includedir}/sysprof-2/util/sp-selection.h
232 %{_includedir}/sysprof-2/util/sp-zoom-manager.h
233 %dir %{_includedir}/sysprof-2/visualizers
234 %{_includedir}/sysprof-2/visualizers/sp-mark-visualizer-row.h
235 %{_pkgconfigdir}/sysprof-2.pc
236 %{_pkgconfigdir}/sysprof-capture-2.pc
237
238 %files ui -f %{name}-ui.lang
239 %defattr(644,root,root,755)
240 %attr(755,root,root) %{_bindir}/sysprof
241 %{_datadir}/glib-2.0/schemas/org.gnome.sysprof2.gschema.xml
242 %{_datadir}/mime/packages/sysprof-mime.xml
243 %{_desktopdir}/org.gnome.Sysprof2.desktop
244 %{_iconsdir}/hicolor/*x*/apps/sysprof.png
245 %{_iconsdir}/hicolor/scalable/apps/sysprof-symbolic.svg
246 %{_datadir}/metainfo/org.gnome.Sysprof2.appdata.xml
247
248 %files ui-libs
249 %defattr(644,root,root,755)
250 %attr(755,root,root) %{_libdir}/libsysprof-ui-2.so
251
252 %files ui-devel
253 %defattr(644,root,root,755)
254 %{_includedir}/sysprof-2/sysprof-ui.h
255 %{_pkgconfigdir}/sysprof-ui-2.pc
256 %{_includedir}/sysprof-2/callgraph/sp-callgraph-view.h
257 %dir %{_includedir}/sysprof-2/visualizers
258 %{_includedir}/sysprof-2/visualizers/sp-cpu-visualizer-row.h
259 %{_includedir}/sysprof-2/visualizers/sp-line-visualizer-row.h
260 %{_includedir}/sysprof-2/visualizers/sp-visualizer-row.h
261 %{_includedir}/sysprof-2/visualizers/sp-visualizer-view.h
262 %dir %{_includedir}/sysprof-2/widgets
263 %{_includedir}/sysprof-2/widgets/sp-cell-renderer-percent.h
264 %{_includedir}/sysprof-2/widgets/sp-empty-state-view.h
265 %{_includedir}/sysprof-2/widgets/sp-failed-state-view.h
266 %{_includedir}/sysprof-2/widgets/sp-multi-paned.h
267 %{_includedir}/sysprof-2/widgets/sp-process-model-row.h
268 %{_includedir}/sysprof-2/widgets/sp-profiler-menu-button.h
269 %{_includedir}/sysprof-2/widgets/sp-recording-state-view.h
This page took 0.081376 seconds and 4 git commands to generate.