]> git.pld-linux.org Git - packages/sysprof.git/blob - sysprof.spec
- updated to 3.48.0 (GNOME 44)
[packages/sysprof.git] / sysprof.spec
1 # TODO: switch to gtk4-update-icon-cache
2 #
3 # Conditional build:
4 %bcond_without  sysprofd        # daemon to run UI without root permissions
5 #
6 Summary:        Sampling CPU profiler for Linux
7 Summary(pl.UTF-8):      Próbkujący profiler procesora dla Linuksa
8 Name:           sysprof
9 Version:        3.48.0
10 Release:        1
11 License:        GPL v3+
12 Group:          Applications/System
13 Source0:        https://download.gnome.org/sources/sysprof/3.48/%{name}-%{version}.tar.xz
14 # Source0-md5:  ee1556063c7b8d9abd414f451b04c33a
15 URL:            http://www.sysprof.com/
16 BuildRequires:  cairo-devel
17 # -std=gnu11 + C11 atomics
18 BuildRequires:  gcc >= 6:4.9
19 BuildRequires:  gettext-tools >= 0.19.6
20 BuildRequires:  glib2-devel >= 1:2.73.0
21 BuildRequires:  gtk4-devel >= 4.6
22 BuildRequires:  json-glib-devel
23 BuildRequires:  libstdc++-devel >= 6:4.7
24 BuildRequires:  libunwind-devel
25 BuildRequires:  meson >= 0.59.0
26 BuildRequires:  ninja >= 1.5
27 BuildRequires:  pango-devel
28 BuildRequires:  pkgconfig >= 1:0.22
29 %{?with_sysprofd:BuildRequires: polkit-devel >= 0.114}
30 BuildRequires:  rpmbuild(macros) >= 1.736
31 %{?with_sysprofd:BuildRequires: systemd-devel >= 1:222}
32 BuildRequires:  tar >= 1:1.22
33 BuildRequires:  xz
34 BuildRequires:  yelp-tools
35 Requires:       %{name}-libs = %{version}-%{release}
36 %{?with_sysprofd:Requires:      polkit >= 0.114}
37 %{?with_sysprofd:Requires:      systemd-units >= 1:222}
38 Requires:       uname(release) >= 2.6.31
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 Sysprof is a sampling CPU profiler for Linux that uses a kernel module
43 to profile the entire system, not just a single application. Sysprof
44 handles shared libraries and applications do not need to be
45 recompiled. In fact they don't even have to be restarted.
46
47 Just insert the kernel module and start sysprof.
48
49 %description -l pl.UTF-8
50 Sysprof to próbkujący profiler procesora dla Linuksa wykorzystujący
51 moduł jądra do profilowania całego systemu, nie tylko pojedynczej
52 aplikacji. Sysprof obsługuje biblioteki współdzielone, a aplikacje nie
53 wymagają rekompilacji. Właściwie nawet nie trzeba ich restartować.
54
55 Wystarczy załadować moduł jądra i uruchomić sysprof.
56
57 %package libs
58 Summary:        The sysprof profiler library
59 Summary(pl.UTF-8):      Biblioteka profilera sysprof
60 Group:          Libraries
61 Requires:       glib2 >= 1:2.73.0
62
63 %description libs
64 The sysprof profiler library.
65
66 %description libs -l pl.UTF-8
67 Biblioteka profilera sysprof.
68
69 %package devel
70 Summary:        Header files for sysprof library
71 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki sysprof
72 Group:          Development/Libraries
73 Requires:       %{name}-libs = %{version}-%{release}
74 Requires:       glib2-devel >= 1:2.73.0
75 Obsoletes:      sysprof-static < 3.28.0
76
77 %description devel
78 Header files for sysprof library.
79
80 %description devel -l pl.UTF-8
81 Pliki nagłówkowe biblioteki sysprof.
82
83 %package ui
84 Summary:        The sysprof graphical user interface
85 Summary(pl.UTF-8):      Graficzny interfejs użytkownika profilera sysprof
86 Group:          Applications/System
87 Requires(post,postun):  desktop-file-utils
88 Requires(post,postun):  glib2 >= 1:2.73.0
89 Requires(post,postun):  gtk-update-icon-cache
90 Requires:       %{name} = %{version}-%{release}
91 Requires:       %{name}-ui-libs = %{version}-%{release}
92 Requires:       hicolor-icon-theme
93 Requires:       shared-mime-info
94
95 %description ui
96 The sysprof graphical user interface.
97
98 %description ui -l pl.UTF-8
99 Graficzny interfejs użytkownika profilera sysprof.
100
101 %package ui-libs
102 Summary:        The sysprof library containing reusable GTK+ widgets
103 Summary(pl.UTF-8):      Biblioteka sysprofa zawierająca widgety GTK+ wielokrotnego użytku
104 Group:          X11/Libraries
105 Requires:       %{name}-libs = %{version}-%{release}
106 Requires:       gtk4 >= 4.6
107
108 %description ui-libs
109 The sysprof library containing reusable GTK+ widgets.
110
111 %description ui-libs -l pl.UTF-8
112 Biblioteka sysprofa zawierająca widgety GTK+ wielokrotnego użytku.
113
114 %package ui-devel
115 Summary:        Header files for sysprof-ui library
116 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki sysprof-ui
117 Group:          X11/Development/Libraries
118 Requires:       %{name}-devel = %{version}-%{release}
119 Requires:       %{name}-ui-libs = %{version}-%{release}
120 Requires:       gtk4-devel >= 4.6
121 Obsoletes:      sysprof-ui-static < 3.28.0
122
123 %description ui-devel
124 Header files for sysprof-ui library.
125
126 %description ui-devel -l pl.UTF-8
127 Pliki nagłówkowe biblioteki sysprof-ui.
128
129 %prep
130 %setup -q
131
132 %build
133 %meson build \
134         %{!?with_sysprofd:-Dwith_sysprofd=host}
135
136 %ninja_build -C build
137
138 %install
139 rm -rf $RPM_BUILD_ROOT
140
141 %ninja_install -C build
142
143 %find_lang %{name} -o %{name}-ui.lang --with-gnome --without-mo
144 %find_lang %{name}
145
146 %clean
147 rm -rf $RPM_BUILD_ROOT
148
149 %if %{with sysprofd}
150 %post
151 %systemd_post sysprof2.service
152
153 %preun
154 %systemd_preun sysprof2.service
155
156 %postun
157 %systemd_reload
158 %endif
159
160 %post   libs -p /sbin/ldconfig
161 %postun libs -p /sbin/ldconfig
162
163 %post ui
164 %update_icon_cache hicolor
165 %update_mime_database
166 %update_desktop_database
167
168 %postun ui
169 %update_icon_cache hicolor
170 %update_mime_database
171 %update_desktop_database
172
173 %post   ui-libs -p /sbin/ldconfig
174 %postun ui-libs -p /sbin/ldconfig
175
176 %files -f %{name}.lang
177 %defattr(644,root,root,755)
178 %doc AUTHORS DESIGN.md NEWS README.md
179 %attr(755,root,root) %{_bindir}/sysprof-agent
180 %attr(755,root,root) %{_bindir}/sysprof-cli
181 %if %{with sysprofd}
182 %attr(755,root,root) %{_libexecdir}/sysprofd
183 %{systemdunitdir}/sysprof2.service
184 %{systemdunitdir}/sysprof3.service
185 %{_datadir}/dbus-1/system-services/org.gnome.Sysprof2.service
186 %{_datadir}/dbus-1/system-services/org.gnome.Sysprof3.service
187 %{_datadir}/dbus-1/system.d/org.gnome.Sysprof2.conf
188 %{_datadir}/dbus-1/system.d/org.gnome.Sysprof3.conf
189 %{_datadir}/polkit-1/actions/org.gnome.sysprof3.policy
190 %endif
191
192 %files libs
193 %defattr(644,root,root,755)
194 %attr(755,root,root) %{_libdir}/libsysprof-4.so
195 %attr(755,root,root) %{_libdir}/libsysprof-memory-4.so
196 %attr(755,root,root) %{_libdir}/libsysprof-speedtrack-4.so
197
198 %files devel
199 %defattr(644,root,root,755)
200 %{_libdir}/libsysprof-capture-4.a
201 %{_includedir}/sysprof-4
202 %{_pkgconfigdir}/sysprof-4.pc
203 %{_pkgconfigdir}/sysprof-capture-4.pc
204 %{_datadir}/dbus-1/interfaces/org.gnome.Sysprof.Agent.xml
205 %{_datadir}/dbus-1/interfaces/org.gnome.Sysprof2.xml
206 %{_datadir}/dbus-1/interfaces/org.gnome.Sysprof3.Profiler.xml
207 %{_datadir}/dbus-1/interfaces/org.gnome.Sysprof3.Service.xml
208
209 %files ui -f %{name}-ui.lang
210 %defattr(644,root,root,755)
211 %attr(755,root,root) %{_bindir}/sysprof
212 %{_datadir}/metainfo/org.gnome.Sysprof.appdata.xml
213 %{_datadir}/mime/packages/sysprof-mime.xml
214 %{_desktopdir}/org.gnome.Sysprof.desktop
215 %{_iconsdir}/hicolor/scalable/actions/sysprof-*.svg
216 %{_iconsdir}/hicolor/scalable/apps/org.gnome.Sysprof.svg
217 %{_iconsdir}/hicolor/symbolic/apps/org.gnome.Sysprof-symbolic.svg
218
219 %files ui-libs
220 %defattr(644,root,root,755)
221 %attr(755,root,root) %{_libdir}/libsysprof-ui-5.so
222
223 %files ui-devel
224 %defattr(644,root,root,755)
225 %{_includedir}/sysprof-ui-5
226 %{_pkgconfigdir}/sysprof-ui-5.pc
This page took 0.094752 seconds and 4 git commands to generate.