]> git.pld-linux.org Git - packages/sysprof.git/blob - sysprof.spec
- up to 1.0.12
[packages/sysprof.git] / sysprof.spec
1 # Conditional build:
2 %bcond_without  dist_kernel     # without distribution kernel
3 %bcond_without  kernel          # don't build kernel modules
4 %bcond_without  userspace       # don't build userspace tools
5 #
6 %define rel     1
7 Summary:        Sampling CPU profiler for Linux
8 Name:           sysprof
9 Version:        1.0.12
10 Release:        %{rel}
11 License:        GPL v2
12 Group:          Applications/System
13 Source0:        http://www.daimi.au.dk/~sandmann/sysprof/%{name}-%{version}.tar.gz
14 # Source0-md5:  9566040f3175678e75133b1c52a473f8
15 URL:            http://www.daimi.au.dk/~sandmann/sysprof/
16 BuildRequires:  binutils-devel
17 BuildRequires:  gtk+2-devel
18 BuildRequires:  rpmbuild(macros) >= 1.217
19 Requires:       uname(release) >= 2.6
20 Conflicts:      kernel < 2.6
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Sysprof is a sampling CPU profiler for Linux that uses a kernel module
25 to profile the entire system, not just a single application. Sysprof
26 handles shared libraries and applications do not need to be
27 recompiled. In fact they don't even have to be restarted.
28
29 Just insert the kernel module and start sysprof.
30
31 %package -n kernel%{_alt_kernel}-sysprof
32 Summary:        sysprof kernel driver
33 Release:        %{rel}@%{_kernel_ver_str}
34 Group:          Base/Kernel
35 Requires(post,postun):  /sbin/depmod
36 %if %{with dist_kernel}
37 %requires_releq_kernel
38 Requires(postun):       %releq_kernel
39 %endif
40
41 %description -n kernel%{_alt_kernel}-sysprof
42 sysprof Linux kernel driver.
43
44 %prep
45 %setup -q
46
47 %build
48 %configure \
49         --disable-kernel-module
50 %if %{with userspace}
51 %{__make}
52 %endif
53
54 %if %{with kernel}
55 cd module
56 %build_kernel_modules SUBDIRS=$PWD -m sysprof-module
57 %endif
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61
62 %if %{with userspace}
63 %{__make} install \
64         DESTDIR=$RPM_BUILD_ROOT
65 %endif
66
67 %if %{with kernel}
68 cd module
69 %install_kernel_modules -m sysprof-module -d misc
70 %endif
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %post -n kernel%{_alt_kernel}-sysprof
76 %depmod %{_kernel_ver}
77
78 %postun -n kernel%{_alt_kernel}-sysprof
79 %depmod %{_kernel_ver}
80
81 %if %{with userspace}
82 %files
83 %defattr(644,root,root,755)
84 %doc AUTHORS ChangeLog README TODO
85 %attr(755,root,root) %{_bindir}/*
86 %{_pixmapsdir}/*.png
87 %{_datadir}/%{name}
88 %endif
89
90 %if %{with kernel}
91 %files -n kernel%{_alt_kernel}-sysprof
92 %defattr(644,root,root,755)
93 /lib/modules/%{_kernel_ver}/misc/*.ko*
94 %endif
This page took 0.10357 seconds and 3 git commands to generate.