]> git.pld-linux.org Git - packages/syslog-ng.git/blob - syslog-ng.spec
- updated to 1.6.5, removed obsolete ac25x patch, simplified spec
[packages/syslog-ng.git] / syslog-ng.spec
1 %define         mainver         1.6
2 %define         minorver        5
3
4 Summary:        Syslog-ng - new generation of the system logger
5 Summary(pl):    Syslog-ng - zamiennik syskloga
6 Summary(pt_BR): Daemon de log nova geração
7 Name:           syslog-ng
8 Version:        %{mainver}.%{minorver}
9 Release:        1
10 License:        GPL
11 Group:          Daemons
12 Source0:        http://www.balabit.hu/downloads/syslog-ng/%{mainver}/src/%{name}-%{version}.tar.gz
13 # Source0-md5:  ce70b4230e73ad79191618530c8c3a72
14 Source1:        %{name}.init
15 Source2:        %{name}.conf
16 Source3:        %{name}.logrotate
17 URL:            http://www.balabit.com/products/syslog_ng/
18 BuildRequires:  autoconf >= 2.53
19 BuildRequires:  automake
20 BuildRequires:  flex
21 BuildRequires:  libol-static >= 0.3.14
22 BuildRequires:  libwrap-devel
23 PreReq:         rc-scripts >= 0.2.0
24 Requires(post,preun):   /sbin/chkconfig
25 Requires(post): fileutils
26 Requires:       logrotate
27 Requires:       psmisc >= 20.1
28 Provides:       syslogdaemon
29 Obsoletes:      syslog
30 Obsoletes:      msyslog
31 Obsoletes:      klogd
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 syslog-ng is a syslogd replacement for unix and unix-like systems. It
36 has been tested on Solaris, BSDi and Linux, and were found to run
37 reliably. syslog-ng gives you a much enhanced configuration scheme,
38 which lets you filter messages based on not only priority/facility
39 pairs, but also on message content. You can use regexps to direct log
40 stream to different destinations. A destination can be anything from a
41 simple file to a network connection. syslog-ng supports TCP
42 logforwarding, together with hashing to prevent unauthorized
43 modification on the line.
44
45 %description -l pl
46 Syslog-ng jest zamiennikiem dla standardowo u¿ywanych programów typu
47 sysklog. Dzia³a w systemie SunOS, BSD, Linux. Daje znacznie wiêksze
48 mo¿liwo¶ci logowania i kontrolowania zbieranych informacji.
49
50 %description -l pt_BR
51 Syslog-ng é um substituto para o syslog tradicional, mas com diversas
52 melhorias, como, por exemplo, a habilidade de filtrar mensagens de log
53 por seu conteúdo (usando expressões regulares) e não apenas pelo par
54 facility/prioridade como o syslog original.
55
56 %prep
57 %setup -q
58
59 %build
60 %{__aclocal}
61 %{__autoconf}
62 %{__automake}
63 %configure \
64         --enable-tcp-wrapper
65 %{__make}
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69 install -d $RPM_BUILD_ROOT{/etc/{logrotate.d,rc.d/init.d},%{_sysconfdir}/syslog-ng} \
70         $RPM_BUILD_ROOT/var/log/{mail,archiv/mail}
71
72 %{__make} install \
73         DESTDIR=$RPM_BUILD_ROOT
74
75 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/syslog-ng
76 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/syslog-ng/syslog-ng.conf
77 install %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/syslog-ng
78
79 > $RPM_BUILD_ROOT/var/log/syslog
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %post
85 for n in /var/log/{cron,daemon,debug,kernel,lpr,maillog,messages,ppp,secure,spooler,syslog,user,mail/{info,warn,err}}
86 do
87         [ -f $n ] && continue
88         touch $n
89         chmod 640 $n
90 done
91
92 /sbin/chkconfig --add syslog-ng
93 if [ -f /var/lock/subsys/syslog-ng ]; then
94         /etc/rc.d/init.d/syslog-ng restart >&2
95 else
96         echo "Run \"/etc/rc.d/init.d/syslog-ng start\" to start syslog-ng daemon."
97 fi
98
99 %preun
100 if [ "$1" = "0" ]; then
101         if [ -f /var/lock/subsys/syslog-ng ]; then
102                 /etc/rc.d/init.d/syslog-ng stop >&2
103         fi
104         /sbin/chkconfig --del syslog-ng
105 fi
106
107 %files
108 %defattr(644,root,root,755)
109 %doc doc/syslog-ng.conf.{demo,sample} doc/sgml/syslog-ng.txt* contrib/syslog-ng.conf.{doc,RedHat}
110 %attr(750,root,root) %dir %{_sysconfdir}/syslog-ng
111 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/syslog-ng/syslog-ng.conf
112 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/logrotate.d/syslog-ng
113 %attr(754,root,root) /etc/rc.d/init.d/syslog-ng
114 %attr(755,root,root) %{_sbindir}/syslog-ng
115 %{_mandir}/man[58]/*
116
117 %attr(640,root,root) %ghost /var/log/syslog
118 %dir /var/log/mail
119 %dir /var/log/archiv
120 %dir /var/log/archiv/mail
This page took 0.181746 seconds and 4 git commands to generate.